ArcGIS Pro 入门

创建工程

ArcGIS Pro 中,地图和数据通常被组织在一个工程中。开始制作地图之前,您将创建一个工程。

  1. 启动 ArcGIS Pro。如果出现提示,请使用您获得许可的 ArcGIS 帐户登录。
    注:

    如果您没有 ArcGIS Pro 或 ArcGIS 帐户,可以注册 ArcGIS 免费试用版

    有多个模板可以用于新工程。要创建地图,您可以选择地图模板。

  2. 新建下,单击地图

    地图工程模板

    随即显示创建新工程窗口。默认情况下,工程将保存在新文件夹中,但是您也可以通过取消选中为此工程创建新文件夹以将工程保存在现有文件夹中。

  3. 对于名称,删除现有文本并输入 Singapore Tourism。保持位置不变并确认为此工程创建新文件夹处于选中状态。

    带有正确参数的“新建工程”窗口

    注:

    您的默认位置可能与示例图像的位置不同。通常,工程保存在安装 ArcGIS Pro 时创建的 ArcGIS 文件夹中。

  4. 单击确定

    使用显示世界的地图创建该工程。在 ArcGIS Pro 中,地图由地理数据图层组成。目前,唯一的图层是底图,它提供了国界和水体等参考信息。

    注:

    根据 ArcGIS 组织的设置,您的地图可能具有不同的默认范围和底图,因此其外观可能与示例图像有所不同。

    带有世界地图的新工程

    地图的两侧为窗格。默认情况下,内容目录窗格处于打开状态,但如果您之前使用过 ArcGIS Pro,则其他窗格也可能处于打开状态。内容窗格列出了地图上的图层,而目录窗格则列出了与工程关联的所有文件。

    地图上方是功能区。功能区包含多个选项卡,每个选项卡都具有多个按钮。这些按钮可能会影响地图导航,更改地图外观或打开具有更多功能的窗口或窗格。

    提示:

    您可以通过拖动窗格标题并将其停靠在新位置来重新排列窗格。您还可以通过拖动窗格的边缘来调整窗格的大小。要返回默认的窗格排列,请单击视图选项卡。在窗口组中,单击重置窗格,然后选择重置窗格以进行映射。在本课程中,可以随意排列窗格和视图。

导航至新加坡

您的感兴趣区域是新加坡的岛国城市,因此您将导航至此处。

  1. 单击功能区上的地图选项卡。在查询组中,单击定位按钮。

    “地图”选项卡上“定位”按钮

    随即显示定位窗格。使用此窗格,您可以搜索并导航至地理位置,包括国家、城市和街道地址。

  2. 定位窗格的搜索框内,输入 Singapore 并按 Enter 键。

    在“定位”窗格中搜索新加坡

    地图将自动导航到第一个结果:新加坡国家。(搜索结果的位置在地图上显示为绿色圆圈。)

    新加坡的默认地图

    新加坡是世界上面积最小的国家之一,拥有 560 万人口,并拥有四种官方语言。现代城市拥有众多历史和文化地标、娱乐场所和生态保护区。它是世界上观光人数最多的城市之一,旅游业是其主要产业。

  3. 关闭定位窗格。
  4. 在功能区上方的快速访问工具栏上,单击保存按钮。

    “保存”按钮

添加数据

底图显示了新加坡及其一些基本的地理信息(例如道路和湖泊)。但是,它不显示旅游目的地或火车站。要创建对游客有用的地图,请将此数据添加到地图中。

  1. 在功能区地图选项卡的图层组中,单击添加数据按钮。

    添加数据按钮

    随即显示添加数据窗口。您可以从多个来源添加数据,包括工程文件夹(工程),您的 ArcGIS 帐户网站(门户)或您的计算机(计算机)。

    大多数 ArcGIS 帐户(包括试用帐户)都使用 ArcGIS Online 网站作为其门户。ArcGIS Online 是一个在线 GIS 映射平台,可托管大量空间数据。您将从那里添加所需的数据。

  2. 添加数据窗口中的门户下,单击所有门户

    “添加数据”窗口中的“所有门户”选项

    此选项提供对门户上托管的所有数据的访问权限。您要使用的数据由 Learn ArcGIS 管理员帐户拥有。要查找数据,您将按名称和所有者进行搜索。

  3. 在搜索栏中,输入 Singapore owner:Learn_ArcGIS,然后按 Enter 键。

    搜索将返回三个结果:Singapore Rail LinesSingapore Rail StationsSingapore Tourist Attractions

    新加坡的搜索结果

    注:

    某些 ArcGIS 帐户使用 ArcGIS Enterprise 网站作为其门户。如果您的帐户使用 ArcGIS Enterprise,您将无法搜索 ArcGIS Online 内容。要添加数据,请转至 ArcGIS OnlineSingapore_Data_gdb 项目,然后单击下载。将已下载文件夹提取至您在计算机上选择的位置。在添加数据窗口中,浏览至解压文件夹的位置。(要查看文件夹,您可能需要单击添加数据窗口中的刷新按钮。)

  4. 按住 Ctrl 键,同时单击 Singapore Rail LinesSingapore Rail StationsSingapore Tourist Attractions 图层以将其选中。
  5. 单击确定

    三个数据图层随即添加到地图中。

    注:

    如果您正在使用 ArcGIS Enterprise,并且已下载了数据,而不是从 ArcGIS Online 进行添加,则您的图层看上去可能与示例图片有所不同。

    带有已添加到地图的数据的新加坡

    图层也将在内容窗格中列出。

    内容窗格

    绿色点代表旅游景点,白色线代表铁路线,黑色面则代表火车站。由点、线或面组成的图层称为要素图层。

    大多数旅游景点都集中在该岛的中南部。该地区是新加坡的市中心,也称为中央商务区。该旅行社希望将其宣传册重点关注这一区域,因此您将放大它。

  6. 在地图上,指向新加坡市中心,然后使用鼠标的滚轮向前滚动以放大。缩放直到市中心区域占据大部分地图。
    提示:

    放大区域的另一种方法是按住 Shift 键,然后在地图上要放大的区域绘制一个框。或者,右键单击地图,然后移动鼠标进行放大或缩小。请选择您偏好的导航方法。

    放大到新加坡市中心

  7. 如有必要,拖动地图以将其平移,直到中央商务区位于地图中心。

    在此范围中,将更详细地显示火车站。根据显示器的大小,可能会显示有关街道和建筑物的详细信息。

    此地图范围将是您在工程其余部分中使用的地图范围。根据需要,可以更快速地返回此范围,因此您将创建一个称为书签的导航快捷方式。

  8. 在功能区上,单击地图选项卡导航组中的书签,然后单击新建书签

    “新建书签”选项

  9. 创建书签窗口中,对于名称,输入 Central Business District

    创建书签窗口

  10. 单击确定

    书签已创建。在本课程中,稍后您将使用此书签。

  11. 保存工程。

设置地图样式

导航地图时,您可能已经注意到某些数据图层很难看到。例如,白色的铁路线经常会与地图上的其他信息融合在一起。

有关街道、水体和建筑物的信息来自底图。底图提供了参考信息以为您的数据提供环境背景。ArcGIS Pro 具有多个预先创建的底图图层,默认为世界地形图。(根据您的 ArcGIS 组织的设置,您可能具有不同的默认底图。)

您需要更改底图,使其突出显示您的数据。颜色较深的底图可以使白色的铁路线更加清晰。

  1. 地图选项卡的图层组中,单击底图,然后选择深灰色画布

    深灰色画布底图

    底图更改。

    带有“深灰色画布”底图的新加坡市中心

    使用此底图,铁路线将更加突出。与地形图底图不同,此底图包含两个图层。其中一个图层 World Dark Gray Reference 包含标注某些区域的文本。该文本对于您的地图用途不是必需的,并且可能会遮挡某些要素,因此您需要将其关闭。

  2. 内容窗格中,取消选中 World Dark Gray Reference

    已取消选中 World Dark Gray Reference 图层

    图层不再显示在地图上。(如果要重新显示参考信息,请再次单击该复选框。)

    旅游景点在地图上显示为不太明显的小点。由于景点本来就是地图的焦点,因此您需要改变它们的外观。

  3. 内容窗格中,单击 Tourist Attractions 图层符号。

    “旅游景点”图层符号

    随即显示符号系统窗格。符号系统用于定义图层的外观。您可以从默认符号库中选择或自定义符号。

  4. 符号系统 - Tourist Attractions 窗格的选项卡中,搜索泪滴形别针。在结果列表中,单击最大的泪滴形别针 1 (40%) 符号。

    泪滴形别针 1 符号

    旅游景点的符号随即更改为所选符号。泪滴形别针符号有助于传达旅游景点是感兴趣地点的想法。40% 表示该符号的透明度为 40%,当符号遮挡部分地图时,这非常有用。

    通过添加轮廓和增加符号大小,可以使符号更加突出。

  5. 单击属性

    属性选项

  6. 单击图层选项卡。

    图层选项卡

  7. 对于轮廓颜色,选择北极白

    北极白轮廓颜色

    提示:

    要在颜色选择器中查看颜色的名称,请指向该颜色。

  8. 轮廓宽度更改为 0.7 pt。将大小更改为 22 pt。

    符号参数

  9. 符号系统窗格的底部单击应用

    新符号系统随即应用到图层中。

    地图上的旅游景点符号随即变化

    现在,旅游景点变得更加清晰明确,并且不遮盖地图上的其他要素。

    注:

    如果您的 ArcGIS 帐户使用 ArcGIS Enterprise 门户,并且您已经下载了图层数据,则铁路线和火车站的符号可能与示例图像中显示的符号不同。要更改铁路线符号以匹配示例图像,请单击其符号以打开符号系统窗格。在属性选项卡的图层选项卡中,将颜色更改为北极白,然后单击应用。要更改火车站符号,请打开其符号系统窗格。在属性选项卡的符号选项卡中,将颜色更改为灰色 80%,将轮廓颜色更改为黑色,并将轮廓宽度更改为 1.2 磅。单击应用

  10. 关闭符号系统窗格并保存工程。

确定邻域

该旅行社希望其宣传册能够告知向用户距离每个旅游景点最近的火车站。一对一地测量每个旅游景点与火车站之间的距离将花费大量时间,因此您将通过运行地理处理工具来自动化该过程。

地理处理工具将对数据集执行操作。在 ArcGIS Pro 中,有数百种地理处理工具,涉及多种操作。您将使用空间连接工具,该工具可以基于两个要素类的空间关系来组合它们的信息。您将使用此工具来确定距离每个旅游景点最近的火车站。

  1. 在功能区上,单击分析选项卡。在地理处理组中,单击工具

    “工具”按钮

    随即显示地理处理窗格。

  2. 地理处理窗格的搜索框内,输入空间连接。在结果列表中,单击空间连接工具。

    搜索结果中的“空间连接”工具

    提示:

    还可以从分析库中打开空间连接工具。在分析选项卡的工具组中,展开分析库。在叠加数据组中,单击空间连接

    空间连接工具随即打开。大多数地理处理工具都具有一些参数,您可以设置这些参数来更改工具的结果。对于此工具,您首先需要选择要连接的要素图层。

  3. 对于目标要素,选择 Tourist Attractions。对于连接要素,选择 Rail Stations

    “空间连接”工具的“目标要素”和“连接要素”参数

    提示:

    要了解有关任何参数的详细信息,请指向该参数。然后,指向随即显示的信息按钮。随即显示工具提示,其中包含参数描述。

    接下来,您将设置输出要素类参数。许多地理处理工具都会创建输出图层,而原始图层则保持不变。

    默认情况下,输出图层保存在专用于地理数据的文件夹中,该文件夹称为地理数据库,该文件夹是在创建工程时创建的。您将保留输出位置不变,但需要更改输出名称。

  4. 对于输出要素类,单击文本框。将文本 TouristAttractions_SpatialJo 替换为 Tourist_Attractions_Join,其余路径保持不变。

    “空间连接”工具的“输出要素类”参数

    您将保留一对一连接连接操作不变。此操作可确保将每个旅游景点仅连接到一个火车站,这对您而言非常理想,因为您只想知道最近的一个火车站。

    下一个参数是连接要素的字段映射。此参数用于确定每个输入要素类中有哪些属性将保留在输出要素类中。您将在稍后了解有关属性的详细信息。目前,您将仅移除 Shape__AreaShape__Length 字段,因为您对地图上要素的大小和形状不感兴趣。

  5. 对于连接要素的字段映射,单击 Shape__Area,然后单击移除

    Shape__Area 字段的“移除”按钮

  6. 移除 Shape__Length 字段。

    接下来,您将设置匹配选项参数。此参数用于确定要连接的要素之间的空间关系。

  7. 对于匹配选项,选择最近
    注:

    您可能需要滚动查看匹配选项参数和最近选项。

    “空间连接”工具的“匹配选项”参数

    您已经设置了所有需要的参数。根据您选择的参数,该工具将运行作,将每个旅游景点的信息与其最近的火车站的信息相结合。

  8. 单击运行

    该工具随即运行。完成运行后,新图层 Tourist_Attractions_Join 将添加到地图和内容窗格中。新图层看起来与原始 Tourist Attractions 图层相似。但是,地理处理工具更改了图层的属性。

    属性是与要素图层中每个要素关联的信息。它们可能包括要素的名称、地址、面积或各种其他类型的信息。通过打开图层的属性表,您可以查看其属性。

  9. 内容窗格中,右键单击 Tourist_Attractions_Join 并选择属性表

    “属性表”选项

    属性表随即打开。

    已打开属性表

    表的每一行代表地图上的单个要素,每一列都是一个信息字段。在此表中,第一行对应于名为 Chinatown Heritage Centre on 48 Pagoda Street 的要素。Object ID 字段包含每个要素的唯一 ID 编号。

    提示:

    像窗格一样,您可以调整属性表的大小并将其重新放置。

  10. 如有必要,可以向右滚动,直到看到最后几个字段。

    属性表中的最后五个字段

    表中包含两个标题为 Name 的字段。第一个 Name 字段为旅游景点的名称,第二个 Name 字段为最近的火车站的名称。当运行空间连接工具后,第二个 Name 字段将添加到表中。

    注:

    Type 字段也由空间连接工具添加。它用于表示最近的车站属于新加坡地铁 (MRT),新加坡轻轨 (LRT) 还是新加坡地铁环线 (CCL) 系统的一部分。通过打开原始 Tourist Attractions 图层的属性表并进行比较,您可以确定工具添加的字段。

  11. 关闭表。

    您不再需要原始 Tourist Attractions 图层,因此可以将其移除。

  12. 内容窗格中,右键单击 Tourist Attractions 图层,然后选择移除

    Tourist Attractions 图层的移除选项

    图层随即被移除。您还将重命名新图层,以便其名称与您移除的图层相匹配。

  13. 单击 Tourist_Attractions_Join 图层名称以选择图层。再次单击该图层以使其名称可编辑。
  14. 将名称更改为 Tourist Attractions 并按 Enter 键。
    提示:

    更改图层名称的另一种方法是双击以打开其图层属性窗口。在常规选项卡上,更改名称。: 单击确定

  15. 保存工程。

导出表

如果游客访问您在 ArcGIS Pro 中的地图或在 ArcGIS Online 中的交互式 Web 地图,他们可以像您一样打开属性表以找到距离每个景点最近的车站。但是,此地图将打印在宣传册中,因此用户不会具有此功能。

为了随附在地图中,旅行社计划在宣传册中打印属性表中的关键信息。您将把属性表导出到纯文本文件,以便旅行社可以将必要数据复制到宣传册的设计中。

  1. 内容窗格中,右键单击 Tourist Attractions,指向数据并选择导出表

    地理处理窗格中,表至表地理处理工具随即打开。此工具可以将图层的属性表转换为新的文件格式。在输入行参数中已选择 Tourist Attractions 图层。

    默认输出位置是随工程创建的地理数据库 Singapore Tourism.gdb。但是,文本文件不能存储在地理数据库中。您需要将输出位置更改为适合导出数据的位置。

  2. 对于输出位置,单击浏览按钮。

    “浏览”按钮

  3. 输出位置窗口中,选择一个您容易记住的计算机上的位置,例如“文档”文件夹。单击确定
    注:

    如果将输出位置更改为地理数据库,则该工具将无法正确运行。确保选择的位置与默认位置不同。

  4. 对于输出名称,输入 Tourist_Attractions.txt。(请确保包括 .txt 扩展模块。)

    “表至表”工具中的“输出名称”参数

    提示:

    您还可以使用 .csv 扩展模块将表导出为逗号分隔值文件,或使用 .dbf 扩展模块将表导出为 dBase 数据库文件。

    当与空间连接工具搭配使用时,表至表工具具有从输出表中移除不需要的字段的选项。您将移除无法向您提供必要信息的 Join_CountTARGET_FID 字段。

  5. 对于字段映射,单击 Joint_Count 字段以将其选中,然后单击移除。以相同方式移除 TARGET_FID 字段。
  6. 单击运行

    工具随即开始运行,并导出表。(您可以检查选择的输出位置来确认是否已成功导出)。此外,已导出的表将添加到独立表标题下的内容窗格中。您不需要工程中的表,因此会将其删除。

  7. 内容窗格中,右键单击 Tourist_Attractions.txt 并选择移除
  8. 关闭地理处理窗格并保存工程。

标注要素

通过导出的表格,旅行社可以将属性信息作为文本信息添加到宣传册中。但是,使用宣传册的游客仍然无法分辨出地图上的点对应于哪个旅游景点。

为了使地图更有用,您将标注旅游景点。标注是显示在地图上的文本信息,可帮助用户更好地理解数据。

  1. 内容窗格中,单击 Tourist Attractions 图层将其选中。

    当您选择 Tourist Attractions 图层时,标注选项卡变为可用。此选项卡为上下文标签,意味着仅在与您正在使用的数据相关时才显示。

  2. 单击功能区上的标注选项卡。在图层组中,单击标注按钮。

    标注按钮

    图层标注已启用。默认情况下,每个旅游景点使用其名称进行标注。但是由于景点很多,所以标注使地图混乱,不容易阅读。

    默认标注

    为了保持地图的可读性,您将使用景点的唯一 ID 编号来标注景点。

  3. 标注分类组中,对于字段,选择 Object ID。(可能需要滚动查看正确的选项。)

    标注的字段选项

    地图上的标注从长名称更改为较短的数字。尽管数字并不能立即标识出每个景点,但宣传册可以包含带有表数据的 ID,以帮助用户识别这些 ID。

    在深色底图上,标注中的深色小号文本无法清晰显示。此外,标注的位置不能确保清楚地表明数字所对应的景点。您将更改标注的外观和位置以使其更清晰。

  4. 文本符号组中,将文本符号字体大小更改至 8,将文本符号颜色更改至北极白

    文本大小和颜色参数

  5. 标注放置组中,单击中心点

    “中心点”标注放置

    标注已在地图上更新。

    已改进地图上的标注

    这些标注得到了改进,但是仍然存在一些小问题。首先,对于某些旅游景点,没有显示标注。默认情况下,如果标注之间的距离太近,则不会显示标注,以免发生重叠。此外,如果标注位于图钉符号的中心,则显示效果更好。您将进行更改以解决这两个问题。

  6. 标注放置组中,单击标注放置属性按钮。

    “标注放置属性”按钮

    标注分类 - Tourist Attraction 窗格随即显示。此窗格具有高级标注选项。

  7. 标注分类 - Tourist Attraction 窗格中,单击冲突解决选项卡。

    “冲突解决”选项卡

  8. 展开未放置的标注部分并选中从不移除(放置压盖)

    “从不移除”选项

    目前,不存在因重叠而被从地图上移除的标注。接下来,您将调整标注位置,以使其在每个图钉符号中更居中。

  9. 单击符号。在常规选项卡中,展开位置部分和将偏移 Y更改为 2 磅。

    “偏移 Y”参数已更改为 2 磅

  10. 单击应用

    标注将略微上移,并定位在图钉符号中心。

    地图上的最终标注

    尽管某些标注与其他图钉符号略微重叠,但通常都清晰易读。结合宣传册中发布的表数据,游客能够识别地图上的每个景点。

  11. 关闭标注分类窗格并保存工程。
    注:

    如果对火车站进行标注,则可能对游客也非常有用。在本课程中,您将不会对其进行标注,但是如果您想要尝试额外挑战,可以尝试创建自己的标注。哪种外观可以使您的标注能够在地图上清晰可见?

    在继续之前,您需要将地图名称更改为更具描述性的名称。默认名称为 Map。

  12. 内容窗格中双击地图

    “内容”窗格中的“地图”

    地图属性窗格随即出现。

  13. 常规选项卡中,对于名称,输入 Central Business District

    名称参数

  14. 单击确定

    地图已重命名。

创建布局

您的地图已完成。剩下的就是将其导出为可以在宣传册中打印的表格。要准备打印地图,您需要创建页面布局。布局是在虚拟页面上组织的地图元素的集合。它定义了地图打印后的外观。

您可以从头开始设计布局,但是 ArcGIS Pro 中还包括几个预制的布局模板。您将使用模板并修改一些布局元素。

  1. 在功能区,单击插入选项卡并单击导入布局按钮。

    “导入布局”按钮

    随即出现可用的模板列表。由于您希望将重点放在地图上,因此最好使用简单布局。

  2. 选择标题栏信纸横向布局。

    “标题栏信纸横向”布局

    布局随即作为新视图打开。(您可以使用视图上方的选项卡在地图视图和布局视图之间进行切换。)

    默认布局

    此布局包含标题、图例和比例尺。布局的所有元素都列于内容窗格中。此外,功能区现在显示与布局交互相关的选项卡。

    默认情况下,您选择的模板包含俄亥俄州哥伦布地图。您将更新布局的地图框以使用新加坡地图。

  3. 内容窗格中双击地图框

    “内容”窗格中的“地图框”

    随即显示设置地图框格式窗格。

  4. 对于地图框,选择 Central Business District

    对于“地图框”参数选择的地图

    布局中的地图随即更改。但是,该地图已缩放至全球范围,因此新加坡不可见。地图范围和布局范围是独立的。

    您将使用之前创建的书签以导航到所需的地图范围。

  5. 单击功能区上的布局选项卡。在地图组中,单击书签,然后选择 Central Business District 书签。

    Central Business District 书签

    地图范围随即更新至您感兴趣的区域。

    带有书签范围的布局

    提示:

    要在布局中将地图平移或缩放至不同范围,需要在地图组中,单击激活。激活后,您可以正常浏览地图。更改范围后,单击布局选项卡,然后单击关闭激活

    接下来,您将为布局设置标题。

  6. 内容窗格中双击地图标题

    格式化文本窗格随即显示。

  7. 对于文本,删除现有文本并输入 Downtown Singapore。单击文本框外的任意位置。

    地图标题文本

    这些更改将应用到布局。

    布局中的新标题

    您还将调整图例,该图例解释了地图上所有符号的含义。默认图例具有白色背景,这意味着白色的铁路线符号将显示不佳。您将移除背景并调整图例的位置。

  8. 内容窗格中双击图例

    格式化图例窗格随即出现。首先,将图例文本更改为白色,以便在移除图例背景时,其可以显示在深色底图上。

  9. 单击文本符号。在属性选项卡中,展开外观,然后将颜色更改为北极白

    颜色已更改为北极白

  10. 单击应用

    接下来,您将更改图例背景。

  11. 在窗格顶部的图例旁边,单击下拉箭头,然后选择背景

    背景选项

  12. 对于颜色,选择无颜色

    “无颜色”选项

  13. 单击应用

    图例的背景已被移除。

  14. 在布局视图中,拖动图例,使其显示在地图的右下角。完成后,单击地图外部布局视图中的任意位置以取消选择图例。

    最终布局

    布局已完成。旅行社将在宣传册内打印此地图图像。宣传册的背面将包含基于您导出的表格列出的旅游景点列表。最终,该宣传册将用于帮助游客找到距离每个旅游景点最近的火车站。

  15. 关闭格式化图例窗格。保存工程。

    接下来,您会将布局导出到图像文件。

  16. 单击功能区上的共享选项卡。在导出组中,单击布局

    “共享”选项卡上的“布局”按钮

    随即显示导出窗格。

  17. 对于文件类型,选择图像文件格式。对于名称,浏览到您的首选输出位置,然后将文件名称更改为 Downtown Singapore
  18. 单击导出

    布局将导出到您选择的位置。

在本课程中,您创建了一张地图,该地图显示了新加坡市中心的热门旅游景点。您创建了一个工程,导航到感兴趣区域,并添加了数据。您更改了地图的外观,并分析了旅游景点和火车站之间的距离。然后,您创建了一个布局并将地图导出到图像文件。

本课程是有关 ArcGIS Pro 的介绍,并且仅涵盖制图和分析等主题的基本信息。要了解有关 ArcGIS Pro 的功能,请参阅以下 Learn ArcGIS 课程:

您可以在 Learn ArcGIS 课程库中找到更多课程。