Import and explore a map

ArcGIS Pro integrates the functionality of ArcMap, ArcCatalog, ArcToolbox , ArcScene, and ArcGlobe within one application, allowing you to switch between 2D and 3D visualization, analysis, and editing.

Import a map document into ArcGIS Pro

One way to get started with ArcGIS Pro is to import an existing ArcMap map document (.mxd).

  1. Sign in to your ArcGIS organizational account.
    Note:

    If you don't have an organizational account, you can sign up for an ArcGIS free trial.

  2. Download the  Mali Language Groups ZIP file.
  3. Open the MaliLanguageGroups.zip file and extract the contents of the ZIP file to a location of your choice and open the new MaliLanguageGroups folder.

    The downloaded folder includes an ArcMap map document (.mxd), a geodatabase (.gdb), and shapefiles. The data for this map was provided by the National Geospatial-Intelligence Agency (NGA) and the Food and Agriculture Organization of the United Nations (FAO).

    Note:

    If you want to explore the project in ArcMap before diving into ArcGIS Pro, double-click MaliLanguageGroups.mxd to open it in ArcMap.

  4. Start ArcGIS Pro.

    If prompted, sign in using your licensed ArcGIS account or an ArcGIS Enterprise named user account.

    ArcGIS Pro opens to the splash screen. Project templates are listed under the New Project heading. Each template will create a project, already configured with resources. For example, the Map template creates a blank map, geodatabase, and toolbox. If you want to start working without creating a project first, you can choose to start without a template.

  5. Under New Project, click Start without a template.

    Start without a template under New Projects

    ArcGIS Pro opens to a blank view. A ribbon at the top contains tabs that sort commands and settings into related groups. For example, the common tools related to editing can be found on the Edit tab.

    The Contents pane is similar to the table of contents in ArcMap, and the Catalog pane is similar to the Catalog window in ArcMap. There are other panes in ArcGIS Pro that can be opened and repositioned as needed. The middle area is currently blank; this is where maps, tables, layouts, models, and other views will appear.

    ArcGIS Pro interface

  6. On the ribbon, under the Insert tab and in the Project group, click Import Map.

    Import Map on the Insert tab

  7. In the Import window, browse to and select MaliLanguageGroups.mxd from the extracted folder you downloaded.

    Select source map

    Tip:

    You can use the Import Map command to bring different kinds of documents into ArcGIS Pro. Expand the Default drop-down menu to view the file types that can be imported.

  8. Click OK.

    The ArcMap document is imported. The Contents pane is now populated with items, and a layout view appears in the middle of the application. The layout shows a map of language groups in Mali, a landlocked country in West Africa.

    Layout view

    Note:

    If a project was saved in Data view in ArcMap, ArcGIS Pro will open the .mxd file in Map view. If the project was saved in Layout view in ArcMap, ArcGIS Pro will open the .mxd file in layout view, which is the case in this example.

Explore the project structure

The Catalog pane is used for data management and provides a quick way to access all the resources available to a project.

  1. In the Catalog pane, expand Layouts.

    Expand Layouts in Catalog pane

    The layout in an ArcMap document becomes a layout item in ArcGIS Pro. Many projects in ArcGIS Pro may have no layout at all.

  2. In the Catalog pane, on the Project tab, expand Maps.

    Review maps in Catalog pane

    The project contains two maps corresponding to the two data frames in the map document. Both can be seen in the layout; one is the map of language groups in Mali, and the other is the locator map of Africa.

  3. In the Catalog pane, under Maps, right-click New Data Frame and click Rename.

    Rename maps

  4. For name, type Mali Language Groups Map and press Enter.
  5. Rename New Data Frame1 as Locator Map.

    Although you changed the name in Catalog, the name of the map frame within the layout remains unchanged. Next, you will update the data frame names in the Contents pane.

  6. In the Contents pane, click on New Data Frame Map Frame two times.

    Data frame is ready for renaming

    This will allow you to rename the data frame.

  7. Rename the data frame Mali Language Groups Map and press Enter. Do the same for New Data Frame Map Frame 1 and rename it Locator Map.

    Rename dataframe Locator Map

  8. At the top of ArcGIS Pro, on the Quick Access Toolbar, click Save.

    Save project

    Because you started without a template and have not previously saved this project, you are presented with the Save Project As window.

  9. In the Save Project As window, browse to a location of your choice.
  10. For Name, type Mali Language Groups.
  11. Click Save.

    ArcGIS Pro stores work in project folders. This structure allows you to assemble all the resources needed for your work in one place. A project can contain maps, scenes, layouts, data, tasks, toolboxes, and styles, as well as connections to servers and folders.

  12. In your file explorer, browse to the new Mali Language Groups folder.

    Inside, you will find a geodatabase (.gdb) and a toolbox (.tbx). Any new data or scripts that you create while working in the project will be stored here by default. The .aprx file is the ArcGIS Pro project file and is equivalent to an .mxd file.

    Review project folder

  13. In ArcGIS Pro, in the Catalog pane, expand Folders and expand Mali Language Groups.

    Explore Catalog pane

    This is a folder connection to the project folder that you just viewed in your file explorer. However, the data for your map is stored in the folder you downloaded.

    In ArcGIS Pro, you can add data without first creating a folder connection. However, creating folder connections for access to project data is still a useful practice.

  14. In the Catalog pane, right-click Folders and choose Add Folder Connection.
  15. Browse to and select the MaliLanguageGroups folder that you previously downloaded. Click OK.

    Create a folder connection to MaliLanguageGroups folder

  16. Expand MaliLanguageGroups.

    The geodatabase and shapefile data referenced by the Mali maps are all stored here.

    Review project source data

    Note:

    In ArcGIS Pro, data sources on the same hard drive are linked to the project folder as relative paths. Links to data sources on a network drive are saved using absolute paths. Links to data sources on a GIS server are stored using universal locator paths. See more information on referencing data in maps.

Explore a map

Next, you'll explore the map of language diversity in Mali.

  1. In the Catalog pane, under Maps, right-click Mali Language Groups Map and choose Open.

    The original ArcMap data frame was saved at a small scale to accommodate the layout, so the map will be very small.

  2. In the Contents pane, right-click District Boundary, then choose Zoom To Layer.

    Zoom To Layer

    The scale updates and the map of Mali comes into view. In ArcGIS Pro, you can zoom and pan a map freely without affecting the scale of the layout.

    Navigate map

  3. Use your mouse wheel to zoom in and out on the map.
  4. Click anywhere on the map.

    The clicked feature flashes and a pop-up window appears, displaying attribute information.

    Identify feature using Pop-up

  5. Close the pop-up.
  6. If necessary, on the ribbon, click the Map tab.

    Another way you can navigate the map is to use the Explore tool.

  7. In the Navigate group, click the Explore button to pan the map.

    Explore

    Note:

    The Explore tool is similar to the Identify tool in ArcMap and is how you access pop-ups. You can change how the Explore tool function by clicking the bottom half of the Explore button to view more options.

Work with symbology and labeling

In ArcGIS Pro, symbology is controlled within a pane instead of a dialog box. This means you can see changes on your map without first having to close out of a set of windows.

  1. In the Contents pane, right-click language_Union and choose Symbology.

    The Symbology pane appears. The top of the pane displays the name of the currently selected layer. Under Primary symbology, you can see that this layer is symbolized using the Unique Values method and the Language Family field.

    Update layer symbology with unique values

    The tabs at the top of the pane give you access to advanced symbology properties, which won't be covered in this lesson.

  2. In the bottom half of the Symbology pane, click the symbol next to Berber and Atlantic.

    Select symbol for update

    The Symbology pane now displays properties for the Berber and Atlantic symbol class only.

  3. Click the Properties tab and click the Layers tab.

    Review symbol properties

    The symbology for the Berber and Atlantic layer is made up of two hatch fill symbols layers. In this tab, you can adjust the color and line width.

    Note:

    ArcGIS Pro and ArcMap use different methods to construct symbols, but the appearance of imported symbols will remain the same. In ArcGIS Pro, complex symbols are built with symbol layers.

  4. In the Symbology pane, click the Back arrow to return to the symbology settings for the entire layer.

    Navigate Symbology pane

  5. In the Contents pane, click District Boundary.

    The Symbology pane updates to display settings for the selected layer. By keeping the Symbology pane open, you can easily switch to display settings for another layer by selecting the layer on the Contents pane.

  6. On the ribbon, click the Labeling tab.

    Labeling tab

    The ribbon interface is contextual. You will see different tabs when you are interacting with a map than with a layout. When you have a layer selected, additional tabs appear under a colored bar. Any changes made on a contextual layer tab—such as labeling—will only apply to the currently selected layer.

  7. In the Layer group, switch the Label button off and on again.

    The white district labels disappear and reappear on the map.

    Explore labeling options

    The most common labeling tasks can be found on the ribbon, while more advanced features are available in a pane.

  8. On the Labeling tab of the ribbon, in the corner of the Label Placement group, click the Label Placement Properties button.

    Show label class properties

    The Label Class pane appears.

  9. If necessary, in the Label Class pane, click the Position tab and the other Position button.

    Explore Label Class properties pane

  10. Expand Spread labels.
  11. Change the second drop-down menu to Spread letters up to a fixed limit and set Maximum to 100%.

    Update label spread

    The white labels on the map expand to better fill the areas that they represent.

    The labeling engine for ArcGIS Pro is more advanced and intuitive than in ArcMap and includes all the Maplex Label Engine functionality.

  12. Close the Label Class pane and the Symbology pane
  13. On the Quick Access Toolbar, click Save.
    Note:

    Learn more about Symbology and Labeling in ArcGIS Pro.

You've now imported a map to ArcGIS Pro and explored some basic functionality.


Update and edit a map

Your map shows that Mali has a rich linguistic diversity. While this map lists seven language groups, there are more than 80 languages spoken in the country. The most widely spoken language is Bambara, part of the Mande language group. The official language is French, introduced during French colonial rule, which serves as a common trade language among the diverse languages of Mali.

You may recognize the place-name Timbuktu on the map, both for the region and the city. The French spelling of this ancient city is Tombouctou. Next, you'll learn how to edit data in ArcGIS Pro, you'll update the map data to the French spelling of Timbuktu.

Edit features

In ArcGIS Pro, it is not necessary to start an editing session before making changes to your data.

  1. In the Contents pane, right-click District Boundary and choose Attribute Table.

    The attribute table appears beneath the map.

  2. In the NAME_1 column, double-click the Timbuktu cell.

    Edit feature attributes in table

  3. Type Tombouctou and press Enter.

    The district label updates on the map.

  4. On the ribbon, click the Edit tab. In the Manage Edits group, click Save.

    Save edits

  5. In the Save Edits window, click Yes.
  6. Close the attribute table and save the project.

    Next, you'll update the label for the city.

  7. In the Contents pane, click Mali_MajorCities.
  8. If necessary, click the Labeling tab.

    In the Layer group, the Label button is turned off, but the major cities appear to be labeled.

    Turn labels on/off

    This is because the labels are coming from an Annotation feature class instead, the layer named Mali_MajorCitiesAnno.

    Annotation feature classes have a different data structure in ArcGIS Pro than in ArcMap. If you have annotation feature classes created in ArcMap, you can display and query them in ArcGIS Pro. However, to edit them or modify them, they must first be upgraded.

  9. On the ribbon, click the Analysis tab. In the Geoprocessing group, click Tools.

    Tolls under Analysis tab on the ribbon

    The Geoprocessing pane appears. This is where you will find all geoprocessing tools, including common tools such as Buffer and Project, as well as some functions that had their own commands in ArcMap, such as Calculate Field and Select Layer by Attribute.

  10. In the search bar, type upgrade dataset and press Enter.
  11. In the search results, click the Upgrade Dataset tool.

    Search for tool using Geoprocessing pane

  12. For Dataset to upgrade, click the drop-down arrow and choose Mali_MajorCitiesAnno.

    Set geoprocessing tool parameters

    Tip:

    Once upgraded, annotation feature classes are no longer usable in ArcMap. You may want to make a copy of the feature class using the Copy Features tool before upgrading.

  13. Click Run.

    When the tool has finished running, a message appears at the bottom of the pane indicating success or failure.

  14. Click View Details to review a geoprocessing report.

    View geoprocessing tool details

    The option to view details is particularly helpful for diagnosing problems when a tool fails.

  15. Close the details window and the Geoprocessing pane.

    Now that the annotation feature class has been updated, you are able to edit it.

  16. In the Contents pane, select the List by Editing tab. Right-click Mali_MajorCitiesAnno and select Make this the only editable layer.

    Make this the only editable layer

  17. On the ribbon, click the Edit tab, in the Tools group, click Annotation.

    Edit annotation

  18. In the Map, zoom to and select the TIMBUKTU annotation feature.

    A selection boundary appears around the annotation feature.

  19. Double-click the text to highlight it.

    Select target annotation feature for edit

  20. Type TOMBOUCTOU to update the spelling of the annotation feature.
  21. Hover over the edge of the text box until the pointer changes to a move symbol. Drag the text so it is positioned to the lower right of the point.

    Update selected feature spelling

    The label is easier to read against the solid colors than the striped symbol.

  22. At the bottom of the map viewer, on the editing toolbar at the bottom of the map view, click Finish to complete the edit.

    Finish button

  23. On the ribbon, in the Selection group, click Clear.

    Clear selected feature

  24. In the Manage Edits group, click Save, and in the Save Edits window, click Yes.
  25. On the ribbon, click the Map tab. In the Navigate group, click the Explore button.

    Now when you click the map, you will not accidentally move or edit features.

  26. Save the project.
    Note:

    Learn more about Editing in ArcGIS Pro.

Add data from ArcGIS Online

One of the biggest advantages of migrating to ArcGIS Pro is closer integration with ArcGIS Online. Without leaving the application, you can browse and access maps and data from outside sources, including ArcGIS Living Atlas of the World and ArcGIS Online.

The map of Mali contains a layer for water bodies that helps give context to the story of language diversity in the country by relating it to physical geography. The Mali_WaterBodies layer was created at a smaller scale and has extra details, like fluctuating rivers and lakes, that may not be necessary for the scale of your map. To demonstrate the integration of ArcGIS Pro with ArcGIS Online, you will search ArcGIS Online and add a simpler map of water bodies in Mali.

  1. If necessary, in the Contents pane, click the List By Drawing Order tab.

    List By Drawing Order tab

  2. Right-click District Boundary then choose Zoom to Layer.
  3. Right-click Mali_WaterBodies and choose Remove.

    Next, you will search ArcGIS Online for another map that only shows the major river that runs through Mali, the Niger River.

  4. Open the Catalog pane.
    Tip:

    If you can't find the Catalog pane, on the ribbon, click View tab and click Catalog Pane.

  5. In the Catalog pane, click the Portal tab and click ArcGIS Online.

    Switch to Portal tab in Catalog pane

  6. In the search bar, type World Major Rivers owner:esri_dm and press Enter.
    Note:

    The owner esri_dm is the name of the Data and Maps for ArcGIS account on ArcGIS Online.

  7. In the search results, point to the first item named World Major Rivers.

    Search Portal items

    Note:

    The World Major Rivers item is a layer package. A layer package includes both the layer properties and the data. If you add a layer package to your map, it will be downloaded to your local machine and the map will reference the local data. In contrast, if you add a hosted feature layer to your map, it will reference an online service.

  8. In the Catalog pane, right-click the World Major Rivers layer package and choose Add To Current Map.

    Add To Current Map

    The World Major Rivers layer appears on the map. You can see the Niger River passing through Mali, but the symbology is difficult to see. Next, you will update the symbology to make the river more visible.

Change layer symbology

Next, you'll choose a new symbol for the World Major Rivers layer.

  1. In the Contents pane, right-click World Major Rivers and choose Symbology.

    The Symbology pane appears, and you can see that the Primary symbology method is set to Single Symbol.

  2. In the Symbology pane, for Label, change the text to Niger River.

    Change label to Niger River

    The label next to the symbol in the Contents pane updates. This is the label that will appear on the map legend later.

  3. In the Symbology pane, click the turquoise symbol to access symbol properties.

    Update layer symbology

  4. In the Symbology pane, click the Gallery tab.

    The symbol gallery contains common symbols that can be employed as is or adapted.

  5. In the gallery, click Limited Access symbol.

    Select line symbol

    The map updates and the Niger River is now drawn with a cased blue line.

    Review map layer symbology

  6. Close the Symbology pane.

    The World Major Rivers layer package also includes a label, which you don't need.

  7. In the Contents pane, right-click World Major Rivers and click Label to turn labeling off.

    Display layer labels

    This has the same effect as disabling labels from the ribbon.

  8. Save the project.

Clip the map

The river is the only layer in the map that extends beyond the boundaries of Mali. Next, you'll clip the map using the country's border to create a cleaner appearance.

Note:

Using Clip Layers in the Map Properties simply limits the extent of data displayed and does not alter the original data file. Using the Geoprocessing Clip Tool removes data outside of the clip and does alter the original data file.

  1. In the Contents pane, right-click Mali Language Groups Map and choose Properties.
  2. In the Map Properties window, click the Clip Layers tab.
  3. From the drop-down menu, choose Clip to the outline.

    Clip to outline

  4. For Get shape from the outline of, click District Boundary.

    The outline of Mali appears in the Selected shape preview. No map content will be displayed outside of this clipping shape.

    Select clip shape

  5. Click Apply and click OK.

    The map updates and the World Major Rivers layer is now clipped to the borders of Mali.

    Clipped map

  6. Save the project.

You've updated and edited your map.


Share a mapping project

Now that your map is configured, you want to share it with a colleague. Before you do so, you'll review the layout to see if there is anything you need to change.

Update a layout legend

In previous steps, you removed a layer from the map and added a new one. This means the legend on the layout will need to be updated.

  1. At the top of the map view, click the MaliLanguageGroups tab to view the layout.

    Switch to layout view

    In ArcMap, panning and zooming in the data view impacts the layout view. This is different in ArcGIS Pro. In the previous steps, you zoomed in and out of the map several times, but the scale and extent in the layout view has remained the same.

    You will notice this layout has two legends, one for language groups and one for reference layers. An item named Niger River was added to each of them when you added the World Major Rivers layer from ArcGIS Online.

    Two legends in layout view

  2. In the Contents pane, expand Legend1 and Legend.

    Expand legend layers

  3. Hold Ctrl and select the items Mali_Roads, Mali_Railroads_NGA, and DistrictBoundary. With the three items selected, click and drag them into Legend.

    Move items from one legend to another

    The top legend updates to include the added items.

  4. Turn off Legend 1.
  5. Click and drag the items in Legend into the following order:

    • LANGUAGE FAMILY
    • Mali_Railroads_NGA
    • Mali_Roads
    • DistrictBoundary
    • World Major Rivers

    The legend items update to the new order.

    Updated legend item order

  6. In the Contents pane, double-click World Major Rivers.

    The Element pane appears.

    Tip:

    In the layout view, you can double-click any item in the Contents pane to access its properties.

  7. At the top of the pane, click Text Symbol.
  8. Expand Appearance and change Font name to Candara. Confirm that Font style is set to Regular.
  9. Change Size to 14 and Color to Gray 70%.
    Tip:

    Point to a color to reveal its name.

    Change legend font properties

  10. Click Apply.

    The new legend item now matches the rest of the legend.

    Review updated legend on map

  11. Click and drag the corners of the legend to adjust the size.

    Adjust legend size

  12. Click anywhere outside of the layout to clear the selection.
  13. Save the project.
    Note:

    Learn more about working with Layouts in ArcGIS Pro.

Share a project package

You have now successfully migrated a map project into ArcGIS Pro and configured the map to be more clear. Next, you want to share the project with a coworker in another office. Since your project uses data from several different source folders on your computer, the simplest way to ensure the project file you share with your coworker does not reference data paths that won't work on another computer is to send it as a project package. Next, you will share your map project as an online project package.

  1. Click the Mali Language Groups Map map view to make it active.

    Click tab to make Mali Language Groups Map active

  2. On the ribbon, click the Share tab.

    This ribbon tab includes commands for sharing maps, data, tools, and other items. For example, you can share web layers to ArcGIS Online, or export PDF files of static maps.

  3. In the Package group, click Project.

    Click Project tab

    A project package (.ppkx) file consolidates all of the maps, data, folder connections, toolboxes, and geoprocessing history reports from a project into a single file. You can additionally include attachments for other file types.

  4. In the Package Project pane, under Start Packaging, choose Upload package to Online account.

    Upload package to Online account

    You are going to share the project package as an item on ArcGIS Online or your portal. That way you can send your colleague an email with a link to where they can view the project's metadata and download the .ppkx file. If you prefer to save the package to your local machine, you would choose Save package to file.

  5. In the Package Project pane, enter the following:
    • For Name, type Mali Language Groups Project and append it with your initials.
    • For Summary, type Mali Language Groups mapping project.
    • For Tags, type Mali, Mali districts, Mali Cities, Language groups.
    • For Share with, check Everyone.

    This will ensure that no matter who you send the item link to, they will be able to access it. Sometimes you may prefer to only share within your organization.

    Update project package settings

    Note:

    Learn more about Sharing with ArcGIS Pro.

  6. Under Finish Packaging, click Analyze.

    Analyzing helps identify performance delays and errors that you need to address before you can share your project as a package. If there are yellow warnings, you may still proceed with sharing. If you receive a red error, you can point to it to receive tips on how to resolve the issue.

    Review project packaging messages

    No issues were identified.

  7. Under Finish Packaging, click Package.
  8. In the Save Project window, click Yes.

    Save project before packaging

    When packaging has completed, a green success message appears at the bottom of the Package Project pane.

  9. Click Manage the package.

    Manage package

  10. A browser window appears, displaying the item page of your project on ArcGIS Online.

    Review published package

    You can now share the URL for this page with your colleague so they can download the project package or open it directly in ArcGIS Pro.

    Tip:

    Consider updating the description and other metadata information on the item details page before sharing.

Congratulations, you have successfully imported an ArcMap project into ArcGIS Pro. You converted data frames into maps, replaced a layer with data from ArcGIS Online, edited features, and modified symbology and labeling properties. You modified a legend on a layout and shared the map as a project package that can now be easily accessed by others.

You may still have questions about where to find the tools or how to accomplish the tasks that you are accustomed to in ArcMap. The following links provide more information for ArcMap users switching to ArcGIS Pro:

You can find more lessons in the Learn ArcGIS Lesson Gallery.