はじめての ArcGIS Pro

プロジェクトの作成

ArcGIS Pro では、マップとデータはプロジェクト内で編成されます。 マップを開始する前に、プロジェクトを作成します。 ArcGIS Pro がポータルでライセンス付与されている限り、ArcGIS Online アカウントまたは ArcGIS Enterprise アカウントを使用してレッスンを完了することができます。

  1. ArcGIS の組織アカウントまたは ArcGIS Enterprise 指定ユーザー アカウントを使用してサイン インします。
    メモ:

    組織のアカウントがない場合、ArcGIS の無料トライアルにサイン アップできます。

  2. [新規] の下で、[マップ] をクリックします。

    [マップ] プロジェクト テンプレート

    [新しいプロジェクトの作成] ウィンドウが開きます。 デフォルトでは、プロジェクトは新規フォルダーに作成されます。 既存のフォルダーに保存するには、[このプロジェクトのための新しいフォルダーを作成] チェックボックスをオフにし、フォルダーを参照します。

  3. [名前] で、既存のテキストを削除し、「Singapore Tourism」と入力します。 [場所] は変更せず、[このプロジェクトのための新しいフォルダーを作成] がオンになっていることを確認します。

    適切なパラメーターが設定された [新しいプロジェクトの作成] ウィンドウ

    メモ:

    デフォルトの場所は、この画像例とは異なる場合があります。 通常、プロジェクトは ArcGIS Pro のインストール時に作成された ArcGIS フォルダーに保存されます。

  4. [OK] をクリックします。

    プロジェクトは、世界を表示するマップとともに作成されます。 ArcGIS Pro では、マップは地理データのレイヤーで構成されています。 この時点で、レイヤーはベースマップのみで、国境や水域などの参照情報を提供します。

    メモ:

    ArcGIS 組織の設定によっては、マップのデフォルト範囲やベースマップが異なる場合があるため、表示が画像例と異なることがあります。

    世界のマップが含まれる新しいプロジェクト

    マップの両側にはウィンドウがあります。 デフォルトで [コンテンツ] ウィンドウと [カタログ] ウィンドウが開いていますが、以前に ArcGIS Pro を使用したことがある場合は、他のウィンドウが開いている場合もあります。 [コンテンツ] ウィンドウにはマップ上のレイヤーがリストされ、[カタログ] ウィンドウにはプロジェクトに関連付けられたすべてのファイルがリストされます。

    マップの上にはリボンがあります。 リボンには複数のタブが表示され、各タブには複数のボタンが用意されています。 これらのボタンを使用することで、マップ ナビゲーションに影響を与えたり、マップの外観を変更したり、多くの機能を備えたウィンドウを開いたりすることができます。

    ヒント:

    ウィンドウを並べ替えるには、タイトルをドラッグして新しい場所にドッキングします。 ウィンドウの端をドラッグして、ウィンドウのサイズを変更することもできます。 デフォルトのウィンドウ配置に戻すには、[表示] タブをクリックします。 [ウィンドウ] グループで [ウィンドウのリセット] をクリックし、[マッピング用にウィンドウをリセット] を選択します。 このレッスンでは、ウィンドウとビューを自由に配置してかまいません。

シンガポールへの移動

今回の対象地域はシンガポール共和国であるため、そこに移動します。

  1. リボンの [マップ] タブをクリックします。 [照会] グループで、[場所検索] ボタンをクリックします。

    [マップ] タブの [場所検索] ボタン

    [場所検索] ウィンドウが表示されます。 このウィンドウを使用すると、国、都市、住所などの地理的位置を検索して移動できます。

  2. [場所検索] ウィンドウの検索バーに「Singapore」と入力し、Enter キーを押します。

    [場所検索] ウィンドウで「Singapore」を検索

    マップは自動的に、最初の結果であるシンガポールに移動します (検索結果の場所は円でマップ上に表示されます)。

    シンガポールのデフォルト マップ

    世界最小の国の 1 つであるシンガポールは、人口が 560 万人で、4 つの公用語が存在します。 近代的な都市の中には、数多くの歴史的および文化的なランドマーク、娯楽施設、および生態学的に重要な場所が存在します。 シンガポールは世界で最も訪問客の多い都市の 1 つであり、観光は主要な産業となっています。

  3. [場所検索] ウィンドウを閉じます。
  4. リボンの上にあるクイック アクセス ツールバーで [保存] ボタンをクリックします。

    保存ボタン

データの追加

ベースマップには、シンガポールと、道路や湖などの基本的な地理情報が表示されます。 ただし、観光地や鉄道駅は表示されません。 観光客に役立つマップを作成するには、このデータをマップに追加します。

  1. リボンの [マップ] タブの [レイヤー] グループで、[データの追加] ボタンをクリックします。

    [データの追加] ボタン

    [データの追加] ウィンドウが開きます。 プロジェクトのフォルダー ([プロジェクト])、ArcGIS アカウントの Web サイト ([ポータル])、コンピューター ([コンピューター]) などの複数のソースからデータを追加できます。

    トライアル アカウントを含むほとんどの ArcGIS アカウントは、ポータルに ArcGIS Online Web サイトを使用します。 ArcGIS Online は、豊富な空間データをホストするオンライン GIS マッピング プラットフォームです。 このプラットフォームから必要なデータを追加します。

  2. [データの追加] ウィンドウで、[ポータル] の下の [ArcGIS Online] をクリックします。

    [データの追加] ウィンドウのすべての [ArcGIS Online] オプション

    このオプションを使用すると、ArcGIS Online でホストされているすべてのデータにアクセスできます。 使用するデータは、Learn ArcGIS の管理者アカウントが所有します。 データを見つけるには、名前と所有者でデータを検索します。

  3. 検索バーに「Singapore owner:Learn_ArcGIS」と入力し、Enter キーを押します。

    検索結果として、[Singapore Rail Lines][Singapore Tourist Attractions][Singapore Rail Stations] の 3 つが返されます。

    「Singapore」の検索結果

    メモ:

    一部の ArcGIS アカウントは、ポータルに ArcGIS Enterprise Web サイトを使用しています。 アカウントで ArcGIS Enterprise を使用している場合、ArcGIS Online コンテンツを検索することはできません。 データを追加するには、ArcGIS OnlineSingapore_Data_gdb アイテムに移動し、[ダウンロード] をクリックします。 コンピューターの任意の場所にダウンロード フォルダーを解凍します。 [データの追加] ウィンドウで、解凍したフォルダーの場所を参照します (フォルダーを表示するには、[データの追加] ウィンドウの [更新] ボタンをクリックする必要がある場合があります)。

  4. Ctrl キーを押しながら、[Singapore Rail Lines][Singapore Tourist Attractions]、および [Singapore Rail Stations] レイヤーをクリックして選択します。
  5. [OK] をクリックします。

    3 つのデータ レイヤーがマップに追加されます。

    メモ:

    ArcGIS Online からデータを追加せずに、ArcGIS Enterprise を使用してデータをダウンロードした場合、レイヤーの表示は画像例と異なる場合があります。

    マップにデータを追加したシンガポール

    レイヤーが [コンテンツ] ウィンドウにもリストされます。

    [コンテンツ] ウィンドウ

    緑色のポイントは観光名所、白色のラインは線路、黒色のポリゴンは駅を表します。 ポイント、ライン、またはポリゴンで構成されるレイヤーは、フィーチャ レイヤーと呼ばれます。

    観光名所の大半は島の中南部にグループ化されています。 このエリアはシンガポールの中心街で、セントラル ビジネス ディストリクトとも呼ばれています。 旅行代理店は、パンフレットでこのエリアを中心に紹介したいため、このエリアを拡大表示します。

  6. マップでシンガポールの中心街にポインターを合わせ、マウスのホイールを使用して拡大表示します。 中心街エリアがマップの大部分に表示されるまで拡大します。
    ヒント:

    エリアを拡大表示するもう 1 つの方法は、[マップ操作] ツールを選択して Shift キーを押しながら、マップ上で拡大表示するボックスを描画することです。 あるいは、マップ上でマウスを右クリックしてドラッグすると、拡大または縮小できます。 希望のナビゲーション方法を使用してください。

    シンガポールの中心街を拡大表示

  7. 必要に応じて、セントラル ビジネス ディストリクトがマップの中央に配置されるまで、マップをドラッグして画面移動します。

    この範囲では、鉄道駅が詳細に表示されます。 モニターのサイズによっては、道路や建物に関する詳細情報が表示される場合があります。

    このマップ範囲は、今後のプロジェクトで使用します。 必要に応じて、この範囲に簡単に戻れるほうが便利なため、ブックマークと呼ばれるナビゲーション ショートカットを作成します。

  8. リボン上の [マップ] タブの [ナビゲーション] グループで、[ブックマーク] をクリックしてから [新しいブックマーク] を選択します。

    [新しいブックマーク] オプション

  9. [ブックマークの作成] ウィンドウで、[名前] に「Central Business District」と入力します。

    [ブックマークの作成] ウィンドウ

  10. [OK] をクリックします。

    ブックマークが作成されます。 今後、このブックマークをレッスンで使用します。

  11. プロジェクトを保存します。

マップのスタイルの設定

マップを操作している際に、データ レイヤーの一部が見づらかったことにお気づきでしょう。 たとえば、線路は白色で、マップ上の他の情報と混ざり合って表示されることがよくあります。

道路、水域、および建物に関する情報は、ベースマップから取得されます。 ベースマップは、データの文脈を説明する参照情報を提供します。 ArcGIS Pro には、複数のベースマップ レイヤーが用意されており、デフォルトは [地形図 (World Topographic Map)] です。 (ArcGIS 組織の設定によっては、デフォルトのベースマップが異なる場合があります)。

データが強調されるようなベースマップに変更します。 ベースマップの色が濃いほど、白色の線路がはっきりと見えるようになります。

  1. [マップ] タブの [レイヤー] グループで、[ベースマップ] をクリックし、[キャンバス (ダーク グレー)] を選択します。

    キャンバス (ダーク グレー) ベースマップ

    ベースマップが変更されます。

    [キャンバス (ダーク グレー)] ベースマップを使用したシンガポールの中心街

    このベースマップを使用すると、線路をさらに目立たせることができます。 [地形図] ベースマップとは異なり、このベースマップには 2 つのレイヤーが含まれています。 これらのレイヤーの 1 つである [Dark Gray Reference] には、一部のエリアにラベルを付けるテキストが含まれています。 このテキストはマップの目的に照らすと不要で、一部のフィーチャがはっきり表示されなくなる可能性があるため、オフにします。

  2. [コンテンツ] ウィンドウで、[Dark Gray Reference] チェックボックスをオフにします。

    [World Dark Gray Reference] レイヤーをオフ

    レイヤーはマップに表示されなくなります。 (参照情報を再表示するには、もう一度チェックボックスをクリックします)。

    観光名所は、目立たない小さなポイントとしてマップに表示されます。 観光名所をマップの中心点として表示することを目的としているため、観光名所の外観を変更します。

  3. [コンテンツ] ウィンドウで [Tourist Attractions] レイヤー シンボルをクリックします。

    [Tourist Attractions] レイヤー シンボル

    [シンボル] ウィンドウが表示されます。 シンボルは、レイヤーの表示設定を定義します。 デフォルト シンボルのギャラリーから選択するか、シンボルをカスタマイズできます。

  4. [シンボル - Tourist Attractions] ウィンドウの [ギャラリー] タブで、「しずく型ピン」を検索します。 結果のリストで、最も大きい [しずく型ピン 1 (40%)] シンボルをクリックします。

    [しずく型ピン 1 (40%)] シンボル

    観光名所のシンボルが選択したシンボルに変わります。 しずく型ピン シンボルは、観光名所が対象地域であるという考えを伝達するのに効果的です。 40% は、シンボルの透明度が 40% であることを示します。これは、シンボルでマップの一部がはっきり表示されない場合に役立ちます。

    アウトラインを追加してシンボルのサイズを大きくすることで、シンボルをさらに目立たせることができます。

  5. [プロパティ] をクリックします。

    [プロパティ] のオプション

  6. [レイヤー] タブをクリックします。

    [レイヤー] タブ

  7. [アウトライン色][白] を選択します。

    [白] アウトライン カラー

    ヒント:

    色にポインターを合わせると、色の名前が表示されます。

  8. [アウトライン幅][0.7] pt に変更します。 [サイズ][22] pt に変更します。

    シンボル パラメーター

  9. [シンボル] ウィンドウの下部にある [適用] をクリックします。

    新しいシンボルがレイヤーに適用されます。

    観光名所シンボルが変更されたマップ

    これで、他のマップ フィーチャが見づらくなることもなく、観光名所がはっきりと見えるようになりました。

    メモ:

    ArcGIS アカウントで ArcGIS Enterprise ポータルを使用し、レイヤー データをダウンロードした場合、線路と鉄道駅には、画像例の表示とは異なるシンボルが含まれている可能性があります。 線路シンボルを画像例と一致するように変更するには、シンボルをクリックして [シンボル] ウィンドウを開きます。 [プロパティ] タブの [レイヤー] タブで、[色][白] に変更し、[適用] をクリックします。 鉄道駅のシンボルを変更するには、[シンボル] ウィンドウを開きます。 [プロパティ] タブの [シンボル] タブで、[色][グレー 80%][アウトライン色][黒][アウトライン幅][1.2] pt に変更します。 [適用] をクリックします。

  10. [シンボル] ウィンドウを閉じて、プロジェクトを保存します。

近接の判定

旅行代理店は、パンフレットで各観光名所に対して最寄りの鉄道駅を知らせたいと考えています。 各観光名所と鉄道駅の間の距離をそれぞれ計測するには時間がかかるため、ジオプロセシング ツールを実行してプロセスを自動化します。

ジオプロセシング ツールは、データセットに対する操作を実行します。 ArcGIS Pro には、広範な操作に対応した数百のジオプロセシング ツールがあります。 [空間結合 (Spatial Join)] ツールを使用し、2 つのフィーチャクラスからの情報を、それらの空間リレーションシップに基づいて結合します。 このツールを使用して、各観光名所に対して最寄りの鉄道駅を判定します。

  1. リボンの [解析] タブをクリックします。 [ジオプロセシング] グループで、[ツール] をクリックします。

    ツール ボタン

    [ジオプロセシング] ウィンドウが表示されます。

  2. [ジオプロセシング] ウィンドウの検索バーに「空間結合」と入力します。 結果リストの [空間結合 (Spatial Join)] ツールをクリックします。

    検索結果の [空間結合 (Spatial Join)] ツール

    ヒント:

    [解析ツール ギャラリー] から、[空間結合 (Spatial Join)] ツールを開くこともできます。 [解析] タブの [ツール] グループで、[解析ツール ギャラリー] を展開します。 [データのオーバーレイ] グループで [空間結合 (Spatial Join)] をクリックします。

    メモ:

    [ジオプロセシング] ウィンドウの右下で、ツールを説明や詳細情報とともに表示するか、リスト ビューとして表示するかを選択できます。

    [空間結合] ダイアログ ボックスが表示されます。 ほとんどのジオプロセシング ツールには、ツールの結果を変更するためのパラメーターを設定できます。 このツールでは、結合するフィーチャ レイヤーを最初に選択します。

  3. [ターゲット フィーチャ][Tourist Attractions] を選択します。 [結合フィーチャ][Rail Stations] を選択します。

    [空間結合 (Spatial Join)] ツールの [ターゲット フィーチャ] および [結合フィーチャ] パラメーター

    ヒント:

    パラメーターの詳細については、パラメーターにポインターを合わせます。 次に、表示される情報ボタンにポインターを合わせます。 パラメーターの説明を含むツールチップが表示されます。

    次に、[出力フィーチャクラス] パラメーターを設定します。 多くのジオプロセシング ツールは、元のレイヤーを変更せずに出力レイヤーを作成します。

    デフォルトで、出力レイヤーは、プロジェクトの作成時に作成された地理データ専用のフォルダー (ジオデータベース) に保存されます。 出力場所は変更せずに、出力名を変更します。

  4. [出力フィーチャクラス] で、テキスト ボックスをクリックします。 テキストを「Tourist_Attractions_Join」に置き換えます。

    空間結合 (Spatial Join) ツール

    [1 対 1 の結合] 操作はそのままにします。 この方法により、各観光名所が 1 つの鉄道駅のみに結合されるようになるため、最寄り駅を 1 つだけ把握する今回の目的に最適です。

    次に、[マッチ オプション] パラメーターを設定します。 このパラメーターは、結合するフィーチャ間の空間リレーションシップを決定します。

  5. [マッチ オプション][最も近い] を選択します。
  6. 表示されているパラメーターの下の [フィールド] を展開します。

    [フィールド マップ] パラメーターは、出力フィーチャクラスで保持される各入力フィーチャクラスの属性を決定します。 属性については、後で詳細に説明します。 今回、マップ上のフィーチャのサイズや形状は重要でないため、Shape__Area および Shape__Length フィールドのみを削除します。

  7. [出力フィールド] 列で [Shape__Area] をクリックし、[削除] ボタンをクリックします。

    Shape__Area フィールドの [削除] ボタン

  8. Shape__Length フィールドを削除します。

    これで、必要なすべてのパラメーターを設定できました。 ツールは選択したパラメーターに基づき、各観光名所の情報と最寄りの鉄道駅の情報を結合した操作を実行します。

  9. [実行] をクリックします。

    ツールが実行されます。 実行が完了すると、新しいレイヤー [Tourist_Attractions_Join] がマップと [コンテンツ] ウィンドウに追加されます。 新しいレイヤーは元の [Tourist Attractions] レイヤーと似ています。ただし、ジオプロセシング ツールがレイヤーの属性を変更しています。

    属性は、フィーチャ レイヤーの各フィーチャに関連付けられた情報です。 属性には、フィーチャの名前、住所、エリアのほか、他の多くの情報タイプが含まれている場合があります。 属性テーブルを開くと、レイヤーの属性を表示できます。

  10. [コンテンツ] ウィンドウで、[Tourist_Attractions_Join] を右クリックして、[属性テーブル] を選択します。

    [属性テーブル] オプション

    属性テーブルが開きます。

    開かれた属性テーブル

    テーブルの各行はマップ上の 1 つのフィーチャを表し、各列は情報を含むフィールドです。 このテーブルの最初の行は、48 Pagoda Street にある Chinatown Heritage Centre という名前のフィーチャに対応しています。 Object ID には、各フィーチャを示す一意の ID 番号が含まれています。

    ヒント:

    テーブルのサイズを変更するには、テーブルの上部にあるハンドルをドラッグします。

  11. 必要に応じて、最後の数個の列を表示できるまで、右にスクロールします。

    属性テーブルの最後の 5 つのフィールド

    テーブルには、Name という 2 つのフィールドが含まれています。 最初の Name フィールドは観光名所の名前を示し、2 番目の Name フィールドは最寄りの鉄道駅の名前を示します。 2 番目の Name フィールドは、[空間結合 (Spatial Join)] ツールを実行した後にテーブルに追加されました。

    メモ:

    Type フィールドも、[空間結合 (Spatial Join)] ツールによって追加されました。 最寄り駅が Massive Rapid Transit (MRT)、Light Rail Transit (LRT)、または Circle Line (CCL) システムに含まれているかどうかを示します。 元の [Tourist Attractions] レイヤーの属性テーブルを開いて比較することで、ツールで追加されたフィールドを確認できます。

  12. テーブルを閉じます。

    元の [Tourist Attractions] レイヤーは不要になったため、削除します。

  13. [コンテンツ] ウィンドウで [Tourist Attractions] レイヤーを右クリックして [削除] を選択します。

    [Tourist Attractions] レイヤーの [削除] オプション

    レイヤーが削除されます。 削除したレイヤーの名前と一致するように、新しいレイヤーの名前も変更します。

  14. [Tourist_Attractions_Join] レイヤー名をクリックして選択します。 もう一度クリックして、レイヤー名を編集可能にします。
  15. 名前を「Tourist Attractions」に変更して Enter キーを押します。
    ヒント:

    レイヤー名をダブルクリックし、[レイヤー プロパティ] ウィンドウを開いて、レイヤー名を変更することもできます。 [一般] タブで、名前を変更します。 [OK] をクリックします。

  16. プロジェクトを保存します。

テーブルのエクスポート

観光客が ArcGIS Pro でマップにアクセスするか、ArcGIS Online の対話型 Web マップとしてマップにアクセスした場合、各観光名所に対する最寄り駅を見つけた際と同様の方法で、属性テーブルを開くことができます。 ただし、このマップはパンフレットに印刷されるため、ユーザーはその機能を利用できません。

マップに付随する情報として、旅行代理店はパンフレットの属性テーブルから主要な情報を印刷することを計画しています。 属性テーブルをプレーン テキスト ファイルにエクスポートして、旅行代理店が必要なデータをパンフレットのデザインにコピーできるようにします。

  1. [コンテンツ] ウィンドウの [Tourist Attractions] を右クリックし、[データ] にポインターを合わせて [テーブルのエクスポート] を選択します。

    [テーブルのエクスポート] ダイアログ ボックスが表示されます。 このツールは、レイヤーの属性テーブルを新しいファイル形式に変換します。 [入力テーブル] パラメーターで、すでに [Tourist Attractions] レイヤーが選択されています。

    デフォルトの出力場所は、プロジェクトで作成されたジオデータベース (Singapore Tourism.gdb) です。 ただし、テキスト ファイルはジオデータベースに格納できません。 出力場所を、エクスポートするデータに適した場所に変更します。

  2. [出力場所] で、[参照] ボタンをクリックします。

    [参照] ボタン

  3. [出力場所] ウィンドウで、[フォルダー] を選択し、[Singapore Tourism] を選択します。

    テーブルをエクスポートする出力場所の選択

    メモ:

    出力場所をジオデータベースに変更すると、ツールは正しく実行されません。デフォルトの場所以外を選択してください。

  4. [OK] をクリックします。
  5. [出力名] に「Tourist_Attractions.txt」と入力します (必ず *.txt 拡張子を含めてください)。

    [テーブルのエクスポート (Export Table)] ツールの [出力名] パラメーター

    ヒント:

    また、*.csv 拡張子を使用してテーブルをカンマ区切り値ファイルにエクスポートしたり、*.dBF 拡張子を使用して dBase データベース ファイルにエクスポートしたりすることもできます。

    [空間結合 (Spatial Join)] ツールと同様に、[テーブルのエクスポート (Export Table)] ツールでフィールドを出力テーブルから削除することもできます。 今回の目的に不要な情報を含む Join_Count および TARGET_FID フィールドを削除します。

  6. [フィールド] を展開します。 [フィールド マップ] で、Join_Count フィールドをクリックして選択し、[削除] ボタンをクリックします。 同様の方法で、TARGET_FID フィールドを削除します。
  7. [OK] をクリックします。

    ツールが実行され、テーブルがエクスポートされます (選択した出力場所を確認すると正常にエクスポートされたことを確認できます)。 さらに、エクスポートされたテーブルが [コンテンツ] ウィンドウの [スタンドアロン テーブル] 見出しの下に追加されます。 このテーブルはプロジェクトには不要なため、削除します。

  8. [コンテンツ] ウィンドウで、[Tourist_Attractions.txt] を右クリックし、[削除] を選択します。
  9. [ジオプロセシング] ウィンドウを閉じて、プロジェクトを保存します。

フィーチャのラベル作成

旅行代理店はエクスポートしたテーブルを使用して、属性情報をテキスト情報としてパンフレットに追加できます。 ただし、パンフレットを使用する観光客は、マップ上で各観光地に対応するポイントを識別することができません。

マップを使いやすくするには、観光名所にラベルを付けます。 ラベルは、マップ上に表示されるテキスト情報で、ユーザーはデータに対する理解を深めることができます。

  1. [コンテンツ] ウィンドウで、[Tourist Attractions] レイヤーをクリックして選択します。

    [ラベリング] タブが使用可能になります。 このタブはコンテキスト タブであり、操作中のデータに関連がある場合にのみ表示されます。

  2. リボンの [ラベリング] タブをクリックします。 [レイヤー] グループの [ラベル] ボタンをクリックします。

    [ラベル] ボタン

    レイヤーに対してラベルが有効化されます。 デフォルトでは、各観光名所にその名前のラベルが付きます。 観光名所が非常に多いため、ラベルでマップが雑然としてしまい、マップが読みづらくなります。

    デフォルト ラベル

    マップを読みやすくするために、代わりに固有の ID 番号を使用して観光名所にラベルを付けます。

  3. [ラベル クラス] グループの [フィールド][オブジェクト ID] を選択します (スクロールしないと、適切なオプションが表示されない場合があります)。

    ラベルの [フィールド] オプション

    マップ上のラベルが、文字数の多い名前から文字数の少ない番号に変わります。 番号で各観光名所をすぐに識別できるわけではありませんが、ユーザーが観光名所を識別できるよう、パンフレットにテーブル データが付属した ID を含めることができます。

    ただし、デフォルトのラベルは小さくて濃い色のテキストであるため、濃い色のベースマップ上ではよく見えません。 また、各観光名所に対応する番号が常に明確にわかるように、ラベルが配置されているわけでもありません。 ラベルの表示設定と配置を変更して明確にします。

  4. [テキスト シンボル] グループで、[テキスト シンボルのフォント サイズ][8][テキスト シンボル色][白] に変更します。

    テキスト サイズと色のパラメーター

  5. [ラベルの配置] グループで、[中心点] をクリックします。

    [中心点] ラベルの配置

    マップ上のラベルが更新されます。

    マップ上の改善されたラベル

    これらのラベルは改善されましたが、まだいくつかの小さな問題が残っています。 まず、一部の観光名所でラベルが表示されません。 デフォルトでは、ラベルが非常に近接している場合、重なって表示されるのを防ぐため、ラベルが表示されません。 また、ピン シンボル内のより中央に配置したほうが、ラベルの見栄えがよくなります。 これらの問題を両方とも解決するために変更を加えます。

  6. [ラベルの配置] グループの [ラベル配置プロパティ] ボタンをクリックします。

    [ラベル配置プロパティ] ボタン

    [ラベル クラス - Tourist Attractions] ウィンドウが表示されます。 このウィンドウには、高度なラベリング オプションが用意されています。

  7. [競合解決] タブをクリックします。

    [競合解決] タブ

  8. [未配置ラベル] セクションを展開し、[ラベルを削除しない (オーバーラップを許可)] をオンにします。

    [ラベルを削除しない] オプション

    これで、ラベルの重複が原因でマップからラベルが削除されなくなりました。 次に、ラベルの位置を調整して、各ピン シンボル内のより中央にラベルが配置されるようにします。

  9. [シンボル] をクリックします。 [一般] タブの [位置] セクションを展開し、[オフセット Y][2] pt に変更します。

    [オフセット Y] パラメーターを 2 pt に変更

  10. [適用] をクリックします。

    ラベルが少し上に移動し、ピン シンボルの中央に配置されるようになります。

    完成したマップ上のラベル

    一部のラベルは他のピン シンボルとわずかに重なっていますが、すべてのラベルが一般的に読みやすくなっています。 パンフレットに印刷されるテーブル データと組み合わせることで、観光客はマップ上のあらゆる観光名所を識別できるようになります。

  11. [ラベル クラス - Tourist Attractions] ウィンドウを閉じて、プロジェクトを保存します。
    メモ:

    また、鉄道駅にラベルが付いていたほうが、ユーザーが使いやすくなります。 このレッスンではラベルを付けませんが、独自のラベルを作成してみてください。 マップ上でラベルを読みやすくするには、どのような表示設定にする必要があるでしょうか?

    続行する前に、マップの名前をわかりやすいものに変更します。 デフォルト名は [マップ] です。

  12. [コンテンツ] ウィンドウで、[マップ] をダブルクリックします。

    [コンテンツ] ウィンドウの [マップ]

    [マップ プロパティ] ウィンドウが表示されます。

  13. [一般] タブの [名前] で「Central Business District」と入力します。

    [名前] パラメーター

  14. [OK] をクリックします。

    マップ名が変更されました。

レイアウトの作成

これでマップが完成しました。 最後に、マップをパンフレットに印刷できる形式にエクスポートします。 印刷用にマップを準備するには、ページ レイアウトを作成します。 レイアウトは、仮想ページ上に整理されたマップ エレメントのコレクションです。 レイアウトは、印刷時のマップの外観を定義します。

レイアウトは最初から設計できますが、ArcGIS Pro にはレイアウト テンプレートも複数含まれています。 テンプレートを使用して、いくつかのレイアウト エレメントを変更します。

  1. リボンの [挿入] タブをクリックし、[レイアウトのインポート] ボタンをクリックします。

    [レイアウトのインポート] ボタン

    使用可能なテンプレートのリストが表示されます。 マップを強調したい場合は、シンプルなレイアウトが最適です。

  2. [タイトル バー レター横] レイアウトを選択します。

    [タイトル バー レター横] レイアウト

    メモ:

    使用可能なテンプレートのリストが表示されない場合は、このレッスンで使用されるレイアウト テンプレートをダウンロードし、インポートできます。

    レイアウトが新しいビューとして開きます (ビューの上にあるタブを使用して、マップ ビューとレイアウト ビューを切り替えることができます)。

    デフォルトのレイアウト

    このレイアウトには、タイトル、凡例、および縮尺記号が含まれています。 すべてのレイアウト エレメントが [コンテンツ] ウィンドウにリストされます。 また、リボンにはレイアウトの操作に関連するタブが表示されるようになります。

    デフォルトでは、選択したテンプレートにオハイオ州コロンバスのマップが含まれています。 レイアウトのマップ フレームを更新して、シンガポールのマップを使用します。

  3. [コンテンツ] ウィンドウで、[マップ フレーム] をダブルクリックします。

    [コンテンツ] ウィンドウの [マップ フレーム]

    [マップ フレームの書式設定] ウィンドウが表示されます。

  4. [オプション][マップ フレーム] で、[Central Business District] を選択します。

    [マップ フレーム] オプションで選択されたマップ

    レイアウト内のマップが変更されます。 ただし、マップは世界全体に拡大表示され、シンガポールは表示されません。 マップ範囲とレイアウト範囲は独立しています。

    以前に作成したブックマークを使用して、目的のマップ範囲に移動します。

  5. リボンの [レイアウト] タブをクリックします。 [マップ] グループの [ブックマーク] をクリックし、[Central Business District] ブックマークを選択します。

    [Central Business District] ブックマーク

    マップ範囲が対象地域に更新されます。

    ブックマーク範囲を含むレイアウト

    ヒント:

    レイアウトでマップを別の範囲に画面移動または拡大表示するには、[マップ] グループの [アクティブ化] をクリックします。 アクティブ化すると、通常どおりにマップを操作できます。 範囲を変更したら、[レイアウト] タブをクリックし、[閉じる] をクリックします。

    次に、レイアウトにタイトルを付けます。

  6. [コンテンツ] ウィンドウで、[マップ タイトル] をダブルクリックします。

    [テキストの書式設定] ウィンドウが表示されます。

  7. [オプション][テキスト] で、既存のテキストを削除し、「Downtown Singapore」と入力します。 テキスト ボックスの外側をクリックします。

    マップ タイトルのテキスト

    変更内容がレイアウトに適用されます。

    レイアウト内の新しいタイトル

    また、マップ上のすべてのシンボルの説明が表示されるよう、凡例を調整します。 デフォルトの凡例の背景は白色であるため、白色の線路シンボルがよく見えません。 背景を削除して、凡例の位置を調整します。

  8. [コンテンツ] ウィンドウで、[凡例] をダブルクリックします。

    [凡例の書式設定] ウィンドウが表示されます。 まず、凡例テキストを白色に変更し、凡例の背景を削除したときに濃い色のベースマップ上で表示されるようにします。

  9. [テキスト シンボル] をクリックします。 [表示設定] を展開して、[色][白] に変更します。

    [色] を [白] に変更

  10. [適用] をクリックします。

    最後に、凡例の背景を変更します。

  11. ウィンドウの上部で、[凡例] ドロップダウン矢印をクリックして、[背景] を選択します。

    [背景] オプション

  12. [色][色なし] を選択します。

    [色なし] オプション

  13. [適用] をクリックします。

    凡例の背景が削除されます。

  14. レイアウト ビューで、凡例をドラッグして、マップの右下隅に表示されるようにします。 完了したら、マップの外側のレイアウト ビューの任意の場所をクリックして、凡例の選択を解除します。

    ほぼ完成したレイアウト

    縮尺記号はマップの左下隅に表示されていますが、よく見えません。 次に、縮尺記号の表示を更新して、よく見えるようにします。

  15. 縮尺記号をクリックすると、[縮尺記号の書式設定] が表示されます。
  16. [縮尺記号の書式設定] ウィンドウで [縮尺記号] を選択し、[表示] ボタンをクリックします。
  17. [背景] で、[シンボル] の色を [グレー 30%] に変更します。 [X ギャップ]に「0.1」、[Y ギャップ]に「0.1」と入力します。

    縮尺記号の外観の書式設定

    縮尺が更新され、タイトルと同じグレーの背景になりました。

    タイトルの背景と同じグレーに更新された縮尺記号の書式設定

  18. 縮尺をクリックして、1 マイルが見えるまで右に伸ばします。

    縮尺記号を伸ばす

  19. 縮尺記号をクリックしてドラッグし、レイアウトおよびタイトルに揃えて配置します。

    完成したマップ

    レイアウトが完成しました。 旅行代理店はこのマップの画像をパンフレットの内側に印刷します。 パンフレットの裏側には、エクスポートしたテーブルに基づく観光名所のリストが含まれています。 最後に、このパンフレットは、観光客が各観光名所に対する最寄りの鉄道駅を見つけるのに役立ちます。

  20. プロジェクトを保存します。

    次に、レイアウトを画像ファイルにエクスポートします。

  21. リボンの [共有] タブをクリックします。 [出力] グループで、[レイアウトのエクスポート] をクリックします。

    [共有] タブの [レイアウト] ボタン

    [エクスポート] ウィンドウが表示されます。

  22. [ファイル タイプ] で、画像ファイル形式を選択します。 [名前] で、希望の出力場所を参照し、ファイル名を「Downtown Singapore」に変更します。
  23. [エクスポート] をクリックします。

    レイアウトが選択した場所にエクスポートされます。

このレッスンでは、シンガポールの中心街で人気のある観光名所を示すマップを作成しました。 プロジェクトを作成し、対象地域に移動して、データを追加しました。 マップの外観を変更し、観光名所と鉄道駅の間の距離を解析しました。 次に、レイアウトを作成し、マップを画像ファイルにエクスポートしました。

このレッスンでは、ArcGIS Pro の概要として、マップ作成や解析などのトピックの基礎のみを紹介しました。 ArcGIS Pro の機能の詳細については、次の Learn ArcGIS レッスンをご参照ください。

その他のレッスンについては、「Learn ArcGIS Lesson ギャラリー」をご参照ください。