Prise en main d'ArcGIS Pro

Créer un projet

Dans ArcGIS Pro, les cartes et les données sont organisées à l’intérieur d’un projet. Avant de commencer la carte, vous allez créer un projet.

  1. Démarrez ArcGIS Pro. Si le système vous y invite, connectez-vous via votre compte ArcGIS sous licence.
    Remarque :

    Si vous ne possédez pas de compte ArcGIS Pro ou ArcGIS, vous pouvez vous inscrire à une version d’évaluation gratuite d’ArcGIS.

    Vous disposez de différents modèles pour créer des projets. Pour créer une carte, vous allez utiliser le modèle Map (Carte).

  2. Sous New (Nouveau), cliquez sur Map (Carte).

    Modèle de projet Map (Carte)

    La boîte de dialogue Create a New Project (Créer un projet) s’affiche. Par défaut, les projets sont enregistrés dans un nouveau dossier. Pour les enregistrer dans un dossier existant, décochez la case Create a new folder for this project (Créer un dossier pour ce projet) et accédez au dossier.

  3. Dans Name (Nom), supprimez le texte et saisissez Singapore Tourism (Tourisme à Singapour). Laissez la case Location (Emplacement) tel que et assurez-vous que Create a new folder for this project (Créer un dossier pour ce projet) est cochée.

    Fenêtre Create a New Project (Créer un projet) avec des paramètres corrects

    Remarque :

    L’emplacement par défaut peut être différent de celui de l’image fourni en exemple. En principe, les projets sont enregistrés dans le dossier ArcGIS créé lorsque vous avez installé ArcGIS Pro.

  4. Cliquez sur OK.

    Le projet est créé avec une carte du monde. Dans ArcGIS Pro, les cartes sont constituées de couches de données géographiques. Pour le moment, la seule couche est le fond de carte, qui fournit des informations de référence comme les limites nationales et les plans d’eau.

    Remarque :

    Selon les paramètres définis pour votre organisation ArcGIS, le fond de carte et l’étendue par défaut de la carte peuvent être différents.

    Nouveau projet présentant une carte du monde

    Des fenêtres se trouvent de part et d’autre de la carte. Par défaut, les fenêtres Contents (Contenu) et Catalog (Catalogue) sont ouvertes ; d’autres fenêtres peuvent être ouvertes si vous avez utilisé ArcGIS Pro auparavant. La fenêtre Contents (Contenu) spécifie les couches de la carte et la fenêtre Catalog (Catalogue) répertorie tous les fichiers associés au projet.

    Le ruban figure sur la partie supérieure de la carte. Il contient plusieurs onglets qui comportent chacun plusieurs boutons. Ces boutons peuvent avoir une incidence sur la navigation cartographique, permettent de modifier l’apparence de la carte ou d’ouvrir des fenêtres offrant des fonctions supplémentaires.

    Astuce :

    Pour réorganiser les fenêtres, il suffit de les faire glisser au niveau de leur titre et de les ancrer à un nouvel emplacement. Vous pouvez également redimensionner les fenêtres en faisant glisser leurs coins. Pour revenir à la disposition des fenêtres par défaut, cliquez sur l’onglet View (Vue). Dans le groupe Windows (Fenêtres), cliquez sur Reset Panes (Réinitialiser les fenêtres) et sélectionnez Reset Panes for Mapping (Réinitialiser les fenêtres pour la cartographie). Durant cette leçon, n’hésitez pas à agencer les fenêtres et les vues à votre guise.

Accéder à Singapour

Votre zone d’intérêt étant la cité-État insulaire de Singapour, vous allez naviguer jusqu’à elle.

  1. Sur le ruban, cliquez sur l’onglet Map (Carte). Dans le groupe Inquiry (Requête), cliquez sur le bouton Locate (Localiser).

    Bouton Locate (Localiser) de l’onglet Map (Carte)

    La fenêtre Locate (Localiser) s’ouvre. Dans cette fenêtre, vous pouvez rechercher des emplacements géographiques et y accéder. Il peut s’agir de pays, de villes ou d’adresses.

  2. Dans la barre de recherche de la fenêtre Locate (Localiser), saisissez Singapore (Singapour) et appuyez sur la touche Entrée.

    Recherche de la ville de Singapour dans la fenêtre Locate (Localiser)

    La carte accède automatiquement au premier résultat : l’État de Singapour (Les emplacements correspondant aux résultats de recherche s’affichent sur la carte sous forme de cercles.)

    Carte par défaut de Singapour

    Singapour, l’une des plus petites nations au monde, accueille 5,6 millions de personnes et compte quatre langues officielles. La ville moderne abrite de nombreux lieux d’intérêt historiques et culturels, des salles de spectacle et des sites écologiques. C’est l’une des villes les plus visitées au monde et le tourisme est un secteur d’activités essentiel.

  3. Fermez le volet Locate (Localiser).
  4. Au-dessus du ruban, dans la barre d’outils Accès rapide, cliquez sur le bouton Save (Enregistrer).

    Bouton Enregistrer

Ajouter

Le fond de carte présente Singapour et certaines informations géographiques de base telles que les routes et les lacs. Toutefois, il ne montre pas les destinations touristiques, ni les gares. Pour créer une carte qui soit utile aux touristes, vous allez ajouter ces données à la carte.

  1. Sur le ruban, sous l’onglet Map (Carte), dans le groupe Layer (Couche), cliquez sur le bouton Add Data (Ajouter des données).

    Bouton Ajouter des données

    La fenêtre Add Data (Ajouter des données) s’affiche. Vous pouvez ajouter des données à partir de différentes sources comme le dossier du projet (Project [Projet]), le site Web de votre compte ArcGIS (Portal [Portail]) ou de votre ordinateur (Computer [Ordinateur]).

    La plupart des comptes ArcGIS, notamment les comptes d’évaluation, utilisent le site Web de ArcGIS Online en guise de portail. ArcGIS Online est une plateforme de cartographie SIG hébergeant une grande quantité de données spatiales. Vous allez ajouter les données nécessaires à partir de cette plateforme.

  2. Dans la fenêtre Add Data (Ajouter des données), sous Portal (Portail), cliquez sur ArcGIS Online.

    Option ArcGIS Online dans la fenêtre Ajouter des données

    Cette option donne accès à toutes les données hébergées sur ArcGIS Online. Les données que vous allez utiliser appartiennent au compte d’administration Learn ArcGIS. Pour localiser les données, vous allez les rechercher en saisissant leur nom et leur propriétaire.

  3. Dans la zone de recherche, saisissez Singapore owner:Learn_ArcGIS et appuyez sur la touche Entrée.

    La recherche renvoie trois résultats : Singapore Rail Lines (Voies ferrées de Singapour), Singapore Rail Stations (Gares de Singapour) et Singapore Tourist Attractions (Attractions touristiques de Singapour).

    Résultats de la recherche pour Singapour

    Remarque :

    Certains comptes ArcGIS utilisent un site Web ArcGIS Enterprise en tant que portail. Si votre compte utilise ArcGIS Enterprise, vous n’êtes pas en mesure de rechercher dans le contenu ArcGIS Online. Pour ajouter les données, accédez à l’élément Singapore_Data_gdb sur ArcGIS Online et cliquez sur Download (Télécharger). Extrayez le dossier téléchargé vers un emplacement sur l’ordinateur. Dans la fenêtre Add Data (Ajouter des données), accédez à l’emplacement du dossier téléchargé. (Vous devrez peut-être cliquer sur le bouton Refresh (Actualiser) dans la fenêtre Add Data (Ajouter des données) pour voir le dossier.)

  4. En appuyant sur la touche Ctrl, cliquez sur les couches Singapore Rail Lines, Singapore Rail Stations et Singapore Tourist Attractions pour les sélectionner.
  5. Cliquez sur OK.

    Les trois couches de données sont ajoutées à la carte.

    Remarque :

    Si vous utilisez ArcGIS Enterprise et avez téléchargé les données au lieu de les ajouter à partir de ArcGIS Online, vos couches peuvent être différentes des exemples illustrés.

    Singapour avec les données ajoutées à la carte

    Les couches sont également répertoriées dans la fenêtre Contents (Contenu).

    Volet Contenu

    Les points verts désignent des attractions touristiques, les lignes blanches des voies ferrées et les polygones noirs des gares. Les couches comportant des points, des lignes ou des polygones sont appelées des couches d’entités.

    La majeure partie des attractions touristiques se trouvent au centre et au sud de l’île. Ce secteur constituant le centre-ville de Singapour, est connu sous le nom de Central Business District. L’agence de tourisme souhaite que sa brochure couvre cette zone, aussi vous allez effectuer un zoom avant sur celle-ci.

  6. Sur la carte, pointez sur le centre-ville de Singapour et actionnez la molette de la souris pour appliquer un zoom avant. Zoomez jusqu’à ce que le centre-ville occupe quasiment tout l’espace de la carte.
    Astuce :

    Une autre manière de zoomer sur un secteur en particulier consiste à maintenir la touche Maj enfoncée et à tracer un cadre autour de la carte qui vous intéresse. Vous pouvez également cliquer avec le bouton droit sur la carte et déplacer la souris pour effectuer un zoom avant ou un zoom arrière. Utilisez la méthode de navigation que vous préférez.

    Zoom sur le centre-ville de Singapour

  7. Si nécessaire, faites glisser la carte pour la déplacer jusqu’à ce que le Central Business District se trouve au centre de la carte.

    À ce degré d’agrandissement, les gares ferroviaires sont très détaillées. Selon la taille de votre moniteur, vous pouvez voir davantage d’informations sur les rues et les bâtiments.

    L’étendue de la carte sera celle que vous utiliserez pour la suite du projet. Il sera pratique de revenir rapidement à cette étendue, c’est la raison pour laquelle vous allez créer un raccourci de navigation appelé géosignet.

  8. Sur le ruban, sous l’onglet Map (Carte), dans le groupe Navigate (Naviguer), cliquez sur Bookmarks (Géosignets) et sélectionnez New Bookmark (Nouveau géosignet).

    Option New Bookmark (Nouveau géosignet)

  9. Dans la fenêtre Create Bookmark (Créer un géosignet), dans Name (Nom), saisissez Central Business District.

    Fenêtre Create Bookmark (Créer un géosignet)

  10. Cliquez sur OK.

    Le géosignet est créé. Vous utiliserez ce géosignet à un stade ultérieur de la présente leçon.

  11. Enregistrez le projet.

Définir le style de la carte

En parcourant la carte, vous avez peut-être remarqué que certaines couches de données sont difficiles à lire. Les voies ferrées, par exemple, de couleur blanches se confondent souvent avec d’autres informations de la carte.

Les informations sur les rues, les plans d’eau et les bâtiments sont issues du fond de carte. Un fond de carte procure des informations de référence qui permettent de contextualiser vos données. ArcGIS Pro comprend plusieurs couches de fond de carte, la carte par défaut étant World Topographic Map (Carte topographique mondiale). Notez que, selon les paramètres définis pour votre organisation ArcGIS, le fond de carte par défaut peut être différent.

Vous allez changer de fond de carte pour utiliser un fond qui mette en valeur vos données. Un fond de carte foncé fera ressortir les lignes blanches des voies ferrées.

  1. Sous l’onglet Map (Carte), dans le groupe Layer (Couche), cliquez sur Basemap (Fond de carte) et sélectionnez Dark Gray Canvas (Nuances de gris foncé).

    Fond de carte Nuances de gris foncé

    Le fond de carte change.

    Centre-ville de Singapour sur le fond de carte Dark Gray Canvas (Nuances de gris foncé)

    Les voies ferrées se détachent davantage sur ce fond de carte. Contrairement au fond de carte Topographic (Topographie), ce fond de carte contient deux couches. L’une de ces couches, World Dark Gray Reference, contient du texte qui permet de libeller ces zones. Ce texte est superflu au vu de la finalité de votre carte et peut nuire à la visibilité d’autres entités, vous allez donc le désactiver.

  2. Dans la fenêtre Contents (Contenu), décochez la case World Dark Gray Reference.

    Couche World Dark Gray Reference décochée

    La couche n’apparaît plus sur la carte. (Pour que les informations de référence réapparaissent, cochez à nouveau la case.)

    Les attractions touristiques s’affichent sur la carte sous forme de points de petite taille qu’il est difficile de distinguer. Étant donné que les attractions répondent à l’objectif premier de la carte, vous allez changer leur apparence.

  3. Dans la fenêtre Contents (Contenu), cliquez sur le symbole de la couche Tourist Attractions.

    Symbole de la couche Tourist Attractions

    La fenêtre Symbologie apparaît. La symbologie définit l’apparence d’une couche. Vous pouvez la choisir dans la bibliothèque de symboles par défaut ou personnaliser un symbole.

  4. Dans la fenêtre Symbology - Tourist Attractions (Symbologie - Attractions touristiques), sous l’onglet Gallery (Bibliothèque), recherchez Tear Pin (Épingle en forme de larme). Dans la liste des résultats, cliquez sur le symbole Tear Pin 1 (40%) (Épingle en forme de larme 1 [40 %]).

    Symbole Tear Pin 1 (Épingle en forme de larme 1)

    Les symboles des attractions touristiques changent conformément au symbole choisi. Le symbole d’épingle en forme de larme attire l’attention sur les lieux d’intérêt que sont les attractions touristiques. Le taux de 40 % indique que le symbole est 40 pour cent transparent, ce qui est utile au cas où les symboles masquent des parties de la carte.

    Vous pouvez faire en sorte que les symboles tranchent davantage en ajoutant un contour et en augmentant la taille du symbole.

  5. Cliquez sur Propriétés.

    Option Properties (Propriétés)

  6. Cliquez sur l’onglet Couches.

    Onglet Couches

  7. Pour Outline color (Couleur du contour), choisissez Arctic White (Blanc arctique).

    Couleur de contour Blanc arctique

    Astuce :

    Pour afficher le nom d’une couleur dans le sélecteur de couleurs, placez le pointeur dessus.

  8. Redéfinissez le champ Outline width (Largeur du contour) sur 0.7 pt (0,7 pt). Redéfinissez le champ Size (Taille) sur 22 pt.

    Paramètres de symbole

  9. Au bas de la fenêtre Symbologie, cliquez sur Appliquer.

    La nouvelle symbologie est appliquée à la carte.

    Le symbole des attractions touristiques change sur la carte

    Les attractions touristiques sont maintenant parfaitement visibles et ne gênent pas les autres entités cartographiques.

    Remarque :

    Si votre compte ArcGIS utilise un portail ArcGIS Enterprise et que vous avez téléchargé les données de la couche, les voies ferrées et les gares peuvent afficher d’autres symboles que ceux illustrés dans les images fournies à titre d’exemple. Pour changer le symbole représentant les voies ferrées selon les images, cliquez sur son symbole pour ouvrir la fenêtre Symbology (Symbologie). Sous l’onglet Properties (Propriétés), onglet Layers (Couches), définissez le champ Color (Couleur) sur Arctic White (Blanc arctique) et cliquez sur Apply (Appliquer). Pour changer le symbole représentant les voies ferrées, ouvrez sa fenêtre Symbology (Symbologie). Sous l’onglet Properties (Propriétés), onglet Symbol (Symbole), définissez Color (Couleur) sur Gray 80% (Gris 80 %), Outline color (Couleur du contour) sur Black (Noir) et Outline width (Largeur du contour) sur 1.2 pt (1,2 pt). Cliquez sur Apply (Appliquer).

  10. Fermez la fenêtre Symbology (Symbologie) et enregistrez le projet.

Déterminer la proximité

L’agence de tourisme souhaite que sa brochure indique la gare la plus proche de chaque attraction touristique. Mesurer la distance séparant chaque attraction d’une gare, une par une, prendrait beaucoup de temps ; vous allez donc automatiser le processus en exécutant un outil de géotraitement.

Un outil de géotraitement applique une opération sur un jeu de données. Dans ArcGIS Pro, il existe une centaine d’outils de géotraitement couvrant un large éventail d’opérations diverses. Vous allez utiliser l’outil Jointure spatiale pour fusionner les informations de deux classes d’entités d’après leur relation spatiale. En utilisant cet outil, vous déterminerez la gare la plus proche pour chaque attraction touristique.

  1. Sur le ruban, cliquez sur l’onglet Analysis (Analyse). Dans le groupe Geoprocessing (Géotraitement), cliquez sur Tools (Outils).

    Bouton Outils

    La fenêtre Géotraitement s'affiche.

  2. Dans la fenêtre Geoprocessing (Géotraitement), dans la barre de recherche, saisissez Spatial Join (Jointure spatiale). Dans la liste des résultats, cliquez sur l’outil Jointure spatiale.

    Outil Jointure spatiale dans les résultats de recherche

    Astuce :

    Il est également possible d’accéder à l’outil Jointure spatiale par la bibliothèque Analysis (Analyse). Sous l’onglet Analysis (Analyse), dans le groupe Tools (Outils), développez la bibliothèque Analysis (Analyse). Dans le groupe Overlay Data (Données superposées), cliquez sur Spatial Join (Jointure spatiale).

    La boîte de dialogue Spatial Join (Jointure spatiale) s’affiche. La plupart des outils de géotraitement ont des paramètres qu’il est possible de modifier pour changer le résultat de l’outil. Pour cet outil, vous allez d’abord choisir les couches d’entités à joindre.

  3. Pour Target Features (Entités cible), sélectionnez Tourist Attractions (Attractions touristiques). Pour Join Features (Entités jointes), sélectionnez Rail Stations (Gares).

    Paramètres Target Features (Entités cible) et Join Features (Entités jointes) de l’outil Jointure spatiale

    Astuce :

    Pour en savoir plus sur l’un des paramètres, pointez sur le paramètre concerné. Puis, placez le pointeur sur le bouton d’information qui apparaît. Une info-bulle s’affiche avec la description du paramètre.

    Vous allez maintenant définir le paramètre Output Feature Class (Classe d’entités en sortie). De nombreux outils de géotraitement créent une couche en sortie sans altérer les couches d’origine.

    Par défaut, les couches en sortie sont enregistrées dans un dossier conçu pour héberger les données géographiques appelé géodatabase. Celui-ci a été constitué à la création du projet. Vous allez modifier le nom en sortie, sans changer l’emplacement en sortie.

  4. Pour Output Feature Class (Classe d’entités en sortie), cliquez sur la zone de texte. Remplacez le texte TouristAttractions_SpatialJo par Tourist_Attractions_Join, sans toucher le reste du chemin.

    Paramètre Output Feature Class (Classe d’entités en sortie) de l’outil Jointure spatiale

    Vous allez laisser l’opération Join one to one (Joindre un vers un) telle quelle. Cette opération assure que chaque attraction touristique est jointe à une seule gare, ce qui correspond à l’objectif recherché puisque vous désirez seulement connaître la gare la plus proche.

    Vous allez maintenant définir le paramètre Match Option (Option de correspondance). Ce paramètre détermine la relation spatiale entre les entités à joindre.

  5. Pour Match Option (Option de correspondance), choisissez Closest (Le plus proche).
  6. En dessous des paramètres visibles, développez Fields (Champs).

    Le paramètre Field Map (Appariement des champs) détermine quels attributs de chaque classe d’entités en entrée sont conservés dans la classe d’entités en sortie. Vous en apprendrez plus sur les attributs ultérieurement. Pour le moment, contentez-vous de supprimer les champs Shape__Area et Shape__Length, car la taille et la forme des entités sur la carte ne présentent pas d’intérêt.

  7. Dans la colonne Output Fields (Champs en sortie), cliquez sur Shape__Area, puis cliquez sur le bouton Remove (Supprimer).

    Bouton de suppression du champ Shape__Area

  8. Supprimez le champ Shape__Length.

    Vous avez défini l’ensemble des paramètres dont vous avez besoin. Selon les paramètres que vous avez choisis, l’outil lance une opération combinant les informations sur chaque attraction touristique et les informations de sa gare la plus proche.

  9. Cliquez sur Run (Exécuter).

    L'outil s'exécute. Une fois l’opération terminée, une nouvelle couche, Tourist_Attractions_Join, est ajoutée à la carte et à la fenêtre Contents (Contenu). La nouvelle couche semble similaire à la couche Tourist Attractions d’origine ; toutefois, l’outil de géotraitement a changé les attributs de la couche.

    Les attributs sont les informations associées à chaque entité dans une couche d’entités. Ils peuvent inclure le nom de l’entité, l’adresse, la surface ou d’autres types d’informations. Vous pouvez consulter les attributs d’une couche en ouvrant sa table attributaire.

  10. Dans la fenêtre Contents (Contenu), cliquez avec le bouton droit sur Tourist_Attractions_Join et sélectionnez Attribute Table (Table attributaire).

    Option Table attributaire

    La table attributaire s'ouvre.

    Table attributaire ouverte

    Chaque ligne de la table représente une entité de la carte et chaque colonne est un champ d’information. Dans cette table, la première ligne correspond à une entité nommée Chinatown Heritage Centre qui se trouve 48 Pagoda Street. Le champ Object ID contient un numéro d’identification unique pour chaque entité.

    Astuce :

    vous pouvez redimensionner et repositionner les tables attributaires.

  11. Si nécessaire, faites défiler l’affichage vers la droite pour voir les derniers champs.

    Les cinq derniers champs de la table attributaire

    La table possède deux champs intitulés Name. Le premier champ Name désigne le nom de l’attraction touristique tandis que le deuxième champ Name désigne le nom de la gare la plus proche. Le deuxième champ Name a été ajouté à la table une fois l’outil Jointure spatiale exécuté.

    Remarque :

    Le champ Type a également été ajouté par l’outil Jointure spatiale. Il indique si la gare la plus proche faire partie du réseau MRT (Massive Rapid Transit) ou LRT (Light Rail Transit) ou encore de la Ligne circulaire (CCL). Vous pouvez déterminer les champs que l’outil a ajoutés en ouvrant la table attributaire pour la couche d’origine Tourist Attractions et en l’examinant.

  12. Fermez la table.

    Comme vous n’avez plus besoin de la couche d’origine Tourist Attractions, vous allez la supprimer.

  13. Dans la fenêtre Contents (Contenu), cliquez avec le bouton droit sur la couche Tourist Attractions et choisissez Remove (Supprimer).

    Option Remove (Supprimer) de la couche Tourist Attractions

    La couche est alors supprimée. Vous allez également renommer la nouvelle couche de sorte que son nom corresponde à celui de la couche supprimée.

  14. Cliquez sur le nom de la couche Tourist_Attractions_Join pour la sélectionner. Cliquez dessus une nouvelle fois pour que le nom de la couche soit modifiable.
  15. Remplacez le nom par Tourist Attractions et appuyez sur la touche Entrée.
    Astuce :

    Il est également possible de changer le nom de la couche en double-cliquant dessus pour ouvrir la fenêtre Layer Properties (Propriétés de la couche). Sous l’onglet General (Général), modifiez le nom. Cliquez sur OK.

  16. Enregistrez le projet.

Exporter une table

Si les touristes avaient accès à votre carte dans ArcGIS Pro ou sous forme d’une carte interactive dans ArcGIS Online, ils pourraient ouvrir la table attributaire comme vous l’aviez fait lors de la détermination de la gare la plus proche de chaque attraction. Néanmoins, cette carte sera imprimée dans une brochure, aussi les utilisateurs n’en auront pas la possibilité.

Pour accompagner la carte, l’agence de tourisme prévoit d’imprimer des informations essentielles à partir de la table attributaire dans la brochure. Vous allez exporter la table attributaire vers un fichier de texte brut de sorte que l’agence puisse copier les données nécessaires dans la maquette de la brochure.

  1. Dans la fenêtre Contents (Contenu), cliquez avec le bouton droit sur Tourist Attractions, pointez le curseur sur Data (Données), puis choisissez Export Table (Exporter la table).

    La boîte de dialogue Export Table (Exporter la table) s’affiche. Cet outil convertit la table attributaire d’une couche dans un nouveau format de fichier. La couche Tourist Attractions est déjà sélectionnée comme valeur du paramètre Input Rows (Lignes en entrée).

    L’emplacement en sortie est par défaut la géodatabase qui a été créée avec le projet, Singapore Tourism.gdb. Un fichier de texte ne peut toutefois pas être stocké dans une géodatabase. Vous allez remplacer l’emplacement en sortie par un emplacement adapté aux données que vous exportez.

  2. Pour Output Location (Emplacement en sortie), cliquez sur le bouton Browse (Parcourir).

    Bouton de navigation

  3. Dans la fenêtre Output Location (Emplacement en sortie), choisissez un emplacement facile à retenir, comme votre dossier Documents. Cliquez sur OK.
    Remarque :

    Si vous changez l’emplacement en sortie pour une géodatabase, l’outil ne s’exécutera pas correctement ; choisissez un emplacement autre que l’emplacement par défaut.

  4. Dans Output Name (Nom en sortie), saisissez Tourist_Attractions.txt (n’oubliez pas d’inclure l’extension .txt).

    Paramètre Nom en sortie de l’outil Exporter la table

    Astuce :

    Vous pouvez également exporter la table sous forme d’un fichier de valeurs séparées par des virgules à l’aide de l’extension .csv ou d’un fichier de base de données dBase à l’aide de l’extension .dbf.

    Tout comme l’outil Spatial Join (Jointure spatiale), l’outil Export Table (Exporter la table) offre la possibilité de supprimer des champs de la table en sortie. Vous allez supprimer les champs Join_Count et TARGET_FID qui ne fournissent pas d’informations utiles dans le cadre de cet exercice.

  5. Développez Fields (Champs). Dans Field Map (Appariement des champs), cliquez sur le champ Join_Count pour le sélectionner, puis cliquez sur le bouton Remove (Supprimer). Supprimez le champ TARGET_FID de la même manière.
  6. Cliquez sur OK.

    L’outil s’exécute et la table est exportée. (Vous pouvez vérifier que l’exportation a réussi en examinant l’emplacement en sortie que vous avez choisi). Par ailleurs, la table exportée est ajoutée à la fenêtre Contents (Contenu) sous l’intitulé Standalone Tables (Tables autonomes). Comme vous n’avez plus besoin de la table dans le projet, vous allez la supprimer.

  7. Dans la fenêtre Contents (Contenu), cliquez avec le bouton droit sur Tourist_Attractions.txt, puis sélectionnez Remove (Supprimer).
  8. Fermez la fenêtre Geoprocessing (Géotraitement) et enregistrez le projet.

Étiqueter les entités

Avec la table exportée, l’agence de tourisme peut ajouter des informations attributaires dans la brochure sous forme d’informations textuelles. Les touristes qui utilisent la brochure ne sont pas en mesure de relier tels points sur la carte à tels sites touristiques.

Pour que la carte soit plus utile, vous allez étiqueter les attractions touristiques. Les étiquettes sont des informations textuelles qui apparaissent sur une carte pour aider les utilisateurs à comprendre les données.

  1. Dans la fenêtre Contents (Contenu), cliquez sur la couche Tourist Attractions pour la sélectionner.

    L’onglet Labeling (Étiquetage) est accessible. Cet onglet est un onglet contextuel, ce qui signifie qu’il ne s’affiche que s’il est pertinent pour les données que vous utilisez.

  2. Dans le ruban, cliquez sur l’onglet Étiquetage. Dans le groupe Layer (Couche), cliquez sur le bouton Label (Étiquette).

    Bouton Étiquette

    Les étiquettes sont activées pour la couche. Par défaut, chaque attraction touristique est étiquetée par son nom. Cependant, du fait du très grand nombre d’attractions, les étiquettes encombrent la carte et sont difficiles à lire.

    Étiquettes par défaut

    Pour faciliter la lecture de la carte, vous allez étiqueter les attractions à l’aide de leur numéro d’identification.

  3. Dans le groupe Label Class (Classe d’étiquettes), pour Field (Champ), sélectionnez Object ID (ID d’objet). (Il se peut que vous deviez faire défiler l’écran pour voir l’option.)

    Options Field (Champ) des étiquettes

    Au lieu d’afficher des noms longs, les étiquettes présentent maintenant des numéros plus courts. Bien que les numéros ne désignent pas directement chaque attraction, la brochure inclut les identifiants avec les données de table pour aider les utilisateurs à les retrouver.

    Les étiquettes présentent un texte noir en petits caractères qui se distingue mal sur le fond de carte sombre. De plus, la position des étiquettes ne permet pas toujours de déterminer avec certitude le numéro qui désigne l’attraction. Vous allez modifier l’apparence et la position des étiquettes pour remédier à cela.

  4. Dans le groupe Text Symbol (Symbole textuel), définissez Text Symbol Font Size (Taille de police du symbole textuel) sur 8 et Text Symbol Color (Couleur de symbole textuel) sur Arctic White (Blanc arctique).

    Paramètres de taille et couleur du texte

  5. Dans le groupe Label Placement (Placement des étiquettes), cliquez sur Centered Point (Point centré).

    Placement des étiquettes de type point centré

    Les étiquettes sont mises à jour sur la carte.

    Étiquettes améliorées sur la carte

    L’affichage des étiquettes a été amélioré, mais il reste encore quelques petits problèmes à résoudre. Tout d’abord, en ce qui concerne les attractions touristiques, aucune étiquette ne s’affiche. Par défaut, les étiquettes ne s’affichent pas si elles sont trop proches les unes des autres pour éviter toute superposition. Par ailleurs, les étiquettes seraient plus élégantes si les numéros se trouvaient plus au centre du symbole d’épingle. Vous allez apporter des modifications pour remédier à ces problèmes.

  6. Dans le groupe Label Placement (Placement des étiquettes), cliquez sur le bouton Label Placement Properties (Propriétés de placement des étiquettes).

    Bouton Label Placement Properties (Propriétés de placement des étiquettes)

    La fenêtre Label Class - Tourist Attractions (Classe d’étiquettes - Attractions touristiques) s’ouvre. Cette fenêtre comporte des options d’étiquetage avancé.

  7. Cliquez sur l’onglet Conflict resolution (Résolution des conflits).

    Onglet Conflict resolution (Résolution des conflits)

  8. Développez la section Unplaced labels (Étiquettes non placées) et cochez l’option Never remove (place overlapping) (Ne jamais supprimer [superposition]).

    Option Never remove (Ne jamais supprimer)

    À présent, aucune étiquette n’est supprimée de la carte en raison de son chevauchement avec une autre. Vous allez ajuster la position des étiquettes de sorte qu’elles soient placées plus au centre du symbole d’épingle.

  9. Cliquez sur Symbol (Symbole). Sous l’onglet General (Général), développez la section Position et redéfinissez Offset Y (Décalage Y) sur 2 pt.

    Paramètre Offset Y (Décalage Y) redéfini sur 2 pt

  10. Cliquez sur Apply (Appliquer).

    Les étiquettes se décalent légèrement vers le haut, ce qui les place au centre des symboles d’épingle.

    Étiquettes finales sur la carte

    Même si certaines étiquettes chevauchent légèrement d’autres symboles d’épingle, elles restent généralement lisibles. En utilisant les données de la table publiées sur la brochure, les touristes seront en mesure d’identifier chaque attraction de la carte.

  11. Fermez la fenêtre Label Class - Tourist Attractions (Classe d’étiquettes - Attractions touristiques) et enregistrez le projet.
    Remarque :

    Il serait également utile aux utilisateurs d’avoir les gares étiquetées. Vous n’allez pas les étiqueter dans le cadre de cette leçon. Toutefois, n’hésitez pas à essayer. Quelle apparence doit adopter vos étiquettes pour être lisibles sur la carte ?

    Avant de continuer, vous allez renommez votre carte pour lui donner un nom plus descriptif. Par défaut, son nom est Map (Carte).

  12. Dans la fenêtre Contents (Contenu), double-cliquez sur Map (Carte).

    Map (Carte) dans la fenêtre Contents (Contenu)

    La fenêtre Map Properties (Propriétés de la carte) s’ouvre.

  13. Sous l’onglet General (Général), dans Name (Nom), saisissez Central Business District.

    Paramètre Name (Nom)

  14. Cliquez sur OK.

    La carte est renommée.

Créer une mise en page

Votre carte est terminée. Tout ce qui vous reste à faire est de l’exporter sous une forme imprimable dans la brochure. Pour préparer votre carte en vue de son impression, vous allez configurer une mise en page. Une mise en page est un ensemble d’éléments cartographiques organisés sur une page virtuelle. Elle définit à quoi ressemblera la carte une fois imprimée.

Vous pouvez concevoir une mise en page entièrement nouvelle, mais ArcGIS Pro inclut déjà plusieurs modèles de mise en page. Vous allez utiliser un modèle et modifier quelques éléments de la mise en page.

  1. Sur le ruban, cliquez sur l’onglet Insert (Insérer), puis sur le bouton Import Layout (Importer la mise en page).

    Bouton Import Layout (Importer la mise en page)

    La liste des modèles disponibles s’affiche. Une mise en page simple convient bien, car c’est la carte que vous désirez mettre en valeur.

  2. Choisissez la mise en page Title Bar Letter Landscape (Paysage - Lettre - Barre de titre).

    Mise en page Paysage - Lettre - Barre de titre mise en page

    Remarque :

    Si vous ne voyez pas la liste des modèles disponibles, vous pouvez télécharger et importer le modèle de mise en page utilisé dans cette leçon.

    La mise en page s’ouvre dans une nouvelle vue (vous passez de la vue cartographique au mode Mise en page par le biais des onglets situés au-dessus de la vue).

    Mise en page par défaut

    Cette mise en page inclut un titre, une légende et une barre d’échelle. Tous les éléments disponibles pour la mise à jour sont répertoriés dans la fenêtre Contents (Contenu). Par ailleurs, le ruban comporte maintenant quatre onglets qui permettent d’interagir avec la mise en page.

    Par défaut, le modèle que vous avez choisi contient une carte de la ville de Columbus dans l’État de l’Ohio. Vous allez mettre à jour la fenêtre cartographique pour utiliser votre carte de Singapour.

  3. Dans la fenêtre Contents (Contenu), double-cliquez sur Map Frame (Fenêtre cartographique).

    Fenêtre cartographique dans la fenêtre Contents (Contenu)

    La fenêtre Format Map Frame (Mettre en forme une fenêtre cartographique) apparaît.

  4. Sous Options, dans Map Frame (Fenêtre cartographique), sélectionnez Central Business District.

    Carte choisie pour l’option Fenêtre cartographique

    La carte dans la mise en page change. Néanmoins, l’étendue de la carte est dorénavant planétaire ; Singapour n’est donc pas visible. L’étendue de la carte et l’étendue de la mise en page sont indépendantes.

    Vous allez utiliser le géosignet créé précédemment pour accéder à l’étendue de la carte souhaitée.

  5. Sur le ruban, cliquez sur l'onglet Mise en page. Dans le groupe Map (Carte), cliquez sur Bookmarks (Géosignets) et sélectionnez le géosignet Central Business District.

    Géosignet Central Business District

    L’étendue de la carte est actualisée selon votre zone d’intérêt.

    Mise en page avec l’étendue du géosignet

    Astuce :

    Pour déplacer ou agrandir la carte selon une étendue différente dans la mise en page, dans le groupe Map (Carte), cliquez sur Activate (Activer). Une fois activé, vous explorez normalement la carte. Lorsque vous avez modifié l’étendue, cliquez sur l’onglet Layout (Mise en page) et cliquez sur Close Activation (Fermer l’activation).

    Vous allez ensuite donner un titre à la mise en page.

  6. Dans la fenêtre Contents (Contenu), double-cliquez sur Map Title (Titre de la carte).

    La fenêtre Format Text (Mettre en forme un texte) s’ouvre.

  7. Sous Options, dans Text (Texte), supprimez le texte et saisissez Downtown Singapore (Centre-ville de Singapour). Cliquez n’importe où en dehors de la zone de texte.

    Texte du titre de la carte

    La modification est appliquée à la mise en page.

    Nouveau titre inséré dans la mise en page

    Vous allez également ajuster la légende décrivant la signification de tous les symboles qui figurent sur la carte. La légende par défaut possède un arrière-plan blanc, ce qui ne permet pas de voir très nettement les voies de chemin de fer de couleur blanche. Vous allez supprimer l’arrière-plan et ajuster la position de la légende.

  8. Dans le volet Contents (Contenu), cliquez deux fois sur Legend (Légende).

    La fenêtre Format Legend (Mettre en forme une légende) s’ouvre. Dans un premier temps, vous allez changer le texte de la légende pour qu’il apparaisse en blanc. Il sera ainsi visible sur le fond de carte foncé lorsque vous aurez supprimé l’arrière-plan de la légende.

  9. Cliquez sur Text Symbol (Symbole textuel). Dans l’onglet Properties (Propriétés), développez Appearance (Apparence) et redéfinissez Color (Couleur) sur Arctic White (Blanc arctique).

    Couleur modifiée en blanc arctique

  10. Cliquez sur Apply (Appliquer).

    Vous allez ensuite modifier l’arrière-plan de la légende.

  11. En haut de la fenêtre, cliquez sur la flèche de la liste déroulante Legend (Légende) et choisissez Background (Arrière-plan).

    Option Background (Arrière-plan)

  12. Dans Color (Couleur), sélectionnez No color (Aucune couleur).

    Option No Color (Aucune couleur)

  13. Cliquez sur Apply (Appliquer).

    L’arrière-plan de la légende est supprimé.

  14. En mode Mise en page, faites glisser la légende de sorte qu’elle s’affiche dans le coin inférieur droit de la carte. Lorsque vous avez fini, cliquez n’importe où en mode Mise en page hors de la carte pour désélectionner la légende.

    Mise en page finale

    La mise en page est terminée. L’agence de tourisme imprimera cette image de la carte dans la page intérieure de la brochure. Le dos de la brochure répertoriera la liste des attractions touristiques selon la table que vous avez exportée. En dernier lieu, la brochure permettra aux touristes de rechercher la gare la plus proche de chaque attraction touristique.

  15. Fermez la fenêtre Format Legend (Mettre en forme une légende). Enregistrez le projet.

    Vous allez ensuite exporter la mise en page sur un fichier image.

  16. Sur le ruban, cliquez sur l’onglet Share (Partager). Dans le groupe Export (Exporter), cliquez sur Layout (Mise en page).

    Bouton Layout (Mise en page) sur l’onglet Share (Partager)

    La fenêtre Export (Exporter) s’affiche.

  17. Dans File Type (Type de fichier), choisissez un format de fichier image. Dans Name (Nom), accédez à l’emplacement en sortie de votre choix et remplacez le nom du fichier par Downtown Singapore (Centre-ville de Singapour).
  18. Cliquez sur Exporter.

    La mise en page est exportée à l’emplacement que vous avez choisi.

Dans cette leçon, vous avez créé une carte qui présente les attractions touristiques les plus populaires situées dans le centre-ville de Singapour. Vous avez créé un projet, accédé à une zone d’intérêt et ajouté des données. Vous avez changé l’apparence de la carte et analysé la distance séparant les attractions touristiques des gares. Vous avez ensuite créé une mise en page et exporté la carte dans un fichier image.

Simple introduction au programme ArcGIS Pro, cette leçon a abordé des notions de base comme la création de cartes et l’analyse. Pour en savoir plus sur les possibilités de ArcGIS Pro, reportez-vous aux leçons Learn ArcGIS suivantes :

Vous trouverez plus de leçons dans la Bibliothèque des leçons Apprendre à utiliser ArcGIS.