Prepare the scene and the buildings

You will first prepare the 3D scene in ArcGIS Pro. You'll use a pre-existing 3D scene representing Rotterdam's city center, add the De Zalmhaven complex buildings to it, and fine-tune the configuration of the scene so that it is ready to share with your audience. The result will look like the following example image (the De Zalmhaven complex appears in dark gray tones).

Final result view

Note:

It is becoming more common for city governments to maintain a 3D scene representing the current state of their city. That scene can then be used by various parties, such as architecture and construction firms, as a backdrop for their new projects. The city government can also use the scene for urban planning and the assessment of new development projects.

Download the data and create a 3D scene

First, you'll download the BIM data representing the De Zalmhaven complex. Then you'll open ArcGIS Pro and load the 3D web scene representing Rotterdam's city center.

  1. Download the De_Zalmhaven_complex_for_sharing.zip compressed folder on your computer.
    Note:

    Depending on your web browser, you may be prompted to choose a file location before you begin the download. Most browsers download to your computer's Downloads folder by default.

  2. Locate the downloaded De_Zalmhaven_complex_for_sharing.zip file, right-click it and extract the content to a location of your choice, such as your Documents folder.

    Next, you'll open ArcGIS Pro.

  3. Start ArcGIS Pro. If prompted, sign in using your licensed ArcGIS account.
    Note:

    If you don't have ArcGIS Pro or an ArcGIS account, you can sign up for an ArcGIS free trial.

  4. Under New Project, click Start without a template.

    Start without a template option

    You'll now open a web scene representing the Rotterdam city center in ArcGIS Pro.

  5. On the ribbon, on the View tab, in the Windows group, click Catalog Pane.

    Catalog Pane button

  6. In the Catalog pane, click Portal and ArcGIS Online. In the search box, type Rotterdam City Center owner:Learn_ArcGIS and press Enter.

    Choose Portal and ArcGIS Online.

  7. In the list of results, right-click the Rotterdam City Center web scene and choose Add And Open.

    Add and open option

    After a few moments, the 3D scene appears.

    Initial scene

    You will use it as the backdrop for the De Zalmhaven complex.

    Note:

    You can also view that web scene in your web browser, where it is accessible to everyone. To learn how to create such scenes, see Create a web scene to support construction planning.

  8. In the Contents pane, review the layers that compose the Rotterdam City Center scene.

    Initial Contents pane

    Besides the basemap and ground layers, the scene includes several feature layers, such as Buildings, Bridges, and Trees. You'll explore the scene to familiarize yourself with it.

  9. In the scene, above the Navigator wheel, click the Show full control button.

    Show full control button

    The Navigator wheel expands to include 3D navigation functionality.

  10. Use the middle Navigator wheel to tilt and rotate the scene.

    You can also use the mouse wheel button to zoom in and out, and you can press the left mouse button and drag to pan.

    Middle navigation wheel

    Tip:

    To learn more about the options for 3D navigation, see Navigation in 3D.

  11. Zoom in and move through the scene to observe it.

    The different layers come together to create an engaging, informative cityscape. You'll now save the project to the same folder where your BIM data is stored.

  12. On the Quick Access Toolbar, click Save.

    Save button

  13. In the Save Project As window, browse to the extracted De_Zalmhaven_complex_for_sharing folder and select it. Click Save.

    Save Project As window

In this section, you downloaded BIM data, opened a 3D web scene in ArcGIS Pro and saved the project.

Add digital building models to the scene

The planned De Zalmhaven complex contains two buildings, a high-rise and a mid-rise. You'll now add the digital models that represent these buildings to the scene.

Note:

A digital model is usually created in a native format, such as Revit, Vectorworks, or Allplan using BIM software. ArcGIS supports the Revit and IFC exchange formats. In ArcGIS, the digital model is then imported as a workspace where it is represented as a set of datasets and feature classes. To learn more about the BIM workspace see BIM files as BIM workspace.

In this tutorial, the two buildings are in the IFC format.

  1. If necessary, on the ribbon, on the View tab, in the Windows group, click Catalog Pane.
  2. In the Catalog pane, click Project. Expand Folders > De_Zalmhaven_complex_for_sharing > Digital_models.

    Expand folders to Digital_models.

    Note:

    If the Digital_Models folder doesn't display, right-click De_Zalmhaven_complex_for_sharing and choose Refresh.

  3. Press the Shift key, and click ZHA-B-BWK-C-HR-R18.ifc and ZHA-B-BWK-C-MR-R18.ifc to select them. Right-click and choose Add To Current Map.

    Add to Current Map option

    After a few moments, the two buildings appear in the scene.

    Buildings added to the scene

    The digital building models are added as building layers. They have already been georeferenced, so they appear at the right location in the scene.

    Note:

    You can learn how to georeference BIM data in Geolocate a 3D digital building model.

  4. In the Contents pane, right-click the ZHA-B-BWK-C-MR-R18 building layer, and choose Zoom To Layer.

    Zoom To Layer menu option

    The scene's camera zooms in to the mid-rise building.

  5. Zoom out, pan, and rotate until you obtain a good view of the De Zalmhaven complex, like in the following example image.

    Zoomed-in view of the buildings

In this section, you added the De Zalmhaven buildings to the scene.

Hide older buildings from the scene

You'll now modify the scene to display the two buildings optimally for your audience. At the location of the future De Zalmhaven complex, you may notice that there are currently two older buildings displaying. You will hide the older buildings to make space for the new ones.

  1. Review the scene and identify the two gray buildings competing for the same space as the De Zalmhaven complex.

    Older buildings

    Next, you must find the IDs of these two older buildings.

  2. Click the first older building to display its informational pop-up and write down its ObjectID value (137392) for later use.

    First older building and its pop-up

    Note:

    If the pop-up does not display, on the ribbon, on the Map tab, in the Navigate group, expand the Explore down arrow, and make sure the Topmost Layer option is selected.

    Topmost Layer option

  3. Close the pop-up.
  4. Similarly, obtain the ObjectID value for the second older building (136753), and close the pop-up.

    Second older building and its pop-up

    Note:

    If necessary, you can rotate the scene to better see that second older building.

    Next, you'll form a definition query with those two building IDs to exclude them from the display.

  5. In the Contents pane, right-click the Buildings layer and choose Properties.

    Properties menu option

  6. In the Layer Properties: Buildings window, choose Definition Query, and click New definition query.

    New definition query button

  7. Under Query1, form the query Where OBJECTID does not include the value(s) 137392, 136753.

    Form the query Where OBJECTID does not include the value(s) 137392, 136753.

  8. Click Apply and click OK.

    The Buildings layer refreshes and redraws without the two older buildings.

    Scene with the older buildings hidden

    Note:

    The two buildings are only removed from sight within your ArcGIS Pro project. They are not removed from the original web scene.

  9. Press Ctrl+S to save the project.

In this section, you removed two older buildings from the scene.

Change the visibility of the building layers

You'll now customize the appearance of the De Zalmhaven building layers. First, you'll rename them.

  1. In the Contents pane, select the layer ZHA-B-BWK-C-MR-R18 and click it again to edit it. Type De Zalmhaven mid-rise.
  2. Similarly, rename the ZHA-B-BWK-C-HR-R18 layer to De Zalmhaven high-rise.

    Renamed buildings

    You'll explore the structure of the building layers.

  3. In the Contents pane, click the arrow next to the Zalmhaven mid-rise layer to expand it.

    Expand the Zalmhaven mid-rise layer.

    The digital model is organized into several disciplines: Architectural, Electrical, Mechanical, Piping, and Structural, currently turned off. There is also an ExteriorShell layer, which is turned on by default.

  4. Expand some of the disciplines to explore them.

    Each discipline is composed of categories. For instance, the Architectural discipline contains categories, such as Chimneys, Columns, and Coverings, and Doors.

    Architectural categories

    Note:

    To learn more about discipline, category and exterior shell layers, see Work with a building layer.

  5. Optionally, turn some of the mid-rise discipline and category layers on and off, and observe the effect in the scene.
  6. Under De Zalmhaven mid-rise, turn off the ExteriorShell and turn on all disciplines.

    ExteriorShell turned off and Disciplines turned on

    After a few moments, in the scene, the mid-rise building redraws with many more construction details.

  7. In the Contents pane, click the arrow next to Zalmhaven mid-rise to collapse it back.
  8. Similarly, for the De Zalmhaven high-rise layer, turn off ExteriorShell and turn on all the disciplines.
  9. Explore the scene, and observe how the two De Zalmhaven buildings seamlessly integrate with the rest of the scene.

    Buildings with all disciplines turned on

In this section, you customized the display of the digital building models, changing the visibility of its disciplines and category layers.

Customize the bookmarks

Next, you'll customize the scene's bookmarks to help your audience navigate to relevant views of the De Zalmhaven complex.

  1. On the ribbon, on the Map tab, in the Navigate group, click Bookmarks, and choose the Overview bookmark.

    Overview bookmark

    The camera navigates to the bookmarked view.

  2. Similarly, navigate to the other two bookmarked views.

    You can see that the Noordereiland bookmarks are not relevant for the De Zalmhaven project. You'll delete them.

  3. On the ribbon, on the Map tab, click Bookmarks, right-click the Noordereiland bookmark and choose Remove Bookmark.

    Remove Bookmark option

  4. Similarly, remove the Noordereiland Underground bookmark.

    You'll now create bookmarks focused on the De Zalmhaven complex project.

  5. In the scene, zoom, pan, rotate and tilt to get a view similar to the one in the following example image.

    View for the De Zalmhaven complex slide

  6. When you are finished, on the ribbon, on the Map tab, click Bookmarks and choose New Bookmark.

    New Bookmark option

  7. In the Create Bookmark window, for Name, type De Zalmhaven complex. For Description, type Overview of the De Zalmhaven development project.

    Create Bookmark window

  8. Click OK.

    You'll create a second bookmark, this time showing an underground view of the De Zalmhaven complex.

  9. Drag the middle Navigator wheel up to go underground. Pan and zoom to show a clear view of the De Zalmhaven complex underground, such as in the following example image.

    Underground view

  10. Create a bookmark named De Zalmhaven underground and described as De Zalmhaven complex foundation.

    You now have three bookmarks that are relevant to your scene's goals.

  11. Test the bookmarks by clicking them and navigating to their corresponding views.
  12. Click the De Zalmhaven complex bookmark to continue the tutorial with a good above-ground view of the buildings.
  13. Press Ctrl+S to save the project.

In this section, you deleted two older bookmarks and created two new ones focused on the De Zalmhaven complex.

Add a building filter to the scene

You will now define a building filter to help visualize the foundation structure of the De Zalmhaven high-rise. A building filter is a predefined view of a building layer where only specific elements display.

  1. If necessary, in the Contents pane, expand the De Zalmhaven high-rise layer and ensure that the ExteriorShell is turned off and all the disciplines are turned on.
  2. In the Contents pane, click the De Zalmhaven high-rise layer to select it.

    High-rise layer selected

  3. On the ribbon, on the BIM Data tab, in the Filter group, click Refresh Filter Values.

    Refresh Filter Values button

    After a few moments, the Building Filter button activates.

  4. Click Building Filter and choose New Filter.

    New Filter button

  5. In the Building Filter - De Zalmhaven high-rise pane, on the General tab, provide the following parameter values:
    • For Name, type Foundation structure.
    • For Description , type This filter shows the foundation structure of the high-rise building for the De Zalmhaven complex.
    • For Filter Type, accept the defaults, since, in this case, you don't need any additional categories.

    Building Filter Name and Description fields

    You will limit the filter display to only show certain category elements of the high-rise building.

  6. Click the Settings tab, and click the arrow next to Filter Block to expand it.

    Settings tab

  7. Under Types, choose Category.

    Under Values, a list of all the category layers appears.

  8. In the list of Values, check the boxes for column, footing, and pile.

    Check the boxes for column, footing, and pile.

    The scene updates to show only the column, footing, and pile category elements for the high-rise building. These elements are relevant for the foundation structure.

    Next, since the filter you are building is focused on the building foundation, you will limit the display to the lowest floors.

  9. Under Types, choose BldgLevel.

    Under Values, all building levels are listed from the ground floor (00) to the 62nd floor (in this building layer, the floor names are written in Dutch).

  10. In the Values list, check the boxes for the floors 00, 00a, and 01.

    Check the boxes for the floors 00, 00a, and 01.

    The scene updates, showing only the lowest floors of the building structure.

  11. In the scene, zoom in, rotate, and pan to observe the high-rise foundation structure from above.

    Foundation from above

  12. On the ribbon, on the Map tab, click Bookmarks and choose De Zalmhaven underground.

    The scene updates to show the underground building foundation.

  13. Zoom in to the high-rise foundation and explore it.

    Foundation from below

  14. On the ribbon, on the Map tab, click Bookmarks and choose De Zalmhaven complex.

    The scene updates to show the De Zalmhaven complex from above.

  15. Close the Building Filter - De Zalmhaven high-rise pane.

    Now that the filter is defined, you can turn it off or on.

  16. On the ribbon, on the BIM Data tab, click Building Filter.

    The Foundation structure filter is highlighted in blue and has a green checkmark, showing that it is on.

    Filter turned on

    Note:

    When the filter is turned on, the scene will only show the elements that you selected for that building, even if all the disciplines and categories are turned on in the Contents pane.

  17. Click Foundation structure to turn the filter off.

    On the scene, the high-rise building updates to its full display.

  18. Optionally, turn the filter on and off again.
  19. Optionally, you can create a similar filter for the De Zalmhaven mid-rise building.
  20. Press Ctrl+S to save the project.

In this section, you created a building filter for the De Zalmhaven high-rise building. Your scene is now ready to share. Next, you will learn about two different sharing options and how to choose between them.

Choose the right sharing option

The scene you've built, integrating the planned De Zalmhaven complex into the Rotterdam cityscape exists only on your computer, as an ArcGIS Pro project. You'll now share it as a web scene to ArcGIS Online to make it available to a larger audience. Since all the layers from the original scene (Buildings, Bridges, Trees, and so on) are already hosted in ArcGIS Online, you won't need to republish them. The only new items that need to be shared are the De Zalmhaven building layers, and the overall scene wrapper that you'll save as a new web scene.

You will learn how to share building layers to ArcGIS Online using two possible methods: you can create web scene layers from scene layer packages or from associated feature layers. The two methods differ in the capabilities they offer, as well as the number of credits they use, as listed in the following table.

Web scene layers from scene layer packagesWeb scene layers from associated feature layers

Visualize the buildings (Building explorer)

Yes

Yes

Pop-ups

Yes

Yes

Predefined filters

Yes

Yes

Edit the geometry or attributes of the buildings

No

Yes

Search capabilities

No

Yes

Credits use

Minimizes credit use

Uses more credits

The first method creates scene layer packages on your computer and publishes them to ArcGIS online. This saves the credit cost of performing data creation in ArcGIS Online. The second method generates scene layers from associated feature layers that are created directly in ArcGIS Online. For more information about usage of credits in ArcGIS Online, see Understand credits in ArcGIS Online.

In the rest of the tutorial, you'll use the two sharing methods in succession to create two web scenes. You'll understand in what circumstances you would choose one method over the other, and learn the detail of both workflows.


Share a 3D scene for visualization

In this first sharing scenario, you are the data manager for the architecture company designing the De Zalmhaven complex. You want to share the web scene with the Rotterdam community and the general public, so that they can better visualize the upcoming construction within its urban context. You want the web scene to have the following capabilities:

  • Offer a general visualization of the two buildings within the larger urban context.
  • Enable a detailed exploration of the buildings' disciplines and categories, as well as building levels.
  • Contain a filter to visualize the building foundation.

The first sharing method (web scene layers from scene layer packages) offers all these capabilities, so you will choose it, since it also allows you to minimize the use of credits.

Prepare the scene for sharing

First, you'll ensure that the layers and scene view are set up as you want them to be published. Then you'll provide essential information about the web scene.

  1. If necessary, in the Contents pane, expand the De Zalmhaven high-rise and De Zalmhaven mid-rise layers and ensure that, for both, ExteriorShell is turned off and all disciplines are turned on.
  2. On the ribbon, on the Map tab, click Bookmarks, and choose the De Zalmhaven complex bookmark.

    Next, you'll enter the information for the new web scene.

  3. On the ribbon, on the Share tab, in the Share As group, click Web Scene.

    Web Scene button

    The Share As Web Scene pane appears.

  4. In the Share As Web Scene pane, for Name, type De Zalmhaven Rotterdam and add your initials, for example, De Zalmhaven Rotterdam YN.
    Note:

    As you create the web scene, make sure its name and the names of its components are unique across your organization. Adding your initials at the end of the scene name ensures that other people in your organization can also complete this tutorial.

  5. For Summary, type or copy and paste 3D scene showing the De Zalmhaven complex project in the Rotterdam city center. Built as part of the tutorial: Share digital building models in a 3D web scene.
  6. For Tags, accept the current tabs.

    The tags come from the original Rotterdam City Center scene.

    Share As Web Scene pane.

  7. Under Location, for Folder, accept the default, choose a destination folder in your ArcGIS Online account, or create a new one.
  8. For Share with, check Everyone.

    Check the Everyone box.

    This will make the web scene available publicly without restriction. This is the appropriate choice as you want to share the scene with the Rotterdam community at large.

In this section, you set up the scene for sharing and provided essential information about the web scene. You will continue the sharing process in the next section.

Configure the web scene layers and share the scene

You will now configure the web scene layers and publish the scene to ArcGIS Online.

  1. In the Share As Web Scene pane, click the Content tab.

    Content tab

    A list appears, showing all the items that need to be created to share the scene online.

    List of layer to share

    Note:

    If necessary, collapse some of the list items to hide the many building disciplines and categories.

    ArcGIS Pro automatically identified the layers in the scene that are currently stored on your desktop computer and must be published to ArcGIS Online:

    • The first item, De_Zalmhaven_Rotterdam, is the overall web scene wrapper.
    • The two De_Zalmhaven_Rotterdam_WSL1 items will represent together the mid-rise building layer.
    • The two De_Zalmhaven_Rotterdam_WSL2 items will represent together the high-rise building layer.

    All the other layers (Bridges, Trees, and so on) already exist in ArcGIS Online and don't need to be republished.

    You'll now configure the layers to ensure that they are using the first sharing method (web scene layers from scene layer packages).

  2. Hover over the first occurrence of De_Zalmhaven_Rotterdam_WSL1.

    A pop-up states that this will be a web scene layer.

    Web Scene Layer pop-up

  3. Hover over the second occurrence of De_Zalmhaven_Rotterdam_WSL1.

    A pop-up states that this will be a web feature layer.

    Web Feature Layer pop-up

    Currently, both the web scene layer and the web feature layer will be created in ArcGIS Online to represent the De Zalmhaven mid-rise in the scene.

    You'll change the layer configuration to create as much of the content as possible on your computer and share only the resulting scene layer package to ArcGIS Online.

  4. On the Content tab, click the De_Zalmhaven_Rotterdam_WSL1 web scene layer to select it, and click the Configure Web Layer Properties button.

    Configure Web Layer Properties button

  5. In the Configure De_Zalmhaven_Rotterdam_WSL1 pane, click Configuration.

    Configuration tab

  6. For Caching, choose Cache locally and accept the default Temp cache location value.

    Cache locally option

    The scene layer package will be created in this local folder. The message Associated web feature layer was removed appears.

  7. Click the back button.

    Back button

  8. In the Content list, hover over the second occurrence of De_Zalmhaven_Rotterdam_WSL1.

    Scene Layer Package pop-up

    The pop-up states that this will now be a scene layer package (not a web feature layer).

  9. Repeat the same configuration change for the De_Zalmhaven_Rotterdam_WSL2 web scene, so that it also uses the Cache locally option.
  10. Check the icons or pop-ups of the items listed to ensure that the content listed is only web scene layers and scene layer packages.

    List of layers cached locally

    You'll now analyze the web scene to verify that there aren't any remaining issues that you need to address.

  11. In the Share As Web Scene pane, under Finish Sharing, click Analyze.

    Analyze button

    The Messages tab appears. Address any errors listed there and review any warnings.

    Note:

    In this tutorial, you get several warnings stating that empty building feature classes will be removed. This means that some building categories have no data and will not be published. This warning can be ignored.

    You are now ready to publish the web scene to ArcGIS Online.

    Note:

    This operation uses some credits and can take 10 minutes or more, since a lot of data will be prepared and shared. If you prefer, you can read through the next few steps and continue the tutorial in the View the web scene section with this ready-made scene.

  12. Under Finish Sharing, click Share.

    Share button

  13. Optionally, under Finish Sharing, click Jobs to monitor progress in more detail.

    Jobs button

    The Job Status pane appears, listing the layers that are currently being processed.

    When the process is complete, in the Share As Web Scene pane, a green message box appears, informing you that the web scene was shared successfully.

    Sharing successful green box

  14. Press Ctrl+S to save the project.

In this section, you published the scene to ArcGIS Online using the first sharing method (web scene layers from scene layer packages).

View the web scene

Now that the Zalmhaven Rotterdam scene is published to ArcGIS Online, you'll inspect it.

  1. In the message box, click the Manage the web scene link to open the web scene in a web browser.

    Link to scene

    Note:

    To explore the ready-made scene instead, go to its item page.

    The item page for the web scene appears in your default web browser. It lists all the information about the scene, including the list of layers it includes.

  2. Click Open in Scene Viewer.

    Open in Scene Viewer button

    The web scene appears. It is similar in content and appearance to the scene you built in ArcGIS Pro, and it is set on the last camera position you had chosen in ArcGIS Pro.

    Initial web scene

  3. Explore the web scene.
    Note:

    Use the mouse wheel button to zoom, click the left mouse button and drag to pan, and click the right mouse button and drag to rotate and tilt.

    Alternatively, you can also use the navigation buttons below the Home button to achieve the same movements.

  4. Hover over the ribbon at the bottom of the scene, and click the three slides one after the other.

    Slides

    The camera navigates smoothly from one view to the other. The slides correspond to the bookmarks you prepared in ArcGIS Pro.

In this section, you explored the web scene.

Explore the building layers with Building explorer

You'll now explore the De Zalmhaven buildings using the Building explorer.

  1. If necessary, click the De Zalmhaven complex slide to come back to the main view of the buildings.
  2. In the side toolbar, click the Building explorer button.

    Building explorer button

    The Building explorer pane appears.

  3. In the Building explorer pane, expand the drop-down list and choose the De Zalmhaven mid-rise building.

    Builder explorer drop-down list

    The view zooms in to the building.

  4. In the scene, if necessary, zoom out, pan, and rotate to have a good view of the mid-rise building.
  5. In the Building explorer pane, on the Level picker, click the second level from the top to select it.

    Level 30 on the Level picker

    The top level appears in dark gray. For added context, the other levels appear in semi-transparent light gray.

    View of level 30

  6. Next to the Level picker, click the down button repeatedly to view each individual level.

    Level picker down button

  7. Under Disciplines & Categories, turn on or off some of the disciplines and categories and continue to explore the different building levels.

    Turn on or off some of the disciplines and categories.

  8. Next to the building picker, click Clear Level to go back to visualizing all the levels.

    Clear Level button

    You can also learn more about every building element.

  9. In the scene, click any element of the mid-rise to select it.

    Opening element selected

    An informational pop-up appears, containing all of the element's properties. In the example, the category is OpeningElement, and this element will eventually host a window.

    Pop-up for an opening element

  10. Optionally, continue to explore various combinations of disciplines and categories for the entire building, and click several construction elements.
  11. In the Building explorer pane, expand the drop-down list and select the De Zalmhaven high-rise building.
  12. Explore various levels, disciplines, and categories for the De Zalmhaven high-rise.
  13. If necessary, turn back on all levels, disciplines and categories for both buildings.
    Note:

    Learn more about the Building explorer in the Explore building scene layers documentation.

Use the building filter

You'll now use the filter that you included in the scene to better understand the building foundation of the high-rise.

  1. If necessary, in the side toolbar, click the Building explorer button.
  2. If necessary, in the Building explorer pane, in the drop-down list, select the De Zalmhaven high-rise building.
  3. Click the options button to display the list of filters, and choose Foundation structure.

    Foundation structure filter turned on.

    On the scene, the high-rise updates, showing only the foundation structure elements.

  4. Optionally, rotate, zoom, and pan to explore the foundation structure.
  5. In the Building explorer, click the options button and choose No predefined filter to turn the filter off.

    On the scene, the high-rise updates to its full display.

  6. Optionally, turn on the Foundation structure filter for the mid-rise building if you created it earlier in the workflow.
    Note:

    Learn more about other Scene Viewer tools and options, such as Measure, Slice, View elevation profile, and Daylight, in the Get started with Scene Viewer documentation.

You applied the first sharing method (web scene layers from scene layer packages) to create a 3D web scene that shows the De Zalmhaven complex in its larger urban context. Then you inspected the scene in ArcGIS Online. This sharing method enables engaging visualization and exploration capabilities, while minimizing the use of credits. It is particularly well suited for public-use web scenes. Next, you'll create a web scene using the second sharing method.


Share a 3D scene with searching capabilities

In this second sharing scenario, you are a data manager for the City of Rotterdam. You want to share the web scene with the city inspectors who need to check various elements of the De Zalmhaven digital models against the schematics submitted by the contractor. You want the web scene to have the following capabilities:

  • Offer a general visualization of the two buildings within the larger urban context.
  • Enable a detailed exploration of the buildings' disciplines and categories, as well as building levels.
  • Contain a filter to visualize the building foundation.
  • Enable searching on specific building elements.

The latter capability requires using the second sharing method (web scene layers from associated feature layers), so that's the one you'll choose.

Prepare the scene for sharing

First, you'll ensure that the layers and scene view are set up as you want them to be published. Then you'll provide essential information about the web scene.

  1. In ArcGIS Pro, the Contents pane, ensure that the two De Zalmhaven building layers have ExteriorShell turned off and all disciplines turned on.
  2. Set the scene to the De Zalmhaven complex bookmark.

    Next, you'll enter the information for the new web scene.

  3. Close the Share as a Web Scene pane.

    This will ensure that you don't keep any of the first sharing scenario's settings.

  4. On the ribbon, on the Share tab, in the Share As group, click Web Scene.

    The Share As Web Scene pane appears.

  5. In the Share As Web Scene pane, for Name, type De Zalmhaven Rotterdam for inspectors and add your initials, for example, De Zalmhaven Rotterdam for inspectors YN.
  6. For Summary, type 3D scene showing the De Zalmhaven complex project in the Rotterdam city center. Includes layer searching capabilities, as well as various visualization options. Built as part of the tutorial: Share digital building models in a 3D web scene.
  7. For Tags, accept the current tabs.

    Share As Web Scene pane

  8. Under Location, for Folder, accept the default, choose a destination folder in your ArcGIS Online account, or create a new one.
  9. For Share with, check your organization only.

    Check your organization check box.

    This will make the web scene available only to the users within your organization. It is the appropriate option in this scenario, as the city inspectors will be the ones using that web scene and it will not be available to the public.

    Note:

    Optionally, choose a specific group within the organization to restrict access further, for instance, the group of city inspectors. To learn more about access in ArcGIS Online, see Share items.

In this section, you set up the scene for sharing and provided essential information about the web scene. You will continue the sharing process in the next section.

Configure the web scene layers and share the scene

You will now configure the web scene layers and publish the scene to ArcGIS Online.

  1. In the Share As Web Scene pane, click the Content tab.

    A list appears, showing all the items that must be created to share the scene online.

    List of layers to share

    By default, the configuration values for these layers are already set to implement to the second sharing method (web scene layers from associated feature layers), so you'll mostly be accepting the defaults. However, to better understand the workflow, you'll review the configuration values.

  2. On the Content tab, click the De_Zalmhaven_Rotterdam_for_inspectors_WSL1 web scene layer to select it, and click the Configure Web Layer Properties button.

    Configure Web Layer Properties button

  3. In the Configure De_Zalmhaven_Rotterdam_for_inspectors _WSL1 pane, click Configuration.
  4. Under Caching, note that Cache online is the default option. Keep that value.

    Cache online option

    As desired with the second sharing method, the data will be prepared directly online, not locally. This means that a hosted feature layer will be generated, which supports searching and editing capabilities.

  5. Click Configure Web Layer Properties.

    Configure Web Layer Properties button

    This is the tab where you can enable editing capabilities for the associated feature layer (both attributes and geometry). For instance, the users of the web scene can be enabled to edit the De Zalmhaven buildings themselves. In this tutorial, however, this is not a feature you need, so you'll leave these options unchecked and accept the default values.

    Editing options

  6. Click the back button.

    Back button

  7. Hover over the first occurrence of De_Zalmhaven_Rotterdam_for_inspectors_WSL1.

    A pop-up states that this will be a web scene layer.

  8. Hover over the second occurrence of De_Zalmhaven_Rotterdam_for_inspectors_WSL1.

    The pop-up states that this will be a web feature layer.

    Web Feature Layer pop-up

    A web scene layer and web feature layer combination is what you want for the second sharing method. Together they will represent the De Zalmhaven mid-rise in the web scene.

  9. Check that De_Zalmhaven_Rotterdam_for_inspectors_WSL2 is also set up similarly.

    Together, the two De_Zalmhaven_Rotterdam_for_inspectors_WSL2 layers will represent the De Zalmhaven high-rise.

    You'll now analyze the web scene to verify that there aren't any remaining issues that you need to address.

  10. In the Share As Web Scene pane, under Finish Sharing, click Analyze.

    Analyze button

    The Messages tab appears. Any errors listed there must be addressed. Any warnings should be reviewed. With this sharing method, there should be neither.

    You are now ready to publish the web scene to ArcGIS Online.

    Note:

    This operation uses some credits and can take 10 minutes or more, since a lot of data will be prepared and shared. If you prefer, you can read through the next few steps and continue the tutorial in the Set up the search capabilities section with this ready-made scene.

  11. Under Finish Sharing, click Share.

    Share button

  12. Optionally, under Finish Sharing, click Jobs to monitor progress in more detail.

    When the sharing process is complete, in the Shade As Web Scene pane, a blue message box appears, informing you that the web scene was shared successfully but that the online caching is still in progress.

    Message for the sharing process being complete.

    A few minutes later, a green message box appears, informing you that the online caching succeeded. The web scene is now ready.

    Message for the caching process being complete.

  13. Press Ctrl+S to save the project.

    In this section, you published the scene to ArcGIS Online using the second sharing method (web scene layers from associated feature layers).

Set up the search capabilities

Now that the Zalmhaven Rotterdam for inspectors scene is published to ArcGIS Online, you must set up its search capabilities to ensure that the city inspectors can use it to do their quality assurance work.

  1. In the message box, click the Manage the web scene link to open the web scene in a web browser.

    Link to scene

    Note:

    To explore the ready-made scene instead, go to its item page. However, you can't change its search settings, as you don't own the scene. The search settings have already been set up for you. You can read through the next few steps and continue the tutorial in the View the web scene and explore the search capabilities section.

  2. When prompted, provide your ArcGIS credentials.

    The item page for the web scene appears in your default web browser.

  3. On the blue toolbar, click Settings.

    Settings button

  4. Click Web Scene.

    Web Scene link

  5. Under Application Settings, check the Enable Search box.

    Enable Search check box

    This enables searching in general for the scene and makes the search box appear in it. Next, you'll define two custom layer-based searches. The first one will enable users to search within the Beams layer.

  6. Check the By Layer box and click Add Layer.

    Add Layer button

  7. Click the drop-down menu for City center area to see the options.

    There are many options tp choose from as the list contains attributes for the mid-rise and the high-rise buildings. Each of them contains the attributes that you want to use, Beams and Columns, so you must select the correct one for the search to work properly.

  8. Scroll down nearly to the bottom of the list and click Beams.
    Note:

    Notice where the scroll bar is and verify that you are selecting the Beams attribute that is near the bottom of the list. This is the correct one for the high-rise building.

    Correct Beams option for high-rise building

  9. Using the drop-down lists, form the following layer search: Beams Tag Contains.

    Form the search Beams Tag Contains.

    The users will be able to retrieve a specific beam by entering its tag (or ID). You'll now add a second layer search that will enable searching within the Columns layer.

  10. Using the drop-down lists, form the following layer search: Columns Tag Contains.
    Note:

    Be sure to use the Columns attribute that is about half-way through the list, not the one at the top.

    Correct Beams option for high-rise

    The search expression should appear as follows:

    Form the search Columns Tag Contains.

    The users will be able to retrieve a specific column by entering its tag (or ID).

  11. Click Save.
    Note:

    You can set up more customized search options based on your needs.

In this section, you set up the custom search capabilities for your scene.

View the web scene and explore the search capabilities

You'll now open the web scene and test the search capabilities.

  1. On the blue toolbar, click Overview and Open in Scene Viewer.

    Overview and Open in Scene Viewer buttons

    The web scene appears.

  2. Explore the web scene.

    Initial web scene

    At first sight, this second web scene looks quite similar to the first one you published. It includes the same 3D visualization capabilities, the slides, the Building explorer tool, and the building filter.

  3. Optionally, try out all these capabilities, as you did for the first web scene.

    However, what differentiates this second scene is its searching capabilities. You'll explore them now. First, you'll choose the building you want to search on and optimize its display to better see the search results.

  4. On the side toolbar, click Building explorer.

    Building explorer button

  5. In the Building explorer pane, expand the drop-down list, and choose De Zalmhaven high-rise.
  6. Under Disciplines & Categories, expand the disciplines, and turn off GenericModel, OpeningElement, and Walls. Keep all the other categories on.

    Turn off GenericModel, OpeningElement, and Walls.

    In the scene, the high-rise building updates. You will now perform some searches.

  7. On the side toolbar, click Search.

    Search button

    Note:

    By default, the search box is set to the generic search capability. You can use it to search for street addresses in Rotterdam or other locations anywhere in the world.

    You'll activate the Beams layer search that you set up earlier.

  8. On the side toolbar, click the down arrow and choose Beams: Tag.

    Beam: Tag option

    Supposing for a moment that you are a city inspector, you identified a beam in the constructor's schematics that bears the tag 12028830. You want to identify it in the web scene for comparison.

  9. In the search box, type 12028830 and press Enter.

    Search for the 12028830 beam tag.

    The beam appears highlighted in the scene.

    Beam highlighted

    In an informational pop-up, the list of the beam properties are listed, for instance:

    • For LoadBearing, the value is Yes.
    • For IsExternal, the value is Yes.
    • For Slope, the value is 0.00.

    As a city inspector, you can now compare the information on the scene to the records submitted by the contractor.

    Next, you'll search for a column that has the tag 4420785.

  10. Click the down arrow next to the search box, and choose Columns: Tag.
  11. In the search box, type 4420785 and press Enter.

    The column appears highlighted in the scene along with its informational pop-up.

    Column highlighted

    These custom layer searches will allow city inspectors to perform detailed quality assurance work.

In the last part of the tutorial, you applied the second sharing method (web scene layers from associated feature layers) to create a 3D web scene that includes search capabilities and allows city inspectors to perform their quality assurance work. Then you inspected the scene in ArcGIS Online and tested the search capabilities. This sharing method, which can also enable feature editing, is well suited for more advanced uses.

In this tutorial, you published two 3D scenes to ArcGIS Online to visualize the planned De Zalmhaven complex within its urban environment. Using a first sharing method, you produced a web scene for the Rotterdam community at large, so that residents can better visualize the upcoming construction in the city center. Using the second sharing method, you produced a web scene that can be used by city inspectors to perform advanced tasks requiring search capabilities.

You can find more tutorials like this in the BIM and GIS learning path.