Design symbology for a thematic map in ArcGIS Pro

Symbolize polygons by color

In 2020, there were more than 270 million people in Indonesia, making it the fourth most populous country in the world. The population is distributed unevenly across thousands of islands. You'll symbolize the population of each of Indonesia's 34 provinces using colors. This kind of map—where each area is assigned a color based on a ratio—is known as a choropleth and is a common way to display quantitative data (such as population) for geographic regions.

  1. Download the IndonesiaPopulation project package.
  2. Locate the downloaded IndonesiaPopulation.ppkx file on your computer. Double-click the file to open it in ArcGIS Pro. If prompted, sign in to your ArcGIS account.
    Note:

    If you don't have ArcGIS Pro or an ArcGIS account, you can sign up for an ArcGIS free trial.

    The map has three thematic layers—Cities, Roads, and Provinces—and two basemap layers. You'll symbolize the provinces polygons first, because it is the most important layer in your map. You'll turn the other layers off for now, so you can focus better on the provinces.

  3. In the Contents pane, check the boxes next to Cities and Roads to turn these layers off.
  4. Right-click Provinces and choose Symbology.

    Symbology in the context menu of the Provinces layer

    The Symbology pane appears. The provinces are symbolized with Single Symbol symbology, which is good when you only want to convey the location of things. But in this map, you also want to convey one of the layer's attributes: population.

  5. In the Symbology pane, click Single Symbol to view the other symbology methods.

    Several of the available methods draw quantities using colors.

  6. Click Graduated Colors.

    Graduated Colors

  7. Confirm that Field is set to Population.

    The map now shows more populous provinces in red and less populous ones in yellow. One way to test how well your symbols convey your intended message is to look at the legend.

  8. In the Contents pane, the legend shows five symbol classes, each with a long label to describe the values it represents.

    Provinces legend with discrete classes

    The cut-off values aren't necessarily meaningful, and they create a map that suggests that a value of 2,060,000 is more similar to 700,000 than it is to 2,050,000.

    You could choose better cut-off values, either by rounding them or choosing a different classification method. But for this map, categorizing the data is not necessary. The data is continuous, not discrete, and the goal of this map is to help a general audience visualize populations as either more or less than other provinces. Classifying the data into discrete partitions does not improve the clarity of this map.

  9. In the Symbology pane, change Primary symbology to Unclassed Colors. Confirm that the field is set to Population.

    The legend now shows that the symbol colors change gradually from a minimum value to a maximum value.

    Provinces legend with a continuous range

    This approach is simpler and more appropriate for the purposes of your map.

    Note:

    When are graduated colors more appropriate than unclassed colors? Sometimes a map is easier to understand if values are grouped into bins representing small, medium, or large values. Sometimes cut-off values are meaningful, for example, if governmental funding is available at different tiers.

    The symbology of this map still has a problem. Central Kalimantan (on the island of Kalimantan, or Borneo) and the Special Region of Yogyakarta (on the island of Java) appear to have similar populations. But one is many times larger than the other, so population density must be very different. This map is misleading because it doesn't indicate well where most of the population lives. Instead of mapping population, it would be better to map population density.

    Map of Indonesia with Central Kalimantan and Yogyakarta highlighted

    When mapping geographic areas with colors, it's important to normalize your data, usually by converting counts to rates or ratios. The point of normalization is to convert values to a standardized scale so that comparisons are meaningful. To normalize this population data, you'll divide the population of each province by its area to calculate the population density.

  10. In the Symbology pane, for Normalization, choose Area (square km).

    Normalization set to Area (square km)

    Now the colors on your map represent the number of people per square kilometer in each province.

    The map shows you that population density is far greater in the Special Capital Region of Jakarta than in any other province.

    Map of Indonesian provinces with Jakarta highlighted

    While this is true, it is not a very interesting map. It only tells you about one province, instead of all of them. You'll adjust the range of the color scheme to better show the comparisons between the other provinces.

    In the lower half of the Symbology pane, a vertical histogram shows the distribution of population density values. Most of the data is at the very top (low density), with one outlier—Jakarta—at the bottom (high density). Two bounding handles on the side of the histogram represent the cut-off values for the darkest and lightest colors. You'll adjust these handles to limit the influence of Jakarta and make variations between the other provinces visible.

  11. On the histogram, double-click the bottom handle (12940.643246) and type 1,500. Press Enter.

    The handle moves closer to the top of the histogram.

    Histogram with bottom handle set to 1,500

    Now all values greater than 1,500 draw with the darkest blue, reserving the range of colors between white and blue for the bulk of the data range.

    Choropleth map of Indonesia provinces in blue

    The map now shows that population density is highest on the island of Java. In fact, Java is the world's most populous island. You can also discern more variation on the islands of Borneo, Sumatra, and Sulawesi.

    Now that you have altered the range of the colors, the legend for this map may be deceiving. The legend ranges from 9.8 to 12,940.6 people per square mile, while the map colors only range between 9.8 and 1,500. You'll improve the legend so the symbology of your map can be more easily interpreted.

  12. In the Symbology pane, for Lower label, type 1,500 people or more per km2.

    You'll round the upper value to make it easier to read.

  13. For Upper label, type 10 people or fewer per km2.

    Upper label and Lower label fields in the Symbology pane

  14. On the histogram, edit the upper handle (9.816906) to 10.

    Histogram with upper handle set to 10

    You are almost done symbolizing the province polygons. The last thing you'll do is change the color scheme. All colors have connotations (which vary by culture). To many people, blue suggests water, so a casual map reader might think this map was about rainfall or flooding. Population and urbanism are often represented on maps with pinks or purples, since these colors are less common in nature.

  15. Click the Color scheme menu and check the Show names check box. Choose the Red-Purple (Continuous) color scheme.

    Show names

    Most map readers interpret dark colors to mean more while light colors mean less, so a good color scheme choice for a population map will be one that ranges evenly from light to dark colors.

    Note:

    On a map with a dark background, this pattern should be reversed. Read Smart Choices for Basemaps and Color Ramps When Mapping Demographic Data to learn more.

    You'll finish this layer by changing its name to make it clear to map readers what it represents.

  16. In the Contents pane, click Provinces and press F2. Rename the layer Provinces: Population density.
  17. On the Quick access toolbar, click Save to save the project.

    Save button

    You've now made a choropleth map that symbolizes the provinces of Indonesia by population density. You learned when to use unclassed colors versus graduated colors, why to use rates or ratios instead of counts, how to adjust the range of the symbology, and how to choose an appropriate color scheme. Next, you'll symbolize cities.

    Choropleth map of Indonesia provinces in pink

Symbolize points by size

For the cities of Indonesia, you'll vary the size of the symbols instead of the color. Because the point features have no area, you don't need to normalize the data into population density. You'll map population counts, with larger symbols for larger cities.

  1. In the Contents pane, click the Cities layer to select it and check it to make it visible.

    The Symbology pane updates to show symbology for the Cities layer.

  2. For Primary symbology, choose Proportional Symbols.

    Proportional symbols are similar to Unclassed colors, where the symbols range evenly and continuously from a minimum value to a maximum value.

  3. Confirm that Field is set to Population.

    Symbology pane for Proportional Symbols

    On the map, the capital Jakarta stands out as the largest city in Indonesia. Unfortunately, it also hides other important map information. You'll make the symbols transparent to prevent this problem. You'll also change the symbol color to match the darkest purple province.

    Map with proportional symbols

  4. In the Symbology pane, click the Template symbol.

    Template symbol in the Symbology pane

    The Symbology pane displays further symbol options.

  5. If necessary, click the Properties tab and the Symbol tab.

    Properties and Symbol tabs in the Symbology pane

  6. Click the Color menu and click Eyedropper.

    Eyedropper tool in the color picker menu

    This tool allows you to choose existing colors from your map.

  7. On the map, zoom to Jakarta until its dark purple color is visible behind the large point symbol. Click the dark purple color.

    Eyedropper tool extracting color from the Special Capital Region of Jakarta

    Now both the point and the polygon layers of the map will use the same color to represent the same theme: urbanism. Using similar colors for similar things makes your map easier to interpret. You'll save this color to a style so you can reuse it elsewhere in your map.

  8. In the Symbology pane, click the Color menu again and click Color Properties.

    The Color Editor window appears.

  9. Click Save color to a style. In the Save Color As window, for Name, type Population density.

    Save color to style

  10. Confirm that Style is set to Favorites and click OK.

    Now that you've saved a fully opaque version of the color for later use, you'll make the color transparent.

  11. For Transparency, type 80%.

    Transparency set to 80%

  12. Click OK.
  13. In the Symbology pane, for Outline color, choose the new Population density color.

    Outline color set to the dark purple Population density color

  14. For Outline width, click the Increment button or type 1 pt.

    Outline width set to 1 pt

    A thicker outline will make the smaller circles bolder and easier to see.

  15. Click Apply and zoom out until you can see all of Indonesia.

    Detail of map with transparent circle symbols

    The transparent circles no longer hide other parts of the map. This is important, because while Jakarta has 10 million people, there are also several other cities just outside of its boundaries with large populations of their own. Clearly the metropolitan area of Jakarta extends beyond the boundaries of its province.

    To finish this layer, you'll ensure that the legend is clear and does not take up too much space on your map.

  16. In the Symbology pane, click the back arrow. Above the histogram, click the Classes tab.

    Histogram tab in the Symbology pane

  17. Change Legend count to 2.

    In the Contents pane, the legend shrinks to only a small and large circle.

  18. Rename the Cities layer to Cities: Population totals.

    Cities: Population totals layer in the Contents pane

  19. Save the project.

    You've now symbolized points with size. You learned how to borrow colors from other map symbols, save a color to a style, and how to create transparent overlapping symbols

    The city points and province polygons work together to tell a story about population distribution. While the provinces carry the entire population—urban and rural—the cities provide more context about where most of the population is concentrated. In particular, they help to highlight the prominence of Jakarta.

Symbolize lines by type

The final thematic layer in your map is a line layer representing roads. Roads and road densities can often serve as a proxy for population and urbanism in maps. You will symbolize the roads based on their type.

  1. In the Contents pane, click the Roads layer to select it and check it to make it visible.
  2. In the Symbology pane, for Primary symbology, choose Unique values.

    So far in this lesson, you have symbolized quantitative data. Next, you'll symbolize qualitative data, or data that varies by types or categories rather than numeric values. Unique Values is the best choice for mapping types.

  3. Confirm that Field 1 is set to Type. Click the Add all values button.

    Add all values button

    A table appears on the Symbology pane, listing four symbol classes:

    • Major Highway
    • Road
    • Unknown
    • <all other values>

    The difference between major highways and roads will vary from one dataset to another. Knowing how many features of each category you have on your map will help you understand the role each type plays.

  4. Above the table, click the More button and check the Show count box.

    Show count

  5. If necessary, drag the side of the Symbology pane to make it wider.

    A Count column was added to the table.

    Count column in the symbol class table

    There are no features on your map in the <all other values> symbol class. This symbol class will only clutter your legend, so you will remove it.

  6. Right-click the <all other values> row and choose Remove.

    Of the remaining symbol classes, Unknown represents the majority of features on the map. There are only a few Major Highway lines, all of them near Jakarta. You'll group the Major Highway and Road classes together.

  7. Click the Major Highway row. Press the Ctrl key and click the Road row to select both rows. Right-click the selected area and choose Group values.

    Group values

    There are now only two symbol classes. Often, your data will have more symbol classes than are needed on your map. Combining them into a simpler set of symbols will make a map that is easier to interpret. Next, you'll improve the legend.

  8. In the Label column, double-click the Major Highway; Road cell. Type Primary roads.
  9. Change the label for the Unknown symbol class to Secondary roads.

    Label column in the symbol class table

    The pale symbol colors are hard to see on the map. You'll make them darker and give them a dashed pattern to help distinguish them from the province borders.

  10. Click the More button and choose Format all symbols.

    Format all symbols

  11. Click the Gallery tab and click the Ferry symbol.

    Ferry symbol in the symbol gallery

    You do not have any ferry route lines on your map, but preconfigured symbols intended for other purposes can be useful starting points for your own symbols.

  12. At the top of the Symbology pane, click the back arrow.

    Both symbol classes are now represented with dashed blue lines.

  13. Click the Primary roads row so it is the only one selected. Right-click its symbol and choose the Gray 80% color. (Point to colors to read their names.)

    Changing a road symbol to dark gray

  14. Right-click the Secondary roads symbol and choose Gray 50%.
  15. Save the project.

    Detail of map with dashed lines for roads

    You've now symbolized lines by type. You learned how to group and rename symbol classes and redesign template symbols for your own purposes. In this lesson, you symbolized one layer at a time. When you work on your own map projects, you will often switch back and forth between layers to ensure that all map symbols work together in a cohesive map design.

Customize the basemap

At the start of this lesson, your thematic map layers were drawn with default symbols, which you changed to better communicate the data. But your map has at least one more layer that should not be left in its default state: the basemap. Next, you'll learn how to mix and match basemap layers to create a simple background that complements your thematic data, rather than distracting from it.

Your map currently uses the World Topographic Map and World Hillshade layers as the basemap. These detailed layers are useful for exploring your data in its geographic context. However, their variety of colors and textures also distract from the focus of your map. Instead of thinking about population density in Indonesia, a map reader's attention may be captured by the ocean trench bordering Java and Sumatra or forest cover in Papua New Guinea.

Detail of map showing New Guinea

A simpler, more neutral background is a better choice for a thematic map. Next, you'll choose a gray basemap that better supports your thematic data.

  1. On the ribbon, click the Map tab. In the Layer group, click Basemap.
  2. In the basemap gallery, scroll down and choose Human Geography Map.

    Human Geography Map in the basemap gallery

    Note:

    If Human Geography Map is not listed in the basemap gallery, open the Catalog pane. On the Portal tab, on the Living Atlas tab, search for the following layers and add them to your map:

    • Human Geography Detail
    • Human Geography Label
    • Human Geography Base

    Add Human Geography layers to the current map

    The contents of the basemap gallery are set by your organization's administrator.

    The map updates. The new map background now appears simpler and better highlights the thematic content. Map with a gray basemap

    Gray is a useful basemap color because it is typically interpreted as no data. Being pale and desaturated allows it to read as background information, rather than foreground. However in the case of the Indonesian archipelago, most of the map is water, so the majority of the map is grey. You may find this to be a bit drab. Next, you'll change the color of your basemap to change the tone of your map.

  3. Open the Catalog pane.
    Tip:

    On the ribbon, click the View tab. In the Windows group, click Catalog Pane.

  4. In the Catalog pane, click the Portal tab and click the Living Atlas tab. In the search bar, type Global Background.

    Add Global Background layer to the current map

  5. In the search results, right-click Global Background and choose Add to Current Map.

    This layer is a large rectangle that covers the entire world. You'll use it to change the color of all the layers underneath it. It is added to the map above the provinces layer. You only want it to affect the basemap, so you'll reorder the layer.

  6. In the Contents pane, drag the GlobalBackground layer and place it between the Provinces: Population density and the Human Geography Base layers.

    Dragging the GlobalBackground layer in the Contents pane

  7. Right-click the GlobalBackground symbol and choose Deep Forest.

    Changing the GlobalBackground layer color to Deep Forest

    The green color is very dark and overwhelms the map. You'll make the green layer blend with the layers underneath, instead of hiding them.

  8. In the Contents pane, make sure the GlobalBackground layer is selected. On the ribbon, click the Appearance tab. In the Effects group, for Layer Blend, choose Screen.

    Layer Blend set to Screen on the ribbon

    Layer blending determines how layers combine with the layers underneath. The expected result for this blend mode is to recolor everything except white to a shade of green. But instead the map returns to gray. You'll investigate the basemap to discover why it was not recolored.

    The Human Geography Map basemap contains three layers. Human Geography Label and Human Geography Detail draw on top of your thematic map layers, while Human Geography Base draws underneath. Layer order is an important aspect of symbology.

  9. In the Contents pane, turn the Human Geography Detail layer off and on again.

    This layer carries most of the basemap information. The green layer is drawing underneath the Human Geography Detail layer and therefore has no effect on it.

  10. Drag the Human Geography Detail layer to the bottom of the layer list.

    Move the Human Geography Detail layer to the bottom of the layer list

  11. Right-click Human Geography Base and choose Remove.

    This layer only contains a pale background for land areas and isn't needed in your map.

    The basemap changes from gray to green, colored by the GlobalBackground layer, which blends with anything drawing underneath it.

    Contents pane and a green basemap

    In addition to reordering, you can also add and remove basemap layers. Next, you'll add a hillshade layer to bring back some texture and topographic context.

  12. In the Catalog pane, on the Living Atlas tab, search for the World Hillshade layer and add it to your map.

    Add World Hillshade layer to current map

    The new layer is added to the map beneath all of the other layers. It is colored green by the GlobalBackground layer, but it is only visible in neighboring countries. It is hidden in Indonesia by the province polygons.

    Detail of map showing hillshade only visible outside of province polygons

    If you move the hillshade layer above the provinces, it will hide them instead. To get around this issue, you'll use another blend mode.

  13. In the Contents pane, select the Provinces: Population density layer. On the ribbon, click the Appearance tab. For Layer Blend, choose Multiply.

    Multiply is one of the most commonly used blend modes. In this situation, it allows both the provinces and the basemap layers underneath to be equally visible.

    Detail of map showing green hillshade blending with pink province polygons

    The green ocean complements the pink provinces nicely. However, the most common forms of color blindness make it difficult for many people to distinguish between reds and greens. While this map may look attractive, it may also be hard for some people to read. You'll change the ocean color to blue.

    Tip:

    You can use online tools such as this Color Blindness Simulator to test the legibility of your map.

  14. In the Contents pane, right-click the GlobalBackground symbol and choose Delft Blue.

    Changing the GlobalBackground layer color to Delft Blue

  15. Save the map.

    Map with blue basemap

    Basemaps are helpful resources for thematic maps, since you do not have to spend time building and symbolizing background geography. But just like every other map element, you don't need to use them in their default state. Choose a gray basemap to better present your thematic data. Try adding, removing, and reordering basemap layers, adjusting their transparency and layer blending, and even changing their color with a blended layer on top.

    An effective basemap elevates your thematic data, rather than distracting from it.

Export the map

You've now designed a map of population in Indonesia. To finish, you'll export the map as a .pdf file so you can print it or share it with others.

  1. Above the map view, click the Layout tab.

    Layout tab above map view

    This A4-sized layout has already been set up for you. However, you'll tidy the legend before you export it.

  2. In the Contents pane, expand Legend.

    Many of the layers in your map are basemap layers that don't need to be presented in the legend.

  3. Click Human Geography Detail. Hold the Ctrl key and click Human Geography Label, GlobalBackground, and World Hillshade so all four basemap layers are selected.
  4. Right-click the selected layers and choose Remove.

    Removing four basemap layers from the legend in the Contents pane

    The legend on the map is smaller, but it still contains redundant information that can be removed. For example, the layer name Cities: Population totals is followed by the heading Population. A cluttered legend takes longer to read and understand.

    Map legend with basemap layers removed

  5. In the Contents pane, right-click Legend and click Properties to open the Format Legend pane.
  6. Click Show properties.

    Show properties button on the Format Legend pane

  7. Under Show, uncheck the Headings box.

    The headings for all three layers are removed from the legend.

    Final map legend

    Note:

    You can continue to edit the legend, title, or other elements. To learn more about building layouts, see the Make a layout video and tutorial

    You're almost ready to export your map. Before you do, you'll take one more look to see if your symbols are working as well as they can. The road layer appears jumbled and crowded at the scale used by the layout.

    Detail of map with thick road symbols

    You'll adjust the line width to better suit this scale. You can make this change from the Layout view.

  8. In the Contents pane, expand Map Frame and Map. Right-click the Roads layer and choose Symbology.
  9. In the Symbology pane, click More and choose Format all symbols.
  10. Click the Properties tab. Under Appearance, change Line width to 0.5 and click Apply.

    Detail of map with thinner road symbols

    Tip:

    To ensure that you always design symbols to work at a particular scale, you can set a Reference scale in the Map Properties window.

    You are now ready to export the map.

  11. Save the project.
  12. On the ribbon, click the Share tab. In the Export group, click Layout.

    Export Layout button on the ribbon

    The Export Layout pane appears.

  13. For File Type, choose PDF.
  14. For Name, click the Browse button and choose a location you can easily access, such as your desktop. Name the file IndonesiaPopulation.pdf
  15. Specify the following properties:
    • Leave all check boxes unchecked except for Compress vector graphics and Embed fonts.
    • For Image compression, choose Adaptive.
    • Set Quality to approximately 80%.
    • For Vector resolution, choose 300 DPI.
    • Set Raster resample between Best and Normal and set Ratio 1 to 2.
    • For Layers and attributes, choose PDF Layers Only.

    Export Layout settings

    Note:

    You can read more about export settings at Export to PDF.

  16. Click Export.

    Finished map of Indonesia population

Designing an attractive and effective map does not require complex symbol effects, but it does require thought and experimentation. In this lesson, you learned some common techniques used by cartographers to design thematic maps, including the following:

  • How to choose colors that work well together and suit the map's theme
  • When to normalize your data
  • How to adjust a symbology histogram to better show a range of data
  • How to improve symbols with simple symbol property changes
  • How to improve a basemap by adding, reordering, and blending layers

Making a map requires making many choices, not just about map symbols. Try some of the resources listed below for further cartographic skills.

You can find more lessons in the Learn ArcGIS Lesson Gallery.