浏览数据

图像时间序列是在同一位置不同时间拍摄的一组图像,有助于了解某一区域随时间推移发生的变化。 例如,森林区域的图像时间序列可以展示树木何时被砍伐及随后如何重新生长,或者火灾或病虫害发生的时间和地点。 由于这些干扰通常伴随着图像像素值的骤变,因此图像时间序列分析会利用算法来检测这些变化。

ArcGIS Image Analyst 扩展模块提供了用于影像的两种时间序列变化检测算法。 LandTrendr 算法便是其中之一,它依赖 Landsat 影像,常用于森林领域的应用。 由于 Landsat-TM 影像自 1984 年以来实现了对地球陆地表面的持续覆盖,因此可以利用其监测多年来土地覆被的变化。

首先,您将熟悉俄勒冈州西喀斯喀特地区的多维栅格。 多维栅格是用于表示图像时间序列的数据集模型。 接着,您将准备用于分析的图像时间序列,并探索图像中单个像素的土地覆被变化。

探索多维栅格

首先,您将下载一个包含本教程所有数据的工程,并在 ArcGIS Pro 中将其打开。 随后,您将熟悉在整个教程中需要使用的多维栅格数据集。

  1. 下载 Forest_Disturbance_Analysis 工程包。
  2. 浏览至下载的文件并双击以在 ArcGIS Pro 中打开该工程。 如有必要,请使用您获得许可的 ArcGIS 账户进行登录。
    注:

    如果您没有 ArcGIS Pro 的访问权限或者 ArcGIS 组织账户,请参阅软件访问权限选项

    该工程包含一张俄勒冈州西喀斯喀特地区的影像地图。

    默认工程

    内容窗格中列出了工程中的图层。 WestCascade.crf 图层包含 1984 年至 2020 年间在西喀斯喀特地区采集的 78 张 Landsat 分析准备就绪影像 (ARD) 卫星影像组成的时间序列。 每个图像都表示为一个多波段栅格,其中包含蓝色、绿色、红色、红外和短波红外光谱波段。 这些图像均在夏季采集,因此树木处于枝繁叶茂且生长阶段相似的状态,这对于满足您将在本教程中使用的 LandTrendr 算法的要求至关重要。 此外,仅包含云覆盖率低于 10% 的图像。 所有这些栅格都被收集到一个单一的以 CRF 格式存储的多维栅格中

    注:

    若要将本教程中的工作流应用到您自己的研究区域,您可以通过从 USGS EarthExplorer 下载感兴趣区域的 Landsat ARD 图像,来创建类似的多维栅格。 要了解如何清理图像并生成多维栅格,请阅读清理 Landsat 影像:去除云和云阴影

    接下来,您将浏览 WestCascade.crf 中包含的 78 张图像,并查看每张图像的采集时间。

  3. 内容窗格中,单击 WestCascade.crf 图层以将其选中。

    “内容”窗格中的 WestCascade.crf

    选择多维数据集时,功能区中会出现多维选项卡。 该选项卡包含用于处理多维栅格的工具。

  4. 在功能区中,单击多维选项卡。

    多维选项卡

  5. 当前显示剖切组中,展开 StdTime 下拉列表。 单击列表中的第二个值(以日期 1984-07-19 开头)。

    StdTime 下拉菜单

    该地图随即进行更新以显示 1984 年 7 月 19 日拍摄的图像。 在像 WestCascade.crf 这样的影像时间序列中,单张图像被称为一个时间片。 刚刚显示的图像是系列中的第二个时间片。

    地图上的第二个时间片

    内容窗格中,图层的图例显示了用于显示图像的光谱波段。

    WestCascade.crf 图层的图例

    图像使用自然色波段组合显示,其中波段 1 为蓝色,波段 2 为绿色,波段 3 为红色。 这种波段组合近似于景观在人眼中的呈现方式。 该图像还包含一个红外波段(波段 4)和两个短波红外波段(波段 5 和波段 6)。 尽管这些波段当前未显示,但您稍后将会使用它们。

    注:

    要了解有关多光谱影像和波段组合的详细信息,请参阅影像入门教程。

    图像的大部分区域为森林(显示为绿色),但图像中央也有一些林木采伐区域(显示为米色)。

    地图上的采伐迹地

    您还可以对时间序列制作动画,从而按顺序查看所有图像。

  6. 多维选项卡的当前显示剖切组中,单击沿 StdTime 播放时间片按钮。

    沿 StdTime 播放时间片按钮

    时间序列将以动画形式播放,每隔几秒切换并显示一张新图像。 森林在相邻图像之间的变化有时非常显著,有时则微乎其微。

    注:

    部分图像包含 NoData 区域,在图层中表现为孔洞。 这些区域对应于已被掩膜过滤掉的云像素,不会对分析造成影响。

  7. 播放完毕后,再次单击沿 StdTime 播放时间片按钮即可停止动画。

    接下来,您将查看图层属性。

  8. 内容窗格中,双击 WestCascade.crf 图层。

    随即出现图层属性窗口。

  9. 单击选项卡。 展开多维信息SRStdTime 部分。

    “图层属性”窗口中的“源”选项卡

    计数值表示该数据集包含 78 个时间片。 SR 像素值对应于表面反射率。 时间范围值是从 1984-07-032020-08-23

  10. 关闭图层属性窗口。

    综上,WestCascade.crf 图层共包含 78 张多光谱图像。 每张图像包含 6 个光谱波段。 这意味着该数据集总共包含 468 个栅格。 下图展示了该多维栅格的结构:

    多维栅格结构

应用指数公式

您将使用 LandTrendr 算法来分析图像时间序列。 LandTrendr 使用多维栅格,其中每个时间片都是一个单波段栅格。 然而,当前的时间片包含 6 个波段。 为了在每个时间片中提取单波段栅格,您需要对时间序列应用指数公式。 您将使用归一化燃烧比 (NBR) 指数,该指数能有效区分健康森林与森林干扰,常用于检测森林过火迹地。

注:

如需了解有关 NBR 指数的详细信息,请参阅利用卫星影像评估火灾后迹地教程。

  1. 内容窗格中,确保 WestCascade.crf 图层以将其选中。
  2. 单击功能区上的影像选项卡。 在工具组中,单击指数

    功能区中的“指数”按钮

  3. 在指数列表的景观下,单击 NBR

    指数列表中的 NBR 选项

    随即弹出 NBR 窗口。 NBR 指数通过数学公式将近红外与短波红外波段结合起来。 在该图层中,这两个波段分别对应于波段 4 和波段 6。

  4. NBR 窗口中,将近红外波段指数设置为 4 - Band_4。 将短波红外波段指数设置为 6 - Band_6

    NBR 工具参数

  5. 单击确定

    一个名为 NBR_WestCascade.crf 的图层被添加到地图中。 这个图层仍为多维栅格,但每个时间片只包含一个 NBR 栅格波段。

    注:

    NBR 工具是可动态生成新栅格图层的栅格函数。 这种方法可以节省处理时间,但新图层仅保存在计算机的内存中。 将该图层从工程中移除后,它就会被彻底删除,届时您需要重新创建它。

    默认情况下,该图层使用黑白拉伸渲染器显示。 接下来您将更改符号系统,以突出健康植被与受干扰区域(即健康植被缺失处)之间的差异。

  6. 内容窗格中,右键单击 NBR_WestCascade.crf 符号,然后展开色带下拉列表。 选中显示名称复选框,然后选择粉-绿色(连续)色带。

    粉-绿色(连续)色带

    地图上的符号系统随即更新。 最高的 NBR 像素值代表健康森林,显示为绿色。 最低的 NBR 像素值代表受干扰区域,显示为紫色。 具有中度值的 NBR 像素以白色或浅绿色表示。

    采用粉-绿符号系统的 NBR 地图

    该新图层同样是一个时间序列。

  7. 内容窗格中,确保已选择 NBR_WestCascade.crf 图层。
  8. 在功能区中,单击多维选项卡。 在当前显示剖切组中,展开 StdTime 下拉列表并选择 1984-07-19 时间片。

    地图将更新显示该日期的图像,且其符号系统保持一致。

  9. StdTime 重新设置回第一个时间片 (1984-07-03)。

绘制单个像素的变化图表

接下来,您将利用 NBR 时间序列来探索森林随时间推移发生的变化。 在整个教程中,您将通过多种不同的方式监测森林变化。 首先,您将通过像素时间序列变化浏览器窗格监测单个像素的变化。

地图当前显示的是 1984 年 7 月 3 日的 NBR 栅格。 如果在该栅格上选择单个像素,并观察其在 1984 至 2020 年间(跨越全部 78 个时间片)的值变化,可以将这些数据绘制成折线图,如下所示:

显示像素值随时间变化的图表

随后,您可以使用 LandTrendr 算法在图表中检测整体变化趋势。 LandTrendr 将定位像素轨迹发生变化的拐点,并将数据拟合为分段线性模型。 拟合结果将是一条由连接相邻拐点的若干线段组成的曲线,如下图所示:

显示拟合到分段线性模型中的数据的图表

每个段代表一个时间段内发生的变化,包括开始时间、结束时间、持续时间、斜率和幅度(即开始时间和结束时间之间发生的变化程度)特征。 在示例图中包含三个线段:

  • 第一段代表健康森林(NBR 值高且稳定)。
  • 第二段表示干扰,例如采伐(NBR 值迅速下降)。
  • 第三线段代表随着树木重新生长的森林恢复过程(NBR 值缓慢增加)。

您将为自己的数据生成一个类似的图表。

  1. 内容窗格中,确保已选择 NBR_WestCascade.crf
  2. 在功能区多维选项卡上的分析组中,单击时间剖面下拉箭头,然后选择像素时间序列变化浏览器

    “像素时间序列变化浏览器”选项

    随即显示一个空白图表视图和图表属性窗格。

  3. 图表属性窗格中的数据选项卡上,对于变化检测方法,选择 LandTrendr

    LandTrendr 选项

    注:

    可能会弹出一个警告,提示构建转置(针对时间序列分析进行优化的附加存储)可提高分析性能。 虽然 NBR_WestCascade.crf 栅格函数图层未构建转置,但底层的 WestCascade.crf 多维栅格已包含该属性。 您可以忽略该警告。

    为方便起见,目标绘图点已在像素位置图层中进行了标记。

  4. 内容窗格中,选中像素位置复选框。

    像素位置复选框

    地图上将显示一个绿色点。 您可以使用书签导航到该位置。

  5. 单击功能区上的地图选项卡。 在导航组中,单击书签并选择像素点书签。

    像素点书签

    地图将自动跳转至该点所标记的像素。 接下来您将为该像素生成图表。

  6. 图表属性窗格的定义像素位置下,单击按钮。

    “点”按钮

  7. 在地图中,单击感兴趣的像素。

    地图上的目标像素

    将在地图上添加一个灰色位置点。 在图表属性窗格中,将在像素位置列表中添加一行。 在为该像素位置生成图表之前,您将选择一些样式选项。

  8. 图表属性窗格的像素位置行中,在符号下,单击该点符号并选择克里特蓝色

    颜色选取器中的“克里特蓝色”选项

    注:

    将鼠标指针悬停在图像上即可查看其名称。

  9. 将大小设置为 3

    符号大小参数

  10. 模型参数下方,针对显示拟合曲线使用,单击颜色线并选择电子金色

    颜色选取器中的“电子金”选项

  11. 将线宽更改为 3

    线宽参数

  12. 模型参数下,单击拟合并创建图表

    在图表窗格中,将显示一个图表。

    显示像素随时间变化的图表

    蓝色点代表 78 个时间片的像素值。 橙色折线则是利用 LandTrendr 算法计算出的拟合曲线,反映了其总体变化趋势。

探索像素变化图表

接下来,您将探索该图表。

  1. 在图表窗格中,将鼠标悬停在其中一个蓝色数据点上。

    时间片的年份及其 NBR 值

    弹出的提示框中将显示该时间片的年份及其对应的 NBR 值。

    橙色拟合曲线由若干线段组成,每段均对应像素演变历史中的一个重要阶段。 图表图例标明了各拟合曲线段的起始与结束时间。

    图表图例

    提示:

    单击图例中的任一项目,可在图表上切换显示或隐藏对应的线段。

    当前包含五个线段。 这可能不是分析或理解该数据的最佳线段数。 您可以调整该拟合曲线的线段数量。 根据您的数据集,可以通过反复试验来确定最佳线段数。

  2. 图表属性窗格中,展开模型参数组。 将最大线段数更改为 4

    “最大线段数”参数

    注:

    有关各模型参数的详细信息,请参阅使用 LandTrendr 分析变化文档。

  3. 单击拟合并更新图表

    此时图表更新,仅保留四个线段:

    • 第一段具有较高的 NBR 值,表示稳定的成熟林区。
    • 第二段显示出显著的干扰。 健康森林比例迅速归零,这极有可能是由区域采伐所致。
    • 第三段表现出快速恢复曲线,此时该区域补植了树苗且生长相对迅速。
    • 第四段则表明植被恢复速度放缓,此时幼树正在稳步向成熟林演替。
  4. 在图表上,将鼠标悬停在这些曲线段上。

    段的拟合模型

    此时会弹出一个提示框,显示该段对应的拟合模型。 拟合模型由格式为 ax + b 的公式表示,其中 a 表示斜率,b 表示截距。 此外还会显示均方根误差 (RMSE) 值。

    为了更好地了解感兴趣区域的变化,您将检查相应的栅格图像。

  5. 在图表视图工具栏上,单击图例按钮。

    “图例”按钮

    此时图例会被隐藏,从而扩展了图表的显示空间。

  6. 在图表上,双击蓝色的顶点以选中对应的某一时间片。
    提示:

    或者,也可以拖动鼠标在该顶点周围绘制一个选择框。

    选择图表上的一个点

    地图随之会更新为该选中时间片对应的图像。

    注:

    如果在图表上精确选择某一点较为困难,您可以对图表执行放大操作。 在图表窗格工具栏中,单击缩放模式按钮并在感兴趣点的周围绘制一个框。

  7. 可视化下图中突出显示的四个时间片:

    要可视化的点

    地图上将呈现以下四个时间片:

    显示随时间变化的图像

    这些时间片清晰呈现了该像素位置的动态演变:从成熟林区到伐木迹地,随后演替为幼树,最终重新恢复为成熟林区。

  8. 关闭图表视图和图表属性窗格。
  9. 内容窗格中,取消选中像素位置复选框。
  10. 右键单击 NBR_WestCascade.crf 图层并选择缩放至图层

    “缩放至图层”选项

    您将返回到数据的全图范围。

  11. 快速访问工具栏中,单击保存工程按钮。

    快速访问工具栏上的“保存工程”按钮

    工程已保存。

至此,您已在 ArcGIS Pro 中完成了工程设置、熟悉了多维栅格,并探索了单个像素处的森林变化。 接下来,您将把对森林变化的观测尺度,从单像素扩展至整幅图像。


检测干扰和恢复

为了分析图像中所有像素的变化,您将首先生成一个变化分析栅格。 然后,您将创建森林干扰地图,以识别整个森林历史中的伐木和火灾等事件。 最后,您将创建一张森林恢复图,以评估受干扰区域恢复为成熟森林所需的时间。

创建变化分析栅格

您将通过使用 LandTrendr 分析变化工具来生成变化分析栅格。 该工具使用与像素时间序列变化浏览器工具相同的 LandTrendr 算法,但它将其应用于多维栅格中的所有像素,而非仅单个像素。 输出将为变化分析栅格,用于捕获有关每个像素的拟合曲线的信息。

  1. 内容窗格中,确保已选择 NBR_WestCascade.crf 图层。
  2. 在功能区中,单击多维选项卡。 在分析组的工具库中,单击更多按钮。

    多维工具库的“更多”按钮

  3. 单击使用 LandTrendr 分析变化工具。

    “使用 LandTrendr 分析变化”工具

    地理处理窗格中随即显示该工具。

  4. 对于输出多维栅格,输入 WestCascade_change_analysis.crf

    “使用 LandTrendr 分析变化”工具参数

    您需要保持其他参数不变。

    注:

    此工具的输出是一个多维栅格,每年只有一个时间片。 在进行 LandTrendr 变化分析之前,该工具会选择输入栅格中每年可用的最佳像素值。 对于给定年份,最佳像素值是来自最接近捕捉日期参数(默认为 6-30 或 6 月 30 日)的时间片中的像素值。 如果由于云而最佳像素值恰好是 NoData,则该工具会从下一个最近的时间片中获取像素值。

  5. 单击运行
    注:

    该过程可能会运行 15 分钟或更长时间。 也可能在完成之前不显示进度。

    随即运行该过程。 完成后,输出栅格将显示在内容窗格中,并且其第一个栅格波段显示在地图上。

    WestCascade_change_analysis.crf 图层是一个包含 34 个时间片的多维栅格,接近每年一个切片(其中某些年份没有任何数据)。 每个时间片都是一个多波段栅格,其中波段用于存储有关 LandTrendr 拟合模型的信息。 您将探索并显示这些栅格波段。

  6. 内容窗格中,单击 WestCascade_change_analysis.crf 符号。

    WestCascade_change_analysis.crf 的符号

    随即显示符号系统窗格。

  7. 符号系统窗格中,针对波段,展开下拉菜单。

    波段下拉菜单

    如果公式 ax + b 表示一段拟合曲线的拟合模型,则适用以下内容:

    • Slope 波段用于存储值 a,其将变化方向描述为递增或递减。
    • Intercept 波段用于存储值 b
    • Fitted_Value 波段用于存储在给定时间内来自拟合模型的插值。 在这个数据集中,它是每个时间片的输入 NBR 值的近似值。
    • RMSE 波段用于存储拟合曲线的均方根误差。
    • Change_Magnitude 波段用于存储变化幅度,即变化周期开始和结束时拟合值之间的差异。
    注:

    列出的所有波段名称都以 Band_1 开头(例如 Band_1_Slope),因为它们源自 NBR 栅格,而该栅格的每个时间片只有一个名为 Band_1 的波段。

    使用此变化分析栅格,您可以提取变化信息,例如变化日期、变化持续时间和变化幅度。 在教程的其余部分,您将使用此多维栅格作为输入来执行各种变化检测任务。

    当前地图上显示的是 Band_1_Slope 波段。 接下来,您将显示另一个波段。

  8. 在波段列表中,选择 Band_1_Fitted_Value

    地图随即更新。

    地图上的拟合值波段

    深绿色区域代表最低的 NBR 拟合值,深紫色区域代表最高的 NBR 拟合值。 您还可以利用多维选项卡上的 StdTime 选项,直观查看不同时间片的 Band_1_Fitted_Value 波段。

  9. 关闭符号系统窗格。

绘制干扰图

现在您已经有了变化分析栅格,可以用它来绘制其他信息。 首先,您将通过使用变化分析栅格检测变化工具绘制森林干扰随时间变化的地图。 您在运行该工具时设置的参数将提取拟合 NBR 值突然减小的事件,这标志着从健康森林到无树木状态的突变。

  1. 内容窗格中,确认已选择 WestCascade_change_analysis.crf 图层。
  2. 在功能区多维选项卡的分析组中,展开工具库,然后选择使用变化分析栅格检测变化

    “使用变化分析栅格检测变化”按钮

    该工具随即显示在地理处理窗格中。

  3. 对于输出栅格,输入 Disturbance.crf

    您需要将变化方向设置为仅检测减小的变化,以确保捕获健康森林受到干扰的区域。 您还将追踪最早发生变化的时间,以便了解干扰何时开始。

  4. 对于变化方向,选择递减。 对于变化类型,选择最早变化时间

    “使用变化分析栅格检测变化”工具参数

    在运行工具之前,您还将对结果进行过滤,以指定持续时间不超过 4 年的事件(标志着突变),且 NBR 值从 0.7 至 1 之间的较高值(健康森林)下降到 -1 至 0.35 之间的较低值(无树木)。 通过查看 Band_1_Fitted_Value 栅格波段中健康森林和采伐或火灾区域的典型值来选择这些像素值范围。

  5. 展开按属性过滤部分。 设置以下参数:
    • 选中按持续时间过滤复选框。
    • 对于最长持续时间(以年为单位),输入 4
    • 选中按起始值过滤复选框。
    • 对于最小起始值,输入 0.7
    • 对于最大起始值,输入 1
    • 选中按结束值过滤复选框。
    • 对于最小结束值,输入 -1
    • 对于最大结束值,输入 0.35

    按属性过滤参数

  6. 单击运行

    Disturbance.crf 图层随即创建并添加到地图中。 它是一个单波段栅格,而非多维栅格。 各像素值代表采伐或火灾事件开始日期。

  7. 关闭地理处理窗格。
  8. 内容窗格中,关闭 WestCascade_change_analysis.crfNBR_WestCascade.crf
  9. 在地图上,单击一个受干扰区域。

    随即显示一个弹出窗口,其中显示了干扰事件的开始日期。

    干扰弹出窗口

  10. 关闭弹出窗口。

填充缺失值

Disturbance.crf 栅格中,受干扰区域内存在一些 NoData 像素,这些区域没有足够的信息来计算有效模型。 然而,这些区域很可能与周围像素具有相同的干扰值。 您将使用附近像素内的多数值,通过统计数据栅格函数填充这些 NoData 区域。

  1. 单击功能区上的影像选项卡。 在分析组中,单击栅格函数按钮。

    栅格函数按钮

    随即显示栅格函数窗格。

  2. 栅格函数窗格中,搜索 Statistics。 在统计组中,单击统计数据

    “统计数据”按钮

    您将设置工具参数,以便对于每个 NoData 像素,该工具会查看其周围 3×3 像素的方框,并选择该方框中出现频率最高的值。

  3. 对于栅格,选择 Disturbance.crf
  4. 对于统计类型,选择众数。 确认行数列数均设置为 3
  5. 选中仅填充 NoData 像素复选框。

    统计栅格函数参数

  6. 单击新建图层

    新栅格图层 Statistics_Disturbance.crf 将添加到地图中。 此图层更加平滑、整洁,受干扰区域内的空隙更少。 您将重命名该图层并更改其符号系统。

  7. 关闭栅格函数窗格。
  8. 内容窗格中,单击 Statistics_Disturbance.crf 使其名称处于可编辑状态。 输入 Smoother_Disturbance.crf 并按 Enter 键。

    Smoother_Disturbance.crf 图层

  9. 单击 Smoother_Disturbance.crf 符号。

    随即显示符号系统窗格。 您无需自己设置符号系统,而是导入一个为您准备好并包含在工程中的图层文件。

  10. 符号系统窗格中,单击选项按钮,然后选择从图层文件导入

    “从图层文件导入”选项

    随即出现导入符号系统窗口。

  11. 导入符号系统窗口中,双击 FoldersForest_Disturbance_Analysiscommondatauserdata。 选择 Disturbance_symbology.lyrx

    “导入符号系统”窗口

  12. 单击确定

    应用具有白色到紫色色带的新符号系统。

    地图上采用新符号系统的干扰

    深紫色区域代表近年来发生的干扰,白色或浅粉色区域代表较早年发生的干扰。 大多数干扰源自采伐活动,这些活动始于该区域的中心,并随着时间的推移向北和向南扩展。 东部和西部的大片区域没有采伐活动。

  13. 关闭符号系统窗格。
  14. 内容窗格中,右键单击 Disturbance.crf 并选择移除

检查干扰

接下来,您将查看森林干扰图层,以更好地了解西喀斯喀特森林中发生的采伐和火灾事件。 首先,您将把这些事件与联邦和州政府管理的森林保护区边界进行对比。

  1. 内容窗格中,开启 Forest management boundaries 图层。

    没有采伐活动的区域位于政府管理的保护区内。

    地图上的 Forest management boundaries 图层

  2. 单击功能区上的地图选项卡。 在导航组中,单击浏览下拉箭头并确认已选择顶部图层

    “顶部图层”菜单选项

    此选项可确保您仅显示内容窗格中列出的最上层图层的弹出窗口。 在此情况下,该图层即为 Forest management boundaries

  3. 在地图上,单击东侧的大片受保护森林区域以显示其弹出窗口。

    州立公园弹出窗口

    该区域是一个州立公园。 您将对其进行更详细的探索。

  4. 关闭弹出窗口。
  5. 在功能区的地图选项卡上,在导航组中,单击书签并选择 State park

    地图随即跳转至该公园。 公园中央的一些像素显示为深紫色,表明近年发生了干扰。

    地图上的 State park 书签

    这是在受保护森林中非法采伐的案例吗? 您将了解有关该特定事件的更多信息。

  6. 导航组中,单击浏览下拉箭头,然后选择可见图层

    “可见图层”选项

    此选项将确保弹出窗口显示所有已显示图层的信息,而不仅是顶层图层。

  7. 单击受干扰区域以显示弹出窗口。

    干扰年份

    在弹出窗口中,干扰日期列在 Smoother_Disturbance.crf 下。 该干扰发生于 2017 年。

  8. 关闭弹出窗口。

    您将使用并排显示来查看该区域对应的图像。

  9. 目录窗格中,展开地图。 右键单击 Source_Images,然后选择打开
    注:

    如果您未看到目录窗格,请单击功能区上的视图选项卡。 在窗口组中,单击目录窗格

    “打开”选项

    Source_Images 地图随即显示。 它显示了原始图像多维栅格 WestCascade.crf

  10. 拖动 Source_Images 选项卡并将其停靠在 Disturbance_Analysis 地图的右侧。

    右侧停靠区域

    您将链接这两个地图,以便它们显示相同的范围。

  11. 单击功能区上的视图选项卡。 在链接组中,单击链接视图下拉箭头并选择中心和比例

    “中心和比例”选项

  12. 放大并平移到州立公园中的受干扰区域。

    两个地图同步更新。 您将查看干扰事件发生后不久的某个日期的影像。

  13. 单击 Source_Images 地图选项卡以将其设置为活动地图。

    Source_Images 选项卡

  14. 内容窗格中,选择 WestCascade.crf
  15. 在功能区中,单击多维选项卡。 对于 StdTime,选择 2018-07-17 时间片。

    影像更新。 该区域看起来并不光秃,而是呈现褐色,这表明树木并未被采伐,而是受到了火灾的影响。

    地图之间受干扰区域的对比

    接下来,您将查看某些过去或最近的干扰事件在最新图像中的显示方式。

  16. 单击功能区上的地图选项卡。 单击书签并选择 Linked view
  17. 确保 Source_Images 地图选项卡处于活动状态。 在功能区的多维选项卡上,对于 StdTime,选择最近时间片 2020-08-23

    通过链接的地图,可以得出以下结论:

    • 许多最早发生干扰的区域(白色或浅粉色)现在已经重新长满了完全长成的树木,因为森林已得以恢复。
    • 在几年前发生干扰的区域(中紫色),现在分布着处于再生阶段的幼树。
    • 对于最近发生的干扰事件(深紫色),图像上显示的主要是裸露的土地。

    近期影像中的恢复情况

  18. 关闭 Source_Images 地图。
  19. 单击功能区上的视图选项卡。 单击链接视图按钮取消链接视图。

测量森林恢复

森林是一个包含干扰与恢复循环的动态系统。 例如,树木因木材采伐而被砍伐,然后重新种植新树木。 恢复过程通常比干扰事件要缓慢得多。 为了估算补植树木生长到成熟的恢复过程所需的时间长度,您将再次运行从变化分析检测变化工具。 这一次,您将提取 NBR 值增加(而非减少)的变化期的开始和结束日期。 然后,您将计算开始日期和结束日期之间的年数。 完整的工作流需要以下步骤:

  • 寻找恢复的变化期并提取变化的开始日期。
  • 再次运行该工具以提取变化的结束日期。
  • 计算两个日期之间的差值(恢复所需的天数)。
  • 将天数除以 365.25 以转换为年数。

为了节省时间,您无需手动执行所有这些步骤。 您将把整个工作流作为单一地理处理模型来运行:

地理处理模型

  1. 目录窗格中,展开工具箱Forest_Disturbance_Analysis.tbx。 双击计算恢复持续时间

    “计算恢复持续时间”模型

    地理处理窗格中随即显示,其中将该模型作为工具显示。

  2. 对于输入变化分析栅格,选择 WestCascade_change_analysis.crf。 关闭使用已过滤记录
  3. 对于输出恢复栅格,删除所有现有文本并输入 Recovery_years.crf
    注:

    如果您在输出恢复栅格旁看到警告符号,这是因为输出位置不存在。 为确保使用正确的输出位置,请务必在输入输出名称之前删除所有文本。

    “计算恢复持续时间”参数

  4. 单击运行

    片刻之后,输出栅格便会创建并添加到地图中。 这是一个单波段栅格,其中像素值为恢复的年数。

    内容窗格中的 Recovery_years.crf 图层

  5. 内容窗格中,右键单击 Recovery_years.crf,然后选择缩放至图层。 关闭 Forest management boundariesSmoother_Disturbance.crf

    您现在可以在地图上看到该图层。

    地图上的恢复图层

    许多采伐迹地呈深粉色,这意味着它们需要 11 到 15 年或更长时间才能恢复。 虽然干扰往往在极短时间内发生,但森林重新生长却需要相对漫长的时间。

  6. 关闭地理处理窗格。
  7. 保存工程。

利用变化分析栅格,您已绘制了干扰图并测量了森林恢复所需的时间。 接下来,您将通过对变化分析栅格进行分类,来分析森林的变化情况。


分类森林变化

为了更全面地了解西瀑布森林多年来的变化态势,需要为每个时间片分别生成森林分类图。 分类过程将为每个像素分配以下三个类之一:

  • 健康森林
  • 干扰
  • 恢复

对图像时间序列进行分类需要对每个时间片中的每个像素进行分类。 您将对在本教程前面部分中生成的派生变化分析栅格 WestCascade_change_analysis.crf 进行分类,而无需对原始图像时间序列 WestCascade.crf 进行分类。 分类工具将使用变化分析栅格的所有波段中存储的信息,包括 Fitted_ValueSlopeInterceptChange_Magnitude,来识别森林的当前状态。 时间序列分类的工作流与单幅影像分类相似,但每个训练样本均需在特定时间片上创建,并标注该时间片对应的日期。

注:

有关对单个影像进行分类的详细信息,请参阅根据光谱影像计算不可渗透表面教程。

您将执行以下工作流:

  • 加载分类方案。
  • 使用启用时间的训练样本管理器工具收集训练样本。
  • 选择一个分类器并在训练样本上对其进行训练。 在本教程中,您将使用随机树分类器
  • 使用经过训练的分类器对时间序列进行分类。
  • 创建一个图表来显示分类结果的汇总。

检查变化分析栅格

为了更好地理解分类过程,您将使用 RGB 符号系统检查变化分析栅格的各波段。 首先,您将设置一个新地图。

  1. 目录窗格的地图部分,右键单击 Classification 地图并选择打开

    地图随即打开,其中仅包含底图和 WestCascade.crf。 您还将添加变化分析栅格。

  2. 目录窗格中,依次展开 FoldersForest_Disturbance_Analysiscommondata。 右键单击 WestCascade_change_analysis.crf 并选择添加至当前地图

    “添加到当前地图”选项

    默认情况下,显示第一个时间片 (1984-06-30)。 您将更改时间片和符号系统。

  3. 内容窗格中,确保已选择 WestCascade_change_analysis.crf
  4. 在功能区中,单击多维选项卡。 对于 StdTime,选择 1987-06-30 时间片。
  5. 内容窗格中,单击 WestCascade_change_analysis.crf 符号。

    随即显示符号系统窗格。

  6. 符号系统选项卡上,设置以下参数:
    • 对于主符号系统,选择 RGB
    • 对于红色,选择 Band_1_Slope
    • 对于绿色,选择 Band_1_Fitted_Value
    • 对于蓝色,选择 Band_1_Change_Magnitude

    RGB 符号系统

    地图随即更新。 RGB 符号系统将三个波段组合为一张红、绿、蓝复合影像。 这种符号系统有助于识别不同的 SlopeFitted_ValueChange_Magnitude 值如何指示不同的森林状态。

  7. 单击功能区上的地图选项卡。 单击书签并选择 RGB 详细信息

    RGB 示例

    根据三个波段的数值,不同区域的颜色从亮绿色到亮粉色变化。 以下列表说明了每种颜色的含义:

    • 健康成熟森林 - 浅绿色:Fitted_Value 较高,Slope 大致平缓(接近 0)。 该区域覆盖着稳定的健康森林。
    • 健康成熟森林但即将被采伐 - 亮绿色:Fitted_Value 较高,Slope 呈强负值。 一片将在接下来的几个时间片中被采伐的健康森林。
    • 干扰 - 深绿色:Fitted_Value 为中等至极低,Slope 呈强负值。 树木正在被砍伐的受干扰区域。
    • 干扰但即将恢复 - 亮粉色:Fitted_Value 极低,Slope 呈强正值。 将在接下来的时间片中重新种植并开始恢复的受干扰区域。
    • 恢复 - 浅粉色:Fitted_Value 为中等,Slope 为正值。 当前处于恢复中的区域,幼树正在成长为成熟林木。
  8. 关闭符号系统窗格。
  9. 内容窗格中,右键单击 WestCascade_change_analysis.crf 并选择缩放至图层

    分类过程将使用存储在 Fitted_ValueSlope 和其他波段中的信息来决定如何对每个像元进行分类。

加载分类方案

现在您已经进一步了解分类过程将如何使用波段信息,您将通过加载分类模式来启动分类工作流。

注:

本教程提供了一个为您准备的分类方案文件。 要创建您自己的方案文件,请参阅训练样本管理器文档。

  1. 内容窗格中,确保已选择 WestCascade_change_analysis.crf
  2. 单击功能区上的影像选项卡。 在影像分类组中,单击分类工具并选择训练样本管理器

    “训练样本管理器”选项

    影像分类窗格随即显示,其中显示了默认方案。 您将加载特定于教程的方案。

  3. 影像分类窗格中,单击分类方案按钮。

    “分类方案”按钮

  4. 加载方案窗口中,依次双击 FoldersForest_Disturbance_Analysiscommondatauserdata。 单击 WestCascadeForestTypes.ecs

    “加载方案”窗口中的 WestCascadeForestTypes.ecs

  5. 单击确定

    该方案将显示在影像分类窗格中。 它列出了三个目标类,与三种森林类型相对应。

    “影像分类”窗格中的分类方案

采集训练样本

接下来,您将为影像分类采集训练样本。 首先,您将更改 WestCascade_change_analysis.crf 图层的符号系统,以便更轻松地识别好的采样位置。

  1. 内容窗格中,右键单击 WestCascade_change_analysis.crf 并选择符号系统
  2. 符号系统窗格中,设置以下参数:
    • 对于主符号系统,选择拉伸
    • 对于波段,选择 Band_1_Fitted_Value
    • 对于配色方案,选择绿色(连续)色带。

    拟合值的符号系统

    地图将更新以显示 NBR 拟合值。 最低值为白色,最高值为亮绿色。

    您应采集能代表所有三个目标类的样本,并在不同的时间片中选取示例。 您将创建的第一个样本对应于当前活动时间片 (1987-06-30) 中的健康森林。

  3. 关闭符号系统窗格。 在影像分类窗格中,单击健康森林类以将其选中。
  4. 单击按钮。

    “影像分类”窗格中的“面”按钮

  5. 在地图上,缩放至一片健康森林(亮绿色)。
  6. 在地图上单击以在健康森林内部勾勒面折点。 双击最后一个点即可完成面。

    地图上的健康森林面

    注:

    为了更好地识别样本位置,您还可以查看原始影像 WestCascade.crf 的同一时间片,作为拟合值视图的补充。

    影像分类窗格中,训练样本将被添加到样本列表中。

    样本列表中的第一行

    接下来,您将在 1992-06-30 时间片中创建一个干扰训练样本。

  7. 在功能区中,单击多维选项卡。 对于 StdTime,选择 1992-06-30 时间片。
  8. 影像分类窗格中,单击干扰类以将其选中。 单击按钮。
  9. 在地图上,确定一片受干扰森林区域(白色)并勾勒一个面。
    注:

    如果需要平移至显示受干扰森林区域的其他位置,请按住 C 键并使用鼠标进行平移和缩放。

    地图上的第二个面

    第二个训练样本将被添加到列表中。

    在实际工作流中,您将继续从不同的时间片创建训练样本,为所有三个类积累良好的示例。 但是,为了节省本教程的时间,将使用一组已为您准备好的训练样本。

  10. 影像分类窗格中,单击加载训练样本按钮。

    “加载训练样本”按钮

  11. 训练样本窗口中,依次双击 DatabasesForest_Disturbance_Analysis.gdb。 选择 WestCascade_training_samples

    训练样本文件

  12. 单击确定

    来自该文件的训练样本将添加到窗格中。

    “影像分类”窗格中的训练样本

    该列表包含约 80 个样本,每个样本都有一个类名和一个时间片日期。

  13. 双击列表中任意训练样本旁的行按钮。

    训练样本的行按钮

    在地图上,将在正确的时间片中显示相应的面。

  14. 关闭影像分类窗格。 在询问是否要保存修改的警告窗口中,选择

    您不需要对训练样本进行任何修改或保存。

  15. 内容窗格中,右键单击 WestCascade_change_analysis.crf 并选择缩放至图层
    注:

    这些训练样本是从使用与您的参数完全相同的参数生成的变化分析栅格中收集的。 如果您使用不同的变化分析栅格(例如,使用不同的捕捉日期参数值生成),则它不适用。

执行分类

接下来,您将使用这些训练样本训练一个分类器。 您将把它应用于时间序列,以对每个时间片中的每个像素进行分类。 首先,您将使用训练随机树分类器工具进行训练。

  1. 在功能区上,单击分析选项卡。 在地理处理组中,单击工具

    “工具”按钮

    将出现地理处理窗格。

  2. 在搜索框中,输入 Train Random Trees Classifier。 在搜索结果列表中,单击 Train Random Trees Classifier

    搜索结果列表中的 Train Random Trees Classifier 工具

  3. 对于输入栅格,选择 WestCascade_change_analysis.crf。 关闭使用已过滤记录
  4. 对于输入训练样本文件,单击浏览按钮。

    “浏览”按钮

  5. 输入训练样本文件窗口中,单击 Databases 并双击 Forest_Disturbance_Analysis.gdb。 选择 WestCascade_training_samples,然后单击确定
  6. 对于维度值字段,选择 StdTime
  7. 对于输出分类器定义文件,删除原有文本并输入 WestCascade_trained_classifier.ecd

    训练随机树分类器参数

  8. 单击运行

    该工具将生成一个 Esri 分类定义 (.ecd) 文件,其中包含每个类的统计信息和分类信息。 接下来,您将使用经过训练的分类器,通过分类栅格工具对整个时间序列进行分类。

  9. 地理处理窗格中,单击后退按钮。

    “地理处理”窗格中的“返回”按钮

  10. 搜索并打开分类栅格工具。
  11. 对于输入栅格,选择 WestCascade_change_analysis.crf。 关闭使用已过滤记录
  12. 对于输入分类器定义文件,单击浏览按钮。 依次展开 FoldersForest_Disturbance_Analysiscommondata
  13. 选择 WestCascade_trained_classifier.ecd,然后单击确定
  14. 对于输出分类栅格,键入 WestCascade_classification.crf

    “分类栅格”工具参数

  15. 单击运行

    该工具利用训练好的分类器中的信息,将变化分析栅格中每个时间片的每个像素分类为三个目标类之一。 多维 CRF 栅格被添加到地图中。 这是一个时间序列,其中每个时间片均由包含分类值的单个波段栅格组成。 默认情况下,显示 1984-06-30 时间片。

    内容窗格中的图例列出了三个类:

    • 深绿色区域被分类为健康森林
    • 亮粉色区域被分类为干扰
    • 浅绿色区域被分类为恢复

    地图上的分类图层

  16. 在功能区中,单击多维选项卡。 在当前显示时间片组中,单击沿 StdTime 播放时间片以动画方式显示时间序列。

    随着时间序列动画播放,健康森林图面成为干扰区域然后恢复。

  17. 观看完动画后,单击沿 StdTime 播放时间片以将其停止。

汇总变化

接下来,您将使用汇总分类栅格工具计算每个时间片中三个类的汇总统计信息。 该工具将计算分配给每个类的像素数。

  1. 地理处理窗格中,单击后退按钮。
  2. 搜索并打开汇总分类栅格工具。
  3. 对于输入分类栅格,选择 WestCascade_classification.crf。 关闭使用已过滤记录
  4. 对于输出汇总表,输入 Forest_class_table

    “汇总分类栅格”工具参数

  5. 单击运行

    该工具随即运行。 在内容窗格中的独立表下,将显示输出表。 接下来,您将创建一个条形图来显示表中包含的信息,并主要集中于 DisturbanceRecovery 类。

  6. 关闭地理处理窗格。
  7. 内容窗格中,右键单击 Forest_class_table,指向创建图表,然后选择条形图

    “条形图”选项

    随即显示图表属性窗格和一个空白图表视图。

  8. 图表属性窗格中,对于类别或日期,选择 StdTime。 对于聚合,选择总和

    “类别或日期”和“聚合”参数

  9. 对于数值字段,单击选择。 选中干扰恢复的复选框,然后单击应用

    图表属性

    随即显示图表。 您将对其进行格式设置并添加标注以改善显示效果。

  10. 图表属性窗格中,单击系列选项卡。

    “系列”选项卡

  11. 在字段列表中,对于 Disturbance,单击其符号并选择牡丹粉

    Disturbance 符号的“牡丹粉”颜色

  12. 对于 Recovery,单击其符号并选择浅苹果绿

    Recovery 符号的“浅苹果绿”颜色

  13. 图表属性窗格中,单击常规选项卡。 设置以下参数:
    • 对于图表标题,输入 Forest Classification (1984-2020)
    • 对于 X 轴标题,输入 Year
    • 对于 Y 轴标题,输入 Number of pixels

    图表常规选项卡

    图表随即进行更新。

    森林分类图表

    该图表显示了 35 年间的森林动态趋势。 它可帮助了解森林生态系统干扰与恢复之间的平衡。 森林动态具有明显的互补性趋势;当森林恢复率高时,森林干扰低,反之亦然。 例如,在 1992 年和 2002 年之间的 10 年间隔中,该图显示了森林恢复率高而森林干扰相对较低的反比关系。 在 1985 年至 1990 年和 2014 年至 2020 年期间,由于木材采伐,干扰相对于恢复有所增加,这些年份的影像证实了这一点。

  14. 保存工程。

森林覆盖变化分析对于评估森林健康和生物多样性至关重要,并可以支持森林管理、木制品生产、监测潜在非法采伐活动等。 满足这些需求需要以合理的成本和频繁的时间间隔监控大面积区域。 LandTrendr 是一种有效的绘图工具,用于检测和监测森林干扰和恢复。 它依赖于 Landsat 影像的时间序列来自动检测森林覆被的空间变化。

在本教程中,您使用了像素时间序列变化浏览器在像素级别检查了森林变化。 然后,您通过使用 LandTrendr 分析变化使用变化分析栅格检测变化工具创建了地图,从而显示森林干扰和恢复的模式和趋势。 最后,您使用随机树分类器将变化分析栅格分为三类,并创建了一个图表,其中显示了 35 年跨度内的森林动态趋势。

您可以在影像和遥感简介教程集中找到更多此类教程。

您可以在教程库中找到更多教程。