Create training samples

Inventorying and assessing the health of each palm tree on the Kolovai, Tonga, plantation would take a lot of time and a large workforce. To simplify the process, you'll use a deep learning model to identify trees, then calculate their health based on a measure of vegetation greenness. The first step is to find imagery that shows Kolovai, Tonga, and has a fine enough spatial and spectral resolution to identify trees. Once you have the imagery, you'll create training samples and convert them to a format that can be used by a deep learning model. For the model to recognize what it's tasked with finding, you need to define images of palm trees so that it can identify similar pixels.

Download the data

Accurate and high-resolution imagery is essential when extracting features. The model will only be able to identify the palm trees if the pixel size is small enough to distinguish palm canopies. Additionally, to calculate tree health, you'll need an image with spectral bands that will enable you to generate a vegetation health index. You'll find and download the imagery for this study from OpenAerialMap, an open-source repository of high-resolution, multispectral imagery.

  1. Download the Deep Learning file and unzip it to your C: drive.
    Примечание:

    The path must be C:\DeepLearning\Data, or the files that reference this path later will not work.

  2. Go to the OpenAerialMap website.
  3. Click Start Exploring.

    In the interactive map view, you can zoom, pan, and search for imagery available anywhere on the planet. The map is broken up into grids. When you point to a grid box, a number appears. This number indicates the number of available images for that box.

  4. In the search box, type Kolovai. In the list of results, click Kolovai.

    This is a town on the main island of Tongatapu with a coconut plantation.

  5. If necessary, zoom out until you see the label for Kolovai on the map. Click the grid box directly over Kolovai and click Kolovai UAV4R Subset (OSM-Fit) by Cristiano Giovando.

    Choose Kolovai image tile

  6. Click the download button to download the raw .tif file. Save the image to a location of your choice.

    Download imagery

    Because of the file size, download may take a few minutes.

Take a look at the data

To begin the classification process, you'll create an ArcGIS Pro project with the imagery you downloaded and save a few bookmarks to use while creating training samples.

  1. Start ArcGIS Pro. If prompted, sign in using your licensed ArcGIS account.
    Примечание:

    If you don't have ArcGIS Pro or an ArcGIS account, you can sign up for an ArcGIS free trial.

  2. Under New, click Map.

    The Map template creates a project with a 2D map.

  3. In the Create a New Project window, name the project CoconutHealth. Save the project to the location of your choice and click OK.

    The project opens and displays the Topographic basemap.

  4. In the Map tab, in the Layer group, click Add Data.

    Add data to the map

    The Add Data window appears.

  5. In the Add Data window, under Computer, browse to the Kolovai image you downloaded from OpenAerialMap. Select the .tif file and click OK.

    The Kolovai image is added to your map. The layer is listed in the Contents pane by its unique identifier, which isn't meaningful. It's best practice to rename the layer to something you understand.

  6. In the Contents pane, click the imagery layer two times and type Kolovai Palms. Press Enter.

    Rename the layer

  7. Pan and zoom around the map to get an idea of what the palm farm looks like.

    A large number of coconut palm trees are in this image. Counting them individually, on the field or by visually inspecting the image, would take days. To enable a deep learning model to do this work for you, you'll create a small sample of palm trees to use for training your model. First, you'll create a custom map display, so you can quickly zoom in on different areas of the image.

  8. At the bottom of the map window, click the map scale arrow and choose Customize.

    Create a custom scale extent

    The Scale Properties window appears.

  9. In the Scale Properties window, make sure the Standard Scales tab is selected. In the Scale box, type 1:500.

    Create custom scale

  10. Click Add and click OK.

    The custom scale option has been added to the list of map scales in your project. You'll use this scale each time you create a bookmark.

  11. On the ribbon, on the Map tab, in the Inquiry group, click Locate.

    Locate button

    The Locate pane appears.

  12. Into the Locate search box, paste the following coordinates and press Enter: 175.3458501°W 21.0901350°S.

    The letter A appears on your map to mark the location of the coordinates. You'll bookmark this location using the custom scale so you can refer to it in the next section.

  13. Click the map scale list and choose 1:500.

    You are looking at a zoomed-in display of the coordinate location in your map.

  14. On the ribbon, on the Map tab, in the Navigate group, click Bookmarks. In the menu, click New Bookmark.

    Create bookmark

    The Create Bookmark window appears.

  15. In the Create Bookmark window, type Northwest palms and click OK.
  16. Create bookmarks for the following coordinates at a scale of 1:500:

    CoordinatesBookmark name

    175.3413074°W 21.0949798°S

    Central east palms

    175.3479054°W 21.1018014°S

    Southwest palms

    175.3409475°W 21.1035265°S

    Southeast palms

    175.3479457°W 21.0959058°S

    Central west palms

  17. Close the Locate pane and save the project.

Create training schema

Creating good training samples is essential when training a deep learning model, or any image classification model. It is also often the most time-consuming step in the process. To provide your deep learning model with the information it needs to extract all the palm trees in the image, you'll create features for a number of palm trees to teach the model what the size, shape, and spectral signature of coconut palms may be. These training samples are managed through the Training Samples Manager. Before digitizing training samples, you'll set up a new schema within the Training Samples Manager.

  1. On the ribbon, click the Imagery tab.

    ArcGIS Pro works on a contextual basis, so certain tools and tabs will only be available to you if the associated data is selected from the Contents pane. To activate the imagery analysis tools, a raster layer must be selected.

  2. In the Contents pane, make sure Kolovai Palms is selected.

    Tools in the Image Classification, Mensuration, and Tools groups are now available to you. A new contextual tab Raster Layer with Appearance and Data tabs are activated.

  3. In the Image Classification group, click Classification Tools and choose Training Samples Manager.

    Image classification tool

    The Training Samples Manager pane appears with the default classification schema from the National Land Cover Database 2011 (NLCD2011). You'll create a schema with only one class because you're only interested in extracting coconut palm trees from the imagery.

  4. In the Image Classification pane, click the Create New Schema button.

    New training schema

    The NLCD2011 schema is removed from the Training Samples Manager pane. You'll rename the schema and add one class to the schema.

  5. Right-click New Schema and choose Edit Properties. For Name, type Coconut Palms. For Description, add a short explanation and click Save.

    The schema is renamed in the Training Samples Manager pane. You can now add samples to it.

  6. With the Coconut Palms schema selected, click the Add New Class button.

    Add a new class to the schema

    Примечание:

    If you don't see the button, try expanding the pane or clicking the drop-down arrow to see more options.

  7. In the Add New Class pane, set the following parameters:

    • For Name, type Palm.
    • For Value, type 1.
    • For Color, choose Mars Red.

    Class properties

  8. Click OK.

    The Palm class is added to the Coconut Palms schema in the Training Samples Manager pane. You'll create features with the Palm class to train the deep learning model in each bookmark you created.

Create training samples

To make sure you're capturing a representative sample of trees in the area, you'll digitize features throughout the image. These features are read into the deep learning model in a specific format called image chips. Image chips are small blocks of imagery cut from the source image. Once you've created a sufficient number of features in the Training Manager, you'll export them as image chips with metadata using a geoprocessing tool.

  1. On the ribbon, click the Map tab. In the Navigate group, click the Bookmarks drop-down button and choose the Northwest palms bookmark.
  2. In the Training Samples Manager pane, select the Palm class and click the Circle tool.

    Circle tool

    You'll use this tool to draw circles around each palm tree in your current display.

  3. On the map, click the center of a palm tree and draw a circle around a single tree.

    Make training samples

    A new palm record is added in the bottom pane of the Training Samples Manager pane. When training a deep learning model, each image chip must have all the palm trees within it labeled as a palm. The image chips will be much smaller than your current map display, but you'll create a palm record for every tree you can to ensure there are many image chips with all the palm trees marked.

  4. Draw circles around each tree in the map display.

    Palm tree training samples

    When you're finished, you'll have approximately 100 samples recorded in the Training Samples Manager pane.

  5. Create training samples for every palm tree on each bookmark.

    Overview of training data

    Примечание:

    The more samples to train the model with, the better the model performs classification.

    Digitizing training samples can be a time-consuming process, but it pays off to have a large number of samples. The more samples you provide the model with as training data, the more accurate results it returns.

  6. When you're done creating samples, in the Training Samples Manager pane, click Save.

    Save the training samples

  7. In the Save current training samples window, under Project, click Databases and double-click the default geodatabase, CoconutHealth.gdb.
  8. Name the feature class PalmTraining and click Save.

    The last step before training the model is exporting your training samples to the correct format, as image chips.

  9. On the ribbon, click the Analysis tab. In the Geoprocessing group, click Tools.

    The Geoprocessing pane appears.

  10. In the Geoprocessing pane, search for and open the Export Training Data for Deep Learning tool.
  11. In the Export Training Data for Deep Learning tool, enter the following parameters:

    • For Input Raster, choose Kolovai Palms.
    • For Output Folder, browse to the CoconutHealth folder, create a folder called ImageChips, and click OK.
    • For Input Feature Class Or Classified Raster, browse to CoconutHealth.gdb, click the Refresh button, and choose PalmTraining.
    • For Class Value Field, choose Classvalue.
    • For Image Format, choose JPEG format.
    • For Tile Size X and Tile Size Y, type 448.
    • For Meta Data Format, choose PASCAL Visual Object Classes.

    Export image chips for training

  12. Click Run.

    The tool runs. It may take several minutes to finish.

  13. In the Catalog pane, expand Folders and CoconutHealth. Right-click the ImageChips folder and choose Refresh.

    The folder is now populated with image chip samples and metadata.

  14. Save the project.

In this lesson, you downloaded and added open-source imagery to a project, created training samples using the Training Samples Manager pane, and exported them to a format compatible with a deep learning model for training. Next, you'll identify all the trees on the plantation.


Detect palm trees with a deep learning model

Clone the default conda environment

First, you created training samples of coconut palm trees and exported them as image chips. These training samples can be used to train a model using a deep learning framework such as TensorFlow, Keras, or CNTK. Optionally, you can use these samples to train your own deep learning model using the arcgis.learn module. Whether you plan to train the model or use the pre-trained model, you'll need to clone the default Conda environment in ArcGIS Pro to install the deep learning libraries that the geoprocessing tools rely on.

  1. On your desktop, search for and run the Python Command Prompt as an administrator.

    The Python Command Prompt was downloaded when you installed ArcGIS Pro, so it automatically runs the propy.bat initialization file. This file, which runs in place of python.exe, recognizes your application's active conda environment and allows you to run standalone scripts using that environment.

    For this project, you want to create a new environment named palm-detection. The default environment in ArcGIS Pro is read only, so you'll clone it to make changes.

  2. Run the following command to create a new conda environment by cloning the default ArcGIS Pro environment:
    conda create -n palm-detection –-clone arcgispro-py3

    The cloning process may take a few minutes. Cloned environments are stored in the envs folder at %LOCALAPPDATA%\Esri\conda\envs\. The system variable %LOCALAPPDATA% is a substitute for the C:\Users\YourUserFolderName\AppData\Local\.

  3. After the new environment is created, run the following commands to change your directory to that folder:
    cd C:\Program Files\ArcGIS\Pro\bin\Python\envs\palm-detection
    Примечание:

    If your ArcGIS Pro installation is not located in the Program Files folder, you must use your installation's path instead. There are several default folders that python environments can be cloned to. These include \AppData\Local\ESRI\conda\envs, as shown in the screen shot, and \ArcGIS\Pro\bin\Python\envs, and may vary depending on the previous active environment.

  4. Run the following command to activate the new environment and update the file path to match where you stored the cloned environment:
    activate palm-detection

    This may take a few minutes. When the activation process is finished, the active environment name appears in parentheses before the Activating the new environment specifies that all changes you make occur only in the selected environment. When doing multiple projects that need different packages or different versions of packages, this is important. Now, you'll install the packages that the arcgis.learn module needs to run.

    Activate new environment

  5. Run the following command to make sure you have the latest arcgis version installed as well as the deep learning dependencies:
    conda install arcgis --no-pin

    Примечание:
    The arcgis.learn module is available in version 1.6 and above of the Python API. ArcGIS Pro 2.3 was pinned with version 1.5.1, so if you encounter errors with the arcgis.learn module later, you may still need to update your version of the arcgis package and/or your version of ArcGIS Pro.

  6. Run the following command to install the deep learning package dependencies:
    conda install -c fastai -c pytorch fastai=1.0.39 pytorch=1.0.0 torchvision

    You now have a conda environment set up with all the libraries needed for the deep learning tools to run. In the next section, you'll use this environment to train your own model. Depending on your familiarity with Python, this process may add an hour to the lesson time, and may be challenging. If you want to use a model that's already been trained to continue working within ArcGIS Pro, skip to the Review the model section.

Train a deep learning model

Using the image chips you exported, you can train a model to recognize palm trees. One of the easiest ways to do this in the ArcGIS platform is to use the ArcGIS API for Python's arcgis.learn module. Using Jupyter Lab, you'll run a .ipynb file that trains a model using the SingleShotDetector method from the arcgis.learn module. Once you're finished training the model, you'll save it with an .emd file, or Esri Model Definition, that you'll use in ArcGIS Pro to detect palm trees in the imagery.

  1. Run the following command to change the directory to C:\DeepLearning\Data, where you downloaded the project data:
    cd C:\DeepLearning\Data

  2. Run the following command to open a Jupyter Lab instance:
    jupyter-lab

    The project data file included a Jupyter Notebook with instructions on training the model.

  3. In the file browser pane, double-click PalmDetectionModel.ipynb to open the notebook in a new tab.

    Open the Jupyter Notebook

    Примечание:

    For best results, run Jupyter Lab in Google Chrome. Firefox and Internet Explorer can work, but are less reliable.

  4. Run through the steps in the Jupyter notebook to produce the output model.

Review the model

The Detect Objects Using Deep Learning geoprocessing tool uses a trained deep learning model to extract features from a given input image. The training process produces an Esri model definition (.emd) file that is formatted to be read by ArcGIS geoprocessing tools. Based on the method used to train the model, the .emd file tells the tool which third-party deep learning Python API to use. You'll populate a .emd file, then use the Detect Objects Using Deep Learning tool to identify palm trees in the image.

If you trained your own model, skip to the Palm tree detection section.

  1. If necessary, open your CoconutHealth project in ArcGIS Pro.
  2. On the ribbon, click the View tab and choose Catalog Pane. Browse to the ImageChips folder you created in the CoconutHealth folder. Right-click the folder and choose Copy Path.

    Copy folder path

  3. Open File Explorer or any other file management system you use and paste the path to navigate to the ImageChips folder.

    ImageChips folder

    There are two folders, two text files, a .json and an .emd file that were created from the Export Training Data for Deep Learning tool. The esri_model_definition.emd file is a template that will be filled in by the data scientist who trained the model, with information such as the deep learning framework, the file path to the trained model, class names, model type, and image specifications of the image used for training. The .emd file is the bridge between the trained model and ArcGIS Pro.

  4. Open the .emd file in a text editor to explore the information it requires.

    The framework, ObjectDetection model configuration and type, and image specifications are listed.

  5. Close the esri_model_definition.emd file.

    Because this is only a template, you'll use the .emd provided with the lesson data. The esri_model_definition file provided in the ImageChips output folder is what you'd provide your data scientists with for training purposes.

  6. Open the CoconutTrees.emd file that was included in the lesson data. It is saved at C:\DeepLearning\Data.

    EMD file

    The framework specifies that the model framework runs within the arcgis.learn module. The ModelFile type is a .pth, or Pytorch model. These two lines tell you that the model relies on Pytorch to run. For example, if the Framework was Tensorflow and the ModelFile had a .pb extension instead, you'd know that the model relied on Tensorflow. You installed these packages earlier in the new environment, so you'll make sure it's active.

Palm tree detection

The bulk of the work in extracting features from imagery is preparing the data, creating training samples, and training the model. Now that these steps have been completed, you'll use a trained model to detect palm trees throughout your imagery.

  1. In ArcGIS Pro, on the ribbon, click the Project tab and choose Python.

    The Python Package Manager opens. Unless you've previously used different environments within ArcGIS Pro, the default environment, arcgispro-py3, is active. Environments created and activated in the command prompt are only persisted in that instance of the prompt unless you also set them as active in ArcGIS Pro.

  2. Under Project Environment, click Manage Environments.

    Manage environments in ArcGIS Pro

    All the environments you've created are listed in the Manage Environments window.

  3. Click palm-detection and click OK.

    In order for the new environment to be activated, you need to restart ArcGIS Pro.

  4. Save the project. Restart ArcGIS Pro and reopen your project.
  5. In the Geoprocessing pane, search for and open the Detect Objects Using Deep Learning tool.

    This tool calls a third-party deep learning Python API and uses the specified Python raster function to process the image.

  6. For the Detect Objects Using Deep Learning tool, enter the following parameters:

    • For Input raster, choose Kolovai Palms.
    • For Output Detected Objects, type CoconutTrees.
    • For Model Definition, navigate to CoconutTrees.emd (downloaded with the lesson data located in C:\DeepLearning\Data) or the .emd file that was created with the model you saved from the Jupyter Notebook.
    • For Batch Size, type 1.
    • Check the box for Non Maximum Suppression.
    • For Max Overlap Ratio, type 0.4.

    Additional arguments will appear in the tool window because of the information in the trained model. The data scientist that supplied you with the model should provide suggestions for each argument. More information about the arguments is provided if you want to experiment with different values. Otherwise, keep the default settings.

    The score_threshold argument is the confidence threshold—how much confidence is acceptable to label an object a palm tree? This number can be tweaked to achieve desired accuracy.

    When performing convolution of imagery in convolutional neural network modeling, you are essentially shrinking the data, and the pixels at the edge of the image are used much less during the analysis, compared to inner pixels. By default, the padding parameter is 0, but a padding parameter of 1 means an additional boundary of pixels is added to the outside edges of the image, all with a value of 0. This reduces the loss of information from the valid edge pixels and shrinking. You can change the parameter to 1 or 2 to see the effects.

    Padding pixels

    The batch_size parameter defines the number of samples that will be used to train the network in each iteration of training. For example, if you have 1,000 training samples (image chips) and a batch size of 100, the first 100 training samples will train the neural network. On the next iteration, the next 100 samples will be used, and so on. Depending on the memory your machine has available, you can increase this parameter, though training should only be done in perfect square batches. For example, you could use a batch of 4, 9, 16, and on.

    The tool could take some time to run for the full image, so if you want to experiment with other parameters, you'll change the processing extent to a smaller area.

  7. Zoom in to a scale of 1:500 somewhere in the image.
  8. Click the Environments tab on the Detect Objects Using Deep Learning tool. Change the Extent to Current Display Extent.
  9. Click Run. Once you see the results on a smaller scale, change the processing extent back to Default to process the entire image.
  10. If necessary, change the parameters for score Threshold, Padding, and Batch Size to 0.6, 0, and 1, respectively.
  11. Click Run.

    The tool may take a few minutes to run, depending on your hardware and whether you are running on CPU, GPU, or RAM.

    Objects detected by deep learning tools

  12. Save the project.

The deep learning tools in ArcGIS Pro depend on a trained model from a data scientist and the inference functions that come with the Python package for third-party deep learning modeling software. In the next lesson, you'll use raster functions to obtain an estimate of vegetation health for each tree in your study area.


Оценка здоровья растительности

На предыдущем уроке вы использовали модель глубокого обучения для извлечения пальмовых деревьев на снимке. На этом уроке вы используете этот же снимок для оценки здоровья растительности при помощи вычисления индекса здоровья растительности.

Для получения сведений о здоровье растительности вы вычислите Индекс устойчивости к видимой атмосфере (VARI), который был разработан как косвенный показатель индекса листовой поверхности (LAI) и доли растительности (VF), используя только значения отражения от видимой длины волны:

(Rg - Rr) / (Rg + Rr - R(Rg - Rb))

где Rr, Rg и Rb – значения отражения для красного, зеленого и синего каналов соответственно (Gitelson et al. 2002).

Обычно для оценки состояния здоровья растительности используются значения отражения и в видимых, и в ближнем инфракрасном (NIR) диапазонах длин волн, как для Стандартизованного индекса различий растительного покрова (NDVI). Но растровые данные для пальм Коловаи, скачанные из OpenAerialMap, – это многоканальное изображение с 3 каналами, все в видимом электромагнитном спектре, поэтому вы будете использовать VARI.

Вычисление VARI

Для измерения VARI в качестве входных данных необходимы три канала растра Пальмы Коловаи. Для вычисления VARI вы примените растровую функцию Арифметика каналов. Растровые функции работают быстрее инструментов геообработки, так как они не создают новые наборы растровых данных. Вместо этого они выполняют анализ в реальном времени по пикселам, по мере перемещения и масштабирования.

  1. Если необходимо, откройте проект CoconutHealth в ArcGIS Pro.
  2. На ленте щелкните вкладку Изображения. В группе Анализ щелкните Функции растра.
  3. На панели Растровые функции найдите и выберите растровую функцию Арифметика каналов.

    Функция Арифметика каналов

  4. В Свойствах Арифметики каналов задайте следующие параметры и щелкните Создать новый слой:

    • Для Растр выберите растровый слой Пальмы Коловаи.
    • Для Метод выберите VARI. В функции для формулы требуется указать индекс каналов, соответствующий входным каналам. Параметр Входные данные под полем для Индексов каналов показывает Red Green Blue, поэтому вы предоставите номера индексов каналов в соответствующем порядке: Red, Green и Blue. Проверьте, что между индексами есть пробел.
    • Для Индекс каналов введите 1 2 3.

    Параметры Арифметики каналов

    Слой VARI добавлен на панель Содержание как Арифметики каналов_Пальмы Коловаи. Перемещаясь и масштабируя снимок, можно увидеть объекты береговой линии, дорог, зданий и полей.

    Результат VARI

  5. На панели Содержание убедитесь, выбран слой Арифметики каналов_Пальмы Коловаи.
  6. На ленте щелкните контекстную вкладку Оформление.
  7. В группе Отображение раскройте ниспадающее меню Тип растяжки и выберите Средне-квадратичное отклонение.

    Изменение типа растяжки растра

  8. На панели Содержание дважды щелкните Арифметики каналов_Пальмы Коловаи и переименуйте его в VARI.

Извлечение VARI для кокосовых пальм

Наличие растрового слоя, показывающего VARI, пригодиться, но не дает места для необходимых действий. Чтобы выяснить, какие деревья требуют внимания, необходимо знать среднее значение VARI для каждого отдельного дерева. Для того, чтобы найти среднее значение VARI для каждого дерева, вы извлечете лежащее в основе среднее значение VARI и присвоите ему символы, чтобы увидеть, какие деревья здоровы, а каким требуется помощь.

Сначала вы конвертируете полигоны объектов в круги, чтобы представить пальмы.

  1. На панели Геообработка найдите и откройте инструмент Объект в точку. Введите следующие параметры и щелкните Запустить:

    • Для Входные объекты выберите слой CoconutTrees.
    • Для Выходной класс объектов введите CoconutTrees_Points.

    Инструмент Объект в точку

    Вы получили класс точечных объектов – центроидов каждого выявленного полигона. Если приблизиться к различным местоположениям и применить инструмент Измерить, можно увидеть, что средний радиус пальмовых деревьев составляет приблизительно 3 метра.

  2. На панели Геообработка найдите и откройте инструмент Буфер.
  3. Укажите следующие параметры и щелкните Запустить:

    • Для Входные объекты выберите CoconutTrees_Points.
    • Для Выходной класс объектов выберите PalmTreesBuffer.
    • Для Расстояние выберите 3 метра (проверьте, что значение задано в Линейных единицах).

    Вы получили класс полигональных объектов, изображающий местоположение и общую форму верхушек каждой пальмы.

  4. На панели Содержание выключите слои VARI, CoconutTrees и CoconutTrees_Points.

    Буфер для пальмовых деревьев

    Далее вы извлечете среднее значение VARI для каждого полигона.

  5. На панели Геообработка найдите и откройте инструмент Зональная статистика в таблицу.
  6. В инструменте Зональная статистика в таблицу введите следующие параметры и щелкните Запустить:

    • Для Входные векторные или растровые данные зон выберите PalmTreesBuffer.
    • Для Поле зоны выберите ORIG_FID.
    • Для Входной растр значений выберите VARI.
    • Для Выходная таблица введите MeanVARI_per_Palm.
    • Включите опцию Игнорировать значение NoData при вычислениях.
    • Для Тип статистики выберите Среднее.

    Указание для Поля зоны ORIG_FID обеспечит получение статистики для каждого отдельного дерева. Этот атрибут является уникальным идентификатором из исходного слоя CoconutTrees .

    Параметры инструмента Зональная статистика в таблицу

    Внизу панели Содержание добавится выходная таблица. Если ее открыть, вы увидите исходное значение FID и столбец с названием MEAN, содержащий среднее значение VARI. Вы присоедините эту таблицу к слою PalmTreesBuffer, чтобы получить класс объектов и со значением Confidence, и средним VARI, для каждого выявленного дерева.

  7. На панели Геообработка найдите и откройте инструмент Соединение полей.
  8. В инструменте Соединение полей введите следующие параметры и щелкните Запустить:

    • Для Входная таблица выберите PalmTreesBuffer.
    • Для Входное поле соединения выберите ORIG_FID.
    • Для Соединяемая таблица выберите MeanVARI_per_Palm.
    • Для Выходное поле соединения выберите ORIG_FID.
    • Для Соединяемые поля выберите MEAN.

    Слой PalmTreesBuffer теперь получил присоединенное поле с именем MEAN. Вы переименуете его и присвоите символы, чтобы данные стали понятны.

  9. На панели Содержание дважды щелкните PalmTreesBuffer и переименуйте его в PalmTreesVARI.
  10. На ленте во вкладке Оформление в группе Отображение щелкните Символы.
  11. Под Основные символы выберите Градуированные цвета.

    Символы градуированных цветов

  12. Для Поля выберите MEAN.
  13. Если необходимо, для Метод выберите Естественные границы и задайте4 для Классы.
  14. Для Цветовой схемы щелкните ниспадающее меню, отметьте Показать все и Показать названия. Прокрутите выберите схему Красно-желто-зеленый (4 класса).

    Схема Красно-желто-зеленый

  15. В Классах щелкните каждую подпись и переименуйте классы сверху вниз следующим образом: Необходима инспекция, Ухудшение здоровья, Среднее и Здорово.

    Подпись категорий

    Теперь вы получили карту с классами объектов, показывающую местоположение, здоровье и достоверность модели для каждого пальмового дерева на снимке.

    Состояние здоровья деревьев на снимке

  16. Сохраните проект.

Дополнительное задание: Назначение полевых задач и мониторинг процесса выполнения проекта

Одним из преимуществ использования ArcGIS Pro для извлечения объектов и анализа снимков является то, что его можно интегрировать со всей платформой ArcGIS. На последнем уроке вы использовали инструменты глубокого обучения в ArcGIS Pro для идентификации кокосовых пальм на снимке. Пальмовые деревья можно сохранить как объекты в классе объектов, который подходит для использования в ГИС GIS. Для продолжения рабочего процесса можно опубликовать результаты в облаке, настроить шаблон веб-приложения для проведения контроля качества, назначить задачи по инспекции деревьев полевым рабочим и отслеживать выполнение при помощи операционная панели.

Публикация на ArcGIS Online

Для того, чтобы использовать настраиваемые приложения с вашими данными, необходимо опубликовать данные о пальмах как сервис объектов в ArcGIS Online или ArcGIS Enterprise. В ArcGIS Pro щелкните правой кнопкой слой PalmTreesVARI на панели Содержание и выберите Общий доступ, а затем – Опубликовать как веб-слой. Он будет опубликован в вашей учетной записи ArcGIS Online.

Более подробно о публикации сервиса объектов.

Использование шаблонов приложений для просмотра точности глубокого обучения

Инструменты глубокого обучения предоставляют результаты с точностью, пропорциональной точности обучающих выборок и качеству обученной модели. Другими словами, результаты не всегда совершенны. Вы можете оценить качество результатов модели, проверив ее через деревья, где величина Confidence, сохраненная в результатах глубокого обучения, меньше заданного значения. Вместо того, чтобы приближаться к каждой записи при помощи фильтра атрибутов в ArcGIS Pro, настраиваемый шаблон веб-приложения Image Visit позволит быстро просмотреть точность результатов в веб-приложении.

Более подробно о приложении Image Visit.

Применение Workforce for ArcGIS для выполнения полевой проверки

Workforce for ArcGIS – мобильное приложение, которое использует местоположения объектов для координирования работы полевых сотрудников. Можно использовать приложение Workforce для назначения задач участникам вашей организации, чтобы все деревья со значением VARI, указанным как Необходима инспекция, были назначены кому-либо из полевых работников, проверены и отмечены предлагаемым лечением.

Более подробно о Workforce for ArcGIS.

Применение Operations Dashboard для мониторинга выполнения работ

Наконец, вы можете отслеживать ход выполнения заданий, отправленных в вашем проекте Workforce for ArcGIS с помощью Operations Dashboard for ArcGIS. Operations Dashboard for ArcGIS – настраиваемое веб-приложение, которое предоставляет визуализацию и аналитику для оперативного просмотра людей, служб и задач в реальном времени.

Более подробно о начале работы с Operations Dashboard.

На этом уроке вы получили снимки с БПЛА из открытого источника данных и создали на снимке обучающие выборки пальмовых деревьев. Эти кусочки изображений были переданы специалисту по изучению и анализу данных и применены для обучения модели глубокого обучения для извлечения примерно 11 000 пальм на снимке.

Вы узнали о глубоком обучении и анализе изображений, а также о настраиваемых приложениях на платформе ArcGIS. Если у вас имеется снимок и знания о моделях глубокого обучения, этот рабочий процесс можно применять для множества задач. Например, эти инструменты можно применять для изучения результатов повреждения сооружений при природных катастрофах, количестве транспорта в городских территориях или поиска антропогенных сооружений рядом с зонами геологического риска.

You can find more lessons in the Learn ArcGIS Lesson Gallery.