データの探索

時系列画像とは、同じ場所で異なる時間に撮影された一連の画像のことで、あるエリアの経時的変化の把握に有用です。 たとえば、森林エリアの時系列画像から、木が伐採され、後に再成長した時期や、火事や害虫の進入がいつどこで発生したかが分かる場合があります。 こうしたかく乱は通常、画像のピクセル値の急激な変化を伴うため、時系列画像解析には、これらの変化を検出するアルゴリズムを使用します。

ArcGIS Image Analyst エクステンションには、画像用に 2 つの時系列変化検出アルゴリズムが用意されています。 そのうちの 1 つが LandTrendr アルゴリズムです。これは Landsat 画像を基にしたアルゴリズムで、主に森林分野の用途に使用されます。 Landsat-TM 画像は 1984 年以降、地球の地表を継続的に撮影しているため、長年にわたる土地被覆の変化の観測に利用できます。

まず、オレゴン州の西カスケード エリアの多次元ラスターについて理解を深めます。 多次元ラスターは時系列画像を表すために使用されるデータセット モデルです。 次に、解析用に時系列画像を準備し、画像の単一ピクセルにおける土地被覆の変化を調べます。

多次元ラスターの探索

最初に、このチュートリアルのデータをすべて含むプロジェクトをダウンロードし、ArcGIS Pro で開きます。 次に、チュートリアル全体で使用する多次元ラスター データセットへの理解を深めます。

  1. Forest_Disturbance_Analysis プロジェクト パッケージをダウンロードします。
  2. ダウンロードしたファイルを参照し、ダブルクリックして ArcGIS Pro でプロジェクトを開きます。 必要に応じて、ライセンス付き ArcGIS アカウントを使用してサイン インします。
    注意:

    ArcGIS Pro へのアクセス権限または組織アカウントがない場合は、ソフトウェア アクセスのオプションをご参照ください

    プロジェクトにはオレゴン州の西カスケード エリアの画像のマップが含まれています。

    デフォルトのプロジェクト

    [コンテンツ] ウィンドウには、プロジェクトのレイヤーが一覧表示されます。 [WestCascade.crf] レイヤーには、西カスケードを対象に 1984 年から 2020 年までの期間に撮影された、ARD (Landsat Analysis Ready Imagery) タイプの時系列の衛星画像が 78 枚あります。 各画像はマルチバンド ラスターとして表されており、青、緑、赤、赤外、短波赤外の各スペクトル バンドが含まれています。 画像はすべて夏に撮影されたため、木々には葉があり、成長段階も同じです。このチュートリアルで使用する LandTrendr アルゴリズムの要件があるため、これは重要です。 さらに、雲量が 10 パーセント未満の画像だけが含まれています。 これらのラスターがすべて 1 つの多次元ラスターとして CRF 形式で保存されています。

    注意:

    このチュートリアルのワークフローを自身の分析範囲に適用するために、USGS EarthExplorer から対象地域の Landsat ARD 画像をダウンロードして、同様の多次元ラスターを作成できます。 画像のクリーン アップと多次元ラスターの生成についての詳細は、「Clean up your Landsat imagery: removing cloud and cloud shadow」をご参照ください。

    次に、[WestCascade.crf] に含まれている 78 枚の画像を参照し、それぞれがいつ収集されたかを確認します。

  3. [コンテンツ] ウィンドウで [WestCascade.crf] レイヤーをクリックして選択します。

    コンテンツ ウィンドウの WestCascade.crf

    多次元データセットを選択すると、リボンに [多次元] タブが表示されます。 このタブには多次元ラスターで機能するツールが含まれています。

  4. リボンで [多次元] タブをクリックします。

    多次元タブ

  5. [現在の表示スライス] グループで、[StdTime] ドロップダウン リストを展開します。 日付が [1984-07-19] で始まるリストの 2 番目の値をクリックします。

    StdTime ドロップダウン メニュー

    マップが更新され、1984 年 7 月 19 日に撮影された画像が表示されます。 [WestCascade.crf] のような時系列画像では、各画像はタイム スライスと呼ばれます。 さきほど表示した画像は時系列の 2 番目のタイム スライスです。

    マップの 2 番目のタイム スライス

    [コンテンツ] ウィンドウのレイヤーの凡例に、画像の表示に使用されるスペクトル バンドが示されます。

    WestCascade.crf レイヤーの凡例

    画像はナチュラル カラー バンド合成を使用して表示されており、バンド 1 が青、バンド 2 が緑、バンド 3 が赤です。 このバンド合成は人の目に映るときの風景に近づけます。 画像には 1 つの近赤外バンド (バンド 4) および 2 つの短波赤外バンド (バンド 5 とバンド 6) も含まれています。 後でこれらのバンドを使用しますが、現在は表示されていません。

    注意:

    マルチスペクトル画像とバンド割り当ての詳細については、「はじめての衛星画像」チュートリアルをご参照ください。

    画像の大半に森林 (緑色) が表示されていますが、画像の中心の一部には木々が伐採されているエリア (ベージュ色) もあります。

    マップ上の木々が完全に伐採されたエリア

    時系列をアニメーション化して、すべての画像を連続して表示することもできます。

  6. [多次元] タブの [現在の表示スライス] グループで、[標準時間に沿ってスライスを再生] ボタンをクリックします。

    標準時間に沿ってスライスを再生 ボタン

    時系列がアニメーションで再生され、新しい画像が数秒ごとに表示されます。 森林が画像間で著しく変化する時もあれば、ほんの少ししか変化しない時もあります。

    注意:

    一部の画像には、レイヤーで穴のように見える [NoData] エリアがあります。 これらのエリアはマスクされている雲ピクセルに対応しており、解析には影響しません。

  7. 終了したら [標準時間に沿ってスライスを再生] ボタンをクリックしてアニメーションを停止します。

    次に、レイヤーのプロパティを確認します。

  8. [コンテンツ] ウィンドウで [WestCascade.crf] レイヤーをダブルクリックします。

    [レイヤー プロパティ] ウィンドウが表示されます。

  9. [ソース] タブをクリックします。 [多次元情報][SR][StdTime] の各セクションを展開します。

    レイヤー プロパティ ウィンドウのソース タブ

    [個数] の値はデータセットにタイム スライスが 78 個あることを示しています。 [SR] はピクセル値で、地表反射率を意味しています。 時間の [範囲] の値は [1984-07-03] から [2020-08-23] までです。

  10. [レイヤー プロパティ] ウィンドウを閉じます。

    ここまでの内容をまとめると、[WestCascade.crf] レイヤーにはマルチスペクトル画像が 78 枚あります。 各画像には 6 つのスペクトル バンドが含まれています。 つまり、データセットには合計 468 個のラスターが含まれています。 以下の画像は、この多次元ラスターの構造を示しています。

    多次元ラスターの構造

指数式の適用

時系列画像の解析には、LandTrendr アルゴリズムを使用します。 LandTrendr は多次元ラスターに対応しており、各タイム スライスが 1 つのバンド ラスターになります。 しかし、タイム スライスには 6 バンドあります。 各タイム スライスに対する単一のバンド ラスターを導き出すには、指数式を時系列に適用します。 今回使用するNBR (Normalized Burn Ratio) 指数は、健全な森林と森林のかく乱を区別するのに適しており、森林火災跡の検出によく使用されます。

注意:

NBR 指数の詳細については、「衛星画像を使用した焼け跡の評価」チュートリアルをご参照ください。

  1. [コンテンツ] ウィンドウで [WestCascade.crf] レイヤーが選択されていることを確認します。
  2. リボンの [画像] タブをクリックします。 [ツール] グループで [指数] をクリックします。

    リボンの指数ボタン

  3. 指数のリストで、[地形][NBR] をクリックします。

    指数リストにある NBR のオプション

    [NBR] ウィンドウが開きます。 NBR 指数は数式を使用して、近赤外バンドと短波長バンドを結合します。 レイヤーでは、これらのバンドはそれぞれ、バンド 4 とバンド 6 に対応します。

  4. [NBR] ウィンドウの [近赤外バンド インデックス][4 - Band_4] を選択します。 [短波赤外バンド インデックス][6 - Band_6] を選択します。

    NBR ツールのパラメーター

  5. [OK] をクリックします。

    [NBR_WestCascade.crf] というレイヤーがマップに追加されます。 このレイヤーは依然として多次元ラスターですが、タイム スライス 1 つにつき NBR ラスター バンドが 1 つしかありません。

    注意:

    [NBR] ツールは新しいラスター レイヤーを動的に生成するラスター関数です。 このアプローチは処理時間を短縮しますが、新しいレイヤーはコンピューターのメモリーにしか存在しません。 レイヤーをプロジェクトから取り除くと、削除されるため、再度作成する必要があります。

    デフォルトでは、黒と白のストレッチ レンダリングを使用してレイヤーが表示されます。 シンボルを変更して、健全な植生とかく乱 (健全な植生がない状態) との差を強調します。

  6. [コンテンツ] ウィンドウで [NBR_WestCascade.crf] シンボルを右クリックし、カラー ランプのドロップダウン リストを展開します。 [名前の表示] チェックボックスをオンにし、[ピンク-緑 (連続)] カラー ランプを選択します。

    ピンク-緑 (連続) カラー ランプ

    マップ上のシンボルが更新されます。 最も高い NBR ピクセル値は健全な森林を表しており、緑で表示されています。 最も低い NBR ピクセル値はかく乱状態を表しており、紫で表示されています。 中間の NBR ピクセル値は白または薄い緑で表されています。

    ピンク-緑のシンボルを使用した NBR マップ

    新しいレイヤーは時系列でもあります。

  7. [コンテンツ] ウィンドウで [NBR_WestCascade.crf] レイヤーが選択されていることを確認します。
  8. リボンで [多次元] タブをクリックします。 [現在の表示スライス] グループの [StdTime] で、ドロップダウン リストを展開し、[1984-07-19] のタイム スライスを選択します。

    マップが更新され、同じようにシンボル設定された、指定した日付の画像が表示されます。

  9. [StdTime] の設定を最初のスライス ([1984-07-03]) に戻します。

1 ピクセル分のチャートの変更

次に、NBR 時系列を使用して、時間の経過に伴う森林の変化の探索を始めます。 このチュートリアル全体で、さまざまな方法で森林の変化を観測します。 まず、[ピクセル時系列変化エクスプローラー] ウィンドウを使用して、1 ピクセルの変化を観測します。

マップには現在、1984 年 7 月 3 日の NBR ラスターが表示されています。 このラスターでピクセルを 1 つ選択し、1984 年から 2020 年の、全 78 タイム スライス間で値がどのように変化するかを観測すると、次の画像のように、値をグラフに示すことができます。

時間の経過に伴うピクセル値の変化を示したグラフ

次に、LandTrendr アルゴリズムを使用してこのグラフの全体的なトレンドを検出します。 LandTrendr はピクセルの軌道が変化する変曲点を検出し、データを区分線形モデルに当てはめます。 結果は以下の画像のように、ある変曲点から次の変曲点まで及ぶ複数のライン セグメントから成るフィッティング曲線になります。

区分線形モデルにフィッティングされたデータが表示されているグラフ

各セグメントはある期間に発生した変化を表しており、開始時間、終了時間、期間、傾斜、強度 (開始時間から終了時間までに発生した変化の大きさ) に関する情報もあります。 画像例には 3 つのセグメントがあります。

  • 最初のセグメントは健全な森林を表しています ([NBR] 値が高い、または一定)。
  • 2 番目のセグメントは伐採などの干渉を表しています ([NBR] 値が急速に低下)。
  • 3 番目のセグメントは木々の再生長など、森林の回復プロセスを表しています ([NBR] 値が緩やかに上昇)。

自身のデータ向けに同様のグラフを生成します。

  1. [コンテンツ] ウィンドウで [NBR_WestCascade.crf] が選択されていることを確認します。
  2. リボンの [多次元] タブにある [解析] グループで、[時系列プロファイル] のドロップダウン矢印をクリックして [ピクセル時系列変化エクスプローラー] を選択します。

    ピクセル時系列変化エクスプローラー オプション

    空のチャート ビューと [チャート プロパティ] ウィンドウが表示されます。

  3. [チャート プロパティ] ウィンドウの [データ] タブの [変化の検出方法] で、[LandTrendr] を選択します。

    LandTrendr オプション

    注意:

    転置 (時系列解析用に最適化された追加のストレージ) の構築がパフォーマンスを向上する旨の警告メッセージが表示される場合があります。 [NBR_WestCascade.crf] ラスター関数レイヤーには転置がありませんが、そのベースとなっている [WestCascade.crf] 多次元ラスターにはあります。 警告は無視してかまいません。

    便宜上、グラフにするポイントは [Pixel location] レイヤーでマーキングしてあります。

  4. [コンテンツ] ウィンドウで、[Pixel location] のチェックボックスをオンにします。

    Pixel location チェックボックス

    緑のポイントがマップに表示されます。 ブックマークを使って、その場所にナビゲートします。

  5. リボンの [マップ] タブをクリックします。 [ナビゲーション] グループで、[ブックマーク] をクリックし、[Pixel point] ブックマークを選択します。

    Pixel point ブックマーク

    マップが、ポイントでマークされたピクセルに移動します。 このピクセルをグラフにします。

  6. [チャート プロパティ] ウィンドウの [ピクセル位置の定義][ポイント] ボタンをクリックします。

    ポイント ボタン

  7. マップ上で対象のピクセルをクリックします。

    マップ上の対象のピクセル

    グレーの位置ポイントがマップに追加されます。 [チャート プロパティ] ウィンドウではピクセル位置リストに行が追加されます。 このピクセル位置のチャートを生成する前に、スタイル設定オプションをいくつか選択しましょう。

  8. [チャート プロパティ] ウィンドウのピクセル位置行にある [シンボル] で、ポイント シンボルをクリックして [クレタ ブルー] を選択します。

    カラー パレットのクレタ ブルーのオプション

    注意:

    画像名を確認するには、画像にポインターを合わせます。

  9. サイズを [3] に設定します。

    シンボル サイズのパラメーター

  10. [モデル パラメーター] の下にある [フィッティングした曲線を表示] で、[色] 行をクリックして [エレクトロン ゴールド] を選択します。

    カラー パレットのエレクトロン ゴールドのオプション

  11. ラインの太さを [3] に変更します。

    ラインの太さのパラメーター

  12. [モデル パラメーター][チャートのフィッティングおよび作成] をクリックします。

    チャート ウィンドウにチャートが表示されます。

    ピクセルの経時的変化を示すチャート

    青のポイントは 78 個のタイム スライスのピクセル値です。 オレンジのラインは LandTrendr アルゴリズムを使用して計算されたフィッティング曲線で、全体的な変化のトレンドが示されています。

ピクセル変化チャートの探索

次に、チャートを探索します。

  1. チャート ウィンドウで、青いポイントの 1 つにポインターを合わせます。

    タイム スライスの年とその NBR 値

    ポップアップにタイムスライスの年とその NBR 値が表示されます。

    オレンジのフィッティング曲線は複数のセグメントで構成されており、それぞれがピクセルの履歴の重要なステージに対応しています。 チャートの凡例で、それぞれのフィッティング曲線セグメントの開始時間と終了時間を特定します。

    チャートの凡例

    ヒント:

    チャートの凡例のいずれかのアイテムをクリックし、チャート上で対応するセグメントのオンとオフを切り替えます。

    現在、5 つのライン セグメントがあります。 これはデータを理解するために最適なセグメント数ではないかもしれません。 フィッティング曲線のセグメント数を変更します。 最適なセグメント数を見つけるには試行錯誤が必要で、データセットの内容にも左右されます。

  2. [チャート プロパティ] ウィンドウの [モデル パラメーター] グループを展開します。 [最大セグメント数] を「4」に変更します。

    最大セグメント数のパラメーター

    注意:

    各モデル パラメーターの詳細については、LandTrendr を使用した変化の解析をご参照ください。

  3. [チャートのフィッティングおよび更新] をクリックします。

    チャートが更新され、セグメントが 4 つのみになります。

    • 1 つ目のセグメントは NBR 値が高く、木々が十分に生長した安定感のある森林を表しています。
    • 2 つ目のセグメントは強いかく乱状態を示しています。 おそらくエリアで伐採が行われ、健全な森林の量が短期間で 0 まで落ちています。
    • 3 つ目のセグメントでは、苗木が植えられ、比較的短期間で成長したため、スピーディーな回復曲線を描いています。
    • 4 つ目のセグメントでは、若木が十分な生長の途中であるため、回復の速度が緩やかです。
  4. チャートで、曲線セグメントにポインターを合わせます。

    セグメントのフィッティング モデル

    ポップアップに、セグメントのフィッティング モデルが示されます。 フィッティング モデルは ax + b という形式の式で表されます。ここで、a は傾斜、b はインターセプトを表します。 RMSE (二乗平均平方根誤差) の値も表示されます。

    対象エリアの変化をより深く理解するために、対応するラスター画像を調べていきましょう。

  5. チャート ビュー ツールバーで [凡例] ボタンをクリックします。

    凡例ボタン

    凡例がオフになり、チャートが展開します。

  6. チャート上で青い頂点をダブルクリックして、タイム スライスを選択します。
    ヒント:

    ポインターをドラッグして、頂点の周囲にボックスを描画することもできます。

    チャートでポイントを選択

    マップが選択したタイム スライスの画像に更新されます。

    注意:

    グラフ上の特定のポイントを選択することが難しい場合は、チャートを拡大できます。 チャート ウィンドウのツールバーで [ズーム モード] ボタンをクリックし、対象ポイントの周囲にボックスを描画します。

  7. 次の画像で強調表示されている 4 つのタイム スライスを視覚化します。

    視覚化するポイント

    マップに次の 4 つのタイム スライスが表示されます。

    時間の経過に伴う変化を示した画像

    これらのタイム スライスは、成熟した森林が伐採され、若木から再び成熟した森林へと戻っていく、ピクセル位置での変化を示しています。

  8. チャート ビューおよび [チャート プロパティ] ウィンドウを閉じます。
  9. [コンテンツ] ウィンドウで、[Pixel location] のチェックボックスをオフにします。
  10. [NBR_WestCascade.crf] レイヤーを右クリックして [レイヤーにズーム] を選択します。

    レイヤーにズーム オプション

    データの全体表示に戻ります。

  11. [クイック アクセス ツールバー][プロジェクトの保存] ボタンをクリックします。

    クイック アクセス ツールバーのプロジェクトの保存ボタン

    プロジェクトが保存されます。

ArcGIS Pro でプロジェクトを設定し、多次元ラスターについて理解し、1 ピクセルでの森林の変化を探索しました。 次に、森林の変化について理解したことを画像全体に広げていきます。


かく乱と回復の検出

画像のすべてのピクセルの変化を解析するために、まず解析ラスターを生成します。 次に、森林かく乱マップを作成し、森林で過去に発生した伐採や火事などのイベントを特定します。 最後に森林回復マップを作成し、かく乱されたエリアが成熟した森林に戻るまでにかかった期間を評価します。

変化解析ラスターの作成

LandTrendr を使用した変化の解析ツールを使用して変化解析ラスターを生成します。 このツールでは、[ピクセル時系列変化エクスプローラー] ツールと同じ LandTrendr アルゴリズムを使用しますが、1 つのピクセルのみではなく、多次元ラスターのすべてのピクセルにアルゴリズムが適用されます。 出力は、あらゆるピクセルのフィッティング曲線に関する情報をキャプチャーする変化解析ラスターとなります。

  1. [コンテンツ] ウィンドウで [NBR_WestCascade.crf] レイヤーが選択されていることを確認します。
  2. リボンで [多次元] タブをクリックします。 [解析] グループのツール ギャラリーで、[その他] ボタンをクリックします。

    多次元ツール ギャラリーのその他ボタン

  3. [LandTrendr を使用した変化の解析] ツールをクリックします。

    LandTrendr を使用した変化の解析ツール

    [ジオプロセシング] ウィンドウが開き、ツールが表示されます。

  4. [出力多次元ラスター] に「WestCascade_change_analysis.crf」と入力します。

    LandTrendr を使用した変化の解析ツールのパラメーター

    その他のパラメーターはそのままにしておきます。

    注意:

    このツールの出力は 1 年あたりの時間スライスが 1 つだけある多次元ラスターです。 LandTrendr 変化解析を行う前に、ツールは各年の入力ラスターで利用できる最適なピクセル値を選択します。 特定の年における最適なピクセル値は [スナップ日付] パラメーターに最も近いタイム スライスのピクセル値です (デフォルトでは [6-30]、または 6 月 30 日)。 雲が原因で最適なピクセル値が [NoData] になる場合、ツールは次に近いタイム スライスからピクセル値を取得します。

  5. [実行] をクリックします。
    注意:

    処理が完了するまで 15 分以上かかる場合があります。 完了するまで進捗が表示されない場合もあります。

    処理が実行されます。 処理が完了すると出力ラスターが [コンテンツ] ウィンドウに表示され、最初のラスター バンドがマップに表示されます。

    [WestCascade_change_analysis.crf] レイヤーは 34 のタイム スライスを持つ多次元ラスターで、だいたい 1 年につき 1 つのタイム スライスがあります (数年間はデータなし)。 各タイム スライスはマルチバンド ラスターで、バンドには LandTrendr フィッティング モデルに関する情報が格納されています。 これらのラスター バンドを調査して表示します。

  6. [コンテンツ] ウィンドウで [WestCascade_change_analysis.crf] シンボルをクリックします。

    WestCascade_change_analysis.crf のシンボル

    [シンボル] ウィンドウが表示されます。

  7. [シンボル] ウィンドウで、[バンド] のドロップダウン メニューを展開します。

    バンド ドロップダウン メニュー

    ax + b がフィッティング曲線の、ある区間のフィッティング モデルを表している場合、以下が適用されます。

    • 増加または減少として変化の方向を表す値 a[傾斜角] バンドに格納されます。
    • b[インターセプト] バンドに格納されます。
    • 特定の時間にフィッティング モデルから内挿された値が [Fitted_Value] バンドに格納されます。 このデータセットでは、各タイム スライスの入力 NBR 値の概算値になります。
    • フィッティング曲線の二乗平均平方根誤差が [RMSE] バンドに格納されます。
    • 変化期間の先頭と末尾のフィッティング値の差、つまり変化強度が [Change_Magnitude] バンドに格納されます。
    注意:

    [Band_1_Slope] のように、表示されているすべてのバンドの名前は [Band_1] から始まっています。これは、[Band_1] という名前のタイム スライスでシングル バンドを持つ [NBR] ラスターから取得されているためです。

    この変化解析ラスターを使用することで、変化日、変化期間、規模などの変化情報を抽出できます。 チュートリアルの残りでは、この多次元ラスターを入力として使用してさまざまな変化検出タスクを実行します。

    現在、[Band_1_Slope] バンドがマップ上に表示されています。 別のバンドを表示しましょう。

  8. バンドのリストで [Band_1_Fitted_Value] を選択します。

    マップが更新されます。

    マップ上のフィッティング値バンド

    NBR フィッティング値が最も低いエリアが濃い緑、最も高いエリアが濃い紫で表されています。 [多次元] タブの [StdTime] オプションを使用して、別のタイム スライスで [Band_1_Fitted_Value] バンドを視覚化することもできます。

  9. [シンボル] ウィンドウを閉じます。

かく乱のマッピング

これで変化解析ラスターの準備は完了で、次に、これを使って他の情報をマッピングします。 まず、変化解析ラスターから変化を検出ツールを使用して、過去の一連の森林かく乱をマッピングします。 健全な森林から木々が失われた急激な変化を表す、NBR フィッティング値の急激な減少の発生を抽出する特定のパラメーターを指定して、ツールを実行します。

  1. [コンテンツ] ウィンドウで [WestCascade_change_analysis.crf] レイヤーが選択されていることを確認します。
  2. リボンの [多次元] タブにある [解析] グループで、ツール ギャラリーを展開して [変化解析ラスターから変化を検出] を選択します。

    変化解析ラスターから変化を検出ボタン

    [ジオプロセシング] ウィンドウにツールが表示されます。

  3. [出力ラスター] で「Disturbance.crf」と入力します。

    減少変化のみが検出されるように変化の方向を設定し、健全な森林でかく乱が発生したエリアをキャプチャーできるようにします。 かく乱がいつ始まったかを把握するために、変化が発生した最も古い時期も追跡します。

  4. [変化の方向][減少] を選択します。 [変化タイプ][最古の変化が発生した時間] を選択します。

    変化解析ラスターから変化を検出ツールのパラメーター

    ツールを実行する前に、結果をフィルターして、継続期間が 4 年に満たないイベント (急激な変化)、0.7 ~ 1 の高い NBR (健全な森林) から -1 ~ 0.35 の低い NBR (木々がない) までの減少を指定します。 これらのピクセル値の範囲は、[Band_1_Fitted_Value] ラスター バンドの健全な森林と伐採または火事に遭ったエリアの標準値を確認することで選択されました。

  5. [属性によるフィルター] セクションを展開します。 次のパラメーターを設定します。
    • [期間によるフィルター] チェックボックスをオンにします。
    • [最長期間 (年)] に「4」と入力します。
    • [開始値でフィルター] チェックボックスをオンにします。
    • [最小の開始値] に「0.7」と入力します。
    • [最大の開始値] に「1」と入力します。
    • [終了値でフィルター] チェックボックスをオンにします。
    • [最小の終了値] に「-1」と入力します。
    • [最大の終了値] に「0.35」と入力します。

    属性によるフィルターのパラメーター

  6. [実行] をクリックします。

    [Disturbance.crf] レイヤーが生成され、マップに追加されます。 これはシングル バンド ラスターであり、多次元ではありません。 各ピクセル値が伐採または火事イベントが始まった日付を表しています。

  7. [ジオプロセシング] ウィンドウを閉じます。
  8. [コンテンツ] ウィンドウで、[WestCascade_change_analysis.crf][NBR_WestCascade.crf] をオフにします。
  9. マップ上でかく乱エリアをクリックします。

    ポップアップが開き、かく乱イベントの開始日が表示されます。

    かく乱のポップアップ

  10. ポップアップを閉じます。

欠損値の補完

[Disturbance.crf] ラスターを見ると、かく乱エリア内に有効なモデルを計算するのに十分な情報がなかった [NoData] ピクセルがいくつかあるのがわかります。 ただし、これらのエリアと周囲のピクセルでかく乱値が同じである可能性があります。 これらの [NoData] エリアを、統計演算ラスター関数で、近接ピクセル内の最頻値を使用して塗りつぶします。

  1. リボンの [画像] タブをクリックします。 [解析] グループで [ラスター関数] ボタンをクリックします。

    ラスター関数ボタン

    [ラスター関数] ウィンドウが表示されます。

  2. [ラスター関数] ウィンドウで「統計」を検索します。 [統計演算] グループで [統計] をクリックします。

    統計ボタン

    ツールが [NoData] ピクセルごとにその周囲の 3x3 ピクセルのボックスを調べ、そのボックスの最頻値を選択するように、ツール パラメーターを設定します。

  3. [ラスター][Disturbance.crf] を選択します。
  4. [統計の種類][最頻値] を選択します。 [ロウ数][カラム数] が両方とも [3] に設定されていることを確認します。
  5. [NoData ピクセルのみの塗りつぶし] チェックボックスをオンにします。

    統計ラスター関数パラメーター

  6. [新しいレイヤーの作成] をクリックします。

    新しいラスター レイヤー [統計_Disturbance.crf] がマップに追加されます。 このレイヤーの方がかく乱エリアの欠落が少なく、より滑らかでわかりやすくなっています。 レイヤーの名前を変更し、シンボルを変更します。

  7. [ラスター関数] ウィンドウを閉じます。
  8. [コンテンツ] ウィンドウで、[統計_Disturbance.crf] をクリックし、名前を編集できるようにします。 「Smoother_Disturbance.crf」と入力して Enter を押します。

    Smoother_Disturbance.crf レイヤー

  9. [Smoother_Disturbance.crf] シンボルをクリックします。

    [シンボル] ウィンドウが表示されます。 シンボルは自分で設定するのではなく、プロジェクト内で用意されているレイヤー ファイルをインポートします。

  10. [シンボル] ウィンドウでオプション ボタンをクリックして [レイヤー ファイルからインポート] を選択します。

    レイヤー ファイルからインポートオプション

    [シンボルのインポート] ウィンドウが開きます。

  11. [シンボルのインポート] ウィンドウで、[フォルダー][Forest_Disturbance_Analysis][commondata][userdata] の順にダブルクリックします。 [Disturbance_symbology.lyrx] を選択します。

    シンボルのインポート ウィンドウ

  12. [OK] をクリックします。

    白から紫までのカラー ランプがある新しいシンボルが適用されます。

    マップ上に新しいシンボルで表示されたかく乱

    ここ数年で発生したかく乱は濃い紫のエリアで表され、それより前に発生したかく乱は白または薄いピンクのエリアで表されています。 かく乱の大半はこの地域の中心から始まった伐採によるものであり、時間とともに北と南に広がっています。 東側と西側の広大なエリアでは、伐採は行われていません。

  13. [シンボル] ウィンドウを閉じます。
  14. [コンテンツ] ウィンドウで、[Disturbance.crf] を右クリックして [削除] を選択します。

かく乱の調査

次に、森林かく乱レイヤーを確認して、西カスケードの森林で過去に発生した伐採イベントと火事イベントについてより深く理解します。 まず、連邦政府と州政府が管理する保護対象森林エリアの境界を使用して、これらのイベントを比較します。

  1. [コンテンツ] ウィンドウで [Forest management boundaries] レイヤーをオンにします。

    伐採が行われていないエリアは政府が管理する保護対象内にあります。

    マップ上の Forest management boundaries レイヤー

  2. リボンの [マップ] タブをクリックします。 [ナビゲーション] グループで、[マップ操作] ドロップダウン矢印をクリックして、[最上位レイヤー] をクリックします。

    最上位レイヤー メニュー オプション

    このオプションにより、[コンテンツ] ウィンドウに表示されている最上位のレイヤーについてのみポップアップが表示されるようになります。 このケースでは、[Forest management boundaries] レイヤーです。

  3. マップ上で東側の大きな保護対象森林エリアをクリックし、ポップアップを表示して詳細を確認します。

    州立公園のポップアップ

    このエリアは州立公園です。 詳細は後で確認します。

  4. ポップアップを閉じます。
  5. リボン上の [マップ] タブにある [ナビゲーション] グループで、[ブックマーク] をクリックして [State park] を選択します。

    マップに公園が表示されます。 公園の中央にある一部のピクセルが、かく乱がここ数年で発生したことを示す濃い紫でシンボル表示されています。

    マップ上の State park ブックマーク

    これは保護対象森林の違法伐採なのでしょうか。 この特定のイベントについてさらに詳しく調べてみましょう。

  6. [ナビゲーション] グループで、[マップ操作] ドロップダウン矢印をクリックして [表示レイヤー] を選択します。

    表示レイヤーオプション

    このオプションにより、最上位レイヤーだけでなく、表示されているすべてのレイヤーの情報がポップアップに表示されるようになります。

  7. かく乱が発生したエリアをクリックしてポップアップを表示します。

    かく乱が発生した年

    ポップアップで [Smoother_Disturbance.crf] の下を見ると、かく乱の日付が表示されています。 このかく乱は 2017 年に発生しました。

  8. ポップアップを閉じます。

    横並び表示を使用して、このエリアに対応する画像を確認します。

  9. [カタログ] ウィンドウで、[マップ] を展開します。 [Source_Images] を右クリックして [開く] を選択します。
    注意:

    [カタログ] ウィンドウが見つからない場合は、リボン上で [表示] タブをクリックします。 [ウィンドウ] グループで、[カタログ ウィンドウ] をクリックします。

    開くオプション

    [Source_Images] マップが表示されます。 オリジナルの画像多次元ラスターである [WestCascade.crf] が表示されます。

  10. [Source_Images] タブをドラッグして、[Disturbance_Analysis] マップの右側にドッキングします。

    右側のドッキング領域

    同じ範囲が表示されるように 2 つのマップをリンクします。

  11. リボンの [表示] タブをクリックします。 [リンク] グループで、[ビューのリンク] ドロップダウン矢印をクリックして、[中心と縮尺] を選択します。

    中心と縮尺オプション

  12. 拡大して、州立公園でかく乱が発生したエリアに画面移動します。

    2 つのマップが同時に更新されます。 干渉イベントからそれほど経過していない日付の画像を表示します。

  13. [Source_Images] マップ タブをクリックしてアクティブなマップにします。

    Source_Images タブ

  14. [コンテンツ] ウィンドウで [WestCascade.crf] を選択します。
  15. リボンで [多次元] タブをクリックします。 [StdTime][2018-07-17] タイム スライスを選択します。

    画像が更新されます。 このエリアに草木がまったくないわけではないようですが、茶色がかっているように見えます。これは、木々が伐採されたわけではなく、火事の影響を受けたことを示しています。

    かく乱が発生したエリアをマップ間で比較

    次に、最新の画像で過去、または最近のかく乱イベントがどのように表示されるかを確認します。

  16. リボンの [マップ] タブをクリックします。 [ブックマーク] をクリックして [Linked view] を選択します。
  17. [Source_Images] マップ タブがアクティブになっていることを確認します。 リボンの [多次元] タブにある [StdTime] で、最も新しいタイム スライスである [2020-08-23] を選択します。

    リンクしたマップを見ると、次のことがわかります。

    • 森林が回復したため、最も古いかく乱エリア (白または薄いピンク) の多くが現在では十分に生長した木々で覆われています。
    • 数年前にかく乱が発生した場所 (中間の紫) では、若木が生長しています。
    • 最近のかく乱イベント (濃い紫) の大半では、画像を見るとほとんど草木が生えていないことがわかります。

    最近の画像でみられる回復

  18. [Source_Images] タブを閉じます。
  19. リボンの [表示] タブをクリックします。 [ビューのリンク] ボタンをクリックして、ビューのリンクを解除します。

森林回復の測定

森林はかく乱と回復を繰り返す動的システムです。 たとえば、木材を生産するために木々が伐採されたり、新しい木が植樹されたりします。 かく乱イベントに比べると、回復の速度は通常かなり緩やかです。 植え直された木々が十分に生長する回復プロセスの期間を見積もるには、再度 [変化解析から変化を検出] ツールを使用します。 今回は、NBR 値が減少ではなく増加した変化期間の開始日と終了日を抽出します。 その後、開始日から終了日までの年数を計算します。 ワークフロー全体では、次の手順が必要です。

  • 回復のための変化期間を特定し、変化の開始日を抽出する。
  • 再度ツールを実行して、変化の終了日を抽出する。
  • 2 つの日付の差異 (回復にかかった日数) を計算する。
  • 365.25 で除算することで、日数を年数に変換する。

時間を節約するために、これらすべての手順を手動では実行しません。 ワークフロー全体を 1 つのジオプロセシング モデルとして実行します。

ジオプロセシング モデル

  1. [カタログ] ウィンドウで [ツールボックス][Forest_Disturbance_Analysis.tbx] を展開します。 [Calculate Recovery Duration] をダブルクリックします。

    Calculate Recovery Duration モデル

    [ジオプロセシング] ウィンドウが開き、モデルがツールとして表示されます。

  2. [Input Change Analysis Raster][WestCascade_change_analysis.crf] を選択します。 [Use the filtered records] をオフにします。
  3. [Output Recovery Raster] ですべての既存テキストを削除し、「Recovery_years.crf」と入力します。
    注意:

    [Output Recovery Raster] の横に警告シンボルが表示されている場合、出力先が存在しないことが原因です。 適切な出力先が使用されるように、出力名を入力する前にすべてのテキストを削除してください。

    Calculate Recovery Duration パラメーター

  4. [実行] をクリックします。

    しばらくすると、出力ラスターが作成されてマップに追加されます。 これは、ピクセル値が回復にかかった年数を表す単一のバンド ラスターです。

    コンテンツ ウィンドウの Recovery_years.crf レイヤー

  5. [コンテンツ] ウィンドウで [Recovery_years.crf] を右クリックして [レイヤーにズーム] を選択します。 [Forest management boundaries][Smoother_Disturbance.crf] をオフにします。

    これで、マップ上にレイヤーが表示されました。

    マップ上の回復レイヤー

    木々がすべて伐採されたエリアは暗いピンクで、回復するまでに 11 ~ 15 年かかっていることになります。 森林のかく乱は急速に進む傾向がある一方で、森林の回復には比較的長い時間がかかることがあります。

  6. [ジオプロセシング] ウィンドウを閉じます。
  7. プロジェクトを保存します。

変化解析ラスターを使用して、かく乱をマッピングし、森林が回復するまでにかかる時間を測定しました。 次に、変化解析ラスターを分類することで、森林がどのように変化したかを解析します。


森林の変化の分類

西カスケードの森林が数年間でどのように変化してきたかをより深く理解するために、タイム スライスごとに森林分類マップを作成しましょう。 分類プロセスでは、次の 3 つのクラスのいずれかをすべてのピクセルに割り当てます。

  • Healthy forest
  • Disturbance
  • Recovery

時系列解析を分類することが、そのまま各タイム スライスのすべてのピクセルを分類することになります。 オリジナルの時系列画像である [WestCascade.crf] を分類する代わりに、このチュートリアルでさきほど生成した、派生変化解析ラスターである [WestCascade_change_analysis.crf] を分類します。 分類ツールでは、[Fitted_Value][Slope][Intercept][Change_Magnitude] など、変化解析ラスターのすべてのバンドに格納されている情報を使用して森林の現在の状態を特定します。 時系列を分類するワークフローは 1 つの画像の分類に似ていますが、各トレーニング サンプルをタイム スライスごとに作成し、タイム スライスの日付でラベル付けする必要があります。

注意:

1 つの画像の分類に関する詳細は、チュートリアル「スペクトル画像から不浸透面を計算」をご参照ください。

ここでは次のワークフローを実行します。

  • 分類スキーマを読み込む。
  • 時間対応のトレーニング サンプル マネージャーツールを使ってトレーニング サンプルを収集する。
  • 分類機を選択してトレーニング サンプルでトレーニングする。 このチュートリアルではランダム ツリーによる分類器を使用します。
  • トレーニング済みの分類器を使用して時系列を分類する。
  • 分類結果のサマリーを表示するチャートを作成する。

変化解析ラスターの確認

分類プロセスをより深く理解するために、RGB シンボルがある変化解析ラスターのバンドを確認しましょう。 まず、新しいマップを設定します。

  1. [カタログ] ウィンドウの [マップ] セクションで、[Classification] マップを右クリックして、[開く] を選択します。

    ベースマップと [WestCascade.crf] を含むマップが開きます。 変化解析ラスターも追加します。

  2. [カタログ] ウィンドウで、[フォルダー][Forest_Disturbance_Analysis][commondata] の順に展開します。 [WestCascade_change_analysis.crf] を右クリックして [現在のマップに追加] を選択します。

    現在のマップに追加オプション

    デフォルトでは、最初のタイム スライス ([1984-06-30]) が表示されます。 タイム スライスとシンボルを変更します。

  3. [コンテンツ] ウィンドウで [WestCascade_change_analysis.crf] が選択されていることを確認します。
  4. リボンで [多次元] タブをクリックします。 [StdTime][1987-06-30] タイム スライスを選択します。
  5. [コンテンツ] ウィンドウで [WestCascade_change_analysis.crf] シンボルをクリックします。

    [シンボル] ウィンドウが表示されます。

  6. [シンボル] タブで、次のパラメーターを設定します。
    • [プライマリー シンボル][RGB] を選択します。
    • [赤][Band_1_Slope] を選択します。
    • [緑][Band_1_Fitted_Value] を選択します。
    • [青][Band_1_Change_Magnitude] を選択します。

    RGB シンボル

    マップが更新されます。 [RGB] シンボルは、3 つのバンドを、単体の赤、緑、青のコンポジット画像として合成します。 [Slope][Fitted_Value][Change_Magnitude] の値が変わると森林の状況がどのように変化するかを確認するにはこのシンボルが便利です。

  7. リボンの [マップ] タブをクリックします。 [ブックマーク] をクリックして [RGB details] を選択します。

    RGB の例

    3 つのバンドの値に応じて、各エリアの色が明るい緑から明るいピンクへと変化します。 次のリストは、各色が何を表しているかを示します。

    • 健全で十分に生長した森林 (薄い緑): [Fitted_Value] の値が高く、[Slope] の値がほぼ均一 (0 に近い) 状態です。 このエリアは安定した健全な森林で覆われています。
    • 健全で十分に生長した森林だが、間もなく伐採される (明るい緑): [Fitted_Value] の値が高く、[Slope] の値がマイナス方向に高い状態です。 次の数回のタイム スライスでこの健全な森林の 1 区画が伐採されます。
    • かく乱 (濃い緑): [Fitted_Value] の値が中程度から非常に低く、[Slope] の値がマイナス方向に高い状態です。 木々が現在伐採されているかく乱エリアです。
    • かく乱、ただし間もなく回復 (明るいピンク): [Fitted_Value] の値が非常に低く、[Slope] の値がプラス方向に高い状態です。 木々の再植樹が行われ、次のタイム スライスから回復し始めるかく乱エリアです。
    • 回復 (薄いピンク): [Fitted_Value] の値が中程度で [Slope] の値がプラスの状態です。 若木が成熟した木に向けて生長している、現在回復が進んでいるエリアです。
  8. [シンボル] ウィンドウを閉じます。
  9. [コンテンツ] ウィンドウで [WestCascade_change_analysis.crf] を右クリックし、[レイヤーにズーム] を選択します。

    分類プロセスでは、[Fitted_Value][Slope]、およびその他のバンドに格納されている情報を使用して各ピクセルの分類方法を決定します。

分類スキーマの読み込み

ここまで、分類プロセスがバンド情報をどのように使用するかを学習してきました。ここからは、分類スキーマを読み込んで分類ワークフローを開始していきます。

注意:

このチュートリアルには受講者用の分類スキーマ ファイルがあらかじめ用意されています。 自身でスキーマ ファイルを作成する方法についてはトレーニング サンプル マネージャーのドキュメントをご参照ください。

  1. [コンテンツ] ウィンドウで [WestCascade_change_analysis.crf] が選択されていることを確認します。
  2. リボンの [画像] タブをクリックします。 [画像分類] グループで [分類ツール] をクリックして、[トレーニング サンプル マネージャー] を選択します。

    トレーニング サンプル マネージャー オプション

    [画像分類] ウィンドウが開き、デフォルトのスキーマが表示されます。 チュートリアル専用のスキーマを読み込みましょう。

  3. [画像分類] ウィンドウで、[分類スキーマ] ボタンをクリックします。

    分類スキーマ ボタン

  4. [スキーマの読み込み] ウィンドウで、[フォルダー][Forest_Disturbance_Analysis][commondata][userdata] の順にダブルクリックします。 [WestCascadeForestTypes.ecs] をクリックします。

    スキーマの読み込みウィンドウの WestCascadeForestTypes.ecs

  5. [OK] をクリックします。

    [画像分類] ウィンドウにスキーマが表示されます。 3 つのターゲット クラスが表示されており、これらは 3 つの森林タイプと一致しています。

    画像分類ウィンドウの分類スキーマ

トレーニング サンプルの収集

次に、画像分類用のトレーニング サンプルを収集します。 まず、優れたサンプルの場所をわかりやすくするために、[WestCascade_change_analysis.crf] レイヤーのシンボルを変更します。

  1. [コンテンツ] ウィンドウで [WestCascade_change_analysis.crf] を右クリックし、[シンボル] を選択します。
  2. [シンボル] ウィンドウで、次のパラメーターを設定します。
    • [プライマリー シンボル][ストレッチ] を選択します。
    • [バンド][Band_1_Fitted_Value] を選択します。
    • [配色][緑 (連続)] カラー ランプを選択します。

    フィッティングされた値のシンボル

    マップが更新され、NBR フィッティング値が表示されます。 最低値は白で、最高値は明るい緑です。

    異なるタイム スライスのサンプルを使用して、3 つすべてのターゲット クラスを説明するサンプルを収集する必要があります。 最初に作成するサンプルは、現在アクティブであるタイム スライス ([1987-06-30]) の健全な森林のサンプルです。

  3. [シンボル] ウィンドウを閉じます。 [画像分類] ウィンドウで [Healthy forest] クラスをクリックして選択します。
  4. [ポリゴン] ボタンをクリックします。

    画像分類ウィンドウのポリゴン ボタン

  5. マップ上で健全な森林 (明るい緑) の 1 区画を拡大します。
  6. マップをクリックして、健全な森林内でポリゴンの頂点をスケッチします。 最後のポイントをダブルクリックしてポリゴンを完成させます。

    マップ上の健全な森林のポリゴン

    注意:

    サンプルの場所を特定しやすくするために、オリジナル画像の [WestCascade.crf] の同じタイム スライスをフィッティング値ビューの補足として確認することもできます。

    [画像分類] ウィンドウでトレーニング サンプルがサンプルのリストに追加されます。

    サンプル リストの最初の行

    次に、[1992-06-30] タイム スライスに [Disturbance] トレーニング サンプルを作成します。

  7. リボンで [多次元] タブをクリックします。 [StdTime][1992-06-30] タイム スライスを選択します。
  8. [画像分類] ウィンドウで [Disturbance] クラスをクリックして選択します。 [ポリゴン] ボタンをクリックします。
  9. マップ上で、かく乱された森林 (白) の 1 区画を特定してポリゴンをスケッチします。
    注意:

    かく乱された森林エリアを表示する別の場所に画面移動する必要がある場合は、C キーを押したままマウスで画面移動およびズームします。

    マップ上の 2 つ目のポリゴン

    2 つ目のトレーニング サンプルがリストに追加されます。

    実際のワークフローでは、さまざまなタイム スライスからトレーニング サンプルの作成を続行して、3 つすべてのクラスの優れたサンプルを蓄積します。 ただし、このチュートリアルでは、時間を節約するためにあらかじめ用意されているトレーニング サンプルのセットを使用します。

  10. [画像分類] ウィンドウで、[トレーニング サンプルの読み込み] ボタンをクリックします。

    トレーニング サンプルの読み込みボタン

  11. [トレーニング サンプル] ウィンドウで、[データベース][Forest_Disturbance_Analysis.gdb] をダブルクリックします。 [WestCascade_training_samples] を選択します。

    トレーニング サンプル ファイル

  12. [OK] をクリックします。

    ファイル内のトレーニング サンプルがウィンドウに追加されます。

    画像分類ウィンドウのトレーニング サンプル

    リストには約 80 個のサンプルが含まれており、それぞれにクラス名とタイム スライスの日付があります。

  13. リストのトレーニング サンプルの横にある行のボタンをダブルクリックします。

    トレーニング サンプルの行のボタン

    マップ上で、対応するポリゴンが正しいタイム スライスに表示されます。

  14. [画像分類] ウィンドウを閉じます。 修正内容を保存するかを確認する警告ウィンドウで、[いいえ] を選択します。

    トレーニング サンプルに対する変更や保存は必要ありません。

  15. [コンテンツ] ウィンドウで [WestCascade_change_analysis.crf] を右クリックし、[レイヤーにズーム] を選択します。
    注意:

    これらのトレーニング サンプルは、自身のものとまったく同じパラメーターを使って生成された変化解析ラスターから収集されたものです。 [スナップ日付] パラメーターの値を変えて生成されたものなど、別の変化解析ラスターを使用した場合はこれが当てはまりません。

分類の実行

次に、トレーニング サンプルを使用して分類器をトレーニングします。 それを時系列に適用して、各タイム スライスのすべてのピクセルを分類します。 まず、[ランダム ツリーによる分類器のトレーニング] ツールを使ってトレーニングを実施します。

  1. リボンの [解析] タブをクリックします。 [ジオプロセシング] グループで、[ツール] をクリックします。

    ツール ボタン

    [ジオプロセシング] ウィンドウが表示されます。

  2. 検索ボックスに「ランダム ツリーによる分類器のトレーニング」と入力します。 検索結果のリストで、[ランダム ツリーによる分類器のトレーニング] をクリックします。

    検索結果のリスト内の、ランダム ツリーによる分類器のトレーニング ツール

  3. [入力ラスター][WestCascade_change_analysis.crf] を選択します。 [フィルターされたレコードを使用] をオフにします。
  4. [入力トレーニング サンプル ファイル][参照] ボタンをクリックします。

    参照ボタン

  5. [入力トレーニング サンプル ファイル] ウィンドウで [データベース] をクリックし、[Forest_Disturbance_Analysis.gdb] をダブルクリックします。 [WestCascade_training_samples] を選択して [OK] をクリックします。
  6. [ディメンション値フィールド][StdTime] を選択します。
  7. [出力分類器定義ファイル] で、テキストを削除して「WestCascade_trained_classifier.ecd」と入力します。

    ランダム ツリーによる分類器のトレーニング パラメーター

  8. [実行] をクリックします。

    各クラスの統計情報と分類情報が含まれる Esri 分類定義 (.ecd) ファイルが生成されます。 次に、このトレーニング済み分類器を使用してラスターの分類ツールで時系列全体を分類します。

  9. [ジオプロセシング] ウィンドウの [戻る] ボタンをクリックします。

    ジオプロセシング ウィンドウの戻るボタン

  10. [ラスターの分類] ツールを検索して開きます。
  11. [入力ラスター][WestCascade_change_analysis.crf] を選択します。 [フィルターされたレコードを使用] をオフにします。
  12. [入力分類器定義ファイル][参照] ボタンをクリックします。 [フォルダー][Forest_Disturbance_Analysis][commondata] の順に展開します。
  13. [WestCascade_trained_classifier.ecd] を選択して [OK] をクリックします。
  14. [出力分類ラスター] に「WestCascade_classification.crf」と入力します。

    ラスターの分類ツールのパラメーター

  15. [実行] をクリックします。

    このツールは、トレーニング済み分類器の情報を使用して、変化解析ラスターの各タイム スライスのすべてのピクセルを 3 つのターゲット クラスのいずれかに分類します。 多次元 CRF ラスターがマップに追加されます。 これは時系列となっており、分類値を含む 1 つのバンド ラスターで各タイム スライスが構成されています。 デフォルトでは、[1984-06-30] のタイム スライスが表示されます。

    [コンテンツ] ウィンドウの凡例に次の 3 つのクラスが表示されます。

    • 濃い緑のエリアが [Healthy forest] として分類されています。
    • 明るいピンクのエリアが [Disturbance] として分類されています。
    • 薄い緑のエリアが [Recovery] として分類されています。

    マップ上の分類レイヤー

  16. リボンで [多次元] タブをクリックします。 [現在の表示スライス] グループで、[標準時間に沿ってスライスを再生] ボタンをクリックして、時系列をアニメーションで表示します。

    時系列のアニメーション表示中、健全な森林の区画がかく乱エリアになってから回復していく様子がわかります。

  17. アニメーションの視聴が終わったら、[標準時間に沿ってスライスを再生] をクリックしてアニメーションを停止します。

変化の集計

次に、カテゴリー ラスターの集計 ツールを使って、各タイム スライスの 3 つのクラスの要約統計を計算します。 各クラスに割り当てられているピクセル数がこのツールによってカウントされます。

  1. [ジオプロセシング] ウィンドウの [戻る] ボタンをクリックします。
  2. [カテゴリー ラスターの集計] ツールを検索して開きます。
  3. [入力カテゴリー ラスター][WestCascade_classification.crf] を選択します。 [フィルターされたレコードを使用] をオフにします。
  4. [出力サマリー テーブル] に「Forest_class_table」と入力します。

    カテゴリー ラスターの集計ツールのパラメーター

  5. [実行] をクリックします。

    ツールが実行されます。 [コンテンツ] ウィンドウの [スタンドアロン テーブル] の下に出力テーブルが表示されます。 次は、[Disturbance] および [Recovery] クラスに焦点を当てて、テーブルに含まれる情報を表示するバー チャートを作成します。

  6. [ジオプロセシング] ウィンドウを閉じます。
  7. [コンテンツ] ウィンドウで、[Forest_class_table] を右クリックして [チャートの作成] をポイントし、[バー チャート] を選択します。

    バー チャート オプション

    [チャート プロパティ] ウィンドウと空のチャート ビューが表示されます。

  8. [チャート プロパティ] ウィンドウの [カテゴリーまたは日付] で、[StdTime] を選択します。 [集約] で、[合計値] を選択します。

    カテゴリーまたは日付と集約のパラメーター

  9. [数値フィールド][選択] ボタンをクリックします。 [Disturbance][Recovery] のチェックボックスをオンにし、[適用] をクリックします。

    チャート プロパティ

    チャートが開きます。 チャートの書式を設定してラベルを追加することで表示を改善します。

  10. [チャート プロパティ] ウィンドウで、[シリーズ] タブをクリックします。

    シリーズ タブ

  11. フィールドのリストの [Disturbance] で、シンボルをクリックして [ピオニー ピンク] を選択します。

    Disturbance シンボルのピオニー ピンクの色

  12. [Recovery] で、シンボルをクリックして [ライト アップル] を選択します。

    Recovery シンボルのライト アップルの色

  13. [チャート プロパティ] ウィンドウで、[一般] タブをクリックします。 次のパラメーターを設定します。
    • [チャートのタイトル] に「Forest Classification (1984-2020)」と入力します。
    • [X 軸のタイトル] に「Year」と入力します。
    • [Y 軸のタイトル] に「Number of pixels」と入力します。

    チャートの一般タブ

    チャートが更新されます。

    Forest Classification チャート

    このチャートは 35 年間にわたる森林の力学のトレンドを示したものです。 これを見ることで、森林エコシステムのかく乱と回復のバランスが理解できます。 明確なトレンドとして挙げられるのが森林の力学の補完的な性質です。森林の回復の度合いが高いと干渉の度合いが低くなり、その逆も同様です。 たとえば、1992 年から 2002 年までの 10 年間のグラフでは、森林の回復の度合いが高いのに対して、森林の干渉の度合いが相対的に低い反比例関係が見られます。 1985 ~ 1990 年と 2014 ~ 2020 年の期間では、木々の伐採により、回復と比較して干渉の度合いが高まっていることがこれらの年の画像からわかります。

  14. プロジェクトを保存します。

森林の健全性と生物学的多様性の評価、森林管理のサポート、木材の生産、違法性が疑われる伐採活動の監視などにおいて森林被覆変化解析は不可欠です。 こうしたニーズを満たすには、合理的なコストで広大なエリアを頻繁に監視する必要があります。 LandTrendr は森林の干渉と回復を検出、監視するうえで効果を発揮するマッピング ツールです。 このツールでは Landsat 画像の時系列を使用して、森林の土地被覆の空間的な変化を自動的に検出します。

このチュートリアルでは、[ピクセル時系列変化エクスプローラー] を使用して、森林の変化をピクセル レベルで調査しました。 その後、[LandTrendr を使用した変化の解析] ツールと [変化解析ラスターから変化を検出] ツールを使用して、森林のかく乱と回復のパターンとトレンドを明らかにするマップを作成しました。 最後に、ランダム ツリーによる分類器を使用して変化解析ラスターを 3 つのクラスに分類し、35 年間の森林の力学のトレンドを示すチャートを作成しました。

同様のチュートリアルについては、「画像およびリモート センシングの概要」チュートリアル コレクションをご参照ください。

他のチュートリアルについては、チュートリアル ギャラリーをご覧ください。