LIDAR データの操作から始める

このレッスンでは、LIDAR データから情報を抽出します。 LIDAR (light detection and ranging) は、レーザー光線を使用して、地表を高密度でサンプリングし、極めて精度の高い X、Y、Z ポイント計測値を生成するリモート センシング手法です。 これらのポイント セットは「点群」と呼ばれます。 LIDAR の詳細については、「LIDAR データとは」をご参照ください。

LIDAR 点群

LIDAR データから 3D 建物シェープを抽出するには、まず、点群ポイントを分類し、対象地域の地表と建物 (または屋根) を示す点群を識別します。 続いて、地表に分類された点群ポイントを使用して、地表の標高を連続ラスターで表す DEM を生成します。 次に、建物に分類された点群ポイントを使用して、2D 建物フットプリントを抽出します。 最後に、これらのエレメントをまとめて 3D 建物フィーチャを生成します。

3D 建物フィーチャ

注意:

このレッスンは、LIDAR データとはなにか、LAS データセットを作成する方法、点群を分類する方法、点群から数値標高モデル (DEM) を生成する方法、2D 建物フットプリントと 3D マルチパッチ建物を抽出する方法など、LIDAR 関連の概念を伝えることに主眼を置いています。

一方で、Esri では、大規模な 3D ベースマップの生成を目指している都市とその他の政府機関を対象とした 3D ベースマップ ソリューションを用意しています。 このソリューションは、一連のワークフローで構成されており、3D ベースマップの作成と管理を効率化することができます。 このソリューションの使用例については、「都市開発に向けた屋根形状の抽出」レッスンをご参照ください。

プロジェクトをダウンロードして開く

まず、レッスンに必要なデータをすべて含むプロジェクトをダウンロードし、ArcGIS Pro で開きます。

  1. Building_Extraction.zip ファイルをダウンロードします。

    *.zip ファイルがコンピューターにダウンロードされます。

  2. コンピューター上で、ダウンロードした [Building_Extraction.zip] ファイルを参照します。
    注意:

    お使いの Web ブラウザーによっては、ダウンロードを開始する前に、ファイルの場所を選択するよう求めるメッセージが表示される場合があります。 ほとんどのブラウザーでは、デフォルトでコンピューターのダウンロード フォルダーがダウンロード先の場所になります。

  3. [Building_Extraction.zip] ファイルを右クリックして、[ドキュメント] フォルダーなどの見つけやすい場所にファイルを展開します。

    次に、ArcGIS Pro でプロジェクトを開きます。

  4. ArcGIS Pro を起動します。 プロンプトが表示されたら、ArcGIS アカウントの認証情報を入力します。
    注意:

    ArcGIS Pro または ArcGIS アカウントがない場合、「ArcGIS の無料トライアル」にサイン アップできます。

  5. ArcGIS Pro[開く][別のプロジェクトを開く] をクリックします。

    [別のプロジェクトを開く] オプション

  6. [プロジェクトを開く] ウィンドウで、ダウンロードした [Building_Extraction] フォルダーを参照します。 [Building_Extraction.aprx] をクリックして選択し、[OK] をクリックします。

    プロジェクトが開きます。

    デフォルトのプロジェクト

    プロジェクトには、デンマークのコペンハーゲンにあるツボルグ港付近を中心とする 3D 対応シーンが含まれています。 このあたりは、ツボルグ醸造所のかつての工業用地に近く、多目的地区として再開発されました。 シーンには、この地区の航空写真として Tuborg_Havn_Ortho_Photo.tif が含まれており、レッスンでは参照用に使用します。

    注意:

    このレッスンで使用する Tuborg_Havn_Ortho_Photo.tif 画像およびすべてのデータは、デンマーク政府の Web サイト Styrelsen for Dataforsyning og Effektivisering にあります。

    ArcGIS Pro では、ローカル シーンは、都市や都市近郊など、限られた空間範囲を持つ 3D データセットの表示に便利です。 ローカル シーンに表示されるデータは、投影座標系を使用する必要があります。

  7. マウス ホイール ボタンを使用して拡大表示し、マップをドラッグして画面移動します。 ツボルグ港付近を調べます。

    この地区には、さまざまな近代的な建物、ボートのあるマリーナ、西端および北端の小さな建物、南東側の開発中のエリアがあります。

    注意:

    この範囲は、レッスンをすみやかに進められるよう制限されています。 実際の運用環境では、より広い近郊や都市全体を処理できます。

    次に、LIDAR データを準備して表示します。

LAS データセットの作成

LIDAR 点群データは通常、LAS ファイル形式で格納されています。 このレッスンでは、ツボルグ港地域は 2 つの LAS 点群にまたがっています。 それらを 1 つの LAS データセットにまとめます。

注意:

対象地域に広がる複数の LAS 点群ファイルを使用するのは、一般的なことです。 LAS データセットには、必要な数の LAS 点群を追加できます。

まず、2 つの LAS 点群ファイルを参照します。

  1. ウィンドウ上部のリボンで [表示] タブをクリックします。 [ウィンドウ] グループで、[カタログ ウィンドウ] をクリックします。

    カタログ ウィンドウ ボタン

    [カタログ] ウィンドウが表示されます。

  2. [カタログ] ウィンドウで、[フォルダー][Building_Extraction][Tuborg_Havn_data]、および [LAS_data] を展開します。

    展開されたフォルダー

    [PUNKTSKY_1km_6181_724.las] および [PUNKTSKY_1km_6181_725.las] は、ツボルグ港近辺に広がる LAS 点群ファイルです。

    注意:

    この 2 つの LAS 点群は、デンマーク政府が管理する、デンマーク全体を含む LIDAR を生成したプロジェクトから取得したものです。

    次に、LAS データセットを作成します。

  3. [LAS_data] フォルダーを右クリックし、[新規作成] をポイントして [LAS データセット] を選択します。

    [LAS データセット] オプション

    新しい LAS データセットが [カタログ] ウィンドウの [LAS_Data] フォルダーに追加され、データセットの名前が編集可能になります。

  4. Tuborg_Havn」と入力して Enter キーを押します。

    拡張子が自動的に追加され、[Tuborg_Havn.lasd] という名前がリストに表示されます。

    [Tuborg_Havn.lasd] は LAS データセットですが、この時点では空です。 次に、データを追加します。

  5. [Tuborg_Havn.lasd] を右クリックして [プロパティ] を選択します。

    プロパティのオプション

  6. [LAS データセット プロパティ] ウィンドウの [LAS ファイル] タブをクリックします。
  7. [ファイル] の下の [ファイルの追加] をクリックします。

    [ファイルの追加] ボタン

  8. [開く] ウィンドウで、[Tuborg_Havn_data] を参照して [LAS_data] をダブルクリックします。
  9. Shift キーを押して [PUNKTSKY_1km_6181_724.las] および [PUNKTSKY_1km_6181_725.las] をクリックし、これらのファイルを両方とも選択します。 [開く] をクリックします。

    選択された LAS ファイル

    2 つのファイルがリストに追加されました。 [ポイント数] の値に応じて、各 LAS ファイルには 300 万から 500 万の間のポイントが含まれています。 [ポイント間隔] の値は、ポイントとポイントの間が約 0.3 メートルであることを示しています。

    [ポイント数] と [ポイント間隔] の値

  10. [一般] タブをクリックします。

    このタブには、新しい LAS データセットの全体的な情報がまとめられています。 2 つの LAS データセットがあり、8,127,305 個の LAS ポイントが含まれていることがわかります。 データの [範囲] の値や、水平 (XY) および垂直 (Z) の単位 (メートル) も表示されています。

    [LAS データセット プロパティ] ウィンドウの [一般] タブ

  11. [統計情報] タブをクリックします。

    [LAS データセット プロパティ] ウィンドウの [統計] タブ

    このタブでは、[分類コード] の下に、LAS ポイントに割り当てられた分類コードのリストが表示されます。 この時点では、ポイントは分類コードを割り当てられていないので、表示されている分類コードは [未分類] のみです。 このレッスンで、地表、建物、ノイズなどの新しいクラスを追加します。

  12. [座標系] タブをクリックします。

    投影座標系は ETRS 1989 UTM Zone 32N です。 これは、元の LAS ファイルから [Tuborg_Havn.lasd] データセットに引き継がれた座標系です。 レッスンでは、この座標系を使用します。

    Tuborg_Havn.lasd レイヤーの投影座標系

  13. [OK] をクリックして [LAS データセット プロパティ] ウィンドウを閉じます。

LAS データセットの表示と調査

次に、LAS データセットをシーンに追加して調べます。 今のところオルソ フォトは必要ないのでオフにします。

  1. [コンテンツ] ウィンドウで、[Tuborg_Havn_Ortho_Photo.tif] のチェックボックスをオフにして、レイヤーを非表示にします。

    レイヤーをオフにした状態

  2. [カタログ] ウィンドウで、[Tuborg_Havn.lasd] データセットを右クリックして [現在のマップに追加] を選択します。

    マップに [Tuborg_Havn.lasd] データセットが表示されます。

    マップ上の [Tuborg Havn LAS] データセット

  3. [コンテンツ] ウィンドウで、[Tuborg_Havn.lasd] を展開します。

    [コンテンツ] ウィンドウで [Tuborg_Havn.lasd] レイヤーを展開する

    凡例では、LAS データセットは、ポイントの高さに応じてシンボル表示されています。 最も低いポイントは濃い紫、最も高いポイントは明るい赤で表示されます。 今度は点群を 3D で調べてみましょう。

  4. シーンの [ナビゲーター] ホイールの上にある [フル コントロールの表示] をクリックします。

    [ナビゲーター] ホイールの [フル コントロールの表示] ボタン

    [ナビゲーター] ホイールが拡張され、3D ナビゲーション機能が追加されます。

  5. 中央の [ナビゲーター] ホイールを使用して、シーンの傾斜や回転を行います。

    傾斜および回転したシーン

    ヒント:

    C キーを押しながらシーンをドラッグして画面移動するか、V キーを押しながらシーンをドラッグして傾けることもできます。

  6. 個々の LAS ポイントを確認できるまで拡大します。

    個々の LAS ポイントを表示するように拡大されたシーン

  7. LAS データセットがワイヤーフレームとして表示されるまで縮小します。

    LAS データセットがワイヤーフレームとして表されるように縮小されたシーン

    ワイヤーフレームは、両方のファイルの範囲と、そのファイルに含まれているポイントの最大の高さを示します

  8. 引き続き、点群データセットを調べます。 拡大/縮小、傾斜、回転、および画面移動して、建物、樹木、地面、その他の要素を横から見てみます。
  9. [クイック アクセス ツールバー] で、[保存] ボタンをクリックして、プロジェクトを保存します。

    クイック アクセス ツールバーの保存

    ヒント:

    Ctrl + S キーを押してプロジェクトを保存することもできます。

2 つの LAS 点群ファイルを含む LAS データセットを作成しました。 また、そのデータセットをマップに追加して調べました。 続いて、LAS データセットを、地表や建物など、いくつかのクラスに分類します。


LAS データセットの分類

ここで、クラウド ポイントの位置や特性を解析し、所属するクラスを決定するツールを使用して、LAS データセットを地表や建物などの複数のクラスに分類します。

注意:

一部の LAS 点群は、すでに分類された状態でプロバイダーから取得されます。 このような場合は、このワークフローの分類ステップをすべてスキップしてください。

LAS 地表ポイントの分類

まず、LAS ポイント クラスが見やすくなるように、シンボルを変更します。

  1. [コンテンツ] ウィンドウで、[Tuborg_Havn.lasd] が選択されていることを確認します。 [Tuborg_Havn.lasd] を右クリックして、[レイヤーの全体表示] を選択します。

    Tuborg_Havn.lasd レイヤーの [レイヤーの全体表示]

  2. リボンの [表示設定] タブの [描画] グループで、[シンボル] 下矢印をクリックし、[クラス] を選択します。

    [クラス] オプション

    シンボルに各ポイントの分類が表示されるようになりました。 現在、すべて未割り当てのため、すべてグレーでシンボル表示されています。

    [コンテンツ] ウィンドウには、設定可能なクラスのリストが表示されますが、そのほとんどが LAS データセットでは現在使用されていません。

    クラスのリスト

    次に、地表ポイントを分類します。

    注意:

    データを作成した航空機の元のフライト ラインが原因で、LAS ファイル同士がオーバーラップしている場所があります。 重複ポイントはノイズを生成する可能性があるため、まず [LAS オーバーラップの分類 (Classify LAS Overlap)] ツールを使用して重複ポイントを特定した後、オフにします。 ただし、現在のデータにオーバーラップは存在しません。 このツールを実行する必要はありません。

  3. リボンの [表示] タブの [ウィンドウ] グループで、[ジオプロセシング] をクリックします。

    [ジオプロセシング] ボタン

    [ジオプロセシング] ウィンドウが表示されます。 まず、[LAS の地表分類 (Classify LAS Ground)] ツールを使用します。

  4. [ジオプロセシング] ウィンドウで「Classify LAS Ground」と入力し、結果リストの [LAS の地表分類 (Classify LAS Ground)] をクリックして開きます。

    「Classify LAS Ground」の検索結果

  5. [LAS の地表分類 (Classify LAS Ground)] ツール ウィンドの [入力 LAS データセット] で、[Tuborg_Havn.lasd] を選択します。

    [LAS の地表分類] ツールのパラメーター

  6. その他のパラメーターはデフォルトのままにし、[実行] をクリックします。
    注意:

    LAS 点群内のすべての地表ポイントを特定するため、[LAS の地表分類 (Classify LAS Ground)] ツールでは、シーン全体で一貫して標高が最も低いポイント セットを検索するなどの手法を使用します。

    プロセスが完了すると、LAS 地表ポイントはシーン内に茶色で表示されます。

  7. LAS 地表ポイントを拡大して、ポイントが地表エリアには表示されるものの、建物、植生、車両、またはボートの位置には表示されず、未分類のままである状況を確認します。

    LAS 地表ポイント

    水域に位置する一部のポイントは地表に分類されていました。 ただし、今回のワークフローでは、地面と水を区別する必要はないため、問題ありません。

  8. LAS 点群全体が表示されるまで縮小します。

DEM の生成

LAS 地表ポイントを使用して DEM を作成します。これはワークフローの後半で役立ちます。 DEM は、地表の標高を連続ラスターで表します。 [LAS データセット → ラスター (LAS Dataset To Raster)] ツールを使用して DEM を生成します。 このツールは地表ポイントのみで実行する必要があるため、未割り当てのポイントはオフにします。

  1. リボンの [表示設定] タブの [フィルター] グループで、[LAS ポイント] をクリックします。

    [LAS ポイント] ボタン

    [レイヤー プロパティ] ウィンドウの [LAS フィルター] タブに、さまざまなタイプのポイントが表示されます。 タイプはそれぞれオン/オフを切り替えることができます。 [分類コード] の下に、現在設定可能な 2 つのクラス ([1 未分類] および [2 地表]) が表示されます。

  2. [レイヤー プロパティ] ウィンドウの [LAS フィルター] タブの [分類コード] の下にある [未割り当て] クラスをオフにして、そのカテゴリに所属するポイントをオフにし、[OK] をクリックします。

    [未割り当て] クラスをオフ

    未割り当てのポイント (グレー) がマップに表示されなくなります。 ここで、[LAS データセット → ラスター (LAS Dataset to Raster)] ツールを実行して、DEM を生成します。

  3. [ジオプロセシング] ウィンドウの [戻る] ボタンをクリックします。

    戻るボタン

  4. [LAS データセット → ラスター (LAS Dataset to Raster)] ツールを検索して開きます。
  5. [LAS データセット → ラスター (LAS Dataset to Raster)] ツール ウィンドウで、次のパラメーターを設定します。
    • [入力 LAS データセット][Tuborg_Havn.lasd] レイヤーを選択します。
    • [出力ラスター] に「Tuborg_Havn_DEM」と入力します。
    • [内挿タイプ][TIN 化] を選択します。
    • [内挿方法][最近隣内挿法 (Natural Neighbor)] を選択します。
    • [サンプリング値] に「0.5」と入力します。

    [LAS データセット → ラスター (LAS Dataset To Raster)] ツールのパラメーター

    注意:

    LAS 地表ポイントは地表の標高に関する多くの情報を提供していますが、各ポイント間で標高が不明な空間が存在します。 [LAS データセット → ラスター (LAS Dataset to Raster)] ツールは数学モデルを使用し、既存の地表ポイントの値に基づいて、これらの不明な地域の標高を計算 (予測) します。 このプロセスを内挿と呼びます。 さまざまな内挿オプションについては、[LAS データセット → ラスター (LAS Dataset to Raster)] ツール ドキュメントをご参照ください。

    ラスターはピクセルまたはセルのグリッドです。 [サンプリング値] パラメーターは、各セルのサイズを示しています。 ポイント間の間隔 (約 0.3 メートル) よりも大きい必要があります。 試行錯誤の結果、このデータセットで最良の結果が得られることが判明した 0.5 メートルを使用します (1 メートルも合理的な可能性があります)。 このレッスンでは、すべてのラスターがこのセル サイズを使用します。

  6. その他のパラメーターはすべてデフォルトのままにし、[実行] をクリックします。

    プロセスが完了すると、[Tuborg_Havn_DEM] ラスターが表示されます。 このラスターは、暗い色のポイントが最も低い標高、明るい色のポイントが最も高い標高を表す滑らかなサーフェスです。

  7. [コンテンツ] ウィンドウで、[Tuborg_Havn.lasd] レイヤーをオフにすると、DEM が見やすくなります。

    マップ上の DEM

    ツボルグ港は複雑な都市景観であるため、DEM は通常の道路レベルを超えたさまざまなバリエーションを示しています。 これには、地下道や駐車場への入り口、建物群がそびえる高台、マリーナの水位などが含まれます。

LAS ノイズ ポイントの分類

これで LAS 地表ポイントを特定したので、次のステップでは残りの未割り当てポイントからノイズ ポイントを特定します。 ノイズ ポイントとは、異常に高いポイントまたは低いポイントのことを指し、LIDAR データのランダム エラーの結果と考えられます。

  1. [コンテンツ] ウィンドウで、[Tuborg_Havn_DEM] ラスターをオフにし、[Tuborg_Havn.lasd] レイヤーをオンにします。 必要に応じて、[Tuborg_Havn.lasd] レイヤーをクリックして選択します。
  2. リボンの [表示設定] タブで、[LAS ポイント] をクリックします。 表示された [レイヤー プロパティ] ウィンドウの [分類コード] の下で、[地表] クラスをオフにし、[未割り当て] クラスをオンにします。 [OK] をクリックします。

    未割り当てのポイントがシーン上にグレーで表示されます。

    マップ上の未割り当てのポイント

  3. [ジオプロセシング] ウィンドウの [戻る] ボタンをクリックします。 [LAS ノイズの分類 (Classify LAS Noise)] ツールを検索して開きます。
  4. [LAS ノイズの分類 (Classify LAS Noise)] ツール ウィンドウで、次のパラメーターを設定します。
    • [入力 LAS データセット][Tuborg_Havn.lasd] レイヤーを選択します。
    • [方法] で、[地表からの相対高度] を選択します。

    [LAS ノイズの分類] ツールのパラメーター

  5. [高さ検出] セクションを展開して、次のパラメーターに値を設定します。
    • [地表] で、[Tuborg_Havn_DEM] を選択します。
    • [最小高さ] に、「-2」と入力します。
    • [最大高さ] は空白のままにします。

    [LAS ノイズの分類] ツール ウィンドウの [高さ検出] パラメーター

  6. [実行] をクリックします。

    高ノイズを特定するため、今回は [絶対高度] メソッドを使用して、ツールを再度実行します。 標高が 42 メートル以上のポイントを高ノイズに分類します。

    注意:

    最大値に 42 メートルを選択しているのは、ツボルグ近郊の建物の最大標高は約 40 メートルであるためです。 これは LAS 点群を探索することで確認できます。 建物の最大標高を見つけるには、拡大して確認できる最も高いポイントをクリックします。 ポップアップ ウィンドウには、そのポイントの標高がメートル単位で表示されます。

  7. [LAS ノイズの分類 (Classify LAS Noise)] ツール ウィンドウの [方法] で、[絶対高度] を選択します。
  8. [高さ検出] セクションの [最小高さ] で、既存のテキストを削除します。 [最大高さ] に、「42」と入力します。

    [方法] が [絶対高度] に設定された [LAS ノイズの分類] ツールのパラメーター

  9. [実行] をクリックします。

    一部の LAS ポイントが低ノイズと高ノイズに分類されるようになりましたが、デフォルトでオフになっているため表示されません。

  10. リボンの [表示設定] タブで、[LAS ポイント] をクリックします。 表示された [レイヤー プロパティ] ウィンドウの [分類コード] で、[7 低ノイズ] および [18 高ノイズ] クラスをオンにし、その他のクラスをすべてオフにして、[OK] をクリックします。

    [レイヤー プロパティ] ウィンドウの [分類コード] の下でオンにされた [低ノイズ] および [高ノイズ]

  11. ツボルグ港近郊を探索し、赤色でシンボル表示された LAS ノイズ ポイントを見つけます。

    たとえば、近郊の南側に高ノイズ ポイントが確認できます。 建設用クレーンに対応していると考えられます。

    マップ上のノイズ

    残りの解析を行うため、これらをオフにします。

  12. [表示設定] タブで、[LAS ポイント] をクリックします。 表示された [レイヤー プロパティ] ウィンドウの [分類コード] で、[未割り当て] クラスをオンにし、その他のクラスをすべてオフにします。 [OK] をクリックします。

建物ポイントの分類

これで LAS 地表ポイントとノイズ ポイントが分類され、表示されないようにしたため、次は建物ポイントを分類します。

  1. [ジオプロセシング] ウィンドウの [戻る] ボタンをクリックします。 [LAS の建物分類 (Classify LAS Building)] ツールを検索して開きます。
  2. [LAS の建物分類 (Classify LAS Building)] ツール ウィンドウで、次のパラメーターの値を設定します。
    • [入力 LAS データセット][Tuborg_Havn.lasd] レイヤーを選択します。
    • [屋上の高さの最小値] が「2」に設定され、単位がメートルに設定されていることを確認します。
    • [最小エリア] に「10」と入力し、単位が平方メートルに設定されていることを確認します。
    • [分類方法][積極的] を選択します。

    [LAS の建物分類] ツールのパラメーター

    注意:

    [LAS の建物分類 (Classify LAS Building)] ツールでは、建物ポイントを特定するために、複数の方法を組み合わせて使用しています。 ツールを実行する前に、地表ポイントを分離しておくことが重要です。 このツールは、未割り当てポイントのうち、レーザー パルスごとの反射が 1 回のみだった平坦なサーフェスを識別します。 一方、樹木が存在する地域は、葉や地表の複数のレベルに光が届いて反射するため、レーザー パルスごとの反射が数回存在する場合があります。

    [屋上の高さの最小値] および [最小エリア] パラメーターは、標高が低すぎるか面積が小さすぎるサーフェスが、誤って建物に分類されないようにするためにも重要です。

    [分類方法] では、点を控えめに建物として分類するか、積極的に分類するかを指定します。

    このレッスンでは、建物に正しく分類されるポイントの数を最大限に高めながら、フォールス ポジティブを最小限に抑えるパラメーター値を試行錯誤しながら選択しました。 引き続きご自身で試してみてください。

  3. [実行] をクリックします。
  4. 処理が完了したら、[表示設定] タブで、[LAS ポイント] をクリックします。 [レイヤー プロパティ] ウィンドウの [分類コード] で、[6 建物] クラスをオンにし、その他のクラスをすべてオフにして、[OK] をクリックします。

    建物ポイントがシーンに表示されます。

    マップ上の建物ポイント

    注意:

    未割り当てのポイントがまだたくさんあります。 たとえば、[高さによる LAS の分類 (Classify LAS By Height)] ツールを使用して、[低植生][中植生]、および [高植生] クラスに所属するポイントを特定するなどして、引き続きポイントを詳細に分類できます。 ただし、3D 建物の抽出に植生情報は必要ないため、このレッスンではこれ以上の分類は実行しません。

  5. プロジェクトを保存します。

LIDAR クラウド ポイントを、地表、低ノイズ、高ノイズ、および建物に分類しました。 地表の標高を連続ラスターで表す DEM も生成しました。 次に、LAS 建物ポイントを使用して、対象地域全体の 2D 建物フットプリントを抽出します。


建物フットプリントの抽出

次に、建物に分類された LAS ポイントを使用して、2D 建物フットプリントを抽出します。 まず、LAS 建物ポイントの場所を示すラスターを生成します。 続いて、ラスターによって建物の存在を示すポリゴンを生成します。 最後に、ポリゴンをクリーンナップして、最終的な建物フットプリント ベクター レイヤーを生成します。

建物ラスターの生成

ワークフローのこの部分は、表示により多くの処理リソースを使用する 3D 表示機能が不要なので、2D マップで行います。 シーンを 2D マップに変換します。

  1. 必要に応じて、リボンの [表示] タブにある [ウィンドウ] グループで、[カタログ] ウィンドウをクリックします。
  2. [カタログ] ウィンドウで、[マップ] を展開します。 [シーン] を右クリックして [変換] をポイントし、[マップに変換] を選択します。

    [マップに変換] オプション

    元の 3D シーンのレイヤーを含む新しい 2D マップが、[Scene_2D] という名前で表示されます。 名前を変更します。

  3. [カタログ] ウィンドウで、[Scene_2D] を右クリックして [名前の変更] をクリックします。 「2D Map」と入力して Enter キーを押します。

    [2D Map] がリストに表示されます。

    名前が変更されたマップ

  4. [2D Map] タブが選択されていることを確認し、必要に応じて、LAS 建物ポイントを表示できるまで拡大します。

    2D マップ

    この時点では、マップには LAS 建物ポイントが表示されています。

    作成する建物フットプリントと実際の建物の関係がわかるよう、オルソ フォトを有効にします。

  5. [コンテンツ] ウィンドウで、[Tuborg_Havn_Ortho_Photo.tif] イメージ レイヤーを有効にします。
  6. 必要に応じて、[コンテンツ] ウィンドウで [Tuborg_Havn.lasd] レイヤーを [Tuborg_Havn_Ortho_Photo.tif] の上の該当位置にドラッグします。

    順序を変更したレイヤー リスト

    オルソ フォトは、実際の建物がどのように見えるかを示します。 ただし、写真の遠近法により、建物のフットプリントと下にある建物を視覚的に完全に一致させることが難しい場合があります。

    建物フットプリントとその下の建物

    次に、LAS 建物ポイントの位置に対応するラスターを作成します。 ラスターの作成には、[LAS ポイント統計をラスターに出力 (LAS Point Statistics As Raster)] ツールを使用します。このツールは、ラスターの各セルの LAS 建物ポイントを検出します。 建物ポイントがある場合、セルの値は建物のクラス コード (6) になります。建物ポイントがない場合、セルは空 (NoData) のままです。

  7. 必要に応じて、リボンの [表示] タブにある [ウィンドウ] グループで、[ジオプロセシング] をクリックします。 必要に応じて、[ジオプロセシング] ウィンドウの [戻る] ボタンをクリックします。
  8. [LAS ポイント統計をラスターに出力 (LAS Point Statistics As Raster)] ツールを探して開きます。
  9. [LAS ポイント統計をラスターに出力 (LAS Point Statistics As Raster)] ツール ウィンドウで、以下のパラメーターを設定します。
    • [入力 LAS データセット][Tuborg_Havn.lasd] レイヤーを選択します。
    • [出力ラスター] に「Buildings_Raster」と入力します。
    • [メソッド][クラス コードの最頻値] を選択します。
    • [サンプリング値] に「0.5」と入力します。

    [LAS ポイント統計をラスターに出力 (LAS Point Statistics As Raster)] ツールのパラメーター

  10. [実行] をクリックします。

    新しく [Buildings_Raster] レイヤーが表示されます。

    レイヤーを確認しやすくするため、LAS データセットをオフにしてラスターのシンボルを変更します。

  11. [コンテンツ] ウィンドウで、[Tuborg_Havn.lasd] レイヤーをオフにします。
  12. [コンテンツ] ウィンドウで、[Buildings_Raster] のシンボルを右クリックしてドロップダウン リストを展開し、[名前の表示] をオンにして [赤紫 (連続)] 配色を選択します。

    赤紫 (連続) 配色

    ラスターがピンクになります。

  13. 拡大して、ラスターの建物をいくつか調べます。

    マップ上の建物

    建物の全体的な形状は正確ですが、建物にいくつかの穴があり、枠線が不規則に見えます。 また、ピンクの形状の一部が実際の建物に対して小さすぎるので、削除する必要があります。 これらの問題は、ワークフローの後半で解決します。ただし、最初の段階で、建物ラスターをポリゴン レイヤーに変換しておきます。

建物フィーチャクラスの生成

続いて、[ラスター → ポリゴン (Raster to Polygon)] ツールを使用して、建物ラスターをポリゴン レイヤーに変換します。 ラスター内の建物セルのクラスターが、新しいレイヤーでポリゴンになります。

  1. [ジオプロセシング] ウィンドウの [戻る] ボタンをクリックします。 [ラスター → ポリゴン (Raster to Polygon)] ツールを探して開きます。
  2. [ラスター → ポリゴン] ツール ウィンドウで、次のパラメーターを設定します。
    • [入力ラスター][Buildings_Raster] を選択します。
    • [出力ポリゴン フィーチャ] に「Buildings_Raw」と入力します。
    • [ポリゴンの単純化] をオフにします。
    注意:

    [ポリゴン単純化] オプションを選択すると、ポリゴンの基本的なクリーンナップを行うことができます。 または、ワークフローの後半でより高度なツールを使用して、より質の高い結果を得ます。

    ラスター → ポリゴン ツールのパラメーター

  3. [実行] をクリックします。

    [Buildings_Raw] という名前の新しいフィーチャ レイヤーが表示されます。 今は、[Buildings_Raster] レイヤーをオフにすることができます。

  4. [コンテンツ] ウィンドウで、[Buildings_Raster] レイヤーをオフにします。
  5. [Buildings_Raw] のシンボルを右クリックして [フクシア ピンク] を選択します。
    ヒント:

    色の名前を表示するには色にカーソルを合わせます。

    フクシア ピンク色

    [Buildings_Raw] レイヤー シンボルが更新されます。

建物ポリゴンのクリーンナップ

建物フットプリントを表すポリゴンが作成されました。 ただし、クリーンナップする必要があります。

  1. 新しいポリゴン レイヤーを拡大して調べます。

    マップ上の新しいポリゴン レイヤー

    建物ラスターと同じ問題があることがわかります。

    • 一部のポリゴンは、実際の建物に対して小さすぎるので、削除する必要があります。
    • ほとんどのポリゴンに穴があります。
    • 建物の縁が不規則です。

    クリーンナップ処理の最初の手順として、最も小さいポリゴンを除外します。 まず、削除するポリゴンの面積のカットオフ値を決定します。

  2. [コンテンツ] ウィンドウで、[Buildings_Raw] レイヤーをクリックして選択します。

    [コンテンツ] ウィンドウで選択された [Buildings_Raw] レイヤー

  3. マップで、小さいピンクのポリゴンをいくつかクリックして、情報が表示されたポップアップ ウィンドウを開き、[Shape_Area] 属性の値に注目してサイズを把握します。 除外しない建物についても同じ作業を行います。

    [Shape_Area] 属性がハイライト表示されたポップアップ

    確認したポリゴンのサイズに基づき、除外する面積の値を 70 平方メートルにします。 次に、その値より大きいポリゴンを選択します。

  4. [ポップアップ] ウィンドウを閉じます。
  5. [ジオプロセシング] ウィンドウの [戻る] ボタンをクリックします。 [属性検索 (Select Layer By Attribute)] ツールを検索して開きます。
  6. [属性検索 (Select Layer By Attribute)] ツール ウィンドウの [入力行] で、[Buildings_Raw] を選択します。
  7. [式] の下で、「Where 句 Shape_Area が 70 以上」という式を作成します。

    [属性検索 (Select Layer By Attribute)] ツール ウィンドウで、「Where 句 Shape_Area が 70 以上」という式を作成します。

  8. [実行] をクリックします。

    70 平方メートル以上のすべてのポリゴンが選択されました。

    マップ上で選択された建物

    次に、[ポリゴン パートの削除 (Eliminate Polygon Part)] ツールを使用して、建物ポリゴンの穴を削除します。 調べた結果、50 平方メートル以下の穴を埋める必要があると結論付けることができます。

  9. 条件以上の大きさの建物ポリゴンを選択した状態で、[ジオプロセシング] ウィンドウの [戻る] ボタンをクリックします。 [ポリゴン パートの削除 (Eliminate Polygon Part)] ツールを探して開きます。
  10. [ポリゴン パートの削除 (Eliminate Polygon Part)] ツール ウィンドウで、次のパラメーターを設定します。
    • [入力フィーチャ][Buildings_Raw] を選択します。
    • [出力フィーチャクラス] に、「Buildings_Clean」と入力します。
    • [エリア] に「50」と入力し、単位が平方メートルに設定されていることを確認します。

    [ポリゴン パートの削除 (Eliminate Polygon Part)] ツールのパラメーター

  11. [実行] をクリックします。

    新しいフィーチャ レイヤーが表示されます。 新しいポリゴンのほとんどには穴がありません。また、条件以上の大きさのポリゴンにのみツールが適用されたので、小さいポリゴンはすべて除外されました。

    新しいレイヤーが見やすくなるよう、[Buildings_Raw] レイヤーをオフにします。

  12. [コンテンツ] ウィンドウで、[Buildings_Raw] レイヤーをオフにします。

    マップ上でクリーンナップされた建物レイヤー

    続いて、建物の枠線を滑らかにします。

  13. [ジオプロセシング] ウィンドウの [戻る] ボタンをクリックします。 [建物フットプリントの正規化 (Regularize Building Footprint)] ツールを探して開きます。

    このツールは、抽出された建物ポリゴンの以下のようなギザギザの枠線をクリーンナップし、滑らかにします。

    ギザギザの枠線が滑らかになる様子を示した図

  14. [建物フットプリントの正規化 (Regularize Building Footprint)] ツール ウィンドウで、次のパラメーターを設定します。
    • [入力フィーチャ][Buildings_Clean] を選択します。
    • [出力フィーチャクラス] に、「Buildings_Footprints」と入力します。
    • [方法][直角] に設定されていることを確認します。
    • [許容値] に「1」と入力します。
    • [密度] に「1」と入力します。
    • [精度] に「0.15」と入力します。

    [建物フットプリントの正規化 (Regularize Building Footprint)] ツールのパラメーター

    [直角] の方法は、完全な直角の建物の作成に重点を置いています。 [任意の角度] などのその他のオプションは、構造が複雑で規模の大きい建物の場合に有用ですが、小さくてシンプルな建物を完全に単純化できない可能性があります。 この演習では行いませんが、ツールを 2 回実行するというオプションがあります。それぞれ、異なる設定と異なる建物を選択して実行します。

    [許容値] は、正規化されたフットプリントが、元のフィーチャの境界から外れることができる最大距離です。 通常は、元のラスター セル (この演習では 0.5 メートル) の約 2 倍のサイズを選択することをお勧めします。

    [密度] は、正規化されたフィーチャが直線か曲線かを評価するのに使用されるサンプリング間隔を決定します。

    [精度] は、正規化プロセスで使用されるグリッドの正確さを定義します。 0.05 ~ 0.25 の値を指定でき、試行錯誤により値を微調整することができます。

  15. [実行] をクリックします。

    正規化された建物ポリゴンを示した新しいフィーチャ レイヤーが表示されます。

  16. [コンテンツ] ウィンドウで [Buildings_Clean] レイヤーをオフにします。
  17. プロジェクトを保存します。

手作業による建物フットプリントの改善

[Building_Footprints] レイヤーは、全体的には正確なフットプリントを構築します。 ささいな欠陥はありますが、このワークフローではそれらを気にする必要はありません。 ただし、いくつかのポリゴンに、修正すべきやや大きな問題が含まれている可能性があります。 そのような問題には、手作業ですばやく解決する方法があります。

まず、いくつかのポリゴンは、建物ではなく高い場所に設置された運動場です。 レイヤーからそれらのポリゴンを削除します。

  1. 以下の画像でハイライト表示されている建物群を検索します。

    ハイライト表示された建物

    この地域の 2 つのポリゴンは、高い場所に設置された運動場です。

    マップ上の高い場所の運動場

  2. リボンの [編集] タブの [選択] グループで、[選択] をクリックします。

    選択ボタン

  3. 最初の運動場ポリゴンをクリックして選択します。

    マップ上で選択された運動場ポリゴン

  4. リボンの [編集] タブの [フィーチャ] グループで、[削除] をクリックします。

    削除 ボタン

  5. 必要に応じて、表示された [削除] 確認ウィンドウで [はい] をクリックします。

    ポリゴンが削除されました。

  6. 2 つ目の運動場ポリゴンを選択して削除します。
  7. リボン上の [編集] タブにある [編集の管理] グループで、[保存] をクリックして、編集内容を保存します。 [編集の保存] ウィンドウでプロンプトが表示されたら、[はい] をクリックします。

    保存ボタン

  8. リボンの [マップ] タブにある [ナビゲーション] グループで、[マップ操作] をクリックして、選択モードを終了します。

    マップ操作ボタン

    次に、ポリゴンの形状を修正します。 場合によっては、以下の画像に見られるような、LIDAR データからの建物フットプリントの正常な抽出を妨げる問題があります。

    問題のある建物フットプリント

    この問題は主に、金網で保護されている空調機器が原因であると考えられます。 そのようなポリゴンを検索して、形状を変更します。

  9. 以下の画像でハイライト表示されている建物を探して拡大します。

    ハイライト表示された、問題のある建物フットプリント

  10. リボンの [編集] タブの [ツール] グループで、[形状変更] をクリックします。

    [形状変更] ボタン

  11. マップで、ポリゴンをクリックして選択します。
  12. 以下の画像で印が付いている 3 つのポイントをクリックして、ポリゴンの形状を変更します。

    印が付いているポイント

  13. 最後のポイントをダブルクリックします。

    ポリゴンの形状が変更されました。

    形状変更されたポリゴン

    ヒント:

    操作を誤った場合は、Ctrl + Z キーを押して再度操作します。

  14. リボン上の [編集] タブにある [編集の管理] グループで、[保存] をクリックします。 [編集の保存] に対するプロンプトが表示されたら、[はい] をクリックします。
  15. [編集] タブの [選択] グループで、[選択解除] をクリックしてポリゴンの選択を解除します。

    [編集] タブの [選択] グループでの [選択解除]

  16. [マップ] タブにある [ナビゲーション] グループで、[マップ操作] をクリックして、選択モードを終了します。
  17. [フィーチャの修正] ウィンドウを閉じます。

    引き続き他の建物の微調整もできますが、このレッスンの目的のため、次の手順に進みます。

抽出された建物フットプリントの評価

建物フットプリントが正常に抽出された結果を評価するため、建物フットプリントを含む地形図ベースマップと比較します。ただし、これらのフットプリントは、分析目的では使用できません。

  1. [コンテンツ] ウィンドウで、[Tuborg_Havn_Ortho_Photo.tif] レイヤーをオフにし、ベースマップを表示します。
  2. 必要に応じて、[Building_Footprints] レイヤーをクリックして選択します。 リボンの [表示設定] タブの [比較] グループで、[スワイプ] を選択します。

    [表示設定] タブの [比較] グループ内のスワイプ ツール

  3. 前後にスワイプして、[Building_Footprints] レイヤーをベースマップのフットプリントと比較します。

    スワイプ ツール

    全体としては、LIDAR から取得した建物フットプリントは、ベースマップの建物フットプリントと非常に似ています。これは、ここで完了したワークフローが適切であったことを示しています。

  4. リボンで [マップ] タブの [ナビゲーション] グループで、[マップ操作] をクリックし、[スワイプ] ツールを非アクティブにします。
  5. プロジェクトを保存します。

ジオプロセシング ツールと編集ツールを使用して、建物フィーチャクラスを生成し、クリーンナップを行いました。


写実的な 3D 建物の抽出

LAS データセットから、写実的な 3D 建物を抽出します。 そのため、これまでに作成したすべてのエレメント (建物に分類された LAS ポイント、DEM ラスター、および建物フットプリント) を使用します。 抽出結果として、複雑な 3D ベクター フィーチャを格納できる形式のマルチパッチ レイヤーが得られます。

マルチパッチ レイヤーの作成

建物の 3D 表示が可能な 3D シーンでこのセクションを実行します。まず初めに、[Building_Footprints] レイヤーをコピーします。

  1. [コンテンツ] ウィンドウで [Building_Footprints] レイヤーを右クリックし、[コピー] をクリックします。

    [コピー] オプション

  2. [シーン] タブをクリックしてアクティブにします。

    [シーン] タブ

  3. [コンテンツ] ウィンドウで、[シーン] を右クリックして [貼り付け] をクリックします。

    [貼り付け] オプション

    [Building_Footprints] レイヤーがシーンに追加されます。 続いて、3D 建物を生成します。

  4. 必要に応じて、リボンの [表示] タブにある [ウィンドウ] グループで、[ジオプロセシング] をクリックします。 必要に応じて、[ジオプロセシング] ウィンドウの [戻る] ボタンをクリックします。
  5. [ジオプロセシング] ウィンドウで、[LAS 建物マルチパッチ] ツールを探して開きます。
  6. [LAS 建物マルチパッチ] ツール ウィンドウで、次のパラメーター値を設定します。
    • [入力 LAS データセット][Tuborg_Havn.lasd] レイヤーを選択します。
    • [入力フィーチャ][Building_Footprints] を選択します。
    • [LAS 屋根ポイントの選択] で、[建物に分類されたポイント] が選択されていることを確認します。
    • [地表の高さ] は、[ラスタ レイヤー] のままで [Tuborg_Havn_DEM] を選択します。
    • [出力マルチパッチ フィーチャクラス] で、[データベース][Building_Extraction.gdb] の順に選択します。 [名前] に「Multipatch_3D_Buildings」と入力します。
    • [単純化許容値] に「0.5」と入力し、単位が [メートル] に設定されていることを確認します。

    [単純化許容値] には、DEM ラスター セルのサイズを選択することをお勧めします。

    [LAS 建物マルチパッチ] ツールのパラメーター

  7. [実行] をクリックします。

    3D の [Multipatch_3D_Buildings] レイヤーが表示されます。

  8. [コンテンツ] ウィンドウで、[Multipatch_3D_Buildings] とベースマップ以外のレイヤーをすべてオフにします。

    マルチパッチ 3D 建物の色を変更して、外観を整えることができます。

  9. [コンテンツ] ウィンドウで、[Multipatch_3D_Buildings] レイヤーのシンボルを右クリックし、[サハラ サンド] 色を選択します。

    サハラ サンド色

    建物の色が変わりました。

    サハラ サンド色でシンボル表示された建物

  10. 3D 建物を調べ、多くの建築の詳細部分が写実的に描かれている点に注目してください。
    注意:

    このワークフローでは、常にカートグラフィ面で満足のいく結果が生成されるとは限りませんが、位置の精度が確保されます。 この種の 3D レイヤーは、見通し線や可視領域など、特定の解析を実行する上で特に有用です。

    スムーズな結果が必要不可欠な 3D ベースマップを生成することが最終的な目標であれば、「都市開発に向けた屋根形状の抽出」レッスンに示されているように、単純化された屋根を生成するワークフローの方がより効果的な場合があります。

    一部の建物が、地表からやや浮き上がっています。 これは、地表レベルの参照として [Tuborg_Havn_DEM] レイヤーを使用して生成されたためです。 [Tuborg_Havn_DEM] は、非常に正確な LIDAR データから生成されているので、描写がやや異なり、地表を 3D でモデル化するためにシーンで使用されるデフォルトの [WorldElevation3D/Terrain3D] レイヤーより詳細にテレインが描かれています。

    [Tuborg_Havn_DEM] レイヤーをシーンの標高サーフェスに追加し、シーンがこのレイヤーを使用して、ツボルグ港近辺のテレインをより正確にモデル化できるようにします。

  11. [コンテンツ] ウィンドウの [標高サーフェス][地表] を右クリックし、[標高ソースの追加] を選択します。

    標高ソースの追加オプション

  12. [標高ソースの追加] ウィンドウで [データベース] を開き、[Building_Extraction.gbd] を開いて [Tuborg_Havn_DEM] をクリックします。 [OK] をクリックします。

    DEM が新しい地表の標高サーフェスとして追加されたので、これを使用するようシーンが更新されます。 一部の建物の下部のわずかな隙間が解消されます。

    標高サーフェス

  13. プロジェクトを保存します。

3D 建物マルチパッチ レイヤーは、さまざまな方法で使用できます。 シーンに追加して、都市計画活動をサポートすることができます。 洪水予測解析、日影影響解析、可視領域および見通し線解析などの実行に使用することもできます。

このレッスンで説明したワークフローは、LIDAR を使用した作業方法、および 3D 建物抽出プロセスの多くの構成要素について理解を深めることに重点を置きました。 このワークフローの詳細と大規模な 3D ベースマップを生成する方法については、Learn ArcGIS レッスン「都市開発に向けた屋根形状の抽出」をお試しください。

このレッスンでは、LIDAR データから 3D 建物を抽出しました。 LAS データセットの作成と分類、DEM ラスターの生成、建物フットプリント ベクター レイヤーの抽出を行いました。 最後に、それらのエレメントをすべて使用して、3D 建物マルチパッチ ベクター レイヤーを作成しました。

その他のレッスンについては、「Learn ArcGIS レッスン ギャラリー」をご参照ください。