Manage data

Publish a hosted feature layer from a CSV file

You already have a CSV spreadsheet with more than five years of reported coyote activity in Oakville. You'll publish this data as a hosted feature layer.

  1. Download the CSV file to your computer and open it in a text editor such as Notepad or Microsoft Excel.
    Note:

    This file includes data downloaded from the Town of Oakville Open Data Portal (licensed under the Open Government License—Town of Oakville). The data has been modified slightly for instructional purposes.

    The data has columns for x,y coordinates and other information such as location notes, type and date of observation, and comments. You’ll add this file to ArcGIS Online to visualize the locations on a map.

  2. Sign in to your ArcGIS organizational account.
    Note:

    If you don't have an organizational account, you can sign up for an ArcGIS free trial.

  3. On the ribbon, click Content.

    Content

  4. Click New item and

    Add an item from your computer.

  5. Drag and drop your downloaded coyotes_oakville.csv file from your computer.

    Next you will update the details in the New item window.

  6. Ensure Add CSV and create a hosted feature layer is checked and click Next.
  7. For the Fields page, leave all the fields on and click Next.
  8. On the Location settings page, leave the default fields and click Next.
    Tip:

    Review best practices for using layers in maps that perform well on the web.

    When you add a CSV file with location information (street addresses or coordinates), the features can be located on a map. In the field table, the Field Name column lists the field names (column headings) from the CSV file. In the Location Fields column, these field names are matched to appropriate categories of address information.

  9. In the New item window, on the File page, enter the following:
    • For Title, accept the default value and add your initials or name.
    • For Tags, type coyotes, crowdsource, Oakville, Ontario, Canada and press Enter after each tag.

    Add the item details

    Publishing a hosted feature layer allows you to share your data in a web map or app and configure it for reuse. Hosted feature layers also allow you to edit data, which supports community contributions.

  10. Click Save.

    The item is now added and the item page appears.

Update item details and configure the layer

Once you've created your feature layer, the item page for your layer appears. On the item page, you can edit details such as a brief summary of the item, a description, and terms of use. To help others understand the purpose of your content, you'll complete the item page. You can refer to the Item Information section for improvement recommendations.

  1. For Description, copy and paste the following text:

    Reported coyote activity in the Town of Oakville, Ontario Canada. This is the source data for a crowdsourcing solution being developed by the city. It has multiple purposes and audiences. The community can report coyote activity and view reports that have been reviewed for quality. City staff can view all recently reported coyote activity and collect new data in the field. City staff in the office can review and modify data for quality before sharing it with the community. This layer was created for instructional purposes only and should not be used as an authoritative resource.

  2. Click Add a brief summary about the item. In the Edit Summary box, type Reported coyote activity in the Town of Oakville, Ontario Canada. and click Save.

    Edit Summary

  3. For Terms of Use, click Edit and copy and paste the following text: This layer was created for instructional purposes using a modified version of the Coyote Encounters CSV data file downloaded from the Town of Oakville Open Data Portal (https://portal-exploreoakville.opendata.arcgis.com).
  4. Click Save.
  5. On the side of the item page, for Credits (Attribution), click Edit and copy and paste the following text: Contains information licensed under the Open Government License — Town of Oakville. (https://www.oakville.ca/data/open_data_licence.html).
  6. Click Save.

    Edit credits

    Now that you have a hosted feature layer with location data and corresponding attributes, you can query and update the data in ArcGIS Online. The CSV file includes columns for the x,y coordinates. ArcGIS used those coordinates to create the points in your layer, so you no longer need to keep the X and Y fields.

  7. Click the Data tab to view the table of fields and attributes for this layer.
  8. Click the X column header and choose Delete.

    Delete option for X field

  9. In the Delete Field window, click Delete Field to continue.
  10. Delete the Y field, and in the Delete Field window, click Delete Field to continue.

    The field names that appear in the column headers are what end users see when they're working with features in the layer. If necessary, you can provide names that are more meaningful.

  11. Click the Fields tab.

    Fields tab

  12. In the Display Name column, click Encounter_type to open settings for the field.
  13. Click the Edit button next to the display name and change the name to Type of observation. Click Save.

    Edit title

    Changing the display name of a field doesn't affect the field name stored in the attribute table. You can also create a list of suggested attribute values that users can choose when adding and editing features. The table already contains four unique values for this field (Encounter, Sighting, Feeding, and Garbage), so you'll populate the list with these values.

  14. Click the Create List button, click Generate List and click Save.

    Now when users add a feature, they can choose one of these values from a list instead of typing their own.

  15. On the ribbon, click the Visualization tab to view the data on a map. Click a feature on the map to display a pop-up.

    The pop-up includes the fields and values for the reported coyote activity. You can change the default configuration to control what information the pop-up displays. You'll update the title.

  16. Close the pop-up. On the layer's toolbar, click the Configure Pop-up button.

    Layer's toolbar with a box around the Configure Pop-up button

  17. For Pop-up Title, replace the text with Coyotes, and at the bottom of the pane, click OK. At the top of the page, click Save Layer.

    The Visualization settings allow you to configure the feature layer style and filter data to display what users will see when the layer is added to a map.

  18. On the ribbon, click the Settings tab. For Delete Protection, check Prevent this item from being accidentally deleted and click Save.

    There are many additional editing settings you can configure on the Settings tab. Although you want city staff to edit this layer, you also want the community to contribute, so you'll create multiple views instead. Hosted feature layer views allow you to publish your feature layer once and create multiple views to meet different viewing and editing requirements. The views reference the same source feature layer so you avoid duplicating data. Otherwise, if you publish multiple copies of the data with unique capabilities for each, you need to merge them periodically in ArcGIS Pro to keep them updated.

  19. Return to the Overview tab.

    Next, to further enhance performance, you will create additional hosted feature layer views by using Feature Definition to only allow relevant editing capabilities and displays for each audience in your group.

Create a hosted feature layer view

You identified three audience needs for your data: public viewing; public contributing; and city staff viewing, contributing, and updating. First, you'll create a view for city staff who need to report coyote activity and see all recent reports.

  1. Click Create View Layer.

    Create View Layer button

  2. In the Create View Layer window, for Title, type Coyotes_Oakville_Staff and add your initials. Accept the default tags and summary from the hosted feature layer and click OK.

    It takes a moment to create the view and publish the layer. The page refreshes and displays the item page for the new view.

  3. On the Coyotes_Oakville_Staff item page, update the item details as follows:
    • For the Description field, type City staff can use this layer to view, add, and update recently reported coyote activity in Oakville. Click Save.
    • For the Terms of Use, click Edit and copy and paste the following text: This layer was created for instructional purposes using a modified version of the Coyote Encounters CSV data file downloaded from the Town of Oakville Open Data Portal (https://portal-exploreoakville.opendata.arcgis.com). Click Save.
    • On the side of the item page, for Credits (Attribution), click Edit and copy and paste the text Contains information licensed under the Open Government License - Town of Oakville. (https://www.oakville.ca/data/open_data_licence.html). Click Save.
  4. Click the Data and Visualization tabs and confirm that they look the same as the source hosted feature layer.

    Map of points showing reported coyote activity

Configure how others can use the data

You can set view definitions to hide fields that you don't want people to see or show only a subset of the features in the overall dataset.

  1. On the Visualization tab, click the More Options button and choose Set View Definition > Define Features.

    More Options menu for the layer with Set View Definition selected and a box around the Define Features option

    You'll set a definition on the view to show only recently reported activity. For this scenario, data collected in 2018 is considered recent data.

  2. In the Define Features window, use the menus to build the expression Date_of_observation is after 12/31/17.

    Define Features window with the completed expression

  3. Click Apply Definition.

    Map of reported coyote activity that meets the defined criteria

    The map updates to show fewer features—only those with attributes that match the criteria of the view definition. It's possible someone may report a coyote sighting without providing a date. You'll edit the view definition to include blank date fields.

  4. Open the Define Features window again and click the Edit tab. Click Add another expression.

    Add another expression

  5. Build the expression Date_of_observation is blank.

    The view should include features that meet the criteria of either expression rather than the default setting to meet the criteria of both expressions.

  6. Above the two expressions, for Define the features that will be available in this layer, choose Only features that match any of the following expressions will be available.
    Only features that match any of the following expressions will be available option
  7. Click Apply Definition.

    The publisher of the feature layer (or the administrator in your organization) decides whether a feature layer is editable and sets the editing capabilities. Before sharing data with the public, you want to confirm that it’s been reviewed. To support your review process, you’ll enable full editing access on the view so city staff can add features, delete duplicate and accidental submissions, and moderate reports by editing inappropriate information.

  8. On the ribbon, click the Settings tab.
  9. In the Feature Layer (hosted, view) section, check Enable editing.

    Enable editing

  10. In the additional options that appear, accept the default values.

    OptionDefault value

    What kind of editing is allowed?

    Add, delete, and update attributes and geometry

    What features can editors see?

    Editors can see all features

    What features can editors edit?

    Editors can edit all features

    What access do anonymous editors (not signed in) have?*

    The same as signed in editors

    In this case, this hosted feature layer view is not shared with the public; therefore, this option does not affect what people can do with the view.

  11. At the bottom of the page, click the Save button.
  12. On the ribbon, click the Overview tab. In the Details section, next to Created from, click the coyotes_oakville_YN link to return to the item page for the hosted feature layer.

    Source layer link

Create and configure more views

The next two views you’ll create are to inform and engage the public. One view can be added to a public awareness app to show areas with a high density of reported activity to emphasize areas with a higher risk of coyote encounters. The final view can be added to a crowdsourcing app to allow the public to report coyote sightings.

  1. On the coyotes_oakville item page, click Create View Layer and create a hosted feature layer view with the title Coyotes_Oakville_PublicView (add your initials). As before, accept the default values for the tags and summary and click OK.
  2. In the Coyotes_Oakville_PublicView item page, for Description, type Reported coyote activity in Oakville. Click Save.
  3. On the ribbon, click the Visualization tab.
  4. Click the More Options button, click Set View Definition, and click Define Features.

    You will set a definition on the view to prevent the public from seeing a feature before it goes through the review process.

  5. Build the expression Review_status is Complete and click Apply Definition.
    Tip:

    For the expression builder, select Unique to choose from a list of known attribute values for the selected field.

    Review_status is Complete expression

    All available features in this view have a Review_status value of Complete, so it's not useful to show this internal field to the public.

  6. Click the More Options button, click Set View Definition, and choose Define Fields.
  7. In the Define Fields window that appears, uncheck the Review_status box and click Apply.

    Define Fields window with the Review_status box unchecked

    The last view you'll create is for the community to report coyote activity. They won't need to see any current data. They just need access to a layer to add a new feature and attributes that describe what they observed and when. For this view, you'll restrict their ability to see features for reported activity, including their own.

  8. On the ribbon, click Overview. On the item page for Coyotoes_Oakville_PublicView, under Details, click the coyotes_oakville feature layer link.
  9. On the coyotes_oakville feature layer item page, click Create View Layer.
  10. In the Create View Layer window, name the layer Coyotes_Oakville_PublicReports, followed by your initials, and click OK.
  11. In the Coyotes_Oakville_PublicReports item page, for Description, click Edit and type The community can use this layer to report coyote activity in Oakville.
  12. Click Save.
  13. On the ribbon, click Visualization.

    Next, you will set a definition on the view that hides the Review_status field.

  14. Click the More Options button, click Set View Definition, and click Define Features.
  15. Build the expression Review_status is blank and click Apply Definition.
  16. On the ribbon, click the Settings tab.
  17. In the Feature Layer (hosted, view) section, under Editing, check the box for Enable editing.
  18. For What kind of editing is allowed, uncheck Delete and Update.

    Delete and Update unchecked

  19. For What features can editors see, select Editors can't see any features, even those they add.

    You will share the Coyotes_Oakville_PublicReports layer with the public and, therefore, the latter setting allows all members of the public to contribute to this view.

  20. At the bottom of the page, click the Save button.

Add layers and edit data

Now that you've created multiple views to meet different viewing and editing requirements, you’ll add them to a map. You can test how the different views will work in practice and confirm that you set them up correctly. You’ll update data by adding and deleting features, noting the latest updates in applicable views.

  1. On the ribbon, click Content.
    Note:

    When you complete this lesson, you can delete the items on the My Content tab by checking the boxes and clicking Delete.

  2. For Coyotes_Oakville_PublicReports, click the options button and choose Add to new map.

    Add to new map

    Note:
    Depending on your organizational and user settings, you may have opened Map Viewer, formerly known as Map Viewer Beta. ArcGIS Online offers two map viewers for viewing, using, and creating maps. For more information on the map viewers available, please see this FAQ.
  3. If necessary, in the pop-up window, on the ribbon, click Open in New Map Viewer.

    The map opens in Map Viewer.

    The map doesn't display any points because you configured this layer to only allow users to add features.

  4. On the Settings (light) toolbar, click More and select Edit.

    Edit on the Settings toolbar

  5. In the Editor window, click Add features and click the map to add a point in the water (so you can easily find your test points). In the pop-up that appears, fill in the fields, and click Add.

    Add feature window

    Edits that you make in Map Viewer are automatically saved to the layer.

  6. After you finish adding test points, on the Settings toolbar, click Edit to close the Place feature window.
  7. In the Layers pane, point to the Coyotes_Oakville_PublicReports layer and click the visibility button to turn it off.

    Visibility button

  8. Click the Add layer button.

    Add layer button

  9. Locate your Coyotes_Oakville_PublicView layer and click the Add button.

    Add button

    The map updates to show points for reported coyote activity. You don't see the new features that you added because you configured this view to only show features that have gone through the review process.

  10. Click features on the map to display pop-ups.
    Pop-up display

    The Review_status field doesn’t appear because you set a field definition for this view. You also don’t see an option to edit the layer or attributes because it’s not an editable layer.

  11. Close the pop-up and add the Coyotes_Oakville_Staff layer to the map.
  12. On the Add layer pane, click the Back button to return to the Layers pane, and click the visibility button for the Coyotes_Oakville_PublicView layer.

    Staff view layer

    The staff layer only displays recently reported activity, including the new features you added using the public layer. You configured this layer with full editing capabilities, including update and delete.

  13. On the Settings toolbar, in the Editor window, click Edit feature. Click a point that you added in the water to view its pop-up.
  14. Click the Edit button and click a point that you added in the water to view its pop-up.
  15. In the pop-up, click Delete to remove the feature from the map and the data. Click Delete in the confirmation pane.

    You don't need to save the map to save your edits.

After deleting test features, you're ready to share the public views with everyone and the staff view with your organization or applicable groups. When you share an editable layer with the organization (or a group), only members who are assigned a role with editing privileges can edit the feature layer. For more information, see Share items and Data access and editing.

In 25 minutes, you published data as a hosted feature layer and created multiple views with different editing capabilities to meet the requirements of your crowdsourcing solution. What's next?

Configure focused apps using the hosted feature layer views that you created. A few suggestions are as follows:

Complete another lesson to learn how to create an app from a map. To find more scenario-based lessons, browse the Learn ArcGIS gallery. You can also visit The ArcGIS Book and The ArcGIS Imagery Book websites.