Configure the image server

Raster Analytics in ArcGIS Enterprise allows you to use distributed processing to perform analysis on large image and raster collections much faster than is possible in a stand-alone GIS environment. You can also run complex, multistep raster models quickly, with the ability to publish and share directly to your enterprise. To perform raster analysis, you must first configure ArcGIS Image Server in your ArcGIS Enterprise.

This lesson has the following prerequisite requirements:

  • Two licenses are required for raster analysis: ArcGIS Enterprise and ArcGIS Image Server.
  • You must have configured, at minimum, a base ArcGIS Enterprise deployment. For help setting up a base deployment, refer to Get Started with ArcGIS Enterprise Builder.
  • You must also have at least one additional server site. If you don't have an additional server site installed and configured, refer to the documentation for Installing ArcGIS Server on one machine.
  • The additional server should be licensed with ArcGIS Image Server. For help, refer to Authorizing ArcGIS Server.

If you have administrative privileges, you can start the lesson now. If you do not, you'll need your ArcGIS Enterprise administrator to complete this first lesson to configure the image server before you can begin at the second lesson.

Register new data stores

Raster analysis services store raster results in a registered data store. This can be either a file share or a cloud store. For this lesson, you’ll register two new data stores on your enterprise machine: a raster data store and a file share containing your lesson data.

Note:

If you are using cloud stores, refer to the documentation on using a cloud store for your raster data store.

  1. Create two new folders on drive C of your enterprise machine named RasterStore and LandslideData.

    Next, you'll ensure that these folders are shared and accessible from all server sites

    Note:

    ArcGIS Server Manager must be communicating over HTTPS when registering or editing a path for a raster data store.

  2. Download the LandslideData.zip file and unzip it to the LandslideData folder.

    The 31 files should be located at the root of the C:\LandslideData folder, rather than inside a subfolder.

  3. From drive C, right-click LandslideData and choose Properties.
  4. In the LandslideData Properties window, click the Sharing tab and click Advanced Sharing.
  5. Check Share this folder and click Apply.
  6. Click Permissions.

    If you have configured the image server in order to allow another member of your organization complete the lesson, you'll need to ensure that this person has full access to the folder.

  7. In the Group or user names list, select the user's account. If necessary, click Add to search for and add the account before selecting it.
  8. In the Permissions box, check Allow for Full Control.
  9. Click Apply and click OK on the Permissions window.
  10. Click Apply and click OK on the Advanced Sharing window.

    Note the network path for the folder—you’ll need it when you register the data.

  11. Close the LandslideData Properties window
  12. Repeat steps 3-11 on the RasterStore folder.
    Note:

    If you cannot access the folders from multiple server sites, you can copy the folders containing lesson data to each of the server machines, and ensure that the file share containing the data is registered to each server site using ArcGIS Server Manager. Refer to the documentation for more information on registering folders on multiple ArcGIS Server sites.

  13. Open ArcGIS Server Manager for the enterprise machine using an administrator account.

    Note:

    If you see a pop-up asking you to choose to open ArcGIS Server Manager in an app or Internet browser, you’ll need to first set a default web browser for your machine.

    Tip:

    To optimize the performance of raster analysis on your system, you should set the number of instances on your server to match your number of cores. In ArcGIS Server Manager, click Services > System > Raster Processing. Under Pooling, set Maximum number of instances per machine to the number of cores available to you.

  14. Click the Site tab and click Data Stores.

    Data Stores

  15. Click the Register drop-down list and choose Raster Store.

    Register Raster Store

  16. For Name, type RasterStore.

    This is a unique name for the registered location and should contain only alphanumeric characters and underscores.

  17. If necessary, for Type, choose File Share.
  18. Next to Path, specify the full path to the raster file share using the pattern \\gisserver\RasterStore. Replace gisserver with the name of the server on your enterprise machine.

    Avoid using local paths like C:\RasterStore unless the same data folder will be available on all nodes of the server site.

  19. Click Create.

    Register Data Store

    The raster data store you registered will now appear in the list of registered data stores. Next, you will register the location where your lesson data is saved.

  20. In the Register menu, select Folder.
  21. For Name, type LandslideData.
  22. For Publisher Folder Path, type the folder name \LandslideData, and for Publisher Folder Hostname, type the server name indicated when you created the network path.
    Register Folder

    Together, Publisher Folder Path and Publisher Folder Hostname make up a full folder path, so make sure you add slashes in the appropriate places. Like before, avoid using the local path C:\LandslideData unless the same data folder will be available on all nodes of the server site.

  23. Click Create.

    The folder with your lesson data now appears in the list of registered data stores.

  24. Access your ArcGIS Image Server machine and repeat steps 1-12 to create two new folders on the C drive and share them.
  25. If necessary, follow the same process to share the arcgisserver folder with Everyone.
  26. Open the ArcGIS Server Manager for your image server machine using an administrator account.
    Tip:

    Your ArcGIS Server Manager can be found at https://gisserver.domain.com:6443/arcgis/manager.

    If this site has ArcGIS Web Adaptor (IIS) configured, the ArcGIS Server Manager can be found here instead: http://gisserver.domain.com/webadaptorname/manager

    The webadaptorname is most commonly defined as server.

  27. Repeat steps 15-24, replacing gisserver with the name of your image server.

Federate an ArcGIS Server site

An ArcGIS Server site licensed as an image server must be federated with your portal to complete the configuration. Once a federated server is visible in your portal, you can assign it as a hosting server, raster analysis server, or other server type.

  1. Sign in to your ArcGIS Enterprise portal as an administrator.
    Note:

    Your ArcGIS Enterprise portal can be found at https://webadaptorhost.domain.com/webadaptorname/home

  2. Click the Organization tab. Click the Settings tab and click Servers.
  3. Under Federated Servers, click Add Server.

    Add

  4. For Services URL, enter the URL to your image server.

    This should be the fully qualified domain URL used by external users when accessing the ArcGIS Server site.

    Tip:

    If the site has ArcGIS Web Adaptor (IIS) configured, the URL will instead be formatted as http://gisserver.domain.com/webadaptorname

    Otherwise, the URL will be formatted as https://gisserver.domain.com:6443/arcgis (this is the same as the URL used in the next step)

  5. For Administration URL, enter the URL used to access ArcGIS Server when performing administrative operations on the internal network.

    This URL will be formatted as https://gisserver.domain.com:6443/arcgis.

  6. For Username, enter the name of the primary site administrator account that was used to initially log in to ArcGIS Server Manager and administer ArcGIS Server.
  7. For Password, enter the password of the primary site administrator account.
  8. Click Add.

    The server has been federated, or linked to your ArcGIS Enterprise account. Next, you’ll set it as the raster analysis server.

  9. Scroll down to Raster Analysis and choose the server site you just federated.

    Raster Analysis server

    A notice appears that the members of your organization now have access to raster analysis capabilities.

  10. Click OK and click Save at the top of the page.

    The federated server settings are saved.

Assign permissions to perform raster analysis

In order to perform raster analysis, you'll need to create or edit a role to have the appropriate permissions. If the rest of the lesson is going to be completed by yourself or someone else with an administrator or publisher role, they already have the correct permissions and can move on to the next lesson.

If you have configured the image server in order to allow another member of your organization complete the lesson, you'll need to complete the steps below to edit or create a custom role for performing raster analysis.

  1. If necessary, sign in to the portal website as an administrator and click Organization. Click Settings and choose Member Roles.
  2. Click Create Role.

    Create custom role

  3. For Role name, type Raster Analyst. For Description, type Role with privileges to perform raster analysis.
  4. Under Role privileges, under General Privileges, ensure that the following boxes are checked as a minimum:

    CategoryPrivileges

    Members

    View

    Content

    Create, update, and delete

    Publish hosted feature layers

    Publish server-based layers

    Sharing

    Share with groups

    Share with portal

    Share with public

    Content and Analysis

    Standard Feature Analysis

    Raster Analysis

    Update permissions for Raster Analysis

  5. Click Save Role.

    Next, you'll assign the Raster Analyst role to your colleague so they can complete the lesson.

  6. Near the top of the page, click Members.
  7. Find the organization's member who is to complete the lesson. Under Role, click the menu and choose Raster Analyst.

    Raster Analyst in the Role menu

In this lesson, you reviewed the required prerequisites for performing raster analysis with ArcGIS Image Server. Then, you added a new data store, federated an ArcGIS Server site, and assigned the appropriate permissions to perform raster analysis. You are now ready to use your image server for raster analysis. In the next lesson, you will use distributed raster analysis to create a landslide risk map.


Create a landslide risk map

Image and raster data analysis provides valuable information for decision support in emergency management applications. Imagery can represent current information about a location and situation, and can be analyzed alongside historical imagery and other spatial information. Processing raster data is challenging because files are often large and complex. Additionally, data from different organizations and sources often need to be shared and analyzed across the enterprise. The elastic distributed processing design of Raster Analytics provides an effective way to share and process large amounts of raster data quickly to support time-critical applications. Once optimized, you can save your processing chain, share it with members of your organization, and execute processing in your Raster Analytics deployment from ArcGIS Pro or the ArcGIS Enterprise portal's Map Viewer.

In the previous lesson, you configured ArcGIS Enterprise for distributed raster analysis. In this lesson, you’ll create a landslide risk map and then summarize the landslide risk based on watershed subbasin. You'll use raster function chains to derive a burn severity map, topographic slope map, and a landcover index map. These individual processing chains will be combined into one processing chain for distributed processing in your Raster Analytics system and then be summarized by watershed subbasin.

Set the active portal

First, you’ll need to set the active portal in ArcGIS Pro. This configuration step shares your licensing information with ArcGIS Pro and allows you to share processed data to your online ArcGIS Enterprise portal.

  1. Open ArcGIS Pro. At the bottom of the window, click Settings.
  2. Click Portals.
  3. If your portal is not listed, click Add Portal and enter your portal URL.

    Add Portal

    Once detected, the portal is added to the list.

  4. Right-click your portal and choose Sign in.
  5. Enter your user name and password and click Sign in.
  6. Right-click the portal and choose Set as Active Portal.

    A green check mark appears next to your portal connection.

  7. Click the back arrow.
  8. At the bottom of the window, click Select another project template.
  9. Click Browse and browse to C:\LandslideData on your Enterprise machine. Choose the project template file, Landslide_Risk_Project.aptx.
    Tip:

    If you can't locate this file, you can download and unzip LandslideData.zip to your local machine.

  10. In the Create a New Project window, name your project Landslide_Risk and save it to your computer.

    The new project opens, displaying a map centered on Santa Rosa, California.

Create a burn severity map

Different types of vegetation and materials burn with different intensity depending on their composition, density, topography, wind, soil moisture, and other factors. Generally, higher burn intensities result in higher water repellence and higher potential for erosion from a rainfall event. Burn intensity, or severity, can be derived from multispectral imagery with a near-infrared and shortwave infrared band, such as Landsat 8 imagery. Using raster functions in a processing chain, you’ll compute a burn ratio using Landsat 8 imagery acquired before and after the wildfires.

  1. On the ribbon, click the Insert tab. In the Project group, click Add Folder.

    Add folder connection

  2. Browse to the LandslideData folder on the C drive of your Enterprise machine. Select it, and click OK.
  3. On the ribbon, click the View tab. In the Windows group, choose Catalog Pane.

    The Catalog pane is added to the map window.

  4. In the Catalog pane, on the Project tab, expand Folders and expand the LandslideData folder. Select all of the datasets inside except for Basins.tif and drag them onto the map.
    Add data to the map

    The data is now listed in the Contents pane. This includes Landsat 8 imagery for before (Before_L8.tif) and after (After_L8.tif) the October 2017 wildfires in Napa and Sonoma counties. There are also two layers you'll use as inputs for your risk map. Dem_10m.tif is a digital elevation model showing the elevation of the terrain. Sonoma_NLCD2011 is a portion of the National Landcover Dataset, which shows land use and predominant vegetation type.

    To compare the burn scars on the before and after imagery, you’ll choose the multispectral bands to be displayed. The default bands that are displayed as red, green, and blue are listed when you expand the layer.

  5. If necessary, in the Contents pane, drag the After_L8.tif layer to the top of the list, and drag Before_L8.tif just below it. Turn off the other layers.
  6. If necessary, expand After_L8.tif. Right-click the red color chip and choose srband 5.

    Assign red band

  7. For green, choose srband 4, and for blue, choose srband 3.

    This band combination displays the Landsat 8 imagery bands in color infrared mode. Vegetation is shown in bright red. Nonvegetated features such as bare and urban areas are displayed in various shades of gray and blue.

  8. Apply the same bands to the Before_L8.tif layer.
  9. Click After_L8.tif in the Contents pane to select it.
  10. On the ribbon, click the Appearance tab. In the Effects group, click the Swipe tool.

    Swipe cursor

    The pointer displays as an arrow in the map display.

  11. Click while swiping across the image in the map to compare the imagery before and after the wildfire.

    You can swipe vertically or horizontally. Notice that many areas that are red in Before_L8.tif are grey or green in After_L8.tif, indicating lost vegetation.

  12. On the ribbon, click the Map tab. In the Navigate group, click Explore.

    The pointer returns to normal. Now that all the data is on the map, you’ll use raster functions to calculate the burn severity.

  13. On the ribbon, click the Imagery tab. In the Analysis group, choose Raster Functions.

    Raster Functions

    The Raster Functions pane opens. On the Systems tab are categories of functions available for raster analysis. For this lesson, two raster function templates, or RFTs, have been created for you. These custom function templates are listed under the Project tab.

  14. In the Raster Functions pane, click the Project tab.
  15. Right-click Landcover_Remap, point to Move to, then point to Custom and click Custom1.

    By moving these functions to a custom category, any edits you make to the RFTs will be saved if they are saved in the Raster Function Editor. Changes made in the Project category will be lost if the project is not saved.

  16. On the Project tab, right-click Burn_Severity and move it to Custom1 as you did in the previous step.
  17. In the Custom tab, right-click the Burn_Severity template and choose Edit.

    The Raster Function Editor opens and displays the processing chain.

    Burn Severity raster function template

    The Band Arithmetic functions turn the pixels of the imagery into expressions. The postfire imagery is subtracted from the prefire imagery and run through a remap function. The remap function categorizes the pixel values into five categories of burn severity. The breakpoints of the five burn severity values are obtained from a landscape assessment study (Key and Benson, 2005). The Attribute Table function in the processing chain assigns a color ramp to the burn severity map. This has already been created for you.

  18. Close the Burn Severity RFT in the Function Editor pane.
  19. In the Raster Functions pane, click the Burn_Severity template.

    The Burn Severity inputs for the template open.

  20. For Pre-Fire Imagery, choose Before_L8.tif, and for Post-Fire Imagery, choose After_L8.tif.
  21. Make sure Output Layer Type is set to Raster Layer and click Create new layer.

    BurnSeverity properties

    The processing may take a few minutes to complete. When finished, the resulting layer is displayed in the map and listed in the Contents pane. Raster functions are temporary in nature—calculations are performed on the fly, or in real-time as you move the map, and are not saved automatically. Burn severity is computed dynamically in the display as you navigate around the layer.

    Burn Severity result layer

  22. Save the project.

Create a slope index map

The slope map is a critical layer in determining slope stability. Slope steepness is derived from a digital elevation model (DEM). The steeper the slope, the more prone it is to slipping, especially during a rainfall event after stabilizing vegetation has been burned away. Next, you’ll build and save a raster function template to calculate percent slope and use it to create a steepness index.

  1. On the ribbon, click the Imagery tab. In the Analysis group, click Function Editor.

    The Function Editor pane docks at the bottom of the map window.

  2. In the Raster Functions pane, click the System tab. At the bottom of the list, expand the Surface group.

    Surface group

  3. Drag the Slope function into the Raster Editor pane.
  4. In the Function Editor pane, on the ribbon, click Add raster variable.

    Add raster variable

    A green box titled Raster is added to the Function Editor pane.

  5. Make sure the green Raster box is positioned to the left of the Slope function box.

    The Raster box will define the input dataset for the Slope function.

  6. Hover over Raster to see the Out parameter displayed. Click Out and drag to connect the raster element (Out parameter) to the Slope function (DEM parameter).

    Connect the output raster

  7. Right-click Raster and click Rename. Type Input DEM.
  8. Double-click the Slope function. In the Slope Properties tool window, click Variables, and for DEM, check the IsPublic field.

    Make the result public

    The IsPublic option allows you to alter the input data in a later tool process.

  9. Click OK.
  10. In the Raster Functions pane, on the System tab, search for Remap.
  11. Drag the Remap function into the Function Editor pane to the right of the Slope function.
  12. Connect Slope to Remap by setting the output of Slope to the Raster input for Remap.

    Connect the Remap function

    Next, you’ll set the inputs for the remap to index the slopes (in units of degrees) into five categories.

  13. Double-click the Remap function. In the Remap Properties tool window, click the first box under the Minimum column and type 0. For Maximum, type 5, and for Output, type 1.
  14. Set the categories with the following values:

    MinimumMaximumOutput

    1

    0

    5

    1

    2

    5

    15

    2

    3

    15

    25

    3

    4

    25

    35

    4

    5

    35

    91

    5

  15. Click OK.

    Slope categories

  16. Right-click the Remap function and choose Rename. Type Slope Remap.

    This will help distinguish between functions later in this lesson when you string several raster function chains together.

  17. In the Raster Functions pane, search for the Attribute Table function and drag it into the Function Editor pane.
  18. Connect the output from the Remap function to the input of the Attribute Table function.
  19. Double-click the Attribute Table function and set Table Type to Manual.
  20. Under the blank table, click the color scheme button.

    Color scheme button

  21. For Maximum Value, choose 5. Click OK.

    Five rows are added with values 1 to 5 and a default green-to-red color scheme.

  22. Click Class Name for each row and assign them as follows:

    ValueClass Name

    1

    Flat

    2

    Low

    3

    Moderate

    4

    Steep

    5

    Very Steep

    Slope attribute table

  23. Click OK.
    Tip:

    Use the Auto Layout button when all inputs and tools are connected to automatically arrange the elements in the diagram.

  24. In the Function Editor, click Save as.
  25. In the Save As window, for Name, type Slope_Index. .
  26. Make sure Category is set to Custom and Sub-Category is set to Custom1.
  27. For Description, type A raster function template to derive slope from an input DEM.
  28. Click OK.

    Your Raster Function Template (RFT) now appears in the Custom category in the Raster Functions pane.

    Tip:

    You may need to clear the search bar before you can see the new RFT.

  29. In the Raster Functions pane, double-click Slope_Index.

    The SlopeIndex Properties appear.

  30. For Input DEM, choose DEM_10m.tif.
  31. Make sure Output Layer Type is set to Raster Layer, and then click Create new layer.

    When it is finished processing, the layer displays on the map and is listed in the Contents pane with the name Slope_Index_DEM_10m.tif

    Slope map

  32. Close the Slope_Index RFT in the Function Editor pane and save your project.

Create the landslide risk map

The landslide risk calculation combines the two variables you just worked with: burn severity and slope. It also includes landcover, which is also important to landslide risk. Vegetation stabilizes slopes via root systems. Wildfire can wipe out much of the stabilizing vegetation. Some types of vegetation, especially species of chaparral, have adapted to wildfire, though, and the root systems are especially deep underground to survive fires. Landcover has already been indexed into five categories for you depending on its stabilizing effect on slopes. To perform the landslide risk calculation, you’ll add the three raster function templates into a chain that will be processed on your Raster Analytics deployment.

  1. On the ribbon on the Imagery tab, click Function Editor.

    A blank Function Editor pane opens.

  2. In the Raster Functions pane, select and drag each RFT (Burn_Severity, Slope_Index, Landcover_Remap) into the Function Editor pane.

    By default, the RFTs cluster together. You’ll want to separate them so that you can more easily connect their outputs.

  3. Click and hold to draw a box around the Slope_Index functions, and then drag the entire group so that it’s below the Burn_Severity RFT.
    Tip:

    The green input boxes mark the beginning of each function chain.

    Move the slope functions

  4. Drag Landcover_Remap below Slope_Index.

    Raster function templates arranged

  5. In the Raster Functions pane, click the System tab and search for the Weighted Overlay function. Drag it into the Function Editor pane to the right of the other three RFTs.
  6. Connect the three Attribute Table outputs to the input parameter of the Weighted Overlay function.
  7. Right-click each Attribute Table function and rename it to correspond with the corresponding Remap function.

    Their new names should be Burn Severity Attribute Table, Slope Attribute Table, and Landcover Attribute table.

  8. Click the Auto Layout button at the top of the Function Editor pane to reorganize the processing chain.

    Auto Layout tool

    The RFTs are arranged compactly.

    Auto Layout applied to function chain

  9. Double-click the Weighted Overlay function.

    The Weighted Overlay Properties window appears. Inside the Weighted Overlay Table you can assign weights in percentages to each raster.

  10. In the Weighted Overlay Table, in the cell next to <Burn Severity Attribute Table.OutputRaster>, type 30. For the Slope Index layer, assign 55 percent. For the Landcover Index layer, assign 15 percent.

    Percentage weights applied in the Weighted Overlay Table

    Hazard weights are loosely based on research done by the USGS for its Landslide Hazards Program.

    The Remap table is still empty. Because all layers have the same number of index categories, you'll map each of them one-to-one.

  11. In the Weighted Overlay Table, click the Burn Severity layer. In the Remap Table, under Value, click NODATA to edit the attribute field and type 1. Under Scale, click NODATA and choose 1.

    Remap Table set to 1 and 1

  12. In the Remap Table, double-click the empty row at the bottom of the Value column and type 2. For Scale, choose 2.
  13. Repeat the previous step to add rows 1-5 for all three rasters in the Weighted Overlay Table.

    Weighted Overlay table

  14. Click OK.
  15. In the Raster Functions pane, on the System tab, search for the Attribute Table function and drag it into the Function Editor pane to the right of the Weighted Overlay function.
  16. Connect the output from the Weighted Overlay function to the input of the Attribute Table function.
  17. Double-click the new Attribute Table function. In the Attribute Table Properties window, for Table Type, choose Manual.
  18. Under the blank table, click the color ramp button and set Maximum Value to 5. Click OK.

    Five rows are added with values 1 to 5 and a default green to red color scheme.

  19. Click Class Name for each row and assign them as following:

    ValueClass Name

    1

    Low

    2

    Medium

    3

    High

    4

    Very High

    5

    Extreme

  20. Click OK to close the Properties window.
  21. In the Function Editor, click Save As.
  22. In the Save As window, for Name, type Landslide_Risk.
  23. Make sure Category is set to Custom and Sub-Category is set to Custom1.
  24. For Description, type Raster Function Template to calculate landslide risk based on wildfire burn severity, slope, and landcover.
  25. Click OK and close the Landslide_Risk RFT in the Function Editor pane.
  26. In the Raster Functions pane, clear your search and click the Custom tab.
  27. Click Landslide_Risk.

    The Landslide_Risk Properties open.

  28. Fill in the input fields as follows:

    • Pre-Fire Imagery: Before_L8.tif
    • Post-Fire Imagery: After_L8.tif
    • Slope Input DEM: DEM_10m.tif
    • Landcover Remap Raster: Sonoma_NLCD2011.tif

  29. For Output Layer Type, choose Web Image Layer and click Next.

    Proceed to web image layer properties

    Note:

    If you don't see an option to set your output to a Web Image Layer, talk to your administrator to make sure that the Raster Analysis server is set and operational.

    The Output Generation dialog box appears and allows you to set the properties for the web layer you’ll create.

  30. Name the web layer Landslide_Risk and add your initials.

    Each piece of content within your organization must have a unique name, and your initials will differentiate your layer from that of anyone else who may have created a similar layer.

  31. For Description, type This web layer shows a landslide risk estimate for Sonoma County, CA.
  32. For Tags, type Sonoma County, landslide, risk, and wildfire. Press Enter after typing each tag.
  33. For Sharing Options, choose your organization.

    The layer will be visible to others in your organization.

  34. Click Run.

    The processing chain is submitted to your portal deployment for distributed processing. A message appears informing you that the process was submitted to your portal.

    Raster Functions notification

  35. Click the Raster Functions notification to view the status of your RFT run. Alternatively, on the Catalog pane, click the History tab and click the Raster Functions tab.

    The Raster Functions tab of the History tab in the Catalog pane

    You'll see a green tick next to the raster function once the process has successfully completed. You'll use this layer later in the web map viewer.

Summarize landslide risk by subbasin

Although the landslide risk map is useful, you want to go further to break down the areas that are most at risk. Because landslide risk is impacted by precipitation patterns and watershed characteristics, you'll summarize risk by watershed basins within the study area. First, you’ll publish the watershed basin layer to the portal. Then, you’ll use the landslide risk map produced in the previous steps to summarize risk per subbasin.

  1. In the Catalog pane, click the Project tab and browse to the LandslideData folder connection.
  2. Right-click Basins.tif and choose Share as Web Layer.

    Share As Web Layer

    The Share As Web Layer pane appears.

  3. For Name, type Basins followed by your initials.

    Each piece of content within your organization must have a unique name, and your initials will differentiate your layer from that of anyone else who may have created a similar layer.

  4. For Summary, type Watershed subbasins in Napa and Sonoma Counties, California.
  5. For Tags, type watershed, basin, and California.
  6. Make sure Reference registered data is selected.
  7. For Server and Folder, choose the Hosting Server.
  8. For Sharing, choose your organization.
  9. Click Analyze and if there are no warnings click Publish.
    Note:

    If a warning is shown that the data source is not registered, the data will be copied to the server instead of referenced. To avoid this, you can right-click the warning and choose Register Data Source With Server before publishing.

    When the web layer succeeds, a success note is shown in the pane.

  10. At the bottom of the pane, click the Manage web layer link.

    Your portal opens to the item details page of your new layer.

  11. Click the browse button next to the Basins layer and choose Open in Map Viewer.
  12. On the ribbon, click Add and choose Search for Layers.
  13. Confirm that the search is set to My Content.
  14. Find your landslide risk layer, and click the Add button.

    Add Landslide_Risk layer

    Your landslide risk layer loads in the map.

    Note:

    If the landslide risk layer fails to load in the map, you may need to wait a few minutes for processing to complete and try again.

  15. On the ribbon, click Analysis and choose Raster Analysis.
  16. Under Summarize Data, click the Summarize Raster Within tool.

    Summarize Raster Within

  17. On the Summarize Raster Within tool, fill out the following properties:

    • Choose area layer to summarzie a raster layer within defined boundaries: Basins
    • Choose field to define the boundaries: Value
    • Choose raster layer to summarize: Landslide_Risk
    • Choose statistic to calculate: Average
    • Ignore missing values in calculation: True (checked)
    • Result layer name: Risk per Basin, followed by your initials.
    • Use current map extent: False (unchecked)

  18. Click Run Analysis.

    When the analysis has finished running, you will have a map that shows average risk per watershed.

    Risk per watershed

    The darker green areas have higher landslide risk values. This is based on the risk you calculated using the raster function template with the weighted inputs of slope, burn severity, and landcover.

  19. Click Save, click Save As, and name your map Landslide Risk per Basin (Sonoma and Napa) followed by your initials.
  20. For Tags, type landslide, risk, and wildfire.
  21. For Summary, type Landslide risk per basin in Sonoma and Napa counties, based on on wildfire burn severity, slope, and landcover.
  22. Click Save Map.

In this lesson, you used raster function chains to create a burn severity map, slope index map, and landcover index map. You then created a landslide risk map, published layers to the portal, and summarized risk by watershed subbasin. In the next lesson, you’ll communicate your findings to other members of your emergency response organization by creating a web app to share the results across your enterprise.


Share a web app

In the previous lesson, you created a risk map that summarized landslide risk per subbasin. Now, you want to communicate the results with the rest of your organization, which includes emergency response personnel both in the office and on the ground. To share your results, you’ll create a web app in your ArcGIS Enterprise portal.

Create a web app

Your results have been published to your portal. Next, you'll change the symbology on your output to make the results easier to interpret. Then, you'll use Web AppBuilder for ArcGIS to share your findings easily with all the associated information needed.

  1. If necessary, open your ArcGIS Enterprise portal in your web browser and sign in. Browse to the map you created in the previous lesson.

    You only want to share your Risk per Basin layer, so next you will remove the other two layers from your map.

  2. Remove the Basins and Landslide Risk layers by hovering over each layer and clicking the More Options button, and then clicking Remove.
  3. In the map viewer, hover over the Risk per Basin layer and click the More Options button.
  4. In the More Options menu, choose Image Display.

    Image Display

  5. For Stretch Type, choose Percent Clip. For Color Ramp, choose the green-to-red ramp named Condition Number. Keep all other settings as default.

    Condition Number ramp

  6. Click Apply and click Close.

    You now have landslide risk visually classified from low (green) to high (red) risk.

  7. Click the More Options button and choose Transparency. Set the slider to 50 percent.

    Because slope and terrain play such an important role in landslide risk, you want to choose a basemap that shows both.

  8. On the ribbon, click Basemap and choose Terrain with Labels.

    Terrain with labels basemap

  9. On the ribbon, click Save and click Save again.
  10. Click Share.

    You can choose to share your map with your entire ArcGIS Enterprise or a specific group.

  11. Under Choose who can view this map, check the box for your organization and click Update Sharing.
  12. Click Create a Web App and click the Web AppBuilder tab.
  13. Keep Title and Tags the same as the map, and for Summary, paste A calculation of landslide risk per basin for Sonoma and Napa counties based on slope, landcover, and burn severity.
  14. Click Get Started.

    Web AppBuilder opens.

  15. On the Theme tab, select Tab Theme and change the Style color to blue.

    Change theme to Tab Theme

  16. Click the Map tab. In the map viewer pane, zoom out so you can see the entire landslide risk map.
  17. Under Set initial extent, click Use current map view.

    This ensures that the users see the full extent of your risk map when they open the app.

  18. Click the Widget tab. Hover over the Full Screen widget and click the Show this widget button.

    Full screen widget

    This widget allows your viewer to make the map full screen. You can add or remove any other widgets in the same way.

  19. At the bottom of the pane, click Save, and then click Launch.

    The app opens in a new tab.

    Landslide risk web app

    Your web app is now available for the members of your organization to use on any device. You will find the web app in your ArcGIS Enterprise portal under Content, in any groups you have shared to, and in your gallery. You can also share the link directly with anyone in your organization, or share the app with the public by changing who the item is shared with.

In this lesson, you created a web app to share your landslide risk map. By sharing the web app with your ArcGIS Enterprise, you ensured that all members of your organization, whether in the office or in the field, could access this vital information for decision making. The flexibility of sharing in ArcGIS Enterprise and customization using Web AppBuilder allows you to share the information you want with who you want.

Your ArcGIS Enterprise deployment is now configured to perform raster analysis. Using the distributed processing capabilities of raster analysis, you created a landslide risk map and summarized the results by watershed subbasin. The patterns that were revealed in your map helped you determine which subbasins were most at risk of landslides after the wildfires occurred. Finally, you created and shared a web app to communicate your findings to your entire organization and help other emergency response personnel gain valuable insight into the risk of landslides.