创建地理数据库工程

从本质上来说,地理数据库相当于一个容器,用于存储空间数据和属性数据以及存在于它们之间的关系。在地理数据库中,可使用规则、关系和拓扑关联对要素及其关联属性进行构造,使其能够作为集成式系统互相配合使用。换句话说,地理数据库允许您根据需要以简单或复杂的方式对现实世界进行建模。

为地理数据库创建 ArcGIS Pro 工程

地理数据库的组织和结构通常被称为方案。在开发供萨尔茨堡旅游机构使用的地理数据库方案之前,调查可由各个组织和机构在需要管理特定基础数据或源数据的集合时部署的通用底图方案将会很有帮助。

虽然我们可以通过多种方法创建地理数据库,但在本课程中,您首先需要根据一个包含地理数据库的模板来创建 ArcGIS Pro 工程。创建新工程时,系统将自动创建新的文件地理数据库,并将其设置为默认地理数据库。该地理数据库将存储萨尔茨堡旅游机构用于支持其绘图工作的数据。

注:

目前的趋势是要为各个城市、组织和机构维护其独特或专有的数据,并利用已发布且公开提供的底图、地图服务和其他权威数据源(如 ArcGIS Living Atlas of the World 中的数据源)对其进行补充。

  1. 转到 Get Started with Geodatabases 群组。

    地理数据库入门群组

  2. 向下滚动,直至看到示例底图 GDB 方案缩略图。单击下载以下载 zip 文件。

    示例底图 GDB 方案

  3. 单击 SalzburgData 缩略图进行下载。

    SalzburgData 缩略图

  4. 将文件内容提取至您选择的位置(例如 C:\Salzburg)。
  5. 打开 ArcGIS Pro
    注:

    如果没有 ArcGIS Pro 或 ArcGIS 帐户,则可以注册 ArcGIS 免费试用版

    ArcGIS Pro 随即打开启动画面。

  6. 单击设置并选择选项

    选项窗格随即出现。

  7. 选项窗格中,单击元数据
  8. 对于元数据样式,选择 FGDC CSDGM 元数据

    “元数据样式”选项

    ArcGIS 平台将默认使用名为“项目描述”的基本元数据样式,但您可以将样式更新和修改为各种其他样式。FGDC CSDGM 元数据样式就是其中的一个样式,该样式允许您查看和编辑完整元数据,是一种已在北美和世界各地使用多年的、众所周知的元数据内容标准。

  9. 单击确定
  10. 单击返回按钮返回到工程或打开工程。
  11. 如有必要,请使用您获得许可的 ArcGIS 帐户登录。
  12. 新建下,单击目录

    目录模板

    ArcGIS Pro 将提供一些空白工程模板以帮助您入门。

    • 要构建 2D 地图,请选择地图模板。
    • 要创建 3D 全局场景,请选择全局场景模板。
    • 要开始使用 3D 局部场景,请选择局部场景模板。
    • 要开始使用目录视图,请选择目录模板。

    如果数据管理是您的主要关注点,请考虑将此工程固定到开始页面或者在启动 ArcGIS Pro 时自动将其打开。由于您对本课程的主要关注点是数据管理,所以目录模板将是个不错的选择。

  13. 对于名称,请输入 SalzburgGeodatabase
  14. 对于位置,请浏览并选择所下载的工程内容所在的位置(例如 C:\Salzburg)。

    为工程创建专用文件夹通常大有裨益。每个新工程都包含一个工程文件 (.aprx)、一个默认地理数据库和一个工具箱。请将这些内容组织到一个文件夹中,以便查找、共享和存储工程和数据。

  15. 请确保选中为此工程创建新文件夹,然后单击确定

    新建工程窗口

    工程随即打开,并将显示内容窗格和目录视图。

    “内容”窗格和“目录”视图

    您可通过目录视图在同一个位置访问与特定工程相关联的所有项目(无论这些项目的来源是本地计算机、网络计算机、ArcGIS Online 还是 ArcGIS Enterprise 门户),并通过添加地图、场景、布局、文件夹连接和地理数据库来构建您的工程。在功能区中,可以打开多个目录视图并使用其来比较数据库或文件夹的内容、比较两个项目的元数据、将样式项目从一个样式复制到另一个样式等。

  16. 视图选项卡的窗口组中,单击目录窗格

    目录窗格随即显示。

    “目录窗格”按钮

    注:

    目录窗格和目录视图相似,但所适用的任务不同。可同时打开目录窗格和目录视图,但它们相互独立运行。无论是在窗格还是视图中,您都可以管理和浏览数据。当您生成新项目时,系统会按类型将其分类,并显示在工程选项卡的目录窗格以及工程集合的目录视图中。

    可以将目录窗格看作是目录视图的精简版本,用于通过门户、收藏夹和历史记录选项卡供用户访问工程相关组件。

    目录视图与目录窗格的对比

    如果说目录窗格适合快速访问,则目录视图更适合更为深入的数据管理任务,且带有内含管理功能的关联功能区选项卡。除此之外,目录视图能够以列的形式显示项目详细信息,并可用于访问元数据。

    在接下来的课程中,您将专注于使用目录视图及其关联的内容窗格。

  17. 关闭目录窗格。
  18. 内容窗格中,单击并展开数据库

    我们已经使用该工程创建了 SalzburgGeodatabase.gdb。在探索目录视图之前,您需要创建一个文件夹连接,以便轻松访问您的课程资源。

  19. 内容窗格中,单击文件夹
  20. 在功能区目录选项卡的创建组中,单击添加并选择添加文件夹连接

    “添加”按钮

  21. 添加文件夹连接窗格中,找到您所提取的数据文件夹(例如 C:\Salzburg),然后单击确定

    文件夹连接是用于查找重要数据和工程相关材料的快捷方式。

  22. 保存工程。

在本课程中,您通过生成一个工程为填充地理数据库提供支持,并将工程的默认元数据样式由项目描述修改为 FGDC CSDGM 元数据样式。接下来,您将评估要纳入地理数据库中的各种数据源。


评估数据源

在本课程中,您将评估将迁移到萨尔茨堡地理数据库的潜在数据源。在评估数据源时需要注意的典型数据质量标准与具体的用途、地理范围、投影、流通、数据和元数据标准、数据谱系、对数据执行的空间操作(包括采样、处理、建模和分析,以及精度和完整性评估)以及相关属性有关。

评估数据源

接下来,您将评估将迁移到萨尔茨堡地理数据库的潜在数据源。这些数据源中包含 shapefile 和 KMZ 文件。

  1. 如有必要,请打开您的工程。
  2. 内容窗格的文件夹连接中,展开 City_of_Salzburg 子文件夹。

    目录视图将更新,以显示表示萨尔茨堡市数据的 shapefile 集合。有关这些 shapefile 的其他详细信息,请参阅名称类型日期列。要对其中任何列中的内容进行排序,请选择列标题。除了项目详细信息,目录视图还支持直接访问用于描述项目的信息(又称元数据)。

    项目详细信息

    City_of_Salzburg 文件夹中包含 29 个 shapefile,这些 shapefile 对旅游机构十分有用,可将其作为图层进行添加以用于更新地图,也可将其添加到新的应用程序中。在决定要保留哪些数据源或用来自其他源的数据替换哪些数据源之前,您应该访问并查看每个潜在的数据源。

  3. 目录视图中,单击 BicyclePaths.shp

    项目类型随即显示,且元数据选项卡将更新,以显示 shapefile 的详细信息。

    Shapefile 元数据

    元数据中包含有关使用限制、配额和空间参考的信息。

    查看限制和空间参考。

    空间参考定义如下:

    • 地理坐标参考-GCS_MGI
    • 投影-MGI_Austria_GK_M31

    在开发地理数据库时,元数据对于了解数据源的实用性和相关性而言至关重要。阅读有关查看和编辑元数据的详细信息。

  4. 单击地理选项卡,以显示和查看 shapefile 中包含的空间要素。如有必要,可平移和缩放地图。

    地理选项卡

  5. 单击选项卡,以显示自行车路径要素的属性字段和值。

    表选项卡

    在查看自行车路径 shapefile 的元数据时,元数据在记录您所创建和使用的内容和工程项目时显然起着重要的作用。这些内容和项目可能包括地图、工程、地理处理模型和地理数据库数据集。

    注:

    元数据将与其描述的项一起保存在以下位置:对于地理数据库项,保存在地理数据库中;对于工程项,保存在工程中;对于基于文件的项,保存在文件系统中;等等。元数据创建后,当使用 ArcGIS 进行管理时,元数据会和数据项一同被复制、移动和删除。

  6. 请查看 Museums.shp元数据地理选项卡。

    这些都是游客经常访问的位置,而且此图层对于维护信息和使信息保持在最新状态非常重要。此数据源的空间参考定义如下:

    • 地理坐标参考-GCS_MGI
    • 投影-MGI_Austria_GK_M31

    此数据源的表中包含属性字段,其中包括位置的名称和地址,而这两者对旅游应用程序而言都很有用。

  7. 查看 ReligiousMonuments.shp 的元数据。

    此元数据似乎相当完整,但在查看 shapefile 未包含要素的地理要素和表格时请加以留意。因此,该数据源可能会被拒绝且不被使用。

  8. 内容窗格的文件夹中,单击 KMZ 文件子文件夹。

    该文件夹中包含三个对旅游机构有用的 KMZ 文件。KMZ 文件指的是压缩的 Keyhole 标记语言 (KML) 文件,可通过包括 ArcGIS Pro 在内的任何 KML 客户端显示。

    KMZ 文件的文件夹

    您的文件夹结构可能会根据您解压下载数据的具体位置而有所不同。

    注:

    KML 格式便于在 Internet 上发布并可通过许多免费应用程序进行查看,因此常用于与非 GIS 用户共享地理数据。KML 文件采用基于 XML 的格式,可使用 .kml.kmz(针对压缩的 KML 文件)文件扩展名。您可以使用 ArcGIS Pro 中的任一扩展名。

  9. 目录视图中,单击 Kunstwerke_mit_Audiotext.kmz

    此 KML 文件中的要素代表了几个重要的露天和室内艺术装置的位置,对特定艺术家的作品感兴趣的游客可能会搜索和访问这些装置。

    注:

    单个 KML 文件可能包含点、线、面要素、栅格影像或上述对象的组合。KML 还可以包含图形、图片、属性和 HTML 等相关内容,尽管通常将 ArcGIS 中的数据集视为独立的同类元素(例如,点要素类只能包含点,栅格只能包含像元或像素,而不能包含要素)。

  10. 查看 Kunstwerke_mit_Audiotext.kmz 的元数据。

    KMZ 元数据

    在本例中,KMZ 没有有用的元数据;但在默认情况下,KMZ 文件将通过 Web 应用程序进行使用,因此会使用 WGS84 作为其坐标系,以便了解有关数据源的一些信息。

  11. 查看 Kunstwerke_mit_Audiotext.kmz 的地理信息。

    KMZ 文件内容

    当您在地图上进行放大和缩小操作时,所显示的要素无法准确地缩放并将显示淡出效果。这是因为 KMZ 文件会在文件中包含其符号系统和其他图层属性(例如弹出信息)。

  12. 查看 Kunstwerke_mit_Audiotext.kmz 的表格。

    由于您当前正在显示和探索未经转换的图层形式的 KMZ 内容,您将无法访问与点相关联的任何表格信息。事实上,KMZ 使用了具有嵌套元素和属性的、基于标签的结构,且基于 XML 标准。如需编辑和修改数据,您需要将 KMZ 文件转换为地理数据库内的要素类,以便访问属性。

  13. 内容窗格的文件夹下,展开 OpenStreetMap_Salzburg 子文件夹。

    此文件夹中包含一系列免费的萨尔茨堡 OpenStreetMap 数据,该数据采用 shapefile 格式,可用于构建旅游地图和应用程序。该数据由志愿者收集和构建,并通过开放内容许可进行发布。OpenStreetMap 许可允许用户免费访问地图图像和所有基础地图数据,且该工程旨在促进用户通过新的和有趣的方法来使用数据。查看以下 OSM 地图要素的描述主题。

  14. 目录视图中,单击 OSM_Salzburg_Amenities.shp。在元数据选项卡上,查看空间参考信息。

    便利设施空间参考信息

    此数据源中具有符合您需求的综合性元数据。但是,空间参考的地理坐标参考设置为 GCS_WGS_1984,且其投影定义为 WGS_1984_Web_Mercator_Auxiliary_Sphere。如果要确定精确的距离、测量面积和比较形状,该投影将不够理想。

  15. 您可以自行探索和查看其他几个 OpenStreetMap 数据源。请务必检查这些源是否具有相同的空间参考。
  16. 保存工程。

接下来,您将使用 XML 交换文件导入通用底图的地理数据库方案。借助底图,您将在更新萨尔茨堡地理数据库的元数据之前探索地理数据库对象,以准备将数据源从其当前的格式和空间参考迁移到合适的空间参考,以便在旅游地图和应用程序中使用。


创建地理数据库方案

地理数据库存储模型以一系列关系数据库概念为基础,并使用了基础数据库管理系统 (DBMS)。DBMS 可提供存储结构、索引、备份和回滚机制以及安全模型。DBMS 表和明确定义的属性类型用于存储各地理数据集的方案、规则库以及空间属性数据。该方法为存储和使用数据提供了一个正式模型。

查看地理数据库对象

在本课程中,您首先需要查看通用底图的方案,以深入了解地理数据库的各个组件,例如要素类、要素数据集以及用于组织和管理数据的独立表。然后,您将转换并导入各种数据集,以创建和更新萨尔茨堡地理数据库的方案。请参阅什么是地理数据库?地理数据库基础知识以了解详细信息。

您首先需要从 XML 交换文件导入底图地理数据库的方案。

  1. 如有必要,请打开您的工程。
  2. 内容窗格中,单击数据库

    您已经拥有了在创建工程时生成的默认 SalzburgGeodatabase.gdb。您将使用萨尔茨堡源数据来填充此数据库。那么在下一步中,您将创建一个额外的地理数据库,用于探索地理数据库组件。

  3. 在功能区数据库选项卡的工程组中,单击新建文件地理数据库

    “新建文件地理数据库”按钮

  4. 新建文件地理数据库窗格的名称中,请输入 SampleBaseMapGDB.gdb。请确保您在 SalzburgGeodatabase 文件夹中创建了地理数据库。

    “新建文件地理数据库”窗口

    接下来,您需要将底图地理数据库方案从 XML 文档导入 SampleBaseMapGDB.gdb。该操作并非总是必要的,但在本例中,您需要查看常见的地理数据库设计和地理数据库对象,且需要探索将来如何使用 XML 工作空间文档来共享您自己的地理数据库方案。

  5. 内容窗格中,单击 SampleBaseMapGDB.gdb
  6. 在功能区目录选项卡的创建组中,单击导入并选择 XML 工作空间文档

    XML 工作空间文档选项

  7. 导入 XML 工作空间文档地理处理工具中,针对导入文件,单击浏览按钮。
  8. 导入文件窗格中,浏览并选择 SampleBasemapGDB.xml,然后单击确定

    “导入文件”窗口

  9. 导入 XML 工作空间文档地理处理工具的导入选项中,选择仅导入方案并单击运行

    导入 XML 工作空间文档工具参数

  10. 内容窗格中,右键单击 SampleBaseMapGDB.gdb,然后单击刷新
  11. 目录视图中,查看 SampleBaseMapGDB.gdb 内容。

    地理数据库由一系列系统表和用户数据组成。用户数据可存储在以下类型的数据集中:

    • 要素类
    • 要素数据集
    • 镶嵌数据集
    • 栅格数据集
    • 表(非空间)

    此外,要素类和表可以包含子类型并具有与之关联的域。您还可能会注意到地理数据库中的附件和关系类。

    导入的地理数据库对象

    在此地理数据库中,要素类将被组织为需要按照主题(例如行政交通)对要素类进行分组的要素数据集。此地理数据库还包含了地理处理工具箱,可用于组织一系列用户创建的地理处理工具、脚本和模型。

    要素数据集可包含要素类以及以下类型的数据集:

    • 几何网络(在 ArcGIS Pro 中为只读)
    • 网络数据集(需要 ArcGIS Network Analyst 扩展模块)
    • 地形(需要 ArcGIS 3D Analyst 扩展模块)
    • 拓扑

  12. 展开并查看在行政要素数据集中组织的要素类。

    此为底图地理数据库方案,因此行政要素数据集将包含多个线和面要素类,用于存储和维护行政区域的边界线和面。

    行政要素数据集

  13. 内容窗格中,单击 SampleBaseMapGDB.gdb

    目录窗格中包含了 PointsOfInterest 要素类,这是一个未在要素数据集中进行组织和维护的独立要素类。

    PointsOfInterest 要素类

    PointsOfInterest 要素类具有一个关联的附件表 PointsOfInterest__ATTACH,其中可能包含要素类中每个点的图像、相关文档以及链接,因此十分值得关注。附件功能提供了一种有效的方法,可以将非地理数据与您的地理信息相关联;在本例中,该功能使用名为 PointsOfInterest__ATTACHREL 的关系类来维持点与其相关附件之间的持久链接。您可以了解有关附件的详细信息

  14. SampleBaseMapGDB.gdb 中,查看 坡度地图正射影像

    这两个地理数据库对象均表示栅格数据存储和管理方法。

    地理数据库栅格

    坡度地图对象将表示单个栅格或图像数据图层的栅格数据集。通常而言,栅格数据集指的是受 ArcGIS Pro 支持的、可以存储在地理数据库中的任何栅格格式。正射影像对象将表示用于管理、显示、提供和共享栅格数据集合的镶嵌数据集。

  15. SampleBaseMapGDB.gdb 中,找到 HistoricSitesDescriptions

    此对象将表示非空间地理数据库表,其中可以包含可根据需要与空间要素进行关联的描述、代码和其他相关数据。

    注:

    您已将 XML 工作空间文档导入了 SampleBaseMapGDB.gdb,用以探索和查看典型的底图设计。在本课程中,您将不会再次用到此地理数据库。

  16. 内容窗格中,展开数据库并单击 SampleBaseMapGDB.gdb
  17. 在功能区目录选项卡的组织组中,单击移除
    注:

    移除地理数据库仅会从工程中移除所选项目。系统将移除该项目的所有工程引用内容,但该项目仍将保留在磁盘上。

    您已经查看了示例底图地理数据库方案,现在可以继续填充自己的旅游地理数据库了。

编写和准备萨尔茨堡地理数据库

在为填充萨尔茨堡地理数据库做准备的过程中,您将编辑和更新地理数据库元数据。

  1. 内容窗格中,右键单击 SalzburgGeodatabase.gdb 并选择编辑元数据

    “编辑元数据”选项

    元数据内容显示在详细信息窗格的目录视图中。内容窗格将更新以显示元数据类别。对于 SalzburgGeodatabase.gdb,将定义三个元数据组:概述元数据资源。您可以了解有关编辑元数据的详细信息

    元数据组

    目录视图中,元数据显示在详细信息窗格中。

    地理数据库元数据

    接下来,您需要填充概述项目的项目描述。

  2. 目录视图的详细信息窗格中,更新以下信息:

    • 对于标题,请输入 Salzburg Tourism Geodatabase
    • 对于标签,请输入 Salzburg, Austria, Visitor map, Tourism, Tourist, Visitor guide, Food, Activities, Attendees, Places to visit, Places to eat, Bike Routes, Ski Resorts, Museums, Art, Castles, Cathedrals
    • 对于摘要,请输入 Collection of data for the city and surrounding areas of Salzburg Austria
    • 对于描述(摘要),请输入 Geodatabase to store and manage a collection of spatial and attribute data that can be used by tourism agencies in the city of Salzburg, Austria to develop updated web maps and apps

  3. 对于制作者名单,请输入以下信息:

    • STADT: SALZBURG https://maps.stadt-salzburg.at/
    • 国家测绘局 - 联邦计量和测量局 (BEV) https://www.bev.gv.at
    • 奥地利在线地图
    • 萨尔茨堡州 - 政府开放数据 (OGD) - https://service.salzburg.gv.at/ogd/client/ 和 https://www.salzburg.gv.at/sagis/
    • 奥地利 OGD 底图 https://www.basemap.at/index_en.html

  4. 适用的比例范围设置为 1:50,000 至 1:5,000。

    比例范围

  5. 单击“添加”按钮以显示和更新边界框信息。添加以下信息:

    西

    12.058153

    14.008495

    46.938376

    48.042424

    边界框值对于已发布的图层和地图而言非常有用,原因是 Web 应用程序将按照框的范围而非整个世界进行显示。

    注:

    在为 ArcGIS 项目创作或更新元数据内容时,记录对于您的组织了解该项目而言相对重要的信息。这可包括项的准确性和时间、与使用和共享项相关的限制、项生命周期中的重要过程(如概化要素)等等。

  6. 在功能区元数据选项卡的管理元数据组中,单击保存
  7. 关闭元数据编辑器窗格。
  8. 内容窗格中,右键单击 SalzburgGeodatabase.gdb 并选择查看元数据

    目录视图将显示萨尔茨堡旅游地理数据库的更新元数据。

    地理数据库元数据

    注:

    当采取措施提供良好的描述性信息时,可以通过搜索找到项,并可以判断搜索结果中的哪个项是目标项。您可改善沟通,并在根据项目的地理空间信息做出决策时充满信心。您可对工程进行存档,以便其将来能够进行恢复、使用和评估。

  9. 保存工程。

接下来,您需要开始将多个数据源从 City_of_SalzburgKMZ 文件OpenStreetMap_Salzburg 文件夹中迁移到 SalzburgGeodatabase.gdb


填充地理数据库

研究萨尔茨堡市目前的旅游地图和在线信息,有助于充分说明各个旅游机构和私营企业需要哪些数据主题才能最好地为游客服务。上述内容可帮助您充分地了解到需要将哪些数据同化到您的地理数据库中;同时请记住,您所构建并将在稍后进行符号化的大多数要素类很可能会显示在当前发布在 ArcGIS Living Atlas of the World 和其他源中的底图图层上。您的要素类将为现有的基础数据提供补充,并为各个机构可能生成和发布的交互式 Web 地图和应用程序增加价值。

最受欢迎的萨尔茨堡旅游地图和数据包括以下项目:

  • 可显示街道、步行区和建筑物的详细城市地图
  • 带有旅游亮点的观光地图
  • 带有市场与展会位置的地图
  • 公共汽车/轻轨站及路线
  • 有创意的步行路线 - 建筑、博物馆、艺术、画廊、教堂
  • 步道和自行车道
  • 内含啤酒厂和酒馆的品酒路线
  • 城市与自然主题的徒步路线
  • 酒店地图

创建要素数据集

在使用地理数据库时,您可以直接从地理数据库创建空要素数据集。首先,您需要为以下四个数据主题创建要素数据集:

  • City_Attractions
  • 交通
  • Scenic_Attractions
  • 路径

  1. 如有必要,请打开您的工程。
  2. 内容窗格中,右键单击 SalzburgGeodatabase.gdb,指向新建,然后单击要素数据集

    与您选择的数据集类型相对应的地理处理工具随即打开。

    “要素数据集”选项

  3. 创建要素数据集地理处理工具的要素数据集名称中,请输入 City_Attractions
  4. 对于坐标系,请单击选择坐标系按钮。

    要定义地理数据库对象的坐标系,最简单方法之一就是从正确定义了坐标系的当前数据源导入或克隆这个坐标系。

  5. 坐标系窗格中,单击添加坐标系按钮并选择导入坐标系

    “导入坐标系”选项

  6. 导入坐标系窗格中,浏览到 City_of_Salzburg 文件夹。选择 BicyclePaths.shp 并单击确定

    “导入坐标系”窗口

  7. 可用 XY 坐标系列表中,确认已选中 MGI Austria GK M31 并单击确定

    坐标系窗口

  8. 创建要素数据集工具中,验证参数并单击运行

    “创建要素数据集工具”参数

    注:

    在奥地利,用于地籍数据的官方投影坐标系是 MGI Austria GK Central - 此为横轴墨卡托投影。但是,奥地利的部分州(例如萨尔茨堡市所在的州)为避免出现负值而应用了一个平移(东偏移量),因此将使用名为 MGI Austria GK M31 的自定义坐标系。

  9. 目录视图中,右键单击 City_Attractions 并选择编辑元数据
  10. 详细信息窗格的目录视图中,对元数据进行以下更新:

    • 对于标题,请输入 Salzburg City Attractions
    • 对于标签,请输入 Salzburg, Austria, City Attractions
    • 对于摘要,请输入 Collection of Salzburg visitor attractions
    • 对于描述(摘要),请输入 Location of various city sites commonly visited by tourists in Salzburg Austria
    • 对于制作者名单,请输入以下信息:
      • STADT: SALZBURG https://maps.stadt-salzburg.at/
      • 国家测绘局 - 联邦计量和测量局 (BEV) https://www.bev.gv.at
      • 奥地利在线地图
      • 萨尔茨堡州 - 政府开放数据 (OGD) - https://service.salzburg.gv.at/ogd/client/ 和 https://www.salzburg.gv.at/sagis/
      • 奥地利 OGD 底图 https://www.basemap.at/index_en.html
    • 适用的比例范围设置为城市 (1:50,000) 至建筑物 (1:5,000)。
    • 对于边界框,请设置以下值:

      西

      12.058153

      14.008495

      46.938376

      48.042424

  11. 在功能区元数据选项卡的管理元数据组中,单击保存
  12. 目录视图中,关闭 City_Attractions 选项卡。
  13. 内容窗格中,右键单击 City_Attractions 并选择查看元数据

    要素数据集元数据

  14. 内容窗格中,单击 SalzburgGeodatabase.gdb
  15. 在功能区目录选项卡的创建组中,单击新建并选择要素数据集

    新建要素数据集

  16. 创建要素数据集地理处理工具中,设置以下参数:

    • 对于输出地理数据库,选择 C:\Salzburg\SalzburgGeodatabase\SalzburgGeodatabase.gdb
    • 对于要素数据集名称,请输入 Scenic_Attractions
    • 对于坐标系,选择 MGI Austria GK M31

  17. 使用相同的工作流和参数,为以下数据类型创建其他要素数据集:

    • 交通
    • 路径

  18. 内容窗格中,展开 SalzburgGeodatabase.gdb 并验证四个要素数据集的创建情况。
    要素数据集
  19. 或者,可更新其他要素数据集的元数据。

导入单个 shapefile

您可以通过从源数据格式导入数据并将其转换为要素类的方式来将数据添加到地理数据库。首先,您将看到将 shapefile 迁移到地理数据库中。shapefile 采用了旧版数据格式,这种格式在 GIS 社区中仍然很流行,但它所存在的一些限制使得我们无法将其作为高效的数据存储类型来使用。shapefile 与要素类类似,因此当您将 shapefile 迁移到地理数据库时,系统会直接将其作为单个要素类映射到地理数据库。

  1. 对于目录窗格中的 SalzburgGeodatabase.gdb,右键单击 City_Attractions 要素数据集,指向导入,然后选择要素类

    导入要素类选项

    您也可以使用导入要素类工具,该工具位于功能区上目录选项卡中的创建组中。

    从目录选项卡导入要素类选项

    将打开要素类至要素类地理处理工具。此工具允许您选择要导入地理数据库的单个数据源。此外,您可以重命名输出要素类,并选择要保留或从源数据中移除的源属性字段。

  2. 要素类至要素类地理处理工具中,对于输入要素,请浏览到 OpenStreetMap_Salzburg 文件夹并选择 OSM_Salzburg_HistoricSites.shp
  3. 请确认输出位置已设置为 City_Attractions
  4. 对于输出要素类,输入 HistoricSites
    注:

    字段映射部分中,输出字段参数可显示将复制到输出数据集的属性字段列表。要删除字段,请选中该字段并选择移除。要移除多个字段,请按 Shift+Ctrl 选中字段,然后选择移除

  5. 输出字段列表中,保留以下字段:HISTORICNAMEADDR_HOUSEADDR_HOU00ADDR_STREEADDR_CITYADDR_STATEADDR_POSTCADDR_PLACE。移除其他所有字段。
  6. 验证参数并单击运行

    要素类至要素类工具参数

    您无需为 HistoricSites 要素类定义空间参考。源 shapefile 将 WGS_1984_Web_Mercator_Auxiliary_Sphere 定义为坐标系。由于您已经定义了目标要素数据集的坐标系,源数据会自动重新投影以匹配目标要素数据集的坐标系。

  7. 内容窗格中,右键单击 City_Attractions 并选择刷新
  8. 目录视图中,单击 HistoricSites

    随即显示元数据选项卡。原始 shapefile 元数据已复制到地理数据库要素类中。

    注:

    如果目录视图不显示您的要素类,请单击位于目录视图右上角的显示/隐藏详细信息按钮。

    要素类元数据

  9. 目录视图中,右键单击 HistoricSites 并选择编辑元数据

    “编辑元数据”选项

  10. 在元数据编辑器窗格中,更新以下信息:

    • 对于标题,请输入 Salzburg Historic Sites
    • 对于标签,请输入 Salzburg, Austria, Historic sites
    • 对于摘要,请输入 Point features of historic sites in Salzburg Austria
    • 对于制作者名单使用限制,请保留默认文本,原因是这些字段是从源元数据填充的。
    • 对于描述(摘要),请输入 Location of historic sites in Salzburg Austria
    • 适用的比例范围设置为城市 (1:50,000) 至建筑物 (1:5,000)。

    所编辑的要素类元数据

  11. 在功能区元数据选项卡的管理元数据组中,单击保存
  12. 关闭元数据编辑器窗格。

将多个要素类导出或导入地理数据库

如果仅需要转换所选要素并选择要复制到输出要素类的特定属性字段,则导出或导入单个 shapefile 将非常有用。有时为了快速进行转换需要批量转换多个源,且此后需要花时间来移除不需要的属性字段。

  1. 内容窗格中,单击 City_of_Salzburg 文件夹。
  2. 目录视图中,单击 Castles.shp,按下 Ctrl 键,然后选择 Museums.shpReligiousMonuments.shp
  3. 右键单击 Castles.shp,指向导出,然后选择要素类至地理数据库

    “要素类至地理数据库”选项

  4. 要素类至地理数据库地理处理工具中,对于输出地理数据库,浏览至 SalzburgGeodatabase.gdb 中的 City_Attractions 要素数据集并将其选中。
  5. 单击运行

    要素类至地理数据库工具参数

  6. 验证 SalzburgGeodatabase.gdb 中的 City_Attractions 要素数据集是否包含四个要素类。

    已导入要素类

  7. 内容窗格的 SalzburgGeodatabase.gdb 下,右键单击 Scenic_Attractions 要素数据集,单击导入,然后选择 Feature_Class(es)

    “导入要素类”工具

  8. 要素类至地理数据库地理处理工具中,针对输入要素,添加以下 shapefile:

    源文件夹 源 shapefile

    City_of_Salzburg

    NatureReserves.shp

    NaturalParks.shp

    Skilifts.shp

    SkiSlopes.shp

    SwimmingHoles.shp

    Waterbodies.shp

    Waterwheels.shp

    OpenStreetMap_Salzburg

    OSM_Salzburg_CableCar.shp

    OSM_Salzburg_CableCarStations.shp

    OSM_Salzburg_NaturalFeatureBoundaries.shp

    OSM_Salzburg_NaturalFeatures.shp

    OSM_Salzburg_ReceationSiteBoundaries.shp

    OSM_Salzburg_RecreationSites.shp

    OSM_Salzburg_Streams.shp

    要素类至地理数据库工具参数

  9. 单击运行
  10. 目录视图中,重命名以下要素类。

    原始名称新名称

    OSM_Salzburg_CableCar.shp

    CableCar

    OSM_Salzburg_CableCarStations.shp

    CableCarStations

    OSM_Salzburg_NaturalFeatureBoundaries.shp

    NaturalFeatureBoundaries

    OSM_Salzburg_NaturalFeatures.shp

    NaturalFeatures

    OSM_Salzburg_ReceationSiteBoundaries.shp

    ReceationSiteBoundaries

    OSM_Salzburg_RecreationSites.shp

    RecreationSites

    OSM_Salzburg_Streams.shp

    河流

  11. 验证 Scenic_Attractions 要素数据集是否包含 14 个要素类。

    已重命名的已导入要素类

  12. 或者,可更新 Scenic_Attactions 的元数据。
  13. 导入并重命名 Transportation 要素数据集中的以下 shapefile。

    源文件夹 源 shapefile 输出要素类名称

    City_of_Salzburg

    BicyclePaths.shp

    BicyclePaths

    BusLanes.shp

    BusLanes

    OneWayStreets.shp

    OneWayStreets

    Pavement.shp

    路面

    RoadNetwork.shp

    RoadNetwork

    Sidewalks.shp

    人行道

    Tunnels.shp

    隧道

    OpenStreetMap_Salzburg

    OSM_Salzburg_Airports.shp

    机场

    OSM_Salzburg_PublicTransportStations.shp

    PublicTransportStations

    OSM_Salzburg_Railroads.shp

    铁路

    OSM_Salzburg_RailroadStations.shp

    RailroadStations

    要素类至地理数据库工具参数

  14. 验证 Transportation 要素数据集是否包含 11 个要素类。

    Transportation 要素类

  15. 或者,可更新 Transportation 要素类的元数据。

导入 KML 文件

一些有用的旅游主题数据源仅作为 KML 文件提供。您将使用 KML 转图层工具将 .kmz 文件转换为文件地理数据库。

  1. 文件夹连接中,单击 kmz_files 子文件夹。

    目录视图中,共有三个 .kmz 文件。这些文件均为压缩的 KML 文件。

    KMZ 文件

    由于您的地理数据库中已有了一个 museums 图层,您只能转换 Burgen_und_Schloesser.kmzKunstwerke_mit_Audiotext.kmz 文件。这些要素用来表示城堡、宫殿以及由知名艺术家创作的艺术装置的位置。

  2. 在功能区分析选项卡的地理处理组中,单击工具
  3. 地理处理窗格中,搜索 kml。选择 KML 转图层转换工具。

    KML 转图层工具

    KML 转图层工具可将具有基于XML的要素的 KML 文件转换为特定于要转换的 KML 文件的唯一地理数据库。然后,要素(如点和面)将作为单独的要素类添加到此地理数据库中的 Placemarks 要素数据集。执行此转换后,您可以像处理其他任何 GIS 数据那样,使用来自 KML 文件的这些要素类中的地理数据。

  4. KML 转图层工具中,设置以下参数:

    • 对于输入 KML 文件,选择 C:\Salzburg\kmz-files\Burgen_und_Schloesser.kmz
    • 对于输出位置,请指定您的数据文件夹,如 C:\Salzburg
    • 对于输出数据名称,输入 Castle_Palace

    用于城堡和宫殿的“KML 转图层”工具参数

  5. 单击运行

    该工具将在输出文件夹的位置(例如 C:\Salzburg)创建一个名为 Castle_Palace.lyr 的输出图层文件和一个名为 Castle_Palace.gdb 的输出文件地理数据库。

  6. 使用以下参数第二次执行 KML 转图层工具:

    • 对于输入 KML 文件,选择 C:\Salzburg\kmz-files\ Kunstwerke_mit_Audiotext.kmz
    • 对于输出位置,请指定您的数据文件夹,如 C:\Salzburg
    • 对于输出数据名称,输入 Art_Installations

    用于艺术的“KML 转图层”工具参数

  7. 单击运行

    该工具将在输出文件夹的位置(例如 C:\Salzburg)创建一个名为 Art_Installations.lyr 的输出图层文件和一个名为 Art_Installations.gdb 的输出文件地理数据库。

  8. 内容窗格中,展开 Salzburg 文件夹并确认已成功创建 Art_Installations.gdbCastle_Palace.gdb

    新建地理数据库

  9. 目录视图中,找到并展开 Art_Installations.gdb

    KML 转图层工具创建的地理数据库中包含名为 Placemarks 的要素数据集。

  10. 展开 Placemarks 要素数据集。

    在要素数据集中,该工具已经添加了包含已转换的 KML 点要素的点要素类。

  11. 右键单击要素类,选择重命名,然后请输入 Art_Installations
  12. 目录视图中,找到并展开 Castle_Palace.gdb
  13. 展开 Placemarks 要素数据集并将重命名为 Castle_Palace
  14. 目录视图中,右键单击 Art_Installations 要素类,然后选择复制

    复制选项

    在地理数据库之间复制要素类无需在不同的数据格式之间进行转换,因此是移动或创建要素类副本的一种简单、快速的方法。

  15. 内容窗格中的 SalzburgGeodatabase.gdb 下,右键单击 City_Attractions 要素数据集,然后选择粘贴

    粘贴选项

    粘贴失败,错误消息报告源要素类和目标要素数据集具有不匹配的坐标系。

    粘贴要素类失败

    原始 KML 文件以及包含点的已转换要素类的地理坐标系设置为 GCS_WGS_1984。目标 City_Attractions 要素数据集将 MGI_Austria_GK_M31 投影作为其坐标系。由于上述原因,将源要素类复制到目标要素数据集失败。但是,将源要素类导入目标要素数据集时,会将源要素重新投影到与目标要素数据集相同的坐标系中。

  16. 目录视图中,右键单击 Art_Installations 要素类,指向导出,然后选择要素类至地理数据库

    “导出至地理数据库”工具

  17. 要素类至地理数据库工具中,设置以下参数:

    • 对于输入要素,浏览至 Castle_Palace 要素类并进行添加。
    • 对于输出地理数据库,浏览至 City_Attractions 要素数据集并将其选中。

    要素类至地理数据库工具参数

  18. 单击运行

    这次,因为已重新投影源要素以匹配 City_Attractions 坐标系,所以要素类成功添加到 City_Attractions 要素数据集。

  19. 目录视图中,针对 City_Attractions,请确认要素类已成功导入。

    新建要素类

  20. 或者,可以更新 Art_InstallationsCastle_Palace 要素类元数据。

    您的 SalzburgGeodatabase.gdb 现在有多个要素类被组织到主题要素数据集中,这对于旅游机构进行维护和更新工作非常有用,使其可以为访问萨尔茨堡市的游客生成新的和经过改进的地图和应用程序。

    在此阶段,您可能希望与利益相关者共享地理数据库以获得反馈,然后再添加其他要素并优化属性,从而通过应用属性验证使数据更加高效和实用。在共享之前,您可能希望进行一些地理数据库管理。

准备地理数据库以供审阅和分发

文件地理数据库将以包含二进制文件的文件夹形式存储在磁盘上。首次向地理数据库添加数据时,每个文件中的记录均有序排列,可按文件系统进行高效访问。然而,随着时间的推移您会删除和添加记录,这样,每个文件中的记录会变得排列无序,而且由于记录被移除还会产生未使用的空间,而新记录又添加到文件的其他位置。这会导致文件系统在每个文件中执行更多的记录查找操作,从而降低了访问记录的速度。由于您是通过将各种源数据集导入地理数据库来添加要素数据集和要素类的,因此您实际上是在编辑地理数据库,并由此影响地理数据库的性能。

接下来,您将为记录重新排序并移除未使用的空间,以提高地理数据库的效率。

  1. 内容窗格中,右键单击 SalzburgGeodatabase.gdb,指向管理,然后选择碎片整理

    单击碎片整理时系统将执行该过程、自动将记录重新排序并移除未使用的空间,以提高地理数据库的效率并减少空间浪费。对频繁编辑的地理数据库进行碎片整理时,会清理存储空间和未使用的空间,同时也会缩减每个文件的大小。如果您频繁添加和删除数据,则应每月对文件地理数据库执行一次碎片整理操作。而且,在执行了任何大规模更改后,也应对地理数据库执行一次紧缩操作。

    “碎片整理”选项

    除了对地理数据库进行碎片整理之外,您还可以应用压缩。所分发的压缩数据集为只读形式,因此除了可以更改其名称以及修改属性索引和元数据之外,无法对其进行任何形式的编辑或修改。压缩非常适合不需要进一步编辑的数据集,它也是将初始地理数据库交付给利益相关者进行审阅,且有效避免其修改源数据要素的理想方式。

    要与利益相关者共享地理数据库,还有几种替代方案可供考量。其中包括创建 XML 工作空间文档;使用复制裁剪工具提取数据子集;或使用“打包”工具集来合并、打包和共享图层、地图文档和结果。

    在以下可选步骤中,您将生成一个 XML 工作空间文档,以共享您 SalzburgGeodatabase.gdb 的数据和方案。

  2. 内容窗格中,右键单击 SalzburgGeodatabase.gdb,指向导出,然后选择地理数据库至 XML 工作空间文档

    “地理数据库至 XML 工作空间文档”选项

  3. 导出 XML 工作空间文档工具中,设置以下参数:
    • 对于输入数据,浏览到 C:\Salzburg\SalzburgGeodatabase\SalzburgGeodatabase.gdb
    • 对于输出文件,请输入 SalzburgGeodatabase_ExportXML.xml
    • 对于导出选项,选择数据
    • 对于存储类型,确认已选择二进制
    • 选中导出元数据

    导出 XML 工作空间文档工具

  4. 单击运行

    您现在即可分发或与利益相关者共享您的输出 XML 工作空间文档,以供审阅和评论。

  5. 保存工程。

在本课程中,您创建了一个 ArcGIS Pro 工程,以此为创建地理数据库提供支持。您使用目录视图与工程组件进行交互并管理地理数据库,而且您创建了多个要素数据集并导入了各种要素类。您探索了向地理数据库组件添加元数据,以及通过应用压缩来提高地理数据库的效率。

您可以在 Learn ArcGIS 课程库中找到更多课程。