Подготовка модели рельефа

Прежде, чем приступить к анализу, вы выполните предварительную обработку цифровой модели рельефа (DEM) города Стоув (шт. Вермонт, США), чтобы сократить вероятные ошибки в результатах. Некоторые наборы данных DEM содержат выемки, представляющие локальные понижения, окруженные ячейками в более высокими значениями высот. Выемки бывают естественные, но чаще представляют собой ошибки в наборах растровых данных ЦМР. Так как вода не может вытечь из локального понижения, эти понижения могут вызывать разнообразные ошибки при анализе того, как протекает вода. Прежде, чем приступить к гидрологическому анализу возможностей наводнений в городе Стоув, надо выявить и удалить локальные понижения из данных рельефа.

Загрузка и открытие проекта

Сначала надо скачать данные по Стоув, предоставленные администрацией Вермонта, а также цифровую модель рельефа DEM из данных Геологической службы США (USGS). Эти данные будут находиться в проекте ArcGIS Pro. Файлы проекта также содержать задачу, которая пошагово проведет вас через весь рабочий процесс.

  1. Скачайте сжатую папку Stowe_Hydrology.
  2. Найдите загруженный файл на компьютере.
    Примечание:

    В зависимости от настроек браузера, вам могло быть предложено выбрать место для сохранения загружаемого файла. Большинство браузеров по умолчанию скачивают все в папку Загрузки.

  3. Щелкните файл правой кнопкой мыши и извлеките туда, где его будет легко найти, например, в папку Документы.
  4. Откройте распакованную папку и в ней папку Stowe_Hydrology.

    Папка содержит файл проекта Stowe_Hydrology для ArcGIS Pro, базу геоданных Stowe_Hydrology и автоматически сгенерированную папку Index. Надо открыть проект.

  5. Если у вас на компьютере уже установлен ArcGIS Pro, дважды щелкните Stowe_Hydrology.aprx, чтобы открыть проект. Если будет предложено, войдите под лицензированной учетной записью ArcGIS.
    Примечание:

    Если у вас нет ArcGIS Pro или учетной записи ArcGIS, можно подписаться на бесплатную пробную версию ArcGIS.

    В проекте по умолчанию показан город Стоув (шт. Вермонт, США)

    Проект содержит карту с топографической базовой картой и следующими слоями:

    • Pour_point – точечный векторный слой, который показывает исток вниз по течению от реки Литтл, где вы создадите удельный гидрограф.
    • Stowe_boundary – векторный полигональный слой с границами города Стоува. Этот слой получен по данным Вермонтского центра географической информации (VCGI).
    • Stowe_surface_water – растровый слой, показывающий все поверхностные водоемы на изучаемой территории. Разрешение этого растрового слоя 30 метров, то есть одна ячейка занимает площадь 30 квадратных метров. Этот слой получен из набора данных NHDPlus Version 2.
    • Stowe_DEM – растровый слой с высотами изучаемой области. Его разрешение также 30 метров. Получен на основании данных Геологической службы США (USGS).
    • Stowe_velocity_example – растровый слой, который показывает пространственно-вариативное поле скоростей для исследуемой области, не зависящее от времени и разряда. На следующем уроке вы узнаете, как создать такой слой (он приложен на всякий случай). В данный момент этот слой не нужен, поэтому он отключен.

    Хотя его нет на карте, в папке проекта (Stowe_Hydrology) находится еще текстовый файл Stowe_isochrones, который содержит ранги классификации для изохронных зон, которые вы создадите на следующем уроке.

    Посмотрев на слой Stowe DEM, вы можете его выключить, чтобы не заслонял результаты.

  6. На панели Содержание отключите слой Stowe_DEM, чтобы его не было видно.
    Примечание:

    В зависимости от параметров конфигурации ArcGIS Pro по умолчанию, панель Содержание может быть скрыта. В случае необходимости щелкните вкладку Вид на ленте. В группе Окна щелкните Содержание.

    Отключите слой Stowe_DEM

    Теперь надо открыть включенную в проект ArcGIS Pro задачу. Эта задача проведет вас через рабочий процесс, необходимый для создания удельного гидрографа.

  7. На панели Каталог разверните папку Задачи.
    Примечание:

    Если панель Каталог не видна, на вкладке Вид в группе Окна щёлкните Панель Каталог.

    Разверните папку Задачи

  8. Дважды щелкните задачу Create unit hydrograph at outlet.

    Появится панель Задачи. Там содержится несколько задач, для разных частей рабочего процесса.

Определение локальных понижений

Сначала надо выявить локальные понижения в DEM. Хотя DEM и была получена на основании достоверного источника, предоставленного Геологической службой США, там все равно могут присутствовать локальные понижения. Для выполнения точного гидрологического анализа окрестностей города Стоува, сначала надо выявить все локальные понижения.

  1. На панели Задачи дважды щелкните задачу Precondition the elevation model.

    Задача Предварительные условия модели рельефа

    Откроется задача. Каждая задача содержит инструкции для работы. Задача состоит из трех шагов (полоса с ходом выполнения в нижней части панели сообщает об общем количестве шагов). Первый шаг открывает инструмент Направление стока. Определив направление стока на изучаемой территории, вы сможете выявить локальные понижения, из которых вода никуда не вытекает.

  2. В качестве Входного растра поверхности выберите Stowe_DEM.
  3. Для Выходной растр направления стока щелкните текстовое окно и подтвердите, что выходной локацией будет база геоданных Stowe_Hydrology. Измените имя выходного слоя на Stowe_flow_direction.

    Параметры инструмента Направление стока

    Остальные параметры можно не менять, так как для данного анализа они не имеют значения.

    Подсказка:

    Если вы хотите получить более подробную информацию о каком-либо параметре, наведите курсор на параметр и информационную кнопку.

  4. Щелкните Run.

    Инструмент запустится, и растровый слой направления стока добавится на карту.

    Слой Stowe_flow_direction

    Символы слоя соответствуют направлению, в котором, вероятно, потечет вода, причем самым темным показано южное, а светлым – северное направление стока. Внешний вид слоя не имеет значения для анализа, так как вы запустите другой инструмент, который автоматически выявляет локальные понижения на основании слоя направления стока.

  5. Если необходимо, откройте панель Содержание. Снимите отметку со слоя Stowe_flow_direction, чтобы отключить его.
    Примечание:

    Возможно, панель Задачи перекрывает панель Содержание. В этом случае вы можете переключаться между панелями, щелкая соответствующие вкладки в нижней части активной панели.

  6. Если необходимо, вернитесь на панель Задачи.

    После завершения первого шага задачи вы автоматически переходите на следующий шаг. В следующем шаге используется инструмент Локальное понижение, выявляющий районы внутреннего дренажа (локальные понижения) в пределах слоя направления стока.

  7. В качестве Входного D8 растра направления стока выберите Stowe_flow_direction.
  8. Для Выходного растра убедитесь, что выбрана база геоданных Stowe_Hydrology, и измените выходное имя на Stowe_sinks.

    Параметры инструмента Локальные понижения

  9. Щелкните Run.

    Инструмент запустится, и растр с локальными понижениями добавится на карту. Новый слой, состоящий в основном из небольших групп черных пикселов, может быть сложно разглядеть с установленными по умолчанию символами. Вы измените символы так, чтобы локальные понижения было проще увидеть.

  10. На панели Содержание щелкните правой кнопкой слой Stowe_sinks и выберите Символы.

    Символы слоя Stowe_sinks

    Появится панель Символы.

  11. В опции Цветовая схема выберите схему Желтый - Красный.

    Цветовая схема Желтый - Красный

  12. Закройте панель Символы.

    Теперь локальные понижения гораздо лучше выделяются на фоне базовой карты, но все равно они очень мелкие и их сложно разглядеть.

  13. Приблизьтесь к точке устья (красному кружку), чтобы рассмотреть какие-нибудь локальные понижения.

    Локальные понижения близ выхода

  14. Перемещайтесь по окрестностям Стоува и изучайте карту.

    Локальные понижения наблюдаются в основном в окрестностях водотоков и водоемов, показанных в слое Stowe_surface_water. Существующие водоемы кажутся плоскими и могут вызывать в цифровой модели рельефа такие ошибки, как локальные понижения.

  15. На панели Содержание щелкните правой кнопкой слой Stowe_DEM и выберите Приблизить к слою.

    Карта приблизится к экстенту изучаемой области.

  16. Отключите слой Stowe_sinks.

Заполнение локальных понижений

Теперь, когда вы определили, где существуют локальные понижения в вашей DEM, вы создадите DEM с удаленными локальными понижениями. В новой DEM вместо локальных понижений всем ячейкам будут присвоены значения высот самой низкой из окружающих понижение ячеек. Каждая ячейка в новой DEM будет частью хотя бы одного непрерывно понижающегося пути из ячеек, ведущему к краю набора данных. На основании этой новой DEM можно будет провести более точных гидрологический анализ окрестностей Стоува.

  1. Если необходимо, вернитесь на панель Задачи.

    Последний шаг текущей задачи использует инструмент Заполнение для удаления локальных понижений из DEM.

  2. В качестве Входного растра поверхности выберите Stowe_DEM.
  3. Для Выходного растра поверхности убедитесь, что выбрана база геоданных Stowe_Hydrology, и измените выходное имя на Stowe_fill.

    Параметры инструмента Заполнение

    В последнем параметре Ограничения по Z позволяют установить максимальные различия высот при заполнении локальных понижений. Если различия в высотах между локальным понижением и его точкой устья больше, чем значение ограничения, это локальное понижение не будет заполнено. Вам надо заполнить все локальные понижения в этом наборе данных, поэтому оставьте этот параметр без изменений.

  4. Щелкните Готово.

    Инструмент запустится, и DEM с заполненными локальными понижениями добавится на карту. Он выглядит практически так же, как исходный DEM, но локальные понижения в наборе данных все заполнены. Вы будете использовать данный слой в качестве основы для дальнейшего анализа гидрологических условий в окрестностях Стоува.

  5. На панели быстрого доступа щелкните кнопку Сохранить, чтобы сохранить проект.

    Кнопка Сохранение

Вы использовали ряд инструментов геообработки для поиска локальных понижений в исходной ЦМР. Также вы исследовали локальные понижения и обнаружили, что почти все они находятся возле водных объектов, возможно по причине неточностей в данных рельефа. Наконец, вы заполнили локальные понижения в наборе данных. Далее вы будете при помощи новой ЦМР определять водосборную область, охватывающую Стоув. Зная водосборную область, можно понять, каким образом вода собирается в окрестностях города.


Определение водосборной области

Ранее вы удалили локальные понижения из своей ЦМР, чтобы она была готова для гидрологического анализа. Теперь вы используете ЦМР для определения области водосбора для точки выхода к югу от Стоув. Водосборная область – это территория, с которой вся вода в итоге стекает в определенную точку; в данном случае в точку стока. В пределах водосборной области вы сможете ограничить результаты последующего анализа областью, подходящей для указанной точки стока. Для определения водосборной области нужны две вещи: растр направления стока и точно указанная точка стока.

Доступ к направлениям стока

Первый шаг для разграничения водосборной области представляет собой определение направления, в котором вода будет течь по цифровой модели рельефа. Таким образом, вы сможете определить области, с которых вода будет стекать в точку стока. Чтобы это сделать, надо построить еще один растр направления стока, на этот раз на основании DEM с заполненными локальными понижениями.

  1. Если надо, откройте свой проект Stowe_Hydrology в ArcGIS Pro и в нем задачу Create unit hydrograph at outlet.
  2. На панели Задачи дважды щелкните задачу Delineate the watershed (разграничение водораздела).

    Задача Delineate the watershed

    Задача состоит из пяти шагов. Первый шаг открывает инструмент Направление стока. Вместо того, чтобы использовать этот инструмент для выявления локальных понижений, как в прошлый раз, вы используете его для создания критически важного промежуточного слоя для определения водосборной области.

  3. В качестве Входного растра поверхности выберите Stowe_fill.
  4. Для Выходного растра направления стока убедитесь, что в качестве выходной локации указана база геоданных Stowe_Hydrology, а имя результата переименуйте в Stowe_fill_flow_direction.

    Параметры инструмента Направление стока

    Как и в прошлый раз, оставьте прочие параметры без изменений.

  5. Щелкните Запустить.

    Инструмент запустится и новый слой добавится на карту.

    Слой Stowe_fill_flow_direction

    В отличие от предыдущего слоя направления стока, который был черно-белым, новый слой получился цветным (цвета подбираются случайным образом и могут отличаться от приведенного здесь примера).

  6. Откройте панель Содержание. Если надо, щелкните стрелку, чтобы развернуть слой Stowe_fill_flow_direction.

    Символы слоя Stowe_fill_flow_direction

    Значениями ячеек растрового слоя направления стока могут быть лишь 8 следующих целочисленных значений: 1, 2, 4, 8, 16, 32, 64 или 128. Эти восемь вариантов значений соответствуют восьми возможным направлениям потока (так как любая конкретная ячейка окружена восемью соседними ячейками). Но в предыдущем растре направления стока были какие-то другие значения, а не эти восемь. Те значения относились к локальным понижениям, которые вы удалили из данных. Так как в исходном слое направления стока был широкий диапазон значений, ему автоматически были присвоены символы на основании цветовой шкалы, которая по умолчанию использует черно-белую схему. Ваш новый слой направления стока содержит лишь эти восемь значений, поэтому он был автоматически обозначен уникальными цветами для этих значений.

Привязка точки стока к водотоку

Новый слой направления стока – это первая составляющая, необходимая для определения водосборной области. Второй необходимый компонент – это точка стока. Один из скачанных вместе с проектом слоев называется Pour_point и представляет точку стока чуть ниже по течению от города Стоув в штате Вермонт. Для точного определения водосборной области точка стока должна находиться строго на водотоке, выявленном по DEM (и может быть слегка смещена относительно реального водотока по причине низкого разрешения DEM или какой-нибудь другой неточности). Сначала надо определить точное местоположение водотока, подсчитав области, где собирается больше всего воды. Затем вы выполните замыкание местоположения точки стока, чтобы она совпадала с водотоком.

  1. Откройте панель Задачи.

    Вторым шагом задача откроет инструмент Суммарный сток. Этот инструмент создает растровый слой, показывающий, где наиболее вероятно будет собираться вода. Накопление воды в каждой ячейке выражается в числовом значении, основанном на количестве ячеек, из которых туда стекает вода. Ячейки с высокими значениями накопления обычно совпадают с водотоками. По растру накопления вы выявите реку Литл, протекающую через город Стоув.

  2. В качестве Входного растра направления стока выберите Stowe_fill_flow_direction.
  3. Для Выходного растра накопления убедитесь, что выбрана база геоданных Stowe_Hydrology, и измените выходное имя на Stowe_flow_accumulation.

    Параметры инструмента Суммарный сток

    Оставьте прочие параметры без изменений. Первый из этих параметров применяет вес к каждой ячейке, что может оказаться полезными, если вы предполагаете неравномерное распределение воды (например, на большой изучаемой области, где осадки в разных местах существенно отличаются). Второй параметр определяет, результаты измерения суммарного стока будут целочисленными или с плавающей точкой. Предложенное по умолчанию значение с плавающей точкой позволяет включать десятичные знаки, что в большинстве ситуаций дает более высокую точность. Третий параметр определяет входные данные направления стока.

  4. Щелкните Запустить.

    Инструмент запустится, и растровый слой суммарного стока добавится на карту.

    Слой Stowe_flow_accumulation

    Ячейки с самым высоким суммарным стоком будут белыми. Тоненькая линия белых ячеек, которая проходит через точку стока – это река Литл. Следующий шаг задачи открывает инструмент Измерить расстояние (который находится на ленте, а не инструмент геообработки). Вы будете использовать этот инструмент для измерения расстояния от текущей точки стока до реки Литл, представленной растром суммарного стока. Это расстояние можно использовать для последующего замыкания точки стока на правильную ячейку, чтобы она оказалась точно выровнена относительно водотока.

    Чтобы провести измерение, надо приблизиться к точке стока. Но сейчас инструмент Измерить расстояние заменил инструмент Исследовать, что ограничивает возможности перемещения по карте. Но вы все равно можете приблизится, используя клавиши быстрого доступа.

  5. Нажмите и удерживайте клавишу Z. Перетащите карту к точке стока.
    Подсказка:

    Чтобы приблизиться, нажмите и удерживайте клавишу C.

    Точка стока по умолчанию

    Точка стока находится неподалеку от водотока, но не строго на нем. Вам надо измерить точное расстояние в метрах, единицах измерения карты.

  6. Если требуется в окне Измерение расстояния настройте отображаемые единицы измерения на Метрические.

    Единицы измерения расстояния – метры

  7. На карте щелкните точку стока. Затем дважды щелкните приблизительно посередине ближайшей ячейки с высоким значением накопления воды.

    Измерение точки стока

    Окно инструмента Измерить расстояние обновится, и в нем появится полученная длина. Должно получиться приблизительно 50 метров (значение может слегка отличаться, это нормально). На основании измерения, вам надо использовать расстояние 60 метров для замыкания точки стока на водоток. Расстояние замыкания, которое немного превышает измеренное расстояние, поможет избежать неоднозначности в инструменте. При принятии решения о расстоянии привязки убедитесь, что оно не превышает измеренное расстояние слишком много, или точка может замкнуться еще ниже по течению.

  8. На ленте на вкладке Карта в группе Навигация щелкните кнопку Исследовать.

    Измерение исчезнет с карты. Теперь можно нормально перемещаться.

  9. На панели Задачи щелкните Далее.

    Следующий шаг откроет инструмент Привязка точки устья. Этот инструмент привязывает точку устья к ячейке с наибольшим суммарным стоком в пределах заданного расстояния, в данном случае в пределах 60 метров.

  10. В качестве Входных растровых или векторных данных точек устьев выберите Pour_point. В качестве Входного растра суммарного стока выберите Stowe_flow_accumulation.
  11. Для Выходного растра убедитесь, что выбрана база геоданных Stowe_Hydrology, и измените выходное имя на Stowe_snapped_outlet.
  12. В качестве Расстояния привязки введите 60.

    Параметры инструмента Привязка точки устья

  13. Щелкните Запустить.

    Инструмент запустится, и растровый слой привязанной точки устья добавится на карту. В растре всего одна ячейка, представляющая новое местоположение точки стока. В нашем примере эта точка показана голубым цветом, но цвет устанавливается случайным образом, поэтому у вас он может быть другим.

    Слой Stowe_snapped_outlet

  14. На панели Содержание щелкните правой кнопкой слой Stowe_flow_accumulation и выберите Приблизить к слою.

    Карта возвращается к полному экстенту данных.

Выявление водораздела выше по течению от точки стока

Теперь у вас есть и слой направления стока, и точное местоположение точки стока; можно приступать к определению водосборной области выше по течению от точки стока. Последним шагом задача откроет инструмент Водосборная область.

  1. На панели Задачи для Входного растра направления стока D8 выберите Stowe_fill_flow_direction. В качестве Входных растровых или векторных данных точек устьев выберите Stowe_snapped_outlet.
  2. Для Выходного растра убедитесь, что выбрана база геоданных Stowe_Hydrology, и измените выходное имя на Stowe_watershed.

    Параметры инструмента Водосборная область

  3. Щелкните Готово.

    Инструмент запустится, и новый растровый слой добавится на карту. Вы измените символы нового слоя перед получением значения для них.

  4. На панели Содержание щелкните правой кнопкой мыши слой Stowe_watershed и выберите Символы.
  5. На панели Символы в разделе Основные символы измените метод назначения символов на Уникальные значения. В нижней части панели на вкладке Значения щелкните цветовой набор и выберите цвет из палитры.

    Слой Stowe_watershed

    Водосборная область представляет собой территорию, с которой вода стекает в указанную точку стока. Эта водосборная область охватывает почти всю территорию города Стоув, то есть почти все выпавшие в городе дождевые осадки потекут через город и никуда не будут отведены.

  6. На панели Содержание отключите следующие слои:
    • Stowe_surface_water
    • Stowe_fill
    • Stowe_fill_flow_direction
    • Stowe_snapped_outlet
    Подсказка:

    Можете свернуть все условные обозначения, чтобы на панели было видно как можно больше слоев.

  7. Сохраните проект.

Вы определили, как вода течет через город Стоув в штате Вермонт. На основании полученных результатов вы замкнули точку стока на реку Литл, как она показана в вашем слое DEM. Имея слой направления стока и точку стока, вы смогли очертить водосборный бассейн, находящийся выше города. Далее вы используете несколько гидрологических слоев и слоев рельефа для определения того, насколько быстро вода потечет через точку стока.


Создание поля со скоростями

Ранее вы создали область водосбора для области Стоув, котороую вы будете использовать как область интереса для большей части последующего анализа. Далее вы начнете подсчитывать, за сколько времени вода попадет в точку стока, что позволит дать прогноз – как быстро в городе будет наводнение в случае возможного ливня. Чтобы определить, за сколько времени вода куда-то попадет, сначала надо посчитать скорость, с которой она будет течь. Скорость воды будет вычисляться на основании поля скоростей – еще одной разновидности растрового слоя. Существует много разных типов полей скорости, вычислить которые можно при помощи разнообразных математических уравнений. Вы будете создавать поле со скоростями, которое меняется в пространстве, но время и суммарный сток меняться не будут. Это значит, что ваше поле со скоростями использует следующие предположения:

  • На скорость влияют такие пространственные компоненты, как уклон и суммарный сток (меняющееся в пространстве).
  • Скорость в конкретных местоположениях со временем не меняется.
  • Скорость в данном месте не зависит от скорости потока воды (не зависит от стока).

На самом деле, скорость может меняться со временем, и несомненно она зависит от объемов стока. Но для включения этих параметров потребуются дополнительные наборы данных, которых может не оказаться в доступности, а также технологии моделирования, которые сложно воспроизвести в ГИС-среде. Пространственно неравномерное поле скоростей, не зависящих от времени и суммарного стока, даст довольно точный результат, хотя надо помнить, что любой метод – это лишь упрощение реального наблюдаемого явления.

Вы будете использовать метод для создания полей скоростей, впервые предложенный Мэйдментом эт ал.. (1996).[1] Согласно этому методу каждой ячейке в поле скоростей назначается скорость на основе локального уклона и площади водосбора вверх по течению (число ячеек, текущих в эту ячейку или накопление стока). Используются следующие уравнения:

V = Vm * (sbAc) / (sbAcm)    (1)

Где V – это скорость в одной ячейке с уклоном s, а количество расположенных выше ячеек, с которых стекает вода – A. Коэффициенты b и c можно определить путем калибровки, статистического метода настройки параметров модели, чтобы предсказанные данные были как можно ближе к наблюдаемым данным. В данном сценарии вы будете использовать рекомендованные для метода значения b = c = 0,5. Vm – это средняя скорость во всех ячейках в пределах водосбора. Вы предположите, что средняя скорость Vm = 0,1 м/с. Наконец, sb Acm – это средний уклон в пределах водосборного бассейна. Чтобы избежать нереально быстрых или медленных результатов, вы установите ограничения на максимальную и минимальную скорости. Нижнее ограничение будет 0,02 метра в секунду, а верхнее – 2 метра в секунду.

Данное уравнение – это лишь один из нескольких способов вычисления поля скоростей, имеющий ряд собственных предположений и ограничений. Кроме того, этот рабочий процесс довольно сложный по причине использования многомерных уравнений. У вас есть резервная копия поля скоростей с названием Stowe_velocity_example, на случай возникновения сложностей при выполнении данного урока.

Создание растра уклона

Основные переменные, которые вы будете использовать в уравнении – это уклон и количество ячеек выше по склону, с которых вода стекает в данную ячейку. У вас уже есть растровый слой с количеством ячеек выше по склону: слой суммарного стока, который вы создали на прошлом уроке. У вас пока нет растра с уклонами, надо его построить.

  1. Если надо, откройте свой проект Stowe_Hydrology в ArcGIS Pro и в нем задачу Create unit hydrograph at outlet.
  2. На панели Задачи дважды щелкните задачу Create a velocity field.

    Задача Create a velocity field

    Эта задача состоит из пяти шагов. Первый шаг открывает инструмент Уклон, вычисляющий растровый слой, в котором для каждой ячейки поверхности растра будет значение уклона. Уклон определяется перепадом значений высоты соседних ячеек, поэтому в качестве входных данных потребуется исходный растр рельефа.

  3. В качестве Входного растра выберите Stowe_DEM.
  4. Для Выходного растра убедитесь, что выбрана база геоданных Stowe_Hydrology, и измените выходное имя на Stowe_slope.
  5. В параметре Выходное измерение установите Процентное увеличение.

    Параметры инструмента Уклон

    Опция измерения Процентное увеличение вычисляет крутизну склона как процент увеличения и называется также уклоном в процентах, в отличие от измерения в градусах. Оставьте прочие параметры без изменений. Плоскостной метод годится для использования на небольших территориях (как данный водосбор), когда разница в уклонах при использовании плоскостного или геодезического метода невелика. Коэффициент Z используется лишь в том случае, если единицы измерения расстояний по X и Y отличаются от единиц измерения высоты Z.

  6. Щелкните Запустить.

    Инструмент запустится, растровый слой уклонов добавится на карту.

    Слой Stowe_slope

    Темными цветами показаны более крутые уклоны. Ближе к горным вершинам уклоны круче, а вокруг русла реки, где расположен город, поверхность довольно плоская.

Вычисление коэффициента уклон-площадь

Получив растровые слои с уклонами и суммарным стоком, вы можете вычислить новый растровый слой, комбинирующий эти показатели. В этом слое будет показан коэффициент уклон-площадь (значение sb Ac из уравнения Мейдмента с соавторами). Следующий шаг задачи откроет инструмент Калькулятор растра, позволяющий создать пользовательский растровый слой, в котором будет вычислено то, что вы пожелаете.

  1. Для Выражения Алгебры карт используйте Инструменты и Растры для создания следующего выражения:

    SquareRoot("Stowe_slope") * SquareRoot("Stowe_flow_accumulation")

    Подсказка:

    Или можете просто скопировать и вставить это выражение.

    Квадратные корни уклонов и суммарного стока здесь используются согласно рекомендованным Мейдментом с соавторами коэффициентам (b = c = 0,5). Коэффициент 0,5 равен квадратному корню значения.

  2. Для Выходного растра убедитесь, что выбрана база геоданных Stowe_Hydrology, и измените выходное имя на Stowe_slope_area_term.

    Параметры инструмента Калькулятор растра

    Наконец, вы измените параметры среды инструмента геообработки, чтобы выходной слой был маскирован (или ограничен) экстентом водосбора Стоува. Сделав это, вы сможете вычислить средний коэффициент уклон-площадь в пределах водосборной области, который будет ключевым компонентом вашего уравнения поля скоростей.

  3. Над параметрами инструмента щелкните Параметры среды. В опции Маска выберите Stowe_watershed.

    Параметры среды инструмента Калькулятор растра

  4. Щелкните Запустить.

    Инструмент запустится, и слой добавится на карту.

    Слой Stowe_slope_area_term

Вычисление поля скоростей

Теперь у вас есть коэффициент уклон-площадь, и можно приступать к вычислению поля скоростей при помощи следующего уравнения:

V = Vm (sb Ac) / (sb Acm)    (1)

Как упоминалось ранее, Vm – это средняя скорость во всех ячейках в пределах водосбора. Вы будете использовать предполагаемое вычисленное значение Vm = 0,1, рекомендованное Мейдментом с соавторами. Аналогично, sb Acm – это средний уклон в пределах водосборного бассейна. Так как вы вычисляли коэффициент уклон-площадь для водосборного бассейна, вы можете точно вычислить среднее значение, а не опираться на предполагаемое.

  1. На панели Содержание щелкните правой кнопкой Stowe_slope_area_term и выберите Свойства.

    Откроется окно Свойства слоя для слоя коэффициентов уклон-площадь.

  2. Щелкните вкладку Источник и разверните раздел Статистика.

    Окно Свойства слоя, вкладка Источник

    В окне перечислена важная статистическая информация о слое, в том числе среднее.

  3. Скопируйте значение Среднего в буфер обмена. Закройте окно Свойства слоя.
  4. Вернитесь на панель Задачи.

    Следующим шагом задача откроет инструмент Калькулятор растра.

  5. В окне Выражение алгебры карт соберите следующее выражение:

    0.1 * ("Stowe_slope_area_term" / [Mean slope-area term])

    Где [Mean slope-area term] – это значение, которое вы скопировали из окна Свойства слоя.

  6. Для Выходного растра убедитесь, что выбрана база геоданных Stowe_Hydrology, и измените выходное имя на Stowe_velocity_unlimited.

    Параметры инструмента Калькулятор растра

  7. Щелкните Запустить.

    Инструмент запустится, и слой добавится на карту. Новый слой выглядит так же, как и слой коэффициентов уклон-площадь, так как был вычислен путем умножения ячеек этого слоя на фиксированное значение.

  8. Если надо, на панели Содержание разверните символы для слоев Stowe_slope_area_term и Stowe_velocity_unlimited.

    Символы двух слоев

    Судя по значениям символов, эти слои отличаются, хоть и выглядят одинаково. (Ваши числа могут незначительно отличаться от примера изображения.)

Ограничение скоростей

Только что созданный растровый слой – это слой скоростей, но в нем присутствуют далекие от реальности высокие и низкие значения скорости. Например, в некоторых ячейках скорость 0 метров в секунду, что маловероятно во время сильного ливня. Но и значение 7,5 метров в секунду тоже маловероятно даже во время наводнения. Вы ограничите значения скоростей от 0,02 до 2 метров в секунду.

  1. Вернитесь на панель Задачи.

    Следующий шаг задачи использует инструмент Условие, выполняющий сравнение значений ячеек растра с указанным вами выражением. Давайте сначала установим нижнюю границу значений скорости.

  2. В опции Входной растр, удовлетворяющий условиям, выберите Stowe_velocity_unlimited.
  3. В опции Выражение щёлкните Новое выражение. Создайте условие Где VALUE больше или равно 0.02.

    Инструмент Условие с нижним ограничением

    Теперь надо добавить значение, которое будет использоваться для всех ячеек, удовлетворяющих условию. Так как вы хотите оставить без изменения все значения, если они больше или равны 0.02, вы выберете тот же растровый слой, который был входным.

  4. В опции Входной растр значения «истина» или константа, выберите Stowe_velocity_unlimited.

    Если условие для ячейки не соблюдается (то есть значение в ячейке меньше 0.02), вы измените значение ячейки на 0.02.

  5. Для опции Входной растр значения "ложь" или константа введите 0.02.
  6. Для Выходного растра убедитесь, что выбрана база геоданных Stowe_Hydrology, и измените выходное имя на Stowe_velocity_lower_limited.

    Параметры инструмента Условие с нижним ограничением скорости

  7. Щелкните Запустить.

    Инструмент запустится, и новый слой добавится на карту. Новый слой всего лишь промежуточный, так как вам еще надо добавить верхнюю границу. Последним шагом задача откроет инструмент Условие.

  8. В опции Входной растр, удовлетворяющий условиям, выберите Stowe_velocity_lower_limited.
  9. Для Выражения добавьте условие Где VALUE меньше или равно 2.
  10. В опции Входной растр значения "истина" или константа, выберите Stowe_velocity_lower_limited. Для опции Входной растр значения "ложь" или константа введите 2.
  11. Для Выходного растра убедитесь, что выбрана база геоданных Stowe_Hydrology, и измените выходное имя на Stowe_velocity.

    Параметры инструмента Условие с верхним ограничением скорости

  12. Щелкните Готово.

    Инструмент запустится, и растровый слой поля скоростей добавится на карту.

    Слой Stowe_velocity

    В этом слое темные цвета представляют медленные скорости, а светлые – быстрые. Вода быстрее всего течет по водотокам, где собирается самое большое количество воды. Область вокруг города Стоув – не исключение, а это значит, что вода быстрее всего будет течь ближе к точке устья ниже по течению от города.

  13. На панели Содержание отключите следующие слои:
    • Stowe_flow_accumulation
    • Stowe_watershed
    • Stowe_slope
    • Stowe_slope_area_term
    • Stowe_velocity_unlimited
    • Stowe_velocity_lower_limited
  14. Сохраните проект.

На этом уроке вы получили пространственную переменную, поле скоростей, не зависящее от времени и объема стока, используя в качестве основы растровые слои суммарного стока и уклонов. Вы использовали одну из многочисленных формул, которые позволяют вычислить поле скоростей. Теперь вы знаете, насколько быстро вода протекает через город Стоув в случае возможного ливня, и это позволит вычислить время достижения водой точки устья.


Создание карты изохрон

Ранее вы использовали слои суммарного стока и водосбора, чтобы создать поле скоростей, прогнозирующее насколько быстро вода протечет через город Стоув (шт. Вермонт, США). Поле со скоростями показало, что вода будет быстрее всего течь вдоль проходящих через город водотоков, но вы все еще не можете построить линейный гидрограф, так как не знаете, за какое время вода дотечет до точки устья. Теперь вы создадите карту изохрон, показывающую время, которое потребуется для того, чтобы достичь определенного местоположения откуда-либо еще с этой территории. Чтобы создать карту изохрон, сначала надо построить сетку весов. Затем, получив доступ к времени пути воды до точки устья, вы можете его переклассифицировать в зоны изохрон.

Создание сетки весов

Время в пути вычисляется довольно простым уравнением: длину пути водяной капли надо поделить на скорость, с которой она будет течь. Благодаря полю скоростей, вы уже знаете как быстро будет течь вода, но вы не знаете длину пути. Чтобы определить длину пути водяной капли, потребуются две переменные: направление стока (которое вы знаете) и вес (который не знаете). Вес применительно к потоку представляет собой импеданс. Например, вода протекает через лесистый район гораздо медленнее, чем по голым камням, потому что ее тормозит поверхность. Хотя вычисление веса может показаться трудным без подробных данных о местности, вы можете получить уравнение для вычисления на основе следующих двух уравнений:

Flow time [T] = Flow Length [L] / Velocity [LT-1]    (1)

Flow time [T] = Flow Length [L] * Weight [L-1T]    (2)

Скомбинировав эти два уравнения, вы получаете следующее:

Weight [L-1T] = 1 / Velocity [LT-1]    (3)

Таким образом, вы можете определить вес на основании слоя поля скоростей. Затем вы будете использовать слой сетки весов вместе со слоем направлений стока, чтобы определить длину и время пути дождевой капли.

  1. Если надо, откройте проект Stowe_Hydrology в ArcGIS Pro и в нем задачу Create unit hydrograph at outlet.
  2. На панели Задачи дважды щелкните задачу Create an isochrone map.

    Задача Create an isochrone map

    Задача состоит из четырех шагов. Первый шаг открывает инструмент Калькулятор растра. Вам надо ввести уравнение весов, чтобы создать сетку весов для водосборной области Стоув.

  3. В окне Выражение алгебры карт соберите (скопируйте и вставьте) следующее выражение:

    1 / "Stowe_velocity"

  4. Для Выходного растра убедитесь, что выбрана база геоданных Stowe_Hydrology, и измените выходное имя на Stowe_weight.

    Параметры инструмента Калькулятор растра

  5. Щелкните Запустить.

    Инструмент запустится, и растровый слой сетки весов добавится на карту.

    Слой Stowe_weight

    Хотя сам по себе этот слой показывает не очень много, его можно использовать в связке с созданным ранее слоем направлений стока, чтобы определить время стекания.

  6. На панели Содержание включите слой Stowe_fill_flow_direction.

    Слой направлений стока вы создавали еще до того, как построили водосборную область Стоув, поэтому экстент данного слоя охватывает значительно большую территорию, чем область интереса. Надо извлечь новую версию слоя направлений стока, охватывающую лишь водосборный бассейн.

  7. Вернитесь на панель Задачи.

    Следующий шаг задачи использует инструмент Извлечь по маске, который вырезает растровый слой по определенному экстенту, основанному на экстенте другого слоя.

  8. В качестве Входного растра выберите Stowe_fill_flow_direction. В опции Входные векторные или растровые данные маски выберите Stowe_watershed.
  9. Для Выходного растра убедитесь, что выбрана база геоданных Stowe_Hydrology, и измените выходное имя на Stowe_watershed_flow_direction.

    Параметры инструмента Извлечь по маске

  10. Щелкните Запустить.

    Инструмент запустится, растровый слой направлений стока добавится на карту.

    Слой Stowe_watershed_flow_direction

    Теперь вы извлекли слой направлений стока, а старый слой на карте уже не нужен.

  11. На панели Содержание выключите слой Stowe_fill_flow_direction. Затем вернитесь на панель Задачи.

Время достижения потоком точки устья

Наконец-то у вас есть все слои, которые нужны для определения времени стекания. Следующим шагом задача откроет инструмент Длина линии стока. Обычно этот инструмент просто вычисляет длину линии стока, но там есть и дополнительный параметр, позволяющий учитывать растр весов. Если задействовать этот параметр, инструмент будет вычислять время стекания.

  1. В качестве Входного растра направления стока выберите Stowe_watershed_flow_direction.
  2. Для Выходного растра убедитесь, что выбрана база геоданных Stowe_Hydrology, и измените выходное имя на Stowe_time.
  3. В опции Направление измерений убедитесь, что выбрано Вниз по течению.
  4. В опции Входной растр весов, выберите Stowe_weight.

    Параметры инструмента Длина линии стока

  5. Щелкните Запустить.

    Инструмент запустится, растровый слой времени стекания добавится на карту.

    Слой Stowe_time

    Каждая ячейка данного растра содержит значение, представляющее время в секундах, которое потребуется выпавшей в данной ячейке капле воды, чтобы дотечь до точки устья. Более темными цветами показано меньшее время. Быстрее всего вода дотечет из низинных областей, находящихся недалеко от точки устья, а вода с западных гор будет течь дольше всего.

  6. Если надо, на панели Содержание разверните символы слоя Stowe_time.

    Символы слоя Stowe_time

    Время варьируется от 0 секунд (для дождя, выпавшего в самой точке устья) до приблизительно 47000 секунд – это больше 13 часов!

Переклассификация времени стекания в изохронные зоны

Ваш растр времени стекания содержит огромное количество уникальных значений, что сильно осложняет дальнейший анализ. Для облегчения задачи, вы переклассифицируете слой времени стекания в изохронные зоны.

Изохроны – это контурные линии, проходящие через точки с одинаковым временем пути до точки устья водосборного бассейна. Вы построите изохроны с временными интервалами 1800 секунд (или 30 минут). Для более обширных территорий изохроны могут использовать переменные интервалы, но для водосборной области Стоува вполне годятся и такие. В этом случае всем ячейкам из первой изохронной зоны потребуется 1800 секунд для достижения точки устья, из второй – 3600 секунд и т.д. Позже вы используете эти временные интервалы но оси ординат своего удельного гидрографа.

Следующим шагом задача откроет инструмент Переклассификация. Вы будете использовать этот инструмент, чтобы переклассифицировать время стекания воды, попадающее в определенные диапазоны значений (например, от 0 до 1800 или от 1800 до 3600) вплоть до верхней границы диапазона. Таким образом, значение 907 будет переклассифицировано в 1800, а значение 2145 – в 3600.

  1. Вернитесь на панель Задачи. В качестве Входного растра выберите Stowe_time.

    Далее надо ввести значения переклассификации. Время в растровом слое времени стекания варьируется от 0 до 47000 секунд, и вам надо предоставить интервалы переклассификации, охватывающие все эти значения. Вводить все эти значения вручную не очень интересно. Для целей нашего урока у вас уже есть скачанная таблица, в которой есть все необходимые интервалы для водосборной области Стоув. Эта таблица была включена в проект, который вы скачали ранее.

  2. В опции Переклассификация под пустой таблицей щелкните кнопку Загрузить перекодировку из таблицы (значок в виде папки с файлами).
  3. В окне Загрузить перекодировку перейдите к папке Stowe_Hydrology (щелкните Проект, откройте Папки, и откройте Stowe_Hydrology). Дважды щелкните Stowe_isochrones.txt, чтобы выбрать.
    Примечание:

    Если появится окно, предлагающее перезаписать, выберите Да.

    Значения переклассификации из таблицы автоматически загрузятся в инструмент. Получилось всего 27 изохрон.

  4. Для Выходного растра убедитесь, что выбрана база геоданных Stowe_Hydrology, и измените выходное имя на Stowe_isochrones.

    Параметры инструмента Переклассификация

    Загруженная таблица переклассифицирует значения из всего слоя, поэтому не надо отмечать последнюю опцию Заменить недостающие значения на NoData.

  5. Щелкните Готово.

    Инструмент запустится, и слой с изохронами добавится на карту.

    Слой Stowe_isochrones

    Символы слоя по умолчанию не очень понятные, так как 27 изохрон, загруженных из таблицы, отображены всего девятью цветами. Вы измените символы на непрерывную цветовую шкалу, в которой все 27 изохрон будут показаны своим цветом.

  6. На панели Содержание щелкните правой кнопкой Stowe_isochrones и выберите Символы.

    Появится панель Символы. Вы отобразите изохроны уникальными символами из цветовой схемы от черного к белому.

  7. Для Основных символов выберите Уникальные значения. В опции Цветовая схема выберите схему Черный - белый.

    Параметры панели символов

    Символы слоя на карте автоматически обновляются.

    Слой Stowe_isochrones с новыми символами

    С такими символами гораздо проще увидеть отдельные изохроны.

    Подсказка:

    Классификация с уникальными значениями занимает на панели Содержание очень много места. Можете свернуть условные обозначения этого и всех остальных слоев, чтобы на панели было видно как можно больше слоев.

  8. Закройте панель Символы.

    Теперь вы откроете таблицу атрибутов слоя, чтобы увидеть, сколько ячеек попало в каждую изохрону, и выбрать определенные изохроны для более детального изучения.

  9. Щелкните в панели Содержания правой кнопкой на слое Stowe_isochrones и выберите Таблица атрибутов.

    Появится таблица. В ней показаны значение и количество ячеек для каждой изохроны.

  10. Если надо, переместите или измените размеры таблицы атрибутов, чтобы на карте был виден весь слой Stowe_isochrones.
  11. Щелкните окошко слева от первой строки таблицы атрибутов.

    Первая строка таблицы атрибутов

    Строка в таблице выделится. Соответствующая изохрона выберется на карте.

    Выбрана первая изохрона

    Как и ожидалось, первая изохрона охватывает пойму реки возле точки устья. Судя по значениям в таблице, в первую изохрону попало лишь 700 ячеек, представляющих время до точки устья не более 1800 секунд (30 минут). В других изохронах ячеек гораздо больше, то есть через несколько часов в точку устья попадет гораздо больше воды, чем когда ливень только начался.

  12. Выберите какие-нибудь другие строки в таблице атрибутов. Например, выберите какие-нибудь изохроны с самым большим количеством ячеек.

    Большие изохроны часто включают ячейки со всей водосборной области, вода из которых окажется в точке устья практически одновременно.

  13. Когда закончите исследовать карту изохрон, закройте таблицу атрибутов. На вкладке Карта в группе Выборка щелкните кнопку Очистить.

    Кнопка Очистить

    Все сделанные выборки будут сброшены.

  14. На панели Содержание отключите следующие слои:
    • Stowe_velocity
    • Stowe_weight
    • Stowe_watershed_flow_direction
    • Stowe_time
  15. Сохраните проект.

Вы использовали растровый слой с полем скоростей для создания сетки весов. Эта сетка весов представляла импеданс для стекания вниз по течению и помогла создать растровый слой времени стекания. Также вы переклассифицировали времена стекания на 27 изохрон через равный интервал времени по 1800 секунд. Далее вы конвертируете карту изохрон в таблицу. Эту таблицу вы используете для создания отношения времени и количество воды, которое будет попадать со всего водосборного бассейна в точку устья после сильного ливня через каждые 1800 секунд. И в итоге вы построите на основании этого отношения график – удельный гидрограф.


Создание удельного гидрографа

На предыдущем уроке была создана карта изохрон водосборного бассейна. На этом уроке вы конвертируете карту изохрон в таблицу, которая будет показывать взаимосвязь времени и территории, с которой вода попадает в точку устья. Затем на основании этой таблицы вы создадите удельный гидрограф, показывающий интервалы времени, когда в точке устья окажется больше всего воды, что позволит лучше прогнозировать будущие ливни и их последствия.

Подготовка таблицы удельного гидрографа

Чтобы создать удельный гидрограф, сначала надо получить отдельную таблицу на основании таблицы атрибутов карты изохрон. В данный момент в таблице атрибутов подсчитано количество ячеек или площадь каждой изохроны, так что вам надо конвертировать эту площадь в метрические единицы измерения.

  1. Если надо, откройте свой проект Stowe_Hydrology в ArcGIS Pro и в нем задачу Create unit hydrograph at outlet.
  2. На панели Задачи дважды щелкните задачу Create a unit hydrograph.

    Задача Create a unit hydrograph

    Задача состоит из пяти шагов. Первый шаг открывает инструмент Таблица в таблицу, который конвертирует таблицы (в том числе атрибутивные) в отдельную таблицу, хранящуюся в базе геоданных.

  3. В качестве Входной таблицы выберите Stowe_isochrones.
  4. В опции Выходное местоположение убедитесь, что установлена база геоданных Stowe_Hydrology. Для Выходного имени введите Stowe_isochrones_table.

    Параметры инструмента Таблица в таблицу

    В остальных параметрах можно указать выражение, извлекающее поднабор строк входной таблицы. Когда на прошлом уроке вы просматривали таблицу атрибутов слоя, все записи были значимыми, поэтому эти параметры менять не надо.

  5. Щелкните Запустить.

    Инструмент запустится, и новая таблица добавится на панель Содержание. Теперь эта таблица полностью совпадает с таблицей атрибутов слоя Stowe_isochrones. Хотя в этой таблице имеются все поля, необходимые для построения удельного гидрографа (время и площадь, с которой вода собирается за это время), область водосбора подсчитана в ячейках, а не в метрических единицах. Следующим шагом задача открывает инструмент Добавить поле, который добавит новое поле, которое вы будете использовать для вычисления площади в квадратных метрах.

  6. В качестве Входной таблицы выберите Stowe_isochrones_table.
  7. В опции Имя поля введите Area_meters. В качестве Типа поля выберите Двойная точность.

    Поле типа Двойная точность может хранить значения с большим количеством десятичных знаков. С таким форматом значения площадей получатся более точными. Следующие два параметра, Разрядность поля и Точность поля, позволяют ограничить количество знаков до и после запятой; оставьте их пустыми.

  8. В опции Псевдоним поля введите Area (Sq. Meters).

    Параметры инструмента Добавить поле

    Остальные параметры предоставляют дополнительные опции для полей. Вам надо просто посчитать площади, поэтому эти параметры не имеют значения и их можно не менять.

  9. Щелкните Запустить.

    Инструмент запустится, и новое поле добавится на карту. Вы добавите таблицу, чтобы посмотреть и проверить это поле.

  10. На панели Содержание щелкните правой кнопкой Stowe_isochrones_table (таблица находится внизу подо всеми слоями) и выберите Открыть.

    Появится таблица.

    Таблица изохрон по умолчанию

    Поле добавилось корректно, с указанным псевдонимом. Однако сейчас это поле не содержит значений.

  11. Закройте таблицу. Вернитесь на панель Задачи.

    Следующим шагом задача откроет инструмент Вычислить поле. Вы будете использовать это поле для вычисления площадей изохрон, в квадратных метрах. Когда вы только начали работать над этим проектом, в пособии было написано, что у исходного слоя Stowe_DEM размер ячеек 30 метров, то есть площадь одной ячейки равна 30 на 30 метров. Так как все производные слои в той или иной степени основывались на исходном слое DEM, у них такой же размер ячеек. Это значит, что можно получить площадь, просто умножив поле Count (количество ячеек в изохроне) из таблицы на размеры одной ячейки.

  12. В качестве Входной таблицы выберите Stowe_isochrones_table. В опции Имя поля выберите Area (Sq. Meters) и убедитесь, что Тип выражения установлен на Python 3.
  13. В Выражение постройте выражение !Count! * 30 * 30.

    Параметры инструмента Вычислить поле

  14. Щелкните Запустить.

    Инструмент запустится, и поле будет подсчитано. Можете проверить, правильно ли были подсчитаны значения в таблице. Следующим шагом задача снова откроет инструмент Добавить поле. Вам надо добавить в таблицу атрибутов еще одно поле, хотя и основанное на уже имеющихся в таблице полях. Это поле будет содержать ординаты линейного гидрографа, показывающего объем стока в секунду в точке устья.

    Если вы создавали гидрограф, показывающий время по одной оси и площадь поверхности стока по другой, по нему можно лишь понять сколько воды достигает точки устья за период 1800 секунд (или 30 минут). Этот интервал был полезен для группировки огромного количества уникальных значений исходного слоя времени стекания в более управляемые 27 уникальных значений. Однако в гипотетической чрезвычайной ситуации 30 минут могут означать разницу между жизнью и смертью. Городским властям Стоува нужны для планирования более точные временные рамки. Ваше новое поле будет оценивать количество воды, достигающее точки устья каждую секунду.

    Ордината удельного гидрографа, Ui, во время iΔt, где i = 1,2,….n, дается по наклонной площадной диаграмме накопления во времени через интервал [(i - 1)Δt,iΔt]. Это делается при помощи следующего уравнения:

    Ui = U(it) = (A(it) - A[(i - 1)∆t]) / ∆t    (1)
    • , где:
      • A(t) – это общая площадь, с которой вода собирается в точку устья за время t с момента начала ливня.

    Уравнение (1) можно переписать следующим образом:

    Ui = Ai / ∆t    (2)

    • , где:
      • Ai – это площадь инкрементного дренажа для i-той зоны изохроны.
  15. Установите инструменту такие же параметры, как во втором шаге задачи, но назовите поле UH_ordinate и дайте ему псевдоним Unit Hydrograph Ordinate.

    Параметры инструмента Добавить поле

  16. Щелкните Запустить.

    Инструмент запустится, и поле добавится в таблицу. Как и в прошлый раз, вам надо вычислить поле. Следующим шагом задача снова откроет инструмент Вычислить поле. Вам надо будет поделить площадь дренажа на временной интервал, чтобы вычислить площадь в секунду.

  17. В качестве Входной таблицы выберите Stowe_isochrones_table. В опции Имя поля выберите Unit Hydrograph Ordinate.
  18. В Выражение постройте выражение !Area_meters! / 1800.

    Параметры инструмента Вычислить поле

  19. Щелкните Готово.

    Инструмент запустится, и поле будет подсчитано.

  20. Откройте таблицу атрибутов и проверьте результаты вычисления. Когда закончите, закройте таблицу.

Построение удельного гидрографа

В ArcGIS Pro вы можете построить диаграмму на основании любой самостоятельной таблицы. Вы будете использовать эту функциональность для того, чтобы построить удельный гидрограф на основании поля ординат вашей таблицы.

  1. На панели Содержание щелкните Stowe_isochrones_table, чтобы выделить.

    При выделении таблицы на ленте вызывается контекстная вкладка. На этой вкладке имеются опции, применимые к таблицам.

  2. Щелкните на ленте вкладку Данные. В группе Визуализация щелкните Построить диаграмму и выберите Диаграмма-график.

    Опция Диаграмма-график

    Появится панель Свойства диаграммы и откроется окно Stowe_isochrones_table - График 1.

  3. На панели Свойства диаграммы на вкладке Данные в опции Дата и число выберите Value.

    Как только вы выберете этот параметр, окно сразу же обновится, и в нем появится пример графика. Поле Value – это ось Х, а поле COUNT автоматически заполнится как ось У. Вам надо, чтобы в графике был показан удельный гидрограф, а не количество ячеек.

  4. На панели Свойства диаграммы в опции Агрегирование выберите <нет>.

    Переменные удельного гидрографа

  5. Для Числовые поля отметьте опцию Ордината удельного гидрографа и щелкните Применить.

    Поля удельного гидрографа

    Далее вы измените название диаграммы и подписи по осям, чтобы они объясняли, что на нем показано.

  6. На панели Свойства диаграммы перейдите на вкладку Общие.
  7. В опции Заголовок диаграммы введите Unit Hydrograph at outlet point.
  8. В опции Заголовок по оси X введите Time (seconds). В опции Заголовок по оси Y введите Discharge at outlet per unit of excess rainfall (sq. meters per second).

    Заголовки в окне диаграммы обновятся автоматически. Удельный гидрограф для точки устья готов.

    Удельный гидрограф

    Примечание:

    Приращения, показанные на осях вашего гидрографа, а также размер блока гидрографа зависят от размеров окна.

  9. Сохраните проект.

Вы превратили изохронные зоны в таблицу. Также вы добавили поля в таблицу, чтобы рассчитать площадь водосбора для каждого изохрона в квадратных метрах и определить ординату удельного гидрографа. Наконец, вы использовали полученную таблицу для создания удельного гидрографа, который показывает, когда во время прогнозируемого ливня через точку устья проходит пик воды. В конечном итоге ваши результаты помогут администрации города Стоув планировать и более эффективно реагировать на наводнения.

Еще больше уроков вы найдете в Галерее уроков Learn ArcGIS.