Настройка сервера изображений

Растровая аналитика в ArcGIS Enterprise позволяет использовать распределенную обработку для выполнения анализа над большими совокупностями изображений и растров гораздо быстрее, чем это возможно в отдельной ГИС-среде. Вы также можете запускать сложные многоступенчатые растровые модели быстро, с возможностью публиковать и выкладывать в общий доступ непосредственно для своего предприятия. Для выполнения анализа растров сначала надо настроить ArcGIS Image Server у себя в ArcGIS Enterprise.

Для выполнения этого урока необходимо следующее:

  • Для анализа растров нужны две лицензии: ArcGIS Enterprise и ArcGIS Image Server.
  • Вы должны как минимум настроить базовое развертывание ArcGIS Enterprise . Для получения справки по настройке базового развертывания см. Начало работы с ArcGIS Enterprise Builder.
  • У вас также должен быть хотя бы один дополнительный сервер сайта. Если у вас не установлен и не настроен дополнительный сервер сайта, см. Установка ArcGIS Server на одном компьютере.
  • Дополнительный сервер должен быть лицензирован с ArcGIS Image Server. Для справки см.Авторизация ArcGIS Server.

Если у вас есть права администратора, вы можете начать урок прямо сейчас. Если нет, вам потребуется, чтобы ваш администратор ArcGIS Enterprise выполнил этот первый урок, чтобы настроить сервер изображений, прежде чем вы сможете начать второй урок.

Регистрация новых хранилищ данных

Сервисы анализа растров хранят результирующие растры в зарегистрированном хранилище данных. Они могут быть либо файловыми, либо облачными хранилищами. Для этого урока вы зарегистрируете два новых хранилища данных у себя на многопользовательском компьютере: растровое и файловое хранилища с учебными данными.

Примечание:

Если вы используете облачные хранилища, см. документацию по использованию облачного хранилища в качестве хранилища растровых данных.

  1. Создайте две папки на диске C многопользовательского компьютера с названиями RasterStore и LandslideData.

    Далее вы убедитесь, что эти папки являются общими и доступны для всех сайтов сервера.

    Примечание:

    ArcGIS Server Manager должен работать по протоколу HTTPS при регистрации и редактировании пути к растровому хранилищу данных.

  2. Скачайте файл LandslideData.zip и распакуйте его в папку LandslideData.

    31 файл должен находиться в корневой папке C:\LandslideData, а не внутри подпапки.

  3. На диске C щелкните правой кнопкой LandslideData и выберите Свойства.
  4. В окне Свойства LandslideDataперейдите на вкладку Общий доступ и щелкните Расширенный общий доступ.
  5. Отметьте Общий доступ к этой папке и щелкните Применить.
  6. Нажмите Права доступа.

    Если вы настроили сервер изображений, чтобы позволить другому участнику вашей организации завершить урок, вам необходимо убедиться, что этот человек имеет полный доступ к папке.

  7. В списке Группы или пользователи выберите учетную запись пользователя. При необходимости, щелкните Добавить для поиска и добавления учетной записи, прежде чем выбрать ее.
  8. В окне Права доступа отметьте Разрешить для Полного контроля.
  9. Щелкните Применить и щелкните OK в окне Права доступа.
  10. Щелкните Применить и щелкните OK в окне Расширенный общий доступ.

    Запомните сетевой путь к этой папке, он вам понадобится при регистрации данных.

  11. Закройте окно Свойства LandslideData
  12. Повторите шаги с 3 по 11 в папке RasterStore.
    Примечание:

    Если у вас нет доступа к папкам со всех сайтов сервера, вы можете скопировать папки с учебными данными на каждую из серверных машин, только убедитесь, что файлообменник содержит данные, зарегистрированные на каждом сайте сервера при помощи ArcGIS Server Manager. См. документацию с более подробной информацией о регистрации папок на нескольких сайтах ArcGIS Server.

  13. Откройте ArcGIS Server Manager для многопользовательской машины из-под учетной записи администратора.

    Примечание:

    Вы увидите всплывающее окно с предложением открыть ArcGIS Server Manager в приложении или браузере, вы должны сперва установить на компьютере браузер по умолчанию.

    Подсказка:

    Чтобы оптимизировать скорость работы анализа растров в вашей системе, вам надо установить количество экземпляров сервера соответственно количеству ядер. В ArcGIS Server Manager щелкните Сервисы > Система > Обработка растров. В опции Pooling установите Максимальное количество экземпляров на машину по числу доступных у вас ядер.

  14. Щелкните вкладку Сайты и выберите Хранилища данных.

    Хранилища данных

  15. В раскрывающемся списке Зарегистрировать выберите Хранилище растров.

    Зарегистрировать хранилище растров

  16. Для Имя введите RasterStore.

    Это уникальное имя для зарегистрированного местоположения, которое может содержать только буквенно-цифровые символы и подчеркивания.

  17. Если необходимо, для Тип выберите Хранилище файлов.
  18. Возле Путь укажите полный путь к хранилищу растровых файлов, по образцу \\gisserver\RasterStore. Замените gisserver на имя сервера на вашем многопользовательском компьютере.

    Не указывайте локальные пути, такие как C:\RasterStore, если это не одна и та же папка с данными, доступная со всех узлов сайта сервера.

  19. Щелкните Создать.

    Регистрировать хранилище данных

    Зарегистрированное вами хранилище растровых данных теперь отображается в списке зарегистрированных хранилищ данных. Далее надо зарегистрировать местоположение, в котором сохранены данные урока.

  20. В меню Регистрировать выберите Папку.
  21. Для Имя введите LandslideData.
  22. В опции Путь публикации папки введите имя папки \LandslideData и в опции Имя хоста папки публикации введите имя сервера, обозначенное при создании сетевого пути.
    Зарегистрировать папку

    Вместе эти опции Путь публикации папки и Имя хоста папки публикации составляют полный путь к папке; не забудьте расставить косые слеши в нужных местах. Как и ранее, не используйте локальные пути C:\LandslideData, если это не одна и та же папка с данными, доступная со всех узлов сайта сервера.

  23. Щелкните Создание.

    Папка с учебными данными теперь отображается в списке зарегистрированных хранилищ данных.

  24. Получите доступ к вашему компьютеру ArcGIS Image Server и повторите шаги с 1 по 12, чтобы создать две папки на диске C и поделиться ими.
  25. При необходимости выполните тот же процесс, чтобы поделиться папкой arcgisserver со Всеми.
  26. Откройте ArcGIS Server Manager для вашего компьютера с сервером изображений, используя учетную запись администратора.
    Подсказка:

    Ваш ArcGIS Server Manager можно найти по https://gisserver.domain.com:6443/arcgis/manager.

    Если этот сайт имеет настройки ArcGIS Web Adaptor (IIS), ArcGIS Server Manager можно найти здесь: http://gisserver.domain.com/webadaptorname/manager

    Имя webadaptorname чаще всего определяется как сервер.

  27. Повторите шаги с 15 по 24, заменив gisserver именем вашего сервера изображений.

Интеграция сайта ArcGIS Server

Сайт ArcGIS Server, лицензированный как сервер изображений, должен быть интегрирован с порталом, чтобы завершить настройку. Как только интегрированный сервер становится виден на портале, вы можете назначить его в качестве хост-сервера, сервера анализа растров или другого типа сервера.

  1. Войдите на портал ArcGIS Enterprise как администратор.
    Примечание:

    Ваш портал ArcGIS Enterprise можно найти по адресу https://webadaptorhost.domain.com/webadaptorname/home

  2. Щелкните вкладку Организация. Щелкните вкладку Настройки и щелкните Серверы.
  3. Под опцией Интегрированные серверы щелкните Добавить сервер.

    Добавить

  4. В опции URL сервисов введите URL своего сервера изображений.

    Это должен быть полный URL-адрес домена, используемый внешними пользователями при доступе к сайту ArcGIS Server .

    Подсказка:

    Если сайт имеет настройку ArcGIS Web Adaptor (IIS), URL вместо этого будет отформатирован как http://gisserver.domain.com/webadaptorname

    В противном случае URL будет отформатирован как https://gisserver.domain.com:6443/arcgis (это то же самое, что URL, использованный на следующем шаге)

  5. В опции Административный URL, введите URL, использованный для доступа к ArcGIS Server при выполнения операций администрирования во внутренней сети.

    Этот URL будет отформатирован как https://gisserver.domain.com:6443/arcgis.

  6. В опции Имя пользователя введите имя первичной учетной записи администратора сайта, которая используется для первоначального входа в ArcGIS Server Manager и администрирования ArcGIS Server.
  7. В опции Пароль введите пароль учетной записи главного администратора сайта.
  8. Нажмите Добавить.

    Сервер интегрирован, или привязан к вашей учетной записи администратора ArcGIS Enterprise. Теперь вы его настроите как сервер анализа растров.

  9. Прокрутите вниз до Анализа растров и выберите сайт сервера, который только что интегрировали.

    Сервер Анализа растров

    Появляется уведомление о том, что участники организации теперь имеют доступ к возможностям анализа растра.

  10. Щелкните OK и нажмите Сохранить в верхней части страницы.

    Настройки интегрированного сервера сохраняются.

Назначение прав для выполнения анализа растров

Чтобы выполнить растровый анализ, вам нужно создать или отредактировать роль, чтобы иметь соответствующие разрешения. Если оставшаяся часть урока будет завершена вами или кем-либо еще с ролью администратора или издателя, у них уже есть правильные разрешения и они могут перейти к следующему уроку.

Если вы настроили сервер изображений, чтобы позволить другому участнику вашей организации завершить урок, вам нужно будет выполнить следующие шаги, чтобы отредактировать или создать пользовательскую роль для выполнения растрового анализа.

  1. Если надо, войдите на сайт портала в качестве администратора и нажмите Организация. Щелкните Настройки и выберите Роли участника.
  2. Щелкните Создать роль.

    Создать пользовательскую роль

  3. Для имени Роли введите Raster Analyst (Анализ растра). Для Описания введите Роль с правами для выполнения анализа растра.
  4. В разделе Права роли под опцией Общие права убедитесь, что следующие поля отмечены как минимум:

    КатегорияПрава доступа

    Участники

    Просмотр

    Ресурсы

    Создание, обновление и удаление

    Публикация размещённых векторных слоёв

    Публикация серверных слоёв

    Публикация

    Общий доступ для групп

    Общий доступ на портале

    Общий доступ для всех

    Ресурсы и анализ

    Стандартный анализ объектов

    Анализ растра

    Обновление прав для анализа растров

  5. Щелкните Сохранить роль.

    Затем вы назначите роль Raster Analyst своим коллегам, чтобы они могли завершить урок.

  6. В верхней части страницы щелкните Участники.
  7. Найдите участника организации, который должен завершить урок. Под опцией Роль щелкните меню и выберите Raster Analyst.

    Роль Raster Analyst в меню

На этом уроке вы рассмотрели предварительные условия для выполнения растрового анализа в ArcGIS Image Server. Затем вы добавили новое хранилище данных, интегрировали сайт ArcGIS Server и назначили соответствующие права для выполнения анализа растров. Теперь вы можете использовать свой сервер изображений для анализа растров. На следующем уроке вы будете использовать распределённый анализ растров для создания карты риска оползней.


Создание карты риска оползней

Анализ изображений и растровых данных предоставляет ценную информацию для поддержки принятия решений в приложениях для управления чрезвычайными ситуациями. Изображения могут представлять текущую информацию о местоположении и обстановке, а также могут анализироваться вместе с историческими изображениями и другой пространственной информацией. Обработка растровых данных нелегка, поскольку файлы часто большие и сложные. Кроме того, данные из разных организаций и источников часто приходится выкладывать в общий доступ и анализировать в пределах предприятия. Эластичная распределенная обработка Raster Analytics предоставляет эффективный способ публикации и обработки больших объемов растровых данных для поддержки срочных и важных приложений. После оптимизации вы можете сохранить свою цепочку обработки, поделиться ею с участниками организации и выполнить обработку в своем приложении Raster Analytics из ArcGIS Pro или на портале ArcGIS Enterprise в Map Viewer.

На предыдущем уроке вы настраивали ArcGIS Enterprise для распределенного анализа растров. На этом уроке вы создадите карту риска оползней, а затем суммируете риск оползня на основе водосборного бассейна второго порядка. Вы будете использовать цепочки растровых функций, чтобы получить карту степени выгорания, карту топографических уклонов и карту индекса почвенно-растительного покрова. Эти отдельные цепочки обработки будут объединены в одну цепочку для распределенной обработки в вашей системе Растровой аналитики, а затем суммируются по бассейнам второго порядка.

Установка активного портала

Во-первых, вам нужно установить активный портал в ArcGIS Pro. На этом этапе настройки ваша лицензионная информация передается в ArcGIS Pro и позволяет обмениваться обработанными данными с онлайн-порталом ArcGIS Enterprise.

  1. Откройте ArcGIS Pro. В нижней части страницы щелкните Настройки.
  2. Щелкните Порталы.
  3. Если портала нет в списке, щелкните Добавить портал и введите URL своего портала.

    Добавить портал

    После обнаружения портал будет добавлен в список.

  4. Щелкните правой кнопкой мыши портал и выберите Войти.
  5. Введите ваши имя пользователя и пароль и нажмите Войти.
  6. Щёлкните портал правой кнопкой и выберите Задать как Активный портал.

    Возле подключения портала появится зеленая отметка.

  7. Щелкните стрелку назад.
  8. Внизу окна щелкните Выбрать шаблон другого проекта.
  9. Щелкните Обзор и перейдите к C:\LandslideData на своем компьютере с Enterprise. Выберите файл шаблона проекта Landslide_Risk_Project.aptx.
    Подсказка:

    Если вы не можете найти этот файл, вы можете скачать и распаковать LandslideData.zip на свой локальный компьютер.

  10. В окне Создать новый проект назовите свой проект Landslide_Risk и сохраните на своем компьютере.

    Откроется новый проект с картой города Санта-Роза, штат Калифорния.

Создание карты степени выгорания

Различные типы растительности и материалы горят с различной интенсивностью, в зависимости от их состава, плотности, топографии, ветра, влажности почвы и других факторов. Как правило, более высокая интенсивность горения приводят к более высокой репеллентности воды и более сильной возможной эрозии в случае дождя. Интенсивность выгорания можно получить на основании из мультиспектральных изображений с инфракрасным и коротковолновым инфракрасным каналом, например снимков с Landsat 8. Используя функции растра в цепочке обработки, вы будете вычислять коэффициент выгорания на основании изображений Landsat 8, полученных до и после лесных пожаров.

  1. На ленте щёлкните вкладку Вставка. В группе Проект щелкните Добавить папку.

    Добавить подключение к папке

  2. Перейдите в папку LandslideData на диске C вашего компьютера Enterprise. Выберите ее и щелкните OK.
  3. Щёлкните вкладку Вид на ленте. В группе Окна щелкните Панель Каталог.

    Панель Каталог добавится в окно карты.

  4. На панели Каталог, на вкладке Проект, разверните Папки, затем разверните папку LandslideData. Выберите все наборы данных внутри, кроме Basins.tif, и перетащите их на карту.
    Добавление данных на карту

    Теперь данные отображаются на панели Содержание. Сюда входят изображения Landsat 8 до (Before_L8.tif) и после (After_L8.tif) лесных пожаров в октябре 2017 года в округах Напа и Сонома. Также есть два слоя, которые вы будете использовать в качестве входных данных для карты рисков. DEM_10m.tif – это цифровая модель рельефа, показывающая высоты земной поверхности. Sonoma_NLCD2011.tif является частью Национального набора данных National Landcover Dataset, который показывает землепользование и преобладающий тип растительности.

    Чтобы сравнить следы от пожаров на изображениях до и после, вы выберете отображаемые мультиспектральные каналы. Каналы по умолчанию, отображаемые красным, зеленым и синим цветами, видны, если развернуть слой.

  5. Если необходимо, на панели Содержание перетащите слой After_L8.tif в начало списка и перетащите Before_L8.tif чуть ниже него. Выключите другие слои.
  6. При необходимости разверните After_L8.tif. Щёлкните правой кнопкой мыши чип красного цвета и выберите srband5.

    Назначить красный канал

  7. Для зелёного выберите srband4, а для синего – srband3.

    Эта комбинация диапазонов отображает каналы снимков Landsat 8 в инфракрасном режиме. Растительность показана ярко-красным. Не-растительные объекты, такие как незастроенные территории и городские районы, отображаются в разных оттенках серого и синего.

  8. Примените те же каналы к слою Before_L8.tif.
  9. Щёлкните After_L8.tif на панели Содержание, чтобы выбрать его.
  10. На ленте щелкните вкладку Оформление. В группе Эффекты щелкните Спрятать.

    Спрятать курсор

    Указатель отображает стрелку на отображении карты.

  11. Щелкните, двигая курсор через изображение на карте, чтобы сравнить изображения до и после пожара.

    Вы можете прокручивать по вертикали или по горизонтали. Обратите внимание, что многие области, которые являются красными в Before_L8.tif, являются серыми или зелеными в After_L8.tif, что указывает на потерю растительности.

  12. На ленте щелкните вкладку Карта. В группе Навигация щелкните Исследовать.

    Указатель возвращается в нормальное состояние. Теперь, когда все данные находятся на карте, вы будете использовать функции растра для вычисления серьезности выгорания.

  13. На ленте щелкните вкладку Изображения. В группе Анализ щелкните Функции растра.

    Функции растра

    Появится панель Функции растра. На вкладке Системы представлены категории функций, доступных для анализа растров. Для этого урока для вас созданы два шаблона функций растра или RFT. Эти настраиваемые шаблоны функций перечислены на вкладке Проект.

  14. На панели Функции растра перейдите на вкладку Проект.
  15. Щелкните правой кнопкой мыши Landcover_Remap и выберите Переместить в, затем выберите Пользовательский и щелкните Пользовательский1.

    Если переместить эти функции в пользовательскую категорию, любые изменения, внесенные вами в RFT, будут сохранены, если они будут сохранены в редакторе функций растра. Изменения, сделанные в категории Проект, будут потеряны, если проект не будет сохранен.

  16. На вкладке Проект щелкните правой кнопкой Burn_Severity и переместите его к Custom1, как в предыдущем шаге.
  17. На вкладке Пользовательский щелкните правой кнопкой шаблон Burn_Severity и выберите Редактировать.

    Откроется Редактор функций растра с цепочкой обработки.

    Шаблон функции растра Burn Severity

    Арифметические функции каналов превращают пикселы изображений в выражения. Снимки после пожара вычитаются из изображений до пожара и прогоняются через функцию переклассификации. Функция переклассификации распределяет значения пикселов по пяти категориям степени выгорания. Границы между степенями выгорания получены из исследования оценки ландшафта (Key and Benson, 2005). Функция таблицы атрибутов в цепочке обработки присваивает цветовую шкалу карте степени выгорания. Она уже для вас построена.

  18. Закройте Burn Severity RFT на панели Редактор функций.
  19. На панели Функции растра щелкните шаблон Burn_Severity.

    Откроются входные параметры шаблона Burn Severity.

  20. В качестве Pre-Fire Imagery (изображения до пожара) выберите Before_L8.tif, а для Post-Fire Imagery (после пожара) – After_L8.tif.
  21. Убедитесь, что Тип выходного слоя установлен как Растровый слой, и щелкните Создать новый слой.

    Свойства BurnSeverity

    Обработка может занять несколько минут. По завершении полученный слой появится на карте и на панели Содержание. Растровые функции являются временными по своему характеру – расчёты выполняются «на лету» или в режиме реального времени при перемещении карты и не сохраняются автоматически. Степень выгорания вычисляется динамически на отображении при перемещении по слою.

    Результирующий слой степени выгорания

  22. Сохраните проект.

Создание карты индекса уклонов

Карта уклонов очень важна при определении стабильности склонов. Крутизна склонов получена из цифровой модели рельефа (ЦМР). Чем круче склон, тем больше предрасположенность к соскальзыванию, особенно во время дождя, после того как удерживающая почву растительность сгорела. Далее вы создадите и сохраните шаблон функции растра, чтобы рассчитать процентный уклон и использовать его для создания индекса крутизны.

  1. На ленте щелкните вкладку Изображения. В группе Анализ щелкните Редактор функций.

    Панель Редактор функций прикрепляется в нижней части окна карты.

  2. На панели Функции растра щелкните вкладку Система. В нижней части списка разверните группу Поверхность.

    Группа Поверхность

  3. Перетащите функцию Уклон на панель Редактор растров.
  4. На панели Редактор функций на ленте щелкните Добавить переменную растра.

    Добавить переменную растра

    Зелёное окошко с названием Растр добавится на панель Редактор функций.

  5. Убедитесь, что зеленое окошко Растр размещено слева от окошка функций Уклон.

    Окошко Растр задаст входной набор данных для функции Уклон.

  6. Наведите курсор на Растр и посмотрите на появившийся параметр Внешний. Щелкните Внешний и перетащите, чтобы соединить растровый элемент (параметр Внешний) с функцией Уклон (параметр ЦМР).

    Соедините выходной растр

  7. Щелкните правой кнопкой мыши Растр и щелкните Переименовать. Введите Input DEM.
  8. Дважды щелкните функцию Уклон. В окне инструмента Свойства уклона щёлкните Переменные и для ЦМР отметьте поле IsPublic.

    Сделать результат общедоступным

    Опция IsPublic позволяет выставлять входные данные в дальнейшую обработку инструмента.

  9. Щелкните OK.
  10. На панели Функции растра щелкните вкладку Система и найдите Перекодировка.
  11. Перетащите функцию Перекодировка на панель Редактор функций справа от функции Уклон.
  12. Соедините Уклон с Перекодировкой, установив выходной от Уклона на входной от Растра для Перекодировки.

    Соединения функции Перекодировка

    Далее вы установите входные параметры перекодировки на индексы уклонов (в единицах степеней) по пяти категориям.

  13. Дважды щелкните функцию Перекодировка. В окне инструмента Свойства перекодировки щелкните первое окошко под столбцом Минимум и введите 0. Для Максимума введите 5, а для выходных введите 1.
  14. Установите категории со следующими значениями:

    МинимумМаксимумВыходные

    1

    0

    5

    1

    2

    5

    15

    2

    3

    15

    25

    3

    4

    25

    35

    4

    5

    35

    91

    5

  15. Щелкните OK.

    Категории уклонов

  16. Щелкните правой кнопкой мыши функцию Перекодировка и выберите Переименовать. Введите Slope Remap.

    Это поможет различать функции дальше в этом уроке, когда вы соберете в цепочку несколько функций растра.

  17. На панели Функции растра найдите функцию Таблица атрибутов и перетащите ее на панель Редактор функций.
  18. Соедините выходные данные функции Перекодировка с входными функции Таблица атрибутов.
  19. Дважды щелкните функцию Таблица атрибутов и установите Тип таблицы на Вручную.
  20. Под пустой таблицей щёлкните кнопку цветовой шкалы.

    Кнопка Цветовой шкалы

  21. Для Максимального значения выберите 5. Щелкните OK.

    Добавится пять строк со значениями от 1 до 5 и зелено-красной цветовой шкалой по умолчанию.

  22. Щелкните Имя класса для каждой строки и назначьте следующее:

    ЗначениеИмя класса

    1

    Плоский

    2

    Низкий

    3

    Умеренный

    4

    Крутизна

    5

    Very Steep

    Таблица атрибутов уклонов

  23. Щелкните OK.
    Подсказка:

    Используйте кнопку Автокомпоновка после того, как все входные данные и инструменты будут соединены, чтобы автоматически расположить элементы на диаграмме.

  24. В окне Редактор функций щёлкните Сохранить как
  25. В окне Сохранить как для Имя введите Slope_Index.
  26. Убедитесь, что Категория установлена на Пользовательский и Под-категория установлена на Пользовательский 1.
  27. Для Описания введите Шаблон растровой функции для получения уклона из выходной ЦМР.
  28. Щелкните OK.

    Ваш Шаблон растровой функции (Raster Function Template – RFT) теперь отображается в Пользовательской категории на панели Функции растра .

    Подсказка:

    Возможно, вам придется очистить строку поиска, прежде чем вы сможете увидеть новый RFT.

  29. На панели Функции растра дважды щелкните Slope_Index.

    Появляются Свойства SlopeIndex.

  30. В качестве Входного ЦМР выберите DEM_10m.tif..
  31. Убедитесь, что Тип выходного слоя установлен как Растровый слой, и щёлкните Создать новый слой.

    По завершении слой появится на карте и будет указан на панели Содержание под именем Slope_Index_DEM_10m.tif..

    Карта уклона

  32. Закройте Slope_Index RFT на панели Редактор функций и сохраните проект.

Создание карты риска оползней

Расчет риска оползней собирает две только что построенные переменные: степень выгорания и уклоны. Он также включает почвенно-растительный покров, который также важен для оценки риска оползней. Корневая система растений стабилизирует склоны. Пожар может уничтожить большую часть стабилизирующей растительности. Однако некоторые виды растительности, особенно характерные для чапаралей, выработали адаптацию к пожарам, пряча корневую систему глубоко под землей. Почвенно-растительный покров уже проиндексирован на пять категорий, на основании его стабилизирующего воздействия на склоны. Чтобы выполнить расчет риска оползня, вы добавите три шаблона функций растра в цепочку, которая будет обработана в вашем развертывании растровой аналитики.

  1. На ленте на вкладке Изображения щелкните Редактор функций.

    Откроется пустая панель Редактора функций.

  2. На панели Функции растра выберите и перетащите каждый RFT (Burn_Severity, Slope_Index, Landcover_Remap) на панель Редактор функций.

    По умолчанию RFT кластеризуется вместе. Вы захотите их разделить, чтобы можно было легко подключать выходные данные.

  3. Нажмите и удерживайте мышку, чтобы очертить рамку вокруг функций Slope_Index, затем перетащите всю группу под Burn_Severity RFT.
    Подсказка:

    Зеленые окошки ввода означают начало каждой функциональной цепочки.

    Перемещение функций уклона

  4. Перетащите Landcover_Remap ниже Slope_Index.

    Организованные шаблоны функций растра

  5. На панели Функции растра щелкните вкладку Система и найдите функцию Взвешенное наложение. Перетащите ее на панель редактора функций справа от остальных трех RFT.
  6. Подключите три выходных параметра таблицы атрибутов к входному параметру функции Взвешенное наложение.
  7. Щёлкните правой кнопкой мыши каждую функцию Таблицы атрибутов и переименуйте, чтобы они соответствовали соответствующим функциям Перекодировки.

    Их новыми именами должны быть Burn Severity Attribute Table, Slope Attribute Table и Landcover Attribute table.

  8. Нажмите кнопку Автокомпоновка в верхней части панели Редактор функций, чтобы красиво расположить цепочку обработки.

    Инструмент Автокомпоновка

    RFT расположатся компактно.

    Автокомпоновка применена к цепочке функций

  9. Дважды щелкните функцию Взвешенное наложение.

    Появится диалоговое окно Свойства взвешенного наложения. Внутри Таблицы взвешенного наложения вы можете назначать веса в процентах для каждого растра.

  10. В Таблице взвешенного наложения, в ячейке рядом с <Burn Severity Attribute Table.OutputRaster> введите 30. Для слоя Slope Index назначьте значение 55 процентов. Для слоя Landcover Index назначьте значение 15 процентов.

    Процентаж весов, примененный в Таблице взвешенного наложения

    Веса опасности основаны на исследованиях, проведённых Геологической службой США для Национальной программы риска оползней.

    Таблица перекодировки все еще пуста. Поскольку все слои имеют одинаковое количество категорий индексов, вы будете сопоставлять каждую из них один к одному.

  11. В Таблице взвешенных наложений щёлкните слой Burn Severity. В Таблице перекодировки в качестве Значения щёлкните NODATA, чтобы отредактировать поле атрибута, и введите 1. Под Масштабом щелкните NODATA и выберите 1.

    Таблица перекодировки установлена на 1 и 1

  12. В Таблице перекодировки дважды щелкните пустую строку в нижней части столбца Значение и введите 2. Для Масштаба выберите 2.
  13. Повторите предыдущий шаг, чтобы добавить строки с 1 по 5 для всех трех растров в Таблице взвешенного наложения.

    Таблица взвешенного наложения

  14. Щелкните OK.
  15. На панели Функции растра на вкладке Система найдите функцию Таблица атрибутов и перетащите ее в панель Редактор функций справа от функции Взвешенное наложение.
  16. Соедините выходные данные функции Взвешенное наложение с входными функции Таблица атрибутов.
  17. Дважды щелкните новую функцию таблицы атрибутов. В окне Свойства таблицы атрибутов для Типа таблицы выберите Вручную.
  18. Под пустой таблицей щёлкните кнопку цветовой шкалы и установите Максимальное значение на 5. Щелкните OK.

    Пять строк добавляются со значениями от 1 до 5 и по умолчанию от зелёного до красного цвета.

  19. Щелкните Имя класса для каждой строки и назначьте следующее:

    ЗначениеИмя класса

    1

    Низкое

    2

    Среднее

    3

    Высокое

    4

    Очень высокое

    5

    Экстремальное

  20. Нажмите OK и закройте окно Свойства.
  21. В окне Редактор функций щёлкните Сохранить как
  22. В окне Сохранить как в качестве Имени введите Landslide_Risk.
  23. Убедитесь, что Категория установлена на Пользовательский и Под-категория установлена на Пользовательский 1.
  24. Для Описания введите Шаблон функции растра для расчета риска оползня на основе пожароопасности, уклона и растительного покрова.
  25. Щелкните OK и закройте Landslide_Risk RFT на панели Редактор функций.
  26. На панели Функции растра очистите поиск и перейдите на вкладку Пользовательский.
  27. Щелкните слой Landslide_Risk.

    Открываются Свойства слоя Landslide_Risk.

  28. Заполните входные поля следующим образом:

    • Изображение до пожара: Before_L8.tif
    • Изображение после пожара: After_L8.tif
    • Входная ЦМР уклонов: DEM_10m.tif
    • Растр перекодировки почвенно-растительного покрова: Sonoma_NLCD2011.tif

  29. В качестве Выходного тип слоя выберите Слой веб-изображения и щелкните Далее.

    Обработка для свойств веб-слоя

    Примечание:

    Если вы не видите опции для настройки вывода на уровень веб-изображений, обратитесь к администратору, чтобы убедиться, что сервер Raster Analysis установлен и работает.

    Появится диалоговое окно генерирования выходных данных, в котором можно установить свойства создаваемого веб-слоя.

  30. Назовите веб-слой Landslide_Risk и припишите к названию свои инициалы.

    Все ресурсы в вашей организации должны уникально называться, и ваши инициалы позволят сделать так, чтобы ваш слой отличался от аналогичных слоев, которые могут создать другие сотрудники.

  31. В качестве Описания введите This web layer shows a landslide risk estimate for Sonoma County, CA.
  32. В разделе Теги введите Sonoma County, landslide, risk и wildfire. После ввода каждого тега нажимайте клавишу Enter.
  33. В Опции публикации выберите вашу организацию.

    Этот слой будет виден другим сотрудникам в вашей организации.

  34. Щёлкните Запустить.

    Цепочка обработки отправляется на развертывание вашего портала для распределенной обработки. Появится сообщение о том, что процесс был передан на ваш портал.

    Уведомление о Функции растра

  35. Щелкните уведомление Функции растра, чтобы просмотреть состояние запуска RFT. Либо на панели Каталог щелкните вкладку История и щёлкните вкладку Функции растра.

    Вкладка Функции растра на вкладке История панели Каталог

    Вы увидите зеленую галочку рядом с функцией растра, как только процесс будет успешно завершен. Вы будете использовать этот слой позже в программе просмотра веб-карты.

Суммирование риска оползней по бассейнам второго порядка

Хотя карта рисков оползней полезна, вы хотите пойти дальше, чтобы выявить районы, наиболее подверженные опасности. Поскольку риск оползней зависит от особенностей распределения осадков и характеристик водосборных бассейнов, вы суммируете риск по бассейнам в пределах изучаемой территории. Сначала вы опубликуете слой водосборных бассейнов на портале. Затем вы будете использовать карту рисков оползней, подготовленную на предыдущем этапе, чтобы суммировать опасность в пределах каждого бассейна.

  1. На панели Каталог щелкните вкладку Проект и перейдите к подключению к папке LandslideData.
  2. Щелкните правой кнопкой Basins.tif и выберите Опубликовать как веб-слой.

    Опубликовать как веб-слой

    Откроется панель Опубликовать как веб-слой.

  3. Для Имя введите Basins с вашими инициалами.

    Все ресурсы в вашей организации должны уникально называться, и ваши инициалы позволят сделать так, чтобы ваш слой отличался от аналогичных слоев, которые могут создать другие сотрудники.

  4. Для Итоговой информации введите Водосборные бассейны в округах Напа и Сонома, Калифорния.
  5. Для Тегов введите водосборы, бассейн и Калифорния.
  6. Убедитесь, что выбрана опция Ссылаться на зарегистрированные данные.
  7. Для Сервера и папки выберите хост-сервер.
  8. Для Публикации выберите вашу организацию.
  9. Щелкните Анализ, и если нет предупреждений, щелкните Опубликовать.
    Примечание:

    Если отображается предупреждение о том, что источник данных не зарегистрирован, данные будут скопированы на сервер вместо ссылки. Чтобы этого избежать, вы можете щелкнуть правой кнопкой мыши предупреждение и выбрать Зарегистрировать источник данных на сервере перед публикацией.

    Когда веб-слой будет готов, на панели отображается заметка об успешном выполнении операции.

  10. Внизу панели щелкните ссылку Управлять веб-слоем.

    Ваш портал открывается на странице сведений об элементе вашего нового слоя.

  11. Щелкните обзорную кнопку возле слоя Basins и выберите Открыть во вьюере карт.
  12. На ленте щёлкните Добавить и выберите Поиск слоёв.
  13. Подтвердите, что для поиска задано Мои ресурсы.
  14. Найдите слой риска оползней и щелкните кнопку Добавить.

    Добавить слой Landslide_Risk

    На карте отображается слой риска оползней.

    Примечание:

    Если слой риска оползня не загружается на карту, возможно, вам придется подождать несколько минут для завершения обработки и повторить попытку.

  15. На ленте щелкните Анализ и выберите Анализ растров.
  16. В разделе Суммировать данные нажмите инструмент Суммировать растр в пределах.

    Суммировать растр в пределах

  17. В инструменте Суммировать растр внутри заполните следующие свойства:

    • Выбрать площадной слой для суммирования растрового слоя в пределах указанных границ:Basins
    • Выберите поле для определения границ: Value
    • Выберите слой растра для суммирования: Landslide_Risk
    • Выберите статистику для вычисления: Average
    • Игнорировать пропущенные значения при вычислениях: True (отмечено)
    • Имя слоя результата: Risk per Basin, за которым следуют ваши инициалы.
    • Использовать текущий экстент карты False (не отмечено)

  18. Нажмите Запустить анализ.

    Когда анализ завершится, у вас получится карта, показывающая средний риск по водосборным бассейнам.

    Риск по водосборным бассейнам

    Более темные зеленые зоны означают более высокие значения риска оползней. Это основано на риске, который вы рассчитали с использованием шаблона растровой функции со взвешенными входными данными уклонов, степени выгорания и почвенно-растительного покрова.

  19. Щелкните Сохранить, затем Сохранить как и назовите свою карту Landslide Risk per Basin (Sonoma and Napa), дополнив инициалами.
  20. Для Тегов введите landslide, risk и wildfire.
  21. Для Итоговой информации введите Риск оползня для каждого бассейна в округах Сонома и Напа, основанный на пожароопасности, склоне и покрытии земли.
  22. Нажмите Сохранить карту.

На этом уроке вы использовали цепочки растровых функций, чтобы получить карту степени выгорания, карту топографических уклонов и карту индекса почвенно-растительного покрова. Затем вы создали карту риска оползней, опубликовали слои на портале и суммировали риск по водосборным бассейнам второго порядка. На следующем уроке вы сообщите о своих открытиях другим участникам организации по быстрому реагированию на ЧС, создав веб-приложение и опубликовав его в пределах предприятия.


Публикация веб-приложения

На прошлом уроке вы создали карту рисков, для которой просуммировали риски оползней по водосборным бассейнам второго порядка. Теперь вы хотите сообщить результаты остальным сотрудникам вашей организации, в том числе службам быстрого реагирования, работающим как в офисе, так и на местах. Чтобы поделиться результатами, вы создадите веб-приложение на портале ArcGIS Enterprise.

Создание веб-приложения

Результаты уже опубликованы на портале. Теперь следует изменить символы выходных данных, чтобы результаты было легче интерпретировать. Затем вы воспользуетесь ArcGIS Web AppBuilder, чтобы поделиться своими результатами и всей необходимой сопутствующей информацией.

  1. Если необходимо, откройте портал ArcGIS Enterprise в браузере и выполните вход. Перейдите к карте, созданной на предыдущем уроке.

    Вы хотите поделиться только своим слоем Risk per Basin, поэтому далее вы удалите два других слоя с вашей карты.

  2. Удалите слои Basins и Landslide Risk, наведя курсор на каждый из слоев и щелкнув кнопку Другие опции, а затем щелкнув Удалить.
  3. Во вьюере карт наведите курсор на слой Risk per Basin и щелкните кнопку Другие опции.
  4. В меню Другие опции выберите Отображение изображения.

    Отображение изображения

  5. Для Типа растяжки, выберите Процент отсечения. Для Цветовой шкалы, выберите зелено-красную шкалу чисел обусловленности. Оставьте все остальные настройки по умолчанию.

    Шкала чисел обусловленности

  6. Щелкните Применить, затем Закрыть.

    Теперь риск оползней визуально классифицирован от низкого (зеленого) до высокого (красного).

  7. Щелкните кнопку Дополнительные опции и воспользуйтесь командой Прозрачность. Установите регулятор на 50 процентов.

    Поскольку уклон и рельеф играют одинаково важную роль в риске оползня, вы хотите выбрать базовую карту, которая показывает и то и другое.

  8. На ленте нажмите кнопку Базовая карта и выберите Рельеф с надписями.

    Базовая карта Рельеф с надписями

  9. На ленте щелкните Сохранить и выберите Сохранить еще раз.
  10. Щёлкните Общий доступ.

    Вы можете опубликовать карту для всего ArcGIS Enterprise или для определенной группы.

  11. Под Выберите, кто может просматривать эту карту, установите опцию для вашей организации и щелкните Обновить параметры общего доступа.
  12. Щелкните Создать веб-приложение и выберите вкладку Web AppBuilder.
  13. Оставьте Название и Теги как у карты, а в Краткую информацию вставьте A calculation of landslide risk per basin for Sonoma and Napa counties based on slope, landcover, and burn severity.
  14. Щелкните Начало работы.

    Откроется Web AppBuilder.

  15. На вкладке Тема выберите тему с закладками и измените цвет Стиля на синий.

    Установка темы с закладками

  16. Щелкните вкладку Карта. На панели вьюера карт приблизьтесь, чтобы была видна вся карта риска оползней.
  17. В графе Настроить исходный экстент выберите Использовать текущий вид карты.

    Это делается для того, чтобы пользователи при открытии приложения видели полный экстент карты рисков.

  18. Щелкните вкладку Виджет. Наведите курсор на виджет Во весь экран и щелкните кнопку Показать этот виджет .

    Виджет Во весь экран

    Этот виджет позволяет просматривать карту во весь экран. You can add or remove any other widgets the same way.

  19. Внизу панели щелкните Сохранить и Запустить.

    Приложение откроется в новой вкладке.

    Веб-приложение риска оползней

    Ваше веб-приложение теперь доступно для использования на любом устройстве участниками вашей организации. Вы найдете это веб-приложение на портале ArcGIS Enterprise в разделе Содержание, во всех группах, к которым вы предоставили доступ, и в своей галерее. Вы также можете переслать ссылку напрямую кому угодно в своей организации или передать приложение для широкой общественности, изменив для кого опубликован элемент.

На этом занятии вы создали веб-приложение, чтобы опубликовать свою карту рисков оползней. Опубликовав веб-приложение посредством ArcGIS Enterprise,вы сделали так, чтобы все участники вашей организации, в офисе или в поле, могли получить доступ к этой важной информации для принятия решений. Гибкость опций публикации в ArcGIS Enterprise и настроек в Web AppBuilder позволяют вам делиться необходимой информацией с кем хотите.

Теперь ваше развертывание ArcGIS Enterprise настроено для выполнения анализа растров. Используя возможности распределенной обработки анализа растров, вы создали карту риска оползней и суммировали результаты по водосборным бассейнам второго порядка. Шаблоны на вашей карте помогли определить, какие бассейны стали наиболее подвержены опасности оползней после пожаров. Наконец, вы построили и опубликовали веб-приложение, чтобы сообщить результаты всей вашей организации и помочь другим сотрудникам службы реагирования на чрезвычайные ситуации получить важную информацию о риске оползней.