Сравнение комбинаций каналов

Сначала мы будем рассматривать гари на снимках Landsat 8. Ознакомившись с районом исследований, вы измените комбинацию каналов снимка, чтобы гари было лучше видно. Затем создадим пользовательскую комбинацию для выделения гарей.

Открытие проекта

Перед тем, как приступить к анализу, загрузите и откройте пакет проекта, содержащий предварительный набор данных.

  1. Перейдите на страницу описания Montana Fires.

    Montana Fires это пакет проекта Пакет проекта содержит все карты, данные, папки и наборы инструментов проекта.

  2. Щелкните Загрузить. Если будет предложено, загрузите файл в место, которое вы легко запомните, например в папку Документы.

    Кнопка загрузки

    Примечание:

    В зависимости от настроек браузера, вам могло быть предложено выбрать место для сохранения загружаемого файла. Большинство браузеров по умолчанию скачивают все в папку Загрузки, и затем вы можете переместить пакет в выбранное вами место.

    В зависимости от ваших настроек загруженный пакет проекта может открыться самостоятельно в ArcGIS Pro. Либо вы откроете его сейчас.

  3. Запустите ArcGIS Pro. Если будет предложено, войдите под лицензированной учетной записью ArcGIS.
    Примечание:

    Если у вас нет ArcGIS Pro или учетной записи ArcGIS, можно подписаться на бесплатную пробную версию ArcGIS.

    Когда вы открываете ArcGIS Pro, вам предоставляется возможность создать новый проект или открыть существующий. Если вы уже создавали проект, вы увидите список последних проектов.

  4. Щёлкните Открыть другой проект (если вы использовали ArcGIS Pro ранее) или Открыть существующий проект (если нет).

    Открыть другой проект

    Затем необходимо найти загруженный проект.

  5. В окне Открыть проект перейдите к каталогу, в котором сохранили пакет проекта Montana_Fires. Дважды щелкните пакет, чтобы открыть его.

    Откроется проект с двумя слоями на панели Содержание.

    Проект по умолчанию

    Слои 2014.tif и 2015.tif – это слои изображений, которые отключены. Карта центрируется на национальном парке Глейшер в Монтане, занимающем более 1 миллиона акров. World Topographic Map – это базовая карта, используемая для этого проекта.

Улучшение изображения

Теперь, получив данные проекта, подумаем, как можно улучшить изображение. Слои 2014.tif и 2015.tif – это два слоя изображений Landsat 8, вырезанные по области исследования вокруг двух конкретных лесных пожаров с названиями: Thompson Fire и Reynolds Creek Fire. Оба снимка получены в августе месяце, в разные годы.

  1. Включите слой 2014.tif на панели Содержание. Щелкните слой правой кнопкой мыши и выберите Приблизить к слою.

    Приблизить к слою

    Карта приблизится к местоположению изображения.

    Слой 2014.tif

    Снимок очень тёмный, на нём почти ничего не разобрать. Вы настроите яркость, контраст и гамму снимка, чтобы лучше его видеть. Яркость определяет, тёмный снимок или светлый. Контраст – насколько отличаются объекты друг от друга. Гамма определяет отношение между тем, как снимок регистрирует свет и его актуальной светимостью. Увеличение этих показателей улучшит читаемость снимка.

  2. Если необходимо, на панели Содержание щелкните слой 2014.tif, чтобы выделить его.
  3. Щелкните вкладку Оформление на ленте в верхней части приложения. В группе Улучшение передвиньте регуляторы Яркости слоя до 20, Контраста слоя до 25 и Гаммы слоя до 1.8. Нажмите Enter.

    Группа Улучшение

    Изображение немедленно изменится.

    Слой 2014.tif скорректирован.

    Теперь вы можете разглядеть обстановку более подробно. Гористая местность отмечена долинами и озёрами. Некоторые горные хребты покрыты снегом, а иные скрываются в облаках. Так как мы знаем, что снимок сделан в августе, в горах могут быть ледники. Также мы видим довольно густой растительный покров. Тип растительности и горные склоны влияют на лесные пожары, особенно на скорость их распространения. Так территория выглядела в 2014 году, до пожаров Reynolds Creek и Thompson. Теперь надо проверить снимок 2015 года.

  4. На панели Содержание отключите слой 2014.tif. Включите слой 2015.tif.

    Изображения 2015.tif видны.

    Отображение 2015.tif по умолчанию

    Отображение по умолчанию снимка 2015 более чёткое, чем было у 2014, но и здесь желательно подрегулировать яркость, контраст и гамму.

  5. На панели Содержание щелкните слой 2015.tif, чтобы его выбрать.
  6. На вкладке Оформление в группе Улучшение передвиньте регуляторы Яркости слоя до 10, Контраста слоя до 15 и Гаммы слоя до 1.5.

    Отображение 2015.tif скорректировано.

    У снимка 2015 два чётких отличия от снимка 2014 года. Во-первых, большое серое облако покрывает середину южной части снимка. На самом деле, это дым от пожара Thompson, который в то время ещё горел.

    Пожар Thompson

    Во-вторых, левее и выше озера посередине северной части снимка мы видим длинную красноватую полосу. Это гарь от пожара Reynolds Creek, который к этому моменту уже потух.

    Пожар Reynolds Creek

    Хотя мы видим оба пожара, их границы требуют уточнения. Затем вы поэкспериментируете с различными комбинациями каналов изображений, чтобы найти ту, которая лучше всего подчеркивает гари.

Просмотр различных комбинаций каналов

На снимках Landsat захватываются различные сектора электромагнитного спектра, в том числе и невидимые для человеческого глаза. Диапазоны длин волн называются спектральными каналами. Каналы описаны в следующей таблице:

НомерИмяЧто лучше всего видно

1

Побережья и аэрозоли

Мелководья, тонкие частицы пыли

2

Синий

Глубоководья, атмосфера

3

Зеленый

Растительность

4

Красный

Антропогенные объекты, почвы, растительность

5

Ближний инфракрасный

Береговые линии, растительность

6

Коротковолновый инфракрасный 1

Проницаемость облачности, влажность почв и растительности

7

Коротковолновый инфракрасный 2

Улучшенная проницаемость облачности, влажность почв и растительности

8

Панхроматический

Чёрно-белые снимки, чёткие детали

9

Перистые облака

Перистые облака

10

Тепловой инфракрасный 1

Термальное картографирование, оценочная влажность почв

11

Тепловой инфракрасный 2

Улучшенное термальное картографирование, оценочная влажность почв

Каналы 2, 3 и 4 (синий, зеленый и красный) представляют видимую часть спектра. Сочетание каналов "Естественные цвета", обычно используемое в снимках, комбинирует эти каналы таким образом, чтобы изображение выглядело так, как его видит человеческий глаз. Далее мы изменим комбинацию каналов снимков, чтобы выделить пожары и сделать их очертания более различимыми.

  1. На панели Содержание подтвердите, что выбран слой 2015.tif.

    Каналы Естественные цвета

    Под именем слоя перечислены каналы, которые используются в данный момент на снимке: Синий, Зеленый и Красный, охватывающие видимую часть спектра. Красный и Зеленый выделяют растительность, что бывает полезно для изучения пожаров по причине контраста между залесенными областями, не затронутыми пожарами, и территориями, на которых пожары уничтожили растительность. Если использовать выделяющий растительность канал, например Ближний ИК (канал 5), контраст только усилится.

  2. На вкладке Оформление в группе Отображение щёлкните Комбинация каналов и выберите Инфракрасный цвет.

    Комбинация каналов

    Изображение изменится соответственно новой комбинации каналов.

    2015 Инфракрасный

    На панели Содержание каналы под именем слоя также изменяются, указывая на то, что это изображение объединяет в себе ближний инфракрасный, красный и зеленый диапазоны (3, 4 и 5). Поскольку Ближний инфракрасный канал обычно невидим для человеческого глаза, он отображается через Красный канал. В результате Красный и Зеленый каналы отображаются через Зеленый и Синий каналы.

    Цветные инфракрасные каналы на панели Содержание

    Примечание:

    Изображение, полученное в результате объединения трех каналов изображений и отображения их через Красный, Зеленый и Синий каналы, называется модель RGB. Любой канал можно использовать для любого из трёх цветовых каналов модели RGB, именно поэтому для отображения красного канала можно использовать зеленый канал. В легенде цвет символа и первое слово означают композитный цвет (или цветовой канал), а второе слово означает выбранный канал.

    Как аналитик изображений, вы быстро привыкнете видеть изображения в этих необычных цветовых сочетаниях.

    На карте растительность показана красным. Обе области гарей показаны темно-коричневым. По сравнению с исходным изображением, гари видны более чётко, особенно Reynolds Creek к северу от озера. Но гарь Thompson всё ещё заслонена дымом. Теперь поэкспериментируем с комбинацией, использующей Коротковолновые инфракрасные каналы (6 и 7), которые проникают сквозь облака.

  3. На вкладке Оформление щелкните Комбинация каналов и выберите Поверхность суши/воды.

    Каналы обновляются, и изображения меняются.

    2015 Дальний ИК

    Каналы под именем слоя на панели Содержание изменились на Коротковолновые инфракрасные и Ближний инфракрасный, то есть на изображении скомбинированы каналы 5, 6 и 7. Хотя основное предназначение данной комбинации разграничивать сушу и воду, она также проникает сквозь дымку (в данном случае дым). Теперь в окрестностях гари Thompson дыма почти не видно, и её границы видны гораздо чётче. Но выгоревшие территории показаны оранжевым, а окружающие горные склоны – жёлтым. Из-за этого гарь Reynolds Creek, которая распространена в горах, стало хуже видно.

  4. Снова щёлкните Комбинация каналов и выберите Анализ растительности.

    Каналы обновляются, и изображения меняются.

    2015 Растительность

    Данная комбинация использует Красный, Ближний инфракрасный и Коротковолновый инфракрасный 1 каналы (4, 5, 6). Таким образом, здесь сочетается выделение растительности в Инфракрасном цвете и улучшенная проницаемость дымки из комбинации каналов Поверхность суши/Воды. Хотя вокруг гари Thompson видна небольшая дымка, а гарь Reynolds Creek местами сливается с горными склонами, эти проблемы не столь критичны, как в предыдущих комбинациях.

    Если бы можно было немного уменьшить дымку, то такое изображение лучше всего подошло для оцифровки гарей. Но ни одна из оставшихся предлагаемых по умолчанию комбинаций не сделает это лучше, чем уже просмотренные. Для того, чтобы изображение соответствовало вашим требованиям, создадим пользовательскую комбинацию каналов.

Создание пользовательской комбинации каналов

До этого вы использовали предустановленные комбинации каналов. Далее вы выберете каналы, чтобы улучшить комбинацию Анализа растительности и уменьшить дымку.

  1. На панели Содержание выберите слой 2015.tif.

    Каналы Анализ растительности

    Комбинация Анализ растительности использует канал Коротковолновый инфракрасный 1 для сокращения дымки и каналы Ближний инфракрасный и Красный для выделения растительности. Переключение Коротковолнового инфракрасного 1 на Коротковолновый инфракрасный 2 улучшит проникновение сквозь дымку (или облака).

  2. Щелкните правой кнопкой мыши канал ShortWaveInfrared_1 и выберите ShortWaveInfrared_2.

    ShortWaveInfrared_2

    Примечание:

    Из данных удалены Панхроматический канал (канал 8) и оба термальных инфракрасных (каналы 10 и 11), предоставленные в пакете этого урока, поэтому в списке каналов их нет.

    Канал автоматически изменится, также поменяется и изображение на карте. Разница на карте незначительна, но вы увидите небольшое улучшение четкости отображения гарей. Далее вы замените Красный канал на Синий.

  3. Щелкните правой кнопкой мыши на Синем цвете и выберите Blue.

    Синий канал

    Изображение на карте слегка изменится. Дымка всё ещё видна, но существенно уменьшилась.

    2015 настроенный

    Теперь вас устраивает отображение гарей. Чтобы в дальнейшем быстро открывать эту комбинацию каналов, вы сохраните ее в списке комбинаций по умолчанию, доступном на вкладке Оформление.

  4. На вкладке Оформление щёлкните Комбинация каналов и выберите Пользовательский.

    Пользовательская комбинация каналов

    Появится окно Пользовательская комбинация каналов.

  5. Для Красного цвета выберите ShortWaveInfrared_2. Для Зеленого установите NearInfrared. Для Синего укажите Blue. Назовите пользовательскую комбинацию каналов Burn Scar Analysis (анализ гарей) и щелкните Добавить.

    Пользовательская комбинация каналов

    Пользовательская комбинация каналов добавится в ниспадающее меню Комбинация каналов, что позволит быстро применить её к другим снимкам (или повторно применить к данному снимку, если вы снова измените комбинацию каналов).

    Примечание:

    Удалить пользовательские комбинации каналов можно только после запуска нового сеанса ArcGIS Pro.

  6. Сохраните проект, щелкнув кнопку Сохранить на Панели инструментов быстрого доступа.

    Кнопка Сохранить на панели быстрого доступа

Вы отобразили снимок двух гарей в национальном парке Глейшер – сначала в естественных цветах, затем с использованием других комбинаций каналов, лучше выделяющих выгоревшие площади. В итоге вы создали пользовательскую комбинацию каналов, специально предназначенную для выделения гарей. Хотя такая комбинация лучше подходит для получения чётких границ гарей, она все равно требует некоторое визуальной интерпретации, чтобы определить, что выгорело, а что нет. Далее мы будем использовать математическую формулу, называющуюся индексом гарей, для количественной оценки выгоревших территорий.


Вычисление индекса гарей

Ранее мы рассматривали спутниковые изображения с использованием различных комбинаций спектральных каналов, чтобы визуально идентифицировать распространение гарей. Далее вы используете индекс для количественного определения выгоревших территорий. Этот индекс называется Нормализованным коэффициентом гари (NBR), в нем для определения серьёзности гари математически сравниваются ближний инфракрасный и коротковолновый инфракрасный 2 каналы (соответственно, каналы 5 и 7).

Вы примените NBR к снимкам 2014.tif и 2015.tif, а затем вычислите разницу между ними,чтобы определить объем изменений до и после пожаров. Результатом будут математически вычисленные следы гарей.

Вычисление нормализованного индекса гарей

Сначала вы вычислите NBR для снимка 2014 года.

  1. Если надо, откройте проект Montana Fires.
  2. На панели Содержание выберите слой 2014.tif. На ленте щелкните вкладку Изображения и в группе Инструменты щелкните Индексы.

    Индексы на вкладке Изображения

  3. На панели Индексы щелкните NBR.

    Инструмент Нормализованный индекс гарей (NBR)

  4. В окне NBR для Индекс канала Ближний инфракрасный выберите 5 - Nearinfrared, а для Индекс канала Коротковолновый инфракрасный выберите 7 - ShortWaveInfrared_2. Нажмите OK.

    Окно NBR

    На панели Содержание появится новый слой NBR_2014.tif.

    NBR_2014.tif

    Далее вы вычислите NBR для снимка 2015 года.

  5. На панели Содержание выберите слой 2015.tif. На ленте на вкладке Изображения в группе Инструменты щелкните Индексы.
  6. На панели Индексы щелкните NBR.
  7. В окне NBR для Индекс канала Ближний инфракрасный выберите 5 - Nearinfrared, а для Индекс канала Коротковолновый инфракрасный выберите 7 - ShortWaveInfrared_2. Нажмите OK.

    На панель Содержание будет добавлен слой NBR_2015.tif.

Выявление изменений NBR

Далее вы воспользуетесь инструментом Разность, чтобы вычислить изменения в NBR между двумя снимками. Таким образом вы выявите области, где значения NBR существенно возросли от 2014 к 2015. Эти области скорее всего и будут следами гарей.

Вы будете вычислять следующую разницу: NBR_2014.tif - NBR_2015.tif. Инструмент Разность берет растры в том порядке, в котором они перечислены на панели Содержание, так что вам нужно перенести NBR_2014.tif над NBR_2015.tif.

  1. На панели Содержание щелкните NBR_2014.tif и перетащите его над NBR_2015.tif. Нажмите клавишу Ctrl и щелкните NBR_2014.tif и NBR_2015.tif, чтобы выбрать оба слоя.

    Выбранные слои.

  2. На ленте на вкладе Изображения в группе Инструменты щелкните стрелку под Обработкой и выберите Разность.

    Инструмент Разность

    На карту будет добавлен растр разности, Difference_NBR_2014.tif_NBR_2015.tif.

    Карта с растром разности

    Теперь гари показаны почти сплошной белой заливкой, резко выделяющейся на фоне окружающих серых и чёрных территорий. Остались ещё белые заснеженные вершины, но их сложно перепутать с гарями. Контраст можно усилить, поменяв символы изображения. Но сначала вы измените имя слоя.

  3. На панели Содержание щелкните Difference_NBR_2014.tif_NBR_2015.tif, чтобы выбрать его и щелкните снова на его названии, чтобы переименовать. Введите change_nbr и нажмите Enter.
  4. Щелкните цветовую схему под change_nbr, чтобы открыть панель Символы.

    Цветовая схема

    Символы слоя change_nbr представлены цветовой схемой, а не сочетанием RGB, поскольку подобно прочим слоям NBR содержит лишь один канал.

  5. На панели Символы для Цветовой схемы разверните ниспадающий список и поставьте отметку для опции Показать названия. Затем для цветовой шкалы, выберите зелено-красную шкалу чисел обусловленности.

    Число обусловленности

    Подсказка:

    На панели Символы щелкните стрелку ниспадающего меню Цветовая схема и выберите Показать имена, чтобы увидеть названия цветовых схем.

  6. Для Типа растяжки выберите Стандартное отклонение.

    Символы обновились.

    Изменившиеся символы.

    Обе гари теперь видны на карте очень хорошо ярко-красным цветом.

  7. Закройте панель Символы.

    Вам больше не нужен исходные слои NBR, поэтому вы их удалите.

  8. На панели Содержание щёлкните правой кнопкой слой NBR_2014.tif и выберите Удалить.

    Удаление

  9. Удалите слой NBR_2015.tif.
  10. Сохраните проект.

Теперь у вас есть достаточно чёткое изображение с гарями, которые можно оцифровать как полигональные объекты.


Оцифровка выгоревших территорий

Теперь у вас есть достаточно четкое изображение экстентов пожара, чтобы оцифровать его в виде полигональных объектов и поделиться с коллегами из Montana Forest Management Services. Сначала вы создадите класс объектов, в котором будут храниться новые полигоны. Затем вы воспользуетесь инструментами редактирования, чтобы отрисовать полигональные объекты, следуя приблизительным границам обоих очагов. Наконец, вы вычислите площадь в акрах для каждой гари.

Создать класс пространственных объектов

Вы начнете с создания класса пространственных объектов, а затем воспользуетесь инструментами редактирования, чтобы отследить контур гари.

  1. На ленте щелкните вкладку Вид и в группе Окна выберите Панель Каталог.

    Панель Каталог

  2. На панели Каталог раскройте папку Базы данных.

    Папка Базы данных на панели Каталог

    Папка содержит montana_fires.gdb, базу геоданных по умолчанию для проекта, где вы создадите новый класс пространственных объектов.

  3. Щелкните правой кнопкой montana_fires.gdb, укажите Новый и выберите Класс объектов.

    Новый класс пространственных объектов

    Появится панель Геообработка, отображающая инструмент Создать класс пространственных объектов.

  4. В панели Создать класс пространственных объектов для Имени введите Fires. Оставьте другие параметры без изменений и щелкните Готово.

    Создайте класс пространственных объектов.

    Создается новый класс пространственных объектов, и новый пустой класс пространственных объектов Fire добавляется к вашей карте и на панель Содержание. Поскольку символы нового класса пространственных объектов по умолчанию имеют сплошную заливку, будет сложно точно отследить объект карты. Теперь вы обновите символы.

  5. На панели Содержание щёлкните символ для Fires, чтобы открыть панель Символы.

    Символ для слоя Fires

    Примечание:

    Цвет символов слоя генерируется случайным образом и может отличаться от изображения в примере, но не влияет на результаты анализа.

    Появится панель Символы. Так как символы по умолчанию для нового класса объектов используют сплошную заливку, очень сложно прорисовать все объекты трассировки на карте.

  6. На панели Символы на вкладке Галерея выберите вторую опцию, Черный контур (2 тчк).

    Черный контур (2 тчк)

    Примечание:

    Вы можете навести курсор на опции символов, чтобы увидеть их полные названия.

    Слой класса пространственных объектов настроен и готов к редактированию.

Отрисуйте границы полигонов

Далее вы воспользуетесь инструментами редактирования, чтобы трассировать края пожаров Рейнольдса и Томпсона, оцифровав гари.

  1. Приблизьтесь к пожару Reynolds Creek.

    Пожар Reynolds Creek

  2. На ленте щелкните вкладку Редактирование. В группе Объекты щелкните Создать.

    Инструмент Создать на вкладке Редактировать

    Появится панель Создать объекты. На ней содержатся слои, для которых вы можете создавать пространственные объекты.

  3. На панели Создать объекты щелкните Fires щёлкните кнопку Полигон.

    Инструмент Полигон в разделе Fires

    Теперь при перемещении по карте курсор выглядит как перекрестье.

  4. Щелкните где-нибудь на краю пожара Reynolds Creek, чтобы начать рисовать полигональный объект.

    Отрисуйте объект.

    Если щёлкнуть где-нибудь ещё, появится ещё одна вершина.

    Подсказка:

    Чтобы перемещаться по карте при добавлении вершин, нажмите и удерживайте клавишу C, чтобы переключиться на инструмент Исследовать, позволяющий перемещать карту. Отпустите клавишу C, чтобы вернуться к инструменту Создать объекты.

  5. Продолжайте добавлять вершины вдоль границы гари.
    Примечание:

    Чем больше добавить вершин, тем более точными будет пространственный объект. Так как это всего лишь учебное упражнение, можно оцифровывать не слишком тщательно, главное чтобы гарь была обведена приблизительно там, где она находится.

  6. Когда вы закончите размещать вершины, дважды щелкните последнюю вершину, чтобы завершить создание объекта.

    Пространственный объект Reynolds Creek

    Примечание:

    Чтобы изменить расположение вершин, щелкните Редактировать вершины (на вкладке Редактировать в группе Инструменты) и измените размещение вершин. Или можно щёлкнуть вкладку Редактирование, в группе Объекты, щелкните Удалить, чтобы удалить весь объект и начать оцифровку заново.

  7. Если объект нравится, на вкладке Редактирование, в группе Управление изменениями, щелкните Сохранить.

    Сохраните изменения.

  8. В окне Сохранить изменения щёлкните Да, чтобы сохранить все изменения.

    Далее вы оцифруете зону пожара Томпсона.

  9. Нажмите клавишу Esc, чтобы вернуться в режим навигации по карте.
  10. Увеличьте и уменьшите экстент пожара Thompson.

    Пожар Thompson

    Пожар Thompson больше по площади и сложнее по форме, чем пожар Reynolds Creek, поэтому его оцифровка займёт больше времени.

  11. При необходимости, на вкладке Редактирование щелкните Создать, чтобы открыть панель Создать объекты.
  12. На панели Создать объекты под пунктом Fires щёлкните кнопку Полигон.

    Создание объектов

  13. Оцифруйте пожар Thompson.

    Гарь Thompson

  14. Если вам нравится полученный результат, сохраните изменения.
  15. Закройте панели Создать объекты и Символы. На панели Содержание щелкните правой кнопкой мыши слой change_nbr и выберите Приблизить к слою, чтобы вернуться к полному экстенту изображения.
    Примечание:

    Оцифровка объектов вручную, как вы только что сделали, хорошо работает, когда у вас небольшое количество объектов. При анализе больших областей вам нужно изучить более автоматизированные методы векторизации, такие как инструмент Растр в полигон.

Добавление атрибутивной информации

Вы создали по объекту для каждой гари, но сейчас там нет атрибутивной информации. Необходимо отредактировать таблицу атрибутов, чтобы можно было идентифицировать каждый объект и вычислить его площадь выгорания в акрах.

  1. На панели Содержание щёлкните правой кнопкой слой Fires и выберите Таблица атрибутов.

    Открыть таблицу атрибутов

    В таблице атрибутов два пространственных объекта, которые вы только что оцифровали. Последний оцифрованный объект, пожар Thompson, возможно ещё выделен.

    Таблица атрибутов

  2. На ленте таблицы атрибутов щёлкните кнопку Очистить выборку.

    Очистить выборку

    Периметр и площадь пожаров уже рассчитаны в атрибутах Shape_Length и Shape_Area, но эти расчеты производятся в квадратных метрах. Обычно измерения площади дают в акрах. Вы создадите новый атрибут и заполните его этой информацией.

  3. На ленте таблицы атрибутов щелкните кнопку Добавить поле.

    Добавить поле

    Откроется представление Поля, с новым пустым полем внизу. Надо добавить два поля: одно для названия гари, а другое для площади в акрах.

  4. Измените для нового поля Имя поля на Name. Дважды щёлкните ячейку Тип данных и выберите Текст.

    Имя поля

  5. На ленте в группе изменения щелкните Сохранить.

    Сохраните поля.

    Примечание:

    Если после оцифровки пространственных объектов у вас оставались несохраненные изменения, вы не сможете изменить таблицу атрибутов. Если это произошло, закройте таблицу атрибутов без сохранения, сохраните пространственные объекты на вкладке Редактирование, а затем снова добавьте новое поле.

  6. Добавьте ещё одно поле.
  7. Измените имя нового поля на Acres и Тип данных на Float..

    Поле Acres добавлено.

  8. На ленте щелкните кнопку Сохранить.
  9. Закройте вид Поля, чтобы вернуться в таблицу атрибутов.

    Пустые поля

    Новые поля сейчас пустые. Вы отредактируете поля Name вручную, но для расчета площади вы запустите инструмент геообработки.

  10. Дважды щелкните поле Name первого пространственного объекта, чтобы его отредактировать. Введите Reynolds Creek и нажмите клавишу Enter.
  11. Исправьте имя второго пространственного объекта на Thompson.

    Названия пожаров обновлены в таблице атрибутов.

  12. На ленте щелкните вкладку Редактирование. В группе Управление изменениями щелкните Сохранить. В окне подтверждения выберите Да, чтобы сохранить все изменения.
  13. Щелкните правой кнопкой мыши на заголовке поля Acres и воспользуйтесь командой Вычислить поле.

    Вычислить поле

    Откроется инструмент Вычислить поле. Этот инструмент позволяет создать выражение для вычисления значений поля. У класса пространственных объектов Fires уже есть поле с площадью, но в квадратных метрах, а не в акрах. Один акр равен 4046,86 кв. метрам, поэтому мы воспользуемся этим коэффициентом для пересчёта.

  14. В разделе Выражение, в столбце Fields дважды щелкните Shape_Area, чтобы добавить его в выражение. Щелкните оператор деления и введите 4046,86.

    Выражение

  15. Щелкните Запустить.

    Итоговая таблица атрибутов

    Поле Acres вычислено. Площадь гари Reynolds Creek приблизительно 4 400 акров, а гари Thompson около 12 400 акров. У вас значения могут отличаться, в зависимости от точности оцифровки.

  16. На ленте на вкладке Редактирование щелкните Сохранить. В окне подтверждения выберите Да, чтобы сохранить все изменения.
  17. Закройте таблицу атрибутов Fires.
  18. Сохраните проект.

Теперь у вас есть полигональные пространственные объекты обеих гарей, а также атрибутивная информация с их названиями и площадями.


Публикация результатов (дополнительно)

Теперь, когда у вас есть полигональные пространственные объекты обеих гарей, а также атрибутивная информация с их названиями и площадями, вы опубликуете класс Fires в ArcGIS Online, чтобы открыть доступ к нему.

Публикация результатов

Вы опубликуете класс объектов Fires в ArcGIS Online инструментом Опубликовать как веб-слой.

  1. На панели Содержание щёлкните правой кнопкой слой Fires, отметьте Опубликовать и выберите Опубликовать как веб-слой.

    Откроется панель Опубликовать как веб-слой. Перед тем, как публиковать слой, надо ввести метаданные, чтобы его было можно искать и систематизировать.

  2. На панели Опубликовать как веб-слой введите следующее:
    • Для Имени замените имеющийся текст на Glacier_National_Park_Fires. В конце добавьте свое имя или инициалы, чтобы имя слоя было уникальным.
    • Для Краткой информации скопируйте и вставьте текст Определение периметра пожаров Рейнольдс-Крик и Томпсон в национальном парке Глейшер летом августа 2015 года. Perimeters defined by difference in Normalized Burn Ratio.
    • В качестве Тегов введите Пожар, Рейнольдс-Крик, Томпсон, Национальный парк Глейшер, Монтана и нажмите Enter.
    • В разделе Общий доступ отметьте Общий (для всех) или свою организацию, в зависимости от того, кто будет видеть веб-слой.
  3. Щелкните Анализировать.

    Анализ

    Слой анализируется на наличие ошибок. Если метаданные отсутствуют или что-то не так с данными, ошибка будет систематизирована и появится описание, чтобы вы могли исправить.

    Может появиться ошибка, говорящая о том, что поле Shape_Length нельзя использовать как поле отображения.

    Результаты анализатора

    Вы обновите настройки Свойств слоя для исправления этой ошибки.

  4. На панели Содержание дважды щелкните слой Пожары и в окне Свойства слоя, на боковой панели, щелкните Показать.
  5. Для Поля отображения выберите Name. Нажмите OK.
  6. На панели Опубликовать как веб-слой щелкните Анализ.

    Ошибка была исправлена, и других ошибок в результатах анализатора нет.

  7. Щелкните Опубликовать.

    Слой опубликован в ArcGIS Online.

  8. Щелкните Управление веб-слоем для просмотра опубликованного слоя в ArcGIS Online.

    Ссылка на Управление веб-слоем

    В окне браузера появится страница элемента векторного слоя Glacier_National_Park_Fires.

  9. При появлении запроса выполните вход и щелкните Открыть во вьюере карт.

    Открыть во вьюере карт

    Этот слой можно добавлять на любое количество карт, менять символы и предоставлять к нему доступ.

На этом уроке вы использовали снимки Landsat для определения экстента двух гарей. Сначала вы рассматривали изображения посредством различных комбинаций спектральных каналов, чтобы визуально определить местоположение гари. Затем вы вычислили нормализованный индекс гарей (Normalized Burn Ratio – NBR), чтобы выделить гари. И наконец, оцифровали обе гари и опубликовали их в ArcGIS Online. В реальной ситуации Департамент лесного хозяйства и управления природными ресурсами мог бы использовать этот слой для изучения сукцессий растительности или планирования пожароопасных ситуаций для этой территории в будущем.

Больше подобных уроков вы можете найти на странице Данные дистанционного зондирования и изображения.