レッスンのプロジェクトへの HYCOM ラスターの追加

ArcGIS Pro プロジェクト パッケージには、このレッスンに必要なすべてのデータおよびシンボルが含まれています。 プロジェクト パッケージをダウンロードして開いた後に、はじめに、メキシコ湾の範囲にクリップされた、含まれている HYCOM 多次元ラスターを解凍します。

プロジェクト パッケージのダウンロードと解凍

このレッスンのプロジェクト パッケージは、ArcGIS Online 上でホストされています。 パッケージを解凍して開くと、その内部に、HYCOM 海流変数を含んでいる圧縮された CRF フォルダーがさらにあります。 このフォルダーを、プロジェクトで使用する前に解凍する必要があります。

  1. Predict ocean currents to plan remote well inspections プロジェクトをダウンロードします。
  2. ダウンロードしたファイルを選択し、プロジェクト パッケージをダブルクリックして解凍し、ArcGIS Pro でプロジェクトを開きます。
  3. 必要に応じて、ArcGIS Pro[展開場所の選択] ウィンドウで、プロジェクトのフォルダーを参照して選択し、コンテンツを展開します。

    展開場所を選択するよう求められなければ、アプリケーションはC:\Users\<NAME>\Documents\ArcGIS\Packages\ predict ocean currents to plan remote well inspections などのデフォルトの場所に展開されます。

    展開場所を選択します。

    プロジェクトが開き、[Gulf of Mexico HYCOM] というタイトルのマップと [Gulf of Mexico Scene] というタイトルのシーンが表示されます。

  4. ファイル エクスプローラーで、解凍したプロジェクトの場所 (たとえば、C:\Users\<NAME>\Documents\ArcGIS\Packages\ predict ocean currents to plan remote well inspections) を参照します。

    プロジェクト フォルダー名の後ろには、\predict ocean currents to plan remote well inspections_d33969 などの一連の文字が追加されます。

  5. \commondata\userdata フォルダー内の HYCOM_GoM.zip ファイルを解凍します。 このフォルダーには、後でこのレッスンで使用するレイヤーとスタイルのファイルもあります。

    HYCOM_GoM.zip ファイルを解凍します。

    HYCOM ラスターが解凍され、このラスターをマップに追加して多次元プロパティを探索できるようになりました。

  6. ファイル エクスプローラーで、[HYCOM_GoM] フォルダーが解凍されていることを確認します。
  7. [カタログ] ウィンドウで [フォルダー] を右クリックして [フォルダー接続の追加] を選択します。

    フォルダー接続を追加します。

  8. [フォルダー接続の追加] ウィンドウで、[HYCOM_GoM] ラスターがある場所を参照して選択し、[OK] をクリックします。

    フォルダーの検索

  9. [カタログ] ウィンドウでフォルダー接続を確認し、[HYCOM_GoM] ラスターにアクセスします。

    フォルダーのコンテンツの探索

  10. プロジェクトを保存します。

マップへの HYCOM ラスターの追加

このレッスンのシナリオは 2021 年 4 月 19 日に行われ、シミュレートされた 7 日間の海流予測を使用します。この海流予測は、少ない処理時間で一貫性のある出力が得られるよう、プロジェクト エリアにすでにクリップされています。 現実のシナリオでは、ArcGIS Living Atlas で提供されるほぼリアルタイムの HYCOM サービスのうちの 1 つが、海流 (あるいは海面の高さ、塩分濃度、温度さえも) を予測するために使用されるでしょう。

プロジェクトには、メキシコ湾のマップおよびシーンのタブが含まれています。 はじめに 2D マップを使用して、井戸の位置および HYCOM データを探索してサンプリングし、シーンに移動して結果を 3D で視覚化します。

  1. 必要に応じて、[Gulf of Mexico HYCOM] マップをアクティブにします。

    Gulf of Mexico HYCOM マップ

  2. [コンテンツ] ウィンドウでマップ レイヤーを確認します。

    マップ レイヤー

    これらのレイヤーには、次のものがあります。

    • [Oil Wells] レイヤーは、30 の石油およびガスの井戸のコレクションで構成されています。
    • [Major Oceans Currents] レイヤーは、ガルフ ストリーム ループ海流を表示します。ガルフ ストリーム ループ湾流は、メキシコ湾を通り、フロリダの南端の周囲を蛇行する主要な海流です。 このレイヤーは、地球上の一貫性のある暖流および寒流を表示します。 このレイヤーは、ArcGIS Living Atlas of the World にあります。
  3. [Gulf of Mexico HYCOM] ラスターをマップに追加する前に、[マップ操作] ツールを使用して、世界の主要な暖流および寒流のいくつかを縮小して探索してみましょう。

    ループ海流

    井戸の位置の一部がガルフ ストリーム ループ湾流の内側にあり、北西のその他の井戸がこの海流の外側にあるはずです。

    ループ海流の内側の井戸

  4. [カタログ] ウィンドウの [フォルダー][HYCOM_GoM] ラスターを見つけて右クリックし、[プロパティ] を選択します。

    HYCOM_GoM プロパティを表示します。

  5. [プロパティ] ウィンドウで、[多次元情報] タブをクリックします。

    HYCOM_GoM 多次元プロパティを表示します。

  6. [プロパティ] セクションを確認し、[デフォルト変数] を展開します。

    多次元 HYCOM ラスターには、2 つの変数 (u と v) および 2 つのディメンションが含まれています。 各変数は、深さと時間のディメンションを含んでいます。

    HYCOM_GoM の変数を確認します。

  7. [変数] および [Eastward_Sea_Water_Velocity__u] で、[Depth] および [StdTime] のディメンションを展開します。

    これで、[Depth] および [StdTime] のディメンションの両方とそれらのプロパティを観察できるようになりました。

    • [Depth] の範囲は -5000 ~ 0、個数は 40 です。
    • [StdTime] の間隔は 3 時間、個数は 56、範囲は 2021-04-19T00:00:00 ~ 2021-04-25T21:00:00 です。

    HYCOM_GoM の深さおよび時間のディメンションを確認します。

    次に、[HYCOM_GoM] ラスターを [Gulf of Mexico HYCOM] マップに追加します。

  8. 各自で [Northward_Sea_Water_Velocity__v] 変数のディメンションのプロパティを調べてみてください。 終了したら、[キャンセル] をクリックしてプロパティ ウィンドウを閉じます。
  9. [カタログ] ウィンドウで、[HYCOM_GoM] ラスターを右クリックして [現在のマップに追加] を選択します。

    マップへの HYCOM_GoM レイヤーの追加

    ラスターがマップに追加されます。

    メモ:

    ArcGIS Pro を開いているときにラスター フォルダーを解凍し、そのラスターがファイル リストに表示されなかった場合、フォルダー接続を右クリックして更新します。

  10. [マップ操作] ツールを使用して、[HYCOM_GoM] ラスターの範囲にズームします。

    HYCOM_GoM レイヤーを探索します。

    HYCOM 多次元ラスターは、時間対応です。 ラスターをマップに追加するときに、タイム スライダーが画面の上部に表示されることに注意してください。 ここでは、タイム スライダーを折りたたんで非表示にすることをお勧めします。 このレッスンでは、後で時間を有効化して使用します。

  11. マップ上でタイム スライダーにポインターを合わせて折りたたみボタンをクリックします。

    タイム スライダーを探索します。

  12. [コンテンツ] ウィンドウで、[HYCOM_GoM] レイヤーをクリックして選択します。
  13. リボンの [表示設定] タブにある [レンダリング] グループで [DRA (ダイナミック レンジ調整)] をクリックします。

    DRA を選択します。

    マップが更新されます。

    DRA が適用された HYCOM_GoM レイヤー

  14. [コンテンツ] ウィンドウで、[HYCOM_GoM] レイヤーを確認します。

    HYCOM_GoM レイヤーの凡例を展開します。

    このレイヤーの凡例には、海流の大きさにおける変化をより良く表示するためのカラー ランプの最小値と最大値が表示されます。

  15. [マップ操作] ツールを使用して、[Oil Wells] レイヤー内のフィーチャにズームします。

    HYCOM ラスターの DRA

  16. [レンダリング] グループの [リサンプリング タイプ] ドロップダウン メニューをクリックし、[共一次内挿法] を選択します。

    共一次内挿リサンプリング方法を選択します。

    この操作は、ラスターのピクセルを滑らかにします。

    HYCOM ラスターの DRA および共一次内挿リサンプリング

    多次元 HYCOM ラスターには、2 つの変数および 2 つのディメンションが含まれています。 これらの変数は、深さと時間を表す u (マップ上に現在表示されている) および v です。

    多次元 HYCOM ラスター変数

    次に、ラスターに表示される変数を u (東西) 成分から v (南北) 成分の方向に変更します。

  17. リボンの [多次元] タブにある [現在の表示スライス] グループで、[変数] ドロップダウン メニューをクリックし、[Northward_Sea_Water_Velocity_v] を選択します。

    表示変数を選択します。

    メモ:

    アクティブな変数を変更する場合は、DRA および共一次内挿リサンプリングを再適用する必要もあります。

  18. リボンの [表示設定] タブにある [レンダリング] グループで [DRA (ダイナミック レンジ調整)] をクリックします。
  19. [レンダリング] グループの [リサンプリング タイプ] ドロップダウン メニューをクリックし、[共一次内挿法] を選択します。
  20. リボンの [多次元] タブにある [現在の表示スライス] グループで、[StdTime] ドロップダウン メニューをクリックします。

    タイム スライスを表示します。

    [StdTime] ディメンションが、[HYCOM_GoM] ラスターの変数およびディメンションのプロパティを確認するときに観察したように、3 時間のステップであることに注意してください。

  21. リボンの [多次元] タブにある [現在の表示スライス] グループで、[Depth] ドロップダウン メニューをクリックします。

    深さのスライスを確認します。

    サーフェスに近いほどステップ間隔の密度が高くなり、観察が -5000 m に達すると、間隔の密度が低くなることに注意してください。 各自でさまざまな時間と深さを探索し、マップ内の HYCOM ラスターがどのように更新されるかを観察してみてください。

  22. プロジェクトを保存します。

このモジュールでは、メキシコ湾の油井検査プロジェクト エリアについての理解を深め、2D での HYCOM データセットの変数およびディメンションを探索し始めました。 次のセクションでは、油井を使用して、特定の位置で海流をサンプリングし、ガルフ ストリーム ループ海流の近くで ROV を操作するのが安全な場所と時期を特定します。 次のモジュールでは、30 か所の井戸で、深さおよび時間の両方のディメンションで HYCOM ラスターをサンプリングし、u ベクトルと v ベクトルを方向と速度に変換します。


HYCOM ラスターのサンプリング

メキシコ湾内の井戸は、ROV の安全な下降と上昇を可能にするほど海流が十分に遅いときに、定期的に調査され、必要な場合、蓋をかぶせられます。

ROV のミッション。 写真の著作権: Keith VanGraafeiland

このモジュールでは、30 か所の各井戸について、HYCOM ラスター内の海流の u ベクトルと v ベクトルの 3 時間の時間ステップのサンプルを取得します。 次に、これらの値を速度と方向に変換します。これらの速度と方向は、動的 3D シンボルを使用して海流を視覚化するために使用されます。

油井の位置の HYCOM サンプル

ROV 調査ミッションを計画するには、井戸の位置で時間をかけて海流を調査する必要があります。 多次元ラスターをサポートする [サンプル (Sample)] ジオプロセシング ツールを使用して、井戸の位置で、HYCOM 予測ラスターの時間と深さのディメンションの全範囲を抽出することができます。

  1. 必要に応じて、[Gulf of Mexico HYCOM] マップを開きます。
  2. [コンテンツ] ウィンドウで、[HYCOM_GoM] ラスター レイヤーをオフにします。
  3. [コンテンツ] ウィンドウで [Oil Wells] レイヤーを展開します。

    Oil Wells レイヤーを展開します。

    ROV が浮いている船舶またはプラットフォームから発進されるかどうかに従って、30 か所の油井がシンボル表示されることに注意してください。

    ボートから発進される ROV。 写真の著作権: Keith VanGraafeiland

    プラットフォームから発進される ROV。 写真の著作権: Keith VanGraafeiland

  4. [マップ操作] ツールを使用して、ループ海流の内側と外側の両方にある井戸のクラスターを拡大します。

    井戸のクラスターを探索します。

  5. リボン上で [コマンド検索] をクリックするか、Alt + Q キーを押します。
  6. [検索] ボックスに「Sample」と入力します。
  7. [検索結果] ドロップダウン メニューで、[Sample (Image Analyst Tools)] を選択します。

    サンプル ツールを見つけて使用します。

  8. [サンプル (Sample)] ジオプロセシング ツールで、次のパラメーターを設定します。

    • [入力ラスター][HYCOM_GoM] を選択します。
    • [入力ロケーション ラスターまたはフィーチャ] で、[Oil Wells] を選択します。
    • [出力テーブルまたはフィーチャクラス] に、「Sample_HYCOM_Go1」と入力します。
    • [一意の ID フィールド] で、[Well ID] を選択します。
    • [多次元として処理] をオンにします。
    • [フィーチャクラスの生成] をオンにします。

    サンプル ツールのパラメーター

    深さと時間のディメンションのプロパティの調査によって、40 の深さの数および 56 の時間の数が明らかになりました。 これらの数が、サンプルの数 (30 か所の井戸) と組み合わさって、[サンプル (Sample)] ジオプロセシング ツールによって生成される出力ポイントの数が決まります。

  9. [実行] をクリックします。

    [Sample_HYCOM_Go1] レイヤーがマップに追加されます。 このレイヤーは、40 の深さの間隔、56 の時間ステップ、および 30 の井戸の位置のサンプリングを表す 67,200 ポイントで構成されています。

  10. プロジェクトを保存します。

    次のモジュールでは、変数 u および v を使用して、海流を 3D でシンボル表示するために必要な属性を変換します。

変数 u および v からの速度と方向の計算

HYCOM ラスターは、海流の移動の大きさを表す東西 (u) および南北 (v) の方向ベクトル成分を使用します。 3D シンボルを拡大/縮小および回転するには、これらの値を最初に速度 (m/s) および方向 (度) に変換する必要があります。 以下の手順では、プロジェクト ツールボックスに含まれているシンプルな ModelBuilder モデルを使用して、これらの追加の属性をサンプル ポイントに追加します。

  1. [コンテンツ] ウィンドウで、[Sample_HYCOM_Go1] を右クリックして、[属性テーブル] を選択します。
  2. [Sample_HYCOM_Go1] 属性テーブルを確認します。

    [サンプル (Sample)] ツールは、最初の井戸 ID、最初の時間ステップ、および最も深い深さの間隔を処理することから開始して、各位置の深さを上に移動し、その後、次の時間ステップに進み、このプロセスを繰り返します。

    Sample_HYCOM_Go1 属性テーブルを探索します。

    なお、深い間隔には NULL 値が存在していますが、これは問題ありません。 メキシコ湾の 30 か所の井戸の最大深度は -1000 m ~ -3000 m であるため、HYCOM ラスターおよびサンプル ポイントのこの深さを超えるデータは、すべて NoData と見なされます。

  3. [カタログ] ウィンドウを開き、[ツールボックス] を展開します。
  4. [多次元海洋データの視覚化] ツールボックスを展開します。

    モデル ツールを見つけます。

  5. [多次元海洋データの視覚化] ツールボックスで、[u および v からの速度と方向の計算] モデルをダブルクリックします。
    メモ:

    [サンプル (Sample)] ツールで使用したのと同じ方法で、「u and v」でジオプロセシング ツールを検索して見つけることもできます。

  6. [u および v からの速度と方向の計算] モデル ツールの [サンプル ポイント][Sample_HYCOM_Go1] を選択し、[実行] をクリックします。

    モデル ツールを使用します。

    ツールは正常に実行されますが、警告が表示されます。 サンプル ポイントの中には、深い間隔に NULL 値を含んでいるものがあるため、これらのレコードを処理できず、警告が生成されます。

    モデル ツールの警告

    メモ:

    ベクトル u および v は、海流の正と負の X 成分および Y 成分を表します。そのため、このモデルでは、速度の値を m/s 単位で求めるために、次のようにピタゴラスの定理が使用されます。

    速度 = √u² + v²

    ジオメトリを次のように使用して、u および v から海流の方向を再度決定できます。

    方向 = (180/π) * arctan(u,v)

  7. [Sample_HYCOM_Go1] 属性テーブルを確認します。

    新しいフィールド値を確認します。

    これでサンプル ポイントが、3D 海流シンボルを時空間内で拡大/縮小および回転するために必要な属性を含むようになりました。 属性テーブル内の [速度] の値に目を通すことによって、より深く進むにつれて、それらの値が急速に減少しているため、ループ海流の動きの大部分が海面近くで発生していることがわかるはずです。

  8. [Sample_HYCOM_Go1] 属性テーブルを閉じます。
  9. プロジェクトを保存します。

このモジュールでは、30 か所の井戸で、深さおよび時間の両方のディメンションで HYCOM ラスターをサンプリングし、u ベクトルと v ベクトルを方向と速度に変換しました。 次のモジュールでは、サンプル ポイントをシーンに追加し、それらを海流の方向と大きさを示す時間対応のカスタム 3D 矢印としてシンボル表示します。


3D 海流シンボルの構成

HYCOM 多次元データの性質から、変化および大きさの複数のディメンションを 2D ビューで合成することが難しくなります。 一度に 1 つの深さまたは時間のスライスを表示することができますが、その場合、前後のスライスとの関係を失います。 シーンを使用することで、67,200 個のサンプルのポイントを、深さのディメンションをすべて 1 つの 3D ビューに捉える直感的なシンボルに変換できます。

HYCOM のサンプルのポイントをシーンに追加して深さを構成する

このモジュールでは、HYCOM のサンプルのポイントをプロジェクトで提供されたシーンに追加し、Living Atlas で利用可能な TopoBathy 3D (地形および測深学) 標高サービスを使用してグローバル シーンで海洋の深さの視覚化をサポートするようにレイヤー プロパティを構成します。 レイヤー ファイル (*.lyrx) は、SketchUp で作成されたシンプルな 3D 方向シンボルを含んでいるプロジェクトでも提供されています。

  1. [Gulf of Mexico HYCOM] マップの [コンテンツ] ウィンドウで、[Sample_HYCOM_Go1] を右クリックして [コピー] を選択します。

    レイヤーをコピーして複製します。

  2. プロジェクトで、Gulf of Mexico シーンをアクティブにします。

    このシーンには、Well 20 の拡大表示の 3D ビューが含まれています。 この井戸は、船舶による検査のためにアクセス可能であり、-2604 m の海底までの最大深度を表示します。

    Gulf of Mexico シーン

  3. シーンの [コンテンツ] ウィンドウで、[Gulf of Mexico Scene] を右クリックして [貼り付け] を選択します。

    レイヤーをコピーして貼り付けます。

    レイヤーが、シーンの 2D レイヤー グループに追加されます。

  4. リボン上の [マップ] タブの [ナビゲーション] グループで、[ブックマーク] を使用して[Well 20] のブックマークを追加します。

    新しいブックマークを追加します。

    ブックマークに、「Well 20」という名前を付けます。

    ブックマークを作成します。

  5. [マップ操作] ツールを使用して、[Sample_HYCOM_Go1] レイヤーのフィーチャを縮小し、探索します。

    Sample_HYCOM_Go1 レイヤーのフィーチャを探索します。

    [Sample_HYCOM_Go1] レイヤーを 3D レイヤー グループに移動するレイヤー ファイルを適用します。

  6. [コンテンツ] ウィンドウで [Sample_HYCOM_Go1] レイヤーをクリックします。
  7. リボンの [表示設定] タブで、[シンボル] ボタンをクリックします。

    シンボル ウィンドウを表示します。

  8. [シンボル] ウィンドウで、[シンボルのインポート] ボタンを見つけてクリックします。

    シンボルのインポート をクリックします。

  9. [レイヤーのシンボル情報を適用 (Apply Symbology From Layer)] ジオプロセシング ツールで、次のパラメーターを設定します。

    • [入力レイヤー] で、[Sample_HYCOM_Go1] が選択されていることを確認します。
    • [シンボル レイヤー] で、フォルダー接続から [3D Arrows.lyrx] を参照して選択します。

    シンボル レイヤーを選択します。

  10. [3D Arrows.lyrx] レイヤー ファイルによって設定された [シンボル フィールド] パラメーターを確認します。

    • [タイプ][値フィールド] に設定されます。
    • [ソース フィールド][速度] に設定されます。
    • [ターゲット フィールド][速度 (m/s)] に設定されます。

    レイヤーのシンボルを適用します。

  11. [実行] をクリックしてシンボルを適用します。

    これでシーンが、Well 20 に位置する海面で、重なり合う 3D 矢印のコレクションを表示するように更新されました。 カスタム 3D 矢印シンボルを適用する、レイヤーを 3D レイヤー グループに移動する、等級色を使用して速度のカットオフを設定する、ラベルを追加するなどの、シンボルの作業の大部分は、レイヤー ファイルによって実行されます。

  12. [コンテンツ] ウィンドウで [Sample_HYCOM_Go1] レイヤーの凡例を確認します。
    メモ:

    [コンテンツ] ウィンドウには、[Sample_HYCOM_Go1] レイヤーに適用されたカスタマイズされた 3D 矢印が表示されません。 ただし、シーン内の井戸は、シンボルを使用してレンダリングされ、等級色およびラベルを使用して速度のカットオフを表示します。

    [コンテンツ] ウィンドウ

    海流の速度のカットオフおよびシンボルは、このレッスンで油井の検査に使用される ROV の仮想的動作限界に基づいています。

  13. [シンボル] ウィンドウで、[属性によってシンボルを変更] タブをクリックして、[サイズ] を展開します。

    シンボル ウィンドウのプロパティの設定

    サイズ フィールドが [速度 (m/s)] を使用するように設定されているはずです。

  14. [シンボル] ウィンドウを閉じます。
  15. [Well 20] ブックマークを使用して対象の井戸にズームします。
  16. シーンで [マップ操作] ツールを使用して、Well 20 を調査したり、回転したり、傾けたりします。

    • 緑色の矢印は、最適な低い流速 (0.25 m/s 未満) を示します
    • 黄色の矢印は、中程度の (まだ許容できる) 流速 (0.25 ~ 0.5 m/s) を表します
    • 赤色の矢印は、ROV の動作限界を超える流速 (0.5 m/s を超える) を示します。

    積み重ねられた矢印の確認

    フィーチャの高さの設定は、レイヤー プロパティからさらに構成する必要があります。

  17. [コンテンツ] ウィンドウで [Sample_HYCOM_Go1] レイヤーをダブルクリックします。

    [レイヤー プロパティ] ウィンドウが表示されます。

  18. [レイヤー プロパティ] ウィンドウで、[高度] タブをクリックします。
  19. [フィーチャ][絶対高度] に設定されていることを確認します。
  20. [フィールド] で、ドロップダウン メニューをクリックして [Depth] を選択します。

    標高プロパティを設定します。

    これで、サンプルのポイントごとに Z 値を設定しました。次に、深さのプロパティを確認します。

  21. [レイヤー プロパティ] ウィンドウで、[表示] タブをクリックします。
  22. [3D シンボルを実世界の単位で表示] がオンになっていることを確認します。 終了したら、[OK] をクリックしてレイヤー プロパティを閉じます。

    レイヤーの表示プロパティを設定します。

    シーンが、海面の下の深さでサンプルのポイントの各セットを表示するように更新され、ラベルが海流の速度をメートル/秒単位で表示します。

    表示プロパティを確認します。

  23. シーンで [マップ操作] ツールを使用して、井戸フィーチャを回転したり、傾けたりして、流速を観察します。
  24. プロジェクトを保存します。

時間の構成

HYCOM 多次元ラスターは、時間対応です。 サンプリング ステップでラスターをマップに追加するときに、画面の上部に表示されたタイム スライダーを折りたたんで非表示するよう指示されました。

時間を構成します。

サンプルのポイントが時間ステップを HYCOM ラスターの属性として組み込みましたが、シーン レイヤー自体は、HYCOM ラスターが時間対応であることをまだ認識していません。 以下の手順では、より簡単に海流の速度の変化を時間のディメンションで探索 (アニメーション表示) できるように、時間を構成します。

  1. Gulf of Mexico シーンの [コンテンツ] ウィンドウで、[Sample_HYCOM_Go1] レイヤーをダブルクリックします。
  2. [レイヤー プロパティ] ウィンドウで、[時間] タブをクリックします。
  3. [時間] タブの [レイヤーの時間] ドロップダウン リストで、[各フィーチャに 1 つの時間フィールドがあります] を選択します。

    レイヤー プロパティを表示します。

  4. [時間フィールド] で、[StdTime] を選択します。

    時間フィールドを選択します。

    現在、HYCOM データセットの時間範囲は、4 月 19 の午前 0 時から 4 月 25 日の午後 9 時までを表示するように設定されています。 HYCOM には 3 時間 (UTC 時間) の頻度があるため、サンプルのポイントの時間プロパティは、この頻度に一致する必要があります。

  5. [時間間隔] で、[通常の時間間隔を使用して表示] をオンにし、[ステップ][3] に設定し、単位を [時間] に設定します。

    時間間隔のステップを設定する

  6. [タイム ゾーン] で、ドロップダウン メニューをクリックして [UTC (世界協定時)] を選択します。

    タイム ゾーンを UTC (世界協定時) に設定します。

  7. [OK] をクリックして、[レイヤー プロパティ] ウィンドウを閉じます。

    レイヤーの時間を構成したら、その時間がシーンの上部に表示されます。

    シーンのタイム スライダー

  8. シーンで、タイム スライダーにポインターを合わせ、[時間の無効化] ボタン (デフォルトでは赤色の x を含む) をクリックして時間を有効化または無効化します。

    時間を有効化または無効化します。

    タイム スライダーは、データをフィルタリングして、時系列内の最初のステップ (2021 年 4 月 19 日午前 0 時) を表示します。

    時系列内の最初のステップ

  9. タイム スライダーの上部にある右矢印をクリックして、複数のステップを時系列の前方に移動します。

    ステップを前方に移動します。

    3 時間の時間移動ウィンドウが現在表示されていますが、移動ウィンドウではなく、1 つの時間値でステップを実行したいということがわかります。

  10. リボンの [時間] タブにある [現在の時間] グループで [間隔] を見つけ、[3][0] に変更します。

    間隔の設定

  11. [ステップ] グループで、[ステップ間隔][3 時間] に設定されていることを確認します。

    ステップ間隔を確認します。

    これで、3 時間の増分で時系列を前方および後方に移動するときに、タイム スライダーが 1 つの値を表示するようになりました。

    ステップ間隔を使用する再生時間。

  12. シーンで [マップ操作] ツールを使用して、Well 20 の近くにズームします。
  13. [コンテンツ] ウィンドウで、[Well Tops] レイヤーをオフにして、海面近くの海流がよく見えるようにします。

    井戸の上部がない再生時間。

    これで、サンプルのポイントに対して、深さと時間のディメンションが構成されました。

  14. 各自で、シーン内の他の井戸の位置のいくつかを探索し、タイム スライダーを使用して、空間、深さ、および時間にわたる海流の速度および方向の変化を比較してみてください。

    アニメーション

    深さの属性をレンジ スライダーに接続することによって、レンジ対応になるようにこのレイヤーを構成することもできます。 たとえば、上部 100 メートル内のサンプルのポイントを表示することのみに興味がある場合、特定の深さまたは深さのレンジを表示することができます。 詳細については、レンジの構成に関する ArcGIS Pro ドキュメントをご参照ください。 データセットに対する時間 (またはレンジ) の構成は、2D および 3D の両方での動的プロセスをフィルタリングして視覚化する基本的な方法です。

レッスンのシナリオには、ROV を海中に送ることができるほど海流が穏やかになる場所と時期を決定するには、処理するべき情報がたくさんあります。 ご安心ください。ArcGIS Pro には、データセットをさらに単純化して、ROV 潜水ウィンドウ候補の計画概要やエグゼクティブサマリーにできる、チャート作成オプションが用意されています。 次のモジュールでは、チャートを生成します。


マトリックス ヒート チャートを使用した ROV の潜水ウィンドウの探索

3D 矢印シンボルとして流れを視覚化することは、方向、大きさ、および深さを表すための直感的な方法です。 ただし、一度に 1 つの井戸にしかアクセスできず、井戸を大きいサンプル データセットに拡大できません。 1 週間の HYCOM および 30 か所の井戸の位置の解析から、1 枚の紙に収まる何かを抽出するには、マトリックス ヒート チャートを使用します。

マトリックス ヒート チャートの構成

マトリックス ヒート チャートは、数値フィールド (Velocity) の値に従って 2 つのカテゴリ フィールド (Well ID および Time) 間の関係を解析する便利な方法です。 このチャートは、「特定の井戸の位置および特定の時間に、海流の速度が ROV の動作パラメーターを超えるか?」という質問に回答するのに役立ちます。 この状況では、海底への下降および海底からの上昇で、すべての深さを通過する必要があるため、個別の深さの値は対象としません。 ただし、所定の井戸と時間における、すべての深さの最大海流値については注目します。

以下の手順では、質問に答えやすくなるよう、サンプルのポイントの属性を使用してマトリックス ヒート チャートを構成します。

  1. 必要に応じて、Gulf of Mexico シーンをアクティブにします。
    メモ:

    タイム スライダーは、本質的に定義クエリとして機能するため、完全なデータセットをチャートに表示するには、タイム スライダーを無効化する必要があります。 ただし、個別の時間値を調べて、チャートがどのように反応するかを確認する場合は、タイム スライダーをチャートで使用することもできます。

  2. シーン ウィンドウでタイム スライダーを見つけ、[時間の無効化] ボタンをクリックします。

    タイム スライダーを無効化します。

  3. Gulf of Mexico シーンの [コンテンツ] ウィンドウで、[Sample_HYCOM_Go1] レイヤーを右クリックして [チャートの作成] にポインターを合わせ、[マトリックス ヒート チャート] を選択します。

    マトリックス ヒート チャートを作成します。

    空のマトリックス ヒート チャートが、右側の対応する [チャート プロパティ] パネルと共に、シーンの下に追加されます。

  4. 必要に応じて、チャートおよびプロパティ ウィンドウの位置を変更します。

    チャートおよびプロパティ ウィンドウの位置を変更してドッキングします。

  5. [チャート プロパティ] ウィンドウの [データ] タブで、以下を更新します。

    • [列カテゴリ] で、[StdTime] を選択します。
    • [行カテゴリ] で、[WellID] を選択します。
    • [集約] で、[最大値] を選択します。
    • [数値] で、[速度 (m/s)] を選択します。
    • [クラス] で、[3] を選択します。

    チャートのプロパティを設定します。

  6. [チャート プロパティ] ウィンドウで、[クラス閾値] を展開します。

    クラス閾値に流速のカットオフは反映されません。

    デフォルトのクラス閾値

    0.25、0.5、および 2.0 のカットオフを使用するための 3 つのクラス閾値を再構成し、色を 3D 方向矢印に一致させる必要があります。

  7. [チャート プロパティ] ウィンドウで [配色] ドロップダウン メニューをクリックし、[名前の表示] をオンにします。 [配色] ドロップダウン メニューから、[HYCOM Velocity Colors] の配色を選択します。

    HYCOM Velocity Colors の配色を選択します。

    HYCOM Velocity Colors の配色は、プロジェクト パッケージに含まれており、上側の値のカットオフの各々に設定されて緑色、黄色、赤色として表示されるように構成された 3 つの色のスタイルから成ります。

  8. [クラス] タブで、間隔ごとの上側の値を次のように更新します。

    • 緑色には、「0.25」と入力します。
    • 黄色には、「0.5」と入力します。
    • 赤色には、「2.0」と入力します。

    クラス間隔を更新します。

    わかりやすいチャートになりましたが、さらに書式設定すると、より明確になります。

    マトリックス ヒート チャートのシンボル表示

  9. [チャート プロパティ] ウィンドウの [書式設定] タブをクリックし、[シンボル エレメント] ボタンをクリックします。

    チャートの書式設定タブ

  10. [グリッド ライン] で、実線を選択します。 色には [50% グレー] を選択し、幅には [0.25pt] を選択します。

    チャートの表示プロパティを設定します。

    チャートが更新され、井戸と時間間隔が識別しやすくなります。

    チャート上の更新された井戸と時間間隔を確認します。

  11. [チャート プロパティ] ウィンドウで、[一般] タブをクリックし、以下のプロパティを更新します。

    • [チャートのタイトル] で、[Maximum of Velocity (m/s) for StdTime and WellID] を確認します。
    • [X 軸のタイトル] に「Time (UTC)」と入力します。
    • [Y 軸のタイトル] に「Well_ID」と入力します。
    • [凡例タイトル] に「Weekly (m/s)」と入力します。
    • [説明] に、「This chart shows the maximum ocean current velocity by Well ID in the Gulf of Mexico calculated from HYCOM between April 19 - April 25, 2021.」と入力します。

    一般的なチャートのプロパティを設定します。

  12. 必要に応じて、他のチャートのスタイルのオプションをカスタマイズします。 終了したら、終了したチャートを拡大し、セルと時間ステップを調べます。

    チャートの井戸の位置が西から東に (ループ海流に向かって) 移動するにつれて海流が変化しているはずです。

  13. チャートの下の画像から、[A] として識別される最も西の井戸 (番号 1 ~ 15) を見ると、これらの井戸の最大海流が 0.25 および 0.50 であり、ROV の動作限界内であることがわかります。

    チャートを使用して、井戸のアクセシビリティについて調査します。

  14. チャートの画像で [B] として識別される東部の井戸 (番号 16 ~ 26) に注目します。 これらの井戸すべてには、海流が強すぎて (2.0 以上) ROV の動作限界を超える期間が存在していることがわかります。

    海流をさらに詳細に調べると、画像で [C] として識別される井戸 (番号 27 ~29) の中には、完全にループ海流の内側にあるため、使用可能な動作のウィンドウが存在しないものがあります。 これは季節性のものであり、季節的変化の結果としてループがシフトするにつれ、動作限界が変化することがあります。

  15. シーンで、タイム スライダーを有効化し、時間データのサブセットに焦点を合わせ、時間をある 1 日に設定します。

    チャートが、ある 1 日の海流のみを表示するように反応します。 シーンとチャートの位置を変更し、井戸とチャートの両方を観察します。

    毎日のマトリックス ヒート チャートを確認します。

  16. プロジェクトを保存します。

このモジュールでは、67,200 個の海流の予測を、ROV の操作を計画するうえで役立つ、読みやすいチャートに集計しました。 HYCOM のノイズに兆候を見つけようとするプロセスを調査しつつ、「最初に概観し、ズームしてフィルタリングし、次に要求に応じて詳細化する」という Ben Shneiderman 博士の情報検索の格言をワークフローにおいて用いました。チャートを作成し (概観)、このチャートを使用してデータセットを単純化し、外れ値を検出しました (ズームおよびフィルタリング)。次に、対象となる特定の井戸の海流をアニメーション化すること (要求に応じた詳細化) によって、この格言 (とレッスン) を終了します。


3D での海流のアニメーション表示

このモジュールでは、1 周間にわたる海流の強度と方向の詳細な動力学を説明するために、HYCOM で時間のディメンションを使用して 1 つの井戸のアニメーションを作成します。 幸い、準備作業の半分は、サンプルのポイント上で時間を構成して有効化することによって実行されているため、実行するべき残りの作業は、井戸を拡大し、時間ステップを新しいアニメーションに読み込み、アノテーションを追加してエクスポートするだけです。

時系列をアニメーションに読み込む

  1. 必要に応じて、Gulf of Mexico シーンをアクティブにします。
  2. シーンのタイム スライダーで、[時間の無効化] ボタンをクリックして時間を無効化します。
  3. シーンのタイム スライダーで、[折りたたみ] ボタンをクリックします。

    タイム スライダーを非表示にします。

  4. [コンテンツ] ウィンドウで、[Well Tops] レイヤーをオンにして選択します。
  5. リボンの [表示設定] タブの [効果] グループにある [透過表示] で、[95%] を選択します。

    これによって、ほとんどの船舶または石油掘削装置が非表示になりますが、まだラベルを確認することができます。

    船舶の透過表示を設定します。

  6. [マップ操作] ツールを使用して、Well 20 (または選択した別の井戸) を調査します。 表示中の井戸の上半分をフレームで囲み、強い海流の大部分が存在する部分を表示します。

    対象の井戸を探索します。

  7. リボンの [表示] タブの [アニメーション] グループで、[追加] をクリックします。

    追加ボタンをクリックします。

    [アニメーション タイムライン] ウィンドウと [アニメーション プロパティ] ウィンドウが表示されます。 必要に応じてウィンドウの位置を変えます。

    ウィンドウの位置を変えます。

  8. [アニメーション タイムライン] ウィンドウで、[最初のキーフレームを作成] をクリックします。

    最初のキーフレームを作成します。

    シーン ウィンドウが更新され、アニメーションが出力ムービーの縦横比 (HD 720、HD 1080 など) でどのようにクリップされるかを示します。

    出力ムービーの縦横比を調べます。

    次に、ムービーのオプションから出力形式を選択します。

  9. リボン上の [アニメーション] タブにある [エクスポート] グループで、[ムービー] ボタンをクリックします。

    エクスポート オプション ウィンドウを表示します。

  10. [ムービーのエクスポート] ウィンドウの [ムービーのエクスポートの事前設定] から、[HD 1080] を選択します。

    ムービーのエクスポートの事前設定を選択します。

  11. リボンの [アニメーション] タブにある [エクスポート] グループで、[ビュー サイズのロック] ボタンをクリックします。

    これによって、選択された 1080 の縦横比に、シーン ビューを確実にクリップします。

    ビュー サイズをロックします。

  12. シーンを見直し、出力ムービーの縦横比がデータまたはラベルをクリップしていないことを確認します。 必要に応じて、ロックされたビューの表示に満足するまで、シーンを移動してフレームを変更します。
  13. [アニメーション タイムライン] ウィンドウの [キーフレーム ギャラリー] で、最初のテスト キーフレームを右クリックして [選択の削除] を選択します。

    最初のフレームを削除します。

  14. リボンの [アニメーション] タブの [作成] グループで、[インポート] ドロップダウン メニューをクリックして [タイム スライダーのステップ] を選択します。

    タイム スライスをフレームとしてインポートします。

    HYCOM の時系列は、56 ステップ (7 日 x 1 日あたり 8 回の計測) を含んでいます。 各ステップは、開始フレームと共にキーフレームとしてタイムラインに追加され、合計で 57 フレームになります。

    タイム スライスによって生成されたフレームを確認します。

    次に、タイムライン全体を選択します。

  15. 先頭のキーフレーム (#1) をクリックし、Shift キーを押しながら最後のキーフレーム (#57) までスクロールしてクリックします。

    アニメーションのフレームを選択します。

  16. リボンの [アニメーション] タブの [編集] グループで、[プロパティ] ボタンをクリックします (または、タイムライン内のフレームを右クリックして [アニメーション プロパティ] を選択します)。

    アニメーション プロパティ ボタン

    [アニメーション プロパティ] ウィンドウで、個別 (またはすべて) のキーフレームの長さを定義できます。 デフォルトでは、1 つのキーフレームにつき 3 秒の値が適用され、実行時間が 2:48 になります。 次に、30 秒未満になるようにムービーの実行時間を変更します。

  17. [アニメーション プロパティ] ウィンドウで、[長さ] の値を「0.25」秒に変更します。

    これによって、実行時間の合計が 14 秒になります。

    アニメーションの長さを設定します。

  18. プロジェクトを保存します。

アニメーション オーバーレイの追加

次に、オーバーレイをアニメーションに追加します。

  1. リボンの [アニメーション] タブにある [オーバーレイ] グループで、[オーバーレイの追加] ドロップダウン メニューをクリックします。 [ダイナミック テキスト] グループから [マップ時間] を選択します。

    オーバーレイをアニメーションに追加します。

    シーンで、開始および終了アノテーション テキストがオーバーレイとして追加されます。 ただし、データはステップごとに 1 つの時間値しか含みません。

    開始および終了アノテーション テキスト

  2. シーンのオーバーレイで、2 番目の終了タイムラインを選択して削除します。

    オーバーレイ テキストを選択して削除します。

  3. オーバーレイが次のテキストを含んでいることを確認します。
    <dyn type="animation" property="startTime" format="short|long"/>
  4. シーンで、[画面上の編集を終了して、変更を確定します] ボタンをクリックします。

    画面上の編集を終了して、変更を確定しますボタン

  5. [アニメーション プロパティ] ウィンドウで、[オーバーレイ] タブをクリックします。
  6. [開始キー][1] に設定されており、[終了キー] [57] に設定されていることを確認します。

    これによって、変更がアニメーション内のすべてのキーフレームに確実に適用されます。

  7. [設定] ボタンを使用して [テキスト シンボルの書式設定] ウィンドウを表示します。

    開始フレームと終了フレームを確認します。

  8. [テキスト シンボルの書式設定] ウィンドウで、必要に応じてフォントとサイズを変更して、テキストの表示設定を更新します。

    マップ時間オーバーレイのフォントとサイズを更新します。

  9. [オーバーレイ] タブで、キーフレームに表示するために、オーバーレイの事前に設定された 9 か所の位置のうちの 1 つを選択します。

    マップ時間オーバーレイの位置を設定します。

    [オーバーレイ] タブを使用して、タイトル、画像、またはその他のテキストをアニメーションのフレームに追加することができます。 ここではアニメーションをシンプルなままにしておき、後で試してみることができます。

  10. [マップ時間] オーバーレイが正常に書式設定されており、キーフレーム内の正しい位置に表示されていることを確認します。

    マップ時間オーバーレイを確認します。

  11. プロジェクトを保存します。
  12. リボン上の [アニメーション] タブにある [エクスポート] グループで、[ムービー] ボタンをクリックします。

    エクスポート ボタン

  13. [ムービーのエクスポート] ウィンドウの [ファイル名] で、選択した位置を参照し、出力名を指定します。
  14. [ファイル エクスポート設定] セクションの [メディア形式] で、[MPEG4 ムービー (mp4)] を選択します。
  15. [1 秒あたりのフレーム数] で、1 秒あたり [30] フレームを選択します。
  16. 終了したら、[エクスポート] ボタンをクリックします。

    アニメーション ムービーをエクスポーします。

    メモ:

    アニメーションのエクスポートは、プロセッサおよびビデオ カードに応じて、しばらく時間がかかります。 このプロセスの完了には 10 分~ 15 分程度かかる場合があります。

  17. [ムービーのエクスポート] ウィンドウで、[ビデオの再生] をクリックしてアニメーション ムービーを確認します。

    ビデオを再生します。

    アニメーションは、スクリーン キャプチャ、チャート、および対話型のシーンに加えて、特に HYCOM からサンプリングされたポイントなどの時間対応レイヤーを扱う場合に、3D で情報を伝えるための重要なツールの 1 つです。 これらの同じアニメーション手法を 2D または 3D で使用できます。 たとえば、特定の井戸の位置の代わりに、サンプルのポイントの等間隔のフィッシュネットを使用して、海洋の表層流と温度における地域的変化を観察することができます。

    この 48 時間のアニメーションでは、2019 年にハリケーン ドリアンが、ほぼ停止してバハマ諸島を壊滅させた後に、東海岸を上に移動します。

    ハリケーン ドリアンを矢印で表示するアニメーション

このレッスンでは、メキシコ湾での ROV のミッションを計画するために、HYCOM 多次元ラスター データセットから海流の予測を抽出してサンプリングする方法について説明しました。 その過程で、u および v 海流変数を理解しやすい 3D シンボルに変換し、概略的なマトリックス ヒート チャートを作成して、完全なデータセットの ROV の潜水ウィンドウを要約し、1 つの井戸を選んで、時系列にわたる海流の変化を詳細に調べました。 これらのワークフローおよびツールを、他の HYCOM の変数または任意のその他の多次元データセットに適用して、時空間における複雑な地球のプロセスを深く理解することができます。