標高モデルの事前処理

解析を開始する前に、バーモント州ストウのデジタル標高モデル (DEM) を事前処理して、結果でエラーが発生する可能性を低くします。DEM にはシンクが含まれている場合があります。シンクは、高い標高値に囲まれた低い標高のエリアです。シンクは自然に発生しますが、多くの場合に DEM ラスター データセットでデータ エラーになります。水はシンクから流出しないため、流出点への水の流れ方を解析するときに、シンクはあらゆる種類のエラーを引き起こす可能性があります。ストウでの洪水の水文解析を始める前に、標高データのシンクを特定して削除します。

プロジェクトをダウンロードして開く

まず、バーモント州政府が提供するストウに関するデータと、USGS (米国地質調査所) のデータから取得した DEM をダウンロードします。このデータは、ArcGIS Pro のプロジェクトに含まれています。プロジェクト ファイルには、ワークフローをステップごとに実行できるタスクも含まれています。

  1. [Stowe_Hydrology] 圧縮フォルダーをダウンロードします。
  2. コンピューター上で、ダウンロードしたファイルを選択します。
    備考:

    お使いの Web ブラウザーによっては、ダウンロードを開始する前に、ファイルの場所を選択するよう求めるメッセージが表示される場合があります。ほとんどのブラウザーでは、デフォルトでコンピューターの [ダウンロード] フォルダーがダウンロード先の場所になります。

  3. ファイルを右クリックして、[ドキュメント] フォルダーなどの見つけやすい場所にファイルを展開します。
  4. 展開したフォルダーを開き、[Stowe_Hydrology] フォルダーを開きます。
    フォルダーには、ArcGIS Pro の [Stowe_Hydrology] プロジェクト ファイル、[Stowe_Hydrology] ジオデータベース、および自走生成された [Index] フォルダーなどがあります。プロジェクトを開きます。
  5. コンピューターに ArcGIS Pro がインストールされている場合は、[Stowe_Hydrology.aprx] をダブルクリックしてプロジェクトを開きます。サイン インを求められたら、ライセンスが割り当てられた ArcGIS アカウントを使用してサイン インします。
    備考:

    ArcGIS Pro または ArcGIS アカウントがない場合、ArcGIS の無料トライアルにサイン アップできます。

    バーモント州ストウを表示するデフォルト プロジェクト

    プロジェクトには、地形図ベースマップと複数のデータ レイヤーが含まれています。これらのレイヤーには、次のものがあります。

    • Pour_point - Little River の下流の流出点を表すポイント フィーチャ レイヤー。この流出点の単位流量図を作成します。
    • Stowe_boundary - バーモント州ストウの境界線を表すポリゴン フィーチャ レイヤー。このレイヤーは、Vermont Center for Geographic Information (VCGI) のデータから取得しました。
    • Stowe_surface_water - 対象地域のすべての地表水域を表すラスター レイヤー。このラスター レイヤーの解像度は 30 メートルです。つまり、レイヤーの各セルの面積は 30 平方メートルです。このレイヤーは、NHDPlus バージョン 2 データセットのフィーチャから取得しました。
    • Stowe_DEM - 分析範囲内の標高を表すラスター レイヤー。この解像度も 30 メートルです。これは、USGS (米国地質調査所) のデータから取得しました。
    • Stowe_velocity_example - 空間的に変化し、時間と流出は変化しない分析範囲の速度フィールドを表すラスター レイヤー。このレイヤーの作成方法は、後のレッスンで学びます (この例はバックアップとして提供されています)。現在のところ、このレイヤーは必要ないのでオフになっています。

    マップ上にありませんが、プロジェクト フォルダー ([Stowe_Hydrology]) には Stowe_isochrones というテキスト ファイルが含まれています。これには、後のレッスンで作成する同時線ゾーンの分類範囲が含まれています。

    ストウの DEM を確認したので、結果が隠れないようにオフにします。

  6. [コンテンツ] ウィンドウで、[Stowe_DEM] をオフにします。
    備考:

    ArcGIS Pro のデフォルト構成によっては、[コンテンツ] ウィンドウが開いていない場合があります。必要に応じて、リボンの [表示] タブをクリックします。[ウィンドウ] グループで、[コンテンツ] をクリックします。

    [Stowe_DEM] レイヤーをオフにします

    次に、プロジェクトに含まれている ArcGIS Pro のタスクを開きます。このタスクは、単位流量図を作成するのに必要なワークフローを段階的に実行します。

  7. [カタログ] ウィンドウで [タスク] フォルダーを展開します。
    備考:

    [カタログ] ウィンドウが開いていない場合は、[表示] タブの [ウィンドウ] グループで [カタログ ウィンドウ] をクリックします。

    [タスク] フォルダーを展開します

  8. [Create unit hydrograph at outlet] タスクをダブルクリックします。

    [タスク] ウィンドウが表示されます。このタスクには、ワークフローの特定の部分に使用される複数のタスクが格納されています。

シンクの特定

まず、DEM 内のシンクを特定します。この DEM は USGS が提供する信頼できるデータから取得しましたが、それでもシンクは存在します。ストウ周辺のエリアで正確な水文解析を実行するために、まずシンクを特定する必要があります。

  1. [タスク] ウィンドウで [Precondition the elevation model] タスクをダブルクリックします。

    [Precondition the elevation model] タスク

    このタスクが開きます。それぞれのタスクでは、作業手順が示されます。このタスクは 3 つのステップから構成されています (ウィンドウ下部の進行状況バーにステップの合計数が表示されます)。最初のステップでは、[流向ラスターの作成 (Flow Direction)] ツールを開きます。エリアのフロー方向を求めることで、水が流出できないエリアであるシンクを特定できます。

  2. [入力サーフェス ラスター][Stowe_DEM] を選択します。
  3. [出力流向ラスター] で、テキスト ボックスをポイントして、出力場所が [Stow_Hydrology] ジオデータベースであることを確認します。出力名を「Stowe_flow_direction」に変更します。

    [流向ラスターの作成 (Flow Direction)] ツールのパラメーター

    残りのパラメーターは解析に関係ないため、そのままにしておきます。

    ヒント:

    パラメーターの詳細については、パラメーターをポイントして、情報ボタンをポイントします。

  4. [実行] をクリックします。

    ツールが実行され、流向ラスター レイヤーがマップに追加されます。

    Stowe_flow_direction レイヤー

    レイヤーのシンボルは、水が流れる可能性が高い方向と対応しています。暗い色は南方向のフロー、明るい色は北方向のフローであることを示しています。流向レイヤーに基づいてシンクを自動的に検出する別のツールを実行するため、このレイヤーの表示設定は解析に重要ではありません。

  5. 必要に応じて、[コンテンツ] ウィンドウを開きます。[Stowe_flow_direction] レイヤーをオフにします。
    備考:

    [タスク] ウィンドウが [コンテンツ] ウィンドウに重なっている可能性があります。その場合は、アクティブなウィンドウの下部で該当するタブをクリックして、ウィンドウを切り替えることができます。

  6. 必要に応じて、[タスク] ウィンドウに戻ります。
    タスクの最初のステップを完了したら、次のステップに自動的に進みます。次のステップでは、[窪地の抽出 (Sink)] ツールを使用して、流向レイヤー内の内部排水のエリア (シンク) を特定します。
  7. [入力 D8 流向ラスター][Stowe_flow_direction] を選択します。
  8. [出力ラスター] で、出力先の場所が [Stowe_Hydrology] ジオデータベースになっていることを確認し、出力名を「Stowe_sinks」に変更します。

    [窪地の抽出 (Sink)] ツールのパラメーター

  9. [Run] をクリックします。

    ツールが実行され、シンク ラスターがマップに追加されます。新しいレイヤーは、ほとんどが黒いピクセルの小さなグループなので、デフォルトのシンボルではわかりにくいかもしれません。シンボルを変更して、シンクを確認しやすくします。

  10. [コンテンツ] ウィンドウで、[Stowe_sinks] レイヤーを右クリックし、[シンボル] を選択します。

    [Stowe_sinks] のシンボル

    [シンボル] ウィンドウが表示されます。

  11. [配色] で、黄色から赤色の配色を選択します。

    黄から赤の配色

  12. [シンボル] ウィンドウを閉じます。

    シンクがベースマップに対して目立つようになりましたが、まだ小さくてわかりにくいです。

  13. 流出点 (赤の円) の近くにズームして、いくつかのシンクを確認します。

    流出点近くのシンク

  14. ストウの周辺を画面移動して、マップを探索します。

    シンクは、Stowe_surface_water レイヤーで識別される河川ネットワークと水域の周辺に主に表示されているようです。既存の水は平らである傾向があり、シンクなどの DEM ではエラーの原因となる可能性があります。

  15. [コンテンツ] ウィンドウで、[Stowe_DEM] レイヤーを右クリックして [レイヤーにズーム] を選択します。[Stowe_sinks] レイヤーをオフにします。

    マップが分析範囲に戻ります。

シンクの平滑化

DEM 内でシンクが存在する位置を特定したら、シンクを削除した DEM を作成します。新しい DEM では、すべてのシンクが、シンクの横にある最も低いセルの標高値に変更されます。新しい DEM では、各セルは、データセットのエッジに向かう、少なくとも 1 つの連続減少セル パスの一部になります。この新しい DEM によって、ストウ地域のより正確な水文解析が実行できます。

  1. 必要に応じて、[タスク] ウィンドウに戻ります。

    現在のタスクの最後のステップでは、[サーフェスの平滑化 (Fill)] ツールを使用して、DEM からシンクを削除します。

  2. [入力サーフェス ラスター][Stowe_DEM] を選択します。
  3. [出力サーフェス ラスター] で、出力先の場所が [Stowe_Hydrology] ジオデータベースになっていることを確認し、出力名を「Stowe_fill」に変更します。

    [サーフェスの平滑化 (Fill)] ツールのパラメーター

    最後のパラメーター [Z 制限] では、シンクを平滑化するための最大標高差を設定できます。シンクとそのエッジの標高差がこの制限より大きい場合、そのシンクは平滑化されません。データ内のすべてのシンクを平滑化するため、これらのパラメーターはそのままにしておきます。

  4. [完了] をクリックします。

    ツールが実行され、平滑化された DEM がマップに追加されます。これは元の DEM とほとんど同じに見えますが、データセット内のシンクが平滑化されています。このレイヤーは、後で実行するストウ周辺の水文状態解析の基盤として使用されます。

  5. [クイック アクセス ツールバー] で、[保存] ボタンをクリックして、プロジェクトを保存します。

    [保存] ボタン

このレッスンでは、一連のジオプロセシング ツールを使用して、生の DEM 内にあるシンクを特定しました。次に、シンクを調査し、ほとんどが標高データが十分でないために、地表水域付近で発生していることがわかりました。最後に、データセット内のシンクを平滑化しました。次のレッスンでは、新しい DEM を使用して、ストウの集水域を特定します。この集水域を把握することで、町の周囲で水がどのように累積されるかを解明できます。


集水域の定義

前のレッスンでは、水文解析に使用できるように DEM からシンクを削除しました。このレッスンでは、DEM を使用してストウの南部にある流出点の集水域を求めます。集水域エリアは、すべての流水が特定ポイント (この場合は流出点) に向かうエリアです。集水域エリアを使用することで、以降の解析結果を流出点に関連するエリアに制限できます。集水域を求めるには、フロー方向ラスター レイヤーと正確な流出点という 2 つの要素が必要です。

フロー方向の評価

集水域を定義する最初のステップでは、DEM で水が流れる方向を求めます。これにより、水が流出点に流れるエリアを判定できます。そのために、今回はシンクを埋めた DEM で、別のフロー方向ラスター レイヤーを作成します。

  1. 必要に応じて、ArcGIS Pro[Stowe_Hydrology] プロジェクトと [Create unit hydrograph at outlet] タスクを開きます。
  2. [タスク] ウィンドウで [Delineate the watershed] タスクをダブルクリックします。

    [Delineate the watershed] タスク

    このタスクは 5 つのステップから構成されます。最初のステップでは、[流向ラスターの作成 (Flow Direction)] ツールを開きます。このツールを使用して、以前はシンクを特定しましたが、今回は集水域エリアを求めるために重要な中間レイヤーを作成します。

  3. [入力サーフェス ラスター][Stowe_fill] を選択します。
  4. [出力流向ラスター] で、出力先の場所が [Stowe_Hydrology] ジオデータベースになっていることを確認し、出力名を「Stowe_fill_flow_direction」に変更します。

    [流向ラスターの作成 (Flow Direction)] ツールのパラメーター

    前回と同様に、残りのパラメーターはそのままにしておきます。

  5. [実行] をクリックします。

    ツールが実行され、新しいレイヤーがマップに追加されます。

    Stowe_fill_flow_direction レイヤー

    前のフロー方向ラスターは黒と白でシンボル表示されましたが、このレイヤーは色付きでシンボル表示されます (使用される色はランダムなので、画像例とは異なる場合があります)。

  6. [コンテンツ] ウィンドウを開きます。必要に応じて、矢印をクリックして [Stowe_fill_flow_direction] レイヤーを展開します。

    Stowe_fill_flow_direction のシンボル

    通常、フロー方向ラスター レイヤーのセル値は 8 つの整数 (1、2、4、8、16、32、64、128) のいずれかになります。これら 8 つの整数は、8 つのフロー方向に対応しています (指定されたセルの周囲に 8 つのセルがあります)。ただし、前のフロー方向レイヤーには、この 8 つの整数のどれでもない値がありました。それらは、後でデータから削除したシンクの値でした。元のフロー方向レイヤーには幅広い値があったため、カラー ランプに基づいて自動的にシンボル表示され、デフォルトの黒と白の配色が使用されました。新しいフロー方向レイヤーには 8 つの値しかないため、各値に一意の色を使用して自動的にシンボル表示されました。

流出点の河川へのスナップ

フロー方向レイヤーは、集水域を求めるための最初の要素です。もう 1 つの要素は、流出点の位置です。プロジェクトと一緒にダウンロードしたレイヤーの 1 つに Pour_point レイヤーがあります。このレイヤーは、バーモント州ストウの下流の流出点を表しています。正確な集水域を求めるために、流出点は DEM で描画されている河川の上に正確に位置する必要があります (現在の位置は、DEM の解像度や他の正確性の欠如から、河川の実際の位置と少し異なっている可能性があります)。まず、水が最も累積するエリアを計算して、河川の厳密な位置を求めます。次に、流出点の位置を河川と厳密に一致するようにスナップします。

  1. [タスク] ウィンドウを開きます。

    タスクの 2 番目のステップでは、[累積流量ラスターの作成 (Flow Accumulation)] ツールを開きます。このツールは、水が累積する可能性が最も高い位置を示すラスター レイヤーを作成します。各セルの累積流量は、そのセルに流れ込むセルの数に基づいた数値で表現されます。多くの場合、累積値が高いセルは流水域の位置と一致します。累積流量ラスターを使用して、ストウを流れる Little River を特定します。

  2. [入力流向ラスター] で、[Stowe_fill_flow_direction] を選択します。
  3. [出力累積流量ラスター] で、出力先の場所が [Stowe_Hydrology] ジオデータベースになっていることを確認し、出力名を「Stowe_flow_accumulation」に変更します。

    [累積流量ラスターの作成 (Flow Accumulation)] ツールのパラメーター

    残りのパラメーターはそのままにしておきます。これらのパラメーターの最初は、加重値を各セルに適用します。これは、排水が一様ではないと予想される場合に役立ちます (たとえば、分析範囲が広い場合、降水レベルは大きく変動する可能性があります)。2 つ目のパラメーターは、整数と浮動小数点のどちらで累積を計測するかを決定します。デフォルト値の浮動小数点では、小数点以下を計測できるため、ほとんどの状況でより正確になります。3 つ目のパラメーターは、入力流向を決定します。

  4. [Run] をクリックします。

    ツールが実行され、累積流量ラスター レイヤーがマップに追加されます。

    Stowe_flow_accumulation レイヤー

    累積流量が最も大きなセルは白で表示されます。流出点を通過している白のセルからなる薄いラインは Little River です。タスクの次のステップでは、[距離の計測] ツールを使用します (このツールはジオプロセシング ツールではなく、リボン上のツールです)。このツールを使用して、現在の流出点と累積流量ラスターに表示された Little River の位置の距離を計測します。その後、この距離を使用して、流出点が河川の上に位置するように流出点を正しいセルにスナップできます。

    計測を実施するには、流出点の近くにズームする必要があります。ただし、[マップ操作] ツールが [距離の計測] ツールに置き換えられるため、ナビゲーション機能は低下します。キーボード ショートカットを使用してズームできます。

  5. Z キーを押したままにします。マップをドラッグして、流出点を拡大します
    ヒント:

    マップを移動するには、C キーを押したままにします。

    デフォルトの流出点

    流出点は河川の位置と近いですが、完全には一致していません。マップで使用されている計測単位であるメートル単位で正確な距離を計測します。

  6. 必要に応じて、[距離の計測] ウィンドウで、表示単位を [メートル法] に設定します。

    距離単位 (メートル)

  7. マップ上の流出点をクリックします。次に、累積流量値が高い、最も近いセルの中央をダブルクリックします。

    流出点の計測

    [距離の計測] ツールのウィンドウが更新され、計測した長さが表示されます。計測値は約 50 メートルです (少し異なる可能性がありますが、大体の値でかまいません)。計測値に基づき、流出点を河川にスナップするときに 60 メートルの距離を使用します。計測距離より少し大きなスナップ距離を使用すると、ツールであいまいさを避けることができます。スナップ距離を決める際に計測距離を大きく超えないようにしてください。値が大きすぎると、さらに下流のエリアに流出点がスナップする可能性があります。

  8. リボンの [マップ] タブの [ナビゲーション] グループで、[マップ操作] ボタンをクリックします。

    計測値がマップから削除されます。これで、通常のナビゲーションが可能になりました。

  9. [タスク] ウィンドウで [次のステップ] をクリックします。

    次のステップでは、[流出点のスナップ (Snap Pour Point)] ツールを開きます。このツールは、指定した距離 (この場合は 60 メートル) 内で累積流量が最も大きいセルに流出点を自動的にスナップします。

  10. [流出点データとして使用する入力ラスター、またはフィーチャ] で、[Pour_point] を選択します。[入力累積ラスター][Stowe_flow_accumulation] を選択します。
  11. [出力ラスター] で、出力先の場所が [Stowe_Hydrology] ジオデータベースになっていることを確認し、出力名を「Stowe_snapped_outlet」に変更します。
  12. [スナップ距離]60 を入力します。

    [流出点のスナップ (Snap Pour Point)] ツールのパラメーター

  13. [Run] をクリックします。

    ツールが実行され、スナップされた流出点ラスター レイヤーがマップに追加されます。ラスターには、流出点の新しい位置を表す 1 つのセルが表示されます。この画像例では、スナップされた流出点は青のセルで表示されていますが、色はランダムなので実際の結果と異なる場合があります。

    Stowe_snapped_outlet レイヤー

  14. [コンテンツ] ウィンドウで、[Stowe_flow_accumulation] レイヤーを右クリックして [レイヤーにズーム] を選択します。

    マップがデータの全範囲に戻ります。

流出点の上流にある集水域エリアの定義

フロー方向レイヤーと正確な流出点レイヤーが用意できたので、流出点の上流にある集水域エリアを求めることができます。タスクの最後のステップでは、[集水域ラスターの作成 (Watershed)] ツールを開きます。

  1. [タスク] ウィンドウの [入力 D8 流向ラスター] で、[Stowe_fill_flow_direction] を選択します。[流出点データとして使用する入力ラスター、またはフィーチャ] で、[Stowe_snapped_outlet] を選択します。
  2. [出力ラスター] で、出力先の場所が [Stowe_Hydrology] ジオデータベースになっていることを確認し、出力名を「Stowe_watershed」に変更します。

    [集水域ラスターの作成 (Watershed)] ツールのパラメーター

  3. [完了] をクリックします。

    ツールが実行され、新しいラスター レイヤーがマップに追加されます。新しいレイヤーのシンボルを変更して、そこから意味を発見します。

  4. [コンテンツ] ウィンドウで、[Stowe_watershed] レイヤーを右クリックし、[シンボル] をクリックします。
  5. [シンボル] ウィンドウの [プライマリ シンボル] の下で、シンボル化の方法を [個別値] に変更します。ウィンドウの下側にある [値] タブで、カラー パッチをクリックして、カラー パレットから色を選択します。

    Stowe_watershed レイヤー

    この集水域は、指定した流出点に流れ込むすべてのエリアを表しています。集水域は、ストウ町の境界のほとんど全部から構成されています。これは、ストウに降るほぼすべての雨が、外に流出せずに実際の町を通過することを示しています。

  6. [コンテンツ] ウィンドウで、次のレイヤーをオフにします。
    • Stowe_surface_water
    • Stowe_fill
    • Stowe_fill_flow_direction
    • Stowe_snapped_outlet
    ヒント:

    オフにしたレイヤーのシンボルを折りたたむと、ウィンドウ内に多くのレイヤーを表示できます。

  7. プロジェクトを保存します。

このレッスンでは、バーモント州ストウにおける水の流れ方を求めました。結果に基づき、流出点を DEM の Little River の位置にスナップしました。フロー方向レイヤーと流出点から、町の上流にある集水域の位置を求めました。次のレッスンでは、いくつかの水文レイヤーと標高レイヤーを使用して、水が流出点に流れる速さを求めます。


速度フィールドの作成

前回のレッスンでは、ストウ地域の集水域を作成しました。これは、以降の多くの解析で分析範囲として使用します。次に、水が流出点に到達するまでにかかる時間を求めます。これにより、町は仮想的な降雨イベント中に洪水がいつ発生するかについて、より正しく予測できます。どこかに水が流れるのにかかる時間を求めるには、まず水が流れる速度を求める必要があります。流水速度は、もう 1 つのタイプのラスター レイヤーである速度フィールドを使用して計算します。速度フィールドには多くの種類があり、さまざまな数式を使用して計算できます。空間的に変化するが、時間と流出は不変な速度フィールドを作成します。つまり、速度フィールドには、次の仮定を設定します。

  • 速度は、傾斜角や累積流量など (空間的に変化する) 空間コンポーネントに影響されます。
  • 所定の位置における速度は、時間の経過とともに変化しません (時間的に不変)。
  • 所定の位置における速度は、その位置の流水率に依存しません (流出は不変)。

実際には、速度は時間的に変化し、流出も確実に変化するでしょう。しかし、これらの変量を組み込むには、入手できるかわからないデータセットを追加する必要があり、GIS 環境では再現できないかもしれないモデリング技術を使用することになるでしょう。空間的に変化し、時間と流出は変化しない速度フィールドは、一般的に正確な結果を提供します。ただし、どのような方法も観測される現象の近似にすぎないことに注意してください。

Maidment 等が最初に提案した速度フィールドの作成方法 (1996) を使用します。[1] この方法では、速度フィールドの各セルに、地域の傾斜角と上流の流出寄与域 (そのセルに流れ込むセルの数、または累積流量) に基づく速度が割り当てられます。次の式を使用します。

V = Vm * (sbAc) / (sbAcm)    (1)

V は 1 つのセルの速度、s は地域の傾斜角、A は上流の流出寄与地域です。係数 b および c はキャリブレーション (予測データを観測データとできる限り近づけるために、モデル パラメーターを微調整する統計的手法) によって求めることができます。このシナリオでは、この方法の推奨値は b = c = 0.5 です。Vm は、集水域内のすべてのセルの平均速度です。平均速度 Vm = 0.1 m/s と仮定します。最後に、sb Acm は、集水域全体の平均傾斜角-地域項です。非現実的に速い/遅い結果を避けるために、速度の下限と上限を設定します。下限は毎秒 0.02 メートル、上限は毎秒 2 メートルにします。

この式は速度フィールドを計算できる多くの方法の 1 つにすぎず、さまざまな仮定と制限が伴います。さらに、このワークフローは多変数方程式の使用によって複雑になる可能性があります。このレッスンを完了するのをサポートするために、Stowe_velocity_example という速度フィールドのバックアップ コピーが提供されています。

傾斜角ラスターの作成

速度フィールドに使用する方程式の主な変数は、傾斜角と上流の流出寄与地域です。上流の流出寄与地域のラスター レイヤーは、前回のレッスンで作成した累積流量レイヤーなので、すでに存在します。傾斜角レイヤーはまだないので作成します。

  1. 必要に応じて、ArcGIS Pro[Stowe_Hydrology] プロジェクトと [Create unit hydrograph at outlet] タスクを開きます。
  2. [タスク] ウィンドウで [Create a velocity field] タスクをダブルクリックします。

    [Create a velocity field] タスク

    このタスクには 5 つのステップがあります。最初のステップでは、[傾斜角 (Slope)] ツールを開きます。このツールは、各セルの値がそのセルの傾斜角であるラスター レイヤーを計算します。傾斜角は、セル間の標高の変化から求めるため、入力として元の標高レイヤーが必要です。

  3. [入力ラスター][Stowe_DEM] を選択します。
  4. [出力ラスター] で、出力先の場所が [Stowe_Hydrology] ジオデータベースになっていることを確認し、出力名を「Stowe_slope」に変更します。
  5. [出力単位] で、[勾配率] を選択します。

    [傾斜角 (Slope)] ツールのパラメーター

    [勾配率] 計測オプションは、度単位での計測と異なり、垂直方向の標高に対する水平方向の標高の割合として傾斜角を計算します。残りのパラメーターはそのままにしておきます。ローカル縮尺のエリア (この集水域のような小さなエリア) は、平面方法と測地線方法の傾斜角の相違が最小限であるため、平面方法の使用が適しています。Z 係数は、X および Y の距離を計測する単位が Z (高さ) の距離を計測する単位と異なる場合のみ使用されます。

  6. [実行] をクリックします。

    ツールが実行され、傾斜角ラスターがマップに追加されます。

    Stowe_slope レイヤー

    色が暗いほど、傾斜角が大きくなります。山頂は傾斜角が最も大きくなる傾向があり、町の周囲にある河床は傾斜が比較的平坦になります。

傾斜角-地域項の計算

傾斜角と累積流量地域のラスター レイヤーが用意できたので、それらを組み合わせた新しいラスター レイヤーを計算します。このレイヤーは、傾斜角-地域項 (Maidment 等の方程式の値 sb Ac) を示します。タスクの次のステップでは、[ラスター演算 (Raster Calculator)] ツールを開きます。このツールでは、指定した式に基づいてカスタマイズされたラスター レイヤーを作成できます。

  1. [マップ代数演算式] で、[ツール][ラスター] を使用して、次の条件式を作成します。

    SquareRoot("Stowe_slope") * SquareRoot("Stowe_flow_accumulation")

    ヒント:

    条件式をコピーして貼り付けることもできます。

    傾斜角と累積流量の平方根を求めるのは、Maidment 等の推奨係数 (b = c = 0.5) を使用しているためです。係数 0.5 は値の平方根に相当します。

  2. [出力ラスター] で、出力先の場所が [Stowe_Hydrology] ジオデータベースになっていることを確認し、出力名を「Stowe_slope_area_term」に変更します。

    [ラスター演算 (Raster Calculator)] ツールのパラメーター

    最後に、ジオプロセシング ツールの環境を変更して、出力レイヤーをストウの集水域の範囲でマスク (制限) します。そうすることで、速度フィールドの方程式の重要なコンポーネントである、集水域全体の平均傾斜角-地域項を後で計算することができます。

  3. ツール パラメーターの上にある [環境] をクリックします。[マスク] で、[Stowe_watershed] を選択します。

    [ラスター演算 (Raster Calculator)] ツールの環境

  4. [実行] をクリックします。

    ツールが実行され、レイヤーがマップに追加されます。

    Stowe_slope_area_term レイヤー

速度フィールドの計算

傾斜角-地域項を求めたので、次の式を使用して速度フィールドを計算できます。

V = Vm (sb Ac) / (sb Acm)    (1)

前述したように、Vm は、集水域内にあるすべてのセルの平均速度です。Maidment 等が推奨する Vm = 0.1 の想定平均値を使用します。同様に、sb Acm は、集水域全体の平均傾斜角-地域項です。集水域の傾斜角-地域項は計算してあるため、想定値に基づかずに厳密な平均値を求めることができます。

  1. [コンテンツ] ウィンドウで、[Stowe_slope_area_term] を右クリックし、[プロパティ] を選択します。

    傾斜角-地域項レイヤーの [レイヤー プロパティ] ウィンドウが開きます。

  2. [ソース] タブをクリックし、[統計情報] の見出しを展開します。

    [レイヤー プロパティ] ウィンドウの [ソース] タブ

    ウィンドウに、平均など、レイヤーのさまざまな重要な統計情報がリストされます。

  3. [平均] 値をクリップボードにコピーします。[レイヤー プロパティ] ウィンドウを閉じます。
  4. [タスク] ウィンドウに戻ります。

    タスクの次のステップでも、[ラスター演算 (Raster Calculator)] ツールを使用します。

  5. [マップ代数演算式] で、次の条件式を作成します。

    0.1 * ("Stowe_slope_area_term" / [Mean slope-area term])

    [Mean slope-area term] は、[レイヤー プロパティ] ウィンドウからコピーした値です。

  6. [出力ラスター] で、出力先の場所が [Stowe_Hydrology] ジオデータベースになっていることを確認し、出力名を「Stowe_velocity_unlimited」に変更します。

    [ラスター演算 (Raster Calculator)] ツールのパラメーター

  7. [実行] をクリックします。

    ツールが実行され、レイヤーがマップに追加されます。新しいレイヤーは、傾斜角-地域項レイヤーのセルと固定値を乗算して計算したため、傾斜角-地域項レイヤーと似ています。

  8. 必要に応じて、[コンテンツ] ウィンドウで、[Stowe_slope_area_term] レイヤーと [Stowe_velocity_unlimited] レイヤーのシンボルを展開します。

    2 つのレイヤーのシンボル

    レイヤー シンボルの値は、2 つのレイヤーが表示は同じでも異なることを示しています。

速度の制限

作成したラスター レイヤーは速度フィールドですが、非現実的に高い速度と低い速度が含まれています。たとえば、フィールドの一部の値は速度が 0 メートル/秒で、激しい降雨イベント中には考えにくい値です。同様に、約 7.5 メートル/秒という最大値は、大洪水の最中でも非現実的です。速度フィールドの下限を 0.02 メートル/秒、上限を 2 メートル/秒に制限します。

  1. [タスク] ウィンドウに戻ります。

    タスクの次のステップでは、[Con] ツールを使用します。このツールは、指定した条件式に基づいて、ラスター レイヤー内の値の条件評価を実行します。まず、速度の下限を設定します。

  2. [入力条件ラスター][Stowe_velocity_unlimited] を選択します。
  3. [条件式][新しい条件式] をクリックします。「値が 0.02 以上である」という句を作成します。

    [Con] ツールの下限の条件式

    次に、条件式が true の場合に各セルに使用する値を追加します。値が 0.02 以上である場合は、その値のままにするため、入力ラスターと同じラスター レイヤーを選択します。

  4. [条件式が TRUE のときの入力ラスター、または定数値][Stowe_velocity_unlimited] を選択します。

    セルの条件式が false (セル値が 0.02 未満) の場合、セル値を 0.02 に変更します。

  5. [条件式が FALSE のときの入力ラスター、または定数値] に「0.02」と入力します。
  6. [出力ラスター] で、出力先の場所が [Stowe_Hydrology] ジオデータベースになっていることを確認し、出力名を「Stowe_velocity_lower_limited」に変更します。

    [Con] ツールの下限のパラメーター

  7. [実行] をクリックします。

    ツールが実行され、新しいレイヤーがマップに追加されます。新しいレイヤーは、さらに上限を追加する必要があるため、中間レイヤーにすぎません。タスクの最後のステップでも、[Con] ツールを使用します。

  8. [入力条件ラスター][Stowe_velocity_lower_limited] を選択します。
  9. [条件式][VALUE] [以下] [2] という条件式を追加します。
  10. [条件式が TRUE のときの入力ラスター、または定数値][Stowe_velocity_lower_limited] を選択します。[条件式が FALSE のときの入力ラスター、または定数値] に「2」と入力します。
  11. [出力ラスター] で、出力先の場所が [Stowe_Hydrology] ジオデータベースになっていることを確認し、出力名を「Stowe_velocity」に変更します。

    [Con] ツールの上限のパラメーター

  12. [完了] をクリックします。

    ツールが実行され、完成した速度フィールド レイヤーがマップに追加されます。

    Stowe_velocity レイヤー

    このレイヤーでは、色が暗いほど速度が遅くなり、色が明るいほど速度が速くなります。水は河川で最も速く流れる傾向があり、最大水量が累積されます。ストウの周辺地域も例外ではなく、町の下流の流出点に集まるときに、水の流れは最も速くなります。

  13. [コンテンツ] ウィンドウで、次のレイヤーをオフにします。
    • Stowe_flow_accumulation
    • Stowe_watershed
    • Stowe_slope
    • Stowe_slope_area_term
    • Stowe_velocity_unlimited
    • Stowe_velocity_lower_limited
  14. プロジェクトを保存します。

このレッスンでは、空間的に変化し、時間と排出は変化しない速度フィールドを、累積流量と傾斜角のラスター レイヤーから導きました。そのために、速度フィールドを計算できる多くの式の中から 1 つを使用しました。仮想的な降雨イベント中にストウを通過する水の速度がわかったので、次のレッスンでは、水が流出点に到達するまでにかかる時間を求めます。


同時線マップの作成

前回のレッスンでは、累積流量と集水域のレイヤーを使用して、バーモント州ストウを流れる水の速度を予測する速度フィールドを作成しました。速度フィールドによって、水は町を通過する河川に沿って最も速く流れることがわかりました。しかし、流出点に大量の水が流入するのにかかる時間がわからないため、単位流量図は作成できません。このレッスンでは、同時線マップを作成します。これは、指定した位置にエリア内の他の場所から到達するのにかかる時間をマッピングします。同時線マップを作成するには、まず加重グリッドを作成します。次に、水が流出点に到達するのにかかる時間を評価し、その時間を同時線ゾーンに再分類します。

加重グリッドの作成

流水時間は、水が流れる長さを流水速度で除算するという比較的単純な式で計算されます。流水速度は速度フィールドによってわかりますが、流長はわかりません。フローの長さを求めるには、流向 (既知) と加重値 (不明) の 2 つの変数が必要です。流水におけるウェイトはインピーダンスを表します。たとえば、森林を流れる水は、地形が障害となって滑らかな岩盤を流れる水より時間がかかります。加重値の計算は詳細な地形データがなければ難しいように思われますが、フロー時間を求める次の 2 つの式に基づいて計算式を導くことができます。

Flow time [T] = Flow Length [L] / Velocity [LT-1]    (1)

Flow time [T] = Flow Length [L] * Weight [L-1T]    (2)

これらの式を組み合わせると、新しい式ができます。

Weight [L-1T] = 1 / Velocity [LT-1]    (3)

このようにして、速度フィールド レイヤーを使用して加重値を求めることができます。後で、加重グリッド レイヤーをフロー方向レイヤーとともに使用して、フローの長さとフロー時間を求めます。

  1. 必要に応じて、ArcGIS Pro[Stowe_Hydrology] プロジェクトと [Create unit hydrograph at outlet] タスクを開きます。
  2. [タスク] ウィンドウで [Create an isochrone map] タスクをダブルクリックします。

    [Create an isochrone map] タスク

    このタスクには 4 つのステップがあります。最初のステップでは、[ラスター演算 (Raster Calculator)] ツールを開きます。加重方程式を入力して、ストウの集水域の加重グリッドを作成します。

  3. [マップ代数演算式] で、次の条件式を作成 (またはコピーおよび貼り付け) します。

    1 / "Stowe_velocity"

  4. [出力ラスター] で、出力先の場所が [Stowe_Hydrology] ジオデータベースになっていることを確認し、出力名を「Stowe_weight」に変更します。

    [ラスター演算 (Raster Calculator)] ツールのパラメーター

  5. [Run] をクリックします。

    ツールが実行され、加重グリッド ラスター レイヤーがマップに追加されます。

    Stowe_weight レイヤー

    このレイヤー自体から多くの情報を得ることはできませんが、これを前に作成したフロー方向レイヤーと組み合わせて使用すると、フロー時間を求めることができます。

  6. [コンテンツ] ウィンドウで [Stowe_fill_flow_direction] をオンにします。

    フロー方向レイヤーはストウの集水域を求める前に作成したため、このレイヤーの範囲は今回の対象より広い地域をカバーしています。集水域のみをカバーする新しいバージョンのフロー方向レイヤーを抽出します。

  7. [タスク] ウィンドウに戻ります。

    タスクの次のステップでは、[マスクで抽出 (Extract by Mask)] ツールを使用します。このツールは、ラスター レイヤーを別のレイヤーの範囲に基づいて、特定の範囲にクリップします。

  8. [入力ラスター][Stowe_fill_flow_direction] を選択します。[入力ラスター、またはフィーチャ マスク データ] で、[Stowe_watershed] を選択します。
  9. [出力ラスター] で、出力先の場所が [Stowe_Hydrology] ジオデータベースになっていることを確認し、出力名を「Stowe_watershed_flow_direction」に変更します。

    [マスクで抽出 (Extract by Mask)] ツールのパラメーター

  10. [Run] をクリックします。

    ツールが実行され、抽出されたフロー方向ラスターがマップに追加されます。

    Stowe_watershed_flow_direction レイヤー

    フロー方向レイヤーを抽出したので、古い方のレイヤーはマップ上に表示する必要がなくなりました。

  11. [コンテンツ] ウィンドウで [Stowe_fill_flow_direction] レイヤーをオフにします。次に、[タスク] ウィンドウに戻ります。

流出点までのフロー時間の評価

これで、フロー時間を求めるのに必要なすべてのレイヤーを取得できました。タスクの次のステップでは、[流長ラスターの作成 (Flow Length)] ツールを使用します。名前が示すように、このツールは通常、フローの長さを計算します。ただし、このツールには、加重ラスターを含めるオプションのパラメーターがあります。加重ラスターを含めた場合、このツールはフロー時間を代わりに計算します。

  1. [入力流向ラスター] で、[Stowe_watershed_flow_direction] を選択します。
  2. [出力ラスター] で、出力先の場所が [Stowe_Hydrology] ジオデータベースになっていることを確認し、出力名を「Stowe_time」に変更します。
  3. [計測方向][下流方向] が選択されていることを確認します。
  4. [入力加重ラスター][Stowe_weight] を選択します。

    [流長ラスターの作成 (Flow Length)] ツールのパラメーター

  5. [Run] をクリックします。

    ツールが実行され、流出点までのフロー時間を表すラスターがマップに追加されます。

    Stowe_time レイヤー

    このラスター レイヤーの各セルには、水がそのセルから流出点に流れるまでにかかる時間 (秒) を表す値が含まれています。色が暗いほど、フロー時間が短いことを表しています。流出点に最も近い低地の河床から流れる時間が最も短く、西の山を流れる水は時間がかかっています。

  6. 必要に応じて、[コンテンツ] ウィンドウで、[Stowe_time] レイヤーのシンボルを展開します。

    Stowe_time レイヤーのシンボル

    水が流出点に流れるまでにかかる時間は 0 秒 (流出点に降る雨) から約 47,000 秒 (13 時間以上) の範囲になります。

フロー時間の同時線ゾーンへの再分類

フロー時間ラスター レイヤーには、非常に多くの個別値が含まれており、以降の解析には複雑で扱いにくくなっています。これを単純化するために、フロー時間レイヤーを同時線ゾーンに再分類します。

同時線は、集水域の流出点までの移動時間が大体同じポイントをつなぐコンター ラインです。1,800 秒 (30 分) という同じ時間間隔で同時線を定義します。これより広いエリアでは、同時線に別の間隔を使用できますが、ストウの集水域の場合は、この時間間隔が適切です。この時間間隔を使用すると、最初の同時線ゾーン内のすべてのセルは流出点まで 1,800 秒かかり、2 番目の同時線ゾーンのすべてのセルは約 3600 秒かかります。それ以降の同時線も同様です。これらの時間間隔は、単位流量図の縦座標として後で使用します。

タスクの次のステップでは、[再分類 (Reclassify)] ツールを開きます。このツールを使用して、特定の値の範囲 (0 ~ 1,800 や 1,800 ~ 3,600 など) にあるフロー時間値をその範囲の上限値に分類します。つまり、値 907 は 1,800、値 2,145 は 3,600 に再分類されます。

  1. [入力ラスター][Stowe_time] を選択します。

    次に、再分類値を入力します。フロー時間レイヤーの時間は 0 秒から約 47,000 秒の範囲にあるので、すべての値をカバーする再分類間隔を指定する必要があります。この間隔は手動で入力できますが、このプロセスは面倒な作業です。このレッスンでは、ストウの集水域の時間間隔をすでに含むテーブルを読み込みます。このテーブルは、前回のレッスンでダウンロードしたプロジェクトに付属しています。

  2. [再分類] の空のテーブルの下で、[テーブルから再分類を読み込み] ボタン (ファイル フォルダー アイコン) をクリックします。
  3. [再分類の読み込み] ウィンドウで、[Stowe_Hydrology] フォルダーを参照します ([プロジェクト] > [フォルダー] > [Stowe_Hydrology] の順にクリックします)。[Stowe_isochrones.txt] をダブルクリックして選択します。
    備考:

    [上書きの確認] ウィンドウが表示されたら [はい] を選択します。

    再分類値がテーブルからツールに自動的に読み込まれます。同時線は全部で 27 あります。

  4. [出力ラスター] で、出力先の場所が [Stowe_Hydrology] ジオデータベースになっていることを確認し、出力名を「Stowe_isochrones」に変更します。

    [再分類 (Reclassify)] ツールのパラメーター

    読み込んだテーブルは、フロー時間レイヤーのすべての値を再分類するため、[再分類されなかった値を NoData に変更] をオンにする必要はありません。

  5. [完了] をクリックします。

    ツールが実行され、同時線レイヤーがマップに追加されます。

    Stowe_isochrones レイヤー

    使用したテーブルの 27 の同時線の範囲は 9 の異なるシンボルのみでシンボル化されているため、レイヤーのデフォルト シンボルではよくわかりません。シンボルを連続配色に変更し、27 のすべての同時線を異なる色で表示します。

  6. [コンテンツ] ウィンドウで、[Stowe_isochrones] を右クリックし、[シンボル] を選択します。

    [シンボル] ウィンドウが表示されます。レイヤーを個別値シンボルの黒から白の配色でシンボル表示します。

  7. [シンボル] で、[個別値] を選択します。[配色][黒から白] の配色を選択します。

    [シンボル] ウィンドウのパラメーター

    マップ上でレイヤーのシンボルが自動的に更新されます。

    新しいシンボルで表示された Stowe_isochrones レイヤー

    このシンボルによって、個々の同時線を簡単に選択できます。

    ヒント:

    個別値ごとにシンボル表示すると、[コンテンツ] ウィンドウの大きなスペースがシンボルに占められてしまいます。このレイヤーや他のレイヤーのシンボルを折りたたむと、ウィンドウ内に多くのレイヤーを表示できます。

  8. [シンボル] ウィンドウを閉じます。

    次に、レイヤーの属性テーブルを開いて、各同時線に分類されたセル数を確認します。また、特定の同時線を選択して、詳しく調べます。

  9. [コンテンツ] ウィンドウで、[Stowe_isochrones] を右クリックして、[属性テーブル] を選択します。

    テーブル表示されます。各同時線の値とセル数が表示されます。

  10. 必要に応じて、属性テーブルを移動したりサイズ変更して、[Stowe_isochrones] レイヤーのすべてをマップ上に表示します。
  11. 属性テーブルの最初の行の左にあるボックスをクリックします。

    属性テーブルの最初の行

    テーブルの行が選択されます。対応する同時線もマップ上で選択されます。

    選択された最初の同時線

    予想通り、最初の同時線は流出点に最も近い河床から構成されています。テーブル内の値によると、最初の同時線にあるセルは約 700 のみです。これは、1,800 秒 (30 分) 以内に流出点に到達する水を表します。他の同時線には、これより多くのセルがあります。つまり、降雨イベントの数時間後は、イベントの開始時より流出点にずっと大量の水が到達します。

  12. 属性テーブルで他の行をいくつか選択します。特に、セル数が最も多い同時線を選択します。

    大きな同時線は集水域全体のセルを含むことが多く、それらがほぼ同じ期間に流出点に流れ込みます。

  13. 同時線マップの探索が終了したら、属性テーブルを閉じます。[マップ] タブの [選択] グループにある [解除] ボタンをクリックします。

    [解除] ボタン

    すべての選択が解除されます。

  14. [コンテンツ] ウィンドウで、次のレイヤーをオフにします。
    • Stowe_velocity
    • Stowe_weight
    • Stowe_watershed_flow_direction
    • Stowe_time
  15. プロジェクトを保存します。

このレッスンでは、速度フィールド ラスター レイヤーを使用して、加重グリッドを作成しました。この加重グリッドは、下流へのインピーダンスを表し、フロー時間ラスター レイヤーの作成に利用しました。次に、フロー時間を再分類して、時間間隔を同じ 1,800 秒にした 27 の同時線を作成しました。次のレッスンでは、同時線マップをテーブルに変換します。このテーブルを使用して、集水域全体に 1,800 秒の間隔で一様に発生する単位超過降雨について、流出点での時間と流出量の関係を開発します。最後に、この関係をプロットして、単位流量図を作成します。


単位流量図の作成

前回のレッスンでは、集水域エリアの同時線マップを作成しました。このレッスンでは、同時線マップを、時間と流出点に流れる水の面積の関係を示すテーブルに変換します。次に、このテーブルを使用して、ほとんどの水が流出点に流れる時間を示す単位流量図をプロットし、今後の降雨イベントにおける洪水予測の改善に役立てます。

単位流量図テーブルの準備

単位流量図を作成するには、まず同時線マップの属性テーブルからスタンドアロン テーブルを取得します。現在、属性テーブルは各同時線の面積をセルの数で計測しているため、面積をメートル単位にも変換します。

  1. 必要に応じて、ArcGIS Pro[Stowe_Hydrology] プロジェクトと [Create unit hydrograph at outlet] タスクを開きます。
  2. [タスク] ウィンドウで [Create a unit hydrograph] タスクをダブルクリックします。

    単位流量図タスクの作成

    このタスクには 5 つのステップがあります。最初のステップでは、[テーブル → テーブル (Table To Table)] ツールを開きます。このツールは、テーブル (属性テーブルを含む) をジオデータベースに格納されるスタンドアロン テーブルに変換できます。

  3. [入力行] で、[Stowe_isochrones] を選択します。
  4. [出力場所] で、出力場所が [Stowe_Hydrology] ジオデータベースであることを確認します。[出力名] に「Stowe_isochrones_table」と入力します。

    [テーブル → テーブル (Table To Table)] ツールのパラメーター

    残りのパラメーターを使用して、入力テーブルのレコードのサブセットを選択する条件式を作成できます。前回のレッスンでレイヤーの属性テーブルを表示したとき、すべてのレコードが有益だったので、これらのパラメーターは変更しません。

  5. [実行] をクリックします。

    ツールが実行され、新しいテーブルが [コンテンツ] ウィンドウに追加されます。現在、このテーブルは [Stowe_isochrones] レイヤーの属性テーブルと同一です。そのテーブルには、単位流量図 (時間と時間あたりの排水面積) を作成するのに必要な値セットのフィールドが含まれていますが、排水面積はメートル単位ではなくセル数で計測されています。タスクの次のステップでは、[フィールドの追加 (Add Field)] ツールを開きます。このツールを使用して、面積を平方メートルで計算するために、新しいフィールドをテーブルに追加します。

  6. [入力テーブル] で、[Stowe_isochrones_table] を選択します。
  7. [フィールド名] に「Area_meters」と入力します。[フィールド タイプ][Double] を選択します。

    [Double] フィールド タイプは、小数点以下の桁数が多い値を格納できます。この形式を使用することで、面積値がより正確になります。次の [フィールドの全桁数][フィールドの小数点以下桁数] という 2 つのパラメーターでは、フィールドの桁数と小数点以下の桁数を制限できるので、これらのパラメーターは空のままにしておきます。

  8. [フィールドのエイリアス] に「Area (Sq. Meters)」と入力します。

    [フィールドの追加 (Add Field)] ツールのパラメーター

    残りのパラメーターは、フィールドの詳細オプションを提供します。単純な面積フィールドなので、これらのパラメーターは重要ではなく、変更する必要はありません。

  9. [Run] をクリックします。

    ツールが実行され、新しいフィールドがスタンドアロン テーブルに追加されます。テーブルを開いて、フィールドが正しく追加されたことを確認します。

  10. [コンテンツ] ウィンドウで [Stowe_isochrones_table] (レイヤーのリストの下部にあります) を右クリックして、[開く] を選択します。

    テーブル表示されます。

    デフォルトの同時線テーブル

    フィールドが、指定したフィールド エイリアスを使用して正しく追加されました。ただし、現在のフィールドには値がありません。

  11. テーブルを閉じます。[タスク] ウィンドウに戻ります。

    タスクの次のステップでは、[フィールド演算 (Calculate Field)] ツールを開きます。このツールを使用して、各同時線の面積を平方メートルで計算します。前回のレッスンでプロジェクトを最初に開いたとき、元の Stowe_DEM レイヤーのセル サイズは 30 メートルで、各セルの面積は 30 x 30 平方メートルであるという説明がありました。その後のすべてのレイヤーは何らかの形で DEM レイヤーに基づいているため、セル サイズは同じです。つまり、テーブル内の [個数] フィールドを 1 つのセルの面積と乗算することで、面積を計算できます。

  12. [入力テーブル] で、[Stowe_isochrones_table] を選択します。[フィールド名] で 「Area (Sq. Meters)」と入力します。
  13. [条件式] で、「!Count! * 30 * 30」という式を作成します。

    [フィールド演算 (Calculate Field)] ツールのパラメーター

  14. [Run] をクリックします。

    ツールが実行され、フィールドが計算されます。必要に応じて、テーブルをチェックして、値が正しく計算されたか確認できます。タスクの次のステップでは、[フィールドの追加 (Add Field)] ツールをもう一度開きます。フィールドをもう 1 つテーブルに追加します。ただし、これはテーブルの既存のフィールドに基づきます。このフィールドには、流出点における 1 秒あたりの流出量を示す単位流量図の縦座標を含めます。

    1 つの軸を時間、もう 1 つの軸を排水面積にしたグラフを作成した場合、わかるのは 1,800 秒 (30 分) の間に流出点に到達した水量のみです。この間隔は、元のフロー時間レイヤーにある多数の個別値をより扱いやすい 27 の個別値にビン化するのに役立ちました。しかし、仮想的な緊急事態では、30 分が生と死の明暗を分ける可能性があります。Stowe 町当局には、計画のためにより正確な時間枠が必要です。新しいフィールドは、流出点に毎秒到達する水量を推定します。

    単位流量図の縦座標 Ui (時間 iΔti = 1,2,….n) は、間隔 [(i - 1)Δt,iΔt] における時間-累積面積ダイアグラムの傾斜角によって求められます。これは、次の式で求められます。

    Ui = U(it) = (A(it) - A[(i - 1)∆t]) / ∆t    (1)
    • where:
      • A(t) は、雨が降り始めてからの時間 t 内に流出点に排水された累積排水面積です。

    式 (1) は、次のように書き換えることができます。

    Ui = Ai / ∆t    (2)

    • ここで
      • Ai は、i 番目の同時線ゾーンにおける増加排水面積です。
  15. ツールの設定には、タスクの 2 番目のステップで使用したのと似たパラメーターを使用しますが、フィールドの名前を「UH_ordinate」、エイリアスを「Unit Hydrograph Ordinate」にします。

    [フィールドの追加 (Add Field)] ツールのパラメーター

  16. [Run] をクリックします。

    ツールが実行され、フィールドがテーブルに追加されます。前回と同様に、フィールドを計算します。タスクの次のステップでは、[フィールド演算 (Calculate Field)] ツールをもう一度開きます。排水面積を間隔 (1,800) で除算し、1 秒あたりの面積を計算します。

  17. [入力テーブル] で、[Stowe_isochrones_table] を選択します。[フィールド名][Unit Hydrograph Ordinate] を選択します。
  18. [条件式] で、「!Area_meters! / 1800」という条件式を作成します。

    [フィールド演算 (Calculate Field)] ツールのパラメーター

  19. [完了] をクリックします。

    ツールが実行され、フィールドが計算されます。

  20. テーブルを開いて、計算結果を確認します。完了したら、テーブルを閉じます。

単位流量図のプロット

ArcGIS Pro では、任意のスタンドアロン テーブルからチャートを作成できます。この機能を使用して、テーブルの縦座標フィールドから単位流量図を作成します。

  1. [コンテンツ] ウィンドウで、[Stowe_isochrones_table] を 1 回クリックして選択します。

    テーブルを選択すると、コンテキスト タブがリボンに追加されます。このタブには、スタンドアロン テーブル固有のオプションが含まれています。

  2. リボンの [データ] タブをクリックします。[視覚化] グループで、[チャートの作成] をクリックして、[ライン チャート] をクリックします。

    [ライン チャート] オプション

    [チャート] ウィンドウと [Stowe_isochrones_table - Line Chart 1] ウィンドウが開きます。

  3. [チャート] ウィンドウの [データ] タブで、[日付または数値][値] を選択します。

    パラメーターを変更すると、ウィンドウがチャート例で自動的に更新されます。[Value] フィールドは X 軸、[COUNT] フィールドは Y 軸に自動的に設定されます。チャートには、セル数の代わりに単位流量図の縦座標を表示します。

  4. [チャート] ウィンドウの [集約] で、[<なし>] を選択します。

    単位流量図の変数

  5. [シリーズ] で、[Unit Hydrograph Ordinate] チェックボックスをオンにして [適用] をクリックします。

    単位流量図のフィールド

    次に、グラフの内容がわかるように、チャートのタイトルと軸のラベルを変更します。

  6. [チャート] ウィンドウで、[一般] タブをクリックします。
  7. [チャートのタイトル] に「Unit Hydrograph at outlet point」と入力します。
  8. [X 軸のタイトル] に「Time (seconds)」と入力します。[Y 軸のタイトル] に「Discharge at outlet per unit of excess rainfall (sq. meters per second)」と入力します。

    ウィンドウ内のチャートが新しいタイトルで自動的に更新されます。流出点の単位流量図が完成しました。

    単位流量図

    備考:

    単位流量図の軸に表示される増加量と、単位流量図のサイズは、ウィンドウのサイズに依存します。

  9. プロジェクトを保存します。

このレッスンでは、まず同時線ゾーンをテーブルに変換しました。次に、フィールドをテーブルに追加して、各同時線の排水面積を平方メートル単位で計算し、単位流量図の縦座標を求めました。最後に、テーブルを使用して、予測される降雨イベント中に、流出点における水の流出量が最大になるときを示す単位流量図を作成しました。最終的に、この結果はストウ町当局が洪水イベントに対して、より効果的に計画および対応するのに役立ちます。

その他のレッスンについては、「Learn ArcGIS Lesson ギャラリー」をご参照ください。