マップのインポートと探索

ArcGIS Pro は、ArcMap、ArcCatalog、ArcToolbox、ArcScene、および ArcGlobe の機能を 1 つのアプリケーションに統合しているため、2D と 3D の表示、分析、編集を切り替えることができます。

マップ ドキュメントの ArcGIS Pro へのインポート

ArcGIS Pro を開始する 1 つの方法は、既存の ArcMap マップ ドキュメント (*.mxd) をインポートすることです。

  1. ArcGIS の組織アカウントにサイン インします。
    メモ:

    組織のアカウントがない場合、ArcGIS の無料トライアルにサイン アップできます。

  2. [Mali Language Groups Map] アイテム ページを開いて、[ダウンロード] をクリックします。

    ダウンロード ボタン

  3. [MaliLanguageGroups.zip] ファイルを開いて、ZIP ファイルのコンテンツを選択した場所に展開し、新しい [MaliLanguageGroups] フォルダーを開きます。

    ダウンロードしたフォルダーには、ArcMap マップ ドキュメント (*.mxd)、ジオデータベース (*.gdb)、およびシェープファイルが含まれています。 このマップのデータは NGA (National Geospatial-Intelligence Agency) および FAO (Food and Agriculture Organization of the United Nations) より提供されました。

    メモ:

    ArcGIS Pro を使用する前に ArcMap でプロジェクトを探索するには、[MaliLanguageGroups.mxd] をダブルクリックして ArcMap で開きます。

  4. ArcGIS Pro を起動します。

    サイン インを求められたら、ライセンスが割り当てられた ArcGIS アカウントまたは ArcGIS Enterprise 指定ユーザー アカウントを使用してサイン インします。

    ArcGIS Pro が開き、スプラッシュ スクリーンが表示されます。 プロジェクト テンプレートが [新規] 見出しに一覧表示されます。 各テンプレートは、リソースですでに構成されたプロジェクトを作成します。 たとえば、マップ テンプレートは、空のマップ、ジオデータベース、およびツールボックスを作成します。 最初にプロジェクトを作成せずに作業を開始する場合は、テンプレートなしで開始することもできます。

  5. [新規][テンプレートを使用せずに開始] をクリックします。

    新規プロジェクト ウィンドウ

    ArcGIS Pro で空のビューが開きます。 上部にあるリボンには、コマンドや設定を関連グループに分類するタブが含まれます。 たとえば、編集に関連する一般的なツールは、[編集] タブにあります。

    [コンテンツ] ウィンドウと [カタログ] ウィンドウはそれぞれ ArcMap のコンテンツ ウィンドウと ArcMap[カタログ] ウィンドウに似ています。 ArcGIS Pro には、必要に応じて開いたり再配置したりできるその他のウィンドウもあります。 中央のエリアは現在空白です。ここには、マップ、テーブル、レイアウト、モデル、その他のビューが表示されます。

    インターフェイス

  6. リボンの [挿入] タブの [プロジェクト] グループで、[マップのインポート] をクリックします。

    マップのインポート

  7. [インポート] ウィンドウで、ダウンロードした展開済みのフォルダーから [MaliLanguageGroups.mxd] を参照して選択します。

    ソース マップの選択

    ヒント:

    [マップのインポート] コマンドを使用して、さまざまな種類のドキュメントを ArcGIS Pro に移すことができます。 [Default] ドロップダウン メニューを展開して、インポート可能なファイル タイプを表示します。

  8. [OK] をクリックします。

    ArcMap ArcMap ドキュメントがインポートされます。 [コンテンツ] ウィンドウにアイテムが入力され、レイアウト ビューがアプリケーションの中央に表示されます。 レイアウトには、西アフリカの陸地に囲まれた国であるマリの言語グループのマップが表示されます。

    レイアウト ビュー

    メモ:

    プロジェクトが ArcMap のデータ ビューに保存された場合、ArcGIS Pro は *.mxd ファイルをマップ ビューで開きます。 プロジェクトが ArcMap のレイアウト ビューに保存された場合、この事例のように、ArcGIS Pro は *.mxd ファイルをレイアウト ビューで開きます。

プロジェクト構造の探索

[カタログ] ウィンドウはデータ管理に使用され、プロジェクトで使用できるすべてのリソースにすばやくアクセスできるようにします。

  1. [カタログ] ウィンドウで、[レイアウト] を展開します。

    カタログ ウィンドウでレイアウトを展開

    ArcMap ドキュメントのレイアウトは、ArcGIS Pro のレイアウト アイテムになります。 ArcGIS Pro の多くのプロジェクトにレイアウトがまったくない場合があります。

  2. [カタログ] ウィンドウの [プロジェクト] タブで [マップ] を展開します。

    カタログ ウィンドウでマップを確認

    プロジェクトには、マップ ドキュメント内の 2 つのデータ フレームに対応する 2 つのマップが含まれています。 どちらもレイアウトで確認できます。一方はマリの言語グループのマップ、もう一方はアフリカのロケーター マップです。

  3. [カタログ] ウィンドウの [マップ] の下で、[New Data Frame] を右クリックして、[名前の変更] をクリックします。

    マップ名の変更

  4. 名前に、「Mali Language Groups Map」と入力して、Enter キーを入力します。
  5. [New Data Frame1] を「Locator Map」に名前を変更します。

    [カタログ] で名前を変更しましたが、レイアウト内のマップ フレームの名前は変更されていません。 次に、[コンテンツ] ウィンドウでデータ フレーム名を更新します。

  6. [コンテンツ] ウィンドウで、[New Data Frame マップ フレーム] を 2 回クリックします。

    名前の変更が可能なデータ フレーム

    これにより、データ フレームの名前を変更できます。

  7. データ フレーム「Mali Language Groups」の名前を変更して Enter キーを押します。 [New Data Frame マップ フレーム 1] も、同じ手順で名前を「Locator Map」に変更します。

    データ フレームの名前を Locator Map に変更

  8. ArcGIS Pro の上部の [クイック アクセス ツールバー] で、[保存] をクリックします。

    プロジェクトの保存

    このプロジェクトはテンプレートなしで開始され、これまでに保存されていないため、[名前を付けてプロジェクトを保存] が表示されます。

  9. [名前を付けてプロジェクトを保存] ウィンドウで、選択した場所を参照します。
  10. [名前] に「Mali Language Groups」と入力します。
  11. [保存] をクリックします。

    ArcGIS Pro は作業をプロジェクト フォルダーに保存します。 この構造により、作業に必要なすべてのリソースを 1 カ所で組み立てることができます。 プロジェクトには、マップ、シーン、レイアウト、データ、タスク、ツールボックス、スタイル、およびサーバーとフォルダーへの接続を含めることができます。

  12. ファイル エクスプローラーで、新しい [Mali Language Groups] フォルダーを参照します。

    そのフォルダー内には、ジオデータベース (*.gdb) とツールボックス (*.tbx) があります。 プロジェクトでの作業中に作成する新しいデータやスクリプトは、デフォルトでこのフォルダーに格納されます。 *.aprx ファイルは ArcGIS Pro プロジェクト ファイルで、*.mxd ファイルと同じです。

    プロジェクト フォルダーの確認

  13. ArcGIS Pro[カタログ] ウィンドウで、[フォルダー] を展開して、[Mali Language Groups] を展開します。

    カタログ ウィンドウの探索

    これは、ファイル エクスプローラーに表示したプロジェクト フォルダーへのフォルダー接続です。 ただし、マップのデータは、ダウンロードしたフォルダーに格納されています。

    ArcGIS Pro では、最初にフォルダー接続を作成しなくてもデータを追加できます。 ただし、プロジェクト データにアクセスするためのフォルダー接続を作成すると便利です。

  14. [カタログ] ウィンドウで [フォルダー] を右クリックして、[フォルダー接続の追加] を選択します。
  15. 前にダウンロードした [MaliLanguageGroups] フォルダーを参照して選択します。 [OK] をクリックします。

    MaliLanguageGroups フォルダーへのフォルダー接続を作成

  16. [MaliLanguageGroups] を展開します。

    マリのマップによって参照されるジオデータベースとシェープファイルはすべて、このフォルダーに格納されます。

    プロジェクト ソース データの確認

    メモ:

    ArcGIS Pro では、同じハード ディスク ドライブ上にあるデータ ソースは、プロジェクト フォルダーへ相対パスとしてリンクされます。 ネットワーク ドライブ上にあるデータ ソースへのリンクは、絶対パスを使用して保存されます。 GIS サーバー上にあるデータ ソースへのリンクは、ユニバーサル ロケーターのパスを使用して保存されます。 詳細については、「マップ内のデータの参照」をご参照ください。

マップの操作

次に、マリの言語多様性のマップを操作します。

  1. [カタログ] ウィンドウの [マップ] の下で、[Mali Language Groups Map] を右クリックして、[開く] を選択します。

    元の ArcMap データ フレームがレイアウトに合わせて小さな縮尺で保存されたため、マップはとても小さくなります。

  2. [コンテンツ] ウィンドウで [District Boundary] を右クリックして [レイヤーにズーム] を選択します。

    レイヤーにズーム

    縮尺が更新され、マリのマップがビューに表示されます。 ArcGIS Pro では、レイアウトの縮尺に影響することなく、マップを自由にズームしたり画面移動したりできます。

    マップ操作

  3. マウス ホイールを使用して、マップを拡大/縮小できます。
  4. マップ上の任意の場所をクリックします。

    クリックしたフィーチャが点滅して、ポップアップ ウィンドウが開き、属性情報が表示されます。

    ポップアップを使用したフィーチャの識別

  5. ポップアップを閉じます。
  6. 必要に応じて、リボンの [マップ] タブをクリックします。

    マップを操作するもう 1 つの方法は、[マップ操作] ツールを使用することです。

  7. [ナビゲーション] グループの [マップ操作] ボタンをクリックして、マップを画面移動します。

    マップ操作

    メモ:

    [マップ操作] ツールは ArcMap の個別属性ツールと似たツールで、ポップアップへのアクセス方法です。 [マップ操作] ツールの機能を変更するには、[マップ操作] ボタンの下半分をクリックしてその他のオプションを表示します。

シンボルとラベルの操作

ArcGIS Pro では、シンボルはダイアログ ボックスではなくウィンドウ内で制御されます。 つまり、最初に一連のウィンドウを閉じなくても、マップ上の変更を確認できます。

  1. [コンテンツ] ウィンドウで [language_Union] を右クリックし、[シンボル] を選択します。

    [シンボル] ウィンドウが表示されます。 ウィンドウの上部には、現在選択されているレイヤーの名前が表示されます。 [プライマリ シンボル] の下で、このレイヤーは [個別値] 方法と [Language Family] フィールドを使用してシンボル化されていることが確認できます。

    個別値を使用したレイヤーのシンボルの更新

    ウィンドウの上部にあるタブを使用すると、高度なシンボル設定にアクセスできますが、このレッスンでは説明しません。

  2. [シンボル] ウィンドウの下半分で、[Berber and Atlantic] の横にあるシンボルをクリックします。

    更新するシンボルの選択

    これで、[シンボル] ウィンドウに Berber and Atlantic シンボル クラスのプロパティのみが表示されます。

  3. [プロパティ] タブをクリックし、[レイヤー] タブをクリックします。

    シンボル プロパティの確認

    [Berber and Atlantic] レイヤーのシンボルは、2 つのハッチ塗りつぶしシンボル レイヤーで構成されています。 このタブでは、色やライン幅を調整することができます。

    メモ:

    ArcGIS ProArcMap は異なる方法を使ってシンボルを作成しますが、インポートされたシンボルの表示は同じままです。 ArcGIS Pro では、複雑なシンボルはシンボル レイヤーで構築されます。

  4. [シンボル] ウィンドウで、[戻る] 矢印をクリックして、レイヤー全体のシンボル設定に戻ります。

    シンボル ウィンドウの操作

  5. [コンテンツ] ウィンドウで、[District Boundary] をクリックします。

    [シンボル] ウィンドウが更新され、選択したレイヤーの設定が表示されます。 [シンボル] ウィンドウを開いたまま、[コンテンツ] ウィンドウ上の別のレイヤーを選択すると、そのレイヤーの表示設定に簡単に切り替えることができます。

  6. リボンの [ラベリング] タブをクリックします。

    ラベリング タブ

    リボン インターフェイスは状況依存です。 レイアウトよりもマップを操作しているときにさまざまなタブが表示されます。 レイヤーを選択すると、色付けされたバーの下に追加のタブが表示されます。 コンテキスト レイヤー タブ (ラベルなど) 上で行われた変更は、現在選択されているレイヤーにのみ適用されます。

  7. [レイヤー] グループで [ラベル] ボタンをオフに切り替えて、再びオンにします。

    白の区域ラベルがマップ上で非表示になり、再表示されます。

    ラベル オプションの確認

    最も一般的なラベリング タスクはリボン上にあり、さらに高度なフィーチャはウィンドウで使用できます。

  8. リボンの [ラベリング] タブの [ラベルの配置] グループで [ラベル配置プロパティ] ボタンをクリックします。

    ラベル クラス プロパティの表示

    [ラベル クラス] ウィンドウが表示されます。

  9. 必要に応じて、[ラベル クラス] ウィンドウで [位置] タブとその他の [位置] ボタンをクリックします。

    ラベル クラス プロパティ ウィンドウの確認

  10. [ラベル間隔] を展開します。
  11. 2 番目のドロップダウン メニューを [一定の制限まで文字間隔を空ける] に変更して、[最大][100%] に設定します。

    文字間隔を開けたラベルの更新

    マップ上の白いラベルが広がり、表示されるエリアがわかりやすく塗りつぶされます。

    ArcGIS Pro のラベル エンジンは ArcMap のラベル エンジンよりも高度かつ直感的で、Maplex Label エンジンの機能をすべて含んでいます。

  12. [ラベル クラス] ウィンドウと [シンボル] ウィンドウを閉じます。
  13. [クイック アクセス ツールバー] で、[保存] をクリックします。
    メモ:

    ArcGIS Pro でのシンボルラベルの詳細

マップを ArcGIS Pro にインポートし、いくつかの基本機能を調べました。


マップの更新と編集

マップには、マリが多様な言語に富んでいることが示されます。 このマップには 7 つの言語グループが表示されていますが、国内では 80 以上の言語が話されています。 最も広く話されている言語は、マンデ語言語グループに属するバンバラ語です。 公用語はフランス語で、フランス植民地統治時に採用されました。マリのさまざまな言語の間で共通の貿易言語としての役割を果たしています。

マップ上には、地域と都市の両方に Timbuktu という場所名が表示されています。 この古代都市のフランス語でのスペルは Tombouctou です。 次に、ArcGIS Pro でデータを編集する方法を学びます。マップ データの Timbuktu をフランス語のスペルに更新します。

フィーチャの編集

ArcGIS Pro では、データに変更を加える前に、編集セッションを開始する必要はありません。

  1. [コンテンツ] ウィンドウで、[District Boundary] を右クリックして [属性テーブル] を選択します。

    属性テーブルがマップの下に表示されます。

  2. [NAME_1] 列で [Timbuktu] セルをダブルクリックします。

    テーブル内のフィーチャ属性の編集

  3. Tombouctou」と入力し、Enter キーを押します。

    マップ上の区域ラベルが更新されます。

  4. リボンの [編集] タブをクリックします。 [編集の管理] グループにある [保存] をクリックします。

    編集内容の保存

  5. [編集の保存] ウィンドウで [はい] をクリックします。
  6. 属性テーブルを閉じて、プロジェクトを保存します。

    次に、都市のラベルを更新します。

  7. [コンテンツ] ウィンドウで、[Mali_MajorCities] をクリックします。
  8. 必要に応じて、[ラベリング] タブをクリックします。

    [レイヤー] グループで、[ラベル] ボタンはオフですが、ラベルが付けられる主要都市は表示されています。

    ラベルのオン/オフの切り替え

    これは、ラベルが代わりにアノテーション フィーチャクラスの [Mali_MajorCitiesAnno] という名前のレイヤーから取得されているためです。

    アノテーション フィーチャクラスのデータ構造は、ArcGIS ProArcMap で異なります。 ArcMap で作成されたアノテーション フィーチャクラスは、ArcGIS Pro で表示および検索することができます。 ただし、それらを編集または変更するには、最初にそれらをアップグレードする必要があります。

  9. リボンの [解析] タブをクリックします。 [ジオプロセシング] グループで、[ツール] をクリックします。

    リボンの解析タブのツール

    [ジオプロセシング] ウィンドウが表示されます。 このウィンドウには、すべてのジオプロセシング ツール ([バッファー][投影変換] などの一般的なツールを含む) および ArcMap の独自の機能を持ついくつかの機能 ([フィールド演算][属性検索] など) が表示されます。

  10. 検索バーに「upgrade dataset」と入力し、Enter キーを押します。
  11. 検索結果で [データセットのアップグレード] ツールをクリックします。

    ジオプロセシング ウィンドウを使ったツールの検索

  12. [アップグレードするデータセット] で、ドロップダウン矢印をクリックして [Mali_MajorCitiesAnno] を選択します。

    ジオプロセシング ツール パラメーターの設定

    ヒント:

    アップグレード後は、アノテーション フィーチャクラスは ArcMap で使用できなくなります。 アップグレードする前に、フィーチャのコピー ツールを使用してフィーチャクラスのコピーを作成できます。

  13. [実行] をクリックします。

    ツールの実行が終了すると、ウィンドウの下部に成功または失敗を示すメッセージが表示されます。

  14. [詳細の表示] をクリックして、ジオプロセシング レポートを確認します。

    ジオプロセシング ツールの詳細の表示

    詳細を表示するオプションは、ツールが失敗したときの問題の診断に特に役立ちます。

  15. [ジオプロセシング] ウィンドウを閉じます。

    これで、アノテーション フィーチャクラスが更新され、編集できるようになりました。

  16. [コンテンツ] ウィンドウで [編集別にリスト] タブを選択します。
  17. [Mali_MajorCitiesAnno] を右クリックして [このレイヤーのみ編集可能にする] をクリックします。

    このレイヤーのみ編集可能にする

  18. リボンの [編集] タブをクリックし、[ツール] グループの [アノテーション] をクリックします。

    アノテーションの編集

  19. [マップ] で、[TIMBUKTU] アノテーション フィーチャにズームして選択します。

    アノテーション フィーチャ周辺に選択境界が表示されます。

  20. テキストをダブルクリックしてハイライト表示します。

    編集するターゲット アノテーション フィーチャの選択

  21. TOMBOUCTOU」と入力して、アノテーション フィーチャのスペルを更新します。
  22. ポインターが移動シンボルに変わるまでテキスト ボックスのエッジの上に置きます。 テキストをドラッグして、マップ上の他のアノテーション フィーチャと同様にポイントの右上に配置します。

    選択したフィーチャのスペルの更新

  23. Map Viewer の下部で、マップ ビューの下部にある編集ツールバーで、[完了] をクリックして編集を完了します。

    完了ボタン

  24. リボン上の [選択] グループで [選択解除] をクリックします。

    フィーチャの選択解除

  25. [編集の管理] グループで [保存] をクリックして、[編集の保存] ウィンドウで [はい] をクリックします。
  26. リボンの [マップ] タブをクリックします。 [ナビゲーション] グループの [マップ操作] ボタンをクリックします。

    これで、マップをクリックしたときに、フィーチャを間違って移動したり編集したりすることがなくなります。

  27. プロジェクトを保存します。

ArcGIS Online からのデータの追加

ArcGIS Pro に移行する最大のメリットの 1 つは、ArcGIS Online との緊密な統合です。 アプリケーションを終了せずに、ArcGIS Living Atlas of the WorldArcGIS Online などの外部ソースのマップやデータを参照してアクセスできます。

マリのマップには、水域のレイヤーが含まれており、物理的な地理と関連させることで、この国の言語の多様性のストーリーに文脈を与えることができます。 [Mali_WaterBodies] レイヤーは小縮尺で作成され、変動する河川や湖など、このマップの縮尺には必要のない余分な詳細情報を含んでいます。 ArcGIS ProArcGIS Online を実際に統合するため、ArcGIS Online でより単純なマリの水域マップを検索して追加します。

  1. 必要に応じて、[コンテンツ] ウィンドウで [描画順にリスト] タブをクリックします。

    描画順にリスト タブ

  2. [District Boundary] を右クリックして [レイヤーにズーム] を選択します。
  3. [Mali_WaterBodies] を右クリックして [削除] を選択します。

    次に、ArcGIS Online で、マリを流れる主要な河川であるニジェール川のみを表示する別のマップを検索します。

  4. [カタログ] ウィンドウを開きます。
    ヒント:

    [カタログ] ウィンドウが見つからない場合は、リボン上の [表示] タブをクリックし、[カタログ ウィンドウ] をクリックします。

  5. [カタログ] ウィンドウで [ポータル] タブをクリックし、[ArcGIS Online] をクリックします。

    カタログ ウィンドウのポータル タブへの切り替え

  6. 検索バーに「World Major Rivers owner:esri_dm」と入力し、Enter キーを押します。
    メモ:

    所有者 [esri_dm] は、ArcGIS OnlineData and Maps for ArcGIS アカウントです。

  7. 検索結果で [World Major Rivers] という名前の最初のアイテムをポイントします。

    ポータル アイテムの検索

    メモ:

    [World Major Rivers] アイテムはレイヤー パッケージです。 レイヤー パッケージには、レイヤー プロパティとデータの両方が格納されます。 レイヤー パッケージをマップに追加すると、ローカル コンピューターにダウンロードされ、マップはローカル データを参照します。 一方、ホスト フィーチャ レイヤーをマップに追加すると、オンライン サービスを参照します。

  8. [カタログ] ウィンドウで、[World Major Rivers] レイヤー パッケージを右クリックして [現在のマップに追加] を選択します。

    現在のマップに追加

    [World Major Rivers] レイヤーがマップ上に表示されます。 マリを流れるニジェール川が表示されますが、シンボルが見づらく感じます。 次に、シンボルを更新し、河川をより見やすくします。

レイヤー シンボルの変更

次に、[World Major Rivers] レイヤーの新しいシンボルを選択します。

  1. [コンテンツ] ウィンドウで [World Major Rivers] を右クリックし、[シンボル] を選択します。

    [シンボル] ウィンドウが開き、[プライマリ シンボル] 方法が [単一シンボル] に設定されていることを確認できます。

  2. [シンボル] ウィンドウの [ラベル] で、テキストを「Niger River」に変更します。

    ラベルを Niger River に変更

    [コンテンツ] ウィンドウでシンボルの横にあるラベルが更新されます。 このラベルは、後でマップ凡例に表示されます。

  3. [シンボル] ウィンドウで、ターコイズのシンボルをクリックして、シンボル プロパティにアクセスします。

    レイヤー シンボルの更新

  4. [シンボル] ウィンドウで [ギャラリー] タブをクリックします。

    シンボル ギャラリーには、そのまま使用できるか、修正できる一般的なシンボルがあります。

  5. ギャラリーで [アクセス制限] シンボルをクリックします。

    ライン シンボルの選択

    マップが更新され、Niger River が青い外縁ラインで描画されます。

    マップ レイヤーのシンボルの確認

  6. [シンボル] ウィンドウを閉じます。

    [World Major Rivers] レイヤー パッケージにはラベルも含まれますが、このラベルは必要ありません。

  7. [コンテンツ] ウィンドウで [World Major Rivers] を右クリックし、[ラベル] をクリックしてラベリングをオフにします。

    レイヤー ラベルの表示

    これは、リボンからラベルを無効にした場合と同じ効果があります。

  8. プロジェクトを保存します。

マップのクリップ

河川は、マリの国境を越えて広がるマップ内の唯一のレイヤーです。 次に、国境を使用してマップをクリップし、外観をわかりやすくします。

メモ:

[マップ プロパティ][レイヤーのクリップ] を使用すると、データの表示範囲を簡単に制限でき、元のデータ ファイルは変更されません。 [クリップ] ジオプロセシング ツールを使用すると、クリップの外側にあるデータが削除され、元のデータ ファイルが変更されます。

  1. [コンテンツ] ウィンドウで [Mali Language Groups Map] を右クリックし、[プロパティ] を選択します。
  2. [マップ プロパティ] ウィンドウで、[レイヤーのクリップ] タブをクリックします。
  3. ドロップダウン メニューから [フィーチャのアウトラインでクリップ] を選択します。

    フィーチャのアウトラインでクリップ

  4. [次のアウトラインから形状を取得:][District Boundary] をクリックします。

    [選択した図形] のプレビューにマリのアウトラインが表示されます。 このクリップ形状の外側には、マップ コンテンツは表示されません。

    クリップ形状の選択

  5. [適用] をクリックして [OK] をクリックします。

    マップが更新され、[World Major Rivers] レイヤーがマリの国境でクリップされます。

    クリップされたマップ

  6. プロジェクトを保存します。

マップを更新して編集しました。


マッピング プロジェクトの共有

マップの構成が完了したので、このマップを同僚と共有します。 共有する前に、レイアウトを確認して、変更する必要があるものがないか確認します。

レイアウトの凡例の更新

前のステップで、レイヤーをマップから削除し、新しいレイヤーを追加しました。 このため、レイアウト上の凡例を更新する必要があります。

  1. マップ ビューの上部にある [MaliLanguageGroups] タブをクリックして、レイアウトを表示します。

    レイアウト ビューへの切り替え

    ArcMap では、データ ビューで画面移動や拡大縮小を行うとレイアウト ビューに影響します。 これは ArcGIS Pro とは異なります。 前のステップで、マップの拡大/縮小を何度か行いましたが、レイアウト ビューの縮尺と範囲は変わりませんでした。

    このレイアウトには 2 つの凡例があり、1 つは言語グループ用、もう 1 つは参照レイヤー用であることがわかります。 ArcGIS Online から [World Major Rivers] レイヤーを追加したときに、[Niger River] という名前の項目が各凡例に追加されました。

    レイアウト ビューの 2 つの凡例

  2. [コンテンツ] ウィンドウで、[Legend 1][Legend] エレメントを展開します。

    Legend レイヤーの展開

  3. Ctrl キーを押しながら、[Mali_Roads][Mali_Railroads_NGA]、および [DistrictBoundary] を選択します。 選択した 3 つの項目をクリックして [Legend] にドラッグします。

    凡例から別の凡例に項目を移動

    上位の凡例が、追加された項目を含むよう更新されます。

  4. [Legend 1] をオフにします。
  5. [Legend] の項目をクリックして、以下の順番にドラッグします。

    • LANGUAGE FAMILY
    • Mali_Railroads_NGA
    • Mali_Roads
    • DistrictBoundary
    • World Major Rivers

    凡例の項目が新しい順番に更新されます。

    順番が更新された凡例の項目

  6. [コンテンツ] ウィンドウで、[World Major Rivers] をダブルクリックします。

    [凡例項目の書式設定] ウィンドウが表示されます。

    ヒント:

    レイアウト ビューで、[コンテンツ] ウィンドウ内の項目をダブルクリックすると、そのプロパティにアクセスできます。

  7. ウィンドウの上部にある [テキスト シンボル] をクリックします。
  8. [表示設定] を展開し、[フォント名][Candara] に変更します。
  9. [サイズ] を 「14」に変更し、[色][グレー 70%] に変更します。
    ヒント:

    カラーにポインターを合わせて、その名前を表示します。

    凡例のフォント プロパティの変更

  10. [適用] をクリックします。

    これで、新しい凡例項目がその他の凡例と揃うようになりました。

    マップ上の更新された凡例の確認

  11. 凡例の角をクリックしてドラッグし、サイズを調整します。

    凡例のサイズ調整

  12. レイアウトの外側の任意の場所をクリックして、選択を解除します。
  13. プロジェクトを保存します。
    メモ:

    ArcGIS Pro のレイアウトの操作の詳細

プロジェクト パッケージの共有

マップ プロジェクトを ArcGIS Pro に正常に移行し、マップを構成してよりわかりやすくしました。 次に、このプロジェクトを別のオフィス内の共同作業者と共有します。 プロジェクトでは、コンピューター上の複数の異なるソース フォルダーのデータが使用されているため、同僚と共有するプロジェクト ファイルが別のコンピューターでは動作しないデータ パスを参照していないことを確認するには、ファイルをプロジェクト パッケージとして送信するのが最も簡単な方法です。 次に、マップ プロジェクトをオンライン プロジェクト パッケージとして共有します。

  1. [Mali Language Groups Map] マップ ビューをクリックし、アクティブにします。

    タブをクリックして Mali Language Groups Map をアクティブにする

  2. リボンの [共有] タブをクリックします。

    このリボン タブには、マップ、データ、ツールなどのアイテムを共有するためのコマンドがあります。 たとえば、Web レイヤーを ArcGIS Online で共有したり、静的なマップの PDF ファイルをエクスポートしたりできます。

  3. [パッケージ] グループで、[プロジェクト] をクリックします。

    プロジェクト タブをクリック

    プロジェクト パッケージ (*.ppkx) ファイルは、プロジェクトのマップ、データ、フォルダー接続、ツールボックス、ジオプロセシング履歴レポートを 1 つのファイルに統合します。 他のファイル タイプの添付ファイルも含めることができます。

  4. [プロジェクトのパッケージ化] ウィンドウの [パッケージ化の開始] で、[パッケージをオンライン アカウントにアップロード] を選択します。

    パッケージをオンライン アカウントにアップロード

    プロジェクト パッケージを ArcGIS Online またはポータル上のアイテムとして共有します。 この方法で、プロジェクトのメタデータを表示したり *.ppkx ファイルをダウンロードしたりできる場所へのリンクを電子メールで同僚に送信できます。 パッケージをローカル コンピューターに保存する場合は [パッケージをファイルに保存] を選択します。

  5. [プロジェクトのパッケージ化] ウィンドウで、次の情報を入力します。
    • [名前] に「Mali Language Groups Project」と入力して、その後に自分のイニシャルを追加します。
    • [概要] に「Mali Language Groups mapping project」と入力します。
    • [タグ]に「Mali」、「Mali districts」、「Mali Cities」、「Language groups」と入力します。
    • [次のグループと共有][すべての人に公開] をオンにします。

    これにより、アイテムのリンクを受け取った誰もがそのアイテムにアクセスできるようになります。 組織内でのみ共有したい場合があります。

    プロジェクト パッケージ設定の更新

    メモ:

    ArcGIS Proでの共有の詳細

  6. [パッケージ化の完了] で、[分析] をクリックします。

    分析は、プロジェクトをパッケージとして共有する前に解決する必要があるパフォーマンス上の遅延やエラーを識別するのに役立ちます。 黄色の警告がある場合は、共有がまだ続行中です。 赤色のエラーが表示された場合、それをポイントすると、問題を解決する方法のヒントを得ることができます。

    プロジェクト パッケージ化のメッセージの確認

    問題は検出されませんでした。

  7. [パッケージ化の完了] で、[パッケージ] をクリックします。
  8. [プロジェクトの保存] ウィンドウで [はい] をクリックします。

    パッケージ化する前にプロジェクトを保存

    パッケージ化が完了すると、[プロジェクトのパッケージ化] ウィンドウの下部に、正常に完了したという緑色のメッセージが表示されます。

  9. [パッケージの管理] をクリックします。

    パッケージの管理

  10. ブラウザー ウィンドウが表示され、ArcGIS Online 上のプロジェクトのアイテム詳細ページが表示されます。

    公開されたパッケージの確認

    このページの URL を同僚と共有できるようになり、同僚はプロジェクト パッケージをダウンロードしたり、ArcGIS Pro で直接開いたりできるようになりました。

    ヒント:

    共有する前に、アイテム詳細ページ上の説明や他のメタデータ情報を更新することを検討してください。

ArcMap プロジェクトは ArcGIS Pro に正常にインポートされました。 データ フレームをマップに変換し、レイヤーを ArcGIS Online のデータと置き換え、フィーチャを編集して、シンボルとラベルのプロパティを変更しました。 レイアウト上の凡例を変更し、他のユーザーが簡単にアクセスできるプロジェクト パッケージとしてマップを共有しました。

ツールの場所や ArcMap で慣れているタスクの実行方法についての質問がある場合は、 次のリンクに、ArcGIS Pro に切り替える ArcMap ユーザーのための詳細情報があります。

その他のレッスンについては、「Learn ArcGIS Lesson ギャラリー」をご参照ください。