3D での溶存酸素の調査

酸素濃度は海洋の生態系を構成する重要な要素です。海洋の酸素濃度はこの数十年間に全世界的に減少しており、今後、気候崩壊の影響が深刻化するにつれ減少し続けることが最近の調査で立証されています。この困難な問題に取り組むためには、海洋中の溶存酸素濃度の正確な三次元モデルを作成できる必要があります。

カリフォルニア州モントレー湾のさまざまな水深で取得された溶存酸素計測値を使用し、3D の地球統計学的内挿を実行して湾全体にわたる酸素濃度を予測します。3D データを調査し、Empirical Bayesian Kriging 3D (EBK3D) のパラメーターを構成して、結果を簡易な GIS 形式およびビデオ アニメーションへとエクスポートする方法を学習します。

プロジェクトのダウンロードおよび調査

まず、溶存酸素計測値を含んでいるプロジェクトをダウンロードし、ArcGIS Pro で開きます。

  1. モントレー湾の 3D 溶存酸素計測値の補間プロジェクト パッケージをダウンロードします。
  2. コンピューター上で、ダウンロードしたファイルを選択します。
  3. [Interpolate_3D_Dissolved_Oxygen_Measurements_in_Monterey_Bay.ppkx] をダブルクリックして、プロジェクトを開きます。サイン インが要求されたら、ArcGIS 組織のアカウントにサイン インします。

    プロジェクトが開くと、マップとローカル シーンが表示されます。

  4. [Monterey Bay] マップ タブをクリックします。必要に応じて、マップ上のポイントを拡大表示して見やすくします。

    酸素サンプル ポイントの 2D マップ

    [OxygenPoints] レイヤーは、米国海洋大気庁 (NOAA) 国立環境情報センター (National Centers for Environmental Information) の全球海洋観測データベース (WOD: World Ocean Database) によって提供されるデータの小規模サンプルです。これらのポイントは、モントレー湾内で溶存酸素濃度 (計測単位: マイクロモル/リットル) がさまざまな水深で観測および記録された位置を表します。

  5. [コンテンツ] ウィンドウで、[OxygenPoints] レイヤーを右クリックして [属性テーブル] を選択します。

    [属性テーブル] オプション

    レイヤーの属性テーブルが開きます。

  6. [マップ] タブの [選択] グループにある [選択] ボタンをクリックします。

    [選択] ボタン

  7. マップ上で、[OxygenPoints] フィーチャをすべて囲むボックスを描画します。

    ボックス内のすべてのフィーチャが選択されます。

  8. [OxygenPoints] テーブルの下にある [選択レコードを表示] ボタンをクリックします。

    [選択レコードを表示] ボタン

    選択レコードのみが属性テーブルに表示されます。

    テーブル内の選択レコード

    選択したサンプル ポイントの中で、X 座標と Y 座標は同じであるが、Z 値が異なっているものが複数あります。これらのポイントは、サーフェスより下のさまざまな深度 (z) で観測された酸素濃度を表しています。選択された一致レコードの数が画像例と異なることがありますが、これは、さまざまな水深にあるサンプル位置ごとに、サンプル数が同じでないことがあるためです。

    注意:

    この時点で酸素濃度の連続サーフェスを補完するとすれば、一度に 1 つの水深 (Z 値) でのみ内挿が実行される可能性があり、さまざまな水深に対応するには複数の補間されたサーフェスを作成する必要があるでしょう。このようなデータでは、水深の増加に伴う酸素濃度の差異を解釈して理解するのが困難です。

    次に、データを 3D シーン内で調査します。

  9. テーブルを閉じます。リボンの [マップ] タブの [選択] グループで、[選択解除] ボタンをクリックします。
  10. マップの上にある [Monterey Bay 3D] タブをクリックします。

    この 3D シーンには、10 倍の高さ強調係数が適用されたカリフォルニア州モントレー湾が表示されます。この結果、モントレーの海底峡谷は実際よりも 10 倍の深度と勾配で表示されます。標高サーフェスを定義するために [WorldElevation/TopoBathy] レイヤーが使用され、[World Ocean Base] ベースマップが標高の上にドレープされて 3D 効果をもたらします。この標高サーフェスは ArcGIS Living Atlas of the World で入手できます。

    モントレー湾の 3D 酸素計測値

    注意:

    一般に、このレッスンでは、ポイントの水深を正の数で表します (例: 「水深 150 メートルのポイント」)。ただし、実際のフィーチャクラスの Z 座標は負の数で格納され、多くの場合、各種ウィンドウや ArcGIS Pro のウィンドウでは標高として表記されます。負の標高は、ポイントの深度が平均海水面より下であることを示しています。

  11. [コンテンツ] ウィンドウで、[OxygenPoints] レイヤー展開します。

    酸素ポイントがそれぞれの酸素濃度によってシンボル表示されます。最小計測値は青色、最大計測値は赤色で表示されます。シンボルに加えて、ポイントには、標高サーフェスに適用されている強調に一致するように、深度に対する 10 倍の高さ強調係数も適用されます。

  12. [OxygenPoints] レイヤーを折りたたんでオフにします。[TargetPoints] レイヤーをオンにします。

    [TargetPoints] レイヤーには 3D でグリッド状になったポイントが含まれています。これらのポイントは属性を持たず、この後のレッスンでターゲット位置として機能します。

  13. [TargetPoints] レイヤーをオフにし、[OxygenPoints] レイヤーをオンにします。
  14. リボンの [マップ] タブの [ナビゲーション] グループで、[マップ操作] ボタンをクリックします。

    [マップ操作] ボタン

  15. モントレーの海底峡谷周辺を回転、傾斜、画面移動、ズームして、さまざまな位置および水深で酸素ポイントを観察します。
    注意:

    マウスにホイール ボタンがある場合は、ホイール ボタンをクリックしたまま 3D で回転や傾斜を実行できます。左ボタンをクリックすると画面移動し、右クリックするとズームします。[マップ操作] ツールを使用したナビゲーションの詳細については、「3D でのナビゲーション」をご参照ください。より高度な 3D ナビゲーションには、スクリーン ナビゲーターを使用できます。このナビゲーターでは、シーンまたはビューの左下にある 1 つのコントロールに多くのカメラ ナビゲーション コマンドが表示されます。

  16. 必要に応じて、[表示] タブの [ナビゲーション] グループにある [ナビゲーター] ボタンをクリックします。

    ナビゲーターでは、マップの左下にあるコントロールを使用して回転、移動、傾斜、画面移動、およびズームを行えます。

    注意:

    ナビゲーターは、カメラの動きに明確な制御が必要な場合に役立ちます。ナビゲーターはサイズ変更可能で、傾斜や方向変更のためのコントロールにすぐにアクセスできるようになっています。カメラ ナビゲーション コマンドの詳細については、「スクリーン ナビゲーターの使用」をご参照ください。

  17. シーン内の任意のポイントをクリックして、そのポップアップを確認します。

    水深ごとの酸素濃度

    それぞれのポイントはその酸素濃度によって個別にシンボル表示され、計測された水深 (Z 値) に表示されます。最高酸素計測値が海面近く、最低計測値が垂直カラムの中央近くに見られます。同じ水深にあるポイントでは酸素濃度がほぼ同じになる傾向があります。ただし、垂直カラム間を上下に移動すると、酸素濃度はすばやく変化します。

  18. ポップアップを閉じます。
  19. リボンの [マップ] タブの [ナビゲーション] グループで、[ブックマーク] をクリックして [Monterey Canyon] を選択します。

    [Monterey Canyon] ブックマーク

酸素計測値の調査

次に、ヒストグラム チャートを使用して溶存酸素計測値の分布を調べ、変換を使用して、この分布が内挿により適したものになるように調整します。ヒストグラムでは、酸素計測値がデータセットに現れる頻度を計測することで、溶存酸素計測値の分布を集計して視覚的に表現します。内挿は正規分布のデータに対して最も効果的に適用されるため、データが偏っている (分布が不均衡) 場合は、データを変換して正規化してみることができます。ヒストグラムを使用すると、データ分布で対数変換や平方根変換の効果を探索できます。

  1. [コンテンツ] ウィンドウで、[OxygenPoints] を右クリックして [チャートの作成] をポイントし、[ヒストグラム] を選択します。

    [ヒストグラム] オプション

    [チャート] および [チャート プロパティ] ウィンドウが表示されます。調査するフィールドを指定するまで、[チャート] ウィンドウは空の状態です。

  2. [チャート プロパティ] ウィンドウの [データ] タブの [数値] で、[Oxygen] を選択します。

    これが、各ポイントの溶存酸素計測値を格納するフィールドです。

    [数値] パラメーター

    [チャート プロパティ] ウィンドウで、平均/最小/最大酸素計測値を示す統計情報が更新されるとともに、チャート ウィンドウが更新されて計測値のヒストグラムが表示されます。次の統計情報が含まれます。

    • [数] は 809 ポイントです。
    • [平均] 溶存酸素濃度は 1.303 マイクロモル/リットルです。
    • 最低 ([最小]) 溶存酸素濃度は 0.140 です。
    • 最高 ([最大]) 溶存酸素濃度は 6.774 です。

    ヒストグラムの統計情報

    このヒストグラムは、分布が大きく左側に偏っている、つまり、分布の下限に多くの観測データが存在し、上限にはデータがほとんどない状態を示しています。

    酸素計測値のヒストグラム

    注意:

    ヒストグラムの各軸に表示される値は、ウィンドウのサイズによって決まるため、ユーザーによって異なる場合があります。

  3. [チャート プロパティ] ウィンドウの [正規分布の表示] ボックスをオンにします。

    このヒストグラムに最もフィットする正規分布と結果を視覚的に比較できるように、チャートが更新されます。

    正規分布ではない酸素計測値

    ヒストグラムに重ねて描画された正規分布を比較すると、ヒストグラムのバーが分布曲線に沿っていないことは明らかです。次に、変換を使用して、酸素計測値の分布を正規分布に近づけてみましょう。

    変換は各データ計測に適用される数学演算で、これには、各値の平方根や対数を取ることなどが挙げられます。変換後のデータセットの分布は元のデータセットの分布と異なります。内挿方法は、データが正規 (釣鐘型) 分布に近いときに最も効果的に適用されます。このため、変換を用いてデータセットを正規分布に近づけることができます。

  4. [チャート プロパティ] ウィンドウの [変換] で、[平方根] を選択します。

    ヒストグラムが更新され、平方根変換が適用された分布が表示されます。

    平方根変換が適用され、右側に偏りが生じた酸素計測値

    平方根変換の適用によって、偏りの一部は解消されましたが、分布はまだ右側に大きく偏っており、正規分布曲線とヒストグラムはあまり一致していません。

  5. [チャート プロパティ] ウィンドウの [変換] で、[対数] を選択します。

    ヒストグラムが更新され、対数変換が適用された分布が表示されます。

    対数変換が適用され、正規分布に近づいた酸素計測値

    これで、前の 2 つのヒストグラムと比べると、分布はより対称的な、釣鐘型に近い形状になりました。これで対数変換が有効であるということがわかりました。これは、後で内挿オプションおよび設定を構成するときに役立ちます。

  6. [チャート プロパティ] ウィンドウおよび [OxygenPoints – Distribution of Oxygen] テーブルを閉じます。

酸素と標高の関係の調査

3D でのナビゲーション中に、湾の海面近くの溶存酸素濃度が最高で、垂直カラムの中央の濃度が最低であることが観察されました。次に、散布図を使用して、水深に伴って酸素濃度がどのように変化するかを視覚化します。

散布図を使用すると、2 つの数値変数の関係を視覚化できます。1 つの変数は X 軸に表示され、もう 1 つの変数は Y 軸に表示されます。

  1. [コンテンツ] ウィンドウで、[OxygenPoints] を右クリックして [チャートの作成] をポイントし、[散布図] を選択します。
  2. [チャート プロパティ] ウィンドウの [データ] タブの [X 軸: 数値] で、[Oxygen] を選択します。
  3. [Y 軸: 数値][z] を選択します。

    チャート名が更新されて [Relationship between Oxygen and z] になります。

  4. [チャート プロパティ - OxygenPoints] ウィンドウの [リニア トレンドの表示] をオフにします。

    散布図パラメーター

    この散布図から、酸素濃度と水深の間に明確な関係があることがわかります。酸素濃度は海面付近で最大になり、その後すぐに定常的に低下し続けます。

    酸素の値と水深を比べた散布図

    最低値は約 -600 メートルから -1,000 メートルの間に現れます。-1,000 メートルより下の水深になると酸素濃度は徐々に上昇し続けます。

    注意:

    さまざまな水深で計測された値をプロットする場合は、Y 軸に水深値を設定することが最も一般的ですが、このレッスンで関心の対象となるのは、水深に基づく酸素濃度の予測であるため、散布図の X 軸に水深を設定する方がより理にかなっています。

  5. [チャート プロパティ] ウィンドウで、次のパラメーターを変更します。
    • [X 軸: 数値][z] を選択します。
    • [Y 軸: 数値][Oxygen] を選択します。

    散布図が更新され、X 軸に水深が表示された状態で水深と酸素濃度の関係が表示されるようになります。

    X 軸に水深が設定された散布図

    前に作成したヒストグラムから、対数変換が適切な選択であることがわかっているため、酸素計測値を対数スケールで表した散布図を表示することが役立つでしょう。

  6. [チャート プロパティ] ウィンドウで、[軸] タブをクリックします。[Y 軸] プロパティの [Log 軸] をオンにします。
    注意:

    対数軸の使用は、直線軸のデータに対数変換を適用することと同じです。これは、前のセクションでヒストグラムに対して行った処理と似ています。

    [Log 軸] パラメーター

    散布図が更新されて、対数スケールで酸素の値が表示されるようになります。対数スケールが適用されると、サーフェスの値が最大で、サーフェスより 800 メートル下付近の値が最小であるという、以前と同じ傾向が見られます。約 -800 メートルの水深までつながっている 2 本の別々のラインをポイントが形成しているように見えます。

    対数スケールで酸素計測値が表示された散布図

    このデータの場合、散布図の近似を示すために必要なラインは 2 本だけですが、 より広範な分布の散布図では、より多くのラインを使用すると、さらに正確な近似を示すことができるでしょう。これは非常に重要な調査結果です。というのも、ローカルのリニア トレンドは、内挿の実行時にモデル化したり、削除したりできるためです。

  7. [チャート プロパティ] ウィンドウおよび [OxygenPoints – Relationship between Oxygen and z] ウィンドウを閉じます。
    注意:

    チャートはレイヤーのプロパティとして管理されるため、チャート作成ウィンドウを閉じても削除されません。チャートを表示するには、[コンテンツ] ウィンドウの [OxygenPoints] レイヤーの凡例を展開し、凡例の下部までスクロールします。凡例内のチャートをダブルクリックすると、チャートが再び開きます。

    [コンテンツ] ウィンドウの [チャート]

  8. 必要に応じて、[コンテンツ] ウィンドウで [OxygenPoints] レイヤーを折りたたみます。
  9. プロジェクトを保存します。

ローカル シーンをナビデートし、ヒストグラムと散布図を使用して、モントレー湾の溶存酸素計測データを調査しました。最大酸素計測値が海面近く、最小計測値が垂直カラムの中央近くにあることを観察しました。

次に、ヒストグラム チャートの利用によって、対数変換が溶存酸素計測値の分布を安定化させることを確かめました。散布図には、酸素濃度と水深の間に強い関係があることが示されており、対数スケールで酸素を表すと、水深に基づくローカルのリニア トレンドによって正確な近似を示すことができると判断しました。


Empirical Bayesian Kriging 3D を使用した溶存酸素の補間

前のレッスンでは、マップで溶存酸素測定値を調査し、酸素計測値の分布が理解しやすくなるようにチャートを使用しました。また、酸素濃度が水深によって大きく異なることを確認しました。

次に、これらの見識を基に、酸素値を 3D 連続モデルに補間して、モントレー湾全体にわたる溶存酸素濃度を予測します。[Empirical Bayesian Kriging 3D (EBK3D)] ジオプロセシング ツールを使用して内挿を実行し、シーンで 3D モデルを調査します。次に、交差検証によって、モデルが正確に溶存酸素を予測するかどうかを評価します。

ジオプロセシング ツールを使用した補間

このセクションでは、EBK3D ジオプロセシング ツールを使用して、溶存酸素計測値を連続モデルに内挿し、計測ポイント間のあらゆる場所で溶存酸素濃度を予測します。

  1. 必要に応じて、プロジェクトを開きます。
  2. リボンの [解析] タブの [ジオプロセシング] グループで、[ツール] をクリックします。

    [ツール] ボタン

    [ジオプロセシング] ウィンドウが開きます。

  3. [ジオプロセシング] ウィンドウの検索ボックスに、「Empirical Bayesian Kriging 3D」と入力します。検索結果で、[Empirical Bayesian Kriging 3D] をクリックします。

    検索結果の [Empirical Bayesian Kriging 3D]

    EBK3D は Geostatistical Wizard 内およびジオプロセシング ツールとして利用可能です。内挿の結果は、指定の標高で水平方向の横断ラインを表示する Geostatistical レイヤーになります。レンジ スライダーを使用して現在の標高を変更すると、レイヤーが更新されて、その新しい標高の補間された予測が表示されます。

  4. [Empirical Bayesian Kriging 3D] ジオプロセシング ツールで、次のパラメーターを変更します。
    • [Input features] に、[OxygenPoints] を指定します。
    • [Elevation field][Shape.Z] に設定されていることを確認します。
    • [Value field] で、[Oxygen] を選択します。
    • [Output geostatistical layer] で、既存のテキストを削除して「Oxygen Prediction」と入力します。

    [Empirical Bayesian Kriging 3D] ツールのパラメーター

    ツールの実行に必要なのは、これらのパラメーターだけです。ただし、前回のレッスンでは、溶存酸素計測値の分布は対数変換を必要とすることを学習しました。このジオプロセシング ツールでは、Log Empirical 変換によって対数変換を適用した後、追加的に正規スコア変換を適用します。

    注意:

    正規スコア変換は、このレッスンでは取り上げませんが、正規分布への柔軟なノンパラメトリック変換であり、経験的分位点を正規分布の対応する分位点に等しいと見なすことに基づいています。対数を適用し、さらに経験的正規スコア変換 (Log Empirical) を使用すると、変換後に結果として表示される分布は正規分布に近くなり、EBK3D を実行するのに最適になります。

  5. [Advanced Model Parameters] を展開します。[Transformation type] で、[Log Empirical] を選択します。

    変換タイプを変更すると、[Semivariogram model type] が自動的に [Exponential] に変化します。デフォルトのセミバリオグラム モデルは変換と同時に適用されません。

    前のレッスンでは、水深に基づく 2 本のローカル トレンド ラインによって酸素濃度の正確な近似が得られることを学習しました。EBK3D では、1 次 (リニア) トレンドの削除を選択して、酸素計測値の垂直リニア トレンドを推定します。この垂直トレンドはサブセット内でローカルに計算されるため、1 次トレンドの削除は、水深対酸素の散布図でローカル トレンド ラインをフィッティングすることに対応します (線形回帰に関する経験がなければ、サブセットでの垂直トレンドの削除と散布図のローカル ラインが対応していることが見てわからないかもしれません)。連続する直線によってこの散布図の正確な近似が得られることが前のレッスンで明らかになったため、1 次トレンドを削除します。

  6. [Advanced Model Parameters] の下にある [Order of trend removal] で、[First order] を選択します。

    [Empirical Bayesian Kriging 3D] ツールの詳細パラメーター

    [Elevation inflation factor] パラメーターは、垂直方向に計測された値と水平方向に計測された値の変化速度の比率を定義します。たとえば、水平方向よりも垂直方向の値の方が 10 倍速く変化する場合、この値は 10 になります。この係数を方程式で使用すると、3D で全方向の計測値に対する適切な重み付けが可能になります。この時点で、酸素計測値に適した標高拡大係数はわからないため、このパラメーターは空のままにします。値はツールの実行時に推定されます。この推定値は、ツールの実行後にツールの詳細を表示することで確認できます。

    この例では、標高拡大係数は、酸素計測値の垂直方向の変化が水平方向の変化よりはるかに速いという事実を補正するために使用されます。マップと散布図の両方で観察されたこの事実は、3D 内挿の問題をもたらします。その理由は、新しい位置で予測を実行するには、クリギング方程式により、それぞれの計測値に対して適切な重み付けを行う必要があるためです。計測値の垂直方向の変化が水平方向より速い場合、これは、新しい位置で予測を実行するときに、水深がほぼ同じであるポイントは、水深が大きく異なるポイントと比べてより大きな重みを付ける必要があることを意味します。これは、同じ水深にあるポイントが予測位置から比較的遠く離れている場合にも当てはまります。

  7. [Advanced Model Parameters] を折りたたみ、[Search Neighborhood Parameters] を展開します。

    [Search neighborhood] パラメーターは、新しい位置で予測を実行するときの近傍の決定方法を定義します。新しい値を予測するには、予測位置近くの酸素計測値 (近傍と呼ばれる) を特定する必要があります。データが垂直カラムを形成する場合は特に、いろいろな方向のさまざまな近傍を取得することが重要になります。

  8. [Search Neighborhood Parameters] で、次のパラメーターを確認します。
    • [Search neighborhood][Standard 3D] に設定されていることを確認します。
    • [Max neighbors]2 に設定されていることを確認します。
    • [Min neighbors]1 に設定されていることを確認します。
    • [Sector Type][12 Sectors (Dodecahedron)] に設定されていることを確認します。

    Search Neighborhood Parameters

    これらの設定は、近傍の検索が 3D の異なる 12 方向で実行され ([Sector Type])、12 方向のそれぞれで最低 1 つの近傍が検出され ([Min neighbors])、最高 2 つの近傍が検出される ([Max neighbors]) ことを確実にします。

  9. [Run] をクリックします。

    ツールが実行されます。ツールの実行には 1 分程度かかることがあります。ジオプロセシング ツールを実行すると、プロジェクトのジオプロセシング履歴にエントリが追加されます。このとき、詳細情報として、ツールの実行日時、使用した設定、ツールが正常に完了したかどうか、およびエラー メッセージが記録されます。

  10. ツールの実行が完了すると、[ジオプロセシング] ウィンドウの [詳細の表示] をクリックします。

    [詳細の表示] ボタン

    ウィンドウが開き、ツールで使用されたパラメーターのサマリーが表示されます。[メッセージ] セクションに、標高拡大係数が約 12.7 であると推定されていることが示されます。これは、垂直トレンドの削除後も、酸素値の垂直方向の変化は水平方向よりも約 12.7 倍速いままであったことを意味します。

    標高拡大係数の値

  11. ウィンドウを閉じます。

    [Oxygen Prediction] Geostatistical レイヤーがマップに追加されました。このレイヤーは海面に 2D スライスとして表示されます。このレイヤーは最初に全体が赤色で表示され、レイヤーの 3D 範囲の周りに小さな 3D ワイヤーフレーム ボックスが描画されます。このワイヤーフレーム ボックスが画面に表示されない場合は、[World Ocean Base] レイヤーをオフにします。この Geostatistical レイヤーには、標高サーフェスおよびポイントと同じ高さ強調が適用されていません。このため、ワイヤーフレーム ボックスが酸素計測値の 3D 範囲に視覚的に一致しません。

    最初の Geostatistical レイヤー

3D での Geostatistical レイヤーの調査

前のセクションでは、EBK3D を使用して、モントレー湾全域の溶存酸素濃度を予測する Geostatistical レイヤーを作成しました。次に、Geostatistical レイヤーを 3D で調査します。最初に、一部の標高およびシンボル設定を変更します。

  1. [コンテンツ] ウィンドウで、[Oxygen Prediction] を右クリックし、[プロパティ] を選択します。
  2. [標高] タブの [高さ強調] で、「10」と入力します。

    これにより、ベースマップおよびポイントと一致するように Geostatistical レイヤーの高さ強調係数が設定されます。

    [高さ強調] パラメーター

  3. [OK] をクリックします。

    Geostatistical レイヤーの周りのワイヤーフレーム ボックスが酸素計測値の一番下まで拡大します。次に、異なる配色を Geostatistical レイヤーに適用します。

  4. [コンテンツ] ウィンドウで、[Oxygen Prediction] レイヤーを展開します。

    [Oxygen Prediction] レイヤーの凡例を展開

    Geostatistical レイヤーは、分類方法に基づく塗りつぶしコンターを使用してレンダリングされます。このデータのデフォルトの配色によると、予測された酸素濃度が 3.785 マイクロモル/リットルを上回るエリアを示すのに赤色が使用されます。海面にあるすべての位置の酸素濃度がこの値を上回ると見られるため、海面では 2D スライス全体が赤色でレンダリングされます。

  5. [Oxygen Prediction] レイヤーを折りたたみます。

    海面での予測された酸素濃度のばらつきを表示するために、分類方法を変更し、クラス数を増やします。

  6. [Oxygen Prediction] レイヤーを右クリックして、[シンボル] を選択します。

    [シンボル] ウィンドウが表示され、使用可能な分類オプションが表示されます。

  7. [シンボル] ウィンドウの [方法] で、[等間隔] を選択します。[クラス] に「32」と入力します。

    シンボルを等間隔の 32 クラスに変更

    方法とクラス数を変更すると、Geostatistical レイヤーが更新されて、予測された酸素濃度が等間隔の 32 クラスの配色を使用して表示されます。これで、更新されたカラー ランプにより、海面における酸素濃度の差異を確認することができます。

    更新された酸素予測シンボル

  8. [シンボル] ウィンドウの [数値分類] リストを下にスクロールして、海面の酸素濃度に関連付ける黄色とオレンジ色のクラス閾値を表示します。

    海面上で観察されるように、これらのクラス閾値は約 4 ~ 6 マイクロモル/リットルの溶存酸素濃度に対応しています。

    約 4 ~ 6 マイクロモル/リットルの予測された酸素濃度

  9. [シンボル] ウィンドウを閉じます。

    この 3D Geostatistical レイヤーに対して、[Monterey Bay 3D] シーンの右側にあるレンジ スライダーが自動的に有効になります。コントロールをポイントすると、コントロールがアクティブになり、Geostatistical レイヤーの現在の水深を変更できるようになります。

  10. [レンジ スライダー] コントロールで、スライダーをポイントし、緑色のボックス内をクリックします。「-100」と入力し、Enter キーを押します。

    レンジ スライダーで水深を海面下 100 メートルに変更

    スライダーが海面下 100 メートルの水深まで移動します。Geostatistical レイヤーが更新されて、新しい水深の予測された酸素濃度が表示されます。

    注意:

    新しい水深でレイヤーが更新されるまでに数秒かかることがあります。コンピューター上で更新にかかる時間が長すぎるようであれば、[シンボル] ウィンドウでクラス数を減らすことができます。この変更により、計算速度が上がりますが、このレッスンで説明した基本概念は変わりません。

    100 メートルの水深で描画される Geostatistical レイヤー

    海面下 100 メートルでは、予測された酸素濃度が大幅に低下しています。これは、散布図で確認された内容に基づくと、予測された状況です。

  11. レンジ スライダー コントロールの中央部分をポイントし、[下へ] ボタンを押します。

    [下へ] ボタン

    レイヤーが水深 169 メートルまで下方向へ移動し、Geostatistical レイヤーが更新されます。Geostatistical レイヤーが海洋中をより深く移動するにつれ、予測された溶存酸素値が低下します。

  12. 元の海面の位置になるまでスライダーをドラッグします。

    海面へドラッグされた Geostatistical レイヤー

    注意:

    誤ってスライダーを 1 つの間隔に分類した場合、Geostatistical レイヤーでは常にその間隔内の最も上の値が使用されます。

  13. リボンの [レンジ] タブをクリックします。[再生] グループの [方向] をクリックして、アニメーションの再生方向を上から下に設定します。

    [方向] ボタン

  14. レンジ スライダーの [再生] ボタンをクリックします。

    [再生] ボタン

    [Oxygen Prediction] レイヤーが海中を下方向に移動し、30 の異なる水深で予測された酸素濃度が表示されます。位置が低下するにつれ、レイヤーが標高サーフェスおよびベースマップの下に移動します。

    注意:

    このアニメーションが完了するまでに数分かかることがあります。これは、新しい水深になるたびにレイヤーでその位置を計算してコンターに合わせる必要があるからです。ただし、水深が一度計算されたら、その値がキャッシュされるので、その同じ水深では、次回以降は毎回、高速に描画されるようになります。

    連続するさまざまな水深のレンジ

  15. アニメーションが終了したら、元の海面の標高 (0) になるまでスライダーをドラッグします。
  16. もう一度 [再生] ボタンをクリックします。

    今度はアニメーションの再生速度が速くなるため、酸素濃度が変化していく様子を確認できます。注意深く観察すると、水深 800 メートルのあたりまで酸素濃度が低下していき、その後、酸素濃度は徐々に上昇し始めることがわかります。

  17. 元の海面の標高 (0) になるまでレンジ スライダーをドラッグします。

モデルの精度評価

マップまたはシーンで調べることによって、モデルに関する多くの洞察を得ることができます。しかし、予測された溶存酸素濃度の正確性および信頼性を検証するには、より定量的な検証手法が必要です。Geostatistical モデルを検証する一般的な手法は交差検証によるものです。

交差検証では、1 つの計測ポイントを削除した後、残りのすべてのポイントを使用して、削除されたポイントの位置を予測します。次に、隠されたポイントの計測値が、交差検証の予測値と比較されます。これらの 2 つの値の差は、交差検証誤差と呼ばれ、すべての入力ポイントを対象に実行されます。

  1. [コンテンツ] ウィンドウで、[Oxygen Prediction] を右クリックし、[Cross Validation] を選択します。

    [Cross Validation] ウィンドウが開き、内挿モデルの正確性に関する各種のグラフィックス診断および数値診断が表示されます。このウィンドウは左側のグラフと右側の統計情報のサマリーで構成されます。計算された統計情報は、モデルとその関連付けられたパラメーター値が妥当であるかどうかを示す診断としての役割を果たします。

    交差検証の統計情報のサマリー

    サマリー統計には、次の情報が含まれます。

    • [Mean] および [Mean Standardized] 誤差は両方とも 0 に近く (それぞれ 0.007 と 0.017)、モデルのバイアスが極めて小さいことを示します。そのモデルは、大きすぎる/小さすぎる値を予測する傾向がありません。
    • [Root-Mean-Square] の値は 0.26 で、予測された酸素濃度と計測値の差は平均で約 4 分の 1 マイクロモル/リットルであることを示します。
    • [Root-Mean-Square-Standardized] の値は 0.94 で、目標値の 1 に近く、[Average Standard Error] は 0.22 で、二乗平均平方根とほぼ等しくなります。これらは、予想のばらつきが正しく推定されていることを示しています。
    • [Inside 90/95 Percent Interval] の値は 90.9 と 95.4 で、どちらも目標値である 90 と 95 に近く、予測値と予測の不確実性の間に整合性があることを示しています。
    • [Average CRPS] は文字どおりに解釈することが困難な値ですが、値が小さいほど、正確性および精度が高いことを示しています。この値は 0.083 で、次のレッスンで別のモデルと比較されます。
  2. [Cross Validation] ウィンドウの右側で、[Table] タブをクリックします。

    テーブルのタブ

    このテーブルには、各入力ポイントの個別の交差検証結果が表示されます。これらの値は、ウィンドウの右側のグラフを生成するために使用されます。

  3. 必要に応じて、[Cross Validation] ウィンドウの左側にある [Predicted] タブをクリックします。

    交差検証では、モデルが隠されたポイントで酸素値を正確に予測できる場合、そのモデルは、計測されなかった新しい位置で酸素濃度を正確に予測できなければなりません。

    このグラフは、交差検証から予測された酸素値とポイントごとに計測された酸素値を比較した散布図です。モデルが正確であれば、予測値と測定値が等しくなければならないため、ポイントがグレーの参照ライン沿いにあることが理想的とされます。青色の回帰直線は、これらのポイントがこの目標ラインにどれだけ近い位置にあるかを判断するために使用されます。

    予測値と計測値を比較したグラフ

    これらのポイントは、回帰直線 (青色) が参照ライン (グレー) をほぼ覆ってしまうほど目標に近いため、見づらくなっています。

    右上のポイントは、酸素値が高いほど、回帰直線周辺のポイントのばらつきが大きいことを示しています。これは、地球統計データでは一般的ですが、興味深いことに、この状況は、海中で酸素濃度が高いエリアよりも酸素濃度が低いエリアでより正確な予測をモデルが実行できることを意味しています。

    グラフの右上隅

  4. [Cross Validation] ウィンドウの左側にある [Error] タブをクリックします。

    計測値と誤差値のグラフには、交差検証誤差に対してプロットされた酸素計測値が表示されます。青色の回帰直線は平らであり、酸素濃度が低い場合も高い場合も、モデルがバイアスのない予測を実行していることを示しています。

    [Error] タブ

    このグラフは、すべての酸素濃度について、予測にバイアスが存在しないことを示すとともに、回帰直線周辺のポイントでは、測定値が最も高いポイントでばらつきが最大になることを示しています。これは、平均でモデルは大きい酸素値を正確に予測しているが、酸素濃度が高いエリアでは個々の予測に大きなばらつきがあることを意味します。

  5. [Cross Validation] ウィンドウを閉じます。

    交差検証の統計情報のサマリーとグラフを利用すると、作成した EBK3D モデルが、約 4 分の 1 マイクロモル/リットルという平均誤差を示しながら、モントレー湾全体にわたる溶存酸素濃度を正確に予測できる確実な証拠が得られます。一般的に、この誤差は酸素濃度が最も高い海面付近で大きくなります。

  6. プロジェクトを保存します。

[Empirical Bayesian Kriging 3D] ツールを使用して、モントレー湾の溶存酸素計測値を補間しました。また、レンジ スライダーを使用して Geostatistical レイヤーを 3D で調査する方法を理解し、交差検証を利用してモデルの正確性を実証しました。


Geostatistical Wizard での 3D 内挿の実行

前のレッスンでは、EBK3D ジオプロセシング ツールを使用し、モントレー湾全体の溶存酸素計測値を補間しました。レンジ スライダーを使用し、Geostatistical レイヤーの深度を変更する方法を学び、モデルの精度を検証しました。

次に、Geostatistical Wizard を使用して、溶存酸素計測値を補間します。Geostatistical Wizard では EBK 3D 手法で予測を立てるために使用する、ローカル クリギング モデルを順を追って操作できます。これらのローカル モデルを探索すると、モントレー湾全体でのローカル モデルの変化を視覚化できます。

Empirical Bayesian Kriging 3D の実行

最初に、2D マップに移動して、Geostatistical Wizard を使用して EBK3D (Empirical Bayesian Kriging 3D) を実行します。デフォルト設定をすべて使用し、交差検証の結果と前回のレッスンの高度なモデルを比較します。

Geostatistical Wizard は、内挿モデルを構築し、そのパフォーマンスを評価するプロセスを順を追って実行するために設計されたページのダイナミックなセットです。1 つのページでの選択によって、それ以降のページで指定できるオプションや、適切なモデルを構築するためにデータを操作する方法も変わってきます。このウィザードでは、内挿方法を選択するところから、モデルで予期されるパフォーマンスのサマリー計測値を表示するところまでを行います。

  1. 必要に応じて、プロジェクトを開きます。
  2. [Monterey Bay] マップ タブをクリックします。

    マップがモントレー湾の 2D マップに変わります。酸素計測値がマップに描画されます。

  3. 必要に応じて、[OxygenPoints] テーブルを閉じます。
  4. リボンの [解析] タブをクリックします。[ワークフロー] グループで、[Geostatistical Wizard] をクリックします。

    [Geostatistical Wizard] ボタン

    Geostatistical Wizard が開きます。ウィザードの 1 ページ目の左側では内挿方法を選択でき、右側では入力パラメーターを指定できます。

  5. [3D Interpolation] グループで [Empirical Bayesian Kriging 3D] を選択します。[Input Dataset] の下の [Source Dataset] で、[OxygenPoints] を選択します。[Data Field] で、[Oxygen] を選択します。

    Geostatistical Wizard の最初のページのパラメーター

    これらの設定は、[OxygenPoints] レイヤーの [Oxygen] 値フィールドで EBK3D を実行することを指定します。

  6. [Geostatistical Wizard] ウィンドウで、[Next] をクリックします。

    Geostatistical Wizard の 2 ページ目が開きます。

    Geostatistical Wizard の 2 ページ目

    Geostatistical Wizard の 2 ページ目は、複数のセクションに分かれています。

    • [General Properties] セクションには、EBK3D で使用できるすべてのパラメーターが表示されます。
    • プレビュー サーフェスは、現在の海深での予測酸素値の水平スライスを示します。[General Properties] でパラメーターが変更されると、それに合わせてプレビュー サーフェスが更新されます。このようにして、パラメーターを対話的に変更し、モデルの変化を見ることができます。
    • ページ左下のセクションには、セミバリオグラムが表示されます。これは、現在の位置と深さで EBK3D からシミュレートされたローカル モデルです。グラフの青色の線は、その位置でのシミュレートされたセミバリオグラムです。このグラフには、データから直接計算された青色の十字も示されています (経験的セミバリアンス)。一般的に、青色の十字は、シミュレートされたセミバリオグラムの中間あたりに集まります。
    • ページ右下の [Identify Result] セクションは、現在の位置と、プレビュー サーフェスの予測値を表示します。位置 ([X] および [Y]) と深さ ([Z]) は [Identify Result] セクションに座標を入力するか、プレビュー サーフェスで位置をクリックすることで変更できます。
  7. プレビュー サーフェスをポイントします。

    現在の深さを変更するための深度スライダーが表示されます。

    深度スライダー

    マップのレンジ スライダーと同じように、このスライダーをドラッグすると、深さを変更することができます。また、スライダーの下にあるボックスに深さを入力することもできます。

  8. スライダーの下にあるボックスに「-500」と入力して、Enter キーを押します。

    深さ 500 メートルのプレビュー サーフェス

    プレビュー サーフェスには、海面から深さ 500 メートルで予測された酸素濃度が表示されます。グラフがこれに合わせて更新され、現在の位置と深さで EBK3D からシミュレートしたローカル モデルを表示するようになります。

    ローカル クリギング モデル

  9. プレビュー セクションで、さまざまな深さにスライダーをドラッグします。

    各深度でプレビュー サーフェスのさまざまな位置をクリックして、ローカル セミバリオグラムの変化を観察します。場所によっては、セミバリオグラムが急上昇することがあります。これらのモデルの上昇が急であればあるほど、その位置での酸素値も急速に変化します。

    複数のセミバリオグラム

  10. ローカル モデルの探索を終了したら、スライダーをドラッグして海面に戻します。

    Geostatistical Wizard で EBK3D のデフォルト設定をすべて許可し、前回のレッスンで作成した高度なモデルの結果と比較できるようにします。チャート作成と探索において高度な設定を使用することを正当化したため、次に、これらの高度なオプションを使用して、より適切な結果を得られたかどうかを確認します。

  11. Geostatistical Wizard で [Next] をクリックします。

    Geostatistical Wizard が実行され、デフォルトの EBK3D 設定の交差検証の結果が表示されます。このページは、前回のレッスンで作成した [Cross Validation] ウィンドウによく似ていますが、Geostatistical Wizard に統合されています。計測値が X 軸に、予測値が Y 軸に表示されます。

    プロットされた予測値と計測値の比較

    予測値と計測値を比較したグラフは、前回のレッスンの高度なモデルと同じパターンを表示します。回帰線はグレーの参照線にほぼ重なっており、最大の酸素計測値は回帰線周辺で最大のばらつきを示します。

  12. [Error] タブをクリックします。

    誤差値が X 軸に、計測値が Y 軸に表示されます。

    [Error] タブ

    計測値と誤差値のグラフは、前回のモデルと同じパターンを示しています。回帰線はフラットで、計測値が大きければ、回帰線周辺のばらつきも大きくなります。

  13. サマリー統計を確認します。

    次に、[Geostatistical Wizard] が生成したデフォルト モデルと前回の高度なモデルにおけるサマリー統計の比較を表にまとめます。

    統計高度なモデルデフォルト モデル

    Average CRPS

    0.083

    0.114

    Inside 90 Percent Interval

    90.9

    91.2

    Inside 95 Percent Interval

    95.4

    95.4

    Mean

    -0.007

    0.007

    Root-Mean-Square

    0.260

    0.308

    Mean Standardized

    0.017

    0.029

    Root-Mean-Square Standardized

    0.945

    0.964

    Average Standard Error

    0.228

    0.305

    サマリー統計では、次の情報がわかります。

    • [Mean][Mean Standardized] 値はどちらもゼロに近いので、デフォルト モデルのバイアスのレベルは低くなる。
    • [Root-Mean-Square Standardized] 値は 1 に近い。
    • [Inside 90 Percent Interval][Inside 95 Percent Interval] 値は、どちらも理想的な値である 90 と 95 に近い。
    • [Root-Mean-Square] 値は [Average Standard Error] 値とほぼ同等である。

    これらは期待を持てる結果であり、デフォルト モデルが地球統計モデルの評価に必要なすべての典型的なテストに合格したことを示します。ただし、次のことも事実です。

    • デフォルト モデルの [Root-Mean-Square] 値は、高度なモデルよりも 18% も大きい。
    • [Average CRPS] 値は 37% も大きい。

    グラフを目視確認しただけではこれらの点は見落とされがちですが、高度なモデルの方がデフォルト モデルよりもはるかに精度が高いのは明らかです。平均すると、高度なモデルの予測は実際値に 18% も近く、予測値に伴う不確実性も精度が高くなっています。この差を明確に識別するには、交差検証のような定量的比較を行うしかありません。

  14. [Finish] をクリックします。

    [Method Report] ウィンドウが開きます。このウィンドウは、ウィザードで使用されたすべてのパラメーターおよび設定を示します。

  15. [Method Report] ウィンドウで、[OK] をクリックします。

    ウィザードが完了すると、[Empirical Bayesian Kriging 3D] という Geostatistical レイヤーがマップに追加されます。最初は、海面での予測酸素濃度を示しており、全体が赤でレンダリングされます。マップの右側にはレンジ スライダーが表示されます。

    2D での Geostatistical レイヤー

標準誤差の調査

次に、レンジ スライダーを使用して Geostatistical レイヤーの深さを変更し、予測の標準誤差に基づいてレイヤーをシンボル化します。3D シーンと同様、2D マップのレンジ スライダーを使用して Geostatistical レイヤーの深さを変更することができます。

標準誤差とは、予測値に伴う不確実性の測定値です。標準誤差が大きいほど、予測値における不確実性が低くなります。酸素計測値が高くなると、酸素計測値が低い場合よりも回帰線周辺のばらつきが大きくなるという交差検証のグラフを思い出してください。これは、予測酸素計測値が高いエリアは、予測酸素計測値が低いエリアよりも標準誤差が大きくなることを意味します。

  1. [コンテンツ] ウィンドウで、[Empirical Bayesian Kriging 3D] レイヤーを右クリックして、[レイヤーにズーム] を選択します。
  2. リボンの [表示設定] タブの [描画] グループで、[表示タイプ] として [標準誤差] を選択します。

    [表示タイプ] パラメーター

    Geostatistical レイヤーが更新され、海面の予測酸素計測値の標準誤差を表示します。

    Geostatistical レイヤーが、海面での標準誤差としてレンダリングされる

    マップ上では、海面での標準誤差は濃い赤でレンダリングされます。これは、3D モデル全体で不確実性が最大限に高いことを表します。海面は酸素濃度が最も高く、標準誤差も最も大きくなることから、これは理にかなっています。

    海面であっても、入力ポイント周辺エリアでは標準誤差がやや低くなっています。モデルでは、計測ポイントから離れた場所の予測よりも、計測ポイント近くの方が予測の確実性が高くなることから、これもまた理にかなっています。

  3. プロジェクトを保存します。

Geostatistical Wizard を使用してモントレー湾の溶存酸素計測値を内挿しました。また、交差検証を行って、前回のレッスンで作成した高度な EBK3D モデルが、このセクションのデフォルト モデルよりもはるかに精度が高いことを確認しました。また、レンジ スライダーを使用して、3D 地理統計モデルの標準誤差を 2D マップで調べました。


結果の共有

前のレッスンでは、3D ナビゲーションおよびチャート作成によって溶存酸素計測値を調査しました。 その後、Empirical Bayesian Kriging 3D 手法を使用して、3D シーンの高度なモデルおよび 2D マップの単純なモデルを作成しました。

次に、結果として作成されたこれらの 3D モデルをエクスポートする方法について学びます。 Geostatistical レイヤーは、レンジ スライダーやクロス検証の結果への簡易アクセスによって地理統計モデルを調査するのに便利ですが、これらの結果をより大規模なワークフローに統合するには、GIS ワークフローでより一般的な形式に結果をエクスポートできる必要があります。 ここでは、2D スライスをラスターとフィーチャのコンターにエクスポートする方法を理解するとともに、サーフェスを使用して、3D でグリッド状の (サンプリングされていない) ポイントの溶存酸素濃度を予測します。

レッスンの最後には、3D でモントレー湾の中を進む高度なモデルのアニメーションを作成し、そのアニメーションをビデオとしてエクスポートします。

さまざまな水深にあるコンター ポリゴンのエクスポート

最初に、ジオプロセシング ツールを使用して、2 か所の水深にある塗りつぶしコンター ポリゴンをエクスポートします。 エクスポートされた塗りつぶしコンター ポリゴンは特定の水深において Geostatistical レイヤーと同一に見えますが、Geostatistical レイヤーではなく、ポリゴン フィーチャクラスに格納されます。

  1. 必要に応じて、プロジェクトを開きます。
  2. [Monterey Bay 3D] シーンを開きます。
  3. [OxygenPoints] および [Oxygen Prediction] レイヤーをオフにします。 必要に応じて、レンジ スライダーを海面までドラッグします。

    シーンには、標高サーフェス状にドレープされたベースマップのみが表示されています。

  4. [Oxygen Prediction] を右クリックして [Export Layer] をポイントし、[To Contours] を選択します。

    [To Contours] オプション

    [ジオプロセシング] ウィンドウが開き、[GA Layer To Contour] ツール パラメーターが表示されます。

  5. [GA Layer To Contour] ツールで、次のパラメーターを変更します。

    • [Input geostatistical layer] で、[Oxygen Prediction] を選択します。
    • [Output feature class] で、すべての既存のテキストを削除して「ContoursDepth0」と入力します。
    • [分類] を展開します。 [Classification type] で、[Equal interval] を選択します。
    • [クラス数] に「32」と入力します。

    注意:

    [GA Layer To Contour] ツールの [Contour type] パラメーターを変更すると、塗りつぶしポリゴンではなくコンター ラインを作成できます。

  6. [実行] をクリックします。

    ツールが完了すると、[ContoursDepth0] というポリゴン レイヤーがマップの [コンテンツ] ウィンドウに追加されます。 このレイヤーは [Oxygen Prediction] Geostatistical レイヤーと同一に見えます。 しかし、これは 1 か所の水深 (0) における元の Empirical Bayesian Kriging 3D 結果を表しているため、3D ワイヤーフレームが表示されない点が異なります。

    コンターと Geostatistical レイヤー

  7. [ContoursDepth0] レイヤーの凡例を折りたたみます。 [Oxygen Prediction] レイヤーをオンにします。
  8. 必要に応じて、[コンテンツ] ウィンドウで [ContoursDepth0] レイヤーをクリックして選択します。 リボンの [表示設定] タブの [比較] グループで、[スワイプ] ボタンをクリックします。
  9. [ContoursDepth0] レイヤーを数方向にスワイプしてみます。

    スワイプしてもレイヤーの見た目の違いに気づきません。 作成したのは、水深 (0) における EBK 結果のコピーであり、その名前に [ContoursDepth0] を指定しました。そのため、このレイヤーは現在のサーフェス深度 (0) の [Oxygen Prediction] レイヤーと視覚的に同一になります。

  10. [マップ] タブの [ナビゲーション] グループにある [マップ操作] ボタンをクリックします。

    次に、水深 -500 メートルのレイヤーを作成します。

  11. [コンテンツ] ウィンドウで [ContoursDepth0] レイヤーをオフにします。

    [GA Layer To Contour] ツールはデフォルトで Geostatistical レイヤーの水深を継承します。 この水深は現在 0 に設定されており、[Output elevation] パラメーターを変更して更新できます。

  12. [GA Layer To Contour] ツールで、次のパラメーターを変更します。
    • [Output feature class] で、すべてのテキストを削除して「ContoursDepth500」と入力します。
    • [Output elevation] で、「-500」と入力します。
    • [Output elevation] で、単位が選択されていない場合は、[メートル] に設定します。
  13. [実行] をクリックします。

    ツールが完了すると、[ContoursDepth500] というレイヤーがシーンに追加されます。 このレイヤーには、海面から深さ 500 メートルで予測された溶存酸素が表示されます。 しかし、このレイヤーにはシーンと同じ高さ強調係数が適用されていないため、レイヤーは最初に正しい水深で描画されません (前のポリゴン レイヤーは水深 0 で表示されるため、高さ強調係数を変更する必要はありませんでした。したがって、水深を 10 倍する必要もありません)。高さ強調係数を変更する必要があります。

  14. [コンテンツ] ウィンドウで、[ContoursDepth500] レイヤーの凡例を折りたたみます。 [ContoursDepth500] を右クリックして [プロパティ] を選択します。
  15. [標高] タブの [高さ強調] で、「10」と入力します。 [OK] をクリックします。

    [ContoursDepth500] レイヤーが調整され、ベースマップを基準とした正しい水深に表示されます。 レイヤーの角が一部の標高サーフェスの下に移動しています。

    高さ強調係数の変更後のコンター

  16. [ContoursDepth500] および [Oxygen Prediction] レイヤーをオフにします。

    複数か所の水深のコンターをエクスポートするには、バッチ ジオプロセシングModelBuilder、または Python スクリプトを使用できます。 この場合、これらのコンターを同じマップ上に表示して、3D 効果をシミュレートできます。

さまざまな水深における標準誤差のラスターのエクスポート

次に、2D マップで予測値の標準誤差をラスターにエクスポートします。 このワークフローはフィーチャのコンターのエクスポートと似ています。

  1. [Monterey Bay] マップに切り替えます。 [Empirical Bayesian Kriging 3D] レイヤーをオフにします。
  2. [コンテンツ] ウィンドウで、[Empirical Bayesian Kriging 3D] を右クリックして [Export Layer] をポイントし、[To Rasters] を選択します。

    [GA Layer To Rasters] ツールが開きます。

  3. [GA Layer To Rasters] ツールで、次のパラメーターを変更します。
    • [Input geostatistical layer][Empirical Bayesian Kriging 3D] に設定されていることを確認します。
    • [Output Surface Type][Prediction standard error] に設定されていることを確認します。
    • [Output raster] で、テキストを削除して「StandardErrorDepth0」と入力します。
    • [Output cell size] で、テキストを削除して「200」と入力します。

    [GA Layer To Rasters] ツールのパラメーター

  4. [実行] をクリックします。

    ツールが完了すると、[StandardErrorDepth0] というラスター レイヤーがマップに追加され、海面における予測値の標準誤差が表示されます。

    2D サーフェス レイヤー

    標準誤差は入力ポイントのすぐ周りのエリアで最低になります。 この理由は、より高い頻度で計測されたエリアでは予測の精度と正確さが向上するためです。

  5. [StandardErrorDepth0] レイヤーをオフにします。

    次に、水深 -500 メートルのもう 1 つのラスター レイヤーを作成します。 [GA Layer To Raster] ツールはデフォルトで Geostatistical レイヤーの水深を継承します。 これは現在 0 に設定されており、[Output elevation] パラメーターを変更して更新できます。

  6. [GA Layer To Rasters] ツールで、次のパラメーターを変更します。
    • [Input geostatistical layer][Empirical Bayesian Kriging 3D] に設定されていることを確認します。
    • [Output Surface Type][Prediction standard error] に設定されていることを確認します。
    • [Output raster] で、すべてのテキストを削除して「StandardErrorDepth500」と入力します。
    • [Output cell size]200 に設定されていることを確認します。
    • [Output elevation] で、「-500」と入力します。
    • [Output elevation units][Meters] に設定されていることを確認します。
  7. [実行] をクリックします。

    ツールが完了すると、[StandardErrorDepth500] というラスター レイヤーがマップに追加され、水深 500 メートルにおける予測された溶存酸素濃度の標準誤差が表示されます。

    水深 500 メートルにおける標準誤差のレイヤー

  8. [スワイプ] ツールを使用して、[StandardErrorDepth500] レイヤーと [StandardErrorDepth0] レイヤーを比較します。

    [StandardErrorDepth500] ラスターは [StandardErrorDepth0] ラスターと非常によく似ています。 最小標準誤差は入力ポイントのすぐ周りのエリアで見られます。 しかし、これらのレイヤーの凡例を見ると、標準誤差の絶対値に大幅な差異があることがわかります。

    ラスターのシンボルはそれぞれ個別のヒストグラムに基づいているため、1 か所の水深に表示される赤色は、さまざまな水深における同じ範囲の値に対応しているわけではありません。 実際に、これらの水深のうち、水深 500 メートルに表示された最も暗い赤色の陰影 (0.217) は、サーフェスに表示された最も明るい赤色の陰影 (0.294) よりもさらに小さい標準誤差に対応しています。

    2 つの標準誤差ラスターの凡例

    高度なモデルと単純なモデルの両方で、酸素値が大きい場合は、酸素値が小さい場合よりも不確実性が高くなるため、このような結果は理にかなっています。

    注意:

    解析で、予測の標準誤差のラスターではなく予測された酸素値のラスターが必要とされる場合は、[GA Layer To Rasters] ツールの [Output Surface Type] パラメーターを [Prediction] に変更します。

    また、[GA Layer to 3D Multidimensional Raster] ツールを使用して、複数の標高に同時にラスターを書き出し、結果を多次元ラスター データセットとして保存することもできます。 このツールは、地理統計レイヤー プロパティ ページの [Export Layer] メニューの [To Multidimensional Raster] ボタンを使って開くことができます。

3D のグリッド ポイントに対する予測

3D Geostatistical レイヤーの重要な使用例の 1 つに、[GA Layer To Points] ジオプロセシング ツールを使用した 3D の任意の場所に対する予測機能があります。 3D の任意のポイントに対して予測ができる限りは、一般に、3D でグリッド状態になったポイントに対して予測を行うと、3D モデル全体を同時に視覚化するのに役立ちます。 次に、この機能を使用して、グリッド ポイントに対して予測を行います。

  1. [Monterey Bay 3D] シーンに切り替えます。
  2. [マップ] タブの [ナビゲーション] グループで、[ブックマーク] をクリックして [Monterey Canyon] を選択します。
  3. [コンテンツ] ウィンドウで [TargetPoints] レイヤーをオンにします。

    [TargetPoints] レイヤー

    このレイヤーには、モントレー湾全体にわたる近似グリッド内の 560 ポイントが含まれています。 これらのポイントは関連する属性を持たず、3D モデルのターゲット位置として機能します。 これらのポイントの水深の範囲は 150 ~ 1,950 メートルと、計測された酸素値の範囲よりもやや狭くなっています。 これは、各ターゲット ポイントの上下に十分な入力ポイントが存在するように保証するためです。

  4. [マップ操作] または [ナビゲーター] ツールを使用して、[TargetPoints] レイヤー内のポイントの分布を調査 (画面移動、ズーム、回転、傾斜) します。

    3D のグリッド ポイント

  5. [コンテンツ] ウィンドウで、[TargetPoints] レイヤーをオフにします。
  6. [Oxygen Prediction] を右クリックして [Export Layer] をポイントし、[To Points] を選択します。

    [GA Layer To Points] ジオプロセシング ツールが開きます。

  7. [GA Layer To Points] ツールで、次のパラメーターを変更します。
    • [Input geostatistical layer][Oxygen Prediction] に設定されていることを確認します。
    • [Input point observation locations] で、[TargetPoints] を選択します。
    • [Elevation field][Shape.Z] に設定されていることを確認します。
    • [Output statistics at point locations] で、すべてのテキストを削除して「TargetPredictions」と入力します。

    [GA Layer To Points] ツールのパラメーター

  8. [実行] をクリックします。

    ツールの実行が終了すると、[TargetPredictions] というレイヤーがマップに追加されます。 ポイントの予測された溶存酸素濃度は Predicted というフィールドに格納され、予測の標準誤差は Standard Error というフィールドに格納されます (これらのフィールドは、[TargetPredictions] 属性テーブルを開いて右側にスクロールすると表示できます)。最初に、これらのポイントは、高さ強調なしで、デフォルトのシンボルを使用して表示されます。

  9. [TargetPredictions] を右クリックして [プロパティ] を選択します。 [標高] タブの [高さ強調] で、「10」と入力して、[OK] をクリックします。

    [TargetPredictions] レイヤーが更新され、ベースマップと同じ高さ強調係数を使用して表示されます。 次に、予測された溶存酸素濃度を使用してポイントをシンボル表示します。 これを行うには、[OxygenPoints] レイヤーからシンボルをインポートして適用します。

  10. [TargetPredictions] を右クリックして [シンボル] を選択します。 [シンボル] ウィンドウで [オプション] メニューをクリックして、[シンボルのインポート] を選択します。

    シンボル オプションのインポート

    [ジオプロセシング] ウィンドウに [レイヤーのシンボル情報を適用 (Apply Symbology From Layer)] ツールが開きます。

  11. [レイヤーのシンボル情報を適用 (Apply Symbology From Layer)] ツールで、次のパラメーターを変更します。
    • [入力レイヤー][TargetPredictions] に設定されていることを確認します。
    • [シンボル レイヤー][OxygenPoints] を選択します。
    • [シンボル フィールド][タイプ] で、[値フィールド] を選択します。
    • [ソース フィールド] で、[Oxygen] を選択します。
    • [ターゲット フィールド] で、[Predicted] を選択します。

    [レイヤーのシンボル情報を適用] ツールのパラメーター

  12. [実行] をクリックします。

    このツールの実行にはしばらく時間がかかりますが、完了すると、[シンボル] ウィンドウで、[TargetPredictions] レイヤーの分類と配色が更新されます。 マップ上で、フィーチャが更新され、予測された溶存酸素濃度によってシンボル表示されます。

    予測された酸素濃度に基づいて描画された 3D の予測ポイント

  13. [シンボル] ウィンドウと [ジオプロセシング] ウィンドウを閉じます。

    水深 150 メートルにある最上位レイヤーのポイントでは予測値の範囲が約 3.2 ~ 3.7 マイクロモル/リットルであり、中央近くのポイントでは、予測された酸素濃度が 1 未満になります。 これより水深が深くなると、この傾向が逆になり、予測値が増加に転じます。 以前にこれと同じ傾向が、散布図のチャートやレンジ スライダーの使用によってさまざまな水深の酸素値でも確認されましたが、この傾向を 3D マップ内で同時に確認したのはこれが初めてです。

    注意:

    3D でのグリッド状の予測ポイントの適用例は数多くあります。これには、予測値の平均を取ることで 3D ボリューム内の予測の平均数を推定したり、予測値が高すぎる/低すぎるエリアを分離するために予測値によってポイントをフィルタリングしたりするなどがあります。

レンジ スライダー設定を使用したアニメーションの作成

次に、モントレー湾の海面から海底まで下方向に進む [Oxygen Prediction] レイヤーのアニメーションを作成します。 その後、アニメーションのビデオをエクスポートして、作業の結果を同僚や一般ユーザーと共有できるようにします。 このアニメーションでは、モントレー湾全体にわたる酸素濃度の予測に使用された 3D の地球統計学的内挿の結果を例証します。

注意:

アニメーションをビデオとして見たい場合は、以下のリンクをクリックしてください。 アニメーションを作成してから、結果を独自のビデオにエクスポートする場合は、次の手順に進みます。

ビデオを見る

  1. [TargetPredictions] レイヤーをオフにして、このレイヤーの凡例を折りたたみます。 [Oxygen Prediction] レイヤーをオンにします。
  2. レンジ スライダーを使用して、[Oxygen Prediction] レイヤーにサーフェスの予想が表示されていることを確認します。
  3. [マップ] タブの [ナビゲーション] グループで、[ブックマーク] をクリックして [Monterey Canyon] を選択します。

    マップには [Oxygen Prediction] Geostatistical レイヤーのみが表示されます。 [World Ocean Base][WorldElevation3D/TopoBathy3D] を除く他のすべてのレイヤーはオフになっています。

    アニメーションの開始深度の設定

  4. リボンの [レンジ] タブの [ステップ] グループで、[ステップ数] をクリックし、30 に設定されていることを確認します。

    [ステップ数] パラメーター

  5. [表示] タブの [アニメーション] グループで [追加] をクリックします。

    [追加] ボタン

    [アニメーション タイムライン] ウィンドウが表示され、アクティブなリボン タブが [アニメーション] タブに変わります。

    注意:

    [アニメーション タイムライン] ウィンドウが表示されない場合は、[アニメーション] タブの [再生] グループで、[タイムライン] ボタンをクリックします。

  6. [アニメーション] タブの [作成] グループで、[インポート] をクリックして [レンジ スライダーのステップ] を選択します。

    [インポート] ボタン

    レンジのステップ数を 30 に設定したため、連続する 32 フレームが生成され、[アニメーション] ウィンドウに横一列に並んで表示されます。 アニメーションの開始キーフレームと終了キーフレームに対応するために、追加フレームが自動的に追加されています。

    注意:

    レンジのステップ間隔、ステップ数、または再生の方向を変更した場合は、表示されるフレーム数が異なることがあります。

  7. 必要に応じて、[アニメーション タイムライン] ビューを [Monterey Bay 3D] シーンの下にドッキングします。

    アニメーションのフレームは当初、空の状態で、空白が表示されるかもしれませんが、水深ごとにフレームが生成されるにつれ、さまざまな水深における Geostatistical レイヤーのプレビューでフレームが徐々に埋められ、更新されます。 すべてのフレームが読み込まれるまでに数分かかることがあります。

    アニメーション タイムライン

  8. [アニメーション タイムライン] ビューで、すべてのフレームが生成されたことを確認します。 フレーム 33 が表示されるまで右にスクロールします。

    最終フレーム

    リボンの [アニメーション] タブの [再生] グループに、アニメーションの [現在] フィールドと [期間] フィールドが表示されます。

    アニメーションの期間は 1 分 36 秒 (01:36.000) に設定されています (期間の値は異なる場合があります)。この時間は長すぎるため、期間を 30 秒に短縮します。

  9. [期間] で、「00:30.000」と入力し、Enter キーを押します。

    [期間] パラメーター

    アニメーション フレーム間の時間が調整され、アニメーション全体の合計時間が 30 秒になります。 次に、アニメーション タイムラインをムービーにエクスポートします。

  10. リボン上の [アニメーション] タブにある [エクスポート] グループで、[ムービー] をクリックします。

    [ムービー] ボタン

    [ムービーのエクスポート] ウィンドウが表示され、エクスポートされるビデオに関連するオプションをここで指定できます。

  11. [ムービーのエクスポート] ウィンドウで、[ムービー エクスポートの事前設定] を展開し、定義済みのエクスポートの事前設定を表示します。 次の事前設定を変更します。
    • 事前設定の中から [HD720] をクリックします。
    • [ファイル名] で、プロジェクトを展開したディレクトリへのファイル パスを変更し、ビデオ ファイルの名前が [Monterey Bay 3D.mp4] であることを確認します。
    • [ファイル エクスポート設定] を展開し、[メディア形式][MPEG4 ムービー (*.mp4)] であることを確認します。
    • [1 秒あたりのフレーム数] で、「15」と入力します。

    [ムービーのエクスポート] ウィンドウ

    エクスポート時間の節約のため、ビデオでは、比較的低速のフレーム レートである 15 フレーム/秒が使用されます。 より高い解像度のビデオを作成する場合は、1 秒あたりのフレーム数を増やすことができます。

  12. [エクスポート] をクリックします。

    ビデオ ファイルがエクスポートされるまでに数分かかることがあります。 お使いのコンピューターのプロセッサーとグラフィックス カードがアニメーションのエクスポート速度に直接影響を及ぼします。 加えて、アニメーションの長さと解像度のサイズも、ムービーの各フレームの生成にかかる時間に影響します。

  13. ビデオのエクスポートが完了したら、[ムービーのエクスポート] ウィンドウの左下にある [ビデオの再生] をクリックします。

    コンピューターのデフォルトのビデオ ビューアーが開き、Geostatistical レイヤーのムービーが表示されます。このムービーはモントレー湾の海面から下方向へ、さまざまな水深を経て進行し、その進行に合わせて溶存酸素濃度が予測されます。

    アニメーション

    これで、このビデオを他のユーザーが共有してアクセスできるようになりました。 このビデオを ArcGIS Online にアップロードしたり、YouTube で共有したり、同僚に見せたりできます。

    注意:

    ArcGIS Pro からエクスポートしたムービーを Windows Media Player または別の一般的なビデオ プレーヤーで再生できない場合は、必要なコーデック ファイルが欠落していることが考えられます。 コーデックは、ビデオ ファイルのサイズを小さく保つために使用される圧縮形式です。 正しいコーデックがインストールされている場合は、Windows Media Player で、サポート対象のムービー形式を再生できます。

  14. [アニメーション タイムライン] ウィンドウと [ムービーのエクスポート] ウィンドウを閉じます。
  15. プロジェクトを保存します。

3D 地理統計レイヤーを輪郭ポリゴン、ラスター、3D ポイントにエクスポートする方法を学びました。 モントレーキャニオンの中を移動する地球統計レイヤーのムービーを作成し、推定溶存酸素を可視化する方法も学びました。


結果をボクセル レイヤーとして可視化

以前、補間の結果をラスター、等高線フィーチャ、アニメーションなどの便利な形式にエクスポートする方法を学びました。

次に、結果をボクセル レイヤーとして可視化する方法を学びます。ボクセル レイヤーは、予測された溶存酸素レベルの完全な 3D キューブを表示および探索できるようにする、3D ボリューム ビジュアライゼーションです。

netCDF ファイルを作成し、ボクセル レイヤーを追加

溶存酸素の予測値をボクセル レイヤーとして可視化するには、まずボクセル レイヤー用のソース ファイルを作成する必要があります。このソースファイルは、ボクセル レイヤーの各ボクセルをレンダリングするために使用される、3D グリッド化された位置を表す netCDF (*.nc)ファイルです。このファイルは [GA Layer 3D To NetCDF] ツールを使用して作成することができます。

  1. 必要に応じて、プロジェクトを開き、[Monterey Bay 3D] シーンを開きます。
  2. [Oxygen Prediction] レイヤーをオフにします。
  3. [マップ] タブの [ナビゲーション] グループで、[ブックマーク] をクリックして [Monterey Canyon] を選択します。
  4. [Oxygen Prediction] を右クリックして [Export Layer] をポイントし、[To NetCDF/Voxel] を選択します。

    [GA レイヤー 3D → NetCDF (GA Layer 3D To NetCDF)] ツールが [ジオプロセシング] ウィンドウで開きます。このツールを使用することにより、3D グリッド化されたポイントを netCDF 形式でエクスポートすることができます。[X spacing][Y spacing]、および [Elevation spacing] パラメーターを使用して、これらのグリッド化されたポイントの間隔を指定することができます。デフォルトでは、すべてのディメンションで 40 ポイント作成され、結果として、64,000 か所になります。

    [Input 3D geostatistical layers] パラメーターにより、自動的に [Oxygen Prediction] レイヤーを追加できます。複数の地理統計レイヤーが提供され、同一の netCDF ファイルにエクスポートすることができます。

  5. [Output netCDF file] で、すべてのテキストを削除して「VoxelSource」と入力します。出力パス全体とファイル名を選択し、右クリックして [コピー] を選択します。

    パスとファイル名は後のステップで貼り付けます。

  6. [Output variables] の場合、プラスボタンをクリックして値テーブルに新しい行を追加します。新しい行の [Layer Name] に、[Oxygen Prediction] を選択します。[Output surface type] では、[Prediction standard error] を選択します。

    このようにパラメーターを設定すると、ツールはその位置での溶存酸素予測の予測値と標準誤差をエクスポートします。

    GA Layer 3D To NetCDF ツール

  7. .[実行] をクリックします。

    ツールの実行が完了するまで、数分の時間がかかることがあります。初期状態では、シーンにはレイヤーは追加されません。

  8. [ジオプロセシング] ウィンドウを閉じます。
  9. [マップ] タブの [レイヤー] グループで、[データの追加] をクリックし、[多次元ボクセル レイヤーの追加] を選択します。

    多次元ボクセル レイヤーの追加

    [ボックス レイヤーの追加] ウィンドウが開きます。

  10. [入力データ ソース] では、コピーした出力パスを貼り付けます。または、[参照] ボタンを使用して、*VoxelSource.nc ファイルを参照します。
    注意:

    ファイルの場所は、例の画像に表示されている場所とは異なる場合があります。

    溶存酸素の予測値と標準誤差は、[変数の選択] セクションに表示されます。予測値は、[デフォルト変数] として選択されます。

    ボクセル レイヤーの追加

  11. [OK] をクリックします。

    [VoxelSource] のボクセル レイヤーがシーンに追加され、3D でレンダリングされます。

    シーン内のボクセル レイヤー

ボクセル レイヤーのプロパティを調整

初期状態では、ボクセル レイヤーはシーンの残りの部分と同じシンボル情報、高さ強調係数ではありません。ボクセル レイヤーのプロパティを調整して、よりシーンにマッチするようにします。

  1. [VoxelSource] を右クリックして [プロパティ] を選択します。
  2. [高度]タブで、[強調モード] から [Z-座標] に変更します。[強調] に「10」と入力します。

    ボクセル レイヤーのプロパティ ページ

  3. [OK] をクリックします。

    ボクセル レイヤーがシーンと同じ高さ強調係数に拡張されます。

  4. [VoxelSource] を右クリックして [シンボル] を選択します。

    [シンボル] ウィンドウが表示されます。

  5. [シンボル][配色] で、メニューをクリックし、[名前の表示] チェックボックスと [すべてを表示] チェックボックスをオンにします。
  6. [Prediction] の配色を選択します。
    ヒント:

    配色がアルファベット順に並べられます。

    ボクセル レイヤーのシンボル情報

  7. [シンボル] ウィンドウを閉じます。

    ボクセル レイヤーは、ポイントや地理統計レイヤーと同じ配色になります。

    シンボル情報付きボクセル レイヤー

  8. [マップ操作] ツールを使用して、モントレー キャニオン周辺を移動します。ボクセル レイヤーをさまざまな角度から見ます。

    ボリュームの中心は予測酸素量が最も少なく、海面で最も多くなります。

スライスを使用して調査エリアの角を除去

ボクセル レイヤーは、完全な 3D キューブを埋めますが、このキューブの中には酸素測定が行われていない領域もあります。スライスを使って、近くにポイントがないボクセル レイヤーの 2 つの角を除去します。

  1. [OxygenPoints] レイヤーをオンにします。

    ボクセル レイヤーを通して、ほとんどのポイントを見ることができます。立方体の中にはポイントがない領域もあります。

  2. [マップ] タブの [ナビゲーション] グループで、[ブックマーク] をクリックし、[Slice Angle 1] を選択します。

    範囲が変化して、ポイントのないボクセル レイヤーの角が表示されます。例に示した画像では、ポイントのない影付き領域は、この後に切り取るボクセル レイヤーの領域です。

    ポイントのないボクセル レイヤー

  3. ボクセル レイヤーが拡張されていない場合は、[VoxelSource] を拡張します。[スライス] を右クリックし、[スライスの作成] を選択します。

    スライスの作成

    シーンの下部に表示される [スライスとセクション] ツールバーで、対話的にスライスを作成することができます。デフォルトでは、[垂直スライス] ボタンが選択されています。

  4. [垂直スライス] ボタンが選択されていることを確認します。除去したいボクセルの領域の端を 2 回クリックします。

    対話的にスライスを作成

    [ボクセル探索] ウィンドウが開きます。ここで、スライスの位置、向き、傾きを変更できます。反対側の角を除去するため、別のスライスを作ります。

  5. [マップ] タブの [ナビゲーション] グループで、[ブックマーク] をクリックし、[Slice Angle 2] を選択します。
  6. [コンテンツ] ウィンドウの [VoxelSource] で、[スライス] を右クリックし、[スライスの作成] を選択します。
  7. [垂直スライス] ツールを使って、トップレイヤーとスライスが交差する 2 つの頂点をクリックします。

    2 つ目のスライスの作成

  8. ツールバーの [反転] ツールをクリックすると、スライスした面を反転させることができます。

    スライスの反転

    ここで、酸素測定をしていないボクセル レイヤーの 2 つの角は、ボクセル レイヤーから除去されています。スライスは、他の 2 つの角を取り除くためにも使用することができます。

  9. [マップ操作] ツールを使用して、モントレー キャニオン周辺を移動します。ボクセル レイヤーをさまざまな角度から見ます。

垂直な断面と角度のついた断面を作成します

断面は、水平、垂直、または角度のついたスライスを視覚化するために使用され、2D 横断面を示します。今までは完全に水平にしか見えませんでした。次に、モントレーキャニオンの最も急峻な部分とほぼ平行な断面を作成します。さらに、第 1 の断面にほぼ垂直な第 2 の断面を作成します。

  1. [マップ] タブの [ナビゲーション] グループで、[ブックマーク] をクリックし、[Section Angle 1] を選択します。

    カメラは、キャニオン側面に平行な角度にズームします。

    最初の断面の角度

  2. [コンテンツ] ウィンドウの [VoxelSource] で、[サーフェス] の隣のボタンをクリックして、可視化を変更します。

    可視化をサーフェスに変更

    ボクセル レイヤーはマップから消え、サーフェスを追加するまで再表示されません。

  3. [サーフェス] を展開し、[セクション] を右クリックし、[セクションの作成] を選択します。

    セクションの作成

    ボクセル レイヤーの透明な視覚化は、スライス作成に役立ちます。

  4. [スライスとセクション] ツールバーの [水平セクション] ボタンをクリックします。

    水平セクション ボタン

  5. [水平セクション] ツールを使って、渓谷の最も急峻な部分の近くのポイントの列の中央をクリックします。

    深度ポイントの水平図

  6. [ボクセル探索] ウィンドウの[傾斜] に「-150」と入力して、Enter キーを押します。

    傾斜の変更

    断面の傾斜を、渓谷とほぼ並行になるように変更します。

    角度のついた断面

  7. [マップ] タブの [ナビゲーション] グループで、[ブックマーク] をクリックし、[Section Angle 2] を選択します。
  8. [コンテンツ] ウィンドウで [VoxelSource] の、[サーフェス][セクション] を右クリックし、[セクションの作成] を選択します。
  9. [垂直セクション] ツールを使って、マップを 2 回クリックすると、最初のセクションとほぼ垂直な別の断面が作成されます。左端より先に右端をクリックしていることを確認してください。

    第 2 の垂直セクション

  10. [マップ] タブの [ナビゲーション] グループで、[ブックマーク] をクリックして [Monterey Canyon] を選択します。
  11. [コンテンツ] ウィンドウの他のレイヤーをクリックすると、垂直セクション上のハイライト効果が解除されます。
  12. [マップ操作] ツールを使って、モントレーキャニオンを移動し、さまざまな角度から断面を見ます。

    2 つの垂直セクションの探索

  13. 終了したら、[マップ] タブの [ナビゲーション] グループで、[ブックマーク] をクリックして [Monterey Canyon] を選択します。

溶存酸素の等値面を作成

等値面は、3D の等高線に相当します。等高線とは、線上のすべての位置が同じ値の線のことです。同様に、等値面とは、シェル上のすべての位置が同じ値の 3 次元シェルのことです。ここでは、等値面を作成し、対話的に等値面の値を変更します。

  1. [コンテンツ] ウィンドウで、[VoxelSource] を展開し、[サーフェス][セクション]の横のチェックボックスをオフにします。

    セクションの無効化

    セクションがマップに表示されなくなります。

  2. [VoxelSource][サーフェス] で、[等値面] を右クリックし、[等値面の作成] を選択します。

    等値面の可視化は、同一溶存酸素レベルの全 3D 領域のシェルを示すマップに追加されます。

    等値面の可視化

    [ボクセル探索] ウィンドウの、[値] の隣のスライダーで、さまざまな溶存酸素レベルの等値面を見ることができます。

  3. [値] スライダーを左端までドラッグすると、最小値が表示されます。

    等値面値スライダー

    この値では、どこにもボクセルはレンダリングされません。

  4. [値] スライダーをゆっくりと右にドラッグして、等値面が 3D で変形するのを見て、さまざまな溶存酸素レベルを視覚化します。

    さまざまな溶存酸素濃度の等値面

  5. プロジェクトを保存します。

Empirical Bayesian Kriging 3D は汎用の 3D 内挿法です。このレッスンで学習したスキルは、海洋学や気象、一部の地質学的応用を含め、多くの分野で直接適用することができます。自分自身のデータに対して Empirical Bayesian Kriging 3D を実行してみたり、全球海洋観測データベース (WOD: World Ocean Database) から違うデータをダウロードし、これらのレッスンで学んだ手順を再現することをおすすめします。

このレッスンでは、Empirical Bayesian Kriging 3D を使用して、モントレー湾の溶存酸素計測値を 3D Geostatistical モデルに内挿し、計測ポイント間のあらゆる場所で溶存酸素濃度を予測できるようにする方法を学習しました。ジオプロセシング ツールと Geostatistical Wizard の両方を使用して Empirical Bayesian Kriging 3D を実行してから、内挿法の正確度を検証する方法を理解しました。結果をラスターとフィーチャのコンターにエクスポートし、モデルのアニメーションを共有して、ここで学習した内容を他のユーザーが確認できるようにしました。最後に、結果をボクセル レイヤーとして可視化し、ボリューム、スライス、セクション、等値面の作成方法を学びました。

その他のレッスンについては、「Learn ArcGIS Lesson ギャラリー」をご参照ください。