ジオデータベース プロジェクトの作成

最も基本的なレベルで、ジオデータベースは、空間データ、属性データ、およびそれらのデータ間に存在するリレーションシップを格納するためのコンテナーです。ジオデータベースでは、フィーチャとそのフィーチャに関連付けられた属性を構造化し、ルール、リレーションシップ、トポロジの関連付けを使用した統合システムとして連携させることができます。このため、ジオデータベースを使用することで、ニーズに応じた単純または複雑な方法で実世界をモデリングできます。

ジオデータベース用の ArcGIS Pro プロジェクトの作成

ジオデータベースの組織と構造は、一般的にスキーマと呼ばれます。ザルツブルクの観光省庁が使用するジオデータベース スキーマを開発する前に、特定のベース データまたはソース データのコレクションを管理する必要がある場合、組織や省庁が配置する可能性のある一般的なベースマップ スキーマを調査することが役立ちます。

複数の方法でジオデータベースを作成できますが、このレッスンでは、ジオデータベースを含むテンプレートから ArcGIS Pro プロジェクトを作成することから始めます。新しいプロジェクトを作成すると、新しいファイル ジオデータベースが自動的に作成され、デフォルト ジオデータベースとして設定されます。このジオデータベースには、ザルツブルグの観光省庁が使用し、マップ構築作業をサポートするデータが格納されます。

備考:

最近の動向では、都市、組織、および省庁が一意または独自のデータを保持し、公開済みかつパブリックに利用可能なベースマップ、マップ サービス、および ArcGIS Living Atlas of the World で利用できるような信頼できるデータ ソースを活用してそのデータを補完します。

  1. [はじめてのジオデータベース] グループに移動します。

    [はじめてのジオデータベース] グループ

  2. [サンプル ベースマップ GDB スキーマ] のサムネイルが表示されるまで下にスクロールします。[ダウンロード] をクリックして zip ファイルをダウンロードします。

    サンプル ベースマップ GDB スキーマ

  3. [SalzburgData] サムネイルをクリックしてダウンロードします。

    SalzburgData サムネイル

  4. ファイル内容を選択した場所 (例: C:\Salzburg) に展開します。
  5. ArcGIS Pro を開きます。
    備考:

    ArcGIS Pro または ArcGIS アカウントがない場合、ArcGIS の無料トライアルにサイン アップできます。

    ArcGIS Pro が開き、スプラッシュ画面が表示されます。

  6. [設定] をクリックし、[オプション] を選択します。

    [オプション] ウィンドウが表示されます。

  7. [オプション] ウィンドウで、[メタデータ] をクリックします。
  8. [メタデータ スタイル] で、[FGDC CSDGM メタデータ] を選択します。

    [メタデータ スタイル] オプション

    ArcGIS プラットフォームでは、デフォルトで [アイテム説明] と呼ばれる基本的なメタデータ スタイルが使用されますが、その他のさまざまなスタイルのいずれかにスタイルを更新および変更できます。これらのスタイルには、完全なメタデータを表示および編集できる FGDC CSDGM メタデータ スタイルも含まれます。このスタイルは、北米および世界中で長年にわたって使用されている有名なメタデータ コンテンツ規格です。

  9. [OK] をクリックします。
  10. [戻る] ボタンをクリックしてプロジェクトに戻るか、またはプロジェクトを開きます。
  11. 必要に応じて、ライセンス付き ArcGIS アカウントを使用してサイン インします。
  12. [新規] の下で、[カタログ] をクリックします。

    カタログ テンプレート

    ArcGIS Pro には、操作を開始するのに役立つ空のプロジェクト テンプレートがいくつか用意されています。

    • 2D マップを構築する場合は、[マップ] テンプレートを選択します。
    • 3D グローバル シーンを作成する場合は、[グローバル シーン] テンプレートを選択します。
    • 3D ローカル シーンから開始する場合は、[ローカル シーン] テンプレートを選択します。
    • [カタログ] ビューから開始する場合は、[カタログ] テンプレートを選択します。

    データ管理が主眼点の場合は、このプロジェクトを開始ページにピンで固定するか、ArcGIS Pro の起動時に自動的に開くようにします。このレッスンの主眼点はデータ管理であるため、[カタログ] テンプレートが適しています。

  13. [名前] に「SalzburgGeodatabase」と入力します。
  14. [場所] で、ダウンロードしたプロジェクト コンテンツの場所を参照して選択します (例: C:\Salzburg)。

    可能な限り、プロジェクトに専用のフォルダーを作成することをお勧めします。新しいプロジェクトごとに、プロジェクト ファイル (*.aprx)、デフォルトのジオデータベース、ツールボックスが含まれています。これらを 1 つのフォルダーにまとめて整理しておくと、プロジェクトとデータの検索、共有、保存が簡単になります。

  15. [このプロジェクトのための新しいフォルダーを作成] がオンになっていることを確認して [OK] をクリックします。

    [新しいプロジェクトの作成] ウィンドウ

    プロジェクトが開き、[コンテンツ] ウィンドウと [カタログ] ビューが表示されます。

    [コンテンツ] ウィンドウと [カタログ] ビュー

    マップ、シーン、レイアウト、フォルダーへの接続、およびジオデータベースを追加してプロジェクトを構築した後、[カタログ] ビューを使用すると、アイテムの場所がローカル コンピューター、ネットワーク コンピューター、ArcGIS Online、または ArcGIS Enterprise ポータルのいずれにある場合でも、特定のプロジェクトに関連付けられたすべてのアイテムに 1 か所からアクセスできます。リボンから複数の [カタログ] ビューを開き、それらを使用してデータベースまたはフォルダーの内容を比較したり、2 つのアイテムのメタデータを比較したり、スタイルアイテムをあるスタイルから別のスタイルにコピーしたりできます。

  16. リボンの [表示] タブにある [ウィンドウ] グループで、[カタログ] ウィンドウをクリックします。

    [カタログ] ウィンドウが表示されます。

    [カタログ ウィンドウ] ボタン

    備考:

    [カタログ] ウィンドウと [カタログ] ビューは似ていますが、異なるタスクを対象にしています。[カタログ] ウィンドウと [カタログ] ビューの両方を同時に開くことができますが、それらは独立して動作します。ウィンドウとビューの両方で、データを管理および参照できます。新しいアイテムを生成すると、タイプ別に分類されて、[カタログ] ウィンドウのプロジェクト タブと [カタログ] ビューのプロジェクト コレクションに表示されます。

    [カタログ] ウィンドウは [カタログ] ビューの軽量版で、ポータル、お気に入り、および履歴を表示するタブから、プロジェクト関連コンポーネントにアクセスすることができます。

    [カタログ] ビューと [カタログ] ウィンドウの比較

    [カタログ] ウィンドウが高速なアクセスに適している一方、[カタログ] ビューは詳細なデータ管理タスクに適しており、各リボン タブに管理機能が関連付けられています。さらに、[カタログ] ビューではアイテムの詳細が列内に表示され、メタデータにアクセスできます。

    次のレッスンでは、主に [カタログ] ビューとそのビューに関連する [コンテンツ] ウィンドウの使用方法について説明します。

  17. [カタログ] ウィンドウを閉じます。
  18. [コンテンツ] ウィンドウで、[データベース] をクリックして展開します。

    プロジェクトに対して、SalzburgGeodatabase.gdb がすでに作成されています。[カタログ] ビューを調べる前に、レッスン リソースに簡単にアクセスするためのフォルダー接続を作成します。

  19. [コンテンツ] ウィンドウで [フォルダー] をクリックします。
  20. リボンの [カタログ] タブにある [作成] グループで、[追加] をクリックして [フォルダー接続の追加] を選択します。

    [追加] ボタン

  21. [フォルダー接続の追加] ウィンドウで、抽出したデータ フォルダー (例: C:\Salzburg) を探して [OK] をクリックします。

    フォルダー接続は、重要なデータやプロジェクト関連資料を探すためのショートカットです。

  22. プロジェクトを保存します。

このレッスンでは、ジオデータベースの設定をサポートするプロジェクトを生成し、プロジェクトのデフォルトになっている [アイテム説明] メタデータ スタイルを [FGDC CSDGM メタデータ] スタイルに変更しました。次に、ジオデータベースに含めるさまざまなデータソースを評価します。


データ ソースの評価

このレッスンでは、Salzburg ジオデータベースに移行する可能性のあるデータ ソースを評価します。データソースを評価する際に留意する一般的なデータ品質基準は、用途、地理範囲、投影法、通貨、データおよびメタデータ規格、データ系譜、データに対して実行される空間処理 (サンプリング、処理、モデリングおよび解析、正確性、完全性など)、および関連する属性です。

データ ソースの評価

次に、Salzburg ジオデータベースに移行する可能性のあるデータ ソースを評価します。これらのデータソースには、シェープファイルと KMZ ファイルが含まれています。

  1. 必要に応じて、プロジェクトを開きます。
  2. [コンテンツ] ウィンドウの [フォルダー] 接続で、[City_of_Salzburg] サブフォルダーを展開します。

    [カタログ] ビューが更新され、ザルツブルク市のデータを表すシェープファイルのコレクションが表示されます。これらのシェープファイルの詳細は、[名前][種類][日付] 列にリストされています。これらのいずれかの列内のコンテンツを並べ替えるには、列見出しを選択します。アイテム詳細に加えて、[カタログ] ビューでは、アイテムを説明する情報 (メタデータ) にも直接アクセスできます。

    アイテムの詳細

    [City_of_Salzburg] フォルダーには、観光省庁がマップの更新や新しいアプリ内で使用するレイヤーとして追加する際に役立つ 29 個のシェープファイルが含まれています。保持するデータ ソースや他のソースのデータで置き換えるデータ ソースを決定する前に、各データ ソースにアクセスして確認する必要があります。

  3. [カタログ] ビューで [BicyclePaths.shp] をクリックします。

    アイテム タイプが表示され、[メタデータ] タブが更新されて、シェープファイルの詳細情報が表示されます。

    シェープファイル メタデータ

    メタデータには、利用制限、著作権、および空間参照に関する情報が含まれています。

    制限および空間参照を確認します。

    空間参照は次のように定義されます。

    • 地理座標参照 - GCS_MGI
    • 投影法 - MGI_Austria_GK_M31

    メタデータは、ジオデータベースを開発する際に、データ ソースの有用性および関連性を判断するうえで不可欠かつ重要です。メタデータの表示と編集の詳細については、こちらをご参照ください。

  4. [ジオグラフィ] タブをクリックして、シェープファイルに含まれる空間フィーチャを表示および確認します。必要に応じて、マップを移動およびズームします。

    [ジオグラフィ] タブ

  5. [テーブル] タブをクリックして、自転車用道路フィーチャの属性フィールドと値を表示します。

    テーブルのタブ

    [Bicycle Paths] シェープファイルのメタデータを確認するにあたり、ユーザーが作成して使用するコンテンツとプロジェクト アイテムのドキュメント化において、メタデータが重要な役割を果たしていることは明らかです。これらには、マップ、プロジェクト、ジオプロセシング モデル、およびジオデータベース データセットが含まれます。

    備考:

    メタデータは、説明するアイテムとともに、ジオデータベース アイテムの場合はジオデータベースに、プロジェクト アイテムの場合はプロジェクトに、ファイルベース アイテムの場合はファイル システムに保存されます。一度作成したメタデータは、ArcGIS によって管理され、アイテムとともにコピー、移動、削除されます。

  6. [Museums.shp][メタデータ][ジオグラフィ]、および [テーブル] タブを確認します。

    博物館は旅行者がよく訪れる場所であり、このレイヤーは最新の状態を維持するために重要です。このデータ ソースの空間参照は、次のように定義されます。

    • 地理座標参照 - GCS_MGI
    • 投影法 - MGI_Austria_GK_M31

    このデータ ソースのテーブルには、場所の名前と住所を含む属性フィールドが含まれており、いずれの情報も観光アプリケーションで役立ちます。

  7. [ReligiousMonuments.shp] のメタデータを確認します。

    このメタデータには完全な情報が含まれているように見えますが、ジオグラフィおよびテーブルを確認すると、シェープファイルにフィーチャが含まれていないことがわかります。このため、このデータ ソースは拒否され、使用できないことがあります。

  8. [コンテンツ] ウィンドウの [フォルダー][kmz-files] サブフォルダーをクリックします。

    このフォルダーには、観光省庁に便利な 3 つの KMZ ファイルが含まれています。KMZ ファイルは KML (Keyhole Markup Language) ファイルを圧縮したもので、あらゆる KML クライアント (ArcGIS Pro など) で表示できます。

    KMZ ファイルのフォルダー

    フォルダー構造は、ダウンロードされたデータを解凍した場所によって異なる場合があります。

    備考:

    KML は簡単にインターネットで配信して、多くの無料アプリケーションで表示できるため、非 GIS ユーザーと地理データを共有するための一般的な形式になっています。KML ファイルの形式は XML ベースであり、拡張子は、*.kml または *.kmz (圧縮された KML ファイル用) のいずれかです。ArcGIS Pro では、いずれかの拡張子を使用できます。

  9. [カタログ] ビューで [Kunstwerke_mit_Audiotext.kmz] をクリックします。

    この KML ファイル内のフィーチャは、特定のアーティストの作品に興味のある観光客が検索および訪問できる、複数の主要な野外および屋内インスタレーション アートの場所を表しています。

    備考:

    1 つの KML ファイルは、ポイント、ライン、ポリゴン フィーチャ、ラスター画像、またはこれらの組み合わせで構成されています。KML には、グラフィックス、画像、属性、HTML などの関連するコンテンツも含めることができますが、ArcGIS のデータセットは通常、同じ種類の要素ごとに構成されています (たとえば、ポイント フィーチャクラスにはポイントのみが含まれ、ラスターにはセルまたはピクセルのみが含まれ、フィーチャは含まれません)。

  10. [Kunstwerke_mit_Audiotext.kmz] のメタデータを確認します。

    KMZ メタデータ

    この場合、KMZ には有効なメタデータがありません。ただし、デフォルトでは、KMZ ファイルは Web アプリケーションから使用することが想定されているため、座標系には WGS84 が使用され、データ ソースに関する一部の情報がわかります。

  11. [Kunstwerke_mit_Audiotext.kmz] のジオグラフィを確認します。

    KMZ ファイルのコンテンツ

    表示されるフィーチャのサイズはあまり変化せず、マップ上で拡大/縮小を行うと、薄い色で表示されるようになります。これは、KMZ ファイルにシンボルと他のレイヤー プロパティ (ポップアップ情報など) が含まれているためです。

  12. [Kunstwerke_mit_Audiotext.kmz] のテーブルを確認します。

    現時点では、レイヤーとして変換されていない KMZ コンテンツを表示および探索しているため、ポイントに関連付けられたテーブル形式の情報にアクセスすることはできません。KMZ はネストされたエレメントと属性を含むタグベースの構造を使用し、XML 標準に基づいています。データを編集および変更するには、KMZ ファイルをジオデータベース内のフィーチャクラスに変換して、属性にアクセスする必要があります。

  13. [コンテンツ] ウィンドウの [フォルダー] で、[OpenStreetMap_Salzburg] サブフォルダーを展開します。

    このフォルダーには、ザルツブルクの無料の OpenStreetMap データのコレクションがシェープファイル形式で含まれており、観光マップやアプリの構築に役立ちます。このデータはボランティアによって収集および構築され、オープン コンテンツ ライセンスでリリースされています。OpenStreetMap ライセンスでは、マップ画像とすべての基礎マップ データに無料でアクセスできます。このプロジェクトの目的は、データを新しく興味深い方法で活用することを促進することです。OSM マップ フィーチャの説明については、次のトピックをご参照ください。

  14. [カタログ] ビューで [OSM_Salzburg_Amenities.shp] をクリックします。[メタデータ] タブで、空間参照情報を確認します。

    環境設備に関する空間参照情報

    このデータ ソースには、ユーザーの目的に役立つ包括的なメタデータが含まれています。ただし、空間参照の地理座標参照は GCS_WGS_1984 に設定され、投影法は WGS_1984_Web_Mercator_Auxiliary_Sphere として定義されています。この投影法は、距離の正確な決定、面積の計測、および形状の比較には適していません。

  15. 自身で、他の OpenStreetMap データ ソースを調査および確認します。これらのソースに同じ空間参照が含まれているかどうかを必ず確認してください。
  16. プロジェクトを保存します。

次に、XML 交換ファイルを使用して、汎用ベースマップのジオデータベース スキーマをインポートします。ベースマップを使用して、Salzburg ジオデータベースのメタデータを更新する前にジオデータベース オブジェクトを探索し、現在の形式と空間参照から観光マップおよびアプリでの使用に適した空間参照にデータソースを移行する準備を行います。


ジオデータベース スキーマの作成

ジオデータベースの格納モデルは、一連のリレーショナル データベース概念に基づき、基本データベース管理システム (DBMS) を使用しています。DBMS は、ストレージ構造、インデックス構築、バックアップとロールバックのメカニズム、およびセキュリティ モデルを提供します。DBMS テーブルと明確に定義された属性タイプを使用して、地理データセットごとにスキーマ、ルール、ベース、空間属性データを格納します。この手法は、データを格納して操作するための形式的なモデルを提供します。

ジオデータベース オブジェクトの確認

このレッスンでは、まず汎用ベースマップのスキーマを確認し、データを整理および管理するために使用されるフィーチャクラス、フィーチャ データセット、スタンドアロン テーブルなどのジオデータベース コンポーネントについての洞察を得ます。次に、さまざまなデータセットを変換およびインポートして、Salzburg ジオデータベースのスキーマを作成および更新します。詳細については、「ジオデータベースとは」 および「ジオデータベースの基礎」をご参照ください。

まず、XML 交換ファイルからベースマップ ジオデータベースのスキーマをインポートします。

  1. 必要に応じて、プロジェクトを開きます。
  2. [コンテンツ] ウィンドウで [データベース] をクリックします。

    プロジェクトの作成時に生成された、デフォルトの [SalzburgGeodatabase.gdb] がすでに存在します。このデータベースに Salzburg ソース データを設定します。ただし、次の手順で、ジオデータベース コンポーネントを探索するための追加のジオデータベースを作成します。

  3. リボンの [データベース] タブにある [プロジェクト] グループで、[新しいファイル ジオデータベース] をクリックします。

    [新しいファイル ジオデータベース] ボタン

  4. [新しいファイル ジオデータベース] ウィンドウの [名前] に「SampleBaseMapGDB.gdb」と入力します。[SalzburgGeodatabase] フォルダーにジオデータベースを作成します。

    [新しいファイル ジオデータベース] ウィンドウ

    次に、ベースマップ ジオデータベース スキーマを XML ドキュメントから [SampleBaseMapGDB.gdb] にインポートします。この場合、一般的なジオデータベース設計とジオデータベース オブジェクトを確認し、今後 XML ワークスペース ドキュメントを使用して独自のジオデータベース スキーマを共有する方法を検討する必要があります (この作業は常に必要なわけではありません)。

  5. [コンテンツ] ウィンドウで、[SampleBaseMapGDB.gdb] をクリックします。
  6. リボンの [カタログ] タブにある [作成] グループで、[インポート] をクリックして [XML ワークスペース ドキュメント] を選択します。

    [XML ワークスペース ドキュメント] オプション

  7. [XML ワークスペース ドキュメントのインポート (Import XML Workspace Document)] ジオプロセシング ツールの [インポート ファイル] で、[参照] ボタンをクリックします。
  8. [インポート ファイル] ウィンドウで [SampleBasemapGDB.xml] を参照して選択し、[OK] をクリックします。

    [インポート ファイル] ウィンドウ

  9. [XML ワークスペース ドキュメントのインポート (Import XML Workspace Document)] ジオプロセシング ツールの [インポート オプション] で、[スキーマのみをインポート] を選択し [実行] をクリックします。

    [XML ワークスペース ドキュメントのインポート (Import XML Workspace Document)] ツールのパラメーター

  10. [コンテンツ] ウィンドウで、[SampleBaseMapGDB.gdb] を右クリックし、[更新] をクリックします。
  11. [カタログ] ビューで、[SampleBaseMapGDB.gdb] の内容を確認します。

    ジオデータベースは、システム テーブルとユーザー データのコレクションから構成されます。ユーザー データは次のタイプのデータセットに格納できます。

    • フィーチャクラス
    • フィーチャ データセット
    • モザイク データセット
    • ラスター データセット
    • テーブル (非空間)

    さらに、フィーチャクラスおよびテーブルにはサブタイプを含めることができ、それらにドメインを関連付けることができます。また、ジオデータベースにはアタッチメントとリレーションシップ クラスも含まれています。

    インポートされたジオデータベース オブジェクト

    このジオデータベースでは、フィーチャクラスは、フィーチャクラスを主題別にグループ化するフィーチャ データセット ([管理][交通] など) に整理されています。このジオデータベースには、ユーザーが作成した一連のジオプロセシング ツール、スクリプト、およびモデルの整理に使用できるジオプロセシング ツールボックスも含まれています。

    フィーチャ データセットには、フィーチャクラスに加え、次のタイプのデータセットを格納できます。

    • ジオメトリック ネットワーク (ArcGIS Pro では読み取り専用)
    • ネットワーク データセット (ArcGIS Network Analyst エクステンションが必要)
    • テレイン (ArcGIS 3D Analyst Extension が必要)
    • トポロジ

  12. [管理] フィーチャ データセットで整理されているフィーチャクラスを展開して確認します。

    [管理] フィーチャ データセットはベースマップ ジオデータベース スキーマであるため、このフィーチャ データセットには、行政区域の境界線およびポリゴンを格納および維持するために設計された複数のラインおよびポリゴン フィーチャクラスが含まれています。

    [管理] フィーチャ データセット

  13. [コンテンツ] ウィンドウで、[SampleBaseMapGDB.gdb] をクリックします。

    [カタログ] ウィンドウには、[PointsOfInterest] フィーチャクラスが含まれています。このフィーチャクラスは、フィーチャ データセットで整理および管理されていないスタンドアロン フィーチャクラスです。

    [PointsOfInterest] フィーチャクラス

    [PointsOfInterest] フィーチャクラスに、関連付けられたアタッチメント テーブル [PointsOfInterest__ATTACH] が含まれていることに注目してください。このテーブルには、フィーチャクラスの各ポイントの画像と関連ドキュメントおよびリンクを含めることができます。アタッチメント機能は、非地理データをユーザーが用意した地理情報に関連付けるための強力な手段です。この場合、[PointsOfInterest__ATTACHREL] という名前のリレーションシップ クラスを使用して、ポイントとそのポイントに関連するアタッチメント ファイル間で永続的なリンクを維持します。アタッチメント ファイルの詳細については、こちらをご参照ください。

  14. [SampleBaseMapGDB.gdb] で、[Slopemap][OrthoPhotos] を確認します。

    これらのジオデータベース オブジェクトはいずれも、ラスター データの格納および管理方法を表しています。

    ジオデータベース ラスター

    [Slopemap] オブジェクトは、1 つのラスターまたは画像データ レイヤーであるラスター データセットを表しています。通常、ラスター データセットは、ArcGIS Pro でサポートされ、ジオデータベースに格納できるラスター形式を指します。[Orthophoto] オブジェクトは、ラスター データのコレクションの管理、表示、提供、および共有に使用されるモザイク データセットを表しています。

  15. [SampleBaseMapGDB.gdb] で、[HistoricSitesDescriptions] を探します。

    このオブジェクトは、必要に応じて空間フィーチャに関連付けることのできる説明、コード、およびその他の関連データを含む非空間ジオデータベース テーブルを表しています。

    備考:

    これで、XML ワークスペース ドキュメントを [SampleBaseMapGDB.gdb] にインポートし、一般的なベースマップ設計を調査および確認できました。このレッスンで、このジオデータベースを再び使用することはありません。

  16. [コンテンツ] ウィンドウで、[データベース] を展開し、[SampleBaseMapGDB.gdb] をクリックします。
  17. リボンの [カタログ] タブの [整理] グループで、[削除] をクリックします。
    備考:

    ジオデータベースを削除すると、選択したアイテムのみがプロジェクトから削除されます。アイテムへのプロジェクト参照はすべて削除されますが、アイテムはディスクに残ります。

    これでサンプル ベースマップ ジオデータベース スキーマの確認が終わり、ユーザー独自の観光ジオデータベースにデータを設定する準備が整いました。

Salzburg ジオデータベースのドキュメント化および準備

Salzburg ジオデータベースにデータを設定する準備として、ジオデータベース メタデータを編集および更新します。

  1. [コンテンツ] ウィンドウで、[SalzburgGeodatabase.gdb] を右クリックして、[メタデータの編集] を選択します。

    [メタデータの編集] オプション

    メタデータ コンテンツは、[カタログ] ビューの詳細ウィンドウに表示されます。[コンテンツ] ウィンドウが更新され、メタデータ カテゴリが表示されます。SalzburgGeodatabase.gdb には、[概要][メタデータ]、および [情報資源] の 3 つのメタデータ グループが定義されています。メタデータの編集の詳細については、こちらをご参照ください。

    メタデータ グループ

    [カタログ] ビューの詳細ウィンドウに、メタデータが表示されます。

    ジオデータベース メタデータ

    次に、アイテムの概要のアイテム説明を設定します。

  2. [カタログ] ビューの詳細ウィンドウで、次の情報を更新します。

    • [タイトル] に「Salzburg Tourism Geodatabase」と入力します。
    • [タグ] に「Salzburg, Austria, Visitor map, Tourism, Tourist, Visitor guide, Food, Activities, Attendees, Places to visit, Places to eat, Bike Routes, Ski Resorts, Museums, Art, Castles, Cathedrals」と入力します。
    • [サマリー] に「Collection of data for the city and surrounding areas of Salzburg Austria」と入力します。
    • [説明 (要約)] に「Geodatabase to store and manage a collection of spatial and attribute data that can be used by tourism agencies in the city of Salzburg, Austria to develop updated web maps and apps」と入力します。

  3. [著作権] に次の情報を入力します。

    • STADT: SALZBURG https://maps.stadt-salzburg.at/
    • National Mapping Agency - Federal Office for Metrology and Surveying (BEV) https://www.bev.gv.at
    • Austrian Map online
    • Land Salzburg - Open Government Data (OGD) - https://service.salzburg.gv.at/ogd/client/ and https://www.salzburg.gv.at/sagis/
    • Austrian OGD basemap https://www.basemap.at/index_en.html

  4. [適切な縮尺範囲] を 1:50,000 ~ 1:5,000 に設定します。

    縮尺範囲

  5. [追加] ボタンをクリックして、[境界四角形] 情報を表示および更新します。次の情報を追加します。

    西

    12.058153

    14.008495

    46.938376

    48.042424

    Web アプリケーションは全世界ではなく境界四角形の範囲で表示されるため、境界四角形の値は公開済みのレイヤーおよびマップに役立ちます。

    備考:

    ArcGIS アイテムのメタデータ コンテンツを作成または更新する場合、組織にとってそのアイテムを理解するために重要な情報をすべて記録します。これには、アイテムの正確度や最新度、アイテムの使用と共有に関する制限、フィーチャの生成などライフ サイクル内の重要なプロセスなどが含まれます。

  6. リボンの [メタデータ] タブの [メタデータの管理] グループで、[保存] をクリックします。
  7. メタデータ エディター ウィンドウを閉じます。
  8. [コンテンツ] ウィンドウで、[SalzburgGeodatabase.gdb] を右クリックして、[メタデータの表示] を選択します。

    [カタログ] ビューには、Salzburg Tourism ジオデータベースの更新されたメタデータが表示されます。

    ジオデータベース メタデータ

    備考:

    わかりやすい情報が提供されている場合は、検索機能を使用してアイテムを探し、検索結果の中からどのアイテムが最も使用に適しているかを評価できます。コミュニケーションを改善し、アイテムの地理空間情報に基づいた意思決定に自信を持つことができます。後から復元、使用、評価できるようにプロジェクトのアーカイブを作成できます。

  9. プロジェクトを保存します。

次に、[City_of_Salzburg][KMZ ファイル]、および [OpenStreetMap_Salzburg] フォルダーから [SalzburgGeodatabase.gdb] に複数のデータソースを移行します。


ジオデータベースへのデータの設定

ザルツブルク市の現在の観光マップとオンライン情報の調査は、さまざまな観光省庁や民間企業が観光客に最適なサービスを提供するために必要なデータ テーマについての適切な判断材料になります。この調査は、ジオデータベースに追加するデータの良い参考になります。今回構築してシンボル表示するフィーチャクラスの大半は、ArcGIS Living Atlas of the World などのソースで公開されている現在のベースマップ レイヤーに高い確率で表示されます。フィーチャクラスは既存のベースデータを補完し、省庁が生成および公開する対話形式の Web マップおよびアプリに付加価値を提供します。

ザルツブルク観光で使用される最も一般的なマップとデータには、次のようなものがあります。

  • 道路、歩行者エリア、および建物を表す詳細な市内マップ
  • 観光客の動向を含む観光マップ
  • 市場および展覧会の場所を示すマップ
  • バスの停留所および鉄道の駅と路線図
  • お勧めの散策 - 建築、博物館、アート、ギャラリー、教会
  • 散策およびサイクリングのルート
  • 醸造所や居酒屋を含むビール ルート
  • 都市と自然のハイキング コース
  • ホテル マップ

フィーチャ データセットの作成

ジオデータベースでの作業時に、ジオデータベースから空のフィーチャ データセットを直接作成できます。まず、次の 4 つのデータ テーマのフィーチャ データセットを作成します。

  • City_Attractions
  • Transportation
  • Scenic_Attractions
  • Trails

  1. 必要に応じて、プロジェクトを開きます。
  2. [コンテンツ] ウィンドウで [SalzburgGeodatabase.gdb] を右クリックし、[新規] をポイントして [フィーチャ データセット] を選択します。

    選択したデータセット タイプに対応するジオプロセシング ツールが開きます。

    [フィーチャ データセット] オプション

  3. [フィーチャ データセットの作成 (Create Feature Dataset)] ジオプロセシング ツールの [フィーチャ データセット名] に「City_Attractions」と入力します。
  4. [座標系][座標系の選択] ボタンをクリックします。

    ジオデータベース オブジェクトの座標系を定義する最も簡単な方法の 1 つは、座標系が正しく定義されている現在のデータ ソースから座標系をインポートまたはクローン作成することです。

  5. [座標系] ウィンドウで [座標系の追加] ボタンをクリックし、[座標系のインポート] を選択します。

    [座標系のインポート] オプション

  6. [座標系のインポート] ウィンドウで、[City_of_Salzburg] フォルダーを参照します。[BicyclePaths.shp] を選択し、[OK] をクリックします。

    [座標系のインポート] ウィンドウ

  7. [使用可能な XY 座標系] リストで、[MGI Austria GK M31] が選択されていることを確認し、[OK] をクリックします。

    [座標系] ウィンドウ

  8. [フィーチャ データセットの作成 (Create Feature Dataset)] ツールで、パラメーターを確認して [実行] をクリックします。

    [フィーチャ データセットの作成 (Create Feature Dataset)] ツールのパラメーター

    備考:

    オーストリアで地籍データに使用される公式な投影座標系は、横メルカトル投影である MGI Austria GK Central です。ただし、ザルツブルク市を含む州に代表されるオーストリアの各州では、負の値を回避するためにシフト (False Easting) を適用しているため、カスタム座標系 (MGI Austria GK M31) が使用されています。

  9. [カタログ] ビューで [City_Attractions] を右クリックして、[メタデータの編集] を選択します。
  10. [カタログ] ビューの [詳細] ウィンドウで、メタデータに次の更新を加えます。

    • [タイトル] に「Salzburg City Attractions」と入力します。
    • [タグ] には「Salzburg, Austria, City Attractions」と入力します。
    • [サマリー] に「Collection of Salzburg visitor attractions」と入力します。
    • [説明 (要約)] に「Location of various city sites commonly visited by tourists in Salzburg Austria」と入力します。
    • [著作権] に次の情報を入力します。
      • STADT: SALZBURG https://maps.stadt-salzburg.at/
      • National Mapping Agency - Federal Office for Metrology and Surveying (BEV) https://www.bev.gv.at
      • Austrian Map online
      • Land Salzburg - Open Government Data (OGD) - https://service.salzburg.gv.at/ogd/client/ and https://www.salzburg.gv.at/sagis/
      • Austrian OGD basemap https://www.basemap.at/index_en.html
    • [適切な縮尺範囲] を都市 (1:50,000) ~ 建物 (1:5,000) に設定します。
    • [境界四角形] に次の値を設定します。

      西

      12.058153

      14.008495

      46.938376

      48.042424

  11. リボンの [メタデータ] タブの [メタデータの管理] グループで、[保存] をクリックします。
  12. [カタログ] ビューで、[City_Attractions] タブをクリックします。
  13. [コンテンツ] ウィンドウで、[City_Attractions] を右クリックして、[メタデータの表示] を選択します。

    フィーチャ データセットのメタデータ

  14. [コンテンツ] ウィンドウで [SalzburgGeodatabase.gdb] をクリックします。
  15. リボンの [カタログ] タブにある [作成] グループで、[新規] をクリックして [フィーチャ データセット] を選択します。

    新規フィーチャ データセット

  16. [フィーチャ データセットの作成 (Create Feature Dataset)] ジオプロセシング ツールで、次のパラメーターを設定します。

    • [出力ジオデータベース] で、[C:\Salzburg\SalzburgGeodatabase\SalzburgGeodatabase.gdb] を選択します。
    • [フィーチャ データセット名] に「Scenic_Attractions」と入力します。
    • [座標系][MGI Austria GK M31] を選択します。

  17. 同じワークフローとパラメーターを使用して、次のデータ タイプに対して追加のフィーチャ データセットを作成します。

    • 交通
    • トレイル

  18. [コンテンツ] ウィンドウで、[SalzburgGeodatabase.gdb] を展開して、4 つのフィーチャ データセットが作成されていることを確認します。
    フィーチャ データセット
  19. 必要に応じて、追加のフィーチャ データセットのメタデータを更新します。

1 つのシェープファイルのインポート

ソース データ形式をインポートしてフィーチャクラスに変換することで、ジオデータベースにデータを追加できます。最初に、シェープファイルのジオデータベースへの移行について説明します。シェープファイルは、GIS コミュニティで現在でも一般的に使用される古いデータ形式ですが、効率的なデータ格納タイプとしての使用を妨げる複数の制限が存在します。シェープファイルはフィーチャクラスに類似しているため、ジオデータベースに移行する際、ジオデータベースに 1 つのフィーチャクラスとして直接マッピングされます。

  1. [カタログ] ウィンドウの [SalzburgGeodatabase.gdb] で、[City_Attractions] フィーチャ データセットを右クリックし、[インポート] をポイントして [フィーチャクラス] を選択します。

    [フィーチャクラスのインポート] オプション

    リボンの [カタログ] タブの [作成] グループにある [フィーチャクラスのインポート] ツールを使用することもできます。

    [カタログ] タブの [フィーチャクラスのインポート] オプション

    [フィーチャクラス → フィーチャクラス (Feature Class to Feature Class)] ジオプロセシング ツールが開きます。このツールを使用すると、ジオデータベースにインポートする 1 つのデータ ソースを選択できます。さらに、出力フィーチャクラスの名前を変更し、ソース データから保持または削除するソース属性フィールドを選択できます。

  2. [フィーチャクラス → フィーチャクラス (Feature Class To Feature Class)] ジオプロセシング ツールの [入力フィーチャ] で、[OpenStreetMap_Salzburg] フォルダーを参照し、[OSM_Salzburg_HistoricSites.shp] を選択します。
  3. [出力場所][City_Attractions] に設定されていることを確認します。
  4. [出力フィーチャクラス] に「HistoricSites」と入力します。
    備考:

    [フィールド マップ] セクションの [出力フィールド] パラメーターには、出力データセットにコピーされる属性フィールドのリストが表示されます。フィールドを削除するには、フィールドを選択して [削除] を選択します。複数のフィールドを削除するには、Shift + Ctrl キーを押してフィールドを選択し、[削除] を選択します。

  5. [出力フィールド] リストで、[HISTORIC][NAME][ADDR_HOUSE][ADDR_HOU00][ADDR_STREE][ADDR_CITY][ADDR_STATE][ADDR_POSTC]、および [ADDR_PLACE] フィールドを保持します。他のすべてのフィールドを削除します。
  6. パラメーターを確認し、[実行] をクリックします。

    [フィーチャクラス → フィーチャクラス (Feature Class to Feature Class)] ツールのパラメーター

    [HistoricSites] フィーチャクラスの空間参照を定義する必要はありません。ソース シェープファイルの座標系には、[WGS_1984_Web_Mercator_Auxiliary_Sphere] が定義されています。ターゲット フィーチャ データセットの座標系はすでに定義されているため、ソース データはターゲット フィーチャ データセットの座標系と一致するように自動的に再投影されます。

  7. [コンテンツ] ウィンドウで [City_Attractions] を右クリックし、[更新] を選択します。
  8. [カタログ] ビューで [HistoricSites] をクリックします。

    [メタデータ] タブが表示されます。元のシェープファイル メタデータがジオデータベース フィーチャクラスにコピーされました。

    備考:

    [カタログ] ビューにフィーチャクラスが表示されない場合は、[カタログ] ビューの右上隅にある [詳細の表示/非表示] ボタンをクリックします。

    フィーチャクラスのメタデータ

  9. [カタログ] ビューで [HistoricSites] を右クリックして、[メタデータの編集] を選択します。

    [メタデータの編集] オプション

  10. [メタデータ エディター] ウィンドウで、次の情報を更新します。

    • [タイトル] に「Salzburg Historic Sites」と入力します。
    • [タグ] に「Salzburg, Austria, Historic sites」と入力します。
    • [サマリー] に「Point features of historic sites in Salzburg Austria」と入力します。
    • [著作権] および [利用制限] フィールドにはソース メタデータのデータが設定されるため、デフォルトのテキストのままにします。
    • [説明 (要約)] に「Location of historic sites in Salzburg Austria」と入力します。
    • [適切な縮尺範囲] を都市 (1:50,000) ~ 建物 (1:5,000) に設定します。

    編集されたフィーチャクラスのメタデータ

  11. リボンの [メタデータ] タブの [メタデータの管理] グループで、[保存] をクリックします。
  12. メタデータ エディター ウィンドウを閉じます。

複数のフィーチャクラスのジオデータベースへのエクスポートまたはインポート

選択したフィーチャのみを変換し、出力フィーチャクラスにコピーする特定の属性フィールドを選択する必要がある場合、1 つのシェープファイルをエクスポートまたはインポートすると便利です。迅速に変換を行うために複数のソースをバッチ変換し、後で不要な属性フィールドを削除する必要がある場合もあります。

  1. [コンテンツ] ウィンドウで、[City_of_Salzburg] フォルダーをクリックします。
  2. [カタログ] ビューで [Castles.shp] をクリックし、Ctrl キーを押して、[Museums.shp] および [ReligiousMonuments.shp] を選択します。
  3. [Castles.shp] を右クリックし、[エクスポート] をポイントして、[フィーチャクラス → ジオデータベース (Feature Class(es) To Geodatabase)] を選択します。

    [フィーチャクラス → ジオデータベース (Feature Class(es) To Geodatabase)] オプション

  4. [フィーチャクラス → ジオデータベース (Feature Class to Geodatabase)] ジオプロセシング ツールの [出力ジオデータベース] で、[SalzburgGeodatabase.gdb][City_Attractions] フィーチャ データセットを参照して選択します。
  5. [実行] をクリックします。

    [フィーチャクラス → ジオデータベース (Feature Class To Geodatabase)] ツールのパラメーター

  6. [SalzburgGeodatabase.gdb][City_Attractions] フィーチャ データセットに 4 つのフィーチャクラスが含まれていることを確認します。

    フィーチャクラスのインポート

  7. [コンテンツ] ウィンドウの [SalzburgGeodatabase.gdb] で、[Scenic_Attractions] フィーチャ データセットを右クリックし、[インポート] をクリックして [複数のフィーチャクラス] を選択します。

    [フィーチャクラスのインポート] ツール

  8. [フィーチャクラス → ジオデータベース (Feature Class to Geodatabase)] ジオプロセシング ツールの [入力フィーチャ] で、次のシェープファイルを追加します。

    ソース フォルダー ソース シェープファイル

    City_of_Salzburg

    NatureReserves.shp

    NaturalParks.shp

    Skilifts.shp

    SkiSlopes.shp

    SwimmingHoles.shp

    Waterbodies.shp

    Waterwheels.shp

    OpenStreetMap_Salzburg

    OSM_Salzburg_CableCar.shp

    OSM_Salzburg_CableCarStations.shp

    OSM_Salzburg_NaturalFeatureBoundaries.shp

    OSM_Salzburg_NaturalFeatures.shp

    OSM_Salzburg_ReceationSiteBoundaries.shp

    OSM_Salzburg_RecreationSites.shp

    OSM_Salzburg_Streams.shp

    [フィーチャクラス → ジオデータベース (Feature Class To Geodatabase)] ツールのパラメーター

  9. [実行] をクリックします。
  10. [カタログ] ビューで、次のフィーチャクラスの名前を変更します。

    元の名前新しい名前

    OSM_Salzburg_CableCar.shp

    CableCar

    OSM_Salzburg_CableCarStations.shp

    CableCarStations

    OSM_Salzburg_NaturalFeatureBoundaries.shp

    NaturalFeatureBoundaries

    OSM_Salzburg_NaturalFeatures.shp

    NaturalFeatures

    OSM_Salzburg_ReceationSiteBoundaries.shp

    ReceationSiteBoundaries

    OSM_Salzburg_RecreationSites.shp

    RecreationSites

    OSM_Salzburg_Streams.shp

    Streams

  11. [Scenic_Attractions] フィーチャ データセットに 14 個のフィーチャクラスが含まれていることを確認します。

    名前が変更されたインポート済みフィーチャクラス

  12. 必要に応じて、[Scenic_Attactions] のメタデータを更新します。
  13. [Transportation] フィーチャ データセットにある次のシェープファイルをインポートして名前を変更します。

    ソース フォルダー ソース シェープファイル 出力フィーチャクラス名

    City_of_Salzburg

    BicyclePaths.shp

    BicyclePaths

    BusLanes.shp

    BusLanes

    OneWayStreets.shp

    OneWayStreets

    Pavement.shp

    pavement

    RoadNetwork.shp

    RoadNetwork

    Sidewalks.shp

    Sidewalks

    Tunnels.shp

    Tunnels

    OpenStreetMap_Salzburg

    OSM_Salzburg_Airports.shp

    Airports

    OSM_Salzburg_PublicTransportStations.shp

    PublicTransportStations

    OSM_Salzburg_Railroads.shp

    Railroads

    OSM_Salzburg_RailroadStations.shp

    RailroadStations

    [フィーチャクラス → ジオデータベース (Feature Class To Geodatabase)] ツールのパラメーター

  14. [Transportation] フィーチャ データセットに 11 個のフィーチャクラスが含まれていることを確認します。

    [Transportation] フィーチャクラス

  15. 必要に応じて、[Transportation] フィーチャクラスのメタデータを更新します。

KML ファイルのインポート

観光を主題とした便利なデータソースが、KMLファイルでのみ利用できます。[KML → レイヤー (KML To Layer)] ツールを使用して *.kmz ファイルをファイル ジオデータベースに変換します。

  1. [フォルダー] 接続で、[kmz_files] サブフォルダーをクリックします。

    [カタログ] ビューには、3 つの *.kmz ファイルがあります。これらは圧縮された KML ファイルです。

    KMZ ファイル

    ジオデータベースに博物館レイヤーがすでに存在するため、[Burgen_und_Schloesser.kmz] および [Kunstwerke_mit_Audiotext.kmz] ファイルのみを変換します。これらは、城や宮殿、および有名なアーティストによるインスタレーション アートの場所を表すフィーチャです。

  2. リボンの [解析] タブの [ジオプロセシング] グループで、[ツール] をクリックします。
  3. [ジオプロセシング] ウィンドウで、「kml」を検索します。[KML → レイヤー (KML To Layer)] 変換ツールを選択します。

    [KML → レイヤー (KML To Layer)] ツール

    [KML → レイヤー (KML To Layer)] ツールは、XML ベースのフィーチャを含む KML ファイルを、変換対象の KML ファイルに固有な一意のジオデータベースに変換します。この際、ポイントやポリゴンなどのフィーチャは、このジオデータベース内の [Placemarks] フィーチャ データセットに個別のフィーチャクラスとして追加されます。この変換を実行すると、他の GIS データと同様に、KML ファイルからこれらのフィーチャクラスの地理データを使用できます。

  4. [KML → レイヤー (KML To Layer)] ツールで、次のパラメーターを設定します。

    • [入力 KML ファイル] で、[C:\Salzburg\kmz-files\Burgen_und_Schloesser.kmz] を選択します。
    • [出力場所] で、データ フォルダーを指定します (例: C:\Salzburg)。
    • [出力データ名] に「Castle_Palace」と入力します。

    城および宮殿に対する [KML → レイヤー (KML To Layer)] ツール パラメーター

  5. [実行] をクリックします。

    このツールは、[Castle_Palace.lyr] という名前の出力レイヤー ファイルと [Castle_Palace.gdb] という名前の出力ファイル ジオデータベースを、出力フォルダーの場所 (例: C:\Salzburg) に作成します。

  6. 次のパラメーターを使用して、[KML → レイヤー (KML To Layer)] ツールを 2 回目に実行します。

    • [入力 KML ファイル] で、[C:\Salzburg\kmz-files\ Kunstwerke_mit_Audiotext.kmz] を選択します。
    • [出力場所] で、データ フォルダーを指定します (例: C:\Salzburg)。
    • [出力データ名] に「Art_Installations」と入力します。

    アートに対する [KML → レイヤー (KML To Layer)] ツール パラメーター

  7. [実行] をクリックします。

    このツールは、[Art_Installations.lyr] という名前の出力レイヤー ファイルと [Art_Installations.gdb] という名前の出力ファイル ジオデータベースを、出力フォルダーの場所 (例: C:\Salzburg) に作成します。

  8. [コンテンツ] ウィンドウで、[Salzburg] フォルダーを展開し、[Art_Installations.gdb] および [Castle_Palace.gdb] が正常に作成されていることを確認します。

    新規ジオデータベース

  9. [カタログ] ビューで、[Art_Installations.gdb] を見つけて展開します。

    [KML → レイヤー (KML To Layer)] ツールで作成されたジオデータベースには、[Placemarks] という名前のフィーチャ データセットが含まれています。

  10. [Placemarks] フィーチャ データセットを展開します。

    フィーチャ データセット内で、変換後の KML ポイントフィーチャを含むポイント フィーチャクラスがツールによって追加されています。

  11. [ポイント] フィーチャクラスを右クリックして、[名前の変更] を選択し、「Art_Installations」と入力します。
  12. [カタログ] ビューで、[Castle_Palace.gdb] を見つけて展開します。
  13. [Placemarks] フィーチャ データセットを展開し、[Points] の名前を「Castle_Palace」に変更します。
  14. [カタログ] ビューで、[Art_Installations] フィーチャクラスを右クリックして、[コピー] を選択します。

    コピー オプション

    異なるデータ形式間で変換を行っていないため、ジオデータベース間でフィーチャクラスをコピーすると、フィーチャクラスのコピーを簡単かつ迅速に移動または作成できます。

  15. [コンテンツ] ウィンドウの [SalzburgGeodatabase.gdb] で、[City_Attractions] フィーチャ データセットを右クリックし、[貼り付け] を選択します。

    [貼り付け] オプション

    貼り付けが失敗し、ソース フィーチャクラスとターゲット フィーチャ データセットの座標系が一致しない旨のエラー メッセージが表示されます。

    フィーチャクラスの貼り付けの失敗

    元の KML ファイル、つまりポイントを含む変換後のフィーチャクラスの地理座標系は [GCS_WGS_1984] に設定されています。ターゲットの [City_Attractions] フィーチャ データセットの座標系には、[MGI_Austria_GK_M31] 投影法が設定されています。このため、ソース フィーチャクラスをターゲット フィーチャ データセットにコピーできませんでした。ただし、ソース フィーチャクラスをターゲット フィーチャ データセットにインポートすると、ソース フィーチャがターゲット フィーチャ データセットと同じ座標系に再投影されます。

  16. [カタログ] ビューで、[Art_Installations] フィーチャクラスを右クリックし、[エクスポート] をポイントして、[フィーチャクラス → ジオデータベース (マルチプル)] を選択します。

    [ジオデータベースへエクスポート] ツール

  17. [フィーチャクラス → ジオデータベース (マルチプル)] ツールで、次のパラメーターを設定します。

    • [入力フィーチャ] で、[Castle_Palace] フィーチャクラスを参照して追加します。
    • [出力ジオデータベース] で、[City_Attractions] フィーチャ データセットを参照して選択します。

    [フィーチャクラス → ジオデータベース (Feature Class To Geodatabase)] ツールのパラメーター

  18. [実行] をクリックします。

    今回は、[City_Attractions] 座標系に一致するようにソース フィーチャが再投影されているため、フィーチャクラスは [City_Attractions] フィーチャ データセットに正常に追加されました。

  19. [カタログ] ビューの [City_Attractions] で、フィーチャクラスが正常にインポートされたことを確認します。

    新規フィーチャクラス

  20. 必要に応じて、[Art_Installations] および [Castle_Palace] フィーチャクラス メタデータを更新します。

    [SalzburgGeodatabase.gdb] には、主題フィーチャ データセットに編成された複数のフィーチャクラスが含まれています。これらのフィーチャクラスは、観光省庁が管理および更新して、ザルツブルク市を訪れる観光客向けに新たに改善されたマップおよびアプリを生成するのに役立ちます。

    この段階で、フィーチャを追加して属性を調整する前に、ジオデータベースを利害関係者と共有してフィードバックを得ることで、属性の検証を適用してデータの効率性と有効性を高めることができます。共有する前に、簡単なジオデータベース管理を行うことをお勧めします。

ジオデータベースのレビューと配布に向けた準備

ファイル ジオデータベースは、複数のバイナリ ファイルを含むフォルダーとしてディスク上に格納されます。データをファイル ジオデータベースに最初に追加した時点では、各ファイル内のレコードは整理された状態なので、ファイル システムから効率よくアクセスすることができます。ただし、レコードの追加や削除を繰り返すうちに各ファイル内のレコードの順番が崩れ、ファイルのどこかでレコードの削除や新しいレコードの追加が行われるたびに未使用の領域が生じます。これにより、ファイル システムによる各ファイル内でのレコード検索処理の回数が増え、レコードのアクセス率が低下します。ジオデータベースにさまざまなソース データセットをインポートしてフィーチャ データセットおよびフィーチャクラスを追加していたため、本質的にジオデータベースを編集しており、ジオデータベースのパフォーマンスに影響を与えていました。

次に、レコードを並べ替えて未使用の領域を削除し、ジオデータベースの効率性を高めます。

  1. [コンテンツ] ウィンドウで [SalzburgGeodatabase.gdb] を右クリックし、[管理] をポイントして [データベースの最適化] を選択します。

    [データベースの最適化] をクリックするとプロセスが実行され、レコードが自動的に並べ替えられて未使用の領域が削除されます。これにより、ジオデータベースの効率性が向上するとともに、無駄な領域が削減されます。頻繁に編集されるジオデータベースの最適化により、各ファイルのサイズが縮小されるとともに、格納領域と未使用領域がクリーンナップされます。データの追加や削除を頻繁に行う場合は、月に一度の割合で、ファイル ジオデータベースを最適化してください。また、大規模な変更が加えられた場合も、その後にジオデータベースを最適化してください。

    [データベースの最適化] オプション

    ジオデータベースの最適化に加えて、圧縮を適用することもできます。圧縮されたデータセット (配布されている場合) は読み取り専用なので、その名前の変更または属性インデックスおよびメタデータの修正を除き、どのような方法でも編集または変更することはできません。圧縮は今後編集する必要のないデータセットに最適で、ソース データ フィーチャの変更を許可せずに、利害関係者に初期ジオデータベースをレビュー用に提供するのに適した方法です。

    利害関係者とジオデータベースを共有する方法には、他にも複数の選択肢があります。そのうちの 1 つは、XML ワークスペース ドキュメントを作成する方法です。[コピー (Copy)] ツールまたは [クリップ (Clip)] ツールを使用して、データのサブセットを抽出するか、[パッケージ] ツールセットを使用して、レイヤー、マップ ドキュメント、および結果を統合、パッケージ化、共有します。

    次のオプションの手順では、[SalzburgGeodatabase.gdb] のデータとスキーマの両方を共有する XML ワークスペースドキュメントを生成します。

  2. [コンテンツ] ウィンドウで [SalzburgGeodatabase.gdb] を右クリックし、[エクスポート] をポイントして [ジオデータベース → XML ワークスペース ドキュメント (Geodatabase To XML Workspace Document)] を選択します。

    [ジオデータベース → XML ワークスペース ドキュメント (Geodatabase To XML Workspace Document)] オプション

  3. [XML ワークスペース ドキュメントのエクスポート (Export XML Workspace Document)] ツールで、次のパラメーターを設定します。
    • [入力データ]C:\Salzburg\SalzburgGeodatabase\SalzburgGeodatabase.gdb を参照します。
    • [出力ファイル] に「SalzburgGeodatabase_ExportXML.xml」と入力します。
    • [エクスポート オプション][データ] を選択します。
    • [ストレージ タイプ][バイナリ] が選択されていることを確認します。
    • [メタデータのエクスポート] をオンにします。

    [XML ワークスペース ドキュメントのエクスポート (Export XML Workspace Document)] ツール

  4. [実行] をクリックします。

    これで、レビューおよびコメント用に、利害関係者に出力 XML ワークスペース ドキュメントを配布および共有することができます。

  5. プロジェクトを保存します。

このレッスンでは、ジオデータベースの作成をサポートする ArcGIS Pro プロジェクトを作成しました。[カタログ] ビューを使用して、プロジェクト コンポーネントの操作、ジオデータベースの管理、複数のフィーチャ データセットの作成、さまざまなフィーチャクラスのインポートを行いました。その後、ジオデータベース コンポーネントへのメタデータの追加を検討し、圧縮を適用してジオデータベースの効率性を高めました。

You can find more lessons in the Learn ArcGIS Lesson Gallery.