バンド割り当ての比較

まず、最初の作業として、Landsat 8 画像を使用して焼け跡を調べます。 調査エリアについて十分な知識を得た後、画像内のバンド割り当てを変更して、焼失地域をわかりやすく表示します。 次に、カスタム割り当てを作成して、焼け跡を強調表示します。

プロジェクトを開く

解析を始める前に、割り当てられた RAW データを含むプロジェクト パッケージをダウンロードして開きます。

  1. Montana Fires プロジェクト パッケージをダウンロードします。 プロンプトが表示されたら、ファイルを覚えやすい場所 ([ドキュメント] フォルダーなど) にダウンロードします。

    プロジェクト パッケージには、プロジェクトのすべてのマップ、データ、フォルダー、ツールボックスが含まれています。

    注意:

    お使いの Web ブラウザーによっては、ダウンロードを開始する前に、ファイルの場所を選択するよう求めるメッセージが表示される場合があります。 ほとんどのブラウザーでは、デフォルトでコンピューターのダウンロード フォルダーにダウンロードされた後、選択した場所にパッケージを移動できます。

    設定によっては、ダウンロードしたプロジェクト パッケージが ArcGIS Pro で自動的に開くことがあります。 自動的に開かない場合は、ここで開きます。

  2. ArcGIS Pro を起動します。 サイン インを求められたら、ライセンスが割り当てられた ArcGIS アカウントを使用してサイン インします。
    注意:

    ArcGIS Pro または ArcGIS アカウントがない場合、ArcGIS の無料トライアルにサイン アップできます。

    ArcGIS Pro を開くと、新しいプロジェクトを作成するか、既存のプロジェクトを開くかを選択できるオプションが表示されます。 以前プロジェクトを作成したことがある場合は、最近使用したプロジェクトのリストが表示されます。

  3. [Open another project] (以前に ArcGIS Pro を使用したことがある場合) または [Open an existing project] (ArcGIS Pro を使用したことがない場合) をクリックします。

    別のプロジェクトを開く

    次に、ダウンロードしたプロジェクトを検索します。

  4. [プロジェクトを開く] ウィンドウで、[Montana_Fires] プロジェクト パッケージがダウンロードされた場所を参照します。 パッケージをダブルクリックして開きます。

    [コンテンツ] ウィンドウに、2 つのレイヤーを含むプロジェクトが開きます。

    デフォルトのプロジェクト

    [2014.tif] および [2015.tif] レイヤーは画像レイヤーで、オフになっています。 マップはモンタナ州のグレイシャー国立公園の中心に配置され、その面積は百万エーカーを超えます。 このプロジェクトで使用するベースマップは [地形図] です。

画像の強調表示

プロジェクト データにアクセスできたところで、次は画像を調べてその表示を強調します。 [2014.tif] および [2015.tif] レイヤーはともに Landsat 8 画像レイヤーで、Thompson 火災と Reynolds Creek 火災という特定の 2 件の山火事を囲む調査エリアにクリップされています。 どちらの画像も、別々の年の 8 月に撮影されたものです。

  1. [コンテンツ] ウィンドウで [2014.tif] レイヤーの横にあるチェックボックスをオンにして、そのレイヤーを有効にします。 レイヤーを右クリックし、[Zoom To Layer] をクリックします。

    レイヤーにズーム

    マップ上で、該当する画像の場所が拡大表示されます。

    2014.tif レイヤー

    この画像は暗い色調のため、見づらく感じます。 画像をわかりやすく表示するために、明るさ、コントラスト、ガンマを調整します。 明るさは、画像の明暗の度合いを決定します。 コントラストは、フィーチャ間を区別できる視覚的な差を決定します。 ガンマは、画像で検出される明るさと画像の実際の発光との関係を決定します。 これらすべての設定値を上げることで、画像の表示を強調します。

  2. 必要に応じて、[コンテンツ] ウィンドウで、[2014.tif] レイヤーをクリックして選択します。
  3. リボンの [表示設定] タブをクリックします。 [強調] グループで、[レイヤーの明るさ]20 に、[レイヤーのコントラスト]25 に、[レイヤーのガンマ]1.8 に上げます。 Enter キーを押します。

    強調 グループ

    変更すると、ただちに画像が更新されます。

    修正された 2014.tif レイヤー

    これで、環境の詳細がよりはっきりと表示されるようになりました。 この山岳地形は渓谷と湖を特徴としています。 山頂の中には、雪をかぶったものもあれば、雲に覆われてぼやけているものもあります。 この画像は 8 月に撮影されたものであるため、山に氷河または万年雪が存在している可能性があります。 また、この地形には広大な植生が存在しているように見えます。 植生の種類と山の傾斜は、特に火災が拡がる速度に影響を及ぼします。 以上が、Reynolds Creek 火災と Thompson 火災の発生前を示す「2014」における調査エリアの概況です。 次に、2015 画像を確認します。

  4. [コンテンツ] ウィンドウで、[2014.tif] レイヤーをオフにして、非表示にします。 [2015.tif] レイヤーをオンにして、表示します。

    [2015.tif] 画像が表示されます。

    2015.tif レイヤーのデフォルト

    デフォルトの 2015 の画像の外観は 2014 の画像よりもはっきりとしていますが、明るさ、コントラスト、ガンマをいくらか補正する余地があります。

  5. [コンテンツ] ウィンドウで、[2015.tif] レイヤーをクリックして選択します。
  6. [表示設定] タブの [強調] グループで、[レイヤーの明るさ] を「10」に、[レイヤーのコントラスト] を「15」に、[レイヤーのガンマ] を「1.5」に上げます。

    修正された 2015.tif レイヤー

    2015 の画像には、2014 の画像と明らかに異なる点が 2 つあります。 第一に、大きなグレーの雲が、この画像の中心から南側の部分を覆っています。 実際、この雲は Thompson 火災による煙で、この画像が撮影された当時も燃え続けていました。

    Thompson 火災

    第二に、この画像の中心から北側の部分にある湖の左上に、赤みを帯びた細長い筋が見えます。 これは、この画像が撮影された時点までに燃焼が終わっていた Reynolds Creek 火災の焼け跡です。

    Reynolds Creek 火災

    どちらの山火事も目で確認できますが、山火事の正確な境界が不明瞭です。 次に、画像のさまざまなバンド割り当てを検証し、最も焼け跡が強調される画像を見つけます。

さまざまなバンド割り当ての表示

Landsat 画像は、電磁スペクトルの波長の範囲を計測しますが、この中には人間の目には見えない波長も含まれます。 これらの範囲をスペクトル バンドと呼びます。 次の表に、スペクトル バンドの説明を示します。

数値名前このバンドで最適に表示される事物

1

コースタル エアロゾル

浅瀬、細かいちり粒子

2

深海、大気

3

植物

4

人工物体、土壌、植生

5

近赤外

海岸線、植生

6

短波赤外 1

雲の貫通性、土壌や植生中の水分

7

短波赤外 2

改善した雲の貫通性、土壌や植生中の水分

8

パンクロマティック

白黒画像、より鮮明な細部

9

Cirrus

巻雲

10

熱赤外 1

サーマル マッピング、推定土壌水分

11

熱赤外 2

改善したサーマル マッピング、推定土壌水分

バンド 2、3、4 (青、緑、赤) は、人間の目に見える光線のスペクトルを構成します。 画像で現在使用されているナチュラル カラー バンド割り当ては、これら 3 つのバンドを組み合わせて、人の目に映るときの画像に近付けます。 次は、バンド割り当てを変更して、山火事を強調表示し、それぞれの火事の境界をよりわかりやすくします。

  1. [コンテンツ] ウィンドウで、[2015.tif] レイヤーを選択されていることを確認します。

    ナチュラル カラー バンド

    レイヤー名の下に、画像で現在使用されているバンドとして、可視光線を含む青、緑、赤の各バンドが表示されます。 赤バンドと緑バンドは植生を強調表示します。火災の被害を受けなかった豊かな植生地域と、火災によって植生が破壊された地域との間にはコントラストがあるため、これらのバンドは火災を確認するのに役立ちます。 近赤外 (バンド 5) のような別のバンドを使用して植生を強調表示すると、コントラストを改善できます。

  2. [Appearance] タブの [Rendering] グループで、[Band Combination] をクリックし、[Color Infrared] を選択します。

    バンド割り当て

    画像が更新され、新しいバンド割り当てが表示されます。

    「2015」赤外

    [コンテンツ] ウィンドウ内で、レイヤー名の下にあるバンドが更新され、この画像が近赤外、赤、緑のバンド (3、4、5) の組み合わせであることが表示されます。 近赤外は通常人間の目には見えないため、赤のチャンネルを通じて表示されます。 その結果、赤と緑のバンドは、緑と青のチャンネルを通じて表示されます。

    コンテンツ ウィンドウのカラー赤外バンド

    注意:

    3 つの画像バンドを割り当て、赤、緑、青の各チャンネルで表示した画像を RGB コンポジットと呼びます。 3 つの RGB コンポジット チャンネルはいずれも、すべてのバンドを使用できます。これが、赤バンドを緑のチャンネルを通じて表示することが可能な理由です。 凡例で、シンボルと最初の単語の色はコンポジット色 (チャンネル) を示しているのに対して、2 番目の単語は選択したバンドを示しています。

    画像アナリストであれば、このようなめずらしい色の割り当てで画像が表示されることにすぐに慣れるでしょう。

    マップで、植生は赤色で表示されます。 火災地域はどちらも暗褐色で表示されます。 元の画像と比較すると、特に湖の北側にある Reynolds Creek 火災がより明確に表示されるようになりました。 ただし、Thompson 火災はまだ煙で多少ぼやけています。 次に、雲を貫通する短波赤外バンド (6 と 7) を使用したバンド割り当てを試してみます。

  3. [Appearance] タブで、[Band Combination] をクリックし、[Land/Water Interface] を選択します。

    バンドが更新され、画像が変化します。

    「2015」SWIR

    [コンテンツ] ウィンドウ内で、レイヤーの下にあるバンドが更新され、両方の短波赤外バンドと近赤外バンドが表示されます。つまり、この画像はバンド 5、6、7 の組み合わせです。 このバンド割り当ての主な目的は陸と水を定義することですが、この割り当てはまた、かすみ (この場合は煙) の貫通も行います。 Thompson 火災の周辺にはほぼすべての煙が表示されなくなり、火事の境界がより明確になりました。 しかし、焼失地域はオレンジ色に見えるのに対して、周囲の山の斜面は黄色に見えます。 これでは、山地まで拡がる Reynolds Creek 火災が、より見づらくなります。

  4. [Band Combination] をもう一度クリックして、[Vegetation Analysis] を選択します。

    バンドが更新され、画像が変化します。

    「2015」植生

    この割り当てでは、赤、近赤外、短波赤外 1 の各バンド (4、5、6) が使用されます。 したがって、赤外カラー割り当てによる植生の強調表示と、陸/水インターフェイス割り当てによる一部のかすみの貫通がともに適用されることになります。 Thompson 火災と Reynolds Creek 火災が山の斜面に融合する部分の周囲には多少の煙が見えますが、これらの問題は、以前のバンド割り当てのときと比べてさほど重要ではなくなりました。

    かすみをあと少し減らすことができれば、この画像は焼け跡をデジタイズするのに最適な状態になることでしょう。 しかし、残りのデフォルトのバンド割り当てはどれも、表示されているこれら 3 つのバンドの表示を改善するのに役立ちません。 ユーザーのニーズに合わせて画像をカスタマイズするために、カスタム バンド割り当てを作成します。

カスタム バンド割り当ての作成

これまでは、構成済みのバンド割り当てを使用してきました。 今度は、ユーザー独自のバンドを選択してカスタム バンド割り当てを作成します。これにより、さらにかすみを減らして、[植生解析] バンド割り当てを改善します。

  1. [コンテンツ] ウィンドウで、[2015.tif] レイヤーを見つけます。

    植生解析バンド

    植生解析バンド割り当てでは、かすみを減らすために短波赤外 1 バンドが使用されるとともに、植生を強調表示するために近赤外バンドと赤バンドが使用されます。 短波赤外 1 を短波赤外 2 に切り替えることで、かすみ (雲) の貫通性を改善します。

  2. [ShortWaveInfrared_1] バンドを右クリックして [ShortWaveInfrared_2] を選択します。

    ShortWaveInfrared_2

    注意:

    パンクロマティック バンド (バンド 8) と両方の熱赤外バンド (バンド 10 とバンド 11) はこのレッスン パッケージで提供されているデータから削除されています。そのため、これらのバンドはバンドのリストに表示されません。

    マップ上で画像が自動的に更新されると同時に、バンドも自動的に更新されます。 マップ上の違いはわずかですが、焼け跡の表示の明瞭さが少し改善されているのがわかります。 次は、赤バンドを青バンドに置き換えます。

  3. [Blue] を右クリックして [Blue] を選択します。

    青バンド

    マップ上の画像がわずかに変化します。 かすみが、まだ見えるとはいえ、減少しています。

    カスタム「2015」レイヤー

    これで、適切に焼け跡を表示できました。 将来、このバンド割り当てに簡単にアクセスできるように、[表示設定] タブで、このバンド割り当てをデフォルト割り当ての 1 つとして保存します。

  4. [Appearance] タブで、[Band Combination] をクリックし、[Custom] を選択します。

    カスタム バンド割り当て

    [カスタム バンド割り当て] ウィンドウが表示されます。

  5. [Red] 色として、[ShortWaveInfrared_2] を選択します。 [Green] 色として、[NearInfrared] を選択します。 [Blue] 色として、[Blue] を選択します。 カスタム バンド割り当てに「Burn Scar Analysis」という名前を付けて [Add] をクリックします。

    カスタム バンド割り当て

    カスタム バンド割り当てが [バンド割り当て] ドロップダウン メニューに追加され、ユーザーは簡単にその割り当てを他の画像に適用できます (または、バンド割り当てを再度変更する場合はその割り当てをこの画像に再適用できます)。

    注意:

    カスタム バンド割り当ては、ArcGIS Pro の新規のセッションを開始した後でのみリストから削除できます。

  6. [クイック アクセス ツールバー][保存] ボタンをクリックして、プロジェクトを保存します。

    クイック アクセス ツールバーの保存ボタン

グレイシャー国立公園で起きた 2 件の山火事の画像を、最初は、ナチュラル カラーの画像として表示し、その後、他のバンド割り当てを使用して、焼失地域をわかりやすく強調表示しました。 最後に、焼け跡の強調に特化されたカスタム バンド割り当てを作成しました。 このカスタム割り当ては、焼け跡の正確な境界を取得することにより適していますが、焼失したものと焼失していないものを特定するには、依然として目視による判読が必要とされます。 次に、燃焼指数と呼ばれる数式を使用して、焼け跡を定量的に計算し、火災に見舞われた地域に対するより正確な計測を可能にします。


燃焼指数の計算

前回は、さまざまなスペクトル バンド割り当てを使用して画像を表示し、焼け跡を目視で確認しました。 次に、焼失地域を定量的に特定する指標を使用します。 この指標は、正規化した燃焼率 (NBR) と呼ばれ、燃焼の重大度を判別するために、画像の近赤外バンドと短波赤外 2 バンド (それぞれバンド 5 とバンド 7) を数学的に比較します。

[2014.tif] および [2015.tif] 画像に NBR を適用し、2 つの画像の差分を計算することで、火災前後の変化量を求めます。 その結果、数学的に計算された焼け跡が生成されます。

正規化した燃焼率の計算

最初に、2014 の画像について NBR を計算します。

  1. 必要な場合は、[Montana Fires] プロジェクトを開きます。
  2. [コンテンツ] ウィンドウで、[2014.tif] レイヤーを選択します。 リボンの [画像] タブをクリックし、[ツール] グループで [指数] をクリックします。

    画像 タブの指数

  3. [指数] ウィンドウで [NBR] をクリックします。

    正規化した燃焼率 (NBR) ツール

  4. [NBR] ウィンドウの [近赤外バンド インデックス][5 - 近赤外][短波赤外バンド インデックス][7 - 短波赤外 2] を選択します。 [OK] をクリックします。

    [NBR] ウィンドウ

    [コンテンツ] ウィンドウで、新しいレイヤー [NBR_2014.tif] が表示されます。

    NBR_2014.tif

    次に、2015 の画像について NBR を計算します。

  5. [コンテンツ] ウィンドウで、[2015.tif] レイヤーを選択します。 リボンの [画像] タブの [ツール] グループで [指数] をクリックします。
  6. [指数] ウィンドウで [NBR] をクリックします。
  7. [NBR] ウィンドウの [近赤外バンド インデックス][5 - 近赤外][短波赤外バンド インデックス][7 - 短波赤外 2] を選択します。 [OK] をクリックします。

    [コンテンツ] ウィンドウに、[NBR_2015.tif] レイヤーが追加されます。

NBR の変化の算出

今度は、[差分] ツールを使用して、2 つの画像間の NBR の変化を計算します。 これにより、2014 年から 2015 年にかけて NBR 値が急激に上昇したエリアを特定します。 これらのエリアが焼け跡に対応します。

計算する差分は、[NBR_2014.tif] - [NBR_2015.tif] です。 [差分] ツールは、[コンテンツ] ウィンドウに表示されている順にラスターを取り込むため、[NBR_2014.tif][NBR_2015.tif] の上に移動させます。

  1. [コンテンツ] ウィンドウで、[NBR_2014.tif] をクリックし、[NBR_2015.tif] の上にドラッグします。 Ctrl キーを押しながら、[NBR_2014.tif][NBR_2015.tif] をクリックして両方を選択します。

    選択されたレイヤー

  2. リボンの [画像] タブの [ツール] グループで、[プロセス] の下にある矢印をクリックし、[差分] を選択します。

    差分 ツール

    差分ラスター [Difference_NBR_2014.tif_NBR_2015.tif] がマップに追加されます。

    差分ラスター マップ

    これで、火災の場所がほとんど白一色で表示されるようになり、これらの場所の周囲にあるグレーと黒色の地域との間に強いコントラストが生じます。 それ以外の白色の地域は、雪に覆われた山岳地域だけであり、これらの地域は一般的に、火災地域と境界を共有することはありません。 この画像をシンボル表示して、コントラストを高めることができます。 ただし、先にレイヤーの名前を変更します。

  3. [コンテンツ] ウィンドウで、[Difference_NBR_2014.tif_NBR_2015.tif] をクリックして選択し、もう一度名前をクリックして名前を変更します。 「change_nbr」と入力して Enter キーを押します。
  4. [change_nbr] の下にあるカラー ランプをクリックして、[シンボル] ウィンドウを開きます。

    カラー ランプ

    [change_nbr] レイヤー シンボルは、RGB コンポジットではなく、カラー ランプによって決定されます。これは、他の NBR レイヤーと同様に、このレイヤーには 1 つのバンドしか含まれていないからです。

  5. [シンボル] ウィンドウの [配色] でドロップダウン リストを展開し、[名前の表示] をオンにします。 その後、[Condition Number] という名前の、緑から赤のランプを選択します。

    Condition Number

    ヒント:

    配色の名前を表示するには、その配色にポインターを合わせるか、[配色] メニューの下部にある [名前の表示] チェックボックスをオンにします。

  6. [ストレッチ タイプ][標準偏差] を選択します。

    シンボルが更新されます。

    シンボル表示された変化

    どちらの山火事も、マップ上に境界が明るい赤色ではっきりと示されるようになりました。

  7. [シンボル] ウィンドウを閉じます。

    元の NBR レイヤーは必要なくなったため、削除します。

  8. [コンテンツ] ウィンドウで、[NBR_2014.tif] レイヤーを右クリックして、[削除] を選択します。

    削除

  9. [NBR_2015.tif] レイヤーを削除します。
  10. プロジェクトを保存します。

山火事の範囲が十分にはっきりとした画像を作成できたところで、モンタナ州森林管理局の同僚と共有するポリゴン フィーチャとして、これらの火災の範囲をデジタイズできます。 。


火災地域のデジタイズ

このセクションでは、最初に新しいポリゴンを格納するフィーチャクラスを作成します。 その後、編集ツールを使用して、両方の山火事の大まかな境界に沿ってポリゴン フィーチャを描画します。 最後に、それぞれの焼け跡の面積 (エーカー単位) を計算します。

フィーチャクラスの作成

最初にフィーチャクラスを作成し、次に編集ツールを使用して焼け跡のアウトラインをトレースします。

  1. リボンの [表示] タブをクリックしてから、[ウィンドウ] グループで [カタログ ウィンドウ] を選択します。

    カタログ ウィンドウ

  2. [カタログ] ウィンドウで、[データベース] フォルダーを開きます。

    [カタログ] ウィンドウの [データベース] フォルダー

    フォルダーには、プロジェクトのデフォルト ジオデータベース [montana_fires.gdb] が含まれ、ここに新しいフィーチャクラスを作成します。

  3. [montana_fires.gdb] を右クリックし、[新規作成] をポイントして、[フィーチャクラス] を選択します。

    新規フィーチャクラス

    [ジオプロセシング] ウィンドウが表示されて、[フィーチャクラスの作成 (Create Feature Class)] ツールが表示されます。

  4. [フィーチャクラスの作成] ウィンドウの [名前] に「Fires」と入力します。 その他のパラメーターはそのままにしておき、[完了] をクリックします。

    フィーチャクラスを作成します。

    新しいフィーチャクラスが作成され、マップと [コンテンツ] ウィンドウに空の [Fire] フィーチャクラスが追加されます。 新しいフィーチャクラスのデフォルトのシンボルは、塗りつぶしであるため、マップ フィーチャを正確にトレースするのは困難です。 次に、シンボルを更新します。

  5. [コンテンツ] ウィンドウで、[Fires] のシンボルをクリックして、[シンボル] ウィンドウを開きます。

    Fires レイヤーのシンボル

    注意:

    レイヤーのシンボル色はランダムに生成されるため、この画像例とは異なる場合がありますが、解析の結果には影響を与えません。

    [シンボル] ウィンドウが表示されます。 新しいフィーチャクラスのデフォルトのシンボルは、塗りつぶしであるため、トレースするマップ フィーチャ周囲のすべてを正しく描画するのが難しい場合があります。

  6. [シンボル] ウィンドウの [ギャラリー] タブで、2 番目のオプション [黒 (アウトライン付き - 2 ポイント)] を選択します。

    黒 (アウトライン付き - 2 ポイント)

    注意:

    シンボル オプションの上にポインターを合わせると、その完全な名前が表示されます。

    フィーチャクラス レイヤーが構成され、編集できるようになりました。

境界ポリゴンの描画

次に、編集ツールを使用して、Reynolds 火災と Thompson 火災のエッジをトレースし、焼け跡をデジタイズします。

  1. Reynolds Creek 火災にズームします。

    Reynolds Creek 火災

  2. リボンの [編集] タブをクリックします。 [フィーチャ] グループの [作成] をクリックします。

    編集 タブの作成 ツール

    [フィーチャ作成] ウィンドウが表示されます。 このウィンドウには、フィーチャを作成できるレイヤーが表示されます。

  3. [フィーチャ作成] ウィンドウで、[Fires] をクリックして、[ポリゴン] ボタンをクリックします。

    Fires のポリゴン ツール

    マップ上にポインターを移動させると、ポインターが十字線に変化します。

  4. Reynolds Creek 火災のエッジ上の任意の場所をクリックして、ポリゴン フィーチャの描画を開始します。

    フィーチャを描画します。

    他の適当な場所をクリックすると、別の頂点が配置されます。

    ヒント:

    頂点を追加しながらマップを移動するには、C キーを押したままにして [マップ操作] ツールに切り替え、マップを画面移動します。 C キーを放すと、[フィーチャ作成] ツールに戻ります。

  5. 火災地域のエッジに沿って頂点を追加していきます。
    注意:

    追加する頂点が多いほど、より正確なフィーチャが描画されます。 これはあくまでも演習であるため、完全なフィーチャを作成する必要はなく、適度に正確なフィーチャで十分です。

  6. 頂点の配置が完了したら、最後の頂点をダブルクリックしてフィーチャの作成を終了します。

    Reynolds Creek フィーチャ

    注意:

    頂点の位置を変更する場合は、[頂点の編集] ([編集] タブの [ツール] グループ) をクリックして、頂点の配置を変更してください。 または、[編集] タブの [フィーチャ] グループで [削除] をクリックし、フィーチャ全体を削除してから、最初からやり直してください。

  7. 結果のフィーチャに問題がなければ、[編集] タブの [編集の管理] グループで [保存] をクリックします。

    編集を保存します。

  8. [編集の保存] ウィンドウで、[はい] をクリックして編集をすべて保存します。

    次に、Thompson 火災エリアをデジタイズします。

  9. Esc キーを押して、マップ ナビゲーション モードに戻ります。
  10. 縮小表示してから、Thompson 火災をもう一度拡大します。

    Thompson 火災

    Thompson 火災は Reynolds Creek 火災よりも規模が大きいため、デジタイズにより長い時間がかかります。

  11. 必要に応じて、[編集] タブの [作成] をクリックし、[フィーチャ作成] ウィンドウを開きます。
  12. [フィーチャ作成] ウィンドウで、[Fires] の下の [ポリゴン] ボタンをクリックします。

    フィーチャ作成

  13. Thompson 火災をデジタイズします。

    Thompson フィーチャ

  14. 結果のフィーチャに問題がなければ、編集を保存します。
  15. [フィーチャの作成] ウィンドウと [シンボル] ウィンドウを閉じます。 [コンテンツ] ウィンドウで、[change_nbr] レイヤーを右クリックして [レイヤーにズーム] を選択すると、画像の全体表示に戻ります。
    注意:

    先ほどのように、手動でフィーチャをデジタイズするのは、フィーチャの数が少ない場合に有効です。 より広いエリアを解析する場合は、[ラスター → ポリゴン (Raster to Polygon)] ツールなど、より自動化されたベクター変換方法を検討します。

属性情報の追加

両方の山火事のフィーチャを作成しましたが、現在のところ、これらのフィーチャには属性情報が含まれていません。 属性テーブルを編集して、各山火事を識別し、それぞれの火災面積を計算します。

  1. [コンテンツ] ウィンドウで、[Fires] レイヤーを右クリックして、[属性テーブル] を選択します。

    属性テーブルを開く

    属性テーブルには、2 つのフィーチャが、デジタイズされた順番で表示されています。 最後に作成したフィーチャである Thompson 火災が選択されたままになっている可能性があります。

    属性テーブル

  2. 属性テーブルのリボンで、[選択の解除] ボタンをクリックします。

    選択解除

    これらの火災の周長と面積はすでに [Shape_Length] および [Shape_Area] 属性で計算されていますが、これらの計算は平方メートル単位で行われています。 面積の計測単位は、エーカーのほうが標準的です。 新しい属性を作成して、この情報を入力します。

  3. 属性テーブルのリボンで、[フィールドの追加] ボタンをクリックします。

    フィールドの追加

    フィールド ビューが開き、下部に空のフィールドが表示されます。 2 つのフィールドを追加します。1 つは山火事の名前用、もう 1 つは山火事の面積用です。

  4. 新しいフィールドについて、[フィールド名] を「Name」に変更します。 [データ タイプ] セルをダブルクリックして、[テキスト] を選択します。

    フィールド名

  5. リボン上の [フィールド] タブにある [変更] グループで [保存] をクリックします。

    フィールドを保存します。

    注意:

    山火事のフィーチャをデジタイズしたときに保存されていない編集内容がある場合は、変更を属性テーブルに保存できません。 保存できない場合は、保存しないで属性テーブルを閉じ、[編集] タブでフィーチャの編集を保存してから、再度、新しいフィールドを追加してください。

  6. フィールドのリストの最下部をクリックして、新しいフィールドを追加します。
  7. 新しいフィールドの名前を「Acres」に変更し、[データ タイプ][Float] に変更します。

    Acres フィールドを追加

  8. リボンの [保存] をクリックします。
  9. [フィールド] ビューを閉じて属性テーブルに戻ります。

    NULL フィールド

    これらのフィールドは現在のところ空です。 [Name] フィールドは直接編集しますが、面積を計算するために、ジオプロセシング ツールを実行します。

  10. 最初のフィーチャの [Name] フィールドをダブルクリックして編集します。 「Reynolds Creek」と入力し、Enter キーを押します。
  11. 2 番目のフィーチャの名前を「Thompson」に変更します。

    属性テーブルで火災の名前を更新

  12. リボンの [編集] タブをクリックします。 [編集の管理] グループにある [保存] をクリックします。 確認ウィンドウで、[はい] を選択して編集をすべて保存します。
  13. [Acres] フィールド見出しを右クリックして、[フィールド演算] を選択します。

    フィールド演算

    [フィールド演算 (Calculate Field)] ツールが開きます。 このツールを使用すると、フィールド値を求めるための条件式を作成できます。 Fires フィーチャクラスにはすでに面積フィールドが存在しますが、このフィールドはエーカー単位ではなく、平方メートル単位です。 1 エーカーは 4,046.86 平方メートルに等しいため、この変換率を基準にして面積を計算します。

  14. [式][フィールド] 列で、[Shape_Area] をダブルクリックして、式のボックスに追加します。 除算演算子をクリックし、その後に「4046.86」と入力します。

    フィールド式

  15. [OK] をクリックします。

    最終的な属性テーブル

    [Acres] フィールドが計算されます。 Reynolds Creek 火災はおよそ 4,400 エーカーであり、Thompson 火災はおよそ 12,400 エーカーです。 フィーチャをデジタイズしたやり方はユーザーによってさまざまであるため、これらの値にはばらつきがあります。

  16. [Fires] 属性テーブルを閉じます。
  17. プロジェクトを保存します。

これで、両方の山火事について、名前と面積に関する属性情報を持つポリゴン フィーチャを作成することができました。


成果の共有 (オプション)

このセクションでは、[Fires] フィーチャクラスを ArcGIS Online に公開することで共有します。

結果の共有

[Fires]フィーチャクラスを、[Web レイヤーとして共有] ツールを使用して ArcGIS Online に共有します。

  1. [コンテンツ] ウィンドウで [Fires] レイヤーを右クリックし、[共有] をポイントして [Web レイヤーとして共有] を選択します。

    [Web レイヤーとして共有] ウィンドウが表示されます。 レイヤーを共有する前に、メタデータを入力して、レイヤーの検索と分類が可能なようにしておく必要があります。

  2. [Web レイヤーの共有] ウィンドウで、次の情報を入力します。
    • [名前] で、既存のテキストを「Glacier_National_Park_Fires」に置き換えます。 自分の名前またはイニシャルをレイヤー名の末尾に追加して、そのレイヤー名が一意になるようにします。
    • [サマリー] に次のテキストをコピーして貼り付けます。Perimeter definition of the Reynolds Creek and Thompson fires in Glacier National Park during the summer of August 2015. Perimeters defined by difference in Normalized Burn Ratio.
    • [タグ] に「Fire, Reynolds Creek, Thompson, Glacier National Park, Montana」と入力し、Enter キーを押します。
    • [共有] では、誰に自分の Web レイヤーを見て欲しいかに応じて、[すべての人に公開 (パブリック)] または組織を選択します。
  3. [統計情報の更新] をクリックします。

    解析

    レイヤーにエラーがないか分析されます。 メタデータが欠けている場合やデータに何らかの問題がある場合は、ユーザーが解決できるように、エラーが分類され、エラーの説明が提供されます。

    フィールド [Shape_Length] を表示フィールドとして使用できない、または Web レイヤーを共有できるよう一意の数値 ID の割り当てを許可がマップ プロパティで無効になっていることを示すエラーが表示される場合があります。

    分析ツールの結果

    [レイヤー プロパティ][マップ プロパティ] の設定を更新してこれらのエラーを解消します。

  4. [コンテンツ] ウィンドウで、[Fires] レイヤーをダブルクリックし、[レイヤー プロパティ] ウィンドウのサイド パネルで [表示] をクリックします。
  5. [表示フィールド][名前] を選択します。 [OK] をクリックします。
  6. [コンテンツ] ウィンドウで [マップ] をダブルクリックします。
  7. [マップ プロパティ] ウィンドウの [一般] 設定で [Web レイヤーを共有できるよう一意の数値 ID の割り当てを許可] の横にあるチェックボックスをオンにします。 [OK] をクリックします。
  8. [Web レイヤーとして共有] ウィンドウで [解析] をクリックします。

    エラーが解消され、分析ツールの結果のエラーはなくなりました。

  9. [公開] をクリックします。

    レイヤーが ArcGIS Online に公開されました。

  10. [Web レイヤーの管理] をクリックし、ArcGIS Online で公開されたレイヤーを表示します。

    Web レイヤーの管理リンク

    [Glacier_National_Park_Fires] フィーチャ レイヤーのアイテム ページがブラウザー ウィンドウに表示されます。

  11. プロンプトが表示されたらサイン インして、[Map Viewer で開く] をクリックします。

    Map Viewer で開く

    このレイヤーは、任意の数のマップへの追加、シンボル表示、共有が可能です。

このレッスンでは、Landsat 画像を使用して、2 件の山火事の範囲を特定しました。 最初に、さまざまなスペクトル バンド割り当てを使用して画像を表示し、火災の場所を目視で評価しました。 次に、正規化した燃焼率を計算して、焼失地域を特別に強調表示しました。 最後に、両方の山火事をデジタイズし、それらを ArcGIS Online で共有しました。 現実世界のシナリオとして、モンタナ州の森林資源管理局は、ここで作成されたレイヤーを植生維持の調査やこのエリアでの今後の火災対策計画に利用することができます。

同様のレッスンについては、「画像およびリモート センシングの概要」ページをご参照ください。