Create a 3D scene for a new building project

In the city center of Frankfurt am Main, Germany, a new high-rise building is planned near the main train station, in a neighborhood being currently redeveloped. The architects would like to document their progress early on in the planning process and share updates with the stakeholders. Most particularly, they would like the stakeholders to give their feedback on the height and overall dimensions of the planned building. Your first step toward this goal will be to create a 3D scene in ArcGIS Pro.

Download the data and create a scene

First, you'll download the compressed zip file that contains some of the data needed for this lesson.

  1. Go to the page for the lesson data and click Download.

    Download button

  2. Locate the downloaded Frankfurt_Construction_Planning.zip compressed folder on your computer, and move it to a location of your choice, such as the Documents folder. Right-click it to extract its content.
    Note:

    Depending on your web browser, you may be prompted to choose a file location before you begin the download. Most browsers download to your computer's Downloads folder by default.

  3. Open the extracted Frankfurt_Construction_Planning folder.

    Folder content

    It contains three data files that you will use later in the lesson: a layer package, ConstructionArea.lpkx, and two scene layer packages, GrandCentral_V1.slpk and GrandCentral_V2.slpk.

    Next, you'll create a global scene in ArcGIS Pro.

  4. Start ArcGIS Pro. If prompted, sign in using your licensed ArcGIS account.
    Note:

    If you don't have ArcGIS Pro or an ArcGIS account, you can sign up for an ArcGIS free trial.

  5. Under New and Blank Templates, choose Global Scene.

    Global Scene button

  6. In the Create a New Project window, choose the following parameter values:
    • For Name, type Frankfurt_Central_Station.
    • For Location, click Browse and browse to your extracted data folder, Frankfurt_Construction_Planning and select it. Click OK.
    • Uncheck the Create a new folder for this project check box.

    Create a New Project window

    The new ArcGIS Pro project will be created in the same folder where your data is.

  7. Click OK.

    A global scene is created.

    Initial global scene

    Note:

    A global scene enables the display of 3D data for any extent up to the entire surface of the earth. It includes worldwide basemap and base elevation layers, and users can zoom out freely without the restriction of a local scene's extent.

  8. In the Contents pane, click Scene to select it. Click it again to make the name editable. Change the name of the scene to Frankfurt Central Station and press Enter.

    Rename the scene.

  9. In the Quick Access Toolbar, click Save.

    Save button

    You created a global scene, but it is currently empty. In the next section, you'll start adding data to it.

Add an integrated mesh layer

In the last section, you created an empty global scene. Next, you'll add a 3D integrated mesh layer that represents the entire city of Frankfurt, Germany. That data layer is hosted on ArcGIS Online.

  1. On the ribbon, on the View tab, in the Windows group, click the Catalog Pane button.

    Catalog Pane button

    The Catalog pane appears.

  2. In the Catalog pane, select the Portal tab and select ArcGIS Online.
  3. In the Search field, type Frankfurt Integrated Mesh owner:esri__3D.

    Search for the mesh layer.

  4. In the list of results, right-click the Frankfurt Integrated Mesh scene layer, and choose Add To Current Map.

    Add the mesh layer to the current map.

    The layer is added to the scene, and the scene automatically zooms in to the extent of that layer.

    The integrated mesh layer appears on the scene.

    You'll now change the basemap so that the integrated mesh layer blends better with the entire scene.

  5. On the ribbon, on the Map tab, in the Layer group, click Basemap. Choose the Imagery basemap.

    Imagery basemap option

    Note:

    If the Imagery basemap was already selected by default, you don't need to change anything. If your organization offers a customized list of basemaps, you can choose one of your liking.

    The basemap updates. You'll now explore the integrated mesh layer in the 3D view.

  6. In the scene, above the Navigator wheel, click Show full control.

    The Navigator wheel expands to include 3D navigation functionality.

    Click the Show full control button.

  7. Use the middle Navigator wheel to tilt and rotate the scene. You can also use the mouse wheel button to zoom in and out and drag to pan.

    Middle wheel

    Note:

    To learn more about the options for 3D navigation, see Navigation in 3D.

  8. Ensure that the scene is tilted to see the data in a 3D perspective. Zoom closer to the mesh layer and pan to explore different areas of the city.

    Frankfurt old town

    Note:

    What is integrated mesh data? It is typically captured by an automated process meant to construct a real-world 3D representation out of large sets of overlapping imagery. The result integrates the original input image information as a textured mesh including 3D objects, such as buildings and trees, and elevation information.

    For example, a construction site could be captured daily by a drone flight, and the resulting data can be visualized as integrated mesh. You can use ArcGIS Drone2Map to create this type of data. Learn more about Drone2Map in the Learn ArcGIS lesson Get started with ArcGIS Drone2Map.

    Integrated mesh scene layers can also be created for citywide 3D mapping, such as in the example of the city of Frankfurt am Main in this lesson. To visualize this data in a performant way, the integrated mesh scene layer has different levels of detail (LODs). When you zoom out and increase the distance to your scene, the complexity of the 3D data is decreased as well.

  9. Press Ctrl-S to save the project.

    Your scene now contains an integrated mesh layer displaying the city of Frankfurt in great detail. In the next section, you'll add a layer representing the construction area for the new building.

Add the 2D construction area

You'll now add the construction area layer to your scene. A simple 2D polygon represents the area where the construction will take place. It is stored in a layer package and is part of the data you downloaded at the beginning of the lesson.

  1. In the Catalog pane, click the Project tab. Expand Folders and expand Frankfurt_Construction_Planning.

    Expand Folders and expand Frankfurt_Construction_Planning.

  2. Right-click ConstructionArea.lpkx and choose Add To Current Map.

    The ConstructionArea layer is added to the Contents pane under the 2D Layers category.

    ConstructionArea layer

  3. In the Contents pane, right-click the ConstructionArea layer, and choose Zoom To Layer to zoom in to the layer.

    Zoom To Layer

  4. In the scene, zoom and pan to examine the ConstructionArea polygon.

    The construction area appears in the scene.

    Because it is a 2D polygon added to a 3D scene, it is displayed draped on the Frankfurt_Mesh layer. In this case, it is displayed draped over an old building that will be demolished to make way for the new construction.

    Note:

    When an integrated mesh layer is added to a scene, it supersedes the ground and basemap of that scene in the display. Any other layers that have an elevation property set to On the ground draw on the ground as well as on the integrated mesh, which is why you are seeing the ConstructionArea polygon with this draped effect.

    You want to ensure that features such as the ConstructionArea polygon can be clicked and selected in the scene, without the mesh layer being affected and displaying a flashing effect. To optimize the user experience, you'll fine-tune the selection settings.

  5. In the Contents pane, click the List By Selection tab. Uncheck the Frankfurt_Mesh layer.

    Selection tab

    Note:

    The Selection tab allows you to specify which layers are selectable and which ones are not.

    The mesh layer is now unselectable.

  6. Click the List By Drawing Order tab to return to the Contents pane default display.

    Drawing Order tab

  7. On the ribbon, on the Map tab, in the Navigate group, click the Explore drop-down arrow. In the drop-down list, choose Selectable Layers.

    Choose the Selectable Layers menu option.

    You'll now examine the content of the informational pop-up.

  8. In the scene, click the ConstructionArea polygon to display the pop-up.
  9. Review the content of the pop-up. Under ProjectWebSite, click the web link to learn more about the construction project.

    The project website URL in the pop-up window

    The web page (in German) appears in a web browser window.

  10. When you are done reviewing the web page information, come back to ArcGIS Pro and close the pop-up.
  11. Press Ctrl+S to save the project.

    Your scene now contains the integrated mesh layer displaying the city of Frankfurt in great detail and a polygon feature representing the construction area for the new building. Next, you'll add the 3D representation of the planned building.

Add the 3D building layer

You'll now add the 3D representation of the planned building, and customize its display.

  1. In the Catalog pane, if necessary, expand Folders and expand Frankfurt_Construction_Planning.
  2. Right-click GrandCentral_V1.slpk and choose Add To Current Map.

    Add the building scene layer to the scene.

    The GrandCentral_V1 scene layer is added to the scene and to the Contents pane under the 3D Layers category. It contains the first version for the new planned building, represented as a 3D object stored in a building scene layer package. It was created from a BIM-design Revit file using the ArcGIS Pro Create building scene layer tool.

    The GrandCentral_V1 scene layer in Contents pane

    Note:

    Building information modeling (BIM) is the process of creating and managing 3D, 4D, and 5D information for a construction project across multiple disciplines. ArcGIS Pro supports BIM-design files from Autodesk Revit as a BIM file workspace.

    Building scene layers allow you to store, distribute, and analyze detailed information from construction documentation in ArcGIS. In the BIM, designers, builders, and owners generate many kinds of information about buildings throughout the life span of the building. You can use the building scene layer to capture the geometry, semantic organization, and attributes in 3D construction data for use with other GIS content.

  3. Zoom and pan to examine the GrandCentral_V1 building.
  4. Tilt the view so you can see the tower in the draft better.

    The building displayed in the scene.

    Note that the base of the building is not visible because it clashes with the old building captured in the integrated mesh layer. You will fix this issue later in the lesson.

  5. In the Contents pane, uncheck the Frankfurt_Mesh layer to turn it off and view the entire planned building.

    Entire building

    The building now displays on top of the ConstructionArea polygon, the Imagery basemap and the Terrain layer, which does not show any of the 3D structures of the city. You can now clearly see the main building's basis, as well as a smaller building on the side.

    Note:

    The construction area appears much larger than the building itself. This is because this is a multiphase project, and the first version of the design only shows the first set of buildings that will be built on this site.

  6. In the Contents pane, review the GrandCentral_V1 layer.

    The layer has two view options: Overview and Full Model. The Overview represents mostly the external shell of the building. The Full Model contains more details, and is organized in several disciplines, such as architectural, mechanical, and structural.

  7. Select the GrandCentral_V1 layer and turn the Full Model on. Expand Full Model and expand Architectural. Check the box next to Architectural to display all the architectural sub-layers.

    Expanded Full Model

    The tall building includes only the Floors and Mass elements. The smaller building contains more elements such as Walls and StairsRailing.

  8. Turn the Floors and Mass layers on and off to see how the tall building changes.
  9. Zoom in and rotate the scene to see the details of the smaller building.

    Small building close up

  10. In the Contents pane, turn the various architectural layers on and off to see the role that each one plays.
  11. Zoom back out to see the entire building set.

    To see the building in the context of the 3D mesh, you'll turn that layer back on.

  12. In the Contents pane, turn the Frankfurt_Mesh layer back on.
  13. In the Contents pane, turn on the Floors layer and turn off the Mass layer.

    The individual floors can be difficult to distinguish. You'll choose a different lighting option to improve the rendition of the Floors layer.

    Note:

    By default, the built-in geometry properties of a 3D object are used to shade it for the scene's current light position. The properties used for lighting are 3D vectors—or normals—that define the direction that each face will reflect light. The shading of each face of the 3D object is calculated from its normal. You can adjust the lighting option for a layer.

  14. In the Contents pane, click the Floors layer to select it.
  15. On the ribbon, on the Appearance tab, in the Faces group, click Lighting. In the Lighting drop-down list, choose Two-Sided Lighting Using Reset Normals to improve the rendition of the Floors layer.

    Change the lighting option.

  16. In the Contents pane, turn the Mass layer back on.
  17. Switch back to the Overview option, and make sure the Overview layer is selected.

    Switch back to Overview.

  18. Apply the same Two-Sided Lighting Using Reset Normals lighting option to the Overview layer.
  19. Collapse the GrandCentral_V1 layer.
  20. Press Ctrl+S to save the project.

You have now created a 3D scene that brings together an integrated mesh layer representing the city of Frankfurt in great detail, a polygon feature layer representing the overall construction area, and a 3D object representing the planned building. Next, you will modify the integrated mesh layer to better align it with the new building.


Modify the area surrounding the new building

The Frankfurt_Mesh layer shows the old building that currently exists on the construction site. As a result, it hides the lower part of the new building. You will modify the mesh layer, flattening it to make space for the new building. This change will happen within the scene only, and will not affect the original mesh data.

Note:

An integrated mesh scene layer can be modified in different manners depending on the use case. First, you can combine the mesh layer with planned construction such as in this lesson, flattening the existing buildings to make room for the new ones. You could show the mesh along with the local underground infrastructure, cutting holes into the mesh to visualize the pipes or other assets. Another option would be to choose to focus on a limited area of the mesh layer by masking out all other areas.

In all cases, you'll perform an integrated mesh modification, which is scene-specific and does not affect the original data. The modification's parameters are stored in the project's geodatabase. This makes it possible to create many different scenes without having to duplicate the mesh data.

Add modification to the integrated mesh layer

In this section, you'll create an integrated mesh modification based on the ConstructionArea layer, using the Replace option to flatten the area.

Note:

The modification will replace the mesh geometry with the geometry of the ConstructionArea polygon, creating a flat plateau for that area at the minimum z-value (height) on the ground.

  1. Turn the ConstructionArea layer back on to visualize its exact location.
  2. In the Contents pane, right-click the ConstructionArea layer, and choose Zoom to Layer.

    Zoom To Layer

    The view in the scene updates to display the construction area.

    Building on construction area

    It will be easier to view the modification of the mesh layer if the ConstructionArea layer is turned off.

  3. In the Contents pane, turn off the ConstructionArea layer.

    You'll now create the modification.

  4. In the Contents pane, select the Frankfurt_Mesh layer.
  5. On the ribbon, on the Data tab, in the Modification group, click Add.

    Add a modification.

  6. In the Add Modification window, choose Import from existing polygon feature layer.
  7. In the drop-down list, choose ConstructionArea. For Operation, verify that Replace is selected.

    Add Modification window

  8. Click OK.
    Note:

    The three options enable the different types of modifications. Clip allows you to cut out the integrated mesh to make the layers underneath visible. Mask allows you to hide the mesh beyond an area of interest. It can also be used to straighten the edges of the integrated mesh. Replace changes parts of an integrated mesh based on a polygon to flatten the area.

    In the Contents pane, under Frankfurt_Mesh, the new modification appears.

    Modification in the Contents pane

  9. In the scene, zoom, pan, and rotate to inspect the modification.

    Flattened area

    The portion of the mesh corresponding to the ConstructionArea polygon is flattened. It does not obstruct the view of the new planned building any longer.

  10. Press Ctrl+S to save the project.

Edit the modification polygon

In the previous section, you added the modification polygon to the integrated mesh layer. The construction area does not extend all the way to the end of the block on the east side of the building. You are asked to rectify this issue so that the end of the block is flattened too. You will edit the modification polygon using the editing tools to extend it eastward.

  1. In the scene, review the flattened area and the remaining bulging slice.

    Remaining mesh slice

    This is the mesh area you want to include in the modification.

  2. In the Contents pane, right-click the Frankfurt_Mesh _Modifications layer and select Zoom To Layer to fully see the modification area.

    You will also turn off the building to better see the entire modification polygon.

  3. In the Contents pane, uncheck the box for the GrandCentral_V1 layer to turn it off.

    Next, you'll select the modification polygon.

  4. In the Contents pane, right-click the Frankfurt_Mesh_Modifications layer, and choose Attribute Table.

    Attribute Table menu option

  5. In the attribute table, review the only row present.

    Modification row

    This is the modification polygon that you just created. You can see in the Shape attribute that the feature is of the Polygon Z type. This means it has z-values and is a 3D polygon, not just a 2D one. The minimum z-value of the polygon is defining the height of the replacement in the integrated mesh layer. Some of the other attributes, such as ProjectName, StartDate, and ProjectWebSite, are inherited from the mesh layer. Finally, the Modifier attribute indicates the type of the modification used, in this case, Replace.

  6. Click in the first column of the row to select the feature.

    Select the row.

    In the scene, the selected polygon's outline is highlighted in cyan blue.

    Selected modification polygon

  7. If necessary, adjust the size of the attribute table pane to better see the scene.

    Adjust the pane size.

  8. On the ribbon, on the Edit tab, in the Tools group, select Edit Vertices.

    Edit Vertices tool

    In the scene, the vertices of the polygon appear as green squares.

  9. Click the vertex in the lower right corner to select it, and move it just beyond the unwanted mesh slice.

    Move the first vertex.

  10. Similarly, move the upper right vertex to build an extended rectangular shape.
  11. On the edit vertices toolbar, click the Finish button to complete your sketch. Alternatively, you can press F2.

    Finish button

    The polygon updates and the flatten area extends, eliminating the unwanted slice.

  12. Zoom and pan to review the extended polygon and the extended flattened area.

    Extended polygon

    Note:

    You can repeat the edits until you have achieved the correct modification.

  13. On the ribbon, on the Edit tab, in the Manage Edits group, click Save.

    Save button on the Edit tab

  14. In the Save Edits window, click Yes to save all your edits.

    Save Edits window

  15. On the ribbon, on the Edit tab, in the Selection group, click Clear to remove the selection.

    Clear the edit selection.

  16. Close the Modify Features pane.

    Close the Modify Features pane.

  17. Close the attribute table pane.
  18. In the Contents pane, turn off the Frankfurt_Mesh_Modifications layer.

    The modification will still be applied, but the polygon itself will not be visible.

  19. Press Ctrl+S to save the project.

    Your 3D scene is now fine-tuned and almost ready to be shared with stakeholders. In the next section, you'll add bookmarks.

Add bookmarks

In the last steps, you prepared all the layers to align well. Before sharing with your audience, you will add bookmarks to make it easier to navigate the scene and find the best angles to visualize the progressing construction. First, you'll create a bookmark showing an overview of the city of Frankfurt.

  1. In the Contents pane, select the Frankfurt_Mesh layer, right-click and choose Zoom To Layer.

    The scene zooms out to see the entire city of Frankfurt.

  2. On the ribbon, on the Map tab, in the Navigate group, click Bookmarks. In the drop-down list, choose New Bookmark.

    New Bookmark menu option

  3. In the Create Bookmark window, for Name, type Frankfurt am Main overview. For Description, type Shows the entire city of Frankfurt, Germany. Click OK to create the bookmark.

    Create Bookmark window

    Next, you'll create a bookmark to show the construction area overview.

  4. In the Contents pane, turn the GrandCentral_V1 layer on.
  5. In the Contents pane, right-click the ConstructionArea layer and choose Zoom To Layer. This gives you a good overview of the construction area. Tilt the view to optimize the angle.

    Construction area overview

  6. On the ribbon, on the Map tab, click Bookmarks. In the drop-down list, choose New Bookmark.
  7. In the Create Bookmark window, for Name, type Central station construction area. For Description, type Overview of the construction area next to the central train station. Click OK to create the bookmark.
  8. On the ribbon, click Bookmarks again.

    The two new bookmarks

    You can see the two bookmarks you created.

  9. Click both bookmarks to see how they allow you to quickly navigate the scene.
  10. When you are done testing the bookmarks, click the Central station construction area bookmark, as you want to save the project with that view.
  11. Press Ctrl+S to save the project.

You have created an integrated mesh modification and edited the modification polygon to optimize the visualization of the proposed building design within the 3D scene. You then created bookmarks to improve the navigation. Your scene is now ready to be published online.


Share the 3D scene and upload a new building design

You'll now share your scene to ArcGIS Online to share with the project stakeholders. Then, you'll learn how to update the building layer to show the new design versions delivered by the architects, as the project progresses.

Publish the 3D scene

In this section, you'll publish the scene from ArcGIS Pro to ArcGIS Online to create a web scene. First, you'll rename the building layer to a more informative name.

  1. In the Contents pane, click GrandCentral_V1 to select it. Click it again to rename it, type Proposed Building Design, and press Enter.

    GrandCentral_V1 renamed to Proposed Building Design

  2. In ArcGIS Pro, at the upper right of the ribbon, look for your Sign-in Status. If it says Not signed in, click Sign in and enter your ArcGIS credentials.

    Sign in link

  3. On the ribbon, on the Share tab, in the Share As group, choose Web Scene.

    Web Scene button

    The Share As Web Scene pane appears.

  4. In the Share As Web Scene pane, on the Scene tab, choose the following values:
    • For Name, type Frankfurt Central Station followed by your initials (for instance, Frankfurt Central Station_dk).
    • For the Summary, type Proposed new building design for the central station location, Frankfurt am Main.
    • For Tags, type Frankfurt, central train station, building project. These tags will allow you and your audience to search for the new web scene more easily in your ArcGIS Online organization.
    • For Location, choose a folder of your choice in your ArcGIS account. Optionally, you can create a folder.
    • For Share with, check your organization's box to make the web scene available to everyone within your organization.
    Note:

    Adding your initials to the web layer name ensures that it remains unique, even if someone else in your ArcGIS Online organization does this same lesson.

    Share As Web Scene pane

  5. In the Share As Web Scene pane, under Finish Sharing, click Analyze.

    Analyze button

    After checking all the components of the scene you want to publish, the tool should report that No errors or warnings were found. If ever issues are found, you should resolve them before sharing the scene online.

  6. When ready, under Finish Sharing, click Share.

    Share button

    The process runs for some time. A status bar at the bottom of the pane shows progress, but you can also monitor the process in more detail.

  7. Under Finish Sharing, click Jobs.

    Jobs button

    The Job Status pane appears, and you can see the publishing status for the various scene elements. When the process is complete, a green check mark appears next to the web scene name.

    Job Status pane

  8. Close the Job Status pane.

    You'll now open the web scene in ArcGIS Online.

  9. In the Share As Web Scene pane, click the Manage the web scene link.

    Manage the web scene link

  10. If prompted, enter your ArcGIS Online credentials.

    The web scene item page opens in ArcGIS Online.

  11. On the web scene item page, click Open in Scene Viewer.

    Open in Scene Viewer

    The web scene appears in your web browser.

  12. In the scene, drag to pan.
  13. Click the Toggle to pan or rotate in 3D button to switch to the rotate mode.

    Toggle to pan or rotate in 3D

  14. Drag to rotate the scene and observe the building design and how it fits in the surrounding urban environment.
  15. If necessary, move the pointer anywhere in the scene to reveal the two bookmarks at the bottom of the browser.

    Bookmarks in the web scene

  16. Click the first bookmark. Then click the second bookmark.

    Each time, the scene updates to the bookmarked view.

    The web scene you published is easy to navigate and makes it easy for stakeholders to view the planned building design in the context of the larger urban environment.

Update the building design

The GrandCentral_V1 building design was just the first version of the project, and the architects will produce new versions on a regular basis during the entire design phase. Each time a new version comes in, you can upload it directly to the web scene to replace the previous design efficiently. You'll do that with the second building design, GrandCentral_V2. First, you'll upload the scene layer package containing that second building version to ArcGIS Online.

  1. On the ArcGIS Online web scene, click Home to expand the drop-down list and choose Content.

    Content menu option

    The Content page appears, listing all the content in your account.

  2. Under Folders, choose the folder location where your scene was published.

    The files for the web scene and all its components are listed within that folder.

    Components of the web scene

    Note:

    Because you published an entire web scene, all the layers it contains are named after that web scene and did not keep their original names. For instance, the first version of the building layer is now named Frankfurt Central Station_<Your Initials>_WSL1, instead of the original GrandCentral_V1.

  3. On the Content page, click Add item, and choose From your computer.

    Add item from your computer.

  4. In the Add an item from your computer window, click Choose File and browse to the Frankfurt_Construction_Planning folder location on your local machine.
  5. Select the GrandCentral_V2.slpk scene layer package, and click Open.

    Select the second building version.

  6. For Title, add your initials to the suggested default.
  7. For Tags, type Frankfurt, central train station, building project and press Enter.

    Add an item from your computer window

  8. Click Add Item.

    The scene layer package is uploaded to your ArcGIS Online account. You'll now share this item with your organization and use it to update the building design.

  9. On the GrandCentral_V2_<your initials> item page, click Share.

    Click Share button.

  10. In the Share window, select Organization and click Save.

    Select Organization.

  11. On the top toolbar, click Content to go back to your scene folder.

    Content button on the toolbar

    The scene layer containing the first version of the building is currently named Frankfurt Central Station_<Your Initials>_WSL1.

  12. Click the Frankfurt Central Station_<Your Initials>_WSL1 scene layer to open the item page.

    Scene layer to replace

  13. On the scene layer item page, click the Replace Layer button.

    Replace Layer button

    On the Replace Layer page, the first of three steps is Select replacement layer.

  14. For Replacement layer, click Select layer.

    Select layer button

  15. In the Select replacement layer window, in the list of layers, locate GrandCentral_V2, and click Select.

    Select GrandCentral_V2 layer.

    When the replacement layer is validated, you'll see a green check mark and the message This replacement is compatible with the current layer.

  16. In the lower right corner, click Next.

    The second step is Archive. The layer that is about to be replaced will first be archived. This way if there is an issue with the replacement, it can be undone.

  17. Turn on the Replace item information option.

    Turn on the Replace item information option.

    With the option, when the layer is replaced, the item information from the GrandCentral_V2 layer will be used (for instance, its title, description, and tags). If you kept the option off, the item information of the older building layer would be used.

  18. Click Next.

    The last step of the Replace layer process is Summary, which lists all the replacement information.

  19. Click the Replace button to complete the replacement process.
  20. On the top toolbar, click Content. In the content list, click the Frankfurt Central Station_<your initials> web scene.

    Web scene file

  21. On the web scene item page, click Open in Scene Viewer to open the web scene.
  22. If necessary, go to the bookmark Central Station Construction Area.

    The second building version appears in the web scene.

    The second version of the building design appears. You can see that it has much expanded compared to the first version.

In this lesson, you created a 3D scene showing a new construction project planned in Frankfurt, Germany. You included an integrated mesh scene layer to display the urban context of the project. You then added the construction area polygon, and a 3D representation of the planned building derived from a BIM-design file. You added a modification to the integrated mesh layer to flatten it within the construction area, and extended the modification polygon. You then shared the scene with the project's stakeholders in ArcGIS Online. Finally, you replaced the first version of the building with a second version, making the swap directly in ArcGIS Online.

You can find more lessons in the Learn ArcGIS Lesson Gallery.