Skip To Content

Create a link map

In this lesson, you're a reporter working on a story about how the refugee crisis developed over time. You're looking for patterns to help you better understand the movement of refugees, asylum seekers, and internally displaced persons when they are forcibly displaced from their homes.

To do so, you'll look at the movement of refugees using a flow map. You'll create a new Insights for ArcGIS workbook and use boundaries from ArcGIS Living Atlas of the World to enable location on a Microsoft Excel file. Then, you'll create a link map and change the settings so that the map shows the best information for your analysis.

Add data

First, you'll download a spreadsheet of population statistics compiled by the United Nations High Commissioner for Refugees (UNHCR). Then, you'll sign in to Insights and add the data to a new workbook.

  1. Download the UNHCR_1951_2017 compressed folder.
  2. Locate the downloaded file on your computer.
    Note:

    Depending on your web browser, you may have been prompted to choose the file's location before you began the download. Most browsers download to your computer's Downloads folder by default.

  3. Right-click the file and extract it to a location you can easily find, such as your Documents folder.

    The folder contains a spreadsheet. Next, you'll create a workbook in Insights for ArcGIS.

  4. Sign in to your ArcGIS organizational account.
    Note:

    If you don't have an organizational account, you can sign up for an ArcGIS free trial.

  5. Click the App Launcher button and choose Insights.

    Insights option

    Note:

    To access Insights for ArcGIS, your ArcGIS organization's administrator must grant you a license for it. If your organization does not have Insights licenses, you can sign up for a free trial.

    If this is your first time signing in to your Insights account, the Welcome to Insights window appears.

  6. If necessary, in the Welcome to Insights window, click Skip.

    The Insights home page is displayed.

  7. Click the Workbooks tab.

    The Workbooks page is displayed. Depending on your previous use of Insights, this page will display the workbooks that you already created or that were shared with you by members of your organization.

  8. Click New workbook.

    The Add To Page window appears. You'll add two datasets to your workbook: one from the Excel spreadsheet you downloaded and one from the Living Atlas.

  9. On the Data tab, click Excel or CSV.

    Excel or CSV option

  10. Click Browse my computer. Browse to and add the UNHCR_1951_2017 spreadsheet.

    The spreadsheet is added to the Selected Data pane. You can choose which of the spreadsheet's four pages to add. You'll add only the Persons of Concern table.

  11. If necessary, uncheck the other pages until only Persons of Concern.Table 1 is selected.

    Persons of Concern.Table1 selected

    This table contains data about the movement of people between countries. You'll also add a layer of countries from the Living Atlas. Later, you'll join your table to the layer to display it spatially.

  12. On the Data tab, click Living Atlas.

    Living Atlas option

    The Living Atlas contains a wide variety of authoritative data from around the world. You'll search for the layer you want.

  13. In the search bar, type Countries and press Enter.

    The search returns two results called World Countries (Generalized) by esri_dm. These layers are similar, but one has country level boundaries, whereas the other is political boundaries, meaning that some countries have been split into multiple parts and others are combined into one multipart feature.

  14. For both of the World Countries (Generalized) results, click View details.

    The description for one of the two results states that the boundaries are at the country level. This is the layer you want to add.

  15. Click the World Countries (Generalized) result with country level boundaries.

    Add World Countries (Generalized)

    The layer is added to the Selected Data pane. It only has one selectable component, World_Countries_(Generalized).

  16. Click Add.

    The datasets are added to the data pane of a new workbook. The countries are also added to a map card called Card 1. This map card doesn't contain information from the Persons of Concern table, so it's not useful. You'll remove it.

  17. Click Card 1.

    The card is activated and the card toolbar appears.

  18. Click the More button and choose the Delete button.

    Delete button

    The card is deleted.

Enable location

Next, you'll enable location on the Persons of Concern table using the layer of countries. You'll need to enable location for two fields in particular: the field that indicates country of asylum or residence (where persons of concern went) and the field that indicates country of origin (where persons of concern came from).

  1. In the data pane, click the arrow to expand Persons of Concern.Table1.

    Expanded Persons of Concern table

    The dataset includes string and number fields, but no location fields.

  2. For Persons of Concern.Table1, click the Dataset options button and choose Enable Location.

    Enable Location option

    The Enable Location pane appears.

  3. In the Enable Location pane, change the following parameters:
    • For Location type, choose Geography.
    • For Location fields, choose Country / territory of asylum/residence.
    • For Matching geography level, choose World_Countries_(Generalized) (the Living Atlas layer).

    Enable Location pane

    The Estimated match accuracy provides a visualization of how many rows in the table can be successfully joined to the geography layer. In this case, every row in the Country / territory of asylum/residence field has a match.

  4. Click Run.

    A location field called World_Countries_(Generalized) is added to the table.

  5. Point to the World_Countries_(Generalized) field and click the Rename Field button. Rename the field Country of residence and press Enter.

    Renamed field

  6. For the Country of residence field, click the Display field button and choose Country.

    Choose Display Field for the Country of residence field

    The country name will be displayed in pop-ups when the location field is used. You've enabled location for the field that indicates where refugees and asylum seekers currently reside. Next, you'll enable a location field that indicates their country of origin.

  7. For Persons of Concern.Table1, click the Dataset options button and choose Enable Location.
  8. In the Enable Location pane, change the following parameters:
    • For Location type, choose Geography.
    • For Location fields, choose Origin.
    • For Matching geography level, choose World_Countries_(Generalized).
  9. Click Run.

    The new field is added. Like the previous field, this one has a default name of World_Countries_(Generalized).

  10. Rename the World_Countries_(Generalized) field to Country of origin.

    The table now has two location fields, one for country of origin and one for country of residence.

  11. For the Country of origin location field, click the Display field button and choose Country.

    Choose Display Field for the Country of origin field

    The country name will be displayed in pop-ups when the location field is used. Next, you'll rename and save the workbook.

  12. On the ribbon, click Untitled Workbook, type UNHCR Population Statistics, and press Enter.
  13. On the workbook toolbar, click the Save button.

    Save button

Create a link map

Link maps focus on relationships and connections in a dataset. They use nodes and lines or arrows to display relationships between locations. You'll create a link map in which the nodes are country of origin and country of residence and the links are the total number of persons of concern moving between them.

  1. In the data pane, click the Country of origin field to select it. Press Ctrl and click the Country of residence and Total Population fields to select them.
    Note:

    Make sure to select the fields in the order listed in the instruction, not the order they appear in the data pane.

    Selected fields

    The Total Population field is the sum of all persons of concern, including refugees, asylum seekers, returned refugees, internally displaced persons, returned internally displaced persons, and stateless persons.

  2. Drag the fields to the page and drop them in the Map drop zone.

    Fields dragged to Map drop zone

    All selected fields are added at once.

    Tip:

    You can also click the Map button above the data pane to create the link map.

    A link map is created with nodes representing countries and links representing the number of persons of concern that have moved between the countries. In this case, the map uses arrows to show the direction of the movement of migrants. Link maps with directional relationships are called flow maps. Next, you'll change the map's settings so that it displays the information more effectively.

  3. On the map card, next to the Persons of Concern.Table1 layer name, click the arrow button.

    The Layer options pane appears. This pane shows an arrow pointing from the country of origin to the country of residence, as well as several parameters.

    Layer options pane

    Note:

    If the fields were selected in the incorrect order, the arrow may point in the opposite direction (from country of residence to country of origin). To change the direction, click the link (the arrow between the two nodes) and click the Flip button.

    The nodes, which represent the countries of origin and the countries of residence, are sized by graduated symbols using a method called centrality. The default centrality is measured by outdegree (the centrality measure is displayed in the Layer options pane, in the Options tab, under the Graph options parameter.)

    The outdegree refers to the number of outgoing links a country has. A country whose refugees settle in many different countries will have a larger symbol than countries whose refugees leave to settle in one or two countries. The outdegree does not specify how many people are leaving a country, only how many outgoing links the country has.

  4. In the Layer options pane, for Size nodes using, choose Indegree.

    Size nodes using parameter

    The Indegree option refers to the number of countries from which a country accepts refugees and asylum seekers. A country that accepts refugees and asylum seekers from many countries will have a larger node than a country that accepts refugees and asylum seekers from one or two countries. The node size does not refer to the number of persons of concern in the country of residence. The indegree will be useful for your story because it provides information about which countries have asylum seekers from across the world.

    Next, you'll change the style of the nodes so that they are easier to interpret.

  5. In the Layer options pane, click the Country of origin node to select it. Click the Style tab.

    Style tab for the nodes

    Note:

    Since both location fields are based on countries, the nodes are styled using the same symbol by default. The style of both nodes will be changed even if only one node is selected.

  6. For Fill color, choose no fill.

    Change the nodes to no fill

  7. For Outline color, choose the purple color in the second row, second-to-last column (hex value #DF73FF).

    Change the node outline to purple

  8. Change the Outline thickness to 1.5 px.

    Node style changed

    Next, you'll change the links to a lighter color.

  9. In the Layer options pane, click the link (arrow) to select it. If necessary, click the Style tab.

    Style tab for the link

  10. For Color, choose the gray color in the first row, second column (hex value #858585).
  11. Close the Layer options pane.

    Lastly, you'll change the basemap. The link map is meant to highlight the relationships between nodes, so you'll choose a basemap with a muted background.

  12. On the workbook header, click the Basemaps button and choose Light Gray Canvas.

    Basemaps button

  13. Click a blank area on the page to deactivate your map card.

    The map card's title, Card 1, is displayed in place of the card toolbar.

  14. Click the Card 1 text, type Migration of persons of concern, and press Enter.

    Renamed link map

  15. Save your workbook.

In this lesson, you enabled location on a nonspatial dataset and used the data to create a flow map, which shows the movement of persons of concern from their country of origin to their country of residence. In the next lesson, you'll create supplemental charts and tables that will give you more insight into the data.