Prepare raster data

You will access an ArcGIS Pro project package that contains thematic rasters for each island in Hawaii and create a single mosaic dataset from them. This mosaic dataset sets the stage for other capabilities by becoming a container for all the rasters. From the mosaic dataset, you will serve a single, logical layer with which your users can interact. This will spare users the trouble of interacting with each of the rasters individually. The thematic rasters come in a .tif format. Each 8-bit TIFF image has values made up of integers, and each integer value corresponds to a land cover class on Hawaii. The mosaic dataset will allow you to serve these eight TIFF images, one for each major island in the Hawaiian Islands, in a service that behaves like one layer.

In this module, you will first download the project package that is hosted in ArcGIS Online. Once you access the project, you will explore the raster datasets before you create the mosaic.

Download project data

Before you can explore the images for Hawaii, you will download an ArcGIS Pro project package that contains the data.

  1. Click Hawaii Rasters to download the project package item.
  2. Once the download completes, move the project package from the Downloads folder to a location on your computer that you will remember for use in the lesson.
  3. Double-click the Hawaii Rasters project package to open it in ArcGIS Pro.
  4. Sign in to your ArcGIS organizational account or into ArcGIS Enterprise using a named user account.
    Note:

    If you don't have an organizational account, you can sign up for an ArcGIS free trial.

  5. Explore the project map and Contents pane.

    Map opens showing Hawaiian islands.

    The project contains eight individual raster layers, each representing a Hawaiian island. The Contents pane displays the layers and their legends.

    Raster layers in Contents pane

    Seven of the layers are displayed using stretched symbology, while the kahoolawe.tif file is displayed as a colormap.

  6. In the Contents pane, right-click kahoolawe.tif and choose Zoom To Layer.

    Zoom To Layer option

    The map zooms to Kahoolawe.

  7. On the ribbon, on the Map tab, in the Navigate group, click Explore.

    Explore tool

  8. Use the mouse wheel button to zoom out so that you can see some of the surrounding islands.

    Islands shown using different symbology

    Visually, the kahoolawe.tif layer is different than the other layers in the project because it uses a color map to symbolize the raster. There may be other properties for this layer that are different that you cannot notice by viewing the layer, so you will dig deeper in the layer properties.

You have downloaded an ArcGIS Pro project package that contains the rasters that you will use in your image layer. Next, you will explore the properties to verify that all images have the same properties.

Explore and set raster properties

Individual rasters going into a mosaic dataset must have almost all the same properties to perform well together as a single, logical layer. In this case, you do not want to create a mosaic dataset where one of the rasters is symbolized differently. You will also set some other properties of the rasters before you create the mosaic dataset. For this example, you do not have to modify properties for all eight layers, but only for the smallest layer, for the smallest island of Kahoolawe. It is good practice to spend the time before you create the mosaic dataset to make sure that all the rasters will look and perform optimally, in whichever app they are added to.

  1. In the Catalog pane, expand Folders, HawaiiRasters0, commondata, and raster_data.
    Tip:

    To open the Catalog pane, click the View tab and in the Windows group, click Catalog Pane.

    Rasters shown in Catalog pane

    The rasters shown in the folder are the same ones that are displayed in the map. Next, you will explore the properties for one of the stretched rasters and then for kahoolawe.tif.

  2. In the Catalog pane, right-click hawaii.tif and choose Properties.

    Open the Properties for hawaii.tif

    The Raster Dataset Properties window appears.

    Before creating the mosaic dataset, you will explore the properties of the stretched rasters so that you can better identify properties in the colormap raster that are different. You are only exploring the properties for one of the stretched rasters, but they are all the same.

  3. In the Raster Dataset Properties window, scroll through and explore the following properties:
    • Number of Bands
    • Source Type
    • Pixel Type
    • Pixel Depth
    • NoData Value
    • Pyramids
    • Projected Coordinate System
    • Statistics

    Properties for hawaii.tif

    The hawaii.tif has the following values for its properties:

    • Number of Bands1
    • Source TypeThematic
    • Pixel Type and Depthunsigned char
    • NoData Value0
    • Projected Coordinate System:—NAD_1983_Contiguous_USA_Albers

    It also has values for Pyramids and Statistics.

  4. Close the Raster Dataset Properties window.

    Next, you will explore the properties for the one colormap raster to see if they are the same as the other rasters.

  5. In the Catalog pane, right-click kahoolawe.tif, and choose Properties.
  6. In the Raster Dataset Properties window, under the Raster Information section, locate the Number of Bands property.

    Number of Bands property

    The raster has the same number of bands as the others. Next, you will check the Source Type.

  7. Scroll down and locate Source Type.

    Source Type property set to Generic

    The Source Type for kahoolawe.tif is Generic, yet land cover is a Thematic data type. It is important to make sure that your rasters are all Thematic before you create the mosaic dataset. You can change the type from here.

  8. For Source Type, in the Value column, click Generic and choose Thematic.

    Choose Thematic for the Source Type.

    Note:

    The thematic raster data type is used to represent features represented by classes, such as land cover or soil type. Setting the data type to thematic helps map clients render the data properly.

    Next, you will verify the pixel type and depth.

  9. Under Source Type, locate Pixel Type and Pixel Depth.

    Pixel Type and Pixel Depth properties

    The pixel parameters match those of the other rasters.

  10. Under Pixel Depth, locate NoData Value.

    NoData value of 255

    The NoData Value for this raster is 255, while the other rasters use a value of 0. You will change the NoData Value to 0 so that it matches the other rasters.

  11. For NoData Value, in the Value column, click the edit button.

    Edit NoData Value

    The NoData Editor window appears.

  12. In the NoData Editor window, for NoData value, replace 255 with 0.

    Change the NoData value to 0.

  13. Click OK.

    The next property you will explore is Pyramids. Pyramids are used when creating overviews in the mosaic and allow for faster display of rasters by creating reduced resolution datasets that are used at smaller scales.

  14. Next to Pyramids, verify that it says level: 6, resampling: Nearest Neighbor, which is slightly the same as the other rasters.

    Pyramids for the raster dataset

    Next, you will see if statistics are calculated for the raster. You will verify that the statistics are of the range you were expecting given this dataset: CCAP land cover data has values that range between 0 and 22, or close to that range. If the statistics show a significantly different minimum and maximum, this is an indicator that something may be wrong with your dataset and it may not be ready to go into the mosaic.

  15. Scroll down and expand Statistics.

    Statistics values

    Statistics have been calculated for this raster and they are similar enough to the others to proceed with creating the mosaic dataset. If there are no values in the Statistics section, you should calculate them.

  16. Expand Spatial Reference and verify that the Projected Coordinate System is NAD_1983_Contiguous_USA_Albers.

    This is the same coordinate system as the other rasters. CCAP data are all in Albers North America projection, which is why Hawaii appears tilted on its side. The mosaic's projection will be Web Mercator, so Hawaii will appear in maps north up.

    Note:

    While all the rasters that you will use in the mosaic dataset have the same coordinate system, this is not a requirement. You can serve rasters that start in different projections, because the mosaic dataset will arrange them in maps in a projection you specify. In general, it is not desirable to reproject the images to agree with the mosaic dataset's output projection. This is because in analysis, each dataset in the mosaic projects from the source projection of the individual raster to the output projection of the ArcGIS Pro map that it is in, completely bypassing the mosaic's output projection. To maintain the integrity of the original data, you want the source data to be close to or the same as the projection in which the data was produced so that your customers can have the most accurate analysis results.

  17. In the Raster Dataset Properties window, click OK.

You have verified several properties and modified some to match the other rasters. Next, you will use geoprocessing tools to delete unnecessary components of the kahoolawe raster.

Delete attribute table and colormap

Rasters work best for mosaic datasets when they are added as raw datasets. Attribute tables and colormaps may cause the mosaic to receive unwanted default information from the raster, which can cause issues with the mosaic. Next, you will check to see if the rasters have attribute tables and delete them.

  1. In the Contents pane, right-click kauai.tif to open the context menu.

    Attribute Table option unavailable

    The Attribute Table option is unavailable, which indicates that no table exists. Next, you will check kahoolawe.tif for an attribute table.

  2. In the Contents pane, right-click kahoolawe.tif.

    Attribute Table option available

    Because Attribute Table is available in the menu, you have confirmed that this layer has a table. Next, you will delete the table so all rasters in the mosaic do not have tables.

  3. Close the attribute table.
  4. On the ribbon, click the Analysis tab. In the Geoprocessing group, click Tools.

    Tools button

  5. In the Geoprocessing pane, in the search bar, type delete raster and press Enter. Click the Delete Raster Attribute Table tool to open it.

    Delete Raster Attribute Table tool

  6. In the Delete Raster Attribute Table tool, for Input Raster, click the down arrow, choose kahoolawe.tif and click Run.
  7. In the Contents pane, right-click kahoolawe.tif and verify that Attribute Table is unavailable.

    It is also recommended that you remove colormaps from the rasters before adding them to the mosaic. To do this, you will use another geoprocessing tool.

  8. In the Geoprocessing pane, click the back arrow.
  9. Replace the existing search text with delete colormap, press Enter and open the Delete Colormap tool.
  10. In the Delete Colormap tool, for Input Raster, click the down arrow and choose kahoolawe.tif and click Run.

    The colormap is removed and the symbology for kahoolawe.tif updates in the Contents pane.

    Colormap raster is now stretched

  11. On the Quick Access Toolbar, click Save.
    Save the project
    Note:

    A message may appear warning you that saving this project file with the current ArcGIS Pro version will prevent you from opening it again in an earlier version. If you see this message, click Yes to proceed.

You have explored the rasters that you will include in the mosaic dataset and changed several properties, deleted an attribute table and deleted a color map. Now all the properties for the eight rasters match and you can create the mosaic dataset that you will share.


Create a mosaic dataset

Mosaic datasets are containers used to manage, display, and share raster data. Mosaic datasets can contain many rasters that are adjoining or disjointed, from which you create a single, logical image layer. There are special properties to a mosaic dataset, such as footprints, a boundary, rules for dynamic display and several others. These properties can be set to maximize the versatility of the collection of images added to the dataset.

Ideally, you want to set up the mosaic dataset on the computer that is running ArcGIS Image Server. You may have a virtual machine or can use a remote desktop connection to access the server. Once you access the server, you should contact your system administrator to verify where you can create the folders to stage the data. Once the data is staged, you can create the mosaic dataset on the server just as you would on your local machine.

If you do not have access to a computer with ArcGIS Image Server on it, you can still create the staging folders and a working mosaic dataset on your desktop computer. You can still complete everything in this lesson, except for publishing the layer as a service.

Stage the mosaic dataset

You will organize, or stage, the data that will make up your mosaic dataset in specific folders, either on the server or local computer. If you are planning to stage the mosaic dataset on a server, you should find out from your system administrator where you may stage your data. In this example, you will create a folder on the C drive to store the various components of your data.

  1. If you have a computer running ArcGIS Image Server, connect to it and open File Explorer. If you do not have a server machine running ArcGIS Image Server, open File Explorer locally.
    Note:

    The steps are the same whether you are using your local computer or a remote desktop connection into a computer running ArcGIS Image Server. The only difference is that you will not be able to share your image layer.

  2. Download Hawaii_CCAP_Land_Cover.zip.

    The Hawaii_CCAP_Land_Cover .zip file contains all the data that you will use. You will copy the Hawaii_CCAP_Land_Cover folder to a folder on your C drive.

  3. In the Downloads folder, extract the Hawaii_CCAP_Land_Cover.zip double-click the Hawaii_CCAP_Land_Cover folder to view its contents.

    Contents of zip file

    The Mosaic folder contains an empty geodatabase for you to store the mosaic dataset. The Attribute_table folder contains a geodatabase with a table that you will use to apply descriptive symbology to the mosaic dataset. The Rasters folder contains all the Hawaii rasters that you worked with previously. The rasters in this folder are in the same state as the rasters would be after completing the previous module.

  4. Click the back to view the Hawaii_CCAP_Land_Cover folder. Right-click the Hawaii_CCAP_Land_Cover folder and choose Copy.
  5. In the C drive, create a folder called Data.
  6. Right-click the Data folder and choose Paste.

    The contents of the .zip file are now in the staging location.

Now that you have the data that you need in the proper location, you will create the mosaic dataset.

Create the mosaic dataset

The data is organized and staged on the server or local computer. Next, you will use a geoprocessing tool in ArcGIS Pro to create a mosaic dataset that contains all eight rasters.

  1. Restore the ArcGIS Pro session that contains the project you worked with earlier.
  2. On the ribbon, click the Insert tab.

    Insert tab on ribbon

    You will add another map to the existing project to display your mosaic dataset once it is created.

  3. On the Insert tab, in the Project group, click New Map.

    New Map button

    A blank map appears with World Topographic Map displayed.

  4. In the Contents pane, click the text Map one time to select it and click it again to make it editable.
  5. Type Mosaic Dataset as the map name and press Enter.

    Rename map to Mosaic Dataset

    Next, you will make a folder connection to the folder that contains your rasters and empty geodatabases.

  6. In the Catalog pane, right-click Folders and choose Add Folder Connection.

    Add Folder Connection

  7. Browse to C:\Data, click Hawaii_CCAP_Land_Cover and click OK.
  8. In the Catalog pane, expand Folders, expand Hawaii_CCAP_Land_Cover and expand Rasters.

    Hawaii rasters in the Rasters folder

    The rasters for each Hawaiian island are staged in the Rasters folder.

  9. If necessary, on the ribbon, click the Analysis tab. In the Geoprocessing group, click Tools to open the Geoprocessing pane.

    From the Geoprocessing pane, you can access hundreds of analyses and data management tools from their toolbox or by searching for them by name. You will search for the Create Mosaic Dataset tool by typing it into the search field.

  10. In the Geoprocessing pane, in the search field, type create mosaic.

    Search for the Create Mosaic Dataset tool

  11. In the search results, click Create Mosaic Dataset to open the tool.
  12. In the Create Mosaic Dataset tool, set the following:
    • For Output Location, click the Browse button and browse to C:\Data\Hawaii_CCAP_Land_Cover\Mosaic. Click mosaic.gdb and click OK.
    • For Mosaic Dataset Name, type Hawaii_CCAP_Land_Cover.
  13. For Coordinate System, click the Select coordinate system button.
  14. In the Coordinate System window, in the search field, type web mercator and press Enter.
  15. Expand Projected Coordinate System, expand World and click WGS 1984 Web Mercator (auxiliary sphere).

    Select the Web Mercator coordinate system

    For the Projected Coordinate System, you will use Web Mercator, which is the default and most used projection for web mapping in ArcGIS Online. When someone accesses and uses a Web Mercator layer for analysis, the layer will be projected from the original datasets into the projection of the analysis. Choosing a web-friendly projection for the mosaic will not require an additional projection step, which would degrade the analysis results. Further, you want to match the Web Mercator projection that NOAA uses in their story.

  16. Click OK.
  17. In the Create Mosaic Dataset tool, expand Pixel Properties. For Number of Bands, type 1 and for Pixel Type, choose 8-bit unsigned.
    Note:

    The values you set in Pixel Properties match the values of the rasters you will add to this mosaic dataset.

    All the parameters are set and the tool is ready to run.

    Create Mosaic Dataset parameters

  18. Click Run.

    The Hawaii_CCAP_Land_Cover layer is added to the Contents pane.

    Mosaic dataset created and added to the Contents pane

    The empty mosaic dataset is added to the Contents pane as a group layer, containing sublayers named Boundary, Footprint and Image.

You have created the container for your rasters that has matching properties of your data and are ready to configure the mosaic dataset and add the rasters to it.


Configure and share an image layer

You have created the mosaic dataset and you will configure its properties and add images to it before you serve your image layer. Your mosaic dataset will contain all eight images making up the Hawaiian Islands. You will add overviews to the mosaic so that the images in the layer draw quickly at all scales and add an attribute table so that the layer serves attributes with the rasters.

If you do not have access to a server that is running ArcGIS Image Server, you can perform these steps on your local desktop machine and ArcGIS Pro; the workflow is the same except for publishing a service at the end.

Set up and populate a mosaic dataset

You will set several properties on the mosaic before you add images to it so that it serves your images properly.

  1. Close the Geoprocessing pane. View the Catalog pane.
  2. In the Catalog pane, if necessary, expand Folders, expand Hawaii_CCAP_Land_Cover, expand Mosaic and expand mosaic.gdb.

    The mosaic.gdb contains the Hawaii_CCAP_Land_Cover mosaic dataset.

    Mosaic dataset shown in geodatabase

    The mosaic dataset is stored in the geodatabase that you specified. From here, you can set properties and add rasters to it.

  3. Right-click Hawaii_CCAP_Land_Cover and choose Properties.

    The source type for the rasters you will add to the mosaic dataset is thematic, so you will set the mosaic dataset’s source type to match.

  4. In the Raster Information section, for Source Type, click its current value of Generic and choose Thematic.

    Set the Source Type to Thematic

  5. Verify that the Pixel Type and Pixel Depth of the mosaic match the rasters that you will add to it; unsigned char and 8 Bit.

    Pixel Type and Pixel Depth properties

  6. For NoData Value, click the edit button.

    The mosaic dataset does not have a NoData Value. You will set a value of 0 to match the other rasters.

  7. In the NoData Editor, for NoData Value, type 0, and click OK.
  8. In the Mosaic Dataset Properties window, click the Defaults tab.

    You will set the Maximum Size of Requests – Rows and Maximum Size of Requests – Columns properties to optimize performance of your image layer. When setting these properties, there is a balance between versatility and performance. If the maximum size is too small, users will not be able to get a big enough piece of the service at one time to do important work. If the maximum size is too large, it will impact the service performance. Values set at 30000 rows and 30000 columns struck a good balance between these trade-offs.

  9. Under Image Properties, set Maximum Size of Requests – Rows and Maximum Size of Requests – Columns to 30000.

    Maximum and minimum values for rows and columns

    Note:

    The values for Maximum Size of Requests – Rows and Maximum Size of Requests – Columns were discovered by testing the service once it was created.

  10. For Allowed Compression Methods, click the edit button.

    The Configure Allow List window appears.

    LERC and JPEG compression methods are lossy, which is not appropriate for thematic data.

    Note:

    Lossy compression is a method of data compression in which the size of the file is reduced by eliminating data in the file. In doing so, image quality is sacrificed to decrease file size. Any data that the compression algorithm deems expendable is removed from the image, thereby reducing its size. See Compression (Environment setting) to learn more.

    You will change the allowed and default compression type to LZ77.

  11. Uncheck the boxes next to JPEG and LERC, leave LZ77 and None checked, and for the Default Method, choose LZ77.

    Setting allowed and default compression methods

  12. Click OK.

    Next, you will set the resampling method to Nearest Neighbor for optimal interpolation. Other resample methods will interpolate data values at coarser scales, which is not appropriate for thematic datasets.

  13. For Default Resampling Method, in the Value column, click the down arrow and choose Nearest Neighbor (for discrete data).

    Setting the Default Resampling Method to Nearest Neighbor.

    Finally, you will set Download Properties to control downloads of your image layer. CCAP data is public domain, so you can, optionally, allow downloads. However, for some datasets, agreements and usage rights forbid granting your users rights to download the source material. For this example, you will not allow downloads of your image layer.

  14. Scroll to the bottom of the dialog box and if necessary, expand Download Properties.
  15. For Maximum number of items downloadable per request, type 0.

    Set the number of downloads allowed

  16. Click OK.

    Now that you have set the necessary properties for the mosaic dataset, you are ready to add the Hawaii rasters.

  17. In the Catalog pane, right-click the Hawaii_CCAP_Land_Cover mosaic dataset and choose Add Rasters.

    Add Rasters to the mosaic dataset

    The Add Rasters To Mosaic Dataset tool pane appears with some parameters already entered. The Mosaic Dataset parameter is set because you right-clicked the Hawaii_CCAP_Land_Cover mosaic dataset. You will accept all default parameters, but you must set the Input Data parameter to your Hawaii rasters.

  18. In the Add Rasters To Mosaic Dataset tool, for Input Data, click the down arrow and choose Dataset and click Browse.

    Choose data type and browse to rasters.

  19. In the Input Data window, under Project, click Folders, and expand Hawaii_CCAP_Land_Cover and expand Rasters.

    Browse to folder with Hawaii rasters

  20. In the Rasters folder, click one of the raster files and press Ctrl+A to select all the rasters and click OK.

    Parameters for Add Rasters To Mosaic Dataset tool

    The tool is ready to run and populate your mosaic dataset.

  21. Click Run.
  22. In the Catalog pane, right-click the Hawaii_CCAP_Land_Cover mosaic, point to Modify, choose Build Item Pyramids and Statistics.

    The Build Pyramids and Statistics tool pane appears.

  23. In the Build Pyramids and Statistics tool, click Run.

    Pyramids and statistics are now built in the mosaic

You have set properties for the mosaic dataset to match the properties of the input rasters, added the rasters to the mosaic dataset, and built pyramids and statistics for the dataset. Next, you will create overviews for the images.

Create overview images

Overviews are reduced resolution images a mosaic dataset uses to draw your layer at small scales. The use of overviews improves response to users when they pan and zoom in your online maps. You may be tempted to go with the defaults, but just a few extra tweaks to the footprint table will optimize your layer for drawing at all levels.

  1. On the map, zoom in and out to see how the rasters display at different scales to optimize performance.

    Mosaic dataset displayed in map

    Notice that the map is oriented correctly now as the data is displayed using the Web Mercator coordinate system. Also, notice that as you zoom in and out, different rasters within the mosaic display and that all rasters do not display at the same time. This display issue is not desirable for this image layer as it should display all the islands of Hawaii at all scales.

  2. In the Contents pane, right-click Hawaii_CCAP_Land_Cover, point to Open Table, and choose Attribute Table.

    The mosaic dataset attribute table appears.

    Mosaic dataset attribute table

    The mosaic dataset attribute table is a special attribute table, shown by default for mosaic datasets. The table contains properties of the behavior of individual images in the table and has nothing to do with the content within the images.

    You will standardize the behavior of the images in the mosaic dataset by altering some of the parameters in the mosaic dataset attribute table. You want all of the images to turn on and off at the same time, and when the user zooms, you want the overview images to turn on and off smoothly and at an optimal scale. You will alter the MaxPS and HighPS values to be that of the highest value in the field. Once completed, you will see all overviews at the same scale. You will use the Field Calculator to expedite the operation.

  3. In the table, right-click the MaxPS field and choose Calculate Field.

    Calculate Field option

  4. In the Calculate Field window, under Expression, for MaxPS =, type 768.

    Enter value of 768 for MaxPS field.

  5. Click OK.

    Now each raster has the same MaxPS value, which will allow them to draw together.

    MaxPS field calculated to 768

    The next modification you will make is to the HighPS field. The LowPS and HighPS values are extracted from the source rasters and used to define the range of pixel sizes that the raster dataset contains. You will calculate the HighPS field to the highest value of 76.8.

  6. In the attribute table, right-click the HighPS field, and choose Calculate Field.
  7. In the Calculate Field window, under Expression , for HighPS =, type 76.8, and click OK.

    Now each raster has the same HighPS value.

    HighPS field calculated to 76.8

  8. Close the table.
  9. In the Catalog pane, right-click the Hawaii_CCAP_Land_Cover mosaic dataset, point to Optimize and choose Define Overviews.

    The Define Overviews tool pane appears.

  10. In the Define Overviews pane, expand Overview Tile Parameters and for Pixel Size, type 768. For Number Of Levels, type 4.

    Pixel Size and Number Of Levels parameters

  11. Click Run.

    Now, no matter the scale, all the rasters in the mosaic dataset display at the same time.

    All rasters display at same scale

    This will be a better experience for consumers of your image service as users will see all the islands at once, rather than having a choppy display of only several islands at a time. Next, you will build overviews and analyze the mosaic dataset.

  12. In the Catalog pane, right-click the Hawaii_CCAP_Land_Cover mosaic dataset, point to Optimize, choose Build Overviews. In the Build Overviews pane that appears, click Run.

    The overviews display in the map.

    Overviews displayed in map

  13. In the Catalog pane, right-click the Hawaii_CCAP_Land_Cover mosaic dataset, point to Optimize and choose Analyze Mosaic Dataset.

    The Analyze Mosaic Dataset pane appears.

  14. In the Analyze Mosaic Dataset pane, for Checks performed (optional), check all the options.

    Analyze Mosaic Dataset tool parameters

    You do not expect any errors but may see some warnings. Warnings inform you of something in your data that is different from normal but will not cause problems. It is good practice to analyze your mosaic datasets so you can locate problems and correct any issues before proceeding to the next phase.

  15. Click Analyze.

    There are some warnings and unresolved items that you can ignore for this example.

  16. Close the Analyze Mosaic Dataset tool.

Now, it is time to add a function to your mosaic dataset, which will serve an attribute table for the layer.

Prepare mosaic dataset to serve attributes

Thematic raster layers served from a mosaic are more useful when they are delivered with an attribute table that describes the information in the layer. Attribute tables reveal information to users in web maps about where they clicked in the image layer. Also, when a user copies a portion of an image layer in ArcGIS Pro, the copy of the layer is saved with an attribute table.

Anything you would find in an ordinary raster attribute table can be delivered with the whole layer by use of an attribute table function. Aside from providing descriptive information about the data, the attribute table also is the source for the colors displayed on the map, and of the classes in the legend.

Attributes cannot be served from the individual rasters that are loaded into the mosaic dataset. To serve your layer with attributes, you must create a table that includes some required fields and serve it using the attribute table function from the mosaic dataset. For this example, the table that you downloaded is populated with the required fields and attributes.

  1. In the Catalog pane, right-click the Hawaii_CCAP_Land_Cover mosaic and choose Manage Processing Templates.

    The Manage Processing Templates pane appears.

  2. In the Manage Processing Templates pane, click options and choose Create New Template.

    Create New Template option

    The Raster Functions and Raster Function Template 1 panes appear.

  3. In the Raster Functions pane, in the search field, type attribute table. Click the Attribute Table function to open it.

    Search for attribute table function

    The Attribute Table Properties pane appears.

  4. On the Parameters tab, for Raster, choose Hawaii_CCAP_Land_Cover.
  5. For Table Type, verify that it is set to External and click the Browse button.

    Add input table

  6. At the bottom of the Input Table window that appears, click the down arrow and choose Tables (All Types).

    Select Tables (all types) for browsing.

  7. Under Project, click Folders, expand Hawaii_CCAP_Land_Cover, expand Attribute_tables, expand attribute_table.gdb.

    Folder location for attribute table

  8. Click Hawaii_CCAP_Land_Cover and click OK.

    The Attribute Table Properties function parameters are now set.

    Next, you will enter some descriptive information in the General tab.

  9. Click the General tab.
  10. For Name, type CCAP Land Use for Hawaii.
  11. For Description, copy and paste Attribute table containing land use symbols and popup text for CCAP Land Use.

    General properties

  12. For Output Pixel Type, choose 8 Bit Unsigned.
  13. Click the arrow for Create new layer and choose Save As.

    Save as option for new layer

    The Save As window appears.

  14. In the Save As window, for Name, type CCAP Land Use for Hawaii.
  15. For Description, type Attribute table containing land use symbols and popup text for CCAP Land Use.

    Properties for output

  16. Click OK and close the Raster Functions pane.

    Next, you will add the processing template you just created.

  17. In the Manage Processing Templates pane, click Import.

    Import a processing template

  18. In the Select Processing Templates window that appears, double-click Custom, double-click Custom1 and double-click CCAP Land Use for Hawaii.rft.xml.

    In the Manage Processing Templates pane, a template called CCAP Land Use for Hawaii appears.

    Processing template added

    Now that you have created the processing template, you will set it as the default template.

  19. In the Templates section, click Set as Default.

    Set as Default button

    Now that your template is the default processing template, it is moved to the Default Template section.

    Default template set

  20. Close the Manage Processing Templates pane, and the Raster Function Template 1 pane below the map.

    When added to a map, the mosaic is now symbolized with the colors in values red, green, blue, and opacity from the attribute table, thus making it a more descriptive and visually appealing layer.

    Rasters symbolized in map

    In the Contents pane, the legend for the Image layer displays the symbology that is provided by the attribute table you added.

    Symbolized legend for the Image layer

  21. Save your project.

You have done a lot of work on your mosaic dataset to set its properties, add rasters, and add an attribute table so it displays with descriptive and aesthetically pleasing symbology. Your mosaic dataset is now ready to share.

Publish and consume image service

At this point, you are ready to share your mosaic dataset to your virtual machine that has ArcGIS Image Server on it. If you do not have access to a virtual machine and ArcGIS Image Server, you will skip the sharing steps, although it is good to read through them to get an idea of the workflow.

Note:

You can only share your image layer if you have a virtual machine with ArcGIS Image Server set up on it. If you do not have the server, read through the workflow and pick back up with the exercise on step 9. An image service has been created and shared for you and is identical to the one you built.

  1. In the Catalog pane, right-click the Hawaii_CCAP_Land_Cover mosaic dataset and choose Share As Web Layer.

    Share As Web Layer

    The Share As Web Layer pane appears.

  2. In the Share As Web Layer pane, enter the following parameters:
    • For Name, accept the default of Hawaii_CCAP_Land_Cover.
    • For Summary, copy this text and paste it into the Summary field: Image layer containing land use for all Hawaiian islands.
    • For Tags, type Hawaii and press Tab.
  3. Add the following tags, pressing Tab after each entry:
    • Land use
    • Land cover
    • CCAP
    • NOAA
  4. For Layer and Data Type, verify that Reference registered data is chosen.

    Reference registered data selected

    When sharing data in the cloud, you can share the location of your cloud data store connection (.acs) file with a federated server by registering a data store in ArcGIS Pro, registering a cloud store in ArcGIS Server Manager, or by registering your cloud location as a data store item in the ArcGIS Enterprise portal. Referencing your data in one of these ways allows the data to exist in one place without making duplicates. You can also copy all the data from the cloud and have it uploaded to the server machine. For this example, you will reference the registered data.

    Note:

    See your GIS system administrator for help on creating a place to publish to localhost on the virtual machine.

  5. Under Location, for Server and Folder, copy and paste the following URL:

    https://localhost:6443/arcgis/admin

  6. Click Publish.

    Now that you have shared an image service to your portal, you will add it to ArcGIS Pro. If you did not share the image service, you will add one that has already been shared for you.

  7. On the ribbon, on the Insert tab, click New Map.
  8. On the ribbon, on the Map tab, click the down arrow for Add Data and choose Data From Path.

    Add Data From Path

  9. On the Add Data From Path window, based on if you shared your own service or are using the one provided, enter the appropriate path:
    • If you shared your own image service, copy and paste the following text into the Path field: https://localhost:6443/arcgis/admin
    • If you do not have a virtual machine and did not share an image service, copy and paste the following text into the Path field: https://landscape10.arcgis.com/arcgis/rest/services/Hawaii_CCAP_Land_Cover/ImageServer
  10. Click Add.

    The service is added to your map and looks identical to the image layer that you created and potentially shared to your own server.

    Image service added to map

You have successfully modified raster data properties so that all datasets match, created and configured a mosaic dataset. You have added the rasters and optionally, shared your mosaic layer as an image service using ArcGIS Image Server. The image layer contains descriptive attributes and symbology and you can consume the service in ArcGIS Pro, or other apps, and use it for mapping, visualization, and analysis.

You can find more lessons in the Learn ArcGIS Lesson Gallery.