Skip To Content

Evaluate the prediction result

In the previous lesson, you predicted seagrass occurrence around the world using the random forest classifier. As an ecologist, you know it is most cost-effective to protect locations with dense seagrass predictions. To find those areas, you'll add your prediction results to the map and use the Kernel Density tool to find locations around the globe where there are large concentrations of predicted seagrass. Finally, you'll insert a layout and add your map so that you can easily export it as a graphic to share.

Create a kernel density surface

First, you'll save the results of your prediction as a feature class, and then you'll add it to the map.

  1. If necessary, open your project.
  2. If necessary, click the View tab on the ribbon, and in the Windows group, click Catalog Pane.
  3. In the Catalog pane, click Project and expand Folders to locate the geodatabase.

    Seagrass geodatabase

  4. Right-click SeagrassPrediction.gdb and click Refresh.
  5. After the refresh is complete, expand SeagrassPrediction.gdb and drag GlobalPrediction onto the map.

    GlobalPrediction layer results of points with seagrasses

  6. In the Geoprocessing pane, search for the Kernel Density tool and choose Kernel Density (Spatial Analyst Tools).
  7. For Input point or polyline features, choose GlobalPrediction. For Output raster, type SeagrassHabitats and change the Output cell size to 0.2.

    Kernel Density tool

    To make sure that the density results do not include land, you'll use the bathymetry_shallow layer as a mask.

  8. Click the Environments tab, and for Mask, choose bathymetry_shallow. Click Run.

    The resulting density surface is a new raster containing the density of seagrass predicted along different coasts around the world. The default symbology shows seagrass growth with a purple color ramp. The dark purple areas indicating high concentration of predicted seagrass are visible, but the lighter areas are difficult to see. In the Contents pane, you can also see that the values have been symbolized using classification. The range of values has been divided into categories, or classes, shown with individual boxes. In this case, the classes aren't meaningful, so you'll reclassify the data using Stretch.

  9. If necessary, turn off all the layers except for SeagrassHabitats.
  10. Right-click the SeagrassHabitats layer and click Symbology.
  11. In the Symbology pane, expand the Symbology menu and choose Stretch as the classification type.

    Instead of breaking the data into strict categories, Stretch takes all the values in your data and shows them as a relative place within a range.

  12. In the Symbology pane, expand the Color scheme menu and click Show All. Choose Heat Map 1.

    Heat Map 1 color ramp

    The map redraws to show predicted seagrass locations with the new heat map color ramp.

    Prediction color scheme

    While seagrasses grow in most shallow coastal areas, the areas in reds and yellows are locations that have the right ocean conditions to create large clusters of seagrass growth. Against the current basemap, the clusters don't stand out very well.

  13. On the ribbon, click the Map tab and change the basemap to Light Gray Canvas.

    Light Gray Canvas basemap

    The simple gray of the continents makes the seagrass layer stand out, which is what you want, because your findings on seagrasses are what you're trying to emphasize on this map. The hot spots you found are also on the easternmost and westernmost edges of the map—you'll change the view to center these clusters.

  14. In the Contents pane, right-click Seagrass and choose Properties.

    Map Properties

  15. In the Map Properties: Seagrass window, click Coordinate Systems and check the Enable wrapping around the date line box. Click OK.

    Enable wrapping around the date line

  16. Pan the map so that the Alaska-Siberia cluster is in the center.

    Map centered on Alaska and Siberia

Insert a layout

Now that you've found the areas that are most important to conserve, you'll put the map in layout form so that you can easily export your work to share in papers and presentations.

  1. On the ribbon, click the Insert tab and expand New Layout. Choose the first option under ANSI – Landscape, Letter.

    Letter layout

    A new layout opens. It is blank so that you can choose which of your maps you want to add.

  2. On the ribbon on the Insert tab, click the Map Frame button. Choose the Seagrass map.

    Add Map Frame

  3. Click the upper left corner of the map and draw a rectangle the size of the layout.

    The map frame is added to the layout. It will show any layers that you had turned on in your map.

  4. Right-click the map frame in your layout and choose Activate.

    Activate map frame

    When the map frame is activated, you can zoom and pan the map to the location you want.

  5. Pan the map until it is roughly centered.
  6. On the ribbon under Activated Map Frame, click the Insert tab. In the Map group, click Close Activation.

    The map frame is deactivated and will stay stationary as you add the rest of the elements, such as a title and scale bar.

  7. On the ribbon, click the Insert tab. In the Text group, click Text (or Rectangle) and then click the map to insert a text box.
  8. If necessary, in the Contents pane, double-click the Text item to open the Format Text pane.
  9. In the Format Text pane, for Text, type GLOBAL SEAGRASS HABITATS and click outside of the text box to apply.

    Format title text

  10. Click the Text Symbol tab and click Properties, and then expand Appearance. Change Font name to Constantia, Font style to Bold, and Size to 24 pt.

    Format title text

  11. Click Apply and center the title at the top of the map.
  12. On the ribbon, on the Insert tab, click Scale Bar and draw a rectangle at the bottom left corner of the map.

    A scale bar is added to the map.

  13. Drag the scale bar to the lower right corner of the layout.

    Map with scale bar

    Finally, you'll add a legend to give the prediction layer more context.

  14. On the ribbon, on the Insert tab, click Legend. Draw a rectangle at the bottom left of the map.

    By default, the legend shows the layer you currently have symbolized on the map. The text on the legend doesn't tell you anything useful, so you'll remove it.

  15. In the Format Legend pane, expand the Legend Items group and click Show Properties. Under Show, uncheck every box.

    The only thing visible on your legend is the color ramp. Because this is all you're choosing to show, you'll make it larger.

  16. If necessary, expand the Sizing group. Change Patch width to 30 pt and Patch height to 20 pt.

    Change patch size

  17. In the upper left corner of the Format pane, click the back arrow.

    Now you'll add your own labels to the legend.

  18. On the ribbon on the Insert tab, click Text. Draw a text box at the top of the legend.
  19. In the Format Text pane, for Text, type High Density.
  20. Click the Text Symbol tab and expand Appearance. Change Font Name to Constantia and Font Style to Bold. Click Apply.
  21. Create another text box named Low Density and format it the same way.
  22. Line the labels up with the top and bottom of the color ramp, respectively.

    Final map layout

    Now that all your layout elements are in place, you'll share the map.

  23. On the ribbon, click the Share tab. In the Export group, click Layout.
  24. Save the map.

You can choose to save your graphic in any format and size you want to be able to use it in a presentation or paper later. The layout shows several important clusters of probable seagrass growth around the world, which you identified using random forest classification to find hospitable ocean conditions. These clusters should be researched further, and ultimately, protected.

You can find more lessons in the Learn ArcGIS Lesson Gallery.