Add HYCOM raster to lesson project

The ArcGIS Pro project package includes all the data and symbology needed for this lesson. After downloading and opening the project package, you will first unzip the included HYCOM multidimensional raster that has been clipped to the extent of the Gulf of Mexico.

Download and extract the project package

The project package for this lesson is hosted on ArcGIS Online. Once you have extracted and opened the package, there is an additional zipped CRF folder inside that contains the HYCOM ocean current variables. You must uncompress this folder before you can use it in the project.

  1. Download the Predict ocean currents to plan remote well inspections project.
  2. Locate your downloaded file, and double-click to extract and open the project in ArcGIS Pro.
  3. If necessary, in ArcGIS Pro, in the Select unpacking location pane, browse and choose a folder for the project to unpack content.

    If you are not prompted to choose an unpacking location, the application unpacks to a default location such as C:\Users\<NAME>\Documents\ArcGIS\Packages\ predict ocean currents to plan remote well inspections.

    Select unpacking location.

    The project opens and displays a map titled Gulf of Mexico HYCOM and a scene titled Gulf of Mexico Scene.

  4. In file explorer, browse to the location of your extracted project, for example, C:\Users\<NAME>\Documents\ArcGIS\Packages\ predict ocean currents to plan remote well inspections.

    The project folder name will have an additional set of characters after it, such as \predict ocean currents to plan remote well inspections_d33969.

  5. In the \commondata\userdata folder, extract the HYCOM_GoM.zip file. This is where you’ll also find the layer and style files used later in this lesson.

    Extract HYCOM_GoM.zip file.

    The HYCOM raster has been extracted and you can now add it to your map and explore its multidimensional properties.

  6. In file explorer, verify the HYCOM_GoM folder has been extracted.
  7. In the Catalog pane, right click Folders, and choose Add Folder Connection.

    Add a folder connection.

  8. In the Add Folder Connection window, browse and choose the location containing the HYCOM_GoM raster, and click OK.

    Locate folder

  9. In the Catalog pane, verify the folder connection and access to the HYCOM_GoM raster.

    Explore folder content

  10. Save the project.

Add the HYCOM raster to the map

This lesson scenario takes place on April 19, 2021, and uses a simulated seven-day ocean current forecast that has already been clipped to the project area to reduce processing time and ensure consistent output. In a real-life scenario, one of the near real-time HYCOM services provided on ArcGIS Living Atlas would be used to forecast ocean currents—or even sea-surface height, salinity, or temperature.

The project contains tabs for a map and a scene for the Gulf of Mexico. You will first use the 2D map to explore and sample the well locations and HYCOM data, and move to the scene to visualize the results in 3D.

  1. If necessary, activate the Gulf of Mexico HYCOM map.

    Gulf of Mexico HYCOM map

  2. In the Contents pane, review the map layers.

    Map layers

    The layers include the following:

    • Oil Wells, a layer consisting of a collection of 30 oil and gas wells.
    • Major Oceans Currents, a layer displaying the Gulf Stream loop current, a major ocean current that snakes its way through the Gulf of Mexico and around the southern tip of Florida. The layer shows the consistent heating and cooling currents around the globe. You can find it on ArcGIS Living Atlas of the World .
  3. Use the Explore tool to zoom out and explore some the major heating and cooling currents of the world before adding the Gulf of Mexico HYCOM raster to the map.

    The loop current

    Notice that some well locations are inside the Gulf Stream loop current, while others on the northwest are outside the current.

    Wells inside and within the loop current

  4. In the Catalog pane, in Folders, locate the HYCOM_GoM raster, right-click, and choose Properties.

    Show HYCOM_GoM properties.

  5. In the Properties pane, click the Multidimensional Info tab.

    Display HYCOM_GoM multidimensional properties.

  6. Review the Properties section and expand Default Variable.

    The multidimensional HYCOM raster has two variables and two dimensions—the variables are u and v. Each variable has a depth and time dimension.

    Review HYCOM_GoM variables.

  7. For Variables and Eastward_Sea_Water_Velocity__u, expand the Depth and StdTime dimensions.

    Now you can observe properties of both the Depth and StdTime dimensions and their properties.

    • For Depth, the extent ranges from -5000 — 0 and the count is 40.
    • For StdTime, the interval is 3 Hours, with a count of 56 and an extent of 2021-04-19T00:00:00 — 2021-04-25T21:00:00.

    Review HYCOM_GoM depth and time dimensions.

    Next, you will add the HYCOM_GoM raster to the Gulf of Mexico HYCOM map.

  8. On your own, investigate the dimensions properties for the Northward_Sea_Water_Velocity__v variable. When you are finished, click Cancel to close the properties pane.
  9. In the Catalog pane, right-click the HYCOM_GoM raster, and choose Add To Current Map.

    Add HYCOM_GoM layer to map

    The raster is added to the map.

    Note:

    if you unzipped the raster folder while ArcGIS Pro was open and do not see the raster it in the file list, right-click the folder connection and refresh.

  10. Use the Explore tool to zoom to the extent of the HYCOM_GoM raster.

    Explore the HYCOM_GoM layer.

    The HYCOM multidimensional raster is time enabled. While adding the raster to the map, notice the time slider displayed at the top of the screen. For now, it is best to collapse and hide the time slider. You will enable and use time later in this lesson.

  11. On the map, hover over the time slider, and click the collapse button.

    Explore the time slider.

  12. In the Contents pane, click and select the HYCOM_GoM layer.
  13. On the ribbon, on the Appearance tab, in the Rendering group, click DRA (dynamic range adjust).

    Choose DRA.

    The map updates.

    HYCOM_GoM l layer with DRA applied

  14. In the Contents pane, review the HYCOM_GoM layer.

    Expand the HYCOM_GoM layer legend.

    The layer legend displays the minimum and maximum values of the color ramp to better show the variations in ocean current magnitude.

  15. Use the Explore tool to zoom to features in the Oil Wells layer.

    HYCOM raster DRA

  16. In the Rendering group, click the Resample Type drop-down menu, and choose Bilinear.

    Select the Bilinear resampling method.

    This action smooths out the raster pixels.

    HYCOM raster DRA and bilinear resampling

    The multidimensional HYCOM raster has two variables and two dimensions. The variables are u (currently shown on the map) and v, representing depth and time.

    Multidimensional HYCOM raster variables

    Next, you will change the variable displayed in the raster from u (east-west) to the v (north-south) component direction.

  17. On the ribbon, on the Multidimensional tab, in the Current Display Slice group, click the Variable drop-down menu and choose Northward_Sea_Water_Velocity_v.

    Select the display variable.

    Note:

    If you change the active variable, you must also reapply DRA and bilinear resampling.

  18. On the ribbon, on the Appearance tab, in the Rendering group, click DRA (dynamic range adjust).
  19. In the Rendering group, click the Resample Type drop-down menu, and choose Bilinear.
  20. On the ribbon, on the Multidimensional tab, in the Current Display Slice group, click the StdTime drop-down menu.

    Display time slices.

    Notice the StdTime dimension is in three-hour steps as you observed when reviewing the properties of the variables and dimensions for the HYCOM_GoM raster.

  21. On the ribbon, on the Multidimensional tab, in the Current Display Slice group, click the Depth drop-down menu.

    Review depth slices,

    Notice the denser step interval closer to the surface and a less dense interval as observations reach -5000 m. On your own, explore different times and depths and observe how the HYCOM raster in the map updates.

  22. Save the project.

In this module, you became familiar with the Gulf of Mexico oil well inspection project area and started to explore the variables and dimensions of the HYCOM dataset in 2D. In the next section, you will use the oil wells to sample the ocean currents at specific locations to determine where and when it is safe to operate a ROV near the Gulf Stream loop current. In the next module, you will sample the HYCOM raster at the 30 well locations in both the depth and time dimensions, and transform the u and v vectors to direction and velocity.


Sample the HYCOM raster

Wells in the Gulf of Mexico are routinely inspected and, when necessary, capped while ocean currents are low enough to allow the ROV a safe descent and ascent.

ROV mission. Photo credit: Keith VanGraafeiland

In this module, you will take a three-hour time step sample of u and v current vectors in the HYCOM raster for each of the 30 well locations. Next, you will transform these values into velocity and direction, which will be used to visualize the ocean current using dynamic 3D symbols.

Oil well location HYCOM samples

To plan the ROV inspection mission, it is necessary to investigate ocean currents over time at well locations. The Sample geoprocessing tool, which supports multidimensional rasters, allows you to extract the full range of time and depth dimensions for the HYCOM forecast raster at well locations.

  1. If necessary, open the Gulf of Mexico HYCOM map.
  2. In the Content pane, uncheck the HYCOM_GoM raster layer.
  3. In the Contents pane, expand the Oil Wells layer.

    Expand the Oil Wells layer.

    Note the 30 oil wells are symbolized according to whether the ROV will be launched from a floating vessel or a platform.

    ROV launched from a boat. Photo credit: Keith VanGraafeiland

    ROV launched from a platform. Photo credit: Keith VanGraafeiland

  4. Use the Explore tool to zoom in to the cluster of wells located both in and out of the loop current.

    Explore well clusters.

  5. On the ribbon, click Command Search or press Alt+Q.
  6. In the Search box, type Sample.
  7. In the Search Results drop-down menu, choose Sample (Image Analyst Tools).

    Locate and use the sample tool.

  8. In the Sample geoprocessing tool, set the following parameters:

    • For Input rasters, choose HYCOM_GoM.
    • For Input location raster or features, choose Oil Wells.
    • For Output table or feature class, type Sample_HYCOM_Go1.
    • For Unique ID field, choose Well ID.
    • Check Process as multidimensional.
    • Check Generate feature class.

    Sample tool parameters

    Investigation of depth and time dimensions properties, revealed a depth count of 40 and a time count of 56. These counts combined with the number of samples (30 wells) determines the number of output points generated by the Sample geoprocessing tool.

  9. Click Run.

    The Sample_HYCOM_Go1 layer is added to the map. It consists of 67,200 points, representing a sampling of 40 depth intervals, 56 time steps, and 30 well locations.

  10. Save the project.

    In the next module, you will transform the attributes needed to symbolize ocean currents in 3D using the u and v variables.

Calculate velocity and direction from u and v variables

The HYCOM raster uses component direction vectors for east-west (u) and north-south (v) that describe the magnitudes of ocean current movement. To scale and rotate 3D symbols, you must first convert these values must first to a velocity (m/s) and a direction (degrees). In the following steps, you will use a simple ModelBuilder model included in the project toolbox to add these additional attributes to the sample points.

  1. In the Contents pane, right-click Sample_HYCOM_Go1 and choose Attribute Table.
  2. Review the Sample_HYCOM_Go1 attribute table.

    The Sample tool starts by processing the first Well ID, the first time step, and the deepest depth interval and moves up the depths for each location before moving on to the next time step and repeating the process.

    Explore the Sample_HYCOM_Go1 attribute table.

    You may notice that there are null values at the deeper intervals—this is okay. The Gulf of Mexico has a maximum depth of between -1000m and -3000m for the 30 wells, so anything beyond that depth is considered NoData in the HYCOM raster and your sample points.

  3. Open the Catalog pane, expand Toolboxes.
  4. Expand the Visualizing Multidimensional Ocean Data toolbox.

    Locate the model tool.

  5. In the Visualizing Multidimensional Ocean Data toolbox, double-click the Calculate Velocity and Direction from u and v model.
    Note:

    You can also search geoprocessing tools for u and v to find it in the same way you did with the Sample tool.

  6. In the Calculate Velocity and Direction from u and v model tool, for Sample Points, choose Sample_HYCOM_Go1, and click Run.

    Use the model tool.

    The tool successfully executes but offers a warning. Because some sample points contain null values at the deeper intervals, the tool cannot process these records and generates the warning.

    Model tool warning

    Note:

    The u and v vectors represent the positive and negative X and Y components of the ocean current, so the Pythagorean theorem is used in the model to solve for the velocity in m/s:

    Velocity = √u² + v²

    You can determine the ocean current direction from the u and v again using some geometry:

    Direction = (180/π) * arctan(u,v)

  7. Review the Sample_HYCOM_Go1 attribute table.

    Review new field values.

    The sample points now have the attributes needed to scale and rotate the 3D ocean current symbols in space and time. You may notice by scanning the Velocity values in the attribute table that they decrease rapidly as you go deeper, so most of the action of the loop current is happening near the surface.

  8. Close the Sample_HYCOM_Go1 attribute table.
  9. Save the project.

In this module, you sampled the HYCOM raster at the 30 well locations in both the depth and time dimensions, and transformed the u and v vectors to direction and velocity. In the next module, you will add the sample points to the scene and symbolize them as time-aware custom 3D arrows showing ocean current direction and magnitude.


Configure 3D ocean current symbols

The nature of the HYCOM multidimensional data means it is difficult to synthesize several dimensions of change and magnitude in a 2D view. You can look at one depth or time slice at a time, but then you lose the context of the slice before or after. Using a scene, you can convert your 67,200 sample points into intuitive symbols that capture all the depth dimensions in a single 3D view.

Add HYCOM sample points to the scene and configure depth

In this module, you will add the HYCOM sample points to a scene provided in the project and configure the layer properties to support the visualization of ocean depth in a global scene using the TopoBathy 3D (topography and bathymetry) elevation service available from Living Atlas. A layer file (.lyrx) has also been provided in the project that includes a simple 3D directional symbol created in SketchUp.

  1. On the Gulf of Mexico HYCOM map, in the Contents pane, right-click Sample_HYCOM_Go1 and choose Copy.

    Copy the layer to duplicate it.

  2. In the project, activate the Gulf of Mexico scene.

    The scene includes a close-up 3D view of Well 20. This well is accessible for inspection by vessel and shows a maximum depth to the ocean floor of -2604m:

    Gulf of Mexico scene

  3. In the scene Contents pane, right-click Gulf of Mexico Scene and choose Paste.

    Copy and paste the layer.

    The layer is added to the 2D Layers group of the scene.

  4. On the ribbon, on the Map tab, in the Navigate group, use Bookmarks to add a bookmark for Well 20.

    Add new bookmark.

    Name the bookmark Well 20.

    Create a bookmark.

  5. Use the Explore tool to zoom out and explore the Sample_HYCOM_Go1 layer features.

    Explore Sample_HYCOM_Go1 layer features.

    You will apply a layer file that will move the Sample_HYCOM_Go1 layer to the 3D Layers group.

  6. In the Contents pane, click the Sample_HYCOM_Go1 layer.
  7. On the ribbon, on the Appearance tab, click the Symbology button.

    Display the Symbology pane.

  8. In the Symbology pane, locate and click the Import symbology button.

    Click import symbology.

  9. In the Apply symbology from Layer geoprocessing tool, set the following parameters:

    • For Input layer, verify Sample_HYCOM_Go1 is selected.
    • For Symbology Layer, browse and select 3D Arrows.lyrx from your folder connection.

    Select symbology layer.

  10. Verify the Symbology Fields parameters set by the 3D Arrows.lyrx layer file.

    • Type is set to Value field.
    • Source Field is set to Velocity.
    • Target Field is set to Velocity (m/s).

    Apply symbology from the layer.

  11. Click Run to apply the symbology.

    The scene is now updated to show a collection of overlapping 3D arrows at the ocean surface located at Well 20. Most of the symbology work was done by the layer file, such as applying a custom 3D arrow symbol, moving the layer to the 3D Layers group, setting velocity cutoffs with graduated colors, and adding labels.

  12. In the Contents pane, review the Sample_HYCOM_Go1 layer legend.
    Note:

    The Contents pane does not display the customized 3D arrows that are applied to the Sample_HYCOM_Go1 layer. However, wells in the scene are rendered with the symbols and display velocity cutoffs with graduated colors, and labels.

    Contents pane

    The ocean current velocity cutoffs and symbols are based on the hypothetical operating limits of the ROV used for the oil well inspections in this lesson.

  13. In the Symbology pane, click the Vary symbology by attribute tab, and expand Size.

    Set Symbology pane properties

    Note the size field is set to use Velocity(m/s).

  14. Close the Symbology pane.
  15. Use the Well 20 bookmark to zoom to the target well.
  16. In the scene, use the Explore tool to investigate, rotate, and tilt Well 20.

    • Green arrows show optimal low current velocities (<0.25 m/s)
    • Yellow arrows represent moderate (but still allowable) current velocities (0.25-0.5 m/s)
    • Red arrows show current velocities (>0.5 m/s) that are beyond the ROV’s operating limits.

    Review stacked arrows

    Notice that the feature height settings still need to be configured in the layer properties.

  17. In the Content pane, double-click the Sample_HYCOM_Go1 layer.

    The Layer Properties pane displays.

  18. In the Layer Properties pane, click the Elevation tab.
  19. Verify Features are is set to At an absolute height.
  20. For A field, click the drop-down menu and choose Depth.

    Set elevation property.

    You have now set the Z value for each sample point; next, you will verify display properties.

  21. In the Layer Properties pane, click the Display tab.
  22. Verify Display 3D symbols in real world units is checked. When you are finished, click OK to close the layer properties.

    Set layer display properties.

    The scene updates to show each set of sample points at their depth below the surface, with a label showing ocean current velocity in meters/second.

    Verify display properties.

  23. In the scene, use the Explore tool to rotate and tilt a well feature and observe current velocity.
  24. Save the project.

Configure time

The HYCOM multidimensional raster is time enabled. When you added the raster to the map for the sampling step, you were instructed to collapse and hide the time-slider displayed at the top of the screen.

Configure time.

While the sample points incorporated the time steps as an attribute from the HYCOM raster, the scene layer itself doesn’t yet know it is time enabled. The following steps will configure time so that you can more easily explore (and animate) ocean current velocity changes in that dimension.

  1. In the Gulf of Mexico scene, in the Contents pane, double-click the Sample_HYCOM_Go1 layer.
  2. In the Layer Properties pane, click the Time tab.
  3. In the Time tab, in the Layer Time drop-down list, choose Each feature has a single time field.

    Display layer properties.

  4. For Time Field, choose StdTime.

    Select a time field.

    Currently, the time extent for the HYCOM dataset is set to display from midnight on April 19 to 9 p.m. on April 25. HYCOM has a temporal frequency of three hours (UTC time), so the time properties of the sample points must match that.

  5. For Time Interval, check View using regular time interval and set Step to 3 and units to Hours.

    Set time interval step

  6. For Time Zone, click the drop-down menu and choose (UTC) Coordinated Universal Time.

    Set time zone to (UTC) Coordinated Universal Time.

  7. Click OK to close the Layer Properties window.

    Once you have configured time for a layer, it displays at the top of the scene.

    Time slider in a scene

  8. In the scene, hover over the time slider and click the Time Disabled button (it will have a red x on it by default) to enable or disable time.

    Enable or disable time.

    The slider will filter the data to show the first step in the series: April 19, 2021, at midnight.

    First step in the series

  9. Click the right arrow on the top of the time slider to move several steps forward through the time series.

    Move steps forward.

    You will notice that it is currently showing a moving three-hour window of time, but you want to step through one time value, not a moving window.

  10. On the ribbon, on the Time tab, in the Current Time group, locate Span, and change 3 to 0.

    Set the time span.

  11. In the Step group, verify Step Interval is set to 3 Hours .

    Verify step interval.

    The time slider now shows a single value as you move forward and backward through the time series, in three-hour increments.

    Play time with step interval.

  12. In the scene, use the Explore tool to zoom closer to Well 20.
  13. In the Contents pane, uncheck the Well Tops layer to better see the near-surface currents.

    Play time without well top.

    The depth and time dimensions have now been configured for your sample points.

  14. On your own, explore some of the other well locations in the scene and use the time slider to compare how the current velocity and directions change over space, depth, and time.

    Animation

    You can also configure this layer to be range aware by plugging the depth attribute into the range slider. You can show certain depths or ranges of depths if you are only interested in seeing the sample points in the top 100 meters, for example. See the ArcGIS Pro documentation on configuring range for more information. Configuring time (or range) on a dataset is an essential method of filtering and visualizing dynamic processes in both 2D and 3D.

For your lesson scenario, there is a lot of information to process to determine where and when the ocean currents are calm enough to send a ROV to the depths. Fortunately, there are charting options in ArcGIS Pro that can further simplify the dataset into a planning or executive overview of potential ROV dive windows. You will generate a chart in the next module.


Discover ROV dive windows with a matrix heat chart

Visualizing currents as 3D arrow symbols is an intuitive way to represent direction, magnitude, and depth. However, you can only assess one well at a time, which doesn’t scale well to large sample datasets. To distill our analysis of one week of HYCOM and 30 well locations into something that can fit on a single sheet of paper, you will use a matrix heat chart.

Configure the matrix heat chart

The matrix heat chart is a convenient way of analyzing the relationship between two categorical fields (Well ID and Time) according to the value of a numeric field (Velocity). The chart will help answer the question At a given well location and a given time, does the velocity of the current exceed the operating parameters of your ROV? In this situation, you aren’t concerned about individual depth values, as you will have to pass through them all on the descent to and ascent from the ocean floor. However, you are concerned with what the maximum current value is for all depths at a given well and time.

In the following steps, you will configure a matrix heat chart using the sample point attributes to help answer the question.

  1. If necessary, activate the Gulf of Mexico scene.
    Note:

    The time slider essentially functions as a definition query, so to show the full dataset in the chart, you must disable it. However, you can also use it with the charts if you want to step through individual time values to see how the chart reacts.

  2. In the scene window, locate the time slider and click the Time Disabled button.

    Disable time slider.

  3. In the Gulf of Mexico scene, in the Contents pane, right-click the Sample_HYCOM_Go1 layer, hover over Create Chart, and choose Matrix Heat Chart.

    Create matrix heat chart.

    An empty matrix heat chart will be added below the scene, along with the corresponding Chart Properties panel to the right.

  4. If necessary, reposition the chart and properties pane.

    Reposition and dock the chart and properties pane.

  5. In the Chart Properties pane, on the Data tab, update the following:

    • For Column category, choose StdTime
    • For Row category, choose WellID
    • For Aggregation, choose Maximum
    • For Number, choose Velocity (m/s)
    • For Classes, choose 3

    Set chart properties.

  6. In the Chart Properties pane, expand Class breaks.

    Note the class breaks values do not reflect your current velocity cutoffs.

    Default class breaks

    You must reconfigure the three class breaks to use the cutoffs of 0.25, 0.5, and 2.0 and match colors to the 3D directional arrows.

  7. In the Chart Properties pane, click the Color scheme drop-down menu and check Show names. From Color schemes drop-down menu, choose the HYCOM Velocity Colors scheme.

    Select the HYCOM Velocity Colors scheme.

    The HYCOM Velocity Colors scheme is included in the project package and consists of three color styles, set to each of the upper value cutoffs configured to display as green, yellow, and red.

  8. In the Classes tab, update the upper value for each interval as follows:

    • For green, type 0.25.
    • For yellow, type 0.5.
    • For red, type 2.0.

    Update the class intervals.

    The chart is starting to be meaningful; however, additional formatting will make things clearer.

    Symbolized matrix heat chart

  9. In the Chart Properties pane, click the Format tab, and click the Symbol elements button.

    Chart format tab

  10. For Grid lines, choose a solid line. For color, choose 50% grey, and for width, choose 0.25pt.

    Set chart display properties.

    The chart updates, and it is easier to identify wells and time intervals.

    Review updated wells and time intervals on chart.

  11. In the Chart Properties pane, click the General tab, and update the following properties:

    • For Chart title, verify Maximum of Velocity (m/s) for StdTime and WellID.
    • For X axis title, type Time (UTC).
    • For Y axis title, type Well_ID.
    • For Legend title, type Weekly (m/s).
    • For Description, type This chart shows the maximum ocean current velocity by Well ID in the Gulf of Mexico calculated from HYCOM between April 19 - April 25, 2021.

    Set general chart properties.

  12. Customize other chart style options as needed. Once you’re finished, enlarge the finished chart to explore cells and time steps.

    In the chart, notice the changes in the current as well locations move from west to east (and toward the loop current).

  13. In the chart, locate the west-most wells (#1-15) identified as A in the image below, and notice that these wells have maximum currents of 0.25 and 0.50 and are within the operating limits of an ROV.

    Investigate well accessibility using the chart.

  14. In the chart, locate the eastern wells (#16-26), identified as B in the image. Notice they all have some period of time where the current is too high (2.0 and higher) and exceeds the operating limits of an ROV.

    As you get deeper into the current, some wells (#27-29) identified as C in the image have no windows of operation available as they are located fully within the loop current. This may be seasonal and operation limits may change as the loop shifts as a result of seasonal changes.

  15. In the scene, enable the time slider, focus in on a subset of the time data, and set the time to a single day.

    The chart reacts to show just a single day of ocean currents. Reposition the scene and chart to observe both the well and chart.

    Review the daily matrix heat chart.

  16. Save the project.

In this module, you summarized 67,200 individual ocean current predictions into a an easy-to-read chart that can be used for planning ROV operations. While investigating the process of trying to find a signal in the HYCOM noise, you used Dr. Ben Shneiderman’s information-seeking mantra in the workflow: “Overview first, zoom and filter, then details-on-demand.” You created a chart (overview), you used the chart to simplify the dataset and find outliers (zoom and filter), and next, you will finish the mantra (and lesson) by animating currents for a specific well of interest (details-on-demand).


Animate ocean currents in 3D

In this module, you will create an animation of one well using the time dimension in HYCOM to illustrate the detailed dynamics of the ocean current intensity and direction over the course of one week. Fortunately, half of the prep work has been done by configuring and enabling time on the sample points, so all that’s left to do is to zoom in to a well, load the time steps into a new animation, add annotation, and export it.

Load a time series into an animation

  1. If necessary, activate the Gulf of Mexico scene.
  2. In the scene, in the time slider, click the Time Disabled button to disable time.
  3. In the scene, in the time slider, click the Collapse button.

    Hide time slider.

  4. In the Contents pane, check and select the Well Tops layer.
  5. On the ribbon, on the Appearance tab, in the Effects group, for Transparency, choose 95%.

    This mostly hides the vessel or oil rig, but you can still see the label.

    Set vessel transparency.

  6. Use the Explore tool to investigate Well 20 (or a different well of your choice). Frame the upper half of the well in the display, showing where most of the higher ocean currents are present.

    Explore a target well.

  7. On the ribbon, on the View tab, in the Animation group, click Add.

    Click the Add button.

    The Animation Timeline and Animation Property panes display. Reposition the panes as needed.

    Reposition the panes.

  8. In the Animation Timeline pane, click Create first keyframe.

    Create the first keyframe.

    The scene window updates, illustrating how the animation will be clipped by the aspect ratio of the output movie (HD 720, HD 1080, and so on).

    Explore the output movie aspect ratio.

    Next, select an output format from movie options.

  9. On the ribbon, on the Animation tab, in the Export group, click the Movie button.

    Display the export options pane.

  10. In the Export Movie pane, from Movie Export Presets, choose HD 1080.

    Select a movie export preset.

  11. On the ribbon, on the Animation tab, in the Export group, click the Lock View Size button.

    This ensures the scene view is clipped to the selected aspect ratio of 1080.

    Lock the view size.

  12. Review the scene and ensure that the aspect ratio of the output movie doesn’t clip the data or labels. If necessary, move and reframe the scene until everything looks good in the locked view.
  13. In the Animation Timeline pane, in the Keyframe Gallery, right-click the first test keyframe, and choose Delete Selection.

    Delete the first frame.

  14. On the ribbon, on the Animation tab, in the Create group, click the Import drop-down menu, and pick Time Slider Steps.

    Import time slices as frames.

    The HYCOM time series includes 56 steps (7 days x 8 measurements per day). Each of these steps is added as a keyframe to the timeline together with a starting frame resulting in a total of 57 frames.

    Verify frames generated by time slices.

    Next, select the full timeline.

  15. Click the first keyframe (#1), hold the Shift key, scroll to the last keyframe (#57), and click.

    Select animation frames.

  16. On the ribbon, on the Animation tab, in the Edit group, click the Properties button (or right-click the frames in the timeline and select Animation Properties).

    Animation properties button

    In the Animation Properties pane, you can define the length of individual keyframes (or all). By default, a value of 3 seconds per keyframe is applied, resulting in a runtime of 2:48. Next, you will modify the movie runtime to be under 30 seconds.

  17. In the Animation Properties pane, change the Length value to 0.25 seconds.

    This will result in a total runtime of 14 seconds.

    Set animation length.

  18. Save the project.

Add animation overlays

Next, you will add an overlay to the animation.

  1. On the ribbon, on the Animation tab, in the Overlay group, click the Add Overlay drop-down menu. From the Dynamic text group, choose Map Time.

    Add overlay to animation.

    In the scene, start and end annotation text is added as an overlay. However, your data only has a single time value for each step.

    Start and end annotation text

  2. In the scene, for the overlay, select and delete the second end time line.

    Select overlay text to delete.

  3. Verify the overlay contains the following text:
    <dyn type="animation" property="startTime" format="short|long"/>
  4. In the scene, click the Close on-screen editing and commit changes button.

    Close on-screen editing and commit changes button

  5. In the Animation Properties pane, click the Overlays tab.
  6. Verify Start Key is set to 1 and End Key is set to 57.

    This ensures changes are applied to all keyframes in the animation.

  7. Use the Settings button to display the Format Text Symbol pane.

    Verify start and end frames.

  8. In the Format Text Symbol pane, update the text appearance by changing the font and size as needed.

    Update map time overlay font and size.

  9. On the Overlays tab, choose one of the nine preset positions for the overlay to be displayed on the keyframe.

    Set map time overlay position.

    Using the Overlays tab, you can add a title, image, or other text to the animation frames. For now, you will keep it simple and you may experiment later.

  10. Verify the Map Time overlay has been successfully formatted and displays in the correct position in the keyframe.

    Review map time overlay.

  11. Save the project.
  12. On the ribbon, on the Animation tab, in the Export group, click the Movie button.

    Export button

  13. In the Export Movie pane, for File Name, browse to a location of your choice and specify an output name.
  14. In the File Export Settings section, for Media Format, choose MPEG4 movie (mp4).
  15. For Frames Per Second, select 30 frames per second.
  16. When you are finished, click the Export button.

    Export animation movie.

    Note:

    Exporting your animation may take some time and is dependent on your processor and video card. It may take as long as 10 to 15 minutes to complete this process.

  17. In the Export Movie pane, click Play the video to review the animation movie.

    Play the video.

    In addition to screen captures, charts, and interactive scenes, animations are one of the key tools for communicating in 3D, particularly when dealing with time-aware layers such as the points sampled from HYCOM. You can use these same animation techniques in 2D or 3D. For example, you can use a regularly spaced fishnet of sample points instead of specific well locations to observe regional changes in ocean surface currents and temperatures.

    In this 48-hour animation, Hurricane Dorian moves up the East Coast after coming to a near standstill and devastating the Bahamas in 2019.

    Animation showing Hurricane Dorian with arrows

This lesson illustrated how to extract and sample ocean current forecasts from HYCOM multidimensional raster datasets to plan ROV missions in the Gulf of Mexico. Along the way, you converted u and v ocean current variables into easy-to-understand 3D symbols, created an overview matrix heat chart to summarize ROV dive windows for the complete dataset, and singled out one well to get a detailed look at the changes in ocean currents over the time series. You can apply these workflows and tools to other HYCOM variables or any other multidimensional datasets to gain a better understanding of complex earth processes in space and time.