Precondition the elevation model

Before you begin your analysis, you'll precondition a digital elevation model (DEM) of Stowe, Vermont, to reduce the possibility of errors in your results. Some DEMs contain sinks, which are areas of low elevation surrounded by higher elevation values. Sinks can occur naturally but are more often data errors in a DEM raster dataset. Because water has no way of flowing out of a sink, sinks can cause all kinds of errors when analyzing how water flows to an outlet. Before you begin your hydrological analysis of flooding potential in Stowe, you'll identify and remove sinks from your elevation data.

Download and open the project

First, you'll download data about Stowe supplied by the Vermont government, as well as a DEM derived from the United States Geological Survey's (USGS) data. This data will be contained in an ArcGIS Pro project. The project files also contain a task that will take you through the workflow step by step.

  1. Download the Stowe_Hydrology compressed folder.
  2. Locate the downloaded file on your computer.
    Note:

    Depending on your web browser, you may have been prompted to choose the file's location before you began the download. Most browsers download to your computer's Downloads folder by default.

  3. Right-click the file and extract it to a location you can find easily, such as your Documents folder.
  4. Open the unzipped folder, and open the Stowe_Hydrology folder.
    The folder contains the Stowe_Hydrology project file for ArcGIS Pro, the Stowe_Hydrology geodatabase, and the automatically generated Index folder. You'll open the project.
  5. If you have ArcGIS Pro installed on your machine, double-click Stowe_Hydrology.aprx to open the project. If prompted, sign in using your licensed ArcGIS account.
    Note:

    If you don't have ArcGIS Pro or an ArcGIS account, you can sign up for an ArcGIS free trial.

    Default project showing Stowe, Vermont

    The project contains a map with a topographic basemap and several data layers. These layers include the following:

    • Pour_point—A point feature layer that depicts the outlet downstream of the Little River where you'll create a unit hydrograph.
    • Stowe_boundary—A polygon feature layer that depicts the boundaries of Stowe, Vermont. This layer was derived from data available from Vermont Center for Geographic Information (VCGI).
    • Stowe_surface_water—A raster layer that depicts all surface water bodies in the area of interest. This raster layer's resolution is 30 meters, which means that each cell in the layer has an area of 30 square meters. The layer was derived from features in the NHDPlus Version 2 dataset.
    • Stowe_DEM—A raster layer that depicts elevation within the study area. It also has a resolution of 30 meters. It was derived from data made available by the United States Geological Survey (USGS).
    • Stowe_velocity_example—A raster layer that depicts a spatially-variant, time- and discharge-invariant velocity field for the study area. You'll learn how to create this layer in a later lesson (this example is provided as a backup). For now, you don't need this layer, so it's turned off.

    Although not on the map, the project folder (Stowe_Hydrology) includes a text file called Stowe_isochrones that contains classification ranges for the isochrone zones you'll create in a later lesson.

    Now that you've seen the Stowe DEM, you'll turn it off so that it doesn't hide your results.

  6. In the Contents pane, uncheck Stowe_DEM to turn it off.
    Note:

    Depending on your default ArcGIS Pro configuration, the Contents pane may not be open. If necessary, on the ribbon, click the View tab. In the Windows group, click Contents.

    Turn off the Stowe_DEM layer

    Next, you'll open an ArcGIS Pro task that is included in your project. The task will guide you through the workflow necessary to create a unit hydrograph.

  7. In the Catalog pane, expand the Tasks folder.
    Note:

    If the Catalog pane isn't open, on the View tab, in the Windows group, click Catalog Pane.

    Expand the Tasks folder

  8. Double-click the Create unit hydrograph at outlet task.

    The Tasks pane appears. It contains several tasks for specific parts of the workflow.

Identify sinks

First, you'll identify sinks in your DEM. Although your DEM was derived from reliable data provided by the USGS, sinks may still be present. To run an accurate hydrological analysis for the area around Stowe, you'll first need to locate any sinks.

  1. In the Tasks pane, double-click the Precondition the elevation model task.

    Precondition the elevation model task

    The task opens. Each task contains instructions for how to proceed. This task consists of three steps (the progress bar at the bottom of the pane tells you the total number of steps). The first step opens the Flow Direction tool. By determining the flow direction for the area, you'll be able to identify sinks, which are areas where water can no longer flow.

  2. For Input surface raster, choose Stowe_DEM.
  3. For Output flow direction raster, point to the text box and confirm that the output location is the Stow_Hydrology geodatabase. Change the output name to Stowe_flow_direction.

    Parameters for the Flow Direction tool

    You'll leave the remaining parameters unchanged, as they're not relevant to your analysis.

    Tip:

    If you want to learn more about any of the parameters, point to the parameter, and point to the information button.

  4. Click Run.

    The tool runs and the flow direction raster layer is added to the map.

    Stowe_flow_direction layer

    The symbology of the layer corresponds to the direction water is likely to flow, with darker colors indicating a more southerly flow direction and lighter colors indicating a more northerly flow direction. The layer's appearance isn't important to your analysis, because you'll run another tool that will automatically find sinks based on the flow direction layer.

  5. If necessary, open the Contents pane. Uncheck the Stowe_flow_direction layer to turn it off.
    Note:

    It's possible that the Tasks pane is covering the Contents pane. If so, you can switch between the panes by clicking the appropriate tabs at the bottom of the active pane.

  6. If necessary, return to the Tasks pane.
    After you completed the first step in the task, it automatically moved to the next step. The next step uses the Sink tool to identify areas of internal drainage (sinks) within the flow direction layer.
  7. For Input D8 flow direction raster, choose Stowe_flow_direction.
  8. For Output raster, confirm that the output location is the Stowe_Hydrology geodatabase and change the output name to Stowe_sinks.

    Parameters for the Sink tool

  9. Click Run.

    The tool runs and the sink raster is added to the map. The new layer, which contains mostly small groups of black pixels, might be difficult to see with its default symbology. You'll change the symbology to make the sinks easier to see.

  10. In the Contents pane, right-click the Stowe_sinks layer and choose Symbology.

    Symbology for Stowe_sinks

    The Symbology pane appears.

  11. For Color scheme, choose the yellow to red color scheme.

    Yellow to red color scheme

  12. Close the Symbology pane.

    The sinks contrast more with the basemap, but they are still small and difficult to see.

  13. Zoom closer to the outlet (the red circle) to see some of the sinks.

    Sinks close to the outlet

  14. Pan around Stowe and explore the map.

    Sinks seem to appear primarily around stream networks and water bodies identified by the Stowe_surface_water layer. Existing water tends to be flat and can cause errors in a DEM, such as sinks.

  15. In the Contents pane, right-click the Stowe_DEM layer and choose Zoom To Layer. Turn off the Stowe_sinks layer.

    The map returns to the extent of your study area.

Fill sinks

Now that you've identified where sinks exist in your DEM, you'll create a DEM with the sinks removed. In your new DEM, all sinks will be changed to have the elevation value of the lowest cell next to the sink. Each cell in the new DEM will be part of at least one continuous decreasing path of cells leading to an edge of the dataset. This new DEM will allow for more accurate hydrological analysis of the Stowe region.

  1. If necessary, return to the Tasks pane.

    The final step in the current task uses the Fill tool to remove sinks from a DEM.

  2. For Input surface raster, choose Stowe_DEM.
  3. For Output surface raster, confirm that the output location is the Stowe_Hydrology geodatabase and change the output name to Stowe_fill.

    Parameters for the Fill tool

    The final parameter, Z limit, allows you to set a maximum elevation difference at which to fill sinks. If the difference in elevation between a sink and its edge is above the limit, the sink won't be filled. You want to fill all of the sinks in your data, so you'll leave this parameter unchanged.

  4. Click Finish.

    The tool runs and the filled DEM is added to the map. It looks almost identical to the original DEM, but the sinks in the dataset have been filled. You'll use this layer as the basis for your subsequent analysis of hydrological conditions in and around Stowe.

  5. On the Quick Access Toolbar, click the Save button to save the project.

    Save button

In this lesson, you used a series of geoprocessing tools to identify sinks within a raw DEM. Then, you inspected the sinks and found that most of them occurred on or close to surface water bodies, likely due to insufficient elevation data. Lastly, you filled the sinks in the dataset. In the next lesson, you'll use your new DEM to determine the watershed that spans Stowe. Knowing this watershed will help you determine how water will accumulate around the town.


Delineate the watershed

In the previous lesson, you removed sinks from your DEM to make it ready for hydrological analysis. In this lesson, you'll use your DEM to determine the watershed area for the outlet point south of Stowe. A watershed area is the area in which all flowing water will flow toward a certain point—in this case, your outlet. With the watershed area, you'll be able to limit your subsequent analysis results to the relevant area for your outlet. Determining a watershed requires two components: a flow direction raster layer and an accurate outlet point.

Assess flow directions

The first step to delineate a watershed is to determine the direction that water will flow in your DEM. That way, you can determine the areas where water will flow to the outlet. To do so, you'll create another flow direction raster layer, this time for your DEM with filled sinks.

  1. If necessary, open your Stowe_Hydrology project in ArcGIS Pro and the Create unit hydrograph at outlet task.
  2. In the Tasks pane, double-click the Delineate the watershed task.

    Delineate the watershed task

    This task consists of five steps. The first step opens the Flow Direction tool. Instead of using this tool to identify sinks as you did previously, you'll use it to create a critical intermediary layer for determining a watershed area.

  3. For Input surface raster, choose Stowe_fill.
  4. For Output flow direction raster, confirm that the output location is the Stowe_Hydrology geodatabase and change the output name to Stowe_fill_flow_direction.

    Parameters for the Flow Direction tool

    As you did previously, you'll leave the remaining parameters unchanged.

  5. Click Run.

    The tool runs, and the new layer is added to the map.

    Stowe_fill_flow_direction layer

    Unlike the previous flow direction layer, which was symbolized in black and white, this layer is symbolized with color (the specific colors used are random and may differ from the example images).

  6. Open the Contents pane. If necessary, click the arrow to expand the Stowe_fill_flow_direction layer.

    Stowe_fill_flow_direction symbology

    The cell values in a flow direction raster layer can normally be one of only eight integers: 1, 2, 4, 8, 16, 32, 64, and 128. These eight integers correspond to the eight possible flow directions (as any given cell is surrounded by eight cells). Your previous flow direction layer, however, had some values that weren't one of those eight integers. Those values belonged to the sinks that you later removed from the data. Because the original flow direction layer had a wide range of values, it was automatically symbolized based on a color ramp, which uses the default black-to-white color scheme. Your new flow direction layer only has eight values, so it was automatically symbolized with a unique color for each value.

Snap outlet to stream

With your flow direction layer, you have the first component for determining a watershed. The other component is the location of an outlet point. One of the layers that you downloaded with the project is the Pour_point layer, which represents an outlet downstream of Stowe, Vermont. For an accurate watershed, the outlet must be precisely located on the stream as rendered in the DEM (which may differ slightly from the actual location of the stream due to the DEM's resolution or other inaccuracies). First, you'll determine the stream's exact location by calculating the areas where water accumulates the most. Then, you'll snap the outlet point's location to match the stream exactly.

  1. Open the Tasks pane.

    The second step of the task opens the Flow Accumulation tool. This tool creates a raster layer that indicates where water is most likely to accumulate. The flow accumulation for each cell is expressed as a numeric value based on the number of cells that flow into that cell. Cells with high values of accumulation often coincide with the locations of flowing water bodies. With your flow accumulation raster, you'll identify the Little River that flows through Stowe.

  2. For Input flow direction raster, choose Stowe_fill_flow_direction.
  3. For Output accumulation raster, confirm that the output location is the Stowe_Hydrology geodatabase and change the output name to Stowe_flow_accumulation.

    Parameters for the Flow Accumulation tool

    You'll leave the remaining parameters unchanged. The first of these parameters applies a weight to each cell, which is useful when you expect water to be distributed in ways that aren't uniform (for instance, in larger study areas where precipitation levels may vary significantly). The second parameter determines whether accumulation will be measured with integers or floating points. Floating point, the default value, allows for the inclusion of decimal places, making it more accurate in most situations. The third parameter determines the input flow direction.

  4. Click Run.

    The tools runs and the flow accumulation raster layer is added to the map.

    Stowe_flow_accumulation layer

    The cells with the highest flow accumulation are white. The faint line of white cells that runs through the outlet point is the Little River. The next step of the task opens the Measure Distance tool (which is a tool on the ribbon, not a geoprocessing tool). You'll use this tool to measure the distance between the current outlet point and the Little River's location as represented in the flow accumulation raster. You can use this distance to then snap the outlet point to the correct cell so that it precisely lines up with the stream.

    To conduct the measurement, you'll need to zoom closer to the outlet point. However, the Measure Distance tool replaces the Explore tool, reducing your ability to navigate. You can still zoom in using keyboard shortcuts.

  5. Press and hold the Z key. Drag the map to zoom in to the outlet point.
    Tip:

    To pan the map, press and hold the C key.

    Default outlet point

    The outlet is close to the stream's location but doesn't match it exactly. You'll measure the exact distance in meters, the same unit of measurement used by the map.

  6. If necessary, in the Measure Distance window, set the display units to Metric.

    Distance Units in Meters

  7. On the map, click the outlet point. Then double-click the approximate center of the nearest cell with a high flow accumulation value.

    Outlet point measurement

    The Measure Distance tool's window updates to include the length of the measurement. The measurement is approximately 50 meters (it may vary slightly, but an approximation is fine). Based on the measurement, you'll use a distance of 60 meters when you snap the outlet point to the stream. A snapping distance that is slightly higher than the measured distance will help avoid ambiguity in the tool. When deciding on a snapping distance, be sure it doesn't exceed the measured distance by too much, or the point may snap to an area further downstream.

  8. On the ribbon, on the Map tab, in the Navigate group, click the Explore button.

    The measurement is removed from the map. You can now navigate normally.

  9. In the Tasks pane, click Next Step.

    The next step opens the Snap Pour Point tool. This tool automatically snaps a point feature to the cell of highest flow accumulation within a specified distance—in this case, 60 meters.

  10. For Input raster or feature pour point data, choose Pour_point. For Input accumulation raster, choose Stowe_flow_accumulation.
  11. For Output raster, confirm that the output location is the Stowe_Hydrology geodatabase and change the output name to Stowe_snapped_outlet.
  12. For Snap distance, type 60.

    Parameters for the Snap Pour Point tool

  13. Click Run.

    The tool runs and the snapped outlet raster layer is added to the map. The raster displays a single cell that represents the outlet's new location. In the example image, the snapped outlet is represented as a blue cell, but the color is random and may differ from your result.

    Stowe_snapped_outlet layer

  14. In the Contents pane, right-click the Stowe_flow_accumulation layer and choose Zoom To Layer.

    The map returns to the full extent of your data.

Delineate watershed upstream of outlet

Now that you have both a flow direction layer and an accurate outlet layer, you can determine the watershed area upstream of the outlet. The final step of the task opens the Watershed tool.

  1. In the Tasks pane, for Input D8 flow direction raster, choose Stowe_fill_flow_direction. For Input raster or feature pour point data, choose Stowe_snapped_outlet.
  2. For Output raster, confirm that the output location is the Stowe_Hydrology geodatabase and change the output name to Stowe_watershed.

    Parameters for the Watershed tool

  3. Click Finish.

    The tool runs and a new raster layer is added to the map. You'll change the new layer's symbology before you derive any meaning from it.

  4. In the Contents pane, right-click the Stowe_watershed layer and click Symbology.
  5. In the Symbology pane, under Primary symbology, change the symbology method to Unique Values. In the lower part of the pane, on the Values tab, click the color patch and choose a color you like on the color palette.

    Stowe_watershed layer

    This watershed represents all of the area that flows to the specified outlet. The watershed comprises almost the entirety of Stowe's town boundaries, indicating that almost all rainfall that lands in Stowe will go rushing through the actual town, rather than draining away from it.

  6. In the Contents pane, turn off the following layers:
    • Stowe_surface_water
    • Stowe_fill
    • Stowe_fill_flow_direction
    • Stowe_snapped_outlet
    Tip:

    You can collapse the symbology for any layers that are turned off in order to display more layers in the pane.

  7. Save the project.

In this lesson, you determined how water will flow throughout Stowe, Vermont. Based on your results, you snapped your outlet point to the location of the Little River in your DEM. From your flow direction layer and your outlet point, you determined the location of the watershed upstream of the town. In the next lesson, you'll use several of your hydrologic and elevation layers to determine how fast water will flow to the outlet point.


Create a velocity field

In the previous lesson, you created a watershed for the Stowe area, which you'll use as a study area for much of your subsequent analysis. Next, you'll start determining how long it takes water to reach the outlet, allowing the town to better predict when flooding will occur during a hypothetical rainfall event. To determine the time it takes water to flow somewhere, you first need to determine how fast water flows. You'll calculate the speed of flowing water with a velocity field, another type of raster layer. There are many types of velocity fields, and they can be calculated with a wide variety of mathematical equations. You'll create a velocity field that is spatially variant, but time and discharge invariant. This means that your velocity field makes the following assumptions:

  • Velocity is affected by spatial components such as slope and flow accumulation (spatially variant).
  • Velocity at a given location does not change over time (time invariant).
  • Velocity at a given location does not depend on the location's rate of water flow (discharge invariant).

In reality, velocity could be time variant and would definitely be discharge variant. However, incorporating these variants would require additional datasets that might not be available and use modeling techniques that might not be replicable in a GIS environment. The spatially variant, time- and discharge-invariant velocity field will provide a generally accurate result, although it's important to remember that any method will be only an approximation of observed phenomena.

You'll use a method for creating velocity fields first proposed by Maidment et al. (1996). [1] In this method, each cell in the velocity field is assigned a velocity based on the local slope and the upstream contributing area (the number of cells that flow into that cell, or flow accumulation). They use the following equation:

V = Vm * (sbAc) / (sbAcm)    (1)

Where V is the velocity of a single cell with a local slope of s and an upstream contributing area of A. Coefficients b and c can be determined by calibration, a statistical method of tweaking model parameters so that predicted data is as close as possible to observed data. In this scenario, you'll use the method's recommended value of b = c = 0.5. Vm is the average velocity of all cells in the watershed. You'll assume an average velocity of Vm = 0.1 m/s. Lastly, sb Acm is the average slope-area term throughout the watershed. To avoid results that are unrealistically fast or slow, you'll set limits for minimum and maximum velocities. The lower limit will be 0.02 meters per second, while the upper limit will be 2 meters per second.

This equation is only one of many ways that a velocity field can be calculated, and it comes with several assumptions and limitations of its own. Additionally, this workflow can be complicated due to its use of multivariable equations. You've been provided with a backup copy of the velocity field, called Stowe_velocity_example, in case you have difficulty completing the lesson.

Create the slope raster

The primary variables in the equation you'll use for your velocity field are slope and upstream contributing area. You already have a raster layer for upstream contributing area: the flow accumulation layer you created in the previous lesson. You don't yet have a slope layer, so you'll create one.

  1. If necessary, open your Stowe_Hydrology project in ArcGIS Pro and the Create unit hydrograph at outlet task.
  2. In the Tasks pane, double-click the Create a velocity field task.

    Create a velocity field task

    This task has five steps. The first step opens the Slope tool, which calculates a raster layer where the value of each cell is that cell's slope. The slope is determined by the change in elevation between cells, so it requires your original elevation layer as an input.

  3. For Input raster, choose Stowe_DEM.
  4. For Output raster, confirm that the output location is the Stowe_Hydrology geodatabase and change the output name to Stowe_slope.
  5. For Output measurement, choose Percent rise.

    Parameters for the Slope tool

    The Percent rise measurement option calculates slope as a percentage of vertical elevation over horizontal elevation, as opposed to a measurement in degrees. You'll leave the remaining parameters unchanged. The planar method is appropriate to use on local scale areas (small areas such as this watershed) where slope differences between planar and geodesic methods are minimal. The Z factor is only used if the units for measuring X and Y distance are different from the units for measuring Z (height) distance.

  6. Click Run.

    The tool runs and a slope raster is added to the map.

    Stowe_slope layer

    The darker colors have a steeper slope. While the mountain peaks tend to have the highest slopes, the stream bed, around which the town is located, have a relatively flat slope.

Calculate the slope-area term

Now that you have a raster layer for both slope and flow accumulation area, you'll calculate a new raster layer that combines them. This layer will show the slope-area term (the value sb Ac from the Maidment et al. equation). The next step of the task opens the Raster Calculator tool, which allows you to create customized raster layers based on an equation that you specify.

  1. For the Map Algebra expression, use the Tools and Rasters to create the following expression:

    SquareRoot("Stowe_slope") * SquareRoot("Stowe_flow_accumulation")

    Tip:

    Alternatively, you can copy and paste the expression.

    The reason you're finding the square root of the slope and flow accumulation is because you're using the recommended coefficients (b = c = 0.5) of Maidment et al. A coefficient of 0.5 is equivalent to the square root of the value.

  2. For Output raster, confirm that the output location is the Stowe_Hydrology geodatabase and change the output name to Stowe_slope_area_term.

    Parameters for the Raster Calculator tool

    Lastly, you'll change the environment for the geoprocessing tool so that the output layer is masked (or limited) by the extent of the Stowe watershed. By doing so, you'll later be able to calculate the average slope-area term throughout the watershed, which is a key component of your velocity field equation.

  3. Above the tool parameters, click Environments. For Mask, choose Stowe_watershed.

    Environments for the Raster Calculator tool

  4. Click Run.

    The tool runs and the layer is added to the map.

    Stowe_slope_area_term layer

Calculate the velocity field

Now that you have the slope-area term, you can calculate a velocity field using the following equation:

V = Vm (sb Ac) / (sb Acm)    (1)

As mentioned previously, Vm is the average velocity of all cells in the watershed. You'll use an assumed average value of Vm = 0.1, which is recommended by Maidment et al. Similarly, sb Acm is the average slope-area term across the watershed. Because you've calculated slope-area term for the watershed, you can determine the exact average rather than relying on an assumed value.

  1. In the Contents pane, right-click Stowe_slope_area_term and choose Properties.

    The Layer Properties window for the slope-area term layer appears.

  2. Click the Source tab and expand the Statistics heading.

    Layer Properties window Source tab

    The window lists several important statistics about the layer, including its average (mean).

  3. Copy the Mean value to your clipboard. Close the Layer Properties window.
  4. Return to the Tasks pane.

    The next step of the task also uses the Raster Calculator tool.

  5. For Map Algebra expression, create the following expression:

    0.1 * ("Stowe_slope_area_term" / [Mean slope-area term])

    Where [Mean slope-area term] is the value that you copied from the Layer Properties window.

  6. For Output raster, confirm that the output location is the Stowe_Hydrology geodatabase and change the output name to Stowe_velocity_unlimited.

    Parameters for the Raster Calculator tool

  7. Click Run.

    The tools runs and the layer is added to the map. The new layer looks similar to the slope-area term layer because it was calculated by multiplying the cells in the slope-area term layer with fixed values.

  8. If necessary, in the Contents pane, expand the symbology for the Stowe_slope_area_term and Stowe_velocity_unlimited layers.

    Symbology for the two layers

    The values in the layer symbology confirm that the two layers are different, even if they look the same.

Limit the velocities

The raster layer you created is a velocity field, but it has unrealistically high and low velocities. For instance, some values in the field have a velocity of 0 meters per second, which is unlikely during an extreme rainfall event. Likewise, the maximum value of approximately 7.5 meters per second is unrealistic even during a major flood. You'll limit the velocity values with a lower limit of 0.02 meters per second and an upper limit of 2 meters per second.

  1. Return to the Tasks pane.

    The next step of the task uses the Con tool, which performs a conditional evaluation of the values in a raster layer based on an expression you specify. First, you'll set the lower limit for velocity.

  2. For Input conditional raster, choose Stowe_velocity_unlimited.
  3. For Expression, click New expression. Create the clause Where VALUE is greater than or equal to 0.02.

    Con tool clause for lower limit

    Next, you'll add the value to use for each cell if the clause is true. Because you want to keep the values the same if they are greater than or equal to 0.02, you'll choose the same raster layer as the input layer.

  4. For Input true raster or constant value, choose Stowe_velocity_unlimited.

    If the clause is false for a cell (meaning the cell value is less than 0.02), you'll change the cell value to 0.02.

  5. For Input false raster or constant value, type 0.02.
  6. For Output raster, confirm that the output location is the Stowe_Hydrology geodatabase and change the output name to Stowe_velocity_lower_limited.

    Parameters for the Con tool for lower limit

  7. Click Run.

    The tool runs and a new layer is added to the map. The new layer is only an intermediary layer, however, because you still need to add the upper limit. The final step of the task also uses the Con tool.

  8. For Input conditional raster, choose Stowe_velocity_lower_limited.
  9. For Expression, add the clause Where VALUE is less than or equal to 2.
  10. For Input true raster or constant value, choose Stowe_velocity_lower_limited. For Input false raster or constant value, type 2.
  11. For Output raster, confirm that the output location is the Stowe_Hydrology geodatabase and change the output name to Stowe_velocity.

    Parameters for the Con tool for upper limit

  12. Click Finish.

    The tool runs and your finished velocity field layer is added to the map.

    Stowe_velocity layer

    In this layer, darker colors represent a slower velocity, while lighter colors represent a faster velocity. Water tends to flow fastest in streams, where the largest amount of water has accumulated. The area around Stowe is no exception, indicating that water will flow at its fastest when funneling toward the outlet point downstream of the town.

  13. In the Contents pane, turn off the following layers:
    • Stowe_flow_accumulation
    • Stowe_watershed
    • Stowe_slope
    • Stowe_slope_area_term
    • Stowe_velocity_unlimited
    • Stowe_velocity_lower_limited
  14. Save the project.

In this lesson, you derived a spatially variant, time- and discharge-invariant velocity field from flow accumulation and slope raster layers. You used one of many formulas that can calculate velocity fields to do so. Now that you know how fast water is flowing through Stowe during your hypothetical rainfall event, you'll determine how long it takes water to flow to the outlet in the next lesson.


Create an isochrone map

In the previous lesson, you used your flow accumulation and watershed layers to create a velocity field that predicts how fast water will flow throughout Stowe, Vermont. Your velocity field showed that water will move fastest along the streams leading through town, but you still can't create a unit hydrograph because you don't know the time it will take water to flood to your outlet point. In this lesson, you'll create an isochrone map, which maps the time it takes to reach a specified location from anywhere else in an area. To create the isochrone map, you'll first create a weight grid. Then, you'll assess the time it takes for water to reach the outlet and reclassify those times into isochrone zones.

Create a weight grid

Flow time is calculated with a relatively simple equation: The length that water must flow divided by the speed at which it flows. While you know how fast water flows due to your velocity field, you don't know flow length. To determine flow length, you need two variables: flow direction (which you know) and weight (which you don't). Weight, in regard to flow, represents impedance. For instance, water flowing through forested land takes longer than water flowing over smooth rock because it's impeded by terrain. While calculating weight may seem difficult without detailed terrain data, you can derive an equation to calculate it based on the following two equations for finding flow time:

Flow time [T] = Flow Length [L] / Velocity [LT-1]    (1)

Flow time [T] = Flow Length [L] * Weight [L-1T]    (2)

By combining these equations, you get a new equation:

Weight [L-1T] = 1 / Velocity [LT-1]    (3)

Thus, you can determine weight using your velocity field layer. Later, you'll use your weight grid layer in conjunction with your flow direction layer to determine flow length and flow time.

  1. If necessary, open your Stowe_Hydrology project in ArcGIS Pro and the Create unit hydrograph at outlet task.
  2. In the Tasks pane, double-click the Create an isochrone map task.

    Create an isochrone map task

    The task has four steps. The first step opens the Raster Calculator tool. You'll input the weight equation to create a weight grid of the Stowe watershed.

  3. For Map Algebra expression, create (or copy and paste) the following expression:

    1 / "Stowe_velocity"

  4. For Output raster, confirm that the output location is the Stowe_Hydrology geodatabase and change the output name to Stowe_weight.

    Parameters for the Raster Calculator tool

  5. Click Run.

    The tool runs and a weight grid raster layer is added to the map.

    Stowe_weight layer

    While this layer doesn't tell you much by itself, you can use it in conjunction with the flow direction layer you created earlier in order to determine flow time.

  6. In the Contents pane, turn on Stowe_fill_flow_direction.

    You created the flow direction layer before you determined the Stowe watershed, so the layer's extent covers far more than your area of interest. You'll extract a new version of the flow direction layer that only covers the watershed.

  7. Return to the Tasks pane.

    The next step of the task uses the Extract by Mask tool, which clips a raster layer to a certain extent based on the extent of another layer.

  8. For Input raster, choose Stowe_fill_flow_direction. For Input raster or feature mask data, choose Stowe_watershed.
  9. For Output raster, confirm that the output location is the Stowe_Hydrology geodatabase and change the output name to Stowe_watershed_flow_direction.

    Parameters for the Extract by Mask tool

  10. Click Run.

    The tool runs and an extracted flow direction raster is added to the map.

    Stowe_watershed_flow_direction layer

    Now that you've extracted your flow direction layer, you don't need to display the old one on the map.

  11. In the Contents pane, turn off the Stowe_fill_flow_direction layer. Then, return to the Tasks pane.

Assess flow time to outlet pour point

You finally have all the layers you need to determine flow time. The next step of the task uses the Flow Length tool. While this tool, as its name suggests, normally calculates flow length, it has an optional parameter to include a weight raster. When a weight raster is included, the tool calculates flow time instead.

  1. For Input flow direction raster, choose Stowe_watershed_flow_direction.
  2. For Output raster, confirm that the output location is the Stowe_Hydrology geodatabase and change the output name to Stowe_time.
  3. For Direction of measurement, confirm that Downstream is chosen.
  4. For Input weight raster, choose Stowe_weight.

    Parameters for the Flow Length tool

  5. Click Run.

    The tool runs and a raster representing flow time to outlet is added to the map.

    Stowe_time layer

    Each cell in this raster layer contains a value that represents the time in seconds for water to flow to the outlet from the cell. Darker colors represent shorter flow times. Water takes the least amount of time to flow from the low-lying stream beds closest to the outlet, while water falling in the western mountains takes longer.

  6. If necessary, in the Contents pane, expand the symbology for the Stowe_time layer.

    Symbology for the Stowe_time layer

    The time it takes water to flow to the outlet ranges from 0 seconds (rain that falls on the outlet itself) to about 47,000 seconds—over 13 hours!

Reclassify flow time into isochrone zones

Your flow time raster layer contains an extremely high number of unique values, which will make subsequent analysis complicated and unwieldy. To make things easier, you'll reclassify the flow time layer into isochrone zones.

An isochrone is a contour line that passes through points of roughly equal travel time to the outlet of the watershed. You'll define isochrones at equal time intervals of 1,800 seconds (or 30 minutes). For larger areas, isochrones can use different intervals, but for the Stowe watershed, this time interval should be appropriate. With this time interval, every cell in the first isochrone zone will take about 1,800 seconds to reach the outlet, every cell in the second isochrone zone will take about 3600 seconds, and so on. You'll later use these time intervals as the ordinate in your unit hydrograph.

The next step of the task opens the Reclassify tool. You'll use this tool to classify flow time values that fall between a specific range of values (say, 0 and 1,800 or 1,800 to 3,600) to the upper limit of the range. Thus, a value of 907 would be reclassified to 1,800, while a value of 2,145 would be reclassified to 3,600.

  1. For Input raster, choose Stowe_time.

    Next, you'll input the reclassification values. The times in your flow time layer range from 0 to about 47,000 seconds, so you'll need to provide reclassification intervals that cover all values. While you can manually input the intervals, the process can be tedious. For the purposes of this lesson, you'll load a table that already contains the time intervals for the Stowe watershed. This table was included with the project when you downloaded it in a previous lesson.

  2. For Reclassification, under the empty table, click the Load remap from table button (the file folder icon).
  3. In the Load Remap window, browse to the Stowe_Hydrology folder (click Project > Folders > Stowe_Hydrology). Double-click Stowe_isochrones.txt to choose it.
    Note:

    If the Confirm overwrite window appears, choose Yes.

    The reclassification values from the table are automatically loaded into the tool. There are 27 isochrones in total.

  4. For Output raster, confirm that the output location is the Stowe_Hydrology geodatabase and change the output name to Stowe_isochrones.

    Parameters for the Reclassify tool

    The table you loaded reclassifies values within the entirety of the flow time layer's range of values, so you don't need to check Change missing values to NoData.

  5. Click Finish.

    The tool runs and the isochrone layer is added to the map.

    Stowe_isochrones layer

    The default symbology of the layer doesn't tell you much, because the 27 isochrone ranges from the table you used have been symbolized with only 9 different symbols. You'll change the symbology to a continuous color scheme, which will display all 27 isochrones with a different color.

  6. In the Contents pane, right-click Stowe_isochrones and choose Symbology.

    The Symbology pane appears. You'll symbolize the layer with unique symbols on a black to white color scheme.

  7. For Symbology, choose Unique Values. For Color scheme, choose the Black to White color scheme.

    Symbology pane parameters

    The layer symbology automatically updates on the map.

    Stowe_isochrones layer with new symbology

    With this symbology, it's easier to pick out the individual isochrones.

    Tip:

    Symbolizing each unique value causes the symbology in the Contents pane to take up a lot of space. You can collapse the symbology for the layer and any other layers to show more layers in the pane.

  8. Close the Symbology pane.

    Next, you'll open the layer's attribute table to see how many cells were classified into each isochrone and to select specific isochrones for closer examination.

  9. In the Contents pane, right-click Stowe_isochrones and choose Attribute Table.

    The table appears. It shows the value and count of cells for each isochrone.

  10. If necessary, move or resize the attribute table so that all of the Stowe_isochrones layer is visible on the map.
  11. Click the box to the left of the first row in the attribute table.

    First row of the attribute table

    The row in the table is selected. The corresponding isochrone is also selected on the map.

    First isochrone selected

    As you probably expected, the first isochrone consists of the stream bed closest to the outlet. Based on the values in the table, only approximately 700 cells are in the first isochrone, which represents water that reaches the outlet within 1,800 seconds (30 minutes). Other isochrones have many more cells, meaning that far more water will reach the outlet point several hours after a rainfall event than when the event first begins.

  12. Select some of the other rows in the attribute table. In particular, select some of the isochrones with the highest count of cells.

    The larger isochrones often include cells from areas all throughout the watershed, which happen to rush to the outlet at about the same time period.

  13. When you finish exploring the isochrone map, close the attribute table. On the Map tab, in the Selection group, click the Clear button.

    Clear button

    Any selections you made are cleared.

  14. In the Contents pane, turn off the following layers:
    • Stowe_velocity
    • Stowe_weight
    • Stowe_watershed_flow_direction
    • Stowe_time
  15. Save the project.

In this lesson, you used your velocity field raster layer to create a weight grid. This weight grid represented impedance to downstream flow and helped you create a flow time raster layer. You then reclassified flow times into 27 isochrones with an equal interval time of 1,800 seconds. In the next lesson, you'll convert your isochrone map into a table. You'll use this table to develop a time-discharge relationship at the outlet for unit excess rainfall that occurs uniformly, over the entire watershed, in intervals of 1,800 seconds. Finally, you'll plot this relationship to create your unit hydrograph.


Create a unit hydrograph

In the previous lesson, you created an isochrone map for the watershed area. In this lesson, you'll convert the isochrone map into a table that will show the relationship between time and the area of water flowing into the outlet. Then, you'll use this table to plot a unit hydrograph that will show the times at which the most water flows into the outlet, allowing for better flood prediction in future rainfall events.

Prepare the unit hydrograph table

To create a unit hydrograph, you'll first derive a stand-alone table from your isochrone map's attribute table. The attribute table currently measures the area of each isochrone in number of cells, so you'll also convert the area into metric units.

  1. If necessary, open your Stowe_Hydrology project in ArcGIS Pro and the Create unit hydrograph at outlet task.
  2. In the Tasks pane, double-click the Create a unit hydrograph task.

    Create a unit hydrograph task

    The task has five steps. The first step opens the Table to Table tool, which can convert a table (including an attribute table) into a stand-alone table stored in a geodatabase.

  3. For Input Rows, choose Stowe_isochrones.
  4. For Output Location, confirm that the output location is the Stowe_Hydrology geodatabase. For Output Name, type Stowe_isochrones_table.

    Parameters for the Table to Table tool

    You can use the remaining parameters to create an expression that will select a subset of the input table records. When you looked at the layer's attribute table in the previous lesson, all of its records were valuable, so you won't change these parameters.

  5. Click Run.

    The tool runs and a new table is added to the Contents pane. Currently, this table is identical to the Stowe_isochrones layer attribute table. While that table has fields for both of the sets of values necessary to create a unit hydrograph (time and drainage area per time), the drainage area is measured in cells, not metric units. The next step of the task opens the Add Field tool, which you'll use to add a new field to the table in order to calculate area in square meters.

  6. For Input Table, choose Stowe_isochrones_table.
  7. For Field Name, type Area_meters. For Field Type, choose Double.

    The Double field type can store values with many decimal places. With this format, your area values will be more precise. The next two parameters, Field Precision and Field Scale, allow you to limit the number of digits and decimal places in the field, so you'll leave these parameters empty.

  8. For Field Alias, type Area (Sq. Meters).

    Parameters for the Add Field tool

    The remaining parameters provide further options for fields. You're doing a simple area field, so these parameters aren't important and can be left unchanged.

  9. Click Run.

    The tool runs and a new field is added to your stand-alone table. You'll open the table to confirm the field was added correctly.

  10. In the Contents pane, right-click Stowe_isochrones_table (it's located at the bottom of the list of layers) and choose Open.

    The table appears.

    Default isochrones table

    The field was correctly added with the field alias you specified. However, the field currently has no values.

  11. Close the table. Return to the Tasks pane.

    The next step of the task opens the Calculate Field tool. You'll use this tool to calculate the area, in square meters, of each isochrone. When you first opened the project in a previous lesson, you were told that your original Stowe_DEM layer had a cell size of 30 meters, meaning that each cell had an area of 30 meters by 30 meters. Because all of your subsequent layers were in some way based on the DEM layer, they have the same cell size. That means you can calculate area by multiplying the Count field in your table by the dimensions of a single cell.

  12. For Input Table, choose Stowe_isochrones_table. For Field Name, choose Area (Sq. Meters).
  13. For Expression, create the expression !Count! * 30 * 30.

    Parameters for the Calculate Field tool

  14. Click Run.

    The tool runs and the field is calculated. If you like, you can check the table to confirm the values were calculated correctly. The next step of the task reopens the Add Field tool. You still have one more field to add to the table, although it's based on the table's existing fields. This field will contain the unit hydrograph ordinate, which shows discharge at the outlet per second.

    If you created a graph that showed time on one axis and drainage area on another, you'd only know how much water is reaching the outlet over periods of 1,800 seconds (or 30 minutes). This interval was useful for binning the original flow time layer's high number of unique values into a more manageable 27 unique values. However, in a hypothetical emergency situation, 30 minutes can mean the difference between life and death. Stowe municipal authorities will need a more precise time frame by which to plan. Your new field will estimate the amount of water reaching the outlet each second.

    Unit hydrograph ordinate, Ui, at time iΔt, where i = 1,2,….n, is given by the slope of the time-cumulative area diagram over the interval [(i - 1)Δt,iΔt]. This is given by the following equation:

    Ui = U(it) = (A(it) - A[(i - 1)∆t]) / ∆t    (1)
    • where:
      • A(t) is the cumulative drainage area that drains to the outlet within time t since rainfall began.

    Equation (1) can be rewritten as follows:

    Ui = Ai / ∆t    (2)

    • where:
      • Ai is the incremental drainage area of the ith isochrone zone.
  15. Set the tool with similar parameters as you used in the second step in the task, but name the field UH_ordinate and give it an alias Unit Hydrograph Ordinate.

    Parameters for the Add Field tool

  16. Click Run.

    The tool runs and the field is added to the table. As before, you'll calculate the field. The next step of the task reopens the Calculate Field tool. You'll divide the drainage area by the time interval (1,800) to calculate area per second.

  17. For Input Table, choose Stowe_isochrones_table. For Field Name, choose Unit Hydrograph Ordinate.
  18. For Expression, create the expression !Area_meters! / 1800.

    Parameters for the Calculate Field tool

  19. Click Finish.

    The tool runs and the field is calculated.

  20. Open the table to confirm the calculation. When finished, close the table.

Plot the unit hydrograph

In ArcGIS Pro, you can make a chart from any stand-alone table. You'll use this functionality to create a unit hydrograph from the ordinate field in your table.

  1. In the Contents pane, click the Stowe_isochrones_table once to select it.

    Selecting the table causes a contextual tab to be added to the ribbon. This tab includes options specific to stand-alone tables.

  2. On the ribbon, click the Data tab. In the Visualize group, click Create Chart and choose Line Chart.

    Line Chart option

    The Chart pane and the Stowe_isochrones_table - Line Chart 1 window open.

  3. In the Chart pane, on the Data tab, for Date or Number, choose Value.

    When you change the parameter, the window automatically updates with an example chart. The Value field is the x-axis and the COUNT field has automatically been supplied as the y-axis. You want your chart to show the unit hydrograph ordinate instead of the count of cells.

  4. In the Chart pane, for Aggregation, choose <none>.

    Variables for the unit hydrograph

  5. Under Series, check the Unit Hydrograph Ordinate box and click Apply.

    Fields for the unit hydrograph

    Next, you'll change your chart's title and axis labels to better explain what the graph is showing.

  6. In the Chart pane, click the General tab.
  7. For Chart title, type Unit Hydrograph at outlet point.
  8. For X axis title, type Time (seconds). For Y axis title, type Discharge at outlet per unit of excess rainfall (sq. meters per second).

    The chart in the window updates automatically with the new titles. Your unit hydrograph for the outlet is now completed.

    Unit hydrograph

    Note:

    The increments shown on the axes of your unit hydrograph, as well as the unit hydrograph's size, depends on the size of the window.

  9. Save the project.

In this lesson, you converted your isochrone zones into a table. Then, you added fields to the table to calculate the water drainage area for each isochrone in square meters and determine the unit hydrograph ordinate. Lastly, you used your table to create a unit hydrograph that shows when water discharge at the outlet is at its height during a predicted rainfall event. Ultimately, your results will help officials in Stowe plan for and respond to flood events more effectively.

You can find more lessons in the Learn ArcGIS Lesson Gallery.