Prepare data for analysis

Obstacle analysis is critical for ensuring safe and efficient operation of aircraft. It involves a spatial analysis of all obstacles around an airfield against a surface that represents minimum operating levels for aircraft approaching and departing the airport. ArcGIS Aviation Airports has several geoprocessing tools that allow you to import, analyze, and visualize obstacles that may present a safety hazard to aircraft.

Download the data

To start, you must download and open a project with aviation features in ArcGIS Pro.

  1. Download the ObstacleAnalysis project package (.ppkx file).
  2. Double-click the ObstacleAnalysis project package to open it in ArcGIS Pro. If prompted, sign in to your ArcGIS account or ArcGIS Enterprise account.
    Note:

    If you don't have ArcGIS Pro or an ArcGIS account, you can sign up for an ArcGIS free trial.

    The project opens and a map containing aviation features appears.

  3. On the ribbon, click the Project tab and click Save As to save this project to a local file on your hard drive.
  4. Specify a name of the project in your Projects folder.
    Note:

    Before continuing, ensure that ArcGIS Pro is configured with the ArcGIS Aviation Airports extension.

  5. Click the Project tab, click the Licensing tab, and in the Esri Extensions table, verify that Aviation Airports has a Licensed status of Yes.

    If the extension is licensed, proceed with the lesson. If it is not, you can request a trial license.

  6. Click the Back button to return to the project.

    The project contains layers of points, lines, and polygons that represent features at San Francisco International Airport (SFO). In the Contents pane, you will find the following features:

    • VerticalStructurePoint—A point feature class that will hold obstacle features.
    • AirportControlPoint—A point feature class containing airport elevation and runway displaced threshold features.
    • ObstructionIdSurface_MP—A multipatch feature class that will hold obstruction identification surfaces.
    • RunwayCenterline—A polyline feature class containing runway center line features at SFO.
    • Runway—A polygon feature class representing runways at SFO.

    The ObstructionIdSurface_MP feature class is empty, but the layer has been symbolized by surface type. An obstruction identification surface is made of several component surfaces. The following diagram shows the types of surfaces contained in a typical obstruction identification surface. You'll create an approach surface later.

    Typical obstruction identification surface components

    An OIS includes the following components:

    1

    Conical surface

    2

    Horizontal surface

    3

    Approach surface

    4

    Transitional surface

Acquire obstacle data

Now that you're familiar with the feature classes in the project, you will populate the VerticalStructurePoint feature class with obstacle data from the Federal Aviation Administration (FAA). The FAA distributes a Digital Obstacle File (DOF) that contains obstacle data for all 50 states as well as United States-controlled airspace.

The FAA's DOF is released on a regular basis under a public domain license. You can download the most recent DOF from the FAA's website, but for this lesson you can use this sample DOF from November 2020.

  1. Download the SourceData package.
  2. Extract the compressed files to a folder on your computer.
  3. In ArcGIS Pro, on the ribbon, click the View tab and click Catalog Pane.

    Open the Catalog pane.

  4. In the Catalog pane, right-click Folders and click Add Folder Connection.
  5. Browse to the SourceData folder you extracted and click OK.
  6. Expand Folders and expand the SourceData folder.

    The SourceData folder contains two files. The 06-CA.DAT file is a DOF containing obstacles in the state of California. The ProposedObstacles.lpkx file is a layer package containing additional obstacles that are not in the DOF.

  7. On the ribbon, on the View tab, click Geoprocessing to open the Geoprocessing pane, and dock it next to the Catalog pane.
  8. In the Geoprocessing pane, click the Find Tools box and type Import Digital Obstacle File.
  9. Click Import Digital Obstacle File.

    The Import Digital Obstacle File tool opens.

    Note:

    If you get a Tool is not licensed message, you do not have a license for ArcGIS Aviation Airports. You can request a trial license. You will not be able to proceed with this lesson until you have a license.

  10. For Input Digital Obstacle File, browse to the 06-CA.DAT file from the SourceData folder.

    Import the 06-CA.Dat DOF file.

  11. For Target Obstacle Features, choose the VerticalStructurePoint feature class.
  12. Click Run.

    The Import Digital Obstacle File tool runs and obstacle points are added to the map.

    DOF points added to the VerticalStructurePoint layer

    You've loaded obstacle data points from the DOF into the VerticalStructurePoint feature class. Each of these points represents a human-made obstacle. You can click these data points to view their attributes.

    The VerticalStructurePoint feature class includes attributes that describe the type of obstacle, the height of the obstacle above mean sea level, the obstacle's height above the surface, and more. The FAA's DOF is updated every 56 days. The DOF you imported does not contain obstacle data for cranes that will be brought in to do planned construction on the rental car facility, so you will add those next.

Add a layer package containing obstacles

The data you downloaded in the SourceData package includes a layer for possible crane locations for the planned construction. Now you'll add that data to the map.

  1. In the Catalog pane, click the SourceData folder.
  2. Right-click the ProposedObstacles.lpkx and click Add To Current Map.

    Add the layer package to the map.

    The ProposedObstacles.lpkx file is a layer package that contains additional obstacles that are not in the DOF.

  3. In the Contents pane, right-click the ProposedObstacles layer and click Zoom To Layer.

    The ProposedObstacles layer contains eight point features (symbolized with open blue circles) representing possible locations of a construction crane.

    Proposed Obstacles layer on the map

  4. Click one of the features to view its attributes.

    A pop-up window appears containing the attribute Elev_Val, which contains the elevation above mean sea level at the top of the crane. You will use the Elev_Val field to visualize these obstacles in 3D later in this lesson.

  5. Close the Pop-up window.

Now you've prepared the project for analysis by loading the DOF data and adding the proposed crane locations to the map. The next step is to begin analyzing the data.


Analyze airport obstacles

Now you'll create surfaces for the airport that you will use to identify if any of the obstacles that you've added to the project will pose a hazard to aircraft.

Create obstruction identification surfaces

Obstruction identification surfaces (OIS) are multipatch or polygon features that represent the clearance between an aircraft in the air and obstacles on the earth's surface. This image shows an approach OIS surface in 3D for a runway at a municipal airport.

Sample obstruction identification surface

This image shows that the height of the OIS (1) changes as the surface slopes down toward the runway (2). For this exercise, you are interested in obstacles whose heights intersect the OIS at any point on its slope down to the runway. Those penetrating obstacles may present a hazard to flight operations.

ArcGIS Aviation Airports contains several geoprocessing tools to generate an OIS for different specifications. Aviation authorities, such as the FAA and ICAO, provide standards and specifications for OIS creation. You will be creating an OIS using the FAA FAR 77 geoprocessing tool.

  1. On the map, zoom out until you can see the airport runways with their labels.
  2. On the ribbon, in the Selection group, click the Map tab and click Select.

    Select tool in the Selection group

  3. Click the runway 10R/28L centerline to select it.

    The 10R/28L runway is selected

  4. On the Geoprocessing pane, search and choose FAA FAR 77 tool.

    The FAA FAR 77 tool opens.

  5. In the FAA FAR 77 tool, enter the following:
    • For Input Runway Features, choose RunwayCenterline.
    • For Target OIS Features, choose ObstructionIdSurface_MP.
    • For High Runway End Classification, choose Non precision instrument runway greater than (>) 3/4 mile.
    • For Low Runway End Classification, accept the default value of Same as high runway end classification.
    • For Input Airport Control Point Feature, choose AirportControlPoint.

    Parameters for the FAA FAR 77 tool

  6. Click Run.

    The FAA FAR 77 geoprocessing tool runs, and the OIS features for the selected runway, 10R/28L, are added to the ObstructionIdSurface_MP feature class.

  7. Zoom out to view the full extent of the updated ObstructioniDSurface_MP layer.

    OIS results for the selected runway, 10R/28L.

  8. On the ribbon, in the Map tab, in the Selection group, click Clear.

    You can also run the tool on all of the runways for an airport, but for simplicity in this exercise, you’re just doing it for this selected runway.

    The OIS you generated includes approach, conical, horizontal, primary, and transitional surfaces. Since you are interested in obstacles at the end of runway 10R, you will only analyze the approach surfaces.

Set a definition query for approach surfaces

You can use a definition query to filter which surfaces are visible based on their attribution.

  1. In the Contents pane, right-click the ObstructionIdSurface_MP layer and click Properties.
  2. In the Layer Properties pane, click Definition Query.
  3. Click New definition query.
  4. Set the query values to the following: Where Name is equal to Approach Surface.

    Query where Name is equal to Approach Surface

  5. Click Apply.
  6. Click OK.

    The definition query is applied, and only the approach surfaces are shown on the map.

    Only the approach surfaces are shown on the map

Analyze runway obstacles

On the map, you can see several obstacles that overlap with the approach surfaces at either end of this runway. These existing obstacles are symbolized with blue dots, and the proposed obstacles associated with the construction are symbolized with large blue circles. There appear to be significantly more obstacles at the low-end of this runway when compared to the high-end, as shown in the image below.

OIS and possible obstacles

While you can assume each of these obstacles may interfere with an aircraft's ability to take off or land at this runway, only obstacles that penetrate the OIS are considered a flight hazard.

The Analyze Runway Obstacles geoprocessing tool compares the elevation values of the obstacles with the height of the approach surface as it slopes down to a runway. This tool outputs a new feature class that describes how each input obstacle interacts with the OIS approach surface.

Now you’ll use the Analyze Runway Obstacles geoprocessing tool to determine which features intersect the OIS approach surface and should be classified as flight hazards.

  1. On the Geoprocessing pane, click the Back button and in the search bar, type Analyze Runway Obstacles.

    The Analyze Runway Obstacles geoprocessing tool appears in the search results.

  2. Click the Analyze Runway Obstacles tool.
  3. In the Analyze Runway Obstacles tool pane, enter the following:
    • For Input OIS Features, choose the ObstructionIdSurface_MP layer.
    • For Input Obstacle Features, choose the VerticalStructurePoint layer.
    • In the Output Obstacle Feature Class box, type DOF_Hazards.
    • For Obstacle Height, choose Elev_Val.
    • For Unit, choose Feet.

    Analyze Runway Obstacles tool.

  4. Click Run.

    The Analyze Runway Obstacles tool runs and the DOF_Hazards feature layer is added to the Contents pane.

    The DOF_Hazards feature layer contains several features, indicating multiple points that are within the OIS.

  5. In the Contents pane, right-click the DOF_Hazards layer and click Attribute Table to see the attributes.

    This diagram shows an obstacle penetrating an OIS and the corresponding field values.

    Obstacle attributes diagram

    1

    Obstruction Identification Surface (OIS)

    2

    The obstacle.

    3

    The Delta_Z field value.

    4

    The OIS_Z field value.

    5

    The Z field value.

    The Delta_Z field refers to the height of the obstacle above or below the OIS. Features with a negative Delta_Z value are below the OIS, while features with a positive or zero Delta_Z value are penetrating the OIS.

Use a definition query to show penetrating obstacles

Next, you'll set a definition query on the DOF_Hazards feature layer to determine the exact number of obstacles that penetrate the OIS.

  1. In the Contents pane, right-click the DOF_Hazards layer and click Properties.
  2. In the Layer Properties window, click Definition Query.
  3. Click New definition query.
  4. Set the query values to the following: Where Delta_Z is greater than or equal to 0.

    Definition Query Where Delta_Z is greater than or equal to 0

  5. Click Apply.
  6. Click OK.

    The definition query is applied.

  7. On the Contents pane, right click DOF_Hazards and click Zoom To Layer.

    Six penetrating DOF obstacles are shown on the map.

    Note:

    The symbology color of the layer are randomly generated and may differ from the example image, but it does not impact the results of the analysis.

    Six obstacles penetrate the OIS

Analyze runway obstacles

Next you will use the Analyze Runway Obstacles geoprocessing tool to analyze obstacles from the ProposedObstacles feature layer.

  1. In the Geoprocessing pane, search for and open the Analyze Runway Obstacles geoprocessing tool.
  2. In the Analyze Runway Obstacles tool pane, enter the following:
    • For Input OIS Features, choose the ObstructionIdSurface_MP feature layer.
    • For Input Obstacle Features, choose the ProposedObstacles feature layer.
    • In the Output Obstacle Feature Class box, type Construction_Hazards.
    • For Obstacle Height, choose Elev_Val.
    • For Unit, choose Feet.

    Analyze Runway Obstacles tool pane with parameters entered

  3. Click Run.

    The Analyze Runway Obstacles tool runs and the Construction_Hazards feature layer is added to the Contents pane.

    The Construction_Hazards feature layer contains eight features.

    Construction hazards

    You will use a definition query similar to the one you used for DOF obstacles to show obstacles that penetrate the OIS.

Use a definition query to show penetrating obstacles

Now you'll build the definition query on the proposed construction crane sites.

  1. In the Contents pane, right-click the Construction_Hazards layer and click Properties.
  2. In the Layer Properties dialog box, click Definition Query.
  3. Click New definition query.
  4. Set the query values to the following: Where Delta_Z is greater than or equal to 0.

    Definition Query Where Delta_Z is greater than or equal to to 0

  5. Click Apply.
  6. Click OK.

    The definition query is applied, and two Construction_Hazard features are shown on the map.

    Construction Hazards—two features penetrating the OIS plane

    This indicates that two of the proposed cranes for the construction on the rental car facility, shown with yellow circles, may pose a risk to flight operations.

You've created the OIS surfaces and compared the DOF hazards and the proposed construction crane sites to them. You determined that two of the proposed construction crane sites may pose a hazard.


Visualize the airport and obstacles in 3D

You can visualize your OIS and obstacle data in 3D with ArcGIS Pro. Viewing your data in 3D allows you to gain additional insights about flight hazards along an approach surface.

Convert the map to a scene

You'll convert the current map to a 3D scene.

  1. On the ribbon, click the View tab.
  2. In the View group, click Convert and click To Local Scene.

    In the View tab, convert the map to Local Scene.

    A new tab opens with a 3D scene containing the same layers as your map. This is a local scene, which is better for showing local scale data than a global scene. Local scenes support local coordinate systems, such as the State Plane coordinate system used in this map.

Apply 3D symbology to the DOF Hazards layer

Now that the map has been converted to a local scene, you can symbolize your obstacle data in three dimensions. First, you'll extrude the obstacle features to their true height above the surface.

  1. In the Contents pane, right-click DOF_Hazards and click Properties.

    The Layer Properties window opens.

  2. In the Layer Properties window, click the Elevation tab.
  3. For Features are, choose On the ground and click OK.

    Setting this option ensures that your features are extruded from their base on the earth's surface.

  4. In the Contents pane, click the DOF_Hazards layer to select it.
  5. On the ribbon, click the Feature Layer tab.
  6. In the Extrusion group, click Type and click Absolute Height.

    Absolute Height in the Type menu

  7. In the Extrusion group, from the Field drop-down menu, choose Z.

    The Z field is the true height of the obstacle above the surface.

  8. For Unit, choose US Feet.
  9. Right-click DOF_Hazards and click Zoom to Layer.

    The existing obstacle features are now extruded from the surface to their true height.

    DOF hazards in 3D

You can see the obstacles that penetrate the OIS. Zooming in on those obstacles gives you a sense of how much of a hazard these obstacles pose to aircraft using this runway. Existing obstacles typically must be removed, lowered, lighted, or otherwise mitigated to ensure safe operation of the airport.

Apply 3D symbology

Next you'll use the same methods to symbolize the Construction_Hazards layer.

  1. In the Contents pane, right-click Construction_Hazards and click Properties.
  2. On the Elevation tab, click the Features are drop-down menu and choose On the ground, and click OK.
  3. In the Contents pane, click the Construction_Hazards layer to select it.
  4. On the ribbon, on the Feature Layer tab, in the Extrusion group, click Type and click Absolute Height.
  5. In the Extrusion group, from the Field drop-down menu, choose Z.

    The Z field is the true height of the obstacle above the surface.

  6. For Unit, confirm US Feet is selected.
  7. Right-click Construction_Hazards and click Zoom to Layer.

    Two construction hazards in 3D

The obstacle features are now extruded from the surface to their true height. You can see the obstacles that penetrate the OIS. Zooming in on those obstacles gives you a sense of how much of a hazard these obstacles pose to aircraft using this runway.

Highlight existing obstacles that may pose a hazard

Now you'll adjust the symbology of the existing obstacle features to highlight the obstacles that present a flight hazard to aircraft.

  1. In the Contents pane, right-click the DOF_Hazards layer and click Symbology.
  2. On the Symbology pane, for Primary symbology, choose Unique Values.
  3. For Field 1, click the Set an expression button.

    Set an expression button

    The Expression Builder appears.

    You'll build an expression to change the symbols for the features in this layer based on a condition.

    The DOF_Hazards features that penetrate the OIS have a Delta_Z attribute greater than or equal to 0. You'll use an Arcade expression to change the symbology for these features based on whether they penetrate the OIS or not.

  4. In the Expression box, delete the existing expression and copy and paste the following Arcade script:

    if ($feature.Delta_Z >= 0) {
        return "Penetrating"
    } 
    else {
        return "Not penetrating"
    }

    Expression entered in the text box

  5. Click OK.

    The Expression Builder closes and the DOF_Hazards feature layer is symbolized by penetrating and non-penetrating features.

  6. On the Symbology pane, click the symbol for the Not penetrating class.

    Symbol for Not penetrating features

  7. In the Gallery tab, choose the green Non penetrating Obstacles symbol and click the Back button.
  8. On the Symbology pane, click the symbol for the Penetrating class. On the Gallery tab, choose the red Penetrating Obstacles symbol, and click the Back button.

    You have updated the Penetrating and Non penetrating symbols.

    Symbology updated for the Penetrating and Non penetrating symbols

    The existing hazard features that penetrate the OIS are now easier to see. Because of the definition query you added earlier, only the penetrating features are currently visible. If you remove the query, the red and green symbology allows you to distinguish the penetrating and non-penetrating features.

Highlight the construction obstacles that may pose a hazard

Now you'll use the same technique to adjust the symbology of the construction hazard obstacle features to highlight the obstacles that present a flight hazard to aircraft.

  1. In the Contents pane, right-click the Construction_Hazards layer and click Symbology.
  2. On the Symbology pane, for Primary symbology, choose Unique Values.
  3. Click the Set an expression button.
  4. In the Expression box, delete the existing expression, and copy and paste the following Arcade script:

    if ($feature.Delta_Z >= 0) {
        return "Penetrating"
    } 
    else {
        return "Not penetrating"
    }

    Expression entered in the text box

  5. Copy and paste the following Arcade script into the Expression box.
  6. Click OK.

    The Expression Builder closes and the DOF_Hazards feature layer is symbolized by penetrating and non-penetrating features.

  7. On the Symbology pane, click the symbol for the Not penetrating class. In the Gallery tab, choose the green Non penetrating Obstacles symbol, and click the Back button.
  8. On the Symbology pane, click the symbol for the Penetrating class. In the Gallery tab, choose the red Penetrating Obstacles symbol, and click the Back button.

    The proposed construction hazard features that penetrate the OIS are now easier to see.

Explore the scene

Now you'll explore the scene in 3D to get a better sense of how much the obstacles penetrate the OIS.

  1. In the lower-left corner of the 3D view, click Show full control to see the expanded version of the 3D navigation controls.

    Show full control.

  2. Click and drag the ring control up to change the perspective on the scene.

    Ring control

    When the ring is horizontal, you see the scene as though you were standing on the surface.

    Ring control horizontal view

    You can also navigate by clicking and dragging on the scene.

    Extruded obstacles seen from horizontal view

  3. Click the 3D scene and drag down to zoom in.

    Zoomed in close to some of the obstacles

    You can also turn the definition queries on and off to view the penetrating obstacles in context with the non-penetrating ones.

  4. In the Contents pane, right-click the Construction_Hazards layer and click Properties.
  5. In the Layer Properties window, click Definition Query.
  6. Click Clear active query and click OK.

    Clear active query.

  7. Right-click the Construction_Hazards layer and click Zoom To Layer.
  8. Use the 3D navigation controls to view hazards from the surface.

    View the obstacles from the surface

  9. Save the project.

    Now you can see how some of the obstacles do not touch the OIS, while the two nearest the runway penetrate it.

You can use these visualizations to illustrate to the construction team which crane positions pose a potential hazard to aircraft.

In the lesson, you assumed the role of a GIS analyst for SFO to analyze obstacles at the end of runway 10L. Obstacle analysis is a critical exercise for ensuring the safe travel of aircraft in and around an airfield. You loaded and analyzed aviation data using geoprocessing tools from the ArcGIS Aviation Airports toolset, and you visualized the results in both 2D and 3D.

You can find more lessons in the Learn ArcGIS Lesson Gallery.