Extract boundary data

In this lesson, you'll process large general datasets to remove unnecessary information and focus only within your geographic area of interest. To do this, you'll download global boundary files from ArcGIS Living Atlas of the World, remove all features not related to the Democratic Republic of the Congo, and merge multifeature polygons into single features. The boundary files will serve as reference data needed to analyze and visualize population and malaria incidence in the next lessons.

Add and extract boundary data from ArcGIS Living Atlas

ArcGIS Living Atlas serves as a continuously updated and authoritative source for data. In this section, you'll add global boundary data from ArcGIS Living Atlas and extract relevant country features. The extracted features will later be appended with population and malaria incidence data to calculate incidence rate and visualize.

  1. Start ArcGIS Pro. If prompted, sign in using your licensed ArcGIS or Enterprise account.
    Note:

    If you don't have ArcGIS Pro, you can sign up for an ArcGIS free trial. If you are signing into an Enterprise account ensure that ArcGIS Pro is configured to use your organization's Portal.

    ArcGIS Pro opens. It contains a list of project templates under the heading New Blank Templates. If you've created a project before, you'll also see a list of recent projects under the heading Recent Project.

  2. Under New Blank Templates, click Map.
  3. In the Create a New Project window, change the project name to MalariaEpidemics. Click OK.

    A new project opens with a Contents pane on the left and a map pane in the center.

    Blank map template

    Now you'll add boundary data from ArcGIS Living Atlas.

  4. On the ribbon, click the Map tab. In the Layer group, click Add Data.

    Add Data tool

    The Add Data window appears. Here you can add data from your computer, an ArcGIS Online or Enterprise organization, or ArcGIS Living Atlas.

  5. In the Add Data window, under Portal, click Living Atlas.
  6. In the search bar, type World Countries owner: esri_dm.
  7. Select the World Countries feature layer and click OK to add it to the map.

    Add Data window showing the World Countries Living Atlas layer

    The World Countries layer is added to the map.

    Next, you'll select and extract the country data for the Democratic Republic of the Congo into two new feature layers.

  8. On the ribbon, click the Analysis tab. In the Geoprocessing group, click Tools.
  9. In the Geoprocessing pane, search for and choose the Feature Class to Feature Class tool.
  10. In the Feature Class to Feature Class tool, for Input Features, choose World_Countries.
  11. For Output Location, ensure you are using the default project geodatabase named MalariaEpidemics.gdb.
  12. For Output Feature Class, name the new feature class DRC_Country.
  13. Click New expression to construct a new query.

    You'll construct an SQL query to select and export the Democratic Republic of the Congo features from the World Countries layer.

  14. In the expression builder, use the drop-down menus to build the following statement: COUNTRY is Equal to Congo DRC. Press Enter to input the clause.
    Note:

    The Democratic Republic of the Congo and The Congo are two different countries. For this lesson, you are focusing on the Democratic Republic of the Congo, referred to here as Congo DRC.

  15. Above the expression, click the green check mark to verify that the expression is valid.

    Feature Class to Feature Class tool showing input parameters

    The Field Map controls which attributes from the original feature layer, World Countries, will carry over to the new feature layer, DRC_Country. Unnecessary attributes increase file size, so you'll remove all unneeded attributes.

  16. For Field Map, for Output Fields, remove all the fields expect Country by clicking a field and clicking the Remove field button.

    Field Map parameter of the Feature Class to Feature Class tool

  17. Click Run.

    After the tool runs, the DRC_Country layer is added to the Contents pane. You no longer need the World Countries layer, so you'll remove it.

  18. In the Contents pane, right-click the World Countries layer and choose Remove.

    Removing the World Countries layer

    Now you'll add administrative boundaries for the Democratic Republic of the Congo.

  19. In the ribbon, on the Map tab, click Add Data.
  20. In the Add Data window, under Portal, click ArcGIS Online.
  21. In the search bar, search DRC 2014, click DRC_Admin_2014, and click OK.

    Add 2014 administrative boundaries for the DRC

    Note:

    For the lesson, you are analyzing malaria data between 2000 and 2015. In 2015, the Democratic Republic of Congo split 11 provinces into 24 provinces. You will use administrative boundaries when the country was only 11 provinces to reflect the malaria data set's time period. You can access administrative boundaries for the Democratic Republic of Congo with 24 provinces by searching the World Administrative Boundary layer in ArcGIS Living Atlas.

    The DRC_Admin_2014 layer adds to the Contents pane.

    Next you will make a copy of this layer so you can edit the fields and run calculations.

  22. On the ribbon, in the Analysis tab, click Tools.

    Geoprocessing tools

    The Geoprocessing pane appears.

  23. In the Geoprocessing pane, search and select the Feature Class to Feature Class tool and set the following parameters:
    • For Input Features, choose DRC_Admin_2014.
    • For Output Name, type DRC_Admin.
  24. Click Run.

    The layer DRC_Admin adds to the Contents pane.

  25. Right-click the layer DRC_Admin and click Zoom To Layer.

    Zoom to center map on the layer

    You now have two layers: the country boundary for the Democratic Republic of the Congo and the administrative level 1 boundary for the country.

    DRC layers added to map

  26. Remove the World Administrative Divisions layer.
  27. Close the Geoprocessing pane.
  28. In the Quick Access Menu, click the Save button.

    Save button in Quick Access Menu

    Note:

    You can also press Ctrl+S to save your project.

Merge multiple features

Some boundary layers may have multiple features that are considered part of the same area. For example, the DRC_Country feature class contains three, instead of one, country border features all considered part of the Democratic Republic of the Congo. These three features correspond to the same area in both files and, in both files, they must be merged into a single feature before proceeding.

  1. In the Contents pane, right-click the DRC_Country layer and choose Attribute Table.

    Open the DRC_Country attribute table

    Notice that there are three polygons designated as the country border. You can assume the feature with the largest area is the main country border, but you should always check the other features.

  2. In the attribute table, click the blank gray cell in the second row to select it.

    Second row in attribute table selected

    The selected row should be highlighted in light blue.

  3. At the top of the attribute table, click Zoom To.

    Zoom to selected feature

    The map zooms to show the features you selected. You can see that these features are mostly small islands within the Congo river that form part of the country border.

    Small island features

  4. In the attribute table, select the third row.

    Third row feature selected

    In the map pane, larger islands along the river border are now highlighted. You have confirmed that the other two feature classes are indeed part of the country's border. You'll merge the three features into one using the Merge tool.

  5. On the ribbon, click the Edit tab. In the Tools group, choose Merge to open the Modify Features pane.

    The tools on the Edit tab are separate from the tools you would find in the Geoprocessing toolbox. They are exclusively accessed and used on the Edit tab for common editing workflows and when editing is performed, you have the option to save or discard the changes.

  6. In the DRC_Country attribute table, press Ctrl+A to select all features. Ensure all features are highlighted.

    All features selected

  7. In the Modify features pane, click Merge.

    Merge tool parameters

    The attribute table now contains only a multipart feature that consists of several geometries, but has only one attribute record. To make these changes permanent, you need to save your edits.

  8. On the Edit tab, in the Manage Edits group, click Save. Click Yes to confirm.

    Save edits

  9. On the Edit tab, in the Selection group, click Clear to deselect all features.

    Clear tool

  10. Close the attribute tables and Modify Features pane.
  11. Save your project.

In this lesson, you added global boundary data from ArcGIS Living Atlas, extracted specific country features, and merged multiple features into a single feature. In the next lesson, you'll add population estimate data from ArcGIS Living Atlas and calculate the estimates within your boundaries.


Add population estimate data

In the previous lesson, you downloaded global boundary data and extracted features for the Democratic Republic of the Congo. Now you'll add population data from ArcGIS Living Atlas of the World. ArcGIS Living Atlas contains authoritative content curated by Esri and content submitted by users approved by Esri to meet quality data standards. Part of Esri's content is a global population estimate layer that is created through a complex algorithm that considers available local population data such as a national census in addition to remotely sensed data. To learn more about how Esri calculates global population, read the published research paper Using Classified and Unclassified Land Cover Data to Estimate the Footprint of Human Settlement.

Add population estimate layers

In this section, you'll add two layers from ArcGIS Living Atlas that contain information on global population estimates and data sources for how those estimates were calculated. It is important to note that the population estimate layers have varying degrees of accuracy across the globe and should not be presumed to be an accurate population distribution. ArcGIS Living Atlas contains additional accuracy indicator layers to assist with such assessments. It is also important to note that the estimates are only as good as the input data allows. The end of the lesson will cover how to add the population estimate data source layer.

Note:

ArcGIS Living Atlas also contains country feature services that inherently contain population estimates, but this number does not include all countries. Over 130 countries have population estimates provided by Michael Bauer Research GmbH (MBR). This workflow provides an alternative for other countries.

  1. If necessary, open your MalariaEpidemics project in ArcGIS Pro.
  2. On the Map tab, in the Layer group, click Add Data.
    Note:

    For Enterprise users: On the Map tab, in the Layer group, click Add Data and choose Add Data From Path. Paste the following URL:

    https://landscape7.arcgis.com/arcgis/rest/services/World_Population_Estimate_2016/ImageServer
  3. In the Add Data window, ensure that you are searching within the ArcGIS Living Atlas.
  4. Search for World Population Estimate 2016.
  5. Select the World Population Estimate 2016 imagery layer and click OK to add it to the map.

    The layer is quite large and may take some time to load.

  6. If necessary, move the World Population Estimate 2016 layer above the DRC_Country and DRC_Admin layers to ensure the layer is visible.

    The population estimate layer is a raster surface showing an approximate spatial distribution of the population. This was achieved with dasymetric mapping that redistributed local census counts into areas coded as settlements based on their likelihood to be where people lived.

    Next, you'll now add the sources layer that shows which information was used in the population estimate.

  7. Search ArcGIS Living Atlas and add the layer World Population Estimate 2016 Sources.
    Note:

    For Enterprise users: On the Map tab, in the Layer group, click Add Data and choose Add Data From Path. Paste the following URL:

    https://services1.arcgis.com/pf6KDbd8NVL1IUHa/arcgis/rest/services/World_Population_Estimate_Sources/FeatureServer

    The World Population Estimate 2016 Sources feature layer is added with a long name. You'll rename the layer to make it easier to read.

  8. In the Content pane, click thePopDetail16WMAS_Alpha2_Generalized_FINAL layer two times and rename the layer Sources.
    Note:

    For Enterprise, the layer is named World_Population_Estimate_Sources. Rename the layer Sources.

  9. Move the Sources layer to the top of the Contents pane.

    The Sources layer contains metadata for the World Population Estimate 2016 layer. While the layer is turned on, you can click anywhere on the map and read the pop-up to learn more about the data.

  10. On the ribbon, in the Navigate group of the Map tab, click Explore.

    Explore tool

  11. In the Map pane, click anywhere within the Democratic Republic of the Congo to view the Sources pop-up.

    Democratic Republic of the Congo population estimate source information

    Note:

    Your pop-up may be configured slightly differently, but the information is the same.

  12. When you are done reading, close the pop-up and turn off the Sources layer.
  13. Save your project.

Calculate population estimates

You'll calculate the population estimates within your boundary files using the Zonal Statistics as Table tool. This tool is extremely useful for performing spatial statistical analysis and delivering a tabular output. In this case, a tabular output is preferred over a spatial output because it is easier to append to the Congo DRC feature. You'll run the tool to calculate the sum of the estimated population within the country and administrative geographic areas in a table that will later be joined to the respective feature class.

First, you'll calculate the population for the country layer.

Note:

Ensure you have enabled the Spatial Analyst extension for ArcGIS Pro. To enable the extension, click the Project tab, and select Licensing to review your settings.

  1. In the Geoprocessing pane, search for and choose the Zonal Statistics as Table (Spatial Analyst Tools) tool.

    Zonal Statistics as Table Spatial Analyst Tool

    The Zonal Statistics tools are a simple but powerful way to summarize raster information into polygons, such as administrative boundaries, or tables.

  2. In the Zonal Statistics as Table pane, set the following parameters:
    • For Input raster or feature zone data, choose DRC_Country.
    • Confirm Zone field is set to Country.
    • For Input value raster, choose World Population Estimate 2016.
    • For Output table, type CountryPop.
    • For Statistics type, choose Sum.

    Zonal Statistics as Table tool parameters

  3. Click Run.

    The tool may take a few minutes to complete. When the tool has finished running, the CountryPop table is added to the Contents pane under Standalone Tables.

  4. In the Contents pane, open the attribute table for CountryPop.

    Attribute table for the layer CountryPop

    In the attribute table, you can see in the SUM field that the population estimate for the entire country is 79,549,483.

  5. Close the CountryPop attribute table.

    Next you will use the Zonal Statistics tool for the DRC_Admin layer.

  6. Open the Zonal Statistics as Table tool and set the following parameters:
    • For Input raster or feature zone set, choose DRC_Admin.
    • For Zone field, confirm Name is selected.
    • For Input value raster, choose World Population Estimate 2016.
    • For Output table, type AdminPop.
    • For Statistics type, choose Sum.
  7. Click Run.

    When the tool finishes running, the AdminPop table is added to the Contents pane under Standalone Tables.

    Population estimate tables in the Contents pane

    Now that you have calculated population estimates, you no longer need the World Population Estimates 2016 layer.

  8. Remove the World Population Estimates 2016 layer.
  9. Save your project.

Join population estimate tables to boundary feature class

Next, you'll add the population data to the country boundary files using the Join Field tool. Usually after a join is performed it lasts only for the session, but by using the Join Field tool, the join becomes permanent and only includes selected attributes.

  1. In the Geoprocessing pane, search for and choose Join Field (Data Management Tools).
  2. In the Join Field pane, set the following parameters:
    • For Input Table, choose DRC_Country.
    • For Input Join Field, choose Country.
    • For Join Table, choose CountryPop.
    • For Join Field Table, choose COUNTRY.
    • For Transfer Fields, choose SUM.

    Join Field tool to add the Sum field to the DRC_Country layer

  3. Click Run.
  4. Open the attribute table for DRC_Country and confirm the SUM field was successfully added.

    Sum field joined to DRC_Country layer

    You have successfully joined the population estimate data to the DRC_Country feature class. Now you'll do the same for the DRC_Admin feature class.

  5. Open the Join Field tool and set the following parameters:
    • For Input Table, choose DRC_Admin.
    • For Input Join Field, choose Name.
    • For Join Table, choose AdminPop.
    • For Join Table Field, choose NAME.
    • For Transfer Fields, choose SUM.
  6. Click Run.
  7. Open the DRC_Admins attribute table to ensure the SUM attribute was successfully added.

    Now that you have added population estimates from the calculated tables to your feature classes, you no longer need the tables.

  8. Remove the CountryPop and AdminPop tables.
  9. Save your project.

In this lesson, you added global population estimate data from ArcGIS Living Atlas and extracted information for the DRC. In the next lesson, you'll clean and format malaria incidence data before importing it into ArcGIS Pro.


Add malaria data

In the previous lesson, you calculated population estimates for the Democratic Republic of the Congo using the layer World Population Estimate 2016 from ArcGIS Living Atlas. Now, you need to add information about the malaria incidence rates. The Malaria Atlas Project (MAP) is a World Health Organization (WHO) partner for collecting malaria incidence data across the world. In this lesson, you'll work with tables containing data on national and subnational incidence counts from 2000 to 2014 for the area of interest. It is common to look at five-year trends, so you'll calculate rates for 2000, 2005, 2010, and 2015. Since the 2015 data is not yet added to the tables, you'll manually add the most recent data.

Load country data using the Excel To Table tool

The Malaria Atlas Project publishes incidence data in a table format. Before loading the data into ArcGIS Pro, you must delete unnecessary rows and columns. Then, you'll run the Excel to Table tool to import the data into ArcGIS Pro and proceed to join it to your feature classes.

Note:

The instructions for this lesson will use a Microsoft Office workflow, but the following steps can also be completed using other spreadsheet software such as LibreOffice. You can download LibreOffice for free.

You can also open Microsoft Excel tables directly in ArcGIS Pro using the Microsoft Access Database Engine driver.

  1. Download the MalariaIncidence.zip file and extract it.

    The .zip file contains two incidence files for country and administrative areas incidence counts and text documents containing related metadata.

  2. Double-click Country_Incidence_2000_2014 to open the file in Microsoft Excel.

    Microsoft Excel opens with attribute columns for the country name and 14 years of malaria incidence counts. Since you are only interested in five-year intervals for the Democratic Republic of the Congo, you'll remove the unnecessary columns and rows.

  3. Select the second row in the sheet and press Shift while clicking the fourteenth row to select all data in between.

    Rows 2 through 14 selected

    All rows from Africa to Côte d'Ivoire should be highlighted.

  4. Right-click anywhere in the highlighted area and choose Delete.

    Delete selected rows

  5. Repeat the previous steps to delete all rows from Djibouti to South Africa.

    Now only the row for the Democratic Republic of the Congo remains.

    Next you'll delete the unnecessary columns.

  6. Select the column for Gaul_Code.
  7. While pressing Ctrl, click to select the columns for 2001, 2002, 2003, 2004, 2006, 2007, 2008, 2009, 2011, 2012, 2013, and 2014.

    Select columns

  8. Right-click anywhere in the highlighted areas and choose Delete.

    Now the table only includes a row with attribute names and a row with the country name and incidence counts for 2000, 2005, and 2010.

    Remaining rows

  9. Press F12 to open the Save As window.
  10. Browse to where your extracted files are located.
  11. Save the file with the name CountryIncidence and ensure you are saving it as an Excel Workbook, or (.xlsx) type.

    Saving file as

  12. Exit Microsoft Excel and return to ArcGIS Pro.

    Now that your malaria incidence data is cleaned and in the correct format, you'll run the Excel to Table tool to load the data into ArcGIS Pro. By using the tool instead of the Add Data button, you ensure that the data is loaded and formatted for use in ArcGIS Pro.

  13. In the Geoprocessing pane search for and choose the Excel to Table tool.
  14. In the Excel to Table pane, enter the following parameters:
    • For Input Excel File, click the browse button and browse to CountryIncidence.xlsx, select it, and click OK.
    • For Output Table, type CountryIncidence.
    • For Sheet, choose Country_Incidence_2000_2014.

    Importing CountryIncidence.xlsx

  15. Click Run.

    The CountryIncidence table adds to the Contents pane.

Update country incidence tables

You have successfully added the table of malaria incidence at the country level. You need to analyze incidents for five-year intervals; however, the data only contains information for 2000, 2005, and 2010. A separate report with data for 2015 is available, but you must manually update the tables.

  1. Right-click the CountryIncidence table and choose Open.

    Notice that the name of the country is spelled out as Democratic Republic of the Congo.

  2. Open the DRC_Country attribute table.

    Notice that the name of the country is spelled as Congo DRC.

    To join the malaria incidence data to the administrative boundary layer, you must join the CountryIncidence table to the DRC_Country feature class with a single attribute in both tables that matches exactly. In this example, you will use the country name, but the naming conventions are different because the data is from different sources. Before performing the join, you'll resolve the naming conflict by editing the table in ArcGIS Pro. The appropriate naming convention will depend on the end use and stakeholders involved in the project. For this lesson, you'll use Congo DRC for brevity.

  3. In the CountryIncidence attribute table, double-click Democratic Republic of the Congo to edit the name.
  4. Rename the cell as Congo DRC and press Enter.
  5. On the Edit tab, in the Manage Edits group, click Save, and click Yes.
  6. Close the CountryIncidence attribute table.

    Now you'll use the Join Field tool to append the CountryIncidence data to the DRC_Country feature class.

  7. In the Geoprocessing pane, search for and open the Join Field tool and enter the following parameters:
    • For Input Table, choose DRC_Country.
    • For Input Join Field, choose Country.
    • For Join Table, choose CountryIncidence.
    • For Join Table Field, choose Name.
    • For Transfer Fields, choose 2000, 2005, and 2010

    Join Field to join incidence fields

  8. Click Run.

    The incident data for 2000, 2005, and 2010 adds to the DRC_Country attribute table.

    Next, you'll clean up the table and add the incidence data for 2015.

  9. Open the DRC_Country attribute table.
  10. On the ribbon, in the Table View tab, in the Field group, click Add.

    Add new field button

    The Fields View for the table opens.

    You can see the field name, which is originally in the data, and the alias name, which is displayed instead of the field name when viewing the attribute table. At the bottom, a new row has been generated and needs to be configured.

  11. Scroll to the last row in the Fields View and click on Click here to add a new field.
  12. In the new row, enter the following:
    • For Field Name, type F2015.
    • For Alias, type 2015.
    • Ensure Data Type is set to Long.
    Note:

    Field names can never start with numbers.

    New field added in Fields View

    Next you'll also change the name of the population estimate attribute from SUM to Pop.

  13. In the Fields table, in the row for SUM, change the Alias name from SUM to Pop.

    Alias for SUM updated to Pop

  14. On the ribbon, in the Fields tab, in the Changes group, click Save.

    Save field edits

    The DRC_Country attribute table now includes a column to add the 2015 incidence data and a more appropriate name for the population estimate attribute.

  15. Close the Fields table.
  16. Open the DRC_Country attribute table.
  17. In the attribute table, in the first row for the 2015 attribute, double-click <Null> to edit the cell value.

    In 2015, there were 18,726,106 recorded malaria incidents.

  18. In the cell, type 18726106 and press Enter.

    2015 malaria incidences

  19. On the ribbon, in the Edit tab, in the Manage Edits group, click Save, then click Yes.
  20. Save the project.

Load administrative data using the Excel to Table tool

Next, you'll add the incidence data at the administrative boundary level.

  1. In your computer's file explorer, open the file Admin_Incidence_2000_2014 in Microsoft Excel.

    The table opens to show malaria incidence data at the administrative level for every country in Africa. You'll filter the data to only show data for the Democratic Republic of the Congo and only for 2000, 2005, and 2010.

  2. Press Ctrl+A to select all the cells.
    Tip:

    To quickly select multiple rows of data, first select the second row and press Ctrl+Shift+Down Arrow.

    Rows 2 through 506 should be selected.

  3. On the ribbon, click the Data tab. In the Sort & Filter group, click Filter.

    Open the standard filter

    The filter option is now available at the top of each column. By clicking the small arrow button, you can select which data you are interested in viewing.

  4. In the Country column, click the arrow button , uncheck (Select All).

    Uncheck (Select all)

  5. Scroll and check Democratic Republic of Congo.

    Check Democratic Republic of Congo

  6. Click OK to apply the filter.

    Only rows with data for the Democratic Republic of the Congo remain. Next, you'll delete unnecessary columns.

  7. Select the column for 2001.
  8. While pressing Ctrl, click to select the following columns: Country_ID, Gaul_Code, 2002, 2003, 2004, 2006, 2007, 2008, 2009, 2011, 2012, 2013, and 2014.

    Five columns in the spreadsheet remain: AdministrativeRegions, Country, 2000, 2005, 2010.

    Remaining columns

  9. Next to the 2010 column, type 2015.
  10. Copy the following incidence counts into the spreadsheet.

    Bandundu

    1278200.367

    Bas-Congo

    722036.3631

    Equateur

    1745605.954

    Kasai-Occidental

    1946129.214

    Kasai-Oriental

    2054728.181

    Katanga

    2989521.021

    Kinshasa

    1398453.358

    Maniema

    678064.6795

    Nord-Kivu

    479545.8178

    Province Orientale

    4910368.382

    Sud-Kivu

    516282.5578

    There are a few naming conflicts you need to resolve. To reiterate, a join cannot be performed unless attributes match exactly. In this case, you need to correct an attribute with a naming conflict and an attribute with an accent conflict.

  11. Rename the following Administrative Regions fields:
    • Bas-Congo to Kongo Central.
    • Equateur to Équateur.
    • Province Orientale to Orientale.
    Note:

    If you are unable to type the accent using your keyboard, copy and paste the above text.

    2015 data added and updated administrative region names

    Now that you have finished editing the spreadsheet, copy only the Congo DRC data into a new spreadsheet.

  12. Select all the visible cells on the spreadsheet.
  13. Press Ctrl+C to copy the data.
  14. Add a new spreadsheet by pressing the add button at the bottom of the Excel window.
  15. In the new spreadsheet, press Ctrl+V to paste the data.
  16. Double-click the sheet tab and change the spreadsheet name from Sheet2 to CongoDRC.

    New tab

  17. Press F12 to open the Save As window. Browse to where your extracted files are located and save the file with the name AdminIncidence as an Excel Workbook type.
  18. Exit Microsoft Excel and return to ArcGIS Pro.

    Next, you'll use the Excel to Table tool to load the data into ArcGIS Pro.

  19. In the Geoprocessing pane, search for and click on the Excel to Table tool.
  20. In the Excel to Table pane, enter the following parameters:
    • For Input Excel File, click the browse button and browse to and select AdminIncidence.xlsx and click OK.
    • For Output Table, type AdminIncidence.
    • For Sheet, choose CongoDRC.
    Note:

    If you do not see AdminIncidence.xlsx, you can click the refresh button so the Excel document is visible.

    to Table tool loading the AdminIncidence spreadsheet

  21. Click Run.

    The AdminIncidence table is now visible in the Contents pane. You'll now proceed to join the table to the feature class.

  22. Open the Join Field tool and set the parameters as follows:
    • For Input Table, choose DRC_Admin.
    • For Input Join Field, choose Name.
    • For Join Table, choose AdminIncidence.
    • For Join Table Field, choose AdministrativeRegions.
    • For Transfer Fields, choose 2000, 2005, 2010, and 2015.
  23. Run the tool.
  24. Remove the CountryIncidence and AdminIncidence tables.
  25. Save your project.

In this lesson, you cleaned and formatted malaria incidence data and loaded it into ArcGIS Pro. In the next lesson, you'll calculate the malaria incidence rate from the population estimate and malaria incidence data you have added so far.


Calculate malaria incidence rates

In the previous lesson, you added malaria data. In this lesson, you'll calculate malaria incidence rates using the population estimate and malaria incidence data you appended in previous lessons. To do this, you'll create attribute fields and use the field calculator to calculate the rate per 1,000 population.

Calculate the rate

Now that you have population and malaria incident count in one layer, you'll create attribute fields to calculate the rate. In this lesson, you cleaned and formatted malaria incidence data and loaded it into ArcGIS Pro. In the next lesson, you will calculate the malaria incidence rate from the population estimate and malaria incidence data you have added so far.

  1. Open the DRC_Country attribute table.
  2. At the top of the attribute table, click Add to open the Field view.

    Add new field from attribute table

  3. Click the last row in the Field view to create a field. You'll need to add four new fields:

    Field nameAliasData type

    Incidence2000

    IncidenceRate2000

    Long

    Incidence2005

    IncidenceRate2005

    Long

    Incidence2010

    IncidenceRate2010

    Long

    Incidence2015

    IncidenceRate2015

    Long

    New incidence fields added

  4. On the Fields tab, in the Changes group, click Save.
  5. Close the Field view.

    You'll now calculate the incident rates for the new fields you just created. The incident rate is calculated with the following equation: (malaria incidence rate/total population) * 1000 = Incidence rate per 1,000 population.

  6. In the DRC_Country attribute table, right-click IncidentRate2000 and choose Calculate Field.

    Open the Calculate Field tool for IncidenceRate2000

    The Calculate Field tool opens.

  7. In the Calculate Field window, confirm Input Table is set to DRC_Country and Field Name is set to IncidenceRate2000.
  8. Build the following expression:

    round((!F2000! / !SUM!)*1000,0)

    Calculate Field tool running for IncidenceRate2000

    Note:

    The incident rate per 1,000 population is calculated by dividing the malaria incidence value by the total population, multiplied by 1,000.

    The expression contains three parts. The round function takes two inputs, separated by a comma. The first input is the number to round and the second is how many spaces to round to. In this case the calculated incidence rate is the number ((!F2000!/ !SUM!)*1000), which will be rounded to 0 spaces.

    The second part is the !F2000!, which corresponds to the 2000 incidence count. When calculating the rate for other years, you'll change this number to reflect the year. You can also select the incidence rate year attributes from Fields.

    The third part is the !SUM!, which corresponds to the population estimate attribute you calculated earlier using Zonal Statistics.

  9. Click the green checkmark to validate the expression.

    The expression should return valid. If not, check your equation for any errors.

  10. Click OK.

    In the DRC_Country attribute table, the value for the IncidenceRate2000 field has now been calculated as 303. This indicates that 303 per 1,000 people experienced a case of malaria in 2000.

  11. Repeat steps 6 through 10 to calculate the country incidence rate for 2005, 2010, and 2015. Change the names and variable usage accordingly.

    Incidence rate attributes calculated for each year

    To calculate the incidence rates for 2000, 2005, 2010, and 2015, use the following expressions:

    • For Incidence2000, type round((!F2000! / !SUM!)*1000,0).
    • For Incidence2005, type round((!F2005! / !SUM!)*1000,0).
    • For Incidence2010, type round((!F2010! / !SUM!)*1000,0).
    • For Incidence2015, type round((!F2015! / !SUM!)*1000,0).

    Tip:

    Ensure that the field name matches the year you are calculating for.

  12. Save your project.

    Now that you have the incidence rate calculated for each year at the country level, you'll calculate it at the administrative level.

  13. Open the DRC_Admin attribute table.
  14. At the top of the attribute table, click Add to open the Field view table.
  15. Add four new fields as described in the following table:

    Field nameAliasData type

    Incidence2000

    IncidenceRate2000

    Long

    Incidence2005

    IncidenceRate2005

    Long

    Incidence2010

    IncidenceRate2010

    Long

    Incidence2015

    IncidenceRate2015

    Long

    Tip:

    To add new fields, on the DRC Admin attribute table, click Add.

    Add new incidence year attributes in the Fields view

  16. Save your edits and close the Fields view.

    Next, you'll calculate the incident rates for the new fields you just created.

  17. Repeat steps 6 through 10 to calculate the incidence rate for each of the new fields.

    To calculate the incidence rates for 2000, 2005, 2010, and 2015, use the following expressions:

    • For Incidence2000, type round((!F2000! / !SUM!)*1000,0).
    • For Incidence2005, type round((!F2005! / !SUM!)*1000,0).
    • For Incidence2010, type round((!F2010! / !SUM!)*1000,0).
    • For Incidence2015, type round((!F2015! / !SUM!)*1000,0).

    Tip:

    Ensure that the field name matches the year you are calculating for.

    Incidence rate per 1,000 calculated for administrative regions

  18. Save your project.

In this lesson, you calculated malaria incidence rates, created maps to visualize incidence trends over time, and edited, updated, and exported a spreadsheet containing the calculated rates. In the next lesson, you'll learn how to share your data as a web map and communicate trends using smart symbology.


Style and share a web map

In the previous lesson, you calculated malaria incidence rates. In this lesson, you'll share your results as a web map on ArcGIS Online or your ArcGIS Enterprise portal.

Share the map

One of the most important things to do before sharing data or maps is to ensure the metadata for the item has been completed. You know from previous lessons that the malaria incidence data has been obtained from the Malaria Atlas Project and that population estimates have been provided through ArcGIS Living Atlas. You'll add both data providers in the metadata before styling the map.

  1. In the Contents pane, right-click DRC_Admin and choose Properties.
  2. In the Map Properties window, choose the Metadata tab.

    The information on the Metadata tab is carried over to your exported web map. ArcGIS Pro does not allow you to export the map without filling in the metadata.

  3. Click Show metadata from data source (read-only) and click Layer has its own metadata, and fill in the following parameters:
    • For Title, type DRC Malaria Incidence 2000 – 2015 followed by your initials.
    • For Tags, type Democratic Republic of the Congo, Congo DRC, Malaria, SDG, SDG#3.
    • For Summary, type This map displays malaria rates from 2000-2015 for the Democratic Republic of the Congo.
    • For Description, type This map displays the malaria incidence rate per 1,000 population for 2000, 2005, 2010, and 2015 in the Democratic Republic of the Congo. The incidence rate is calculated for reporting on the United Nations Sustainable Development goal #3 Good Health and Well-Being on indicator 3.3.3 End Epidemics of Malaria.
    • For Credits, type The Malaria Atlas Project, ArcGIS Living Atlas.
    • For Use limitations, type None.
    Note:

    Each item shared requires a unique name. As a user in an organization, you should attach your initials to any items you create.

  4. Map metadata completed

  5. Click OK.

    Next, you'll share your map as a web map.

  6. On the Share tab, in the Share As group, click Web Map.

    Share as a Web Map

  7. In the Share As Web Map pane, for Name, type DRC Malaria Incidence Rates 2000 to 2015 followed by your initials.
  8. For Share with, check Everyone.

    Share As Web Map pane

  9. Click Share.

    The map is now accessible through your ArcGIS Online or ArcGIS Enterprise account. When ArcGIS Pro has finished publishing the map, you'll see a confirmation message that includes a link to manage your web map.

  10. At the bottom of the Share As Web Map pane, click Manage the web map to open your map.

    Link to Details Page for Web Layer

  11. If necessary, sign in to your ArcGIS account.
  12. Save and close ArcGIS Pro.

Use smart mapping

One way to visualize the malaria incident rate per 1,000 people for each year is to create a choropleth map. This type of map assigns a gradient color scheme to the data, and each area is shaded according to the incident rate. However, this type of symbology can be misleading, because it leads you to associate the size of an area with the number being reported. Administrative regions with cities, which have small geographic regions but dense populations, would be visually misrepresented.

The appropriate way to communicate this data is to use proportional symbols. Proportional symbols show relative differences among features. Next, you'll calculate the malaria incidence rate per 1,000 population, use proportional symbols to represent malaria rates, and show changing rates over time. You'll use Esri's smart mapping functionality, which automatically analyzes your data and offers data-driven styling suggestions, to visualize the data.

  1. On the Congo DRC Malaria Incidence 2000 - 2015 item details page, on the right side of the page, click the options arrow for Open in Map Viewer Classic, and click Open in Map Viewer.

    Open in Map Viewer

    Note:

    ArcGIS Online offers two map viewers for viewing, using, and creating maps. For more information on the map viewers available, please see this FAQ.

    Your layer opens in Map Viewer and the Layers pane appears.

    Map appears in Map Viewer

    There are options to change the display attribute and edit the symbology style using any of the attributes found in the data. This dataset contains the rate in 2000 and the rate in 2015, but it does not contain the change between the two years. You'll first create a custom attribute expression using Arcade to show the change in trends from 2000 to 2015. Then you'll configure the pop-ups to include a bar chart showing the rise and decline of incidence for each year.

    Note:

    Arcade is an expression language created by Esri that is compatible across the ArcGIS platform. The language provides a simple scripting syntax that allows users to control how features are rendered, control label text, and more. You can read more about the Arcade language on the ArcGIS Developers website.

  2. In the Layers pane, click the layer DRC_Admin.

    Select the DRC_Admin layer in the Layers pane

    The Properties pane for the layer DRC_Admin appears.

  3. In the Properties pane, for Symbology, click Edit layer style.

    Edit layer style

    The Styles pane appears.

  4. In the Styles pane, for Choose attributes, click Expression.

    Style attributes using an expression

    The Script Editor window appears. In the editor, you can create custom attributes by combining globals, which are attributes in the data, and basic scripting functions, which are statements that will perform a task or calculate a value. You'll copy a preconstructed expression into the editor.

  5. In the Script Editor window, delete the existing text and copy and paste the following expression:
    var y2000 = $feature.Incidence2000
    
    var y2015 = $feature.Incidence2015
    
    when(y2015 > y2000, "Increase", y2015 < y2000, "Decrease", "No Change")

    Note:

    Alternatively, you can construct the expression by selecting the same code from the Globals and Functions tabs.

    The expression measures if there was an increase or decrease from 2000 to 2015. The first two lines create variables for each year and assign them to the corresponding feature attribute. Then, a function is written that compares the years and assigns the comparison outputs one of three labels: Increase, Decrease, or No Change. The expression below reads: When incidence rates in 2015 were greater than 2000, return "Increase", when incidence rates in 2015 were less then 2000, return "Decrease", all other results will return "No Change".

    Expression to calculate change

    Now you'll name the custom expression.

  6. At the top of the Script Editor window, click Edit.

    Editing the expression name

  7. In the text box, type Incidence Change.

    Rename the expression Incidence Change.

    The expression title is shown in the legend.

  8. Click Save.
  9. Click OK.

    The map symbology changes to show to the custom attribute expression you just coded, which automatically symbolizes the data using the Types (Unique symbols) style.

    Malaria incidence rate visualized as increasing or decreasing

    The change in incidence rate is symbolized as a choropleth map that displays either decreasing (red) or increasing (blue) from 2000 to 2015. Color is useful to show the direction of change, but you can do more by showing the amount of change using proportional symbols.

  10. In the Styles pane, for Choose attribute, click Expression.

    By adding a second attribute, you can display two variables in your map using different cartographic techniques.

  11. In the Script Editor window, copy and paste the following expression:
    var y2000 = $feature.Incidence2000
    
    var y2015 = $feature.Incidence2015
    
    abs(y2015-y2000)

    The Existing tab lists all Arcade expressions you have built for the current web map. You can see the Arcade expression you built for the first attribute.

  12. Click Incidence Change (Color Style) to select the Arcade expression.
  13. Rename the expression to Incidence Change (Rate per 100,000 people).

    Second expression renamed

  14. Click OK.

    The map symbology changes to show size as a secondary visual variable that represents the amount of change. This is useful to distinguish between regions such as Bandundu, which experienced a large decrease in malaria incidence, and Katanga, which experienced a small decrease. You can also see that the two regions with increased rates, Maniema and Kinshasa, only experienced small increases.

    Next, you will edit the color scheme to better highlight incidence change by regions.

  15. In the Styles pane, under Try a drawing style, for Types and Size, click Style options.

    Style options

  16. In the next pane, for Types (unique symbols), choose Style Options.

    In the Style Options pane, you will edit the color scheme to better highlight change in the regions.

  17. Next to Decrease, click the red circle symbol.
  18. In the Symbol window, in the Fill section, and select a mid-range blue color.

    Blue fill color

  19. Click the symbol for Increase and under Fill, expand Custom color and enter FFAA00 and press Enter.

    Type a custom color

    The circles on the map have changed colors to show areas with a decrease in malaria incidence in blue and areas with an increase in orange.

  20. In the Style options pane, click Done three times.
  21. On the left panel, click Basemap and click Dark Gray Canvas.

    Note:

    If you are unable to see the left menu text, at the bottom of the menu, click the Expand button.

    The basemap updates.

    Map styled

Configure pop-ups

Now that your map is styled, you'll configure pop-ups for the layer to display a chart graph that shows incidence for every year. The map displays long-term trends from 2000 to 2015, but the chart graph allows insight into rates for years in between.

  1. In the left panel, click Layers, and click the DRC Admin layer.

    The Properties pane appears.

  2. In the right panel, click Configure pop-ups

    Configure pop-ups

    The Pop-ups pane appears along with a preview window of the pop-up. Here you can edit the title of the pop-up, choose which attributes to display, write custom Arcade expressions, or add media. The pop-up title is already set to the NAME attribute.

  3. In the Pop-ups pane, click the More options button for Fields list and click Delete.

    Delete Fields list

  4. Click the Add content button.

    Add content button

  5. Click Chart.

    Chart button

  6. In the Configure Chart window, for Title, type Malaria Incidence Rate 2000-2015.
  7. Click Select fields and choose Incidence2000, Incidence2005, Incidence2010, and Incidence2015.

    As you select the fields, the chart bars appear in the pop-up preview window.

    Chart configuration

  8. Click Done twice, and close the Pop-ups pane.
  9. Click any administrative region on the map to test your pop-up configuration.

    The new pop-up window displays the name of the administrative region and four columns for each incidence year. If you hover your pointer over a column, a ToolTip appears displaying the specific incidence rate.

    Preview pop-up

    Also notice the right-pointing arrow in the upper right of the pop-up window. This indicates that the point where you clicked has more than one pop-up, as may be the case when you are displaying multiple overlapping layers. In this map, the Sources layer also has a pop-up for the entire country.

  10. Click Next feature to view the Sources layer pop-up.

    Administrative region ToolTip for 2015 inside the pop-up

    Note:

    If clicking the Next feature button shows a blank pop-up, zoom in more and click the administrative region again.

    Now that your web map is complete, you'll save and share it.

  11. In the left panel, click Save.
    Note:

    If you are prompted with a message that the map was previously updated in Map Viewer Classic, click Save this map to continue.

  12. In the left pane, click Share map.

    The Share window allows you to control who your map will be shared with and provides a link to the web map. Additionally, you can choose to embed the map into your website with various configurations for map element settings.

  13. In the Share window, select Everyone (public) and click Save.
    Note:

    If you are prompted to update sharing permissions, click Update to continue.

  14. In the left pane, click Map properties and click Item details.

    Link to Item details page

    The Item Details page for your web map appears.

  15. On the Item Details page, in the Details section, click the Share URL button to get a shortened URL of your web map.

    Share URL button

In these lessons, you calculated malaria incidence rates; created maps to visualize incidence trends over time; and edited, updated, and exported a spreadsheet containing the calculated rates. By creating these maps and spreadsheets, you can visually communicate whether trends are increasing or decreasing and understand where aid and resources are needed most. While the maps are a visual communication tool, you can also share your calculated analysis through the spreadsheet.

You have now learned to how to use spatial analysis and data to calculate the Sustainable Development Goal (SDG) indicator 3.3.3 malaria incidence per 1,000 population. The workflow you used here can be used in future SDG 3.3.3 reporting and can be adapted to include updated data as well. Finally, the maps you created can be shared to gain valuable insight into incidence trends throughout the country.

You can find more lessons in the Learn ArcGIS Lesson Gallery.