Create a map

First, you'll create a map using ArcGIS Pro. You'll start a project, which will contain your map and the tools you need to make it. Then, you'll search online for Venice data and add it to the map. Finally, you'll explore the data with navigation tools and bookmarks.

Start a project

Before you can make a map, you must first create a project. A project contains maps, databases, toolboxes, styles, and other folders that may be useful when making your map.

  1. Start ArcGIS Pro. If prompted, sign in using your licensed ArcGIS account.
    Note:

    If you don't have ArcGIS Pro or an ArcGIS account, you can sign up for an ArcGIS free trial.

    When you open ArcGIS Pro, you're given the option to create a new project or open an existing one. If you've created a project before, you'll see a list of recent projects.

  2. Under Blank Templates, click Map.

    Map template

    The Map template creates a 2D map with your project, allowing you to quickly get started. You can also add 3D maps to the project, even if you start with a 2D map template. The Catalog and Start without a template options open projects without maps, so that you can add whatever map or scene type you want (the Catalog template begins with the catalog view open by default). The Scene templates create projects with 3D maps.

  3. In the Create a New Project window, change the project name to Venice Acqua Alta.

    Project settings

    By default, the project is saved to the ArcGIS folder, located in the Documents folder on your computer's C: drive. To save the project elsewhere, browse to a different location.

  4. Click OK.

    The project opens and displays a map view.

    Default map

Add data to the map

To explore the geography of Venice, you need data. You can add data in many ways, but in this lesson, you'll add the data in the form of a layer package. A layer package can bundle multiple data layers into one file, allowing you to add a lot of data at once.

  1. If necessary, on the ribbon at the top of the page, click the Map tab. In the Layer group, click Add Data.

    Add Data button

    The Add Data window appears. The window has three places to find data: your project's folder (Project), online (Portal), and your computer (Computer).

    Note:

    If you're using ArcGIS Enterprise, download and unzip VeniceData.zip to the project folder you created with the project. Browse to VeniceData and add the Venice_Feature_Layers item. For portal security, Enterprise doesn't allow users to search for items stored in ArcGIS Online. Data must be hosted in your licensing portal, ArcGIS Living Atlas, or locally.

  2. In the pane of the window, under Portal, click ArcGIS Online.

    Add Data window pane

  3. In the search box at the top of the window, type Venice_Feature_Layers. To limit the search results to those owned by the Learn ArcGIS administrator account, add owner:Learn_ArcGIS to the search. Press Enter.

    Search for data

  4. In the search results, double-click the Venice_Feature_Layers layer package to add its layers to the map.

    The layer is added to the map and zooms to Venice, Italy.

    Venice default extent

    The small green points are famous landmarks, the red lines are canals, and the turquoise polygons are structures.

Navigate the map and create bookmarks

For the final part of this lesson, you'll navigate the map and create bookmarks to quickly return to key areas.

  1. On the Map tab, in the Navigate group, click the Fixed Zoom Out button.

    Fixed Zoom Out button

    The map zooms out a fixed distance.

    Tip:

    You can also zoom by positioning the pointer in the map window and using your mouse's scroll wheel.

  2. If necessary, continue to zoom out until you see the entire city.

    Venice full extent

    Venice is almost completely covered in structures. The basemap depicts the few areas of natural terrain in light green, although these areas are difficult to see due to the symbology of the structures. You'll change the symbology in the next lesson, but for now, continue exploring.

  3. If necessary, on the Map tab, in the Navigate group, click the Explore button.

    Explore button

  4. Click and drag the map to pan across the bridge to the northwest.

    Bridge to the mainland

    The bridge connects Venice to mainland Italy. Venice is in the Laguna Veneta, part of the Gulf of Venice in the Adriatic Sea. The Adriatic Sea's long, narrow shape amplifies water movement and contributes to Venice's high tides.

  5. Pan back to Venice.

    Next, you'll create bookmarks to quickly navigate to points of interest.

  6. On the Map tab, in the Navigate group, click the Bookmarks button and choose New Bookmark.

    Bookmarks button

  7. For Name, type Venice and click OK.

    Create Bookmark window

  8. Zoom to the open area in the south-central part of the city, pictured below:

    Piazza San Marco

    Tip:

    To zoom to a specific extent, press and hold the Shift key and draw a box around the area on the map.

    This is the Piazza San Marco, Venice's main public square. It is one of Venice's most visited places as well as one of its lowest lying. It is frequently submerged during acqua alta.

  9. Bookmark the piazza. Name the bookmark Piazza San Marco.
  10. Click the Bookmarks button and click the Venice bookmark.

    Where might be another significant location to bookmark? Unless you've visited Venice before, you probably have no idea. Fortunately, the Landmarks layer shows significant locations.

  11. Click any of the small green circles on the map to open its pop-up.

    Teatro la Fenice pop-up

    Every feature has a pop-up. By default, a pop-up displays the attribute data of the selected feature. The above example includes the feature's name and a description of its significance.

  12. Click some of the nine landmarks to learn about the data and the challenges that flooding poses to the city.
    Tip:

    The current symbology of the landmarks makes them blend into the structures. If you have trouble finding them, you can turn off the Structures layer by unchecking the box next to the layer name in the Contents pane.

  13. Zoom to two or three points that interest you and create a bookmark for each.

    You can revisit these bookmarks when you analyze how flooding affects the city in a later lesson.

  14. Return to the Venice bookmark. On the Quick Access Toolbar, click the Save button to save your project.

    Save button

You've started a project in ArcGIS Pro, added data to a map, and explored the data.


Symbolize layers and edit features

When you explored the data, it was difficult to distinguish some of the features because of how they were symbolized. Next, you'll symbolize your map more appropriately.

Symbolize the Structures layer

First, you'll give the turquoise structures a more appropriate color.

  1. If necessary, open the Venice Acqua Alta project in ArcGIS Pro.
  2. In the Contents pane, click the turquoise rectangle symbol for the Structures layer.

    Structures symbol

    The Symbology pane opens to the Gallery.

  3. In the search box, type Sienna and press Enter. Choose the Sienna symbology.
    Note:

    Alternatively, you can choose any medium dark brown color.

    Sienna symbol

    The symbology for the Structures layer updates from turquoise to brown.

    Symbolized structures

Symbolize the Canals layer

The canals are currently symbolized as dark red. Venice certainly isn't known for dark red canals. Canals are water bodies, so a different color to represent blue would make more sense. Next, you'll change the canals symbol.

  1. In the Contents pane, click the red line symbol for the Canals layer.
  2. In the Symbology pane, click Properties.

    Symbology pane properties

  3. For Color, click the symbol and choose Yogo Blue.

    Yogo Blue

    Tip:

    Hover over a color to see its name.

    Yogo Blue provides a blue color that represents water without blending into the topographic basemap blue color. However, the canals are thin and difficult to see in some places.

  4. For Line Width, type 1.5.
  5. At the bottom of the Symbology pane, click Apply.

    The Canals layer is more visible and better represents a waterway.

    Symbolized canals

Symbolize the Landmarks layer

The Landmarks layer represents important locations, so you'll customize a symbol to draw attention to them.

  1. In the Contents pane, click the green point symbol for the Landmarks layer.
  2. In the Symbology pane, click Gallery. In the text box, type Push Pin and press Enter.

    The search returns several results.

  3. Click the larger, rounded push pin symbol.

    Push pin symbol

    The layer symbol updates and the Symbology pane updates.

    You can customize the default style to make it even more eye-catching.

  4. In the Symbology pane, click the symbol.

    Symbol

  5. Click the Properties tab and click the Layers button.

    Layers tab

  6. Under Appearance, for Shape fill symbol, choose Solid fill with outline (0.5 pt).

    Solid fill with outline (0.5 pt)

  7. For Color, choose Dark Amethyst.

    Dark Amethyst

    A purple color will stand out against the orange-brown structures. For the outline, a slightly darker shade will work.

  8. For Outline color, choose Ultramarine.

    Ultramarine

  9. Accept the default settings for Outline width and Size.

    Push pin appearance settings

  10. Click Apply.

    Symbolized landmarks

    The purple push pins stand out much more clearly than the green dots.

  11. Close the Symbology pane.

Edit the Landmarks layer

A few key places are missing from the Landmarks layer, such as the Piazza San Marco you explored in the previous lesson. Data may not always be perfect. That's okay; you can edit the layer to add the missing places.

  1. Zoom to the Piazza San Marco bookmark.
  2. On the ribbon, click the Edit tab. In the Features group, click the Create button.

    Create button

    The Create Features pane appears, displaying the layers available for editing.

  3. In the Create Features pane, click Landmarks push pin symbol.

    Create Features pane

    You can now add landmarks to the map.

  4. Click the center of the Piazza San Marco to add a point.

    Piazza San Marco landmark

    The new point is automatically selected, highlighting it in blue.

    Tip:

    If you don't like where you placed your point, you can undo it. Alternatively, you can delete it: make sure the point is selected, and on the Edit tab, in the Features group, click the Delete button.

  5. Zoom to the Venice bookmark.

    Next, you'll add a landmark to another important place in Venice: the Rialto Bridge.

  6. Use your mouse wheel button to zoom and press C to pan the map. Zoom in to the bridge that crosses the canal in the center of Venice.

    Rialto Bridge location

    This is the Rialto Bridge, the oldest bridge in Venice.

  7. Release the C key to change the pointer back to the Landmarks symbol. Add a point to the bridge.

    Rialto Bridge landmark

    Note:

    When you add a point, the pointer may snap to other feature layers. Snapping is an editing feature that makes it easier to place features next to each other. To turn off snapping, on the Edit tab, click the Snapping button (or temporarily suspend snapping by holding the spacebar while editing).

  8. Zoom to the Venice bookmark.

    You'll add one more landmark at a location that serves an important function to Venice: the island of San Michele.

  9. Zoom to the island just north of Venice.

    San Michele location

  10. Add a point near the center of the island.

    San Michele landmark

    San Michele is the resting place of many of Venice's dead (but not always the final resting place—space is at a premium, and sometimes bodies need to be moved). Although not as famous as Piazza San Marco or the Rialto Bridge, it's still a significant landmark.

  11. Return to the Venice bookmark and close the Create Features pane.
  12. Click the Edit tab, and in the Manage Edits group, click the Save button.

    Save button

  13. In the Save Edits window, click Yes to save all edits.
    Note:

    The Save button on the Edit tab saves any changes made to the selected layer in the Contents pane. It does not save the project. To save your entire project, click the Save button on the Quick Access Toolbar.

Edit attribute data

You've added three new features to the Landmarks layer. However, those features have no attributes to explain what they are or why they're important.

  1. In the Contents pane, right-click the Landmarks layer and click Attribute Table.

    Attribute Table

  2. Examine the fields in the attribute table.

    Default attribute table

    The Landmarks layer has four fields. ObjectID and Shape are set by the software, but the Name and Description fields are user-specified. The three points you added have Null values for those fields. The last point you added is selected both on the map and in the attribute table.

    Note:

    If you deleted a point during the editing process, your points may have different ObjectID values. Even though the IDs are different, it will not affect the analysis outcome.

  3. In the row of the first point you added, double-click the Null value in the Name field to start editing. Type Piazza San Marco and press Enter.

    Edit table

  4. Edit the Name attribute of the second point you added to Ponte di Rialto.
  5. Edit the Name attribute of the last point to Isola di San Michele.

    The points have names but no descriptions. As you saw earlier, the Description field includes a paragraph explaining the landmark's significance. Since these can be long, you'll paste them instead of typing.

  6. Highlight and copy the following text:

    As Venice's main public square, the Piazza San Marco is one of the most visited places in the city, with some of its most famous landmarks. Popular attractions include St. Mark's Basilica, the Biblioteca Nazionale Marciana, and the Doge's Palace. The piazza is one of the lowest-lying areas of Venice and frequently floods when waters rise.

  7. Double-click the Description field of the Piazza San Marco to start editing. Paste the description from the previous step and press Enter.
  8. Use the same process to give the Ponte di Rialto the following description:

    The Ponte di Rialto, or Rialto Bridge, is the oldest of the four bridges that span Venice's Grand Canal. Historically, it provided an important connection to the main financial center of the city, the Rialto market. During acqua alta (high water) conditions, the majority of the elevated bridge remains dry, but surrounding areas require wooden footbridges to allow pedestrians safe travel.

  9. Use the same process to give the Isola di San Michele the following description:

    San Michele has served as Venice's cemetery since the early 19th century and holds the graves of Igor Stravinsky and Ezra Pound. Although the Cappella Emiliana chapel on the edge of the island is protected from flooding by metal barriers, it remains in danger of damage from particularly high flood water.

  10. Confirm that all points have names and descriptions.

    Attribute table updated

  11. Close the attribute table.
  12. On the Edit tab, in the Manage Edits group, click the Save button and save all edits.
  13. Click Save on the Quick Access Toolbar to save your project.

You've symbolized layers and modified features. Previously, the map was symbolized in an unappealing and unclear way. The data also lacked key features that represented some of the most important landmarks in the city. You're now ready to explore the problem of flooding in Venice.


Explore 3D data

Next, you'll begin to analyze flooding in Venice. Known to locals as acqua alta, flooding in Venice is a tale of two elevations: the low elevation of the city and the high elevation of the lagoon during extreme tide levels. Previously, you worked with 2D data, but elevation adds a new dimension: height.

Your goal is to determine how much of Venice is affected at an exceptional tide, defined as 1.4 meters above sea level. To communicate your results in a meaningful way, you need to be able to visualize your 3D data. In this lesson, you'll add a layer of elevation to your map. Then, you'll convert your data into 3D to better understand Venice's elevation—or lack thereof.

Add and explore raster data

Previously, you worked with feature data: data displayed as discrete objects, or features. While feature data is great for depicting structures, canals, or landmarks, it is not the best way to depict elevation over a continuous surface. For that, you'll use a different type of data, called raster data.

Raster data is composed of many pixels, each with its own value. Although it looks different from feature data, you add it to the map in the same way.

  1. If necessary, open the Venice Acqua Alta project in ArcGIS Pro.
  2. On the Map tab, in the Layer group, click the Add Data button.
    Note:

    If you're using ArcGIS Enterprise, browse to VeniceData and add the Venice_Elevation_Data item and skip to step 6.

  3. In the Add Data window, under Portal, click ArcGIS Online.
  4. In the search box, type Venice_Elevation_Data owner:Learn_ArcGIS and press Enter.

    Search for data

  5. Double-click Venice_Elevation_Data to add it to the map.
    Note:

    The package is a somewhat sizeable 150 MB and may take several minutes to download, depending on your network connection.

  6. In the Contents pane, if necessary, expand the new layers.

    The package contains two layers: Venice 1m and Venice Ground Surface.

    Like before, because the layers were added as part of a layer package, they're put in a group layer on the Catalog pane.

  7. In the Contents pane, uncheck the boxes next to Landmarks, Canals, and Structures, leaving only Venice 1m and the basemap visible.

    Venice 1m raster layer

    Unlike the other feature layers you have explored so far in this lesson with shape geometry, Venice 1m is a raster layer that uses pixel matrixes in which each pixel stores its own value. The name of the layer, Venice 1m, refers to its resolution: the size of its pixels. The 1m means that each pixel represents an area of one square meter.

  8. In the Contents pane, click the arrow next to Venice 1m to view its symbology.

    Venice 1m symbology

    Instead of a single symbol, this layer has a color scheme for different values. The values represent elevation in meters. Venice's elevation ranges from just below sea level (dark) to about eleven meters above sea level (light)—very flat terrain.

  9. On the Map tab, in the Navigate group, click Explore. Click anywhere on the raster layer to open a pop-up.

    Venice 1m pop-up

    In the example image, the pixel has an elevation of about 2.9 meters above sea level.

  10. Close the pop-up.

    From examining the map, you may conclude that most of Venice lies only about 1 meter above sea level, with the eastern and western ends of the city at a somewhat higher elevation. Such a low-lying environment leaves Venice susceptible to flooding. To better understand Venice's extremely flat terrain, you'll visualize it in 3D.

Convert a map to a scene

Traditionally, a map displays data in 2D. A scene is a map that displays data in 3D. By default, ArcGIS Pro will convert a map to a global scene, which depicts the entire world as a spherical globe. Since your area of interest is Venice, not the entire globe, you'll alter the settings so the map converts to a local scene instead.

  1. On the ribbon, click the View tab. In the View group, click Convert and choose To Local Scene.

    Convert button

    Your map converts to 3D, creating a new pane called Map_3D. You can return to your 2D map at any time by clicking the Map tab.

  2. In the Contents pane, uncheck Venice 1m to turn it off. Check Structures, Landmarks, and Canals to turn them on.
    Note:

    In scenes, layers are designated as either 3D or 2D. Currently, your layers are 2D layers, which is part of the reason why they are still flat. You'll change this later in the lesson.

    Default Venice scene

  3. Navigate the 3D scene by pressing V while dragging the pointer to tilt and rotate the scene. Pan and zoom the same way you would in a 2D map. You can also zoom by right-clicking.

    Tilted Venice scene

    The flatness of Venice's terrain contrasts with the hills in the distance. Since your raster layers do not extend past Venice, where did those hills come from? By default, scenes use a map of elevation data, called an elevation surface, to determine the ground's elevation. This default surface spans the entire world, although at a low resolution (meaning low detail).

  4. Return to the Venice bookmark.
    Note:

    When you converted your map to a scene, you also converted your map's 2D bookmarks to 3D bookmarks. Both sets of bookmarks are currently identical, so you can use either.

Add an elevation source

For visualization purposes, the default ground surface accurately depicts Venice as incredibly flat. However, its low resolution makes it inadequate for detailed analysis. To prepare for the next lesson, you'll add one of your high-resolution raster layers as a new elevation surface.

  1. In the Contents pane, check the Venice Ground Surface layer to turn it on.

    Venice ground surface

    The Venice Ground Surface layer has similar elevation data to the Venice 1m layer but includes sea level elevation data for some of the surrounding lagoon. The extra data provides context to Venice's elevation and helps set the scene. You'll set this layer as your ground elevation.

  2. On the Map tab, in the Layer group, click the Add Preset button and choose Ground.

    Add Preset button

    The Add Data window appears. Normally, you can access layers used in your project from the project's associated databases and folders. Since you downloaded the Venice Ground Surface layer and added it directly to your map, you cannot access it from your project. Instead, you'll browse to its location on your computer.

  3. In the left pane, under Computer, click Documents.

    Add Data left pane

    Layer packages are saved to your ArcGIS folder when you download them. The ArcGIS folder is automatically created in your Documents folder when you use an ArcGIS application on your computer. It serves as the default output location for anything you make using an ArcGIS application and is also where your project is saved.

  4. Browse to the layer you'll use to set the ground elevation using the following path:
    1. From the Documents folder, open the ArcGIS folder.
    2. Open the Packages folder.
    3. Open the folder that begins with Venice_Ground_Surface and ends with an ID string.
    4. Open the p folder that corresponds to the version of ArcGIS Pro you're using. P20 is compatible with ArcGIS Pro 2.0 and higher, while p12 works with versions prior to 2.0.
    5. Open the raster_data.gdb geodatabase.

    The geodatabase contains two files: venice1m (the Venice 1m layer) and venicesource (the Venice Ground Surface layer).

    Add Preset venicesource

  5. Click venicesource and click OK.

    The venicesource layer is added to the Contents pane under the Elevation Surfaces section. There are two elevation sources. The first is the venicesource layer you just added, and the second is the default surface.

  6. Click the Add Preset button and choose Ground.
  7. Click venice1m and click OK.
  8. Click OK.

    The new elevation source is set as the ground in the area around Venice. The default elevation values are still used in the area outside Venice, so you can still see the hills in the background.

  9. In the Contents pane, under 2D Layers, uncheck Venice Ground Surface to turn it off.
  10. Pan, zoom, and tilt to navigate the scene and better view the new ground elevation.

    Updated Venice scene

    You may have to zoom very close to see the shifts in elevation—Venice is incredibly flat and low-lying. The dramatic lack of elevation puts into perspective how serious flooding can be in Venice.

Display the Landmarks layer in 3D

As you see when you tilt the scene, the Landmarks layer is displayed as a 2D layer, with its push pin symbol flat on the ground. While this layer does not have elevation data, you can give depth to the push pin symbol by changing how the layer is displayed.

  1. In the Contents pane, under the 2D Layers section, drag the Landmarks layer from the 2D Layers group to the 3D Layers group.

    3D Landmarks

    The push pins appear in 3D, standing upright as you rotate and pan the map.

    Venice scene

Extrude the Structures layer

Another layer that is currently flat but could be displayed in 3D is the Structures layer. Unlike the Landmarks layer, the Structures layer has height data in its attributes. To display the layer in 3D, you'll use a command called extrusion, which displays features in 3D using a constant or an attribute as the z-value.

  1. In the Contents pane, drag the Structures layer from the 2D Layers group to the 3D Layers group, placing it under the Landmarks layer.

    The appearance of the Structures layer changes slightly, but it's still flat. To extrude the features, you'll use an attribute to determine each feature's z-value.

  2. In the Contents pane, right-click Structures and choose Attribute Table.

    Attribute table

    The table has five fields, one of which is Height. You'll extrude the Structures layer with the values in this field.

  3. Close the attribute table.
  4. On the Appearance tab, in the Extrusion group, click the Type button and choose Max Height.
    Note:

    The Appearance tab is contextual, meaning it only displays under certain circumstances. This tab only appears if a layer is selected in the Contents pane. Make sure the Structures layer is selected before proceeding.

    Type button

  5. In the Extrusion group, for Field, choose Height. Leave the Unit parameter unchanged.

    Field parameter

    The features are extruded, meaning they are given a height value based on the selected field. They now appear 3D on the map.

    Extruded scene

  6. Save the project.

You've converted your 2D map into a scene and adjusted elevation and rendering settings to display your data more effectively. From your observations, Venice is incredibly low-lying and flat, placing it in danger of even small increases in water level.


Analyze acqua alta conditions

Previously, you created a 3D map of Venice and observed its drastically low elevation. Next, you'll calculate the percentage of the city submerged during acqua alta conditions and depict the flooding in 3D.

You'll first create a raster representing submerged portions of the city. Then, you'll calculate the area affected. Finally, you'll use your scene from the previous lesson to visualize the flooding.

Create a flood raster layer

To create a raster of the flooded parts of Venice, you need two values: the elevation of the land and the height of the water above sea level. You already have the land—it's the Venice 1m raster from the previous lesson. For the water, you'll use a height of 1.4 meters, which the Venetian municipality defines as an exceptionally high tide. In the past, an exceptional tide has occurred once about every four years. Between 2008 and 2014, however, there were six recorded exceptional tides: a rate of one per year.

With these values, you'll use a mathematical expression to create a raster layer of flooded areas and areas that are not flooded. Then, you'll remove the areas that are not flooded, leaving a layer of only the areas underwater.

  1. If necessary, open the Venice Acqua Alta project in ArcGIS Pro.

    To create your flood layer and calculate its area, you'll create other layers as stepping stones toward the final product. To keep these layers from cluttering your scene, you can use your 2D map as a workplace.

  2. Click the Map tab to return to your 2D map.

    Map tab

  3. Click the Analysis tab, and in the Geoprocessing group, click Tools.

    Tools button

  4. In the Geoprocessing pane search box, type Raster Calculator. Click Raster Calculator (Spatial Analyst Tools).

    Search Raster Calculator

    The Raster Calculator tool applies a mathematical expression to an existing raster to create a raster. You'll apply an expression to the Venice 1m raster to determine flood extent.

  5. In the Map Algebra expression box, create the expression "Venice 1m" < 1.4.
    Tip:

    To add "Venice 1m" to the expression, double-click Venice 1m under Rasters. To add <, under Tools, double-click the less than operator.

    Map Algebra expression

    You will use the value 1.4 meters as the water height in your analysis. It represents an exceptionally annual high water level. Although it does not occur often, it is the scenario municipal authorities should be most prepared for. Optionally, you can change the water height in your analysis by changing the value in this expression.

    The expression determines whether each pixel value in the Venice 1m raster is less than 1.4 (a pixel value lower than the water height) or more than 1.4 (a pixel value higher than the water height) and assigns a value of 1 or 0 to each pixel.

    For instance, a pixel in the Venice 1m raster has a value of 1.2 meters. Since this value is less than 1.4, the expression is true and the pixel is assigned an arbitrary value of 1 for true. If the pixel value is 1.6 meters, however, the expression is false and the pixel is assigned a value of 0 for false.

  6. In the Raster Calculator tool, for Output raster, type Flood_Calculation and click Run.

    The layer is added to the map.

  7. Uncheck all layers except Flood_Calculation and the basemap.

    Flood calculation

    Note:

    The layer's colors are randomly assigned. You can change the colors by clicking the symbols under the layer name in the Contents pane.

    Pixels with a value of 1 in the new raster represent flooded regions, while pixels with a value of 0 represent regions that are not flooded. For your analysis, only flooded regions are important. Next, you'll remove the values for regions that are not flooded from the raster so they don't interfere with your analysis.

  8. In the Geoprocessing pane, click the Back button to return to the search box.

    Back button

  9. Clear the existing search and type Set Null. Click Set Null (Spatial Analyst Tools).

    Search Set Null

    The Set Null tool changes pixel values to NoData values, which will be ignored during analysis.

  10. In the Set Null tool, for Input conditional raster, choose Flood_Calculation.
  11. In the Expression box, create the expression Where Value is equal to 0.

    Set Null query

  12. For Input false raster or constant value, choose Flood_Calculation.

    This parameter will keep values that are not 0 (in this case, values of 1) unchanged.

    If necessary, click the Browse folder and select Flood_Calculation from the Venice Acqua Alta.gdb

  13. Change the Output raster name to Flood_Region and click Run.

    Set Null parameters

    The raster layer is added to the map.

  14. In the Contents pane, uncheck Flood_Calculation to turn the layer off.

    Flood region

    This raster has only one value, which indicates the regions flooded at a water level of 1.4 meters. So how much of Venice is flooded? It looks like a lot, but you'll need to perform additional analysis to quantify the area.

  15. Save the project.

Calculate the submerged area

The flooded area equals the cell size (one square meter) multiplied by the number of cells in the raster with a value of 1. You can make this calculation using a tool called Zonal Geometry. Zonal Geometry calculates the area for each zone of a raster, with a zone defined as all cells with the same value. Since you only have one value, there is only one zone.

  1. In the Geoprocessing pane, click the Back button to return to the search box. Clear the existing search and type Zonal Geometry. Click Zonal Geometry (Spatial Analyst Tools).

    Search Zonal Geometry

  2. In the Zonal Geometry tool, for Input raster or feature zone data, choose Flood_Region.
  3. Change the Output raster name to Flood_Statistics and leave the other parameters unchanged. Confirm that your parameters look like the following graphic:

    Zonal Geometry parameters

  4. Click Run.

    The raster layer is added to the map.

    Zonal Geometry layer

  5. Click anywhere on the Flood_Statistics layer to view its pop-up.

    Flood area pop-up

    The pixel value gives the total area of the flood zone (every pixel has the same value). The value is approximately 7.4 million square meters, or about 7.4 square kilometers.

  6. Close the pop-up and save the project.

    The total area of Venice is about 12.9 square kilometers. When flood levels reach 1.4 meters, about three-fifths of the city (57.3 percent) is underwater.

Create the Floodwater layer

You've analyzed how much of Venice is affected by flooding at a certain water level. Next, you'll model that flooding in your 3D map to combine your analysis with a visual component.

  1. Click the Map_3D tab to return to your scene.

    Map_3D tab

    None of the raster layers you created in the previous sections appear in your scene, because you made them in the 2D map and did not convert them. You won't need them anyway. To model water level in 3D, you'll create a polygon layer and extrude it.

  2. In the Geoprocessing pane, click the Back button to return to the search box. Clear the existing search and type Raster to Polygon. Click Raster to Polygon (Conversion Tools).

    Search Raster to Polygon

    The Raster to Polygon tool converts a raster layer to a polygon layer, which will put your flood raster into a format that can be extruded.

  3. In the Raster to Polygon tool, for Input raster, click the Browse button.

    Your flood raster isn't in the Map_3D Contents pane, so instead of selecting it from a list, you will browse to the folder containing the raster data.

  4. In the left pane of the browser window, under Project, click Databases. Double-click the database with the same name as your project (Venice Acqua Alta). Click the Flood_Region raster layer and click OK.

    Search for raster

  5. For Output polygon features, type Floodwater. Leave all other parameters unchanged.

    Raster to Polygon parameters

  6. Click Run.

    The polygon layer is added to the map.

    Floodwater layer

  7. Save the project.

Add height attribute data for the Floodwater layer

The new polygon layer doesn't have an attribute representing water height, which you'll need to extrude the layer properly. You'll add a new attribute to the table and give it the correct value.

  1. In the Contents pane, right-click Floodwater and choose Attribute Table.

    Attribute table

    The Floodwater layer has thousands of features, representing each polygon in the layer.

  2. At the top of the attribute table, click the Add Field button.

    Add Field

    The Fields view appears. Here, you can edit the parameters of existing or new fields.

  3. In the empty field at the bottom of the table, for Field Name, type Height. For Data Type, double-click the existing value and choose Float, which allows data to have decimals. Leave the other parameters unchanged.

    New field parameters

  4. On the ribbon, on the Fields tab, click Save.

    Save button

    The changes are saved and the field is added to the table.

  5. Close the Fields view.
  6. Locate the Height field in the Floodwater attribute table.

    Height field

    The Floodwater layer now has a field to store the height data, but the values are Null. You'll need to edit the values.

  7. At the top of the attribute table, click the Calculate Field button.

    Calculate Field button

    the Calculate Field window appears.

  8. In the Calculate Field window, for Field Name, choose Height. In the Expression text box, type 1.4.

    Calculate field parameters

  9. Click OK.

    The values in the Height column of the attribute table change to 1.4.

  10. Close the attribute table.

Extrude the Floodwater layer

The Floodwater layer now has height data to extrude. However, it's currently still a 2D layer at the same elevation as the ground, rather than at sea level. Since water level is measured in meters above sea level, you need to change this setting.

  1. In the Contents pane, drag Floodwater from 2D Layers to 3D Layers, placing it below Landmarks.

    3D Floodwater

  2. In the Contents pane, right-click Floodwater and choose Properties.

    The Layer Properties window appears.

  3. In the Layer Properties window, click Elevation. For Features are, choose At an absolute height.

    At an absolute height

    The default absolute height is 0 meters, or sea level, so leave the other values unchanged.

  4. Click OK.

    Now you can extrude the Floodwater features.

  5. On the Appearance tab, in the Extrusion group, click Type and choose Max Height. In the drop-down box next to Type, choose Height. Leave the Unit parameter unchanged.

    Extrusion

    The Floodwater layer is extruded to the height of 1.4 meters.

Symbolize the Floodwater layer

Since the symbology of the Floodwater layer was randomly generated, it may not reflect a color associated with water. You'll change it and explore your scene.

  1. In the Contents pane, click the symbol for Floodwater to open the Symbology pane.
  2. Click the Gallery tab, if necessary, and in the search box, type Water and press Enter. If necessary, expand the ArcGIS 2D heading.

    Symbology pane

    The search returns multiple water symbols.

  3. Choose the Water (area) symbol that you like best.

    Symbolized floodwater

  4. Close the Symbology pane.
  5. Click the Appearance tab, in the Effects group, change Transparency to 50.0%.

    Transparency

    Transparency will prevent the Floodwater layer from obscuring the other layers.
  6. Explore your scene. Zoom in and view the structures inundated with flood water, such as those in the Piazza San Marco.

    Piazza San Marco

    The places where the transparent floodwater layer touches the sides of the structures indicate inundation. By exploring the landmarks and the areas around them, you can see several locations of potential damage to architecture.

    The Riva degli Schiavoni is one example:

    Riva degli Schiavoni

    The Campo Santi Giovanni e Paolo is another example:

    Campo Santi Giovanni e Paolo

    And the Santa Maria della Salute is another:

    Santa Maria della Salute

    Note:

    When zoomed in, the extruded structures may make it difficult to see some of the landmarks. You can turn the Structures layer off or make it transparent to help you navigate.

    Which landmarks are most affected by flooding? Which are least affected? Are any not affected at all? With your scene, you can answer these questions.

    Flood modelling has many practical aspects. Knowing where structures will be inundated can help focus restoration efforts, minimizing or preventing water damage to Venice's historic structures. It can also give authorities information to construct elevated walkways and keep transportation around the city flowing. When combined with the analytical data you compiled, your 3D map can provide a valuable tool for instruction and urban planning, helping Venice prepare for the acqua alta conditions that frequently impact it.

  7. Save the project.

You've used geoprocessing tools to create a flood raster and calculated the percentage of Venice affected by flooding. You also converted your raster to a polygon to show the potential extent of damage caused by acqua alta.


Display a scene with realistic detail

Previously, you finished your analysis of the flooding problem in Venice. Although you came up with results you can visualize and show others, your scene could be even more compelling. Currently, all of the structures in your scene use the same generic symbology. Next, you'll add special 3D textures and models to your scene to give it a realistic appearance.

Apply a rule package to the Structures layer

The symbology of the structures is okay in 3D but doesn't give the impression of a realistic city model. To make the structures look more realistic, you can set the layer's symbology with a rule package created in ArcGIS CityEngine. Rule packages contain a series of design settings that create more complex symbology. Although you can't create rule packages in ArcGIS Pro, you can apply and modify them from an external file.

  1. Download the Venice Facades rule package.
  2. Locate the compressed file in your Downloads folder. Use Windows Explorer to extract its contents to the Documents folder on your computer's C: drive or a location of your choosing.

    The extracted file is a single file: VeniceFacades.rpk.

  3. If necessary, open the Venice Acqua Alta project in ArcGIS Pro.
  4. In the Contents pane, click the symbol for Structures.
  5. In the Symbology pane, click Properties and click the Layers button.

    Symbology pane layers

    You'll change the solid fill symbology to a procedural fill using the rule package you downloaded.

  6. Click Solid fill and choose Procedural fill.

    Procedural layer

    The options change to show the procedural fill settings, but they are currently empty. You'll need to assign a rule.

  7. Click Rule.

    Rule button

    The Select Rule Package window appears.

  8. Browse to the location of the extracted VeniceFacades.rpk file and double-click it.
    Note:

    You may need to refresh the Select Rule Package window to access the rule package.

    The Symbology pane populates with several symbology settings, or rules, that you can adjust. For now, you'll see what the default settings look like.

  9. Click Apply.
    Note:

    It may take some time for all of the structures to update.

  10. Zoom to Piazza San Marco and explore the map to get a closer look at the updated symbology.

    Applied rule default

    The structures now have realistic-looking textures instead of generic colors. However, the tower in the Piazza San Marco has shrunk to a small, flat building. The heights of other buildings have changed as well. One of the rules in the package determines height, overriding the height attribute you used to extrude the structures. You'll fix this problem by adjusting the rule settings.

  11. In the Symbology pane, examine the rules.

    Symbology pane rules

    The Nbr_of_Floors setting determines how many floors a structure will have, while the Floor_Height setting determines how high each floor will be. At the current settings, each structure has three floors of approximately four meters each, before the roof is included.

    Although you can adjust the floor height to any static number between 3 and 4.5 (the minimum and maximum values set in the rule), you can also map the rule to the structure's height attribute.

  12. For the Floor_Height setting, click the Set attribute mapping button.

    Set attribute mapping button

    The Set Attribute Mapping window appears. You could set the floor height to be exactly the same as the structure's height attribute, but each structure has three floors. To account for the number of floors, you'll create an expression to set floor height to one-third the height attribute.

  13. In the Set Attribute Mapping window, click the Set an expression button.

    Set an expression button

    The Expression Builder window appears.

  14. In the Expression Builder window, build the expression $feature.Height/3.

    Expression Builder

  15. Click OK. In the Set Attribute Mapping window, click OK.
  16. In the Symbology pane, click Apply and close the Symbology pane.

    The structures update with the new height data.

    Note:

    It may a few minutes for the features to redraw.

    Applied rule

    Next, you'll change the basemap to add to the scene's appearance.

  17. On the Map tab, in the Layer group, click Basemap.

    Basemap button

  18. Choose the Imagery basemap.

    Imagery basemap selected

    Your scene looks more like the real-life Venice.

    Imagery basemap applied

  19. Save your project.

Add a 3D model of the Piazza San Marco

While the rule package's symbology functions as intended for most of the structures in Venice, the famous structures of the Piazza San Marco (such as the Doge's Palace and St. Mark's Basilica) would look better with more detailed symbols that capture their unique architecture. You'll add new features that were specially designed in CityEngine to have the look of these famous structures, completing your scene.

  1. On the Map tab, click the Add Data button.
  2. In the Add Data dialog box, under Portal, click ArcGIS Online. In the search box, type Piazza_San_Marco owner:Learn_ArcGIS and press Enter.
  3. Double-click Piazza_San_Marco to add it to the scene. Zoom to the Piazza San Marco bookmark to view the new features.

    New features

    The new features are added, but they overlap with the existing Structures layer.

  4. In the Contents pane, turn off all layers except the Piazza San Marco layer and the basemap.
  5. Pan, zoom, and tilt the scene to explore the new features.

    Piazza San Marco

    The new features have elements such as the domed roofs and arches of St. Mark's Basilica that could not be achieved by applying rules to extruded features. These features are multipatch features. Unlike extruded features, such as the Structures layer, multipatch features are not simply 2D footprints given a uniform height value. Instead, their third dimension has been specifically modeled in CityEngine, allowing for much more detail.

    Next, you'll remove the features in the Structures layer that overlap with the Piazza San Marco. You'll select the overlapping features and delete them completely from the dataset. Since it is not recommended to delete features without having a backup of the original data, you'll make a copy of the data first.

  6. In the Contents pane, right-click the Structures layer, point to Data, and click Export Features.

    Export Features

    The Export Features window appears.

  7. In the Export Features window, for Output Name, type Structures_Copy.

    Export Features parameters

    The copy will be saved to the project's default geodatabase, which is where the Floodwater layer from the previous lesson is saved.

  8. Click OK.

    The copy of the original Structures layer is added to the map as a 3D layer. Now that you know your data has a backup, you no longer need the copy on the map. You'll remove it before you start deleting features from the original Structures layer.

  9. In the Contents pane, right-click the Structures_Copy layer and click Remove. Check the Structures layer to turn it on.
  10. On the Map tab, in the Selection group, click the Select By Location button.

    Select By Location

    The Geoprocessing pane opens to the Select Layer By Location tool.

  11. In the Select By Location window, for Input Features, choose Structures. For Selecting Features, choose Piazza San Marco. Leave the other parameters as they are.

    Select by Location parameters

    The tool will select all features in the Structures layer that touch (intersect) the Piazza San Marco layer.

  12. Click OK.

    The selected features are highlighted in a cyan color.

    Selected features

  13. Explore the selected features.

    As you explore, you may notice two features that were selected although only a small edge touches the Piazza San Marco features, circled in the below image:

    Not overlapping features

    Since these features don't really overlap, there's no reason to remove them. You'll unselect them while keeping the rest of the features selected.

  14. On the Map tab, in the Selection group, click the Selection Options button.

    Selection Options

    The Options window appears open to the Selection tab.

  15. In the Options window, for Selection combination mode, choose Remove from the current selection.

    Set selection options

    By choosing this setting, when you use the Select tool, the features you click will be unselected, while the other features will remain selected.

    Tip:

    You can also remove features from the current selection by holding the Ctrl key while clicking the features.

  16. Click OK.
  17. On the Map tab, in the Selection group, click the Select button.

    Select button

  18. Find the feature at the southern end of the Piazza San Marco that doesn't overlap and click it to unselect it.
    Tip:

    If you need to pan, zoom, or tilt to get closer to the feature, press and hold the C key to enable the Explore tool.

    Unselect 1

    Tip:

    If you unselect the wrong feature, you can reselect it by returning to the selection options and choosing Add to the current selection for Selection combination mode.

  19. Find the feature at the northern end of the Piazza San Marco that doesn't overlap and click it to unselect it.

    Unselect 2

    Tip:

    Once you finish unselecting, you may want to change the Selection combination mode setting back to its default, Create a new selection.

    Next, you'll remove the selected features.

  20. Click the Edit tab, and in the Features group, click Delete.

    Delete button

    The remaining selected features are removed completely.

    Piazza San Marco final

  21. In the Manage Edits group, click Save. In the Save Edits dialog box, click Yes to save the edits.
  22. In the Contents pane, check the Landmarks, Floodwater, and Canals layers to turn them back on.
  23. Save your project.

    Your scene is finished.

    Completed map

Your scene is finished. You used rule packages and multipatch features to give your scene a realistic appearance. Your analysis from previous lessons is now combined with an attractive map output and is ready to be shown to the world.

You can find more lessons in the Learn ArcGIS Lesson Gallery.