Install Insights and work with incident data

First, you'll become familiar with some of the main functions for preparing your data in ArcGIS Insights as you begin your analysis of incident data. You must first gain an understanding of where and when the incidents are occurring to propose proper preventive measures. The incident data will be imported from a CSV spreadsheet to be prepped in Insights. Once you have a better understanding of your datasets, you'll be prepared to analyze later.

Install and activate ArcGIS Insights Desktop

Although this lesson can be completed with Insights in ArcGIS Online or ArcGIS Enterprise, you are encouraged to try this lesson in Insights desktop. If you already have Insights desktop installed, or if you prefer to do the lesson in ArcGIS Online or ArcGIS Enterprise, skip this section and begin at the Add incident data section.

Otherwise, follow the steps below to install and activate Insights desktop. Insights desktop is compatible with both macOS and Windows.

Note:

To help you get set up properly, reference the system requirements for running Insights and learn how how to administer Insights in ArcGIS Online or ArcGIS Enterprise.

  1. Go to the download page for Insights desktop.
  2. Choose Windows or MacOS for the operating system.
  3. Select a language from the list of supported setup languages.

    The language you choose will be used when you run the installation program.

  4. Fill in the remaining fields on the form. Fields marked with an asterisk (*) are required.
  5. Read Esri's privacy statement and check the boxes if you agree. Click Submit.

    The installation program is saved in your browser's default download location. The installation program includes the Insights desktop app and English language reference help.

  6. Browse to the location of the downloaded installation file, double-click it to begin the setup, and click Run.
  7. Review the information in the wizard and click Next to proceed.
  8. Accept all defaults, click Next, and Close the dialog box to launch the setup application.
  9. In the setup wizard, click Next, click I accept the master agreement, click Next two more times, and click Install.

    The installation program runs, and Insights desktop is installed on your computer. A shortcut icon is added to your desktop and can be used to launch Insights desktop.

  10. Click Finish to close the wizard when the installation completes.

    Insights desktop is now installed on your computer and ready to use.

    Note:

    The first time you open Insights desktop, you will be prompted to activate it using your organizational account, which can be ArcGIS Online or ArcGIS Enterprise, depending on your setup.

Sign in and activate the app

You have installed Insights desktop and now you will sign in to it using your organizational account.

  1. From the Start menu, choose ArcGIS Insights.

    The application launches with the Activate license splash screen displayed.

    Note:

    The default URL is www.arcgis.com, which you will keep if you are using an ArcGIS Online account. If you are using the URL for your ArcGIS Enterprise portal, then you can use that in place of www.arcgis.com

  2. Click Sign in to activate.
  3. Enter the user name and password for either your ArcGIS Online or ArcGIS Enterprise account. The account must include the necessary licensing to access to Insights.
  4. Click Keep me signed in.
  5. Click Sign in, and once you successfully sign in, click OK.

Add incident data

Now that you are signed in, you will download a CSV file containing incident data from ArcGIS Online and add it to a workbook.

  1. Go to the IncidentData item and click Download.
  2. Once the .zip file is downloaded, extract its contents to a folder that is easily accessible.

    The .zip file contains an Excel CSV spreadsheet containing yearly incident data in Washington, D.C.

  3. If you have not already, open Insights and click Sign in and sign in using your organizational account.

    The first thing you must do before you work with data is to create a workbook. Workbooks act as the canvas for you to add maps, tables, and charts to visualize your data.

  4. If necessary, in the Welcome to Insights window, click Skip.
  5. On the home page, click the Workbooks tab, and click New workbook.

    New workbook button

    A workbook is created, and you are prompted to add data to the page. You will upload the CSV spreadsheet and add it to the page.

  6. Click Browse my computer.
  7. Browse to where you stored the Incidents CSV file and double-click it to add it. The Incidents CSV file is selected to be added to the workbook.

    Incidents data selected.

  8. Click Add.

    The data is added to your workbook and displays as a dataset in the data pane.

    Incidents data added to workbook.

    Next, you will do some basic data preparation steps before visualizing and analyzing the incidents.

  9. In the data pane, click the arrow next to the Incidents dataset to expand it.

    Expand dataset.

    The incident dataset's fields are listed below. Not all the fields are relevant for your analysis, so you will hide some of them.

  10. Click the following fields to select them (a check mark will appear and the field will be highlighted):
    • METHOD
    • BLOCK
    • DISTRICT
    • PSA
    • WARD
    • ANC
    • NEIGHBORHOOD_CLUSTER
    • BLOCK_GROUP
    • CENSUS_TRACT
    • VOTING_PRECINCT
    • CCN
    • XBLOCK
    • YBLOCK

    Selected fields

  11. For the Incidents dataset, click Dataset options, and click Hide Selected Fields.

    Hide fields.

    Often, field names are cryptic, capitalized, or contain underscores. You will rename some fields so that they are easier to interpret.

  12. Point to the REPORT_DAT field and click Rename Field.

    Rename Field button

  13. Type Incident Date as the field name.

    Field renamed to Incident Date.

    The last two fields in the incident dataset, x and y, represent latitude-longitude coordinates for the incidents. You will use these two fields to enable location on the dataset.

  14. For the Incidents layer, click Dataset options, and choose Enable Location.

    Enable Location

  15. On the Enable location dialog box, keep the default options for all parameters.

    You can enable location using coordinates, addresses, or another geography, such as a boundary dataset. In this case, you will use the Coordinates option because your incident data has location fields (x and y). In incident data, there may be multiple incidents that occurred at the same location. To ensure that all incidents display on the map, you choose to repeat identical features.

  16. Check Repeat identical features.

    Enable location parameters

  17. Click Run.

    A Coordinates field is added to the incident dataset. You will use this field in the next section to map the incidents.

    Coordinates field

    Next, you will save your workbook.

  18. At the top of the application, click Untitled Workbook. Type Data-driven policing.
  19. On the ribbon, click Save.

    Save button

    Your workbook is saved containing the location-enabled Incidents dataset.

Now that your data has been prepared and location-enabled, you can begin visualizing and analyzing it using maps and charts.


Visualize incidents using maps and charts

You have added incident data to your workbook, and it is ready to use for visualization and analysis. Next, you will learn how to create cards in your workbook. Cards are windows that contain a specific type of visualization, such as a map, table, bar chart, pie chart, and so on. You use map cards to display location data and experiment with the symbology options to determine the best visualization for your data. You can also create tables and many types of charts to get a visual picture of a dataset's attributes. Creating many types of cards, analyzing what you discover, and identifying patterns or relationships is what Insights is all about.

Visualize incident data

Next, you will learn two mapping options that are useful for visualizing many points: binned maps and heat maps. Binning helps by viewing large amounts of point data in various polygons or bins, while heat maps will create concentrations of incidents that are color-coded according to which bin they fall within.

  1. If necessary, open the Data-driven policing workbook.

    With the coordinates field that was added after enabling location on the Incidents dataset, you can now view the incident locations on a map. In Insights, you can drag fields onto the workbook and the various options for the types of cards that you create appear.

  2. In the dataset pane, click the Coordinates field and drag it onto the workbook.

    The three main card drop zones appear.

    Card options

    Drop the Coordinates field onto the Map drop zone to create a map card.

    Visualizing Coordinates field on a map.

    Now you can see the incidents, which were previously just rows of information in a spreadsheet, as points on a map. However, just looking at the points on a map is not the most effective visualization type. You can begin to look at general patterns of distribution throughout the city by trying different map visualization types.

  3. In the map card, next to the Incidents layer, click the arrow to open the Layer options.

    Open Layer options.

    The Layer options pane allows you to configure a layer's symbology and view its attributes. You will begin by modifying the symbol type.

  4. In the Layer options pane, click Options. For Symbol type, click the down arrow, and choose Bins.

    Bins symbol type

    The incidents display using bins.

    Bins displayed in map.

    Binned maps provide a quick representation of how your data is distributed. This map visualization is helpful for finding spatial patterns in large datasets. You will now explore the map's legend to see which areas of the city have the highest counts of incidents according to the binned map.

  5. In the Layer options pane, click Legend.

    Legend button

    The legend shows that deep purple bins in the map indicate more incidents, while lighter yellow bins indicate fewer incidents.

    Bin legend

  6. Click the symbol for the darkest purple color, which represents values 313 – 618.

    Click the darkest purple bin.

    Clicking the symbol in the legend emphasizes the bins within that range in the map.

    Purple bins in map

    The bins with the most incidents tend to be near the center of the city (results may vary based on how the bins respond to the zoom level of the map).

  7. In the Layer options pane, click other bins to see the distribution.

    Notice that the bins start to disperse outward from the city center. This general pattern shows there are more crime incidents in the city center than there are as you expand farther out to the city boundaries.

  8. Click anywhere in the map, on the base map, to display all incidents.

    Another map visualization type is a heat map. Heat maps help you visualize areas with the most point features as the hottest.

  9. In the Layer options pane, click Options, and for Symbol type, choose Heat Map.

    Heat Map option

  10. Click the Legend button.

    Heat map and legend

    The map and legend show that areas in bright yellow are considered the hottest, meaning there are more incidents, and the blue areas are cooler, or have fewer incidents. Based on your observations of the incidents displayed using bins, it makes sense that the yellow areas are in the city center.

  11. On the map card, use the mouse wheel button and zoom in and out from the data. Also, click the map and drag it to pan.

    When panning and zooming, the heat map visualization dynamically changes based on the map extent, as the features are not as densely distributed as a larger scale. By exploring your data in this way, you can begin to identify specific areas or corridors that have more incidents.

    Zoomed in to heat map

  12. Close the Layer options pane. On the map card, click the Default Extent button to return to the original map extent.

    Default extent button

  13. Click anywhere off the map card to deselect the card and show its title, Card 1. Click Card 1 to edit it, and type Incident Heat Map as the card name.

    Card renamed.

    The card is renamed to a more meaningful title.

    You now have a powerful visual of a heat map of incidents. However, heat maps are more of a visual aid than an accurate way to show point density; they are best when used with another visualization type, such as a time series chart. Next, you will begin to incorporate time into your analysis of the crime incidents.

Integrate time into your analysis

Visualizing and analyzing spatial data is an integral component to any GIS project. It is vital to know where things are in relation to other things to help recognize patterns. Another element that is important to GIS analysis is time. Incorporating time into your analysis unlocks other potential because now you can see where things are, but also see and analyze when things happened. For crime incidents, analyzing where and when they occurred can help you determine a spatiotemporal pattern. For example, a high number of auto thefts occur on Fridays between 8:00 p.m. and midnight and that is important information to know for theft reduction strategies to be implemented properly.

  1. If necessary, in the data pane, expand the Incidents dataset.

    The Incidents dataset contains a field named REPORT_DAT, which stores the date and time of the incident. Earlier, you renamed it the Incident Date field. When the CSV spreadsheet was added to Insights, the Incident Date field was assigned as a string field. You will change the field type to the Date/Time field type and rename the field.

  2. Click the field type icon next to the Incident Date field and select Date/Time.

    Change field type.

    When the field type is changed to Date/Time, it is automatically divided date/time fields into subfields that can be used as string fields in other visualizations.

    Time subfields

    Next, you will create multiple cards to visualize temporal patterns in your data. You will create a time series chart, which displays the incidents as a graph in chronological order.

  3. Click the Incident Date field, drag it to the right of the Incident Heat Map card, and drop it onto Time Series.

    Create time series.

    The time series graph shows a weekly count of incidents plotted along the x-axis and connected by a continuous line.

    Time series chart

    Looking at the time series graph can help determine whether any crime reduction strategies have been effective over the course of the year.

  4. Drag and expand the right side of the time series graph to the edge of the page. Visually inspect the time series graph by pointing to certain points for more detail.

    Time series graph

    There is a slight drop in incidents in March, however, the rest of the year shows a general pattern of between 600 and 800 incidents per week. Looking at the total number of incidents over the year only tells part of the story. Subgrouping the time series chart by another field, such as offense type, can provide more insight into the effectiveness of crime reduction strategies for various types of incidents.

  5. On the time series chart card, click Group by, and choose Offense.

    Group by Offense

  6. On the chart toolbar, click the Legend button.

    Legend button

    The grouped time series chart indicates most incidents were either Theft F/Auto (theft from auto) or Theft/Other.

    Time series graph and legend

    The counts of both theft offense types show a similar pattern to the ungrouped time series, and the other incident types (burglary, motor vehicle theft, assault) have relatively stable counts throughout the year.

    You want to dig deeper into when Theft F/Auto most often occurs. To do this, you will create a related column chart showing day of week.

  7. From the data pane, in the Incident Date field, drag the Day of Week subfield onto Column Chart. Position the column chart card underneath the Incident Heat Map card.

    Create column chart.

    The column chart card shows the total count of incidents for each day of the week.

    Default column chart

    The chart is showing all offense types and you only want auto thefts. You will filter the column chart card to just the Theft F/Auto offense type.

  8. On the toolbar for the column chart, click the Card filter button.

    Card filter button

  9. In the New Filter pane, for Filter By, choose Offense. Uncheck Select All.
  10. Next to Search for a value, click the sort arrows, and choose Count: Highest to lowest.

    Sort highest to lowest.

  11. From the list of fields, choose Theft F/Auto, and click Apply.

    Choose Theft F/Auto field.

    Now you can see the total count of theft from auto incidents for each day of the week. The red line in the column chart represents the mean value of 1,465 incidents per day of week.

  12. In the column chart, point to each column to see the total count of incidents for each day.

    Hover over columns.

    Pointing to columns in the chart shows that Saturday and Sunday have the highest theft incident counts. This helps narrow down the priority days to focus on for your reduction strategy. Next, you will drill down into the data to look at the weekend incidents.

    You will create a cross filter between the column chart, the grouped time series graph, and the heat map.

  13. On the toolbar for all three cards, click the Enable cross filter button.

    Cross filter button

    Cross filters are a way to filter your data using a selection on a different card. When cross filters are activated on a card, a filter will be applied to that card whenever a compatible selection is made. For a selection to be compatible, the card with the filter and the card with the selection must be using the same dataset. In this case, you would like to filter the time series graph and heat map to only show theft from auto incidents on Saturday and Sunday.

  14. In the column chart, hold the Shift key while clicking the Saturday and Sunday columns.

    The other cards update based on the selection.

    Saturday and Sunday columns selected.

    From this selection, the time series chart and heat map are filtered. Based on what is understood from the three cards, you will now focus the rest of your analysis to help recommend strategies on reducing thefts from auto in the city during the weekend.

  15. Rename the time series chart and column chart to Incident Time Series Chart and Theft from Auto – Column Chart, respectively. Save your workbook.

You have now visualized your data in multiple map styles and learned one of a few different charts available to create. Next, you will calculate theft rates for each police district.


Perform analysis using incidents and districts

At this point, you have a pretty good understanding of what type of incidents most often occur (theft from auto), and when they occur most (Saturday and Sunday). But you still only have a basic idea of where they occur, using the heat map visualization. You will perform further analysis by calculating theft rates and spatially aggregating the incidents with police districts.

Aggregate and enrich data

Next, you will create a page in your workbook, filter the incidents dataset, and start investigating your data spatially.

  1. From the data pane, click the Incidents dataset, move it to the bottom of the application window, and drop it onto the New page button.

    New page button

    Another page is added to the workbook, and the Incidents dataset is added to it.

  2. In the data pane, expand the Incidents dataset, point to the Offense field, and click Dataset filter.

    Dataset filter button

  3. Uncheck Select All to unselect all fields, check the check box for Theft F/Auto, and click Apply.

    Filter by Offense

  4. In the data pane, point to the Incident Date field, point to Day of week, click Dataset filter, click Sort by, and choose Count: Highest to lowest.

    Sort highest to lowest

  5. Check only Saturday and Sunday to filter those days.

    Filter Saturday and Sunday.

  6. Click Apply.

    You have set up the filters. Next, you will download the police districts for Washington, D.C., so that you can determine theft rates for each district.

  7. Go to the PoliceDistricts item in ArcGIS Online and click Download.
  8. Once the .zip file downloads, move it to the folder where you stored the Incidents file.

    Now that you have downloaded the police districts, you will add them to the page so that you can calculate theft rates for each district.

  9. On the ribbon, click the Add button.

    Add button

    Under Add to page, click Upload file, and click Browse my computer.

  10. Browse to where you stored the downloaded data, click PoliceDistricts.zip, and click Open.

    Police districts added.

    You can add shapefiles if all the components that make up the shapefile are zipped into one file.

  11. Click Add.
  12. Rename Police_Districts to DC Police Districts.
  13. Drag the DC Police Districts dataset onto the workbook and create a Map card.

    To understand which of the seven police districts has the highest count of theft from auto incidents, you will perform a spatial aggregation. Performing this analysis will result in a calculated count of incidents in each police district.

  14. Drag the Incidents dataset onto the map card containing the districts and drop it on Spatial aggregation.

    Spatial aggregation drop zone

    In the Spatial Aggregation pane, keep the default settings and click Run.

    Spatial aggregation parameters

    After running the analysis, a result dataset named Spatial Aggregation 1 is added to the data pane, and it is presented on the map with a graduated sizes symbol type.

    Spatial aggregation results

    In the map card, you can point to a police district to see incident counts per district. Districts with larger orange circles are those with higher incident counts. District 3, near the center of the city, has the highest count of theft incidents on Saturday and Sunday. However, analysts typically use the UCR (Uniform Crime Reporting) rate for property crimes, which is calculated as number of incidents per 100,000 persons. To more accurately measure theft in each district, you will create a field to represent Theft Rate (per 100,000).

    To gain access to attributes that you do not have, you will add population data to your spatially aggregated dataset by adding online demographic variables.

  15. On the map card, click Action button.

    Action button

  16. Click Enrich Data.

    Enrich Data tool

    The Enrich Data tool uses the Esri GeoEnrichment service from ArcGIS Online to give you demographic and landscape data for the people, places, and businesses associated with your spatial data locations.

  17. In the Enrich Data pane, click Open data browser.

    Open data browser

  18. In the Data Browser, click Global, and choose United States.

    Choose United States.

  19. In the list of categories, click Population, and select 2020 Total Population (Esri).

    Select population variable.

  20. Click Apply, and in the Enrich Data pane, click Run.
  21. In the data pane, rename the Spatial Aggregation 1 dataset to Theft F/Auto Incidents by District. Expand Theft F/Auto Incidents by District to view its fields.

    Spatial aggregation fields

    The dataset now has a field named 2020 Total Population, which is the result of enriching the layer.

    You will use this population field to calculate a theft from auto field that you will add to the table.

Calculate theft rates

After enriching your layer with population data, you have all the necessary information to calculate theft rates for each district. You will add a field to the data table and calculate it using an expression.

  1. In the data pane, for Theft F/Auto Incidents by District, click Dataset options, and choose View Data Table.

    View Data Table

  2. Click the + Field button to add a field.
  3. For Enter calculate function, click in the text box. When you click in the text box, functions and fields appear for you to build your calculation expression.

    Build expression.

  4. From the list of operators, click the button to begin parentheses.

    Start parentheses.

  5. From the Fields section, click Count of Incidents to add it to the expression.

    Count of Incidents added.

  6. Following (Count of Incidents, type a /. From the Fields section, choose 2020 Total Population, and close the parentheses.
  7. Click the multiply button and after it, type 100000.

    Multiply fields by 100000.

  8. Click Run.
  9. Click the field name, New Field, and type Theft Rate (per 100,000).

    Field calculated and renamed

  10. Close the table.

    The Theft Rate (per 100,000) field is visible in the data pane.

    Theft Rate (per 100,000) field in data pane

    Because this field represents a rate, you will change its field type accordingly.

  11. In the data pane, click the field type for Theft Rate (per 100,000), and choose Rate/Ratio.

    Change field type to Rate/Ratio.

    Next, you will change the map's style to show the districts symbolized using the Theft Rate (per 100,000) field.

  12. In the map card, go to the Layer options, click Options, and for Style by, choose Theft Rate (per 100,000).

    Style by Theft Rate (per 100,000) field

  13. Rename Card 1 to District Theft F/Auto Rates, and save your workbook.

    Districts symbolized by theft rates.

    Styling the map by theft rate automatically changes the card to a choropleth map. This type of map is particularly useful when comparing rates or percentages between geographic areas. The default data classification for the choropleth map is natural breaks. Classes are based on natural groupings inherent in the data. This method is good for comparing the theft rates in each district. The rates will be grouped so that districts with a similar rate will be symbolized with the same color. The map shows you that District 3 has the highest theft rate, and the districts that touch District 1's south and east boundaries also have relatively high theft rates. Based on theft rate, District 3 is the highest priority for the reduction strategy.

    You will focus your efforts on District 3 for the remainder of the analysis.

Identify microclusters of theft

The next step is to find small, high-density areas of theft within District 3. You will create a map of theft from auto incidents that are within District 3's boundary using a spatial filter and create a density surface from the data.

  1. Drag the Incidents dataset onto the workbook canvas and drop it on Map.
  2. In the District Theft F/Auto Rates map, click district 3 (dark purple polygon in city center) to select it.

    District 3 selected.

  3. From the District Theft F/Auto Rates map, drag the District 3 polygon onto the other map card's Filter by selected feature area.

    Filter by selected feature

    The Spatial Filter pane appears.

  4. Accept all defaults and click Run.

    This operation is called a spatial filter, which creates a resulting dataset that contains just the theft from auto incidents that are within the District 3 boundary.

    Theft from auto in District 3

  5. In the data pane, rename Spatial Filter 1 to Thefts F/Auto – District 3.

    Next, you will identify small, high-density areas, also known as microclusters, within District 3.

  6. On the map card containing the incidents in District 3, click Action button, and click Calculate Density.

    Calculate Density tool

    The Calculate Density tool uses the theft from auto incidents as input data to calculate a density map.

  7. Accept the defaults and click Run.

    Calculate Density parameters

    A layer is added to the map that shows the density of incidents. The default symbology of the Density layer is difficult to see on the map, so you will modify its symbology.

  8. In the map card, click the Density layer and drag it on top of Thefts F/Auto – District 3.

    Reorder layers.

  9. For the Density layer, open the Layer options.
  10. On the Options tab, expand Classification, and set Number of classes to 5.

    Number of classes set to 5.

  11. On the Style tab, set Layer transparency to25%.

    Layer transparency set to 25%.

    The map updates dynamically as you make changes.

    Updated density layer

  12. Rename the map card to Density of Thefts from Auto.

    By visually inspecting the map, there are a few high-density areas where theft from auto is more prevalent, and your department should prioritize its efforts in these areas. You have determined where to prioritize theft reduction efforts, and now will investigate when these efforts should occur. You will combine spatial analysis with the temporal analysis you performed earlier to help determine exactly where and when auto thefts occur.

  13. In the data pane, expand the Thefts F/Auto – District 3 dataset. Select both the Incident Date – Day of week and Incident Date – Hour fields.

    Selected fields

  14. Drag the selected fields onto the workbook, point to Chart, and drop the fields on Heat Chart.

    Create heat chart.

    The heat chart displays in the card.

    Heat chart

    Heat charts are used to visualize the numeric relationship between two categorical variables. In this case, you want to know the day of week and hour with the most theft from auto incidents. The darker the color in the heat chart, the more incidents there are during that day of week/hour combination. First, you will flip the fields in the chart so that the days display on the vertical axis.

  15. At the bottom of the heat chart card, click Flip fields.

    Flip fields button

  16. Expand the heat chart so that the card is wider. Point to a day and time combination, such as Sunday at 1 PM.

    Fields flipped.

    There are two cells with the darkest purple color: Saturday from 3–4 a.m., and Sunday from 1–2 p.m. By setting up cross filters on the heat chart and map card, you can select these time slots to see where these specific incidents occurred.

  17. Rename the heat chart card to Theft from Auto – District 3 Heat Chart.
  18. From the toolbar on the Density of Thefts from Auto and the Theft from Auto – District 3 Heat Chart cards, click Enable cross filters. Hold the Shift key and click the darkest purple cells in the heat chart.

    In the map card, the incidents update to display only the day and time combinations that you selected in the heat chart.

    Cross filtered cards

    You now have determined the most frequent times during the weekend that theft from auto occurs in these high-density areas throughout the city, and you can more confidently decide where and when the department should allocate its patrol officers to more effectively reduce this type of crime. You can also look at each individual area to further refine your strategy.

  19. In the Density of Thefts from Auto card, click the Thefts F/Auto – District 3 layer to activate it.

    Activate a layer.

  20. Click the symbol for the Density layer to turn it off.

    Density layer symbol

  21. On the Density of Thefts from Auto card, click Selection Tools.

    Selection tools

  22. Click Lasso.

    Lasso selection tool

  23. On the map, draw a circle around one of the high-density areas. Press down to start and let go to finish your circle.

    Select by lasso.

    The heat chart has filtered to show the most common weekend hours of those selected incidents. You can repeat this selection process for each of the high-density areas to determine whether the most weekend hours for thefts from auto varies within each area. For example, the selection below shows that the most common weekend hours for the selected incidents were between 3 a.m. and 5 a.m. on Saturday. It probably makes sense to deploy more patrol officers to that general area during that two-hour block.

    Filtered heat chart

  24. Perform another lasso selection on another area to see the results. Once finished selecting and exploring the results, click within the map card to clear all selections. Save your workbook.

You have learned ways to visualize and analyze large amounts of point data: spatial aggregation, density, and heat charts. These techniques are designed to make your analysis more comprehensive and informative. In this next section, you'll learn how to share your work.


Share your results

ArcGIS Insights provides many ways to share your work. You can share pages, workbooks, or your analysis so that you can input different incident data into it and run through the same operations. How you share your model depends on the intended audience. Next, you will learn how to share the analysis as a model and a page.

Prepare page for sharing

Throughout this entire analysis, you have been able to specifically identify high-density areas of thefts from auto within the most impacted district in the city and have determined potential strategies for allocating patrol officers at specific locations and specific times during the weekend. This analysis workflow can be repeated for other districts, year over year, and even shared with fellow analysts. This is because ArcGIS Insights has tracked the work you've done the entire time as a model.

  1. On the ribbon, click the Analysis view button.

    Analysis view button

    The model for your workflow displays on the workbook.

  2. Scroll through the model, and you will recognize all the operations that you performed individually throughout this lesson.

    Model

    A model is a visual recording of the steps in your analysis. In ArcGIS Insights, models are created automatically as you work, so you can focus on exploring your data and performing analysis, rather than creating a model. You can share this model as an item in ArcGIS Online or ArcGIS Enterprise, and colleagues can reuse it with the same or different datasets, if they share the same fields used in the original analysis.

  3. When finished exploring the model, on the ribbon, click Page view.

    Page view button

    Another way of sharing your work is through an interactive page. This method is best for audiences that only need to view your work and analysis and use it to better understand and make decisions. Some example recipients could be the district commander or the general public. You will now create a third page for the purposes of sharing with your leadership.

  4. At the bottom of the ArcGIS Insights window, click the arrow next to Page 1, and click Duplicate Page.

    Duplicate Page

  5. Rename Page 1 Copy to Theft from Auto Analysis and add your initials to the end.

    The duplicate page contains all the cards from the page that you duplicated. Next, you will copy and paste the cards from Page 2 into your duplicated page.

  6. Go to Page 2, click the District Theft F/Auto Rates card to select it. Press Ctrl+C to copy the card.
  7. Return to the Theft from Auto Analysis card and press Ctrl+V to paste the card into the page.
  8. From Page 2, copy the Density of Thefts from Auto card and paste it into the Theft from Auto Analysis page.
  9. From Page 2, copy the Theft from Auto – District 3 Heat Chart card and paste it into the Theft from Auto Analysis page.
  10. Resize and adjust placement of all cards on the Theft from Auto Analysis page.

    Full page

    All the cards and their associated datasets have now been copied over to the page and it is ready to be shared.

  11. Next to the Theft from Auto Analysis page, click Page options, and click Share As.

    Page options

    The Share as window appears. Here you can configure the title, tags, and description of your page. Other sharing methods include a model and a theme. You can also allow viewers to export the data that's used in the cards.

    Finally, you can decide with whom you want to share your page. You can share the page with your organization, select groups from your organization, or the public. For now, you will keep the sharing options unchecked.

  12. For Tag, type crime, police, and crime analysis.
  13. For Description, copy and paste Insights page shared in Learn lesson into the field.

    Share as dialog box

  14. Click Share.

    Once your page is shared, a new window will appear, allowing you to view your shared page, view the page item in your organization, copy the <iframe> to embed the page in a story or web page, or schedule updates to the shared page.

    Page shared.

    Once the window is closed, the ArcGIS Insights page item will continue to be available from the Pages tab on the home page.

  15. For the first option, View Your Shared Page, click Go.

    View shared page.

    Your shared page opens in a web browser tab.

    Shared page

    When accessed, the page item opens a separate read-only viewer that allows others to interact with cards by making selections and viewing pop-ups.

    The Page Viewer can be accessed by anyone with an ArcGIS account, even without an ArcGIS Insights license. Users without an ArcGIS account can also access the Page Viewer to see public pages if they have access to the URL for the item. The Page Viewer is interactive, but does not allow editing functions, such as adding or deleting cards, or performing spatial analysis.

In less than an hour, you were able to quickly prepare, visualize, and analyze your data to make recommendations for a theft reduction strategy. You also learned how to share your work with your leadership, and you are now able to use the analysis results to make data-driven, informed decisions. You have enhanced your workflows and simplified the process by using data visualization and spatial analysis techniques in ArcGIS Insights.

You can find more lessons in the Learn ArcGIS Lesson Gallery.