Join tabular data to spatial data

Because of the oil boom, North Dakota is one of the most economically successful states in the country. To illustrate the scope and need for more housing, you'll need data. You'll use ArcGIS Pro to join tabular data on homelessness from the federal government to spatial data of the United States from ArcGIS Living Atlas.

Explore the data

First, you'll download and open an ArcGIS Pro project containing the data needed to complete this lesson.

  1. Download the Homelessness compressed folder.
  2. Right-click the downloaded folder and extract it to a location you can easily find, such as your Documents folder.
  3. Open the Homelessness folder. If you have ArcGIS Pro installed on your machine, double-click Homelessness.aprx to open it. If prompted, sign in using your licensed ArcGIS account.
    Note:

    If you don't have ArcGIS Pro or an ArcGIS account, you can sign up for an ArcGIS free trial.

    The map appears, showing the United States.

    Map of the United States

    The orange layer, USA_States_Generalized, is provided by ArcGIS Living Atlas. You can find out more about this data on the layer's details page.

  4. In the Contents pane, right-click Sheet1$ and choose Open.

    Open Sheet1$ from the Contents pane.

    Note:

    If there is a red exclamation point next to the stand-alone table, you may need to install the Microsoft Access Database Engine driver. Alternatively, to add the table, use the Excel to Table geoprocessing tool.

    The table appears. Sheet1$ is the first sheet in a spreadsheet, Homeless Data.xlsx, provided in the download folder. This spreadsheet was adapted from the PIT Counts by State files published by the United States Department of Housing and Urban Development, which are available on the HUD Exchange site. Point-in-Time (PIT) counts are the annual practice of counting people experiencing homelessness on a single night in January. The National Alliance to End Homelessness offers an additional explanation of Point-in-Time counts.

    Table view of Sheet1$

    The table contains five fields:

    • State—Abbreviation of state name
    • Change—Change in total unhoused count between 2012 and 2013
    • Pop13—Total population in 2013
    • Homeless13—Total homeless count in 2013
    • ObjectID—Identifier number added by ArcGIS Pro
  5. Locate the row representing North Dakota (abbreviated to ND).

    ND row selected in the table.

  6. Review the Total unhoused count for North Dakota (ND) and North Carolina (NC).

    In 2013, North Dakota had a total unhoused count of 2,069 while North Carolina had a count of 12,168.

    What does this mean in a national context? North Carolina had nearly six times as many people experiencing homelessness as North Dakota, and some states had even more. Many of these states have significantly higher population than North Dakota, which may explain their higher population of people experiencing homelessness.

    The more dramatic number is in the Change column. The value of 2.007 represents an increase in their unhoused population of more than 200 percent. Such a sharp increase indicates the problem in North Dakota may be more severe than the total count suggests.

  7. If necessary, unselect any selected rows in the Sheet1$ table.
  8. Close the Sheet1$ table.
  9. In the Contents pane, right-click USA_States_Generalized and choose Attribute Table.

    The attribute table appears.

    Attribute table

    The attribute table contains data describing the features of the layer. Some of the fields in this table include the state name, the state's abbreviation (STATE_ABBR), and the region of the country the state is in. The abbreviation field has identical data to the State column in your Homeless Data table, and can be used to join the two tables together.

Join the unhoused data to the spatial layer

A table join takes data from one table and connects it to data from another. You cannot join any two tables; both tables must share a field of common values. Otherwise, the software will not be able to identify which records in the join table match which records in the target table. In this case, the tables you want to join have common records of state name abbreviations.

  1. If necessary, open the attribute table of USA_States_Generalized.

    There is a lot more data here than you need. It distracts from the work you need to do to map the unhoused population. Before you add even more data with a join, you will clean up this table to show only what you need.

  2. In the Contents pane, right-click USA_States_Generalized, point to Design, and choose Fields.

    The Fields table shows all fields for the layer. The Visible column shows which fields are visible in the attribute table.

  3. Click the check box next to the Visible column header to turn off all fields.

    Uncheck all fields as visible on layer.

  4. In the Visible column, check the boxes next to the following fields to turn them on:
    • STATE_NAME
    • STATE_ABBR
  5. On the ribbon, on the Fields tab, in the Changes group, click Save.

    Save button on the Fields tab on the ribbon

  6. Close the Fields table and confirm that in the attribute table only the STATE_NAME and STATE_ABBR fields remain visible.

    The other fields have been turned off but not removed entirely.

    Note:

    Before continuing, confirm no records are currently selected in the Sheet1$ table.

  7. In the Contents pane, right-click USA_States_Generalized, point to Joins and Relates, and choose Add Join.

    A new window appears with the Add Join tool.

  8. For Layer Name or Table View, confirm that USA_States_Generalized is chosen. Change Input Join Field to STATE_ABBR.
  9. For Join Table, choose Sheet1$.
  10. For Output Join Field, confirm that State is chosen.

    Add Join tool

  11. Click OK to join the tables.
  12. In the attribute table for USA_States_Generalized, you should see five new fields added.

    Table with original and joined fields

  13. Close the attribute table.
  14. On the toolbar at the top of the ribbon, click the Save button.

    Save button on the Quick Access Toolbar

You've joined stand-alone table data from a spreadsheet to a spatial layer of the United States. Next, you will prepare and publish your layer.


Prepare and publish a layer

Previously, you joined your unhoused population data to a layer of the United States. You can use this layer to map unhoused population;' variables in North Dakota and the rest of the country. To share your results as widely as possible, you will publish your layer to ArcGIS Online.

Copy the layer to a new feature class

The current layer cannot be published for two reasons. First, it is already a published feature service on ArcGIS Online. Second, you cannot publish a layer if all or part of its table is from a data source unsupported by ArcGIS Online (such as Microsoft Excel or a similar spreadsheet program). You can bypass both problems by copying the layer as a new feature class, which will preserve the data but change the source to a publishable file type.

  1. On the ribbon, click the Analysis tab. In the Geoprocessing group, click Tools.

    The Geoprocessing pane appears.

  2. In the Geoprocessing pane, search for and choose the Copy Features tool.
  3. In the Copy Features geoprocessing pane, for Input Features, choose USA_States_Generalized.
  4. Click inside the Output Feature Class box to see the full path.

    Full path of output feature class in the Copy Features tool

    The new feature class will be saved inside the project’s geodatabase, Homelessness.gdb.

  5. In the Output Feature Class box, type USA_States.
  6. Click Run.

    A new layer is added to your map.

  7. In the Contents pane, right-click USA_States_Generalized and choose Remove.
  8. Right-click the new USA_States layer, point to Design, and choose Fields.

    Another benefit of exporting data is that fields that are not visible are not copied to the new dataset. The FID and Shape fields were not visible but were still copied because they are mandatory fields managed by the software.

Clean up the new layer

Before you publish data, it should be as clear and concise as possible. You have already removed some fields to show only the data you intend to use, but you can also make this data easier to read.

When the data was joined from your spreadsheet, prefixes were added to the field names to indicate the source of each field. Field aliases act as display names for fields and can include spaces and hyphens, while field names cannot.

  1. In the Fields table, double-click the cell for STATE_NAME in the Alias column. Change the alias to State.
  2. Change the aliases of the following fields in the same way:
    • Sheet1__ChangeHomeless Change (2012-13)
    • Sheet1__Pop13Population (2013)
    • Sheet1__Homeless13Homeless Count (2013)
  3. Uncheck visibility for the following fields:
    • OBJECTID
    • L0USA_States_Generalized_STATE_ABBR
    • Sheet1__State
    • Sheet1_ObjectID
    • Shape_Length
    • Shape_Area

    Fields view showing all rows as edited except for Shape

  4. Click Save on the ribbon and close the fields view.
  5. Open the attribute table of USA_States to confirm your changes. The headers for the columns now show their short aliases instead of their long field names.

    Attribute table showing aliases instead of field names

    You know the total population and the population of homeless in each state, but a single number for percentage of homeless would be more useful.

  6. At the top of the attribute table, click the Add Field button.

    Add Field option on the attribute table

    The fields view appears with a new row at the bottom.

  7. Assign the following values to the new field:
    • Field Name: HomelessPer10000
    • Alias: Homeless per 10,000
    • Data Type: Short
  8. Click Save on the ribbon and close the fields view.
  9. Confirm that the new field has been added to the attribute table.

    All of its values are <Null>. Next, you will calculate the values for this field.

  10. Right-click the column header and choose Calculate Field.

    Calculate Field option in the context menu of the Homeless per 10,000 column of the attribute table

    A window appears with the Calculate Field tool.

  11. Change Expression Type to Arcade.
  12. In the HomelessPer10000 box, copy and paste or build the following expression using appropriate fields and math operators:
    $feature.Sheet1__Homeless13 / $feature.Sheet1__Pop13 * 10000

    The expression divides the homeless count of each state by the state's population and multiplies the result by 10,000 to create a value that is easier to interpret.

  13. Click Apply and click OK. Confirm that the values were added to the Homeless per 10,000 field.
  14. Close the attribute table.
  15. On the map view, click one of the states to open a pop-up.

    Pop-up showing correct attribute values

    Tip:

    If your pop-up does not look similar, you may need to reset it:

    • In the Contents pane, right-click USA_States and choose Configure Pop-ups.
    • At the bottom of the Configure Pop-ups pane, click Reset.
    • Close and reopen the pop-up.
  16. Close the pop-up.

Publish the layer to ArcGIS Online

You'll now publish the layer as a hosted feature layer to ArcGIS Online. To transform a disk-based layer to a web-based layer, you must have a Publisher role in an ArcGIS Online organization.

  1. In the upper left corner of the ribbon, look for your sign-in status. If it says Not signed in, click it and click Sign in.

    Sign-in status expanded to show Sign in option.

  2. In the Contents pane, right-click USA_States, point to Sharing, and choose Share As Web Layer.
  3. Fill in the following fields:
    • NameHomelessness_YourName
    • SummaryHomelessness data by U.S. state for 2013, including the change in homeless populations between 2012 and 2013. From the United States Department of Housing and Urban Development.
    • TagsHomelessness, United States, 2013, HUD
  4. For Layer Type, choose Feature.
  5. For Share with, check Everyone.

    Share As Web Layer pane with all fields filled in

  6. Click Publish.

    The map is now accessible through your ArcGIS Online or ArcGIS Enterprise account. When ArcGIS Pro has finished publishing the layer, you will see a confirmation message that includes a link to manage your web map.

  7. Save and close ArcGIS Pro.

You've prepared your layer for the web and published it. Next, you will create three maps that help to analyze the unhoused population of the US by state from 2012-2013.


Map homelessness by state

Previously, you published a layer of the United States with data on total population, homeless population, and change in homeless population. Next, you'll use that layer to create three web maps of the United States.

Start a new map

Your first map will show the total number of people experiencing homelesness per state. From looking at the data, you know North Dakota has a relatively low total unhoused population, so this map will probably not help your cause. However, because it is such a fundamental statistic, you must show it.

  1. Sign in to your ArcGIS organizational account.
  2. At the top of your organization's home page, click Content.

    Content

    The My Content tab on the content page includes two new items titled Homelessness_YourName. One is a service definition file that contains the actual data and drawing specifications for your published service, while the other is a feature layer that you can add to a map. You will work with the feature layer.

  3. Click the browse button next to the Homelessness_YourName feature layer and choose Add to new map.

    Add to new map option in the feature layer menu

    A new map containing the layer appears.

  4. Zoom in until the extent roughly corresponds with the contiguous 48 states.

    Next, you will rename the layer to reflect the data this map will show.

  5. If necessary, close the Change Style pane (click Cancel).
  6. In the Contents pane, point to the Homelessness YourName layer. Click the More Options button and choose Rename.

    Rename in the More Options menu

  7. Rename the layer Homeless Counts and click OK.

Symbolize the layer by unhoused population

Next, you will symbolize the number of people experiencing homelessness by drawing a circle within each state. The size of the circle will vary depending on the attribute value. Using graduated symbols instead of colors helps the user compare symbols to one another independently of the areal boundaries of the states. It also avoids creating the impression that unhoused

people are evenly dispersed throughout each state.

  1. Under the Homeless Counts layer, click the Change Style button.

    Change Style button

  2. In the Change Style pane, for Choose an attribute to show, choose Homeless Count (2013).

    Choose an attribute to show set to Homeless Count (2013).

    The pane updates to show the ways the attribute can be symbolized.

  3. Under Counts and Amounts (Size), click Select.

    Select button for Counts and Amounts (Size)

    On the map, each state is symbolized with an orange circle that changes size depending on the state's unhoused population.

    Map symbolized with orange circles using Counts and Amounts (Size).

  4. Under Counts and Amounts (Size), click Options.

    The Change Style pane changes to show the options. You can adjust symbol size, color, and more.

  5. Under Size, check Classify Data.

    Classify Data check box under Size options

    Classify Data uses a mathematical formula to determine the values at which symbols change size on the map, also known as breaks. The default classification scheme is Natural Breaks, which uses large differences between groups of values to set breaks.

  6. Under Classify Data, change the number of classes to 5.

    Classify Data with 5 classes

    The number of classes determines the number of breaks in the data. When you change the classes, the symbols on the map update automatically. Many of the symbols are unnecessarily large and cover smaller symbols, so next you will change the maximum and minimum symbol sizes.

  7. Under Size, change Min to 8 pixels and Max to 24 pixels.

    Min size set to 8 pixels and max size set to 24 pixels.

    You can also change the symbol color.

  8. Click Symbols.

    Symbols

    A window appears with additional symbology options.

  9. At the top of the window, click Fill. On the color palette, click the fourth dark blue from the top.

    Blue color #005CE6 selected.

  10. At the top of the window, click Outline. On the color palette, click the fifth dark blue from the top.

    Blue color #004DA8 selected.

  11. Change Line Width to 2 pixels.

    Line Width slider set to 2 pixels.

  12. Click OK. At the bottom of the Change Style pane, click OK and click Done.

    Part of the map showing blue circle symbols in each state

    Note:

    The size of the symbols remains the same when you zoom in and out. Your symbols may appear larger or smaller relative to the state boundaries depending on your extent. You can change the symbol sizes in the Change Symbol window.

    On the map, you can see that North Dakota and many of the rural plains states have small unhoused populations compared to the more urbanized states such as Illinois and New York. The default Topographic basemap is better suited for a reference map (which emphasizes the geographic location of features) than a thematic map (which focuses on a specific theme, such as homelessness). Next, you will change the basemap to something simpler.

  13. On the ribbon, click Basemap and choose Light Gray Canvas.

    Light Gray Canvas in the Basemap gallery

    The basemap changes.

    Part of the map with blue circles in each state and a light gray basemap

    The map gives a generalized visual representation of the data but not exact numbers. The exact counts are accessible through pop-ups, so when users click a state, they can see how many people experiencing homelessness live there.

Configure pop-ups for the unhoused population map

When you were preparing your data in ArcGIS Pro, you reset the configuration of the pop-ups to show a feature’s attribute information. You can further customize pop-ups to only show the information relevant to the map.

  1. On the map, click North Dakota.

    Pop-up for North Dakota showing all attributes

    The default pop-up appears. It displays all of the attributes. The pop-up could be better, however. First, this map is only about homeless counts, but other attributes are also visible. Second, the state name is displayed twice. Third, the attribute values for population and count are not easy to read.

  2. Close the pop-up. In the More Options menu of the Homeless Counts layer, click Configure Pop-up.
  3. In the Pop-up Properties pane, confirm that Pop-up Title is set to {L0USA_States_Generalized_STATE_}. If it is not, click the Add Field Name button next to the text box and choose State {L0USA_States_Generalized_STATE_}.

    Add Field Name button next to Pop-up Title

    A field name in braces is substituted with the attribute for that field when a feature is clicked. For instance, when you click North Dakota, the pop-up will display North Dakota as the title.

  4. Under Pop-up Contents, click Configure Attributes.

    Configure Attributes link beneath pop-up attributes list

  5. In the Configure Attributes window, uncheck the boxes in the Display column next to all fields except Homeless Count (2013).

    Check Display only for Homeless Count (2013).

    Now, only Homeless Count (2013) will be displayed in the pop-up.

  6. Click OK. In the Configure Pop-up pane, click OK.
  7. On the map, click North Dakota (or any state) to view the pop-up.

    Pop-up for North Dakota showing only Homeless count

    Your pop-up shows only the information that this map is supposed to show.

  8. Close the pop-up. On the ribbon, click Save and choose Save As.

    Save As

  9. In the Save Map window, type the following information:
    • TitleNumber of Homeless, 2013
    • Tagshomelessnesshomeless counts, United States2013 (you can add additional tags)
    • SummaryMap of homeless counts by state in the United States
    Tip:

    When entering tags, press Enter after each tag to enter it as an individual tag. Alternatively, type all of the tags separated by commas and press Enter.

    Save map as Number of Homeless, 2013.

  10. Click Save Map.
  11. On the ribbon, click Share.
  12. In the Share window, check Everyone and click Done. (You may need to scroll down to find the Done button.)
    Tip:

    If you are prompted to update the sharing properties of the layers, click Update sharing.

Symbolize the layer by percentage of people experiencing homelessness

Although the total number of people experiencing homelessness in North Dakota is fairly small, that does not mean the problem is less severe for its scale. A state with nearly 40 million people, such as California, is going to have more unhoused people than a state with almost 800,000 people, such as North Dakota. But the state with more people will also have more resources to handle the problem. To make your audience see more than "homeless counts", your next map will normalize counts by population to show what percentage of a state's population is unhoused.

Since your second map will be similar to your first, you will start by making a copy of your first map.

  1. In the Number of Homeless, 2013 map, click Save and choose Save As.
  2. In the Save Map window, edit the following fields:
    • Title: Type Homeless as Percentage of Population, 2013.
    • Tags: homelessnesshomeless percentages, United States2013.
    • Summary: Map of homeless percentages by state in the United States

    Save map as Homeless as Percentage of Population, 2013.

  3. Click Save Map.

    The map title changes. You can now make and save edits to the map without affecting your first map. As with your previous map, you will change this map's symbology and configure its pop-ups to show the relevant data.

  4. Rename the Homeless Counts layer Homeless Percentages.
  5. Under the Homeless Percentages layer, click the Change Style button.

    In your previous map, you used graduated symbols to represent the count of homeless people. One reason you did not use color shading was that you did not want to suggest that homeless people were evenly distributed throughout each state. Now that you are dealing with a ratio, that consideration does not apply.

  6. Under Choose an attribute to show, choose Homeless per 10,000.
  7. Under Select a drawing style, select Counts and Amounts (Color) and click Options.

    Counts and Amounts (Color)

  8. In the symbology options, click Symbols.

    Symbols

    Since you are symbolizing by color instead of size, the symbols window has several color ranges for you to choose from.

  9. Click the last color range, red to yellow, and click OK.

    Red to yellow color scheme

    The map updates with the new colors.

  10. As you did in the previous map, check Classify Data and change the number of classes to 5.

    Map with red to yellow color scheme showing North Dakota as dark orange

    This map does not seem to show the problem in North Dakota, either. North Dakota is in a middling class, while a small number of outliers take up the higher classes. However, unlike the previous map, the problem is not that North Dakota has a low value; in fact, it has one of the highest values in the country. The problem is that the class breaks between categories are skewed by three or four exceptionally high values.

    The Natural Breaks classification method is useful for showing outliers, but your goal is to show that North Dakota is in the top percentage of states.

  11. Under Classify Data, change Using to Quantile.

    Classify data using quantile with five classes.

    Quantile determines class breaks by distributing an equal number of values into each class. Since your data has 51 features (all states plus the District of Columbia) and you are using five classes, each class has roughly 10 features.

    Map with red to yellow color scheme, showing North Dakota as dark red

    North Dakota is in the highest class, which consists of the 10 states with the highest homelessness rates.

  12. At the bottom of the Change Style pane, click OK and click Done.
  13. Save the map.

Configure pop-ups for the Homeless Percentages map

Next, you'll configure pop-ups for the map. Since the Homeless per 10,000 attribute does not have a self-explanatory title, you will configure a custom attribute display that better explains the data.

  1. In the Contents pane, in the More Options menu of the Homeless Percentages layer, click Configure Pop-up.
  2. Under Pop-up Contents, change Display to A custom attribute display.

    Configure a custom attribute display.

  3. Click Configure. In the Custom Attribute Display window, type or copy and paste the following: 
    In 2013, {L0USA_States_Generalized_STATE_} had {HomelessPer10000} people experiencing homelessness for every 10,000 people.
    Tip:

    If your pasted text has a font or styling that you do not like, you can select it and click the Remove Format button.

  4. Use the Bold button to add bold formatting to {HomelessPer10000}. (Ensure that you include the braces.)

    The Bold button in the Pop-up configure window

  5. Click OK. In the Configure Pop-up pane, click OK.
  6. On the map, click North Dakota (or any state) to view the pop-up.

    Pop-up for North Dakota

  7. Close the pop-up.
  8. Save and share the map with everyone.

    With your second map, more of the story comes into focus. Although North Dakota has a low homeless count, that count is relatively high for its population. However, there are still states that have both higher counts and higher percentages, such as California and New York. To finish the picture of homelessness in North Dakota, you will create one more map: change.

Symbolize the layer by homeless change

Change plays an important role in determining the severity of homelessness in a state. A state with low or negative change, even if it has high homeless counts and percentages, will likely have enough shelters and resources from previous years to deal with the problem. A state with high change, however, may not have such infrastructure, exacerbating homeless conditions. Your final map will depict change in homeless counts from 2012 to 2013.

  1. In your Homeless as Percentage of Population, 2013 map, click Save and choose Save As.
  2. In the Save Map window, edit the following fields. When you finish, click Save Map.
    • Title: Type Percent Change in Homeless Counts, 2012-13.
    • Tags: homelessnesshomeless change, United States2013.
    • Summary: Map of homeless change by state in the United States

    Save map as Percent Change in Homeless Counts, 2012-13.

  3. In the Contents pane, rename the Homeless Percentages layer Homeless Change.

    The original Homeless Data Excel sheet expressed change data as percentages, but when you viewed that data in ArcGIS Pro, it was formatted with fractions, so 200.7 percent was written as 2.007. You will multiply those fractions by 100 to convert them to percentages.

  4. Under the Homeless Change layer, click the Show Table button.
  5. On the right side of the table, click the add button and check Homeless Change (2012-13). Uncheck Homeless Count (2013).

    Show/Hide Columns list with Homeless Change and Homeless Count

  6. Click the header of the Homeless Change (2012-13) column and choose Calculate.
  7. For language, choose SQL.
  8. In the Expression Builder, copy and paste the expression Sheet1__Change * 100.

    Expression

  9. Click Calculate. Confirm that the values were updated in the Homeless Change field. They should now range between -47.44 and 200.73. Close the table.
  10. In the Contents pane, under the Homeless Change layer, click the Change Style button.
  11. In the Change Style pane, under Choose an attribute to show, choose Homeless Change (2012-13). Under Counts and Amounts (Color), click Options.

    Counts and Amounts (Color)

    For the classification scheme, you will use Natural Breaks instead of Quantile to emphasize the fact that North Dakota had an exceptionally high change. You will also increase the number of classes to show that despite the large variation between states, North Dakota still stands out.

  12. Check Classify Data. Change the number of classes to 7.

    Classify Data using Natural Breaks with 7 classes

    Some states have had declines in unhoused count, while others have had increases. To show this difference, you will use a diverging color scheme.

  13. Click Symbols. In the list of color ranges, in the second row from the bottom, choose the diverging green and purple color scheme.

    Green to purple color scheme

  14. Click OK. At the bottom of the Change Style pane, click OK and click Done.

    Map with green to purple color scheme showing North Dakota as dark green

    In this map, green states experienced increased counts of people experiencing homelessness, while purple states experienced decreased counts. The white states had relatively little change either way. North Dakota is the only state in the highest class. This will be your most persuasive map for informing your audience of the unhoused problem in North Dakota.

Configure pop-ups for the Homeless Change map

You'll now configure a pop-up to display the values.

  1. In the More Options menu of the Homeless Change layer, click Configure Pop-up.
  2. In the Pop-up Properties pane, under Pop-up Contents, click Configure to open the Custom Attribute Display window.
  3. Clear the existing text. Type or copy and paste the following: Between 2012 and 2013, {L0USA_States_Generalized_STATE_} experienced a {Sheet1__Change} percent change in counts of people experiencing homelessness.
  4. Use the Bold button to add bold formatting to {Sheet1__Change}.

    Pop-up configure window

  5. Click OK. In the Configure Pop-up pane, click OK.
  6. On the map, click North Dakota (or any state) to view the pop-up.

    Pop-up for North Dakota describing 200.73 percent change in homeless counts

  7. Close the pop-up.
  8. Save and share the map with everyone.

You've used your layer to create three maps of the United States, each focusing on a different aspect of homelessness. Finally, you will create a story and share your findings.


Share your results

Previously, you mapped homelessness in the United States. Next, you'll share your results using a story. ArcGIS StoryMaps has several features that are tailored for displaying data and telling a story with.

Create a story with ArcGIS StoryMaps

To showcase your map, you will create a story that allows your users to easily evaluate your three maps.

  1. On the ArcGIS home page, click the App Launcher.
  2. Choose StoryMaps.

    Open StoryMaps from the App Launcher.

    The ArcGIS StoryMaps app opens.

  3. Click New story and from the drop-down menu, choose Start from scratch.

    Start a new story.

    The blank template opens to make your story.

  4. In the Title your story section, type People Experiencing Homelessness in the Badlands.

    Add a title.

  5. In the Start with a short introduction or subtitle section, type  Evaluating Homelessness in North Dakota, and the US, from 2012 to 2013..

    Add a subtitle.

  6. To start your story, click the Add Content block button, and add a Text block.

    Add a text block.

  7. Add the text Number of People Experiencing Homelessness, 2013.

    Add a title.

  8. Underneath the heading, click Add Content block, and choose text add the a text content block, with the following text: Nationwide, people experiencing homelessness is on the decline, with most states experiencing decreases in the amount of homelessness. Most of the exceptions are clustered in the northeastern and north-central parts of the country, but even in these regions the increases were for the most part relatively modest. In North Dakota, however, the amount of people experiencing homelessness exploded, tripling in only a year's time. Such a sudden and severe increase means that no existing shelters or local relief programs are in place to deal with homelessness at such a scale. Furthermore, an upward trend could cause the problem to worsen if nothing is done to stop it. As the Bakken oil formation that precipitated North Dakota's explosive growth and subsequent housing problem shows no signs of running dry in the near future, effort must be spent to curtail this issue before it grows uncontrollable.

    Add a descriptive paragraph.

  9. Underneath the paragraph, add a new Content block. Under the Immersive section, choose Sidecar.

    Add a sidecar.

  10. In the Change layout panel, choose Docked panel.

    Choose Docked panel template.

    The sidecar block appears.

  11. In the media panel of the sidecar (right), click the Add media button, and choose Add map.

    Add a map media type.

  12. In the Add a map window, select your Number of Homeless, 2013 map.

    Add Number of Homeless, 2013 map.

  13. On the Options tab, turn on Allow map navigation, Search, and Legend.

    Turn on map settings.

  14. Zoom in to the map so that it fills the pane.and click Place map.

    The map now appears on the right side of the sidecar.

    The map is added.

  15. At the bottom of the map, click the Legend button to make your legend visible.
    Make legend visible.
  16. Above the map click the Options button.

    Click the Options button.

  17. In the Web map options, for Alternative text (optional), type Map of number of people experiencing homelessness, 2013.

    Add alt text

  18. Click Save.
  19. In the narrative panel of the sidecar, add the following text: In 2013, unhoused populations were concentrated primarily in states with large urban areas, such as California, New York, and Florida. The rural and sparsely-populated central and western states, including North Dakota, had comparably fewer people experiencing homelessness in terms of count alone. While this map indicates that North Dakota does not constitute a problem with people experiencing homelessness on a national scale, it does not show the struggles the state is facing on its own, smaller scale.

    Add narrative text

  20. Click the Change panel size button to increase the size of the narrative panel and expand the text.

    Use the Change panel size button.

    The sidecar is updated.

    The sidecar is updated.

Add the other two maps

Add the other two maps you made, to help readers analyze the issue.

  1. Underneath the sidecar, click the Add content block button and add a text block, and change it to a Heading block.
  2. For the heading, type People Experiencing Homelessness as a Percentage of the Population, 2013.

    Add a heading.

  3. Underneath the title, add another Sidecar, Immersive block.
    Add a sidecar.
  4. In the Change layout panel, choose Docked panel.

    The sidecar section appears.

  5. In the media panel of the sidecar, click the Add media button, and choose Add map.
  6. In the Add a map window, select your Homeless as a Percentage of Population, 2013 map.

    Add the homeless percentage map.

  7. On the Options tab, turn on Allow map navigation, Search, and Legend.

    Zoom in to the map so that it fills the pane.

  8. Click Place map.

    The map now appears on the right side of the sidecar.

    The map is added to the page.

  9. Above the map click the Options button.

    Click the options button.

  10. In the Web map options, for Alternative text (optional), type: Map of the percentage of people experiencing homelessness in each U.S. state in 2012-2013.

    Add the alt text.

  11. In the narrative panel of the sidecar, add the following text: When the amount of people experiencing homelessness counts are normalized by the population, a somewhat different pattern emerges than in the homeless counts map. While California and New York still dominate, several states in the Midwest display relatively large numbers of people experiencing homelessness for their population. Among these states, North Dakota stands out as having a particularly high percentage of people experiencing homelessness, as migrant workers have flocked to the state in search of well-paying energy industry jobs, only to discover a housing shortage and high cost of living. A high unhoused percentage may strain a state's ability to combat the problem with its own resources, necessitating external assistance.

    Add the homeless percentage text.

    In between the map, click the Change panel size button to expand the size of the narrative panel.

    The sidecar is updated.

  12. In between the two panes, click the Switch panel placement button.

    Choose switch panel placement.

    The two sides of the panel swap placement.

    The map panels swap.
  13. Underneath the sidecar, click the Add content block button, add a text block, then change it to a Heading.
  14. For the heading, type People Experiencing Homelessness: Percentage Change, 2012-2013.

  15. Underneath the title, add another Sidecar content block.
  16. In the Change layout panel, choose Docked panel.

    The sidecar section appears.

  17. In the media panel, click the Add media button, and choose Add map.
  18. In the Add a map window, select your Percent Change in Homeless Count, 2012-2013 map.

    Add the percent change map.

  19. On the Options tab, turn on Allow map navigation, Search, and Legend.

    Zoom in to the map so that it fills the pane.

  20. Click Place map.

    The map now appears on the right side of the sidecar.

  21. Above the map, click the Options button.
    Click the Options button.
  22. In the Web map options, for Alternative text (optional), type Map of the percentage change of people experiencing homelessness in each U.S. state in 2012-2013.

    Add the alt text.

  23. Click Save.
  24. In the narrative panel of the sidecar, add the following text: In the period from 2012 to 2013, discoveries in shale oil and advances in drilling techniques created an oil boom in North Dakota. Migrant workers from across the continent flocked to the rural prairie state in search of plentiful and well-paying jobs. The state now boasts high economic indexes across the board, including the lowest unemployment rate in the country. But the boom has put a strain on North Dakota's infrastructure. As some cities nearly double their populations, housing has been unable to keep pace with the growth. Employed and healthy individuals are experencing homelessness, working by day and finding housing in cars and tents.
    Add the new text.
  25. In between the panels, click the Change panel size button to expand the text.

    The sidecar is updated.

    The sidecar is updated.

    You have added the texts and maps to your story. Now you'll change the design and publish the map.

Design your story

The story looks good; now customize the design for better readability.

  1. At the top of the ribbon, select the Design menu.

    Choose Design from the ribbon.

    The Design panel appears.

  2. Under Optional story sections, ensure the Navigation and Credits buttons are turned on.

    Alter the Design pane.

    By turning on Navigation, your story generates tabs to separate the different sections of your story.

  3. Under the Theme section, choose Slate.

    Add the Slate theme.

    The theme is updated.

  4. On the cover of your story, click the Add cover image or video button.

    Add a cover image.

    A new window appears.

  5. In the Add image or video window, click Browse your files and select your homeless-in-the-badlands-thumb.png file.

    Add the cover image.

  6. Click Add in the window.

    The cover image updates.

    If necessary, click the Options button and adjust the image.

Publish your story

Now that you have built your story, you'll publish it so it can be shared with everyone.

  1. On the ribbon, select Preview.

    Preview the map.

    Review your changes and make sure everything looks right.

  2. Close the reviewing panel and select Publish.
  3. Select Everyone (Public) from the Publish menu.

    Set the sharing option to Everyone (Public).

    Choosing this setting allows anyone to view your story.

  4. Click Publish story.

    Your story is now finished and you can share the link with everyone.

In this lesson, you downloaded tabular data and joined it to a layer. You published the layer to ArcGIS Online and created three maps using your data. Finally, you shared your results as a web app.

This lesson dealt with an issue that occurred primarily in 2012 and 2013. New data suggests that the homeless problem in North Dakota has started to decline as infrastructure is built to sustain the migrant population. Although the problem has not been completely resolved, the work of advocates and analysts has made and will continue to make a difference in North Dakota.

You can find more lessons in the Learn ArcGIS Lesson Gallery.