Perform a service drop

First, you'll explore utility network editing functionality through interaction with the network topology, feature templates, and the Modify Associations pane. You're required to use a recent design received from an engineer that outlines a service drop within a new development as a template for this purpose. You'll refer to this design as you progress through the editing workflow. If you're new to ArcGIS Pro or the ArcGIS Utility Network, take a quick tour.

Configure the edit environment

Before you begin editing, verify that your snapping environment is properly configured. Snapping, along with network rules, help ensure that proper connectivity is established between network features and objects.

  1. Download the Get Started with the ArcGIS Utility Network project package.

    Note:

    If you don't have ArcGIS Pro or an ArcGIS account, you can sign up for an ArcGIS free trial.

    Note:
    This lesson was most recently tested for ArcGIS Pro 2.9. For ArcGIS Pro 2.5 or earlier use the Get Started with the ArcGIS Utility Network pdf and Review the Utility Network ribbon.

  2. Locate the downloaded project package on your computer. Move the file to a suitable location if necessary, and double-click it.

    The project opens in ArcGIS Pro. It contains a map with several layers classified by the type attributes of Asset group and Asset type. To the west of Wrights Mill Road is your existing network. You'll begin adding features to connect the new services you're creating along Ogletree Road to the existing network.

  3. On the ribbon, click the Edit tab. In the Snapping group, click the Snapping drop-down arrow.
  4. Verify that Snapping is On is highlighted.

    Make snapping active.

  5. Verify that Point, End, Vertex, and Edge are enabled.

    Select snap types.

    With snapping configured, you’ll navigate to the location of the design you’ve received to begin constructing network features.

  6. On the ribbon, click the Map tab. In the Navigate group, click Bookmarks and choose Perform a Service Drop.

    Your map updates to the extent where a new service drop needs to be added.

    Identify area of interest

  7. On the ribbon, click the Edit tab. In the Features group, click Create.

    Choose Create tool

    The Create Features pane appears.

  8. If necessary, dock the Create Features pane on the along with the Catalog pane.

    Review the various feature templates associated with the network layers. These are basic feature templates that use default attribute values for each asset groups.

    Note:

    To improve the efficiency of the editing process, you can create templates or modify existing ones using the Manage Templates button in the Create Features pane of your project.

    The design you are following will carry a single phase (B). To prevent the need to configure the active template when placing features, you’ll preconfigure the templates with this phase designation.

  9. In the Create Features pane, click Manage Templates to open the Manage Templates pane.

    Manage Templates button in Create Features pane

  10. In the Manage Templates pane, select Electric Distribution Junction and double-click Connection Point to open the Template Properties window.

    Select Connection Point template

  11. In the Template Properties window, click the Attributes tab to display the default attributes used with the Connection Point template.
  12. In the attributes list, make the following updates:

    • For Phases Built, choose B.
    • For Phases Normal, choose B.
    • For Phases Current, choose B.
    • For phasesenergized, choose B.

    Update template attribute values

    Updating the default attribute values ensures that the proper phase is set when placing connection points.

  13. Click OK.

    All future connection points you place will use these attribute values as defaults in the template. Next, you'll use the Manage Templates pane to update the templates for the other features you will be working with in this lesson.

  14. In the Manage Templates pane, select Electric Distribution Line and double-click Medium Voltage to open its template properties.
  15. In the Template Properties window, click the Attributes tab and update the following:

    • For Asset type, choose Single Phase Overhead.
    • For Phases Built, choose B.
    • For Phases Normal, choose B.
    • For Phases Current, choose B.
    • For phasesenergized, choose B.

  16. Click OK to close the window.
  17. In the Manage Templates pane, for Electric Distribution Line, double-click Low Voltage and update the following attributes:

    • For Phases Built, choose B.
    • For Phases Normal, choose B.
    • For Phases Current, choose B.
    • For phasesenergized, choose B.

  18. In the Manage Templates pane, select Electric Distribution Device. Double-click Fuse, Transformer, Circuit Breaker, and Service Point and update the following attributes:
    • For Phases Built, choose B.
    • For Phases Normal, choose B.
    • For Phases Current, choose B.
    • For phasesenergized, choose B.
  19. In the Template Properties window, click OK to close the window.
  20. Close the Manage Templates pane.

Editing features

With the default attribute values set, you can continue to create features without the need to update attributes after editing. You'll add several new network features to digitize a new development east of the existing network.

  1. If necessary, navigate back to the Create Features pane.
    Use feature templates
  2. In the Create Features pane, expand the Electric Distribution Junction template and click Connection Point.
    Tip:

    If necessary, use the search box at the top of the Create Features pane to quickly locate the template. If the layer is not visible, check the box in the Contents pane to turn it on.

    Select updated Connection Point template.

  3. In the Connection Point template, click the Active Template arrow to view the attributes set for this template.

    Review template settings

  4. Verify that the default values in the template correspond with those you set earlier in the Template Properties window using the Manage Templates pane.

    Confirm attribute value settings

  5. In the Active Template pane, click the Point Placement button.

    Select feature construction tool

  6. On the Map, locate Ogletree Road and use the pointer to place four connection points in a line along the north side of the road.

    Create features on map

    Consider using a scale of 1:35 to review the points. A purple hashed polygon that encompasses each point feature has been created, signifying that the polygon represents a dirty area. There should be four polygon features, one for each new point.

    Tip:
    To temporarily disable Edit mode so you can zoom and pan, press the C key.

    Next you will add a medium voltage line to connect each connection point.

  7. In the Create Features pane, expand Electric Distribution Line, click Medium Voltage, and choose the Line tool.

    Choose Medium Voltage construction tool.

  8. On the map, draw a line from the topmost connection point to the second point. Double-click the second point to end the line segment. Make sure the line snapped to both point features.
  9. Draw two more individual line segments to connect the rest of the points.

    Construct medium voltage lines

    Note:

    You can snap medium voltage lines to the connection points because a Junction-Edge network rule has been established to allow this type of connectivity. You can review the network rules on the Network Properties tab.

  10. On the ribbon, on the Edit tab, in the Manage Edits group, click Save.
  11. On the Save Edits dialog box, click Yes to save all edits.
  12. Review the map and note the dirty areas displayed around each of the new medium voltage lines.

    The dirty area polygons created when editing the medium voltage lines are more evident than those placed around connection point features. Dirty area polygons are created for the minimum bounding rectangle of a feature.

    Review medium voltage line dirty areas

    Note:

    It is important to keep the network topology updated so that you can perform analytics such as creating network diagrams or performing traces with accurate results. The network topology is updated by validating the network topology to remove dirty areas.

    Next, you will validate the network topology to clean the dirty areas.

  13. If necessary, zoom out so that all new features and dirty areas are displayed on the map.
  14. On the Utility Network ribbon, on the Data tab, in the Network Topology group, click Validate.

    Validate topology

    The Validate drop-down menu has two options: Current Extent (the default) and Entire Extent. After validation has completed, the dirty areas are no longer present on the map.

    Tip:

    Tools that you use frequently can be added to the quick access toolbar in the upper left corner of the project. To add a tool, right-click the tool and choose Add to Quick Access Toolbar. You may find it useful to do this for both the Validate and Save tools, which are located on the Edit tab of the ribbon. Other tools, such as Select and Clear, are good to have easy access to as well.

    Next, verify the dirty areas have been removed, and save the edit.

  15. On the Edit tab, in the Manage Edits group, click Save.
  16. On the Save Edits dialog box, click Yes.

Perform a connected trace

After creating the first series of electric lines and validating your work, you’ll run a basic connected trace in the trace gallery to verify that features are properly connected.

  1. If necessary, zoom to Ogletree Rd.
  2. On the Utility Network ribbon, click the Data tab. In the Tools group, click Trace Locations and choose Starting Points.

    Select starting point for network trace

    The Trace Locations pane appears with the Starting Points tab selected.

  3. In the Trace Locations pane, click the Add features tool.

    Add feature to trace

  4. On the map, click one of the connection points to denote the start location for the trace.

    Select starting point in map

    The map updates and displays a green circle denoting the placement of your starting point. In the Trace Locations pane, an entry is added identifying the starting point feature.

    Note:

    If you uncheck the Auto Apply option, the behavior changes. Without Auto Apply, adding a starting point results in a gray circle on the map and an entry in the Trace Locations pane with an asterisk next to it. This option adds an Apply button at the bottom of the pane; clicking Apply removes the asterisk and turns the circle green on the map.

  5. On the ribbon, in the Tools group, click Connected.

    Choose Connected trace

    The Trace geoprocessing tool dialog box appears with default settings for a connected trace.

    Set trace properties

  6. Review the Trace parameters and click Run.

    Using the default settings results in a trace that verifies connectivity. When the trace is completed, it returns seven features selected on the map.

  7. In the Contents pane, click List by Selection to verify which features are selected.
    Review trace results in map with selected voltage lines
  8. Save the project.

The first features for the new services were successfully added and verified. Next, you'll add more features to create services for the new homes and connect these with the features you just created.


Create a network diagram

The connection points and lines you added will form the basis for the services that will be placed for the new development to be added to the network. Next, you'll add more infrastructure and visualize it using a network diagram.

Generate a network diagram

Now that you have created network features and updated the network topology to reflect the changes made, you can generate a network diagram. A network diagram is a schematic representation of your data that can make it easier to visualize networks.

  1. On the map, ensure that the seven features selected by the Trace tool are selected.
    Note:

    If they're not selected, on the Edit tab, in the Selection group, click the Select tool and click the point and line features you just added.

  2. On the Utility Network ribbon, click the Data tab. In the Diagram group, click New.

    Create network diagram

    When you click the New button, you can choose the diagram template. If you don't choose, the default diagram type is Basic. A new diagram view is generated showing the seven selected features. Additionally, the ribbon changes to display the contextual tab for a network diagram.

    View the new diagram.

    Network diagrams are representations of a set of features that participate in the utility network. These allow you to display simplified representations of sometimes-complex network features as well as nonspatial junction and objects to illustrate how the network is structured and how it operates without the limitations of real-world scaling and feature placement.

  3. On the Network Diagram tab, in the Manage group, click Store to open the Store Diagram dialog box.
    Note:

    Network diagrams can be stored in the database if needed and retrieved using the Find Diagrams function. However, it is recommended to store diagrams only when it makes sense; for example, diagrams with a refined layout that you want to save or diagrams that you want to share with others.

  4. In the Geoprocessing pane, update the following parameters:
    • For Network Diagram Name, type Testdiagram.
    • For Tags, type Ogletree, Design1001.

    Set network diagram storage properties

    Note:

    If you receive an error with the Network Diagram Name parameter, add your name or initials to the end of Testdiagram.

  5. Click Run.

    The Testdiagram layer is added to the Contents pane.

    Review resultant diagram

Update network diagrams

As you make edits to the network, it is important to keep the network diagram up to date. This can help analysts and stakeholders track assets. Diagrams can be updated and regenerated whenever you add new features to the network. To test your diagram, you'll delete a feature and redraw the schematic.

  1. Click the Getting to Know map tab to activate the map view.
  2. Zoom to your edits on Ogletree Rd.
  3. On the Edit tab, in the Selection group, click Clear to remove the selection used to create the diagram.
  4. In the Selection group, click the Select tool. On the map, click the leftmost (first) medium voltage line.

    Delete a diagram source feature

  5. With the feature selected, press the Delete key on your keyboard. In the pop-up, click Delete.

    The line is deleted and a dirty area appears on the map.

    Dirty area around deleted feature

  6. On the Data tab, in the Network Topology group, click Validate.
  7. On the Edit tab, in the Manage Edits group, click Save.
  8. Click the Testdiagram tab to switch to the diagram view.

    Activate Diagram view

    The deleted medium voltage line no longer appears in the diagram. If the diagram has not updated, zoom in or out to refresh it.

  9. On the Network Diagram tab, in the Manage group, click Consistency.

    The diagram becomes inconsistent when dirty areas are present that impact features in the diagram or any time updates are made to the network topology space with updates that intersect the diagram area.

    Check diagram for consistency

    Note:

    The consistency functionality identifies whether the diagram is consistent or not. When a diagram is inconsistent, a consistency warning is displayed next to the diagram layer entry in the Contents pane. A red consistency warning indicates that the diagram is inconsistent with regard to the feature editing space. An orange consistency warning indicates that the diagram may be inconsistent with regard to the network topology space. Until dirty areas impacting features in the diagram are present, the red consistency warning displays next to the diagram layer.

    Once the network topology is validated and dirty areas disappear, the consistency warning icon becomes orange. The diagram can then be updated to reflect the network topology changes.

    In the Contents pane, a yellow caution icon appears next to Testdiagram.

    Note consistency caution as a result of deleted feature

    This icon signifies that the diagram may no longer be consistent with your network. If you open an existing diagram stored in the system, a consistency check is automatically performed. Since the diagram was open when the changes were made to the map, you must perform a manual check.

  10. On the Network Diagram tab, in the Modify group, click Update.

    Update network diagram

    The update button refreshes the diagram to reflect the changes made to the network topology. The warning icon is removed from the Contents pane once the update is complete.

  11. Close the Testdiagram view.
    Note:

    To access this diagram again, on the Data tab, in the Diagram group, click Find.

    Next, you'll recreate the line just deleted to demonstrate the consistency check with the diagram.

  12. On the Edit tab, in the Features group, click Create to open the Create Features pane.
  13. In the Create Features pane, in the Electric Distribution Line template, click Medium Voltage.
  14. In the Medium Voltage template, click the Line button.
  15. In the map view, select the rightmost connection point along the north side of Ogletree Rd.
  16. Use the Medium Voltage Line option to replace the line you deleted.

    Recreated deleted feature

  17. On the Data tab. in the Network Topology group, click Validate.
  18. On the Edit tab, in the Manage Edits group, click Save. In the Save Edits window, click Yes.
  19. Save the project.

Explore connectivity associations and terminal configurations

So far, you've created connection points and electric distribution lines using snapping and connectivity rules. Each dirty area, or visual marker of where edits are made, has been validated and updated in the network topology to perform network analytics such as tracing and creation of network diagrams. Now, you'll add connectivity associations and terminal configurations and extend low voltage lines from the low side terminal of a device to a few new service points.

  1. On the Edit tab, in the Selection group, click Select and select the rightmost connection point along Ogletree Rd.
  2. In the map view, on the bottom ribbon, click Selected Features: 1 to center the feature on the map.
  3. In the Create Features pane, expand Electric Distribution Device and choose the Fuse template.
  4. Select the Point At End of Line tool and add a fuse to the selected connection point.

    Select feature construction tool

    Next, you'll create a fuse using a temporary line offset by three feet from the selected connection point.

  5. Right-click the map to open the contextual menu with advanced editing options.
  6. Choose Distance.

    The Distance pane appears and allows the setting of a construction constraint.

  7. In the Distance window, enter a distance of 3 ft.

    Distance window

  8. Press Enter to apply the distance constraint.

    On the map, a construction line constrained to 3 feet extends from the selected connection point.

    Initiate feature construction

  9. Double-click the map to add a new fuse southeast of the selected connection point.

    Finalize feature construction

    Because the Point At End of Line tool is selected, the fuse point moves 3 feet southeast of the connection point.

  10. In the Create Features pane, for the Transformer template, choose Point at End of Line and click the new fuse.

    Select transformer construction tool

  11. Right-click the map and choose Distance.
  12. Enter a distance of 6 ft and press Enter. Double-click the map to add a new transformer.

    Construct transformer feature

    Next, you'll add new service points to connect three houses to the network.

  13. On the ribbon, click the Map tab. In the Navigation group, click Bookmarks and choose Place Service Points.

    The map zooms out to show three houses on the basemap.

  14. In the Create Features pane, for the Service Point template, choose the Point tool.
  15. Click the map to add three service points, each close to one of the three homes in the design.

    Construct service points on map

    The edits you've just made present a good use case for connectivity associations since the features are close together.

    Connectivity associations are useful when you want to establish connectivity between two junction features but don't need to see the actual line feature that connects them. Connectivity associations are also useful in situations when you are working with multiple stacked junctions or in scenarios where you are establishing connectivity to nonspatial junction or edge objects. Junction-Junction Connectivity rules manage this type of association and can be viewed on the Network Properties tab in the Rules section and the Junction-Junction Connectivity subsection.

Explore connectivity associations

Before extending low voltage lines from the homes to the service points from the transformer, you'll create connectivity associations between the rightmost connection point, the fuse, and the transformer to establish connectivity between the objects.

  1. On the Utility Network ribbon, click the Data tab. In the Associations group, click Modify.

    Locate modify associations tool

    The Modify Associations pane appears.

  2. In the Modify Associations pane, click Add features.

    Select network junction

    The Add features tool will display a different arrow icon as you move over the map.

  3. On the map, zoom to the Connection Point feature at the right end of the medium voltage line.

    Identify connection point on map

  4. Confirm that the Add features tool is active and click the connection point.

    The Active Item in the Modify Associations pane is populated with the connection point feature.

    Active Item in the features

  5. In the Modify Associations pane, expand the Junction - Junction section.

    Modify Associations and Add Features

  6. Click the Add feautures tool and select the fuse on the map.

    The fuse is added to the pane in the Junction - Junction section with an green indicator to indicate it is a new association.

    Review selected associations

  7. In the Modify Associations pane, click Apply.

    A dirty area is created on the connection point and the fuse where you created the connectivity association. The indicator for the association becomes purple to indicate that the associated features are dirty.

    Identify new dirty area around associations

    Next, you'll create a junction-junction connectivity association between the fuse and the high side terminal of the transformer.

  8. In the Junction - Junction section of the Modify Associations pane, right-click the Fuse and choose Modify Associations.

    Modify associations

    Modify Associations makes the fuse the Active Item and lists any current connectivity associations for the fuse (including the connection point in the previous step). In addition, it activates the Add features tool to select and add additional connectivity associations for the fuse.

  9. In the Junction - Junction section of the Modify Associations pane, confirm that the Add Features tool is active, and click the transformer on the map.

    The transformer is added to the Junction - Junction section, with a green indicator indicating it is a new connectivity association.

  10. In the Modify Associations pane, for the transformer, confirm that the High side terminal is selected.

    Specify transformer terminal type

    Terminals represent distinct nongeographical ports, entries, or exit locations on either a Device or Junction Object. Terminals create internal paths within the feature or object; from those paths, a set of valid paths can be established to control how a commodity can flow through the network feature at different states.

    Terminals can connect directly only to the endpoint of a line. Midspan connectivity to a terminal is established through a connectivity association to another point feature that is located on the line, such as a connection point or tap.

  11. Click Apply.
  12. On the ribbon, click on the Data tab. In the Associations group, click View to switch to View Associations mode.

    Choose view associations tool

    View associations mode displays the connectivity association for the area within the current map extent. If you pan or move to a different area, you need to toggle the view button to disable and enable the view mode and refresh the display.

    View associations on map

    Next, you'll validate the network topology and save your edits.

  13. On the Utility Network ribbon, click on the Data tab. In the Network Topology group, click Validate.
  14. On the Edit tab, in the Manage Edits group, click Save to save all edits.

Explore structural attachments

Now that you have established connectivity associations between the connection point, fuse, and transformer, you'll extend low voltage lines to the service points and create a pole structure feature. Then, you'll configure a structural attachment association between the pole and the devices you created earlier.

  1. On the Edit tab, in the Features group, click Create to open the Create Features pane.
  2. In the Create Features pane, expand the Electric Distribution Line template and click Low Voltage.

    Select Low Voltage distribution line

  3. In the Create Features pane, select the Radial tool to create a line feature originating from a common center.

    Choose Low Voltage construction tool

  4. On the map, click the transformer feature.

    Construct low voltage line on map

  5. Starting from the transformer, add separate low voltage lines between the transformer and each of the service points located near the new homes.

    Add lines to service points

  6. Right-click and select Finish to exit the Radial tool.

    Next, you'll verify that the low voltage lines are associated with the proper terminal of the transformer to ensure proper modeling of the junction-edge connectivity of these features. You will use the Modify Terminal Connections pane to set a terminal connection between this line and the low-side terminal of the transformer device feature.

  7. On the Utility Network ribbon, click the Data tab. In the Network Topology group, click Terminal Connections.

    Select Terminal Connections

    The Modify Terminal Connections pane appears.

  8. In the Modify Terminal Connections pane, click the Select a line feature tool.
  9. On the map, select one of the low voltage lines.
  10. In the Modify Terminal Connections pane, verify that the terminal connection is properly associated with the Low side terminal of the transformer.

    Update Transformer Terminal to Low.

  11. Click Apply.
  12. Repeat the process to modify connections to the other two lines.
  13. On the Edit tab, in the Manage Edits group, click Save to save all edits.
  14. On the Map tab, in the Navigate group, click Explore to review your edits.

    Review dirty areas on map

  15. In the Selection group, click Clear to clear the current selection. Click Select.
  16. Change the map scale to 1:40.
  17. On the map, select the transformer feature.
  18. On the bottom ribbon of the map, click Selected Features:1 to center the transformer.

    Zoom to selected feature on map

    Next, you'll create a pole within the structure network to support the electrical devices you previously placed and establish a structural attachment association between them.

    Structural attachments are used to attach a point features and junction objects with another point or junction object in the structure network. They establish a logical association between domain network features and structure network features in a utility network. These associations allow you to model the relationship between structures that support equipment and associated assets that are attached.

    Structures are not part of the network for purposes of tracing the resource, but you may need to quickly identify and list structures that are attached to network features. This can be useful to report which structural features, such as poles, are associated with a subnetwork, or which assets may be impacted due to work on a structure feature.

  19. In the Create Features pane, expand Structure Junction and choose the Pole template. Click the Point tool.

    Locate Pole template

  20. On the map, add a pole feature roughly 6 feet to the west of the transformer.
    Tip:

    For accuracy, use the Point at end of Line tool and constrain construction by setting the direction to west and the distance to 6 feet.

    Add new pole to map

    Next, create a structural attachment association between the pole and the nearby connection point, fuse, and transformer.

  21. On the Utility Network ribbon, click the Data tab. In the Associations group, click Modify.
  22. In the Modify Associations pane, if the pole is still selected, click the Load selected to populate the Active Item in the pane with the pole feature.
  23. If the pole is not selected, in the map view, click the pole feature.

    The Active Item in the Modify Associations pane is updated with the pole structure junction.

    Select pole to modify associations

  24. In the Modify Associations pane, click the Attachment tab, expand the Attachments section, and click the Add Features tool.

    Add attachments to associations

  25. On the map, click the connection point feature at the end of the medium voltage line, and then click the fuse and the transformer that connects to the low voltage lines.

    All three features are added to the pane with green indicators to represent that they are new attachments.

    Verify associated features

  26. In the Modify Associations pane, click Apply.

    Dirty areas are shown, indicating features need to be validated.

    Review associated feature dirty areas on map

  27. On the Utility Network ribbon, click the Data tab. In the Network Topology group, click Validate.

    Instead of zooming to the extent of all edits to validate the current extent, you can choose the Entire extent option in the drop-down list for the Validate command.

    Validate full extent of map

  28. On the Edit tab, in the Manage Edits group, click Save.

    Save edits

    You have now created structural attachment associations as well as connectivity associations to establish connectivity between junction features in your network. Now you'll review the associations you've created to this point using the View Associations mode.

  29. On the Utility Network ribbon, click the Data tab. In the Associations group, click View.

    Select view associations tool

    On the map, brown dashed lines represent the connectivity associations and green dashed lines represent structural attachment associations.

    Review associations in map

  30. On the Utility Network ribbon, click the Data tab. In the Associations group, click View to switch from View Associations mode and remove the dashed lines.
  31. Save the project.

    You've created features and created associations to connect services for the new homes to the network features and validated them. Next, you'll connect the new assets to a new substation.


Work with network diagrams and layouts

You have completed the service extension to the three new services outlined in the required design. You'll now take another look at the capabilities provided with network diagrams using the simple diagram you created earlier.

A reminder about diagrams: Diagrams provide a symbolic representation of geographic information using various visualization methods to convey information about your network. They are often used to represent networks in a defined space without scaling constraints (cable length, distances, and so on)—for example, a piece of paper on which numerous pieces of information are displayed in a defined space through optimization of feature placement.

In this scenario, you will run another connected trace and generate a diagram to apply layout algorithms for your organization. Finally, you will propagate the selection set between your diagram and map views.

Learn more about network diagrams

Create a diagram

To create a new diagram, you will re-run the same trace operation you executed at the beginning of this scenario.

  1. On the ribbon, click the Analysis tab. In the Geoprocessing group, click History to open the History pane.

    Recall geoprocessing history

    The History pane appears and provides access to previously executed geoprocessing tools. Running the Trace geoprocessing tool from the History pane allows you to execute the trace using the same parameters and settings you used with the previous trace.

    Review past geoprocessing steps

  2. In the History pane, right-click Trace and click Run.
    Note:

    If you previously cleared your starting points, the trace will fail. Place a new starting point anywhere on the medium voltage line and run the trace.

  3. Verify that 15 features are selected on the map.

    Verify selected features returned by trace

    You'll now create a diagram based on the selected features.

  4. On the Data tab, in the Diagram group, click New.

    Create diagram from selected features

    The Create Diagram tool creates a diagram from the Basic template. If you select everything in the Diagram view after the diagram has been created, 17 features will be selected (15 network features and 2 connectivity association features). The pole you placed earlier and its associated structural attachments are not listed since they have been not traced in the map. The trace tool was configured to execute with the Include Structures option unchecked.

  5. On the Network Diagram tab, in the Layout group, click Set Flags.
  6. In the Set Flags drop-down list, choose Set Root Junction.

    Set diagram flags

  7. In the Diagram view, click the first connection point in the diagram.

    A green circle appears over the selected location and the diagram changes to use the same orientation as the Map view.

    Set first connection point in diagram

  8. On the Network Diagram tab, in the Layout group, click the Diagram Layouts drop-down menu.

    Choose diagram layout

  9. In the Diagram Layouts gallery, in the Hierarchical group, click Smart Tree to open the Apply Smart Tree Layout geoprocessing tool.

    Select Smart Tree diagram layout

    The Smart Tree layout algorithm arranges the diagram features hierarchically and places them in a smart tree according to the direction and spacing distances specified in the tool. You will set a root junction to designate the starting point for the diagram. This is referenced when applying layouts.

  10. In the Apply Smart Tree Layout geoprocessing tool dialog box, set the following parameters and click Run:

    • Input Network Diagram Layer>Temporary Diagram
    • Tree Direction>From left to right
    • Accept all additional default settings.

    Review resultant diagram

    Diagrams are useful because they provide a logical view of the network. Compared to the Map view, they can be helpful to understand the features that are being represented. Next, you will switch between the Map and Diagram views to visualize network features and generate selection sets.

  11. Click the Diagram tab and drag and dock it to the right of the Map view.

    Review Map and Diagram views side by side

  12. On the Network Diagram tab, in the Selection group, click the Options button at the lower right.

    Selection options

    The Utility Network Options window appears.

  13. In the Utility Network Options window, on the Network Diagrams tab, uncheck Zoom to the resulting selected features, and click OK.

    Uncheck option to zoom to resulting selected features

  14. If necessary, select the Diagram view to make it active.
  15. On the Network Diagram tab, in the Selection group, click the Select tool.
  16. Select a segment of the medium voltage line in the Diagram view.
  17. On the Network Diagram tab, in the Selection group, click Apply To Maps and choose the current map, Getting to Know.

    Link diagram update to map

    The map updates to display the same selected features as the diagram. The corresponding line feature is selected in the Map view.

    Select in diagram to highlight associated feature in map

  18. Click the Getting to Know tab to make the Map view active.
  19. On the ribbon, click the Map tab. In the Selection group, click the Select tool.
  20. Select the low voltage line in the Map view.
  21. On the Utility Network ribbon, on the Data tab, in the Selection group, click Apply To Diagrams.

    Apply map update to diagram

    The corresponding line feature is selected in the Diagram view.

    Select in Map view and observe corresponding selection in Diagram view

  22. Close the Diagram view.

Explore containment associations and subnetwork management

In your existing network, a substation is located about 2 miles to the south, on the southern border of Chewacla State Park. This wasn’t loaded with the sample data provided by the consultant, so you'll create a substation closer to the location of your design’s area of interest specifically for the purposes of exploration. You'll place a circuit breaker to configure a subnetwork controller and establish a new circuit to build an understanding of containment associations and the basics of subnetwork management.

  1. On the Map tab, in the Navigation group, click Bookmarks, and choose Place Substation.

    Your map updates to the extent where a new substation will be added.

  2. On the Edit tab, in the Features group, click Create to open the Create Features pane.
  3. In the Create Features pane, expand Structure Boundary, and choose the Substation feature template .
  4. Choose the Polygon tool and draw a substation feature on the map.

    Construct substation feature on map

    Substations are a special type of feature known as a container. Containers can contain other features that are logically inside of them and are used to improve cartographic clarity. With the substation feature selected, you will enter containment mode and add content to this container.

  5. On the Utility Network ribbon, on the Data tab, in the Associations group, click Enter Containment.

    Select container association tool

    In the Map view, the pointer updates to a box with an arrow.

  6. In the Map view, select the substation feature.

    Select substation to add to container

    Selecting the substation places the system in containment mode and updates the map extent to the selected container feature. The feature is selected and surrounded by a dashed outline. The dashed line provides a visual reminder that you are in containment mode.

    Note:

    Any feature you create while in containment mode will be set as content if there is a valid containment rule defined.

    Verify substation is part of container

  7. In the Create Features pane, expand Electric Distribution Device, select the Circuit Breaker template, and click the Point tool.
  8. Click the map to place a new circuit breaker within the boundary of the selected substation polygon.

    Construct circuit breaker on map

    Next, you will set the circuit breaker as a source in the network.

  9. Confirm that the circuit breaker feature is selected.
  10. On the Edit tab, in the Selection group, click Attributes.

    Select Attributes

    The Attributes pane appears. The Association status value is set to Content. This is because the feature was created within the substation boundary while in containment mode.

  11. Review the Is subnetwork controller attribute, which is set to False.

    Set subnetwork controller identification value

    Certain types of features are permitted to become subnetwork controllers. This is done using network category settings in the utility network configuration. Subnetwork controllers act as either a source or a sink to determine how resources flow through the network.

    In this scenario’s configuration, only circuit breaker and transformer devices can be set as subnetwork controllers. Next, you'll set the new circuit breaker as a subnetwork controller so that it can become the source for a new circuit containing the service extension you designed.

  12. Close the Attributes pane.
  13. On the Utility Network ribbon, on the Data tab, in the Subnetwork group, click Modify Controller.

    Select Modify Controller tool

    The Modify Subnetwork Controller pane appears.

  14. In the Modify Subnetwork Controller pane, click the Select feature tool and click to select Circuit Breaker.

    The Modify Subnetwork Controller pane updates and displays Circuit Breaker properties that can be set and updated.

  15. In the Modify Subnetwork Controller pane, update the following and click Apply:

    • For Tier, verify that Medium Voltage is selected.
    • For Subnetwork Controller Name, type Ogletree Substation.
    • For Subnetwork Name, type RM1001.
    • Leave all other fields empty.

    Update subnetwork controller properties

    Note:

    If you do not provide a name for the subnetwork in the Subnetwork Name field, a GUID value will automatically populate the field when you click Apply. When creating a subnetwork, provide a descriptive name, as this will be used to represent the subnetwork in other parts of the system.

  16. Close the Modify Subnetwork Controller pane.

    Close pane

    You've now configured this circuit breaker as a subnetwork controller. Review its attributes to verify the changes made to the feature.

  17. On the Edit tab, in the Selection group, click Attributes.

    In the Attributes pane, the Is subnetwork controller attribute is set to True for this feature.

  18. Close the Attributes pane.
  19. On the Utility Network Ribbon, click the Data tab. In the Associations group, click Exit Containment.

    Select Exit Containment mode

    Features created after this will no longer be set as content. Next, you'll add connections to the Ogletree substation from both the existing development that your consultant loaded as reference for you and the development you've created.

  20. On the Map tab, in the Navigation group, click Bookmarks and select Extend Medium Voltage from Substation.

    Your map updates to an extent displaying both the Substation feature and the end of the Medium Voltage line alone Ogletree Rd.

  21. In the Create Features pane, expand Electric Distribution Line, open the Medium Voltage template, and click the Line tool.

    Select line construction tool

  22. In the Map view, construct a medium voltage line between the leftmost connection point created earlier along the north side of Ogletree Road and the circuit breaker.

    Construct medium voltage line

  23. On the Map tab, in the Navigate group, click Bookmarks and choose Existing Development Connection Point.

    The map updates and displays a connection point at the intersection of Wrights Mill Rd. and Estate Ave.

    Review new development area on map

  24. In the Create Features pane, in the Medium Voltage template, click the Line tool.

    Add new line features to map

  25. Construct a medium voltage line between the circuit breaker located inside the substation you created earlier and the connection point near the intersection of Wrights Mill Rd. and Estate Ave.

    Start line construction

    The new medium voltage line is added, and a dirty area is shown. Now, you'll ensure that both medium voltage lines are associated with the correct terminal of the circuit breaker to properly model the junction-edge connectivity of the features. You'll use the Modify Terminal Connections pane again to set a terminal connection between the lines and the load terminal of the circuit breaker feature.

  26. On the Utility Network ribbon, on the Data tab, in the Network Topology group, click Terminal Connections.

    Select Terminal Connections tool

    The Modify Terminal Connections pane appears.

  27. In the Modify Terminal Connections pane, click Select a line feature and select the medium voltage line that spans between the circuit breaker and the connection point to its west.

    Selecting these features ensures that the terminal connection is properly associated with the load side terminal.

    Select line feature in map

    Once a feature is selected, the Select a line feature tool in the Modify Terminal Connections pane updates to the Change line selection tool.

  28. Review the Modify Terminal Connections pane to ensure that the Load side terminal is selected and click Apply.

    Update feature terminal load

  29. On the map, select the medium voltage line between the circuit breaker and the westernmost connection point along Ogletree Rd.

    Add additional lines between circuit breaker and connection points

  30. Review the Modify Terminal Connections pane to ensure that the Load side terminal is selected and click Apply.
  31. On the Data tab, in the Network Topology group, click Validate to validate the network topology.
  32. On the Edit tab, in the Manage Edits group, click Save to save all edits.

Create a subnetwork

You have finished construction of a substation and connected it to the service extension outlined in your design as well as an existing development migrated for reference. You will finish your exploration of the utility network by creating a subnetwork using the Update Subnetwork geoprocessing tool within your medium voltage tier, using the circuit breaker created earlier as its source. Once this is complete, you will execute a final trace and review its results.

  1. In the Geoprocessing pane, search for and select the Update Subnetwork tool.
    Note:

    A subnetwork is a collection of connected lines, devices, and junctions within the network. The existence of a subnetwork will allow you to perform subnetwork analysis and understand the flow of commodities throughout your network. It is the subnetwork that drives tracing events, network diagrams, and provides techniques for network visualization such as rendering, labeling, and map generation (for example, creation of circuit maps).

    The Update Subnetwork tool opens in the geoprocessing pane. When you created the circuit breaker and set it as a subnetwork controller earlier to establish the Ogletree substation, this was established as the source for a topological subpart of the medium voltage tier. You may not have realized it at the time, but you completed the first step toward the creation of a subnetwork. The update subnetwork process will refresh subnetwork information and generate a subnetwork system diagram, create a feature in the SubnetLine feature class, and traverse connected features in the source and update them with the subnetwork name to which they belong.

  2. In the Update Subnetwork tool dialog box, set the following parameters and click Run:

    • For Input Utility Network, choose GettingtoKnow Utility Network.
    • For Domain Network, choose ElectricDistribution.
    • For Tier, choose Medium Voltage.
    • Uncheck All subnetworks in tier.
    • For Subnetwork Name, choose RM1001.

    Set tool parameters

    The tool runs and creates the RM1001 subnetwork, validates feature connectivity, and populates the subnetwork name and Is connected attribute on all connected features.

    Note:

    The process also adds a single aggregated feature to the SubnetLine class to represent the lines of the selected subnetwork. This read-only, system-provided feature class is useful for gaining a high-level view of the various subnetworks that comprise the tiers in your network. It can be labeled, symbolized, and published to create quick subnetwork maps (circuit maps). A subnetwork diagram is also created for the selected subnetwork using the Basic template.

    Next, you'll verify the changes by reviewing the attributes of the transformer you placed when creating the services outlined in the design. Then you'll review the SubnetLine class and the subnetwork diagram.

  3. Zoom to the transformer located along the north side of Ogletree Rd.

    Verify subnetwork on map

  4. On the Edit tab, in the Selection group, click Select and select the transformer.
  5. On the Edit tab, in the Selection group, click Attributes and review the attributes of the selected transformer.

    Review attributes

    The Is connected value is set to True and the subnetworkname value is set to RM1001. Next, you will visualize the SubnetLine feature class feature that was created.

  6. On the Map tab, click Bookmarks and click View SubnetLine feature.

    The map updates to the extent of your design.

    Navigate to subnetwork on map

  7. In the Contents pane, turn off the Electric Distribution Line group layer.

    The map updates to display a single line feature representing the RM1001 subnetwork in the Electric Distribution SubnetLine layer.

    Explore subnetwork on map

  8. On the map, select the SubnetLine along Ogletree Rd.

    The entire subnetwork is highlighted.

    Select subnetwork

    Next, you'll review the subnetwork diagram.

  9. In the Contents pane, turn on the Electric Distribution Line group layer and clear the current selection.
  10. On the Data tab, in the Diagram group, click Find.

    Locate network diagram

    The Find Diagrams pane appears. By default, the pane displays all diagrams containing features found in the current map extent. Two diagrams are listed, Testdiagram, which you created earlier, and the subnetwork diagram (Basic_RM1001) that was created when you ran the Update Subnetwork tool.

    Select diagram

  11. In the Find Diagrams pane, double-click the Basic_RM1001 diagram.

    The Basic_RM1001 diagram opens in the Diagram view. Try placing the views side by side and propagating selections between the two views.

Perform a subnetwork trace

You will finish your exploration using another of the available trace configurations to run a Subnetwork trace using the Trace tool. A subnetwork trace discovers all features participating in a subnetwork. This type of trace begins at one or more starting points and spans outward along connected features to find subnetwork controllers that are traversable. Once a subnetwork controller is encountered, the trace spans outward from that controller along the subnetwork and stops when either a barrier or a feature that is not traversable is encountered, or when there are no more connected features.

  1. On the Data tab, in the Tools group, click Trace Locations.

    Choose Trace Locations tool

    The map updates to display the trace starting point you added in previous steps.

    Select trace starting point

    Note:

    If the starting point was removed, click the Trace Locations drop-down arrow and choose Starting Points. In the Trace Locations pane, use the Add features tool to place a new starting point along the medium voltage line or skip this step and specify the RM1001 subnetwork for the Subnetwork Name parameter.

  2. On the Data tab, in the Tools group in the trace gallery, click Subnetwork.

    Select Subnetwork tool

    The Trace geoprocessing tool opens in the Geoprocessing pane.

  3. In the Trace geoprocessing tool dialog box, update the following parameters:

    • For Domain Network, chooseElectricDistribution.
    • For Tier, choose Medium Voltage.
    • For Subnetwork Name, choose RM1001 if you elected not to use a starting point.
    • Keep all other defaults.

    Trace geoprocessing tool

  4. Click Run.

    Completed trace

    The map updates to display all features that are connected in the subnetwork. While all the data in this example scenario is contained within this single subnetwork, the subnetwork trace discovers all features that participate within a subnetwork and stops when either a barrier or nontraversable feature is encountered. Unlike other trace types, the subnetwork trace automatically defines controllers outside of the specified subnetwork as barriers and stops the trace. This is useful for validating whether subnetworks, such as the circuit you just created, are defined or edited appropriately.

    Note:

    Subnetwork traces require a clean subnetwork. This means that as features within the subnetwork are edited in the future, Update Subnetwork must be run to update the network topology and subnetwork definition before running future subnetwork traces.

  5. Save the project.

In this lesson, you familiarized yourself with the tools and options available on the Utility Network ribbon as well as the Data and Network Diagram tabs. You then used this knowledge to create templates and edit new features for a design that placed services for a new development.

Through this lesson, you became familiar with the capabilities provided by the utility network to accurately model network features using connectivity associations, structural attachments, and terminal connections. You explored the concepts of network topology and dirty areas and built an understanding of the roles they play with network analytics, such as tracing and diagram creation. You then examined containment associations through creation of a substation and created content to serve as a subnetwork controller and source for a new subnetwork.

With these fundamentals established, you have become more familiar with the utility network and the capabilities it provides for the accurate modeling of your electric network and are ready to move on to more advanced workflows associated with the utility network. For more practice, check out the Get to Know ArcGIS Utility Network Management and Creating and Managing Utility Networks with ArcGIS courses.

You can find more lessons in the Learn ArcGIS Lesson Gallery.