Create a multidimensional raster from Landsat data

Before you can visualize change using multidimensional raster data, you must convert the individual image files into a multidimensional stack. In this lesson, you’ll create a multidimensional mosaic dataset from Landsat images collected over the Chuquicamata copper mine in Chile, from 1990 to 2010.

Create a project and access the data

First, you'll download the compressed .zip file that contains the data you'll use in this lesson.

  1. Go to the page for the lesson data, and click Download.

    Download button

    The .zip file may take some time to download, since it contains several large raster files.

  2. Locate the downloaded Chuquicamata_imagery.zip compressed folder on your computer, and move it to a location of your choice, such as the Documents folder. Right-click it to extract its content.
    Note:

    Depending on your web browser, you may be prompted to choose a file location before you begin the download. Most browsers download to your computer's Downloads folder by default.

    Next, you’ll create an ArcGIS Pro project using the Map template.

  3. Start ArcGIS Pro. If prompted, sign in using your licensed ArcGIS account.
    Note:

    If you don't have ArcGIS Pro or an ArcGIS account, you can sign up for an ArcGIS free trial.

    This lesson was most recently tested for ArcGIS Pro 2.7. If you're using a different version of ArcGIS Pro, you may receive different results.

  4. Under New, choose Map.

    New Map button

  5. In the Create a New Project window, for Name, type Chuquicamata mine. For Location, click Browse and choose a location of your choice. Click OK.

    Create a New Project window

    The new project appears. You'll now connect the project to the data folder you downloaded.

  6. On the ribbon, on the View tab, in the Windows group, click Catalog Pane.

    Catalog Pane button

  7. In the Catalog pane, expand Folders. Right-click Folders and choose Add Folder Connection.

    Add Folder Connection

  8. Browse to the location where you stored the downloaded data. Select the Chuquicamata_imagery folder and click OK.

    The folder is added to the project.

  9. Expand the Chuquicamata_imagery folder.

    Chuquicamata imagery folder

    The folder contains five subfolders, one for each of the five Landsat Thematic Mapper (TM) Level-1 Terrain-corrected images you will be working with. The images were acquired in the years 1990, 1995, 2000, 2005, and 2010.

    Note:

    The Thematic Mapper instrument was onboard Landsats 4 and 5 starting in 1982 and decommissioned in 2013. Landsat Level-1 Terrain products (L1TP) contain surface reflectance values. They include radiometric, geometric, and precision correction and use a Digital Elevation Model (DEM) to correct for topographic relief. For more information, see Landsat 4-5 Thematic Mapper Collection 1 products.

  10. Expand one of the folders.

    Folder for one image

    You can see that a single Landsat TM image is made of several files, which include several surface reflectance spectral bands (sr_band) and some quality assurance files (qa). The bands correspond to the following portions of the electromagnetic spectrum, as described on the USGS web page about spectral bands (section Landsat 4-5 Thematic Mapper):

    • sr_band1: blue
    • sr_band2: green
    • sr_band3: red
    • sr_band4: near infrared
    • sr_band5: shortwave-infrared 1
    • sr_band7: shortwave-infrared 2
    Note:

    Band 6 is not present. It is a thermal band and is usually not used together with the surface reflectance bands.

You'll now create a mosaic dataset and populate it with the five Landsat TM images.

Create a mosaic dataset

You'll complete the following steps to create a mosaic dataset.

  1. On the ribbon, in the Analysis tab, in the Geoprocessing group, click Tools.

    Tools button

    The Geoprocessing pane appears.

  2. In the Geoprocessing pane, search for Create Mosaic Dataset. In the result list, click Create Mosaic Dataset to open it.

    Create Mosaic Dataset button

    You'll create the mosaic dataset in the project geodatabase.

  3. On the Create Mosaic Dataset dialog box, under Parameters, for the Output Location, click Browse, click Project, click Databases, and select Chuquicamata mine.gdb. Click OK.

    Output Location window

  4. For Mosaic Dataset Name, type Chuquicamata Landsat.
  5. For Coordinate System, click Select Coordinate System.
  6. Search for WGS 1984 UTM Zone 19S. Expand Projected Coordinate System, UTM, WGS 1984, Southern Hemisphere, and select WGS 1984 UTM Zone 19S. Click OK.

    Coordinate System window

    This coordinate system is appropriate for the region of Chile where the Chuquicamata mine is.

  7. For Product Definition, expand the drop-down list and choose Landsat TM and ETM+.

    Create Mosaic Dataset parameters

  8. Expand Product Properties.

    Some names are proposed for the six bands. To fully match the description listed for Landsat 4-5 Thematic Mapper on the USGS site, you'll rename some of the band names.

  9. Change the following band names:
    • For NearInfrared_1, type Near Infrared.
    • For NearInfrared_2, type Short-wave Infrared 1.
    • For MidInfrared, type Short-wave Infrared 2.

    Product properties

  10. Leave all other parameters as default and click Run.

    The empty mosaic dataset gets added to the map. You'll now populate it with the five Landsat images.

    Note:

    By default, the map zooms in to the area that is covered by the coordinate system chosen for the mosaic dataset.

  11. At the bottom of the Geoprocessing pane, click the Catalog tab to go back to the Catalog pane.

    Catalog tab

  12. In the Catalog pane, browse to the newly created mosaic dataset by expanding Databases and Chuquicamata mine.gdb.
  13. Right-click the Chuquicamata_Landsat mosaic dataset, and select Add Rasters.

    Add Rasters

  14. In the Add Rasters To Mosaic Dataset parameters, for Mosaic Dataset, make sure the Chuquicamata_Landsat dataset is selected.
  15. For Raster Type, select Landsat 4-5 TM.
  16. For Processing Templates, select Surface Reflectance.

    Here, you are setting the processing template to reflect the type of imagery you are working with.

  17. For Input Data, click the drop-down list and select Folder. Click Browse, and under Folders, select the Chuquicamata_imagery folder. Click OK.

    Input Data window

    The tool searches all subfolders and adds images it finds to the mosaic dataset.

    Add Rasters To Mosaic Dataset parameters

  18. Expand Raster Processing, and check the Calculate Statistics box .
  19. Expand Mosaic Post-processing, and check the Update Overviews box.

    Add Rasters To Mosaic Dataset parameters, lower section

  20. Leave all other parameters as default and click Run.

    After a few moments, the mosaic dataset is populated with imagery. You'll zoom in to better see it.

  21. In the Contents pane, under the Chuquicamata_Landsat mosaic dataset, right-click the Footprint layer and choose Zoom To Layer.

    Zoom To Layer menu option

    You can now see the imagery on the map.

    The imagery appears.

    You'll now inspect the attribute table.

  22. In the Contents pane, under the Chuquicamata_Landsat mosaic dataset, right-click the Footprint layer, and choose Attribute Table.

    Attribute Table option

    Note:

    The Footprint layers, in bright green, indicates the extent occupied by each image.

    The attribute table appears.

    Attribute table

    There are five images (listed as Primary in the Category field) and four overviews. The five primary images are the actual Landsat imagery. Overviews are like raster pyramids for a mosaic dataset: they are reduced resolution overview images that are generated to improve the speed at which the mosaic is displayed.

    Note:

    Although there are only five primary images in the table, remember that each image is multispectral. This means that each image is made up of six spectral bands, and each band is actually a separate raster. The mosaic dataset template accounts for this by grouping all the bands that belong to a same image together. All of this work is done by raster functions behind the scenes.

    The ProductName field lists Surface Reflectance as the type of imagery information. If you scroll to the right on the attribute table, you will also see a field called Acquisition Date, which lists the date and time that the images were captured.

  23. Close the attribute table.
  24. In the Contents pane, right-click Chuquicamata_Landsat and select Properties. In the Source tab, explore the information that is available.

    Layer Properties window

    There are five sections containing information about the data source, the rasters, the bands, the band statistics, and the spatial reference.

  25. Click Cancel to close the Layer Properties.

Add multidimensional information to the mosaic dataset

You’ve created your mosaic dataset, but it is not yet a multidimensional mosaic dataset. Although it has time information (the Acquisition Date), multidimensional mosaic datasets require explicit information about the variables and dimensions contained in the dataset to become fully actionable. To do this, you’ll build multidimensional metadata for your mosaic dataset, declaring that the variable is the Surface Reflectance and the time dimension is the Acquisition Date.

  1. In the Geoprocessing pane, click the Back button.

    Geoprocessing Back button

  2. In the Geoprocessing pane, search for and open the Build Multidimensional Info tool.
  3. In the Build Multidimensional Info tool, choose the following parameter values:
    • For Mosaic Dataset, choose Chuquicamata_Landsat.
    • For Variable Field, choose ProductName.
    • Under Variable Info, for Variable Name, choose Surface Reflectance.
    • For Description, type Landsat surface reflectance.
    • Under Dimensions Fields, for Dimension Field, choose AcquisitionDate.
    • For Description, type Date of image acquisition.

    Build Multidimensional Info parameters

  4. Click Run.

    When the tool finishes running, there is no apparent modification to the mosaic dataset. You'll check its properties to observe the changes.

  5. In the Contents pane, right-click Chuquicamata_Landsat and select Properties.
  6. On the Source tab, note that there is now a new heading called Multidimensional Info . Expand the Multidimensional Infoheading.

    Notice that the variable Surface Reflectance and dimension StdTime have been added to the mosaic dataset.

    Multidimensional Info properties

    Note:

    Although you provided the Acquisition Date field as the dimension, it is listed as StdTime. That is because the Acquisition Date was recognized as a time and date field and is therefore accepted as a standard time value. This prevents multiple time dimensions from being added to a single multidimensional dataset.

    The mosaic dataset is now flagged as multidimensional, and you can use it in multidimensional analysis and management tools. Surface Reflectance (StdTime = 5) means that this multidimensional raster allows you to follow the evolution of the variable Surface Reflectance through five different time points.

  7. Click OK to close the properties window.

    You'll now explore the multidimensional raster slices.

  8. In the Contents pane, ensure that the Chuquicamata_Landsat layer is selected.
  9. On the ribbon, in the Mosaic Layer tab group, click the Multidimensional tab.

    Multidimensional tab

    Note:

    This tab is only available when the mosaic dataset is multidimensional.

  10. On the Multidimensional tab, in the Current Display Slice group, expand the StdTime drop-down list, and choose 2010-04-27.

    The drop-down list contains the five dates from 1990 to 2010. Each date corresponds to a slice of the multidimensional raster. You can choose any of them and observe the map update to that different slice.

    Current slice

  11. On the Multidimensional tab, in the Data Management group, click the Data Management button to see the tools available for management of the mosaic dataset.

    Data Management tools

  12. Save your project.

    Save button

You created a multidimensional mosaic dataset. The mosaic dataset is a data management solution for managing many rasters over space and time. In the next module, you'll convert the mosaic dataset to the powerful CRF format.


Work with a multidimensional CRF

In the previous module, you created a multidimensional mosaic dataset using five Landsat TM images. In this module, you will convert the mosaic dataset to the cloud raster format (CRF), and measure and visualize the changing Chuquicamata copper mine.

CRF is an Esri native file format that is optimized for storing both standard and multidimensional raster data for distributed computing. You can also transpose a multidimensional CRF dataset for faster temporal profiling, especially when working with many slices. All multidimensional analysis tools in ArcGIS Pro generate CRF outputs, and CRF offers more options for data management.

Convert mosaic dataset to CRF

In this section, you'll convert your mosaic dataset to CRF.

  1. In the Geoprocessing pane, if necessary, click the Back button. Search for and open the Copy Raster tool.
  2. In the Copy Raster tool, choose the following parameters values:
    • For Input Raster, choose the Chuquicamata_Landsat mosaic dataset.
    • For Output Raster Dataset, click Browse, double-click Folders, and click Chuquicamata mine.
    • For Name, type Chuquicamata_Landsat.crf.
    • For Format, verify that Cloud raster format is selected.
    • Check the Process as Multidimensional box.
    • Leave Build Multidimensional Transpose unchecked.
    Note:

    Building a multidimensional transpose modifies the storage structure in the CRF for faster processing when working with many slices. In this case, you have a small number of slices, so transposing it is not necessary.

    Copy Raster parameters

  3. Accept all other default values, and click Run.

    The new CRF is added to the map.

  4. Turn off the Chuquicamata_Landsat mosaic dataset layer, so that only the new Chuquicamata_Landsat.crf is visible.
  5. In the Contents pane, make sure the Chuquicamata_Landsat.crf layer is selected.
  6. On the ribbon, on the Multidimensional tab, in the Data Management group, click the Data Management button to see the tools available for the management of the CRF dataset.

    CRF data management

    There are now two additional options that were not available for the mosaic dataset. The Transpose tool allows you to build a multidimensional transpose, which improves the performance of the dataset when analyzing pixel values over a dimension. The Manage Multidimensional Raster tool allows you to append or delete variables and dimensions in an existing multidimensional raster. Both of these options are only available for CRF datasets.

Measure and visualize change

Now that your CRF multidimensional raster dataset is ready, you’ll measure how the Chuquicamata mine has grown between 1990 and 2010.

  1. On the ribbon, in the Map tab, in the Inquiry group, click the Locate button.

    The Locate pane appears.

  2. In the Locate pane, in the search box, enter 68.9004325°W 22.2880568°S, which are the longitude and latitude of the mine.
    Note:

    Alternatively, you could also search for the keyword Chuquicamata and choose the first result.

    Locate pane

  3. Close the Locate pane.
  4. Change the scale of the map to 1:50,000.

    Choose scale

    You can see the large surface copper mine. The image is displayed by default as a natural color composite display, where the red, green, and blue bands are displayed with the corresponding channels, so features in the image are rendered as the human eye would see them in real life.

    1990 layer with natural color

  5. In the Contents pane, make sure Chuquicamata_Landsat.crf is selected.
  6. On the ribbon, on the Multidimensional tab, in the Current Display Slice group, change the current StdTime value to 2010-04-27.

    2010 layer with natural color

    The layer updates on the map, and you can see that the mine has changed and expanded since 1990.

  7. In the Multidimensional tab, change StdTime back to 1990-02-15. Click the Play button next to StdTime.

    Play button

    The map updates with each slice in the multidimensional raster, creating an animation. You can see how the mine has changed over time.

  8. Click the Pause button to stop the animation. Set StdTime back to 1990-02-15 using the drop-down list.

    You'll now take an approximate measurement of the main mine pit.

  9. On the ribbon, on the Map tab, in the Inquiry group, click the Measure tool.

    Measure button

    The Measure Distance tool window appears.

  10. On the map, click the southern-most point of the main pit, and double-click the northern-most point to obtain a measurement.

    Measure mine pit in 1990

    In 1990, the main mine pit was approximately 3.5 km long.

  11. On the ribbon, on the Multidimensional tab, in the Current Display Slice group, change StdTime to 2010-04-27.
  12. Measure the length of the mine again.

    Measure mine pit in 2010

    The main mine pit is now over 4 km long. If you observe the larger area of the mine, you'll notice that several secondary pits have also appeared or expanded between 1990 and 2010.

  13. Close the Measure Distance tool.
  14. Set StdTime back to 1990.
  15. Save your project.

In this module, you created a multidimensional raster layer in Esri’s native multidimensional format and observed through visual inspection and measurement that the Chuquicamata copper mine had expanded over time. But multispectral imagery contains more than just what meets the eye. In the next module, you will extract additional information using a different band combination and a band ratio.


Enhance spectral information

In this module, you'll use the multispectral bands of your dataset to better visualize the change in the Chuquicamata copper mine.

Explore spectral information

First, you'll use a different band combination and look at the spectral profile of different points on the map. For now, the imagery is displayed as a Natural Color composite, using the bands red, green, and blue. However, using different bands can allow you to enhance the information displayed in your imagery, as different segments of the electromagnetic spectrum can emphasize different features. You'll choose a band combination that includes the short-wave infrared bands.

  1. In the Contents pane, for the Chuquicamata_Landsat.crf layer, right-click the Red channel and select Short-wave Infrared 1.
  2. Similarly, change the Green channel to the Red band, and the Blue channel to the Short-wave Infrared 2 band.

    Change band combination

    The layer updates in the map.

    Imagery with SWIR band combination

    Clay and carbonate minerals are often found in porphyry copper deposits around mines. These types of minerals show strong absorption around 2.2μm, which would be captured in the Short-wave Infrared 2 band of Landsat TM data, and strong reflectance in the wavelengths captured in the Short-wave Infrared 1 band. In the RGB composite you created, areas in light pink mean that there is stronger reflectance in the Short-wave Infrared 1 band, indicating the presence of clay or carbonate minerals. These brighter pixels may represent areas where copper tailings were deposited.

    To explore this further, you will use the Image Information pane to see spectral reflectance information as you move your pointer over the image.

  3. On the ribbon, on the Imagery tab, in the Tools group, click Image Information.

    Image Information button

    The Image Information pane opens. The default setting in the Point of Interest section is the Track Cursor option, which allows you to move your pointer over the image in your map to see the spectral reflectance for each band, for the pixel under your pointer. This is also called the spectral profile for the pixel.

  4. Move your pointer over the image in your map and notice the spectral profile for each pixel you point to in the Image Information pane.

    Spectral profile in Image Information pane

    Note that the reflectance is highest in short-wave infrared band 1 (displayed in red) in the light pink areas in the image, while reflectance for these bands is generally low in the dark purple areas in the image. The Image Information pane also provides information about the pixel row and column value (Image (X, Y)), the coordinate of the pixel (Decimal), and the source information (Source). The bands that are currently displayed with the red, green, and blue channels are also indicated in the spectral chart.

  5. On the ribbon, on the Multidimensional tab, in the Current Display Slice group, use the StdTime drop-down list to click through the slices in the multidimensional raster layer. Observe how the mine is rendered for the different dates.

    The power of multidimensional rasters is that the band combination chosen was applied to all the slices in one go.

Calculate a band ratio

You’ll now generate an Iron Oxide band ratio to visualize additional information.

Note:

A band ratio (or index) combines different spectral bands through a mathematical formula. The resulting output is a new raster. Different band ratios are meant to highlight different types of features and phenomena.

The Iron Oxide ratio has been used to identify hydrothermal alteration minerals associated with copper mineralization (Pour & Hashim, 2014). The Iron Oxide band ratio uses spectral reflectance information from the red and blue portions of the electromagnetic spectrum because iron oxides or hydroxides have high reflectance at 0.63-0.69μm (Red band) and high absorption at 0.45-0.52μm (Blue band).

You’ll apply this Iron Oxide ratio and determine whether it helps you better distinguish the changes in the Chuquicamata mine. To generate the Iron Oxide band ratio, you'll perform the calculation using a raster function, which applies calculations directly to a raster's pixel values without requiring new data to be saved.

  1. On the ribbon, on the Imagery tab, in the Analysis group, click the Raster Functions button.

    Raster Functions button

    The Raster Functions pane appears. To calculate the band ratio, you’ll use the Band Arithmetic function.

  2. In the search box, type band. In the list of results, under Math, click Band Arithmetic.

    Band Arithmetic button

    Like geoprocessing tools, raster functions require input parameters.

  3. In the Band Arithmetic Properties pane, for Raster, choose Chuquicamata_Landsat.crf. For Method, choose Iron Oxide.

    Band indexes parameter

    For Band Indexes, a hint appears showing the equation for the Iron Oxide band ratio and the bands that are required. The tool knows the Iron Oxide ratio formula, but you need to tell it on which of your imagery's bands to apply it.

  4. For Band Indexes, type 3 1.

    Band index 3 represents the red band, and band index 1 is for the blue band. Separate them by a space.

    Band arithmetic tool

  5. Click Create new layer.

    The new multidimensional layer is added to the map.

    Iron oxide index layer

    You'll enhance the appearance with DRA.

  6. On the Appearance tab, in the Rendering group, click DRA.

    DRA button

    DRA stands for dynamic range adjustment. It makes the layer rendering stretch dynamically to improve the contrast and allow you to better visualize the results.

  7. On the ribbon, on the Multidimensional tab, in the Current Display Slice group, use the StdTime drop-down list to click through the slices in the multidimensional raster layer.

    All slices have the Iron Oxide band ratio applied, as well as the DRA stretch.

  8. In the Contents pane, click the layer name Band Arithmetic_Chuquicamata_Landsat.crf two times and rename it to Iron Oxide.

    Iron Oxide index layer with DRA

    What other features can be distinguished using this band ratio?

In this lesson, you created a multidimensional mosaic dataset using Landsat TM imagery, converted it to Cloud Raster Format, and observed the change over time in the Chuquicamata copper mine. You also changed the band combination and generated a band ratio to further visualize the changes.