Create a map layout

The maps for this lesson are already symbolized and labeled, using data from the 2011 government census. You'll create a layout and fill it with the two maps, a chart, a title, legends, and text.

Insert a layout and a map frame

In ArcGIS Pro, layout design is done in a layout view, separate from the map view where analysis and symbology take place. You'll add a new layout to your project and add the map to it. You'll also set up guides to help you with the placement of maps and other elements.

  1. Download the IndiaLanguages zip file and unzip it to a location on your computer, for example, your C:\ drive.
  2. Open the unzipped IndiaLanguages folder and double-click IndiaLanguages.aprx to open the project in ArcGIS Pro.

    IndiaLanguages.aprx in File Explorer in Windows

  3. If prompted, sign in to your ArcGIS account.
    Note:

    If you don't have ArcGIS Pro or an ArcGIS account, you can sign up for an ArcGIS free trial.

    The Scheduled languages map is active.

    Map of languages in India

    India does not have a national language, but there are 22 languages recognized by the Eighth Schedule to the Constitution of India, which the government has committed to supporting and promoting. This map shows where each of the "scheduled" languages are spoken as a mother tongue. The opacity of the color indicates the percentage of speakers. For example, if a district has a 50 percent transparent purple color, half of the people there speak Telugu as their mother tongue.

    Note:

    The census defines mother tongue as "the language spoken in childhood by the person's mother to the person." In the absence of a mother, the main language spoken in the childhood home is listed as the mother tongue.

  4. On the ribbon, click the Insert tab. In the Project group, click New Layout. In the ISO - Portrait group, click A3.

    Portrait A3 page size

    ISO is a standard of paper sizes used in most of the world, while ANSI is a standard primarily used in North America.

    It's important to consider where and how your map will be displayed when you choose a layout size. Designing in the wrong size may result in text that is too small to read, and designing in the wrong ratio may result in information being cropped off. Your primary goal for this map is to print it as a poster, but you also intend to display it on a website. Portrait layouts are slightly better suited for the web, since they behave well with vertical scrolling.

    You now have a blank page. You'll set up some guides to make sure you keep an even white margin around the edges of your map.

  5. Right-click the ruler surrounding the layout view and choose Add Guides.

    Add Guides

  6. In the Add Guides window, change the following parameters:
    • For Orientation, choose Both.
    • For Placement, choose Offset from edge.
    • For Margin, type 10 mm.

    Add Guides window

  7. Click OK.

    Thin blue lines now mark a margin area around your map. Avoid placing any information outside of these lines so that it is not cut off during printing.

  8. Below the layout view, ensure that the Snapping button is highlighted, indicating that snapping is on.

    Snapping is on.

  9. On the ribbon, in the Map Frames group, click Map Frame. Under Scheduled Languages, click Default Extent.
  10. On the layout, click and drag between opposite corners of the guides.

    Dragging between opposite corners of the layout guide to insert the map

    The map of India appears in the center of the page. You'll adjust its size and placement later, when you've added more items to the page.

  11. On the Quick Access Toolbar, click Save to save the project.

    Save button on the Quick Access Toolbar

Add a title and description

The map is the most important, and therefore largest, element in your layout. Next, you'll add a title and other text to give the map context. You'll also define a default text symbol so you only have to change the font and color once.

  1. On the ribbon, on the Insert tab, in the Graphics and Text group, click the Straight text button.

    Straight text button

    Straight text changes the size of the font when resized, making it a good choice for titles.

  2. Zoom in on the layout view. Click anywhere on the layout and type Languages of India.
    Tip:

    To pan on the layout, use the wheel button of your mouse or press and hold the 1 key.

    You'll change the font to match the one used by the map's labels. Using more than one or two fonts on a map can create a cluttered and confusing design.

  3. Select the text on the layout. On the ribbon, click the Format tab. In the Text Symbol group, change the font to Century Gothic. Change the color to Gray 60%.

    Font name and color

    Using dark gray instead of black gives text slightly less contrast—and therefore less visual importance—without compromising its legibility.

    You'll have to add many pieces of text to the layout before it is done. You'll set up a default text symbol so you don't have to change the font and color every time.

  4. On the layout, right-click Languages of India and choose Save to Style. In the Save Text Symbol As window, for Name, type LayoutDefault and click OK.

    Save Text Symbol As window

  5. On the ribbon, click the Project tab. Click Options, and in the Options window, click Text and Graphics.

    Text and Graphics tab in the Options window

  6. Under Default Graphic Element Symbols, click the Text symbol.

    Default text symbol

  7. In the Default Text Symbol window, under Favorites, click LayoutDefault and click OK.
  8. Change the Text size to 8 pt.

    Text symbol changed to 8 pt.

    This is a reasonable size for most of the text you'll add to the layout later. You'll also change the default style of the line symbol, since you'll be adding lines later to connect text blocks to parts of the map.

  9. Click the Line symbol. Search for and choose the Marker Only symbol and click OK.

    Updated line symbol

    Tip:

    If the Marker Only symbol is not available, choose a gray dashed line such as Boundary or Dashed 4:4.

  10. Click OK and click the Back button to return to the layout.
  11. On the ribbon, click the Layout tab. In the Navigate group, click the Full Extent button to zoom out to the entire layout.

    Full extent button on the ribbon

  12. On the ribbon, click the Insert tab. In the Graphics and Text group, click Rectangle text and drag a box anywhere on the layout.

    Rectangle text is preferable when there is more than one line of text, since resizing will resize the box and not the letters.

  13. Copy and paste the following text into the new text box:

    How many languages are spoken in India?

    The Census of India 2011 names 273 languages. Other sources list up to 780. The difference between counts is explained by the difficulty in defining a language versus a dialect.

    What is the national language?

    India has no national language, but 22 languages are named in the Eighth Schedule to the Constitution of India. The status of scheduled obligates the government to promote these languages.

    This map shows where each of the scheduled languages is spoken as a mother tongue, according to the 2011 census.

    What is the official language?

    Each state or territory can name its own official languages. The official language of India is Hindi in Devanagari script, but English may also be used for official purposes. This use of English was tentatively planned to end in 1965, but the change was met with resistance from parts of the country that did not speak Hindi natively.

  14. Drag any corner of the text box to resize it until all of the text is visible.

    Rectangle text is useful for multiline text, since the text will wrap to fit the available space. A red ellipse symbol appears in the lower-right corner of the text box if it is not big enough to fit all of the content.

  15. Highlight the text How many languages are spoken in India? and on the ribbon, click the Format tab. In the Text Symbol group, change the text style to Bold.

    Change text to bold on the Format tab of the ribbon.

  16. Also bold What is the national language? and What is the official language?. Remove the empty line after all three headers.
  17. Make the text This map bold as well.

    Formatted text

Create a legend

There are many layers in this map, so a legend may be very long. When a legend lists more than five colors, it can become difficult to read. In this case, it is difficult to distinguish between the different green symbols for Manipuri, Sindhi, Santali, and Punjabi. Fortunately, each language is clearly labeled on the map, with the same color as the map symbols, so they don't need to be listed again in a legend. It is often easier to explain map features with labels instead of a legend.

However, labels alone are not enough to explain this map's symbology. You'll build a custom legend with text and graphics to explain what phenomenon is being mapped, by what measurement, and within what boundaries. You'll also explain why some of the colors are more transparent than others.

  1. On the ribbon, in the Graphics and Text group, click the Rectangle button. Drag to draw a tall rectangle.

    Rectangle button and new rectangle drawn on the layout.

    The Format Polygon pane appears. Here, you can change the properties of the new graphic.

  2. In the Format Polygon pane, click the Symbol tab and click the Layers tab.

    Symbol tab and Layers tab

  3. Click the Solid stroke symbol layer. Under Appearance, change the Color to Gray 60% and the Width to 0.5 pt.

    Symbol properties for the stroke symbol layer

  4. For the second symbol layer, change Solid fill to Gradient fill. Click the first color and click Eyedropper.

    Eyedropper tool

    If a message appears asking if you want to apply uncommitted symbol formatting, click Yes.

  5. On the map, zoom to one of the language labels and click it.

    Eyedropper tool gathering color from the Hindi label

    The map symbols include varying transparencies, while the labels use the fully opaque versions of the colors.

  6. Change the second color to match the first one. Click the second color again and change it to No color.

    Changing the second gradient fill color from yellow to no color

    Now the color of the rectangle will range smoothly from a fully opaque color to a fully transparent version of itself, just like the symbols on the map.

  7. Expand Pattern and change the following parameters:
    • For Direction, choose Linear.
    • For Angle, choose 270°.
    • For Type, choose Continuous.
  8. Click Apply.

    Symbol properties for the rectangle

    Next, you'll add labels to describe the new legend item.

  9. On the ribbon, on the Insert tab, in the Graphics and Text group, click Rectangle text. Add the new text above the rectangle and type the following:

    Districts of India

    Percent of the population that speaks this language as their mother tongue:

  10. Make the first line (Districts of India) bold and remove the empty space between it and the next line.
  11. Resize the Districts of India text box so the text takes up four lines.

    The text was made with rectangle text, so the font size does not change when the box is resized.

    Formatted text for the legend

  12. Add Straight text above the transparent end of the rectangle and type 0%.
  13. Add more Straight text below the opaque end of the rectangle and type 100%.

    This custom legend combines text and graphics to explain which phenomenon is being mapped (mother tongue languages), by what measurement (percent of the population), and within what boundary (districts). It also explains the relative opacity of each color. However, there are some districts on the map with a hatched gray line instead of a color. These also need to be explained.

  14. In the Contents pane, under Map Frame, click the No data layer to select it.
  15. On the ribbon, click the Insert tab. In the Map Surrounds group, click Legend and draw a box on the layout, below the 100% text.

    A legend appears, with only one legend item, since you had only one layer selected.

    No data legend added below the custom legend.

    There are a few other layers in your map, but they do not need to be explained, so you won't add them to your legend.

Align, distribute, and group legend items

Next, you'll use layout tools to arrange all of the legend elements together into a tidy group.

  1. Move the legend items to arrange them vertically in the following order:
    • Districts of India
    • 0%
    • Rectangle
    • 100%
    • No data
  2. Hold the Shift key and click all five legend items to select them all at once. Right-click, point to Align, and click Align Left.

    Align Left

  3. Right-click again, point to Distribute, and click Distribute Vertically.

    Now the elements are evenly spaced.

  4. Right-click again and click Group.
  5. In the Contents pane, click Group Element twice and rename the layer Legend Group.

    Legend Group in the Contents pane

Add a second map and legend

Often one map is not enough to tell the story of your data. In this map, the areas of greatest linguistic diversity are not very obvious, since they are not dominated by any one language, so they appear gray or white. You'll add a second map to tell this part of the story.

  1. On the ribbon, on the Insert tab, in the Map Frame group, click Map Frame. Under Language density, click Default Extent.
  2. Drag a box anywhere on the layout to add the second map.

    This map emphasizes regions with more mother tongue languages in darker colors.

    Layout with two maps

    Note:

    Your layout may look different than the example shown above. The positions and sizes of the elements will be refined later in the lesson

  3. With the new map selected, add a legend to the layout.

    New legend for new map

    This legend contains some information that can be removed.

  4. In the Contents pane, expand Legend 1. Right-click India and choose Remove.

    This symbol is only used for an outline around the country and does not need to be explained. You'll also remove the legend headings and replace them with custom text, which can be rearranged more flexibly on the page.

  5. Right-click Legend 1 and choose Properties. In the Format Legend pane, under Legend Items, click Show properties.

    Show properties button

  6. Under Show, uncheck Layer name and Headings.

    Unselected legend items

    Since this map will be smaller than the other one, you'd like to make the legend smaller as well. However, you don't want to make the text any smaller because it would be difficult to read. You'll condense the legend instead, removing unnecessary space.

  7. Under Sizing, change Patch width to 12 pt.

    The legend patches change from rectangles to squares.

    Legend with square legend patches

  8. Click the back arrow and click the Legend Arrangement Options tab.

    Legend Arrangement Options tab

  9. Expand Spacing. For Categories and Classes, change the Value to 0 pt.

    Spacing settings

    On the layout, the gaps between the legend rows disappear. The text "<excluded>" on the legend is not explained. You'll edit this next.

  10. In the Contents pane, under Map Frame 1, right-click India Languages and choose Symbology.

    Open Symbology for the India Languages layer.

  11. In the Symbology pane, in the Classes table, in the Label column, change the <excluded> text to No data.

    The symbol classes can also be improved. They are not very difficult to read, but they would be slightly easier if the classes were rounded. This time you'll edit the Upper value instead of the Label, so the map symbology is also updated, not just the labels.

  12. In the Upper value column, make the following edits:
    • Change 6 to 5.
    • Change 13 to 10.
    • Change 23 to 20.

    You won't change the last class because you want it to be clear to map readers that the largest count of mother tongue languages in any district is 44.

    Upper values of symbology classes

  13. Close the Symbology pane.

    To finish the legend, you'll add text to replace the headers that you removed.

  14. Above the legend, add Rectangle text and type Number of languages spoken as mother tongue:. Make the text bold.

    You'll align and group these legend elements later, when you determine the final placement of all elements together. For now, you'll remove the border for the map frame. Borders around maps and other elements are rarely necessary.

  15. Right-click the map frame and choose Properties. In the Format Map Frame pane, click the Display tab and under Border, change the Symbol size to 0 pt.

    Map frame border symbol properties

  16. Remove the border from the other map frame as well. Close the Format Map Frame pane.

Add a chart

The story still isn't complete. You've now indicated the geographic spread of the languages, and the linguistic diversity of each district. But this map doesn't tell you how many people speak each language. It also doesn't show two of the scheduled languages because they are not spoken by a majority of people in any district. Sometimes a map isn't the best tool for conveying your data, and a chart or other graphic will serve better. You'll make a chart to supplement your map.

  1. In the Contents pane, under Map Frame, expand the Scheduled languages map.
  2. Right-click LanguageTotals and choose Attribute Table.

    Attribute table showing number of mother tongue speakers for each language

    This data is also from the 2011 census. It lists the total number of people who claimed each language as their mother tongue. You'll build a bar chart from this table.

  3. Close the attribute table. Right-click LanguageTotals, point to Create Chart, and choose Bar Chart.

    Create bar chart from the LanguageTotals layer.

  4. In the Chart Properties pane, set the following properties: .
    • For Category or Date, choose Language.
    • For Numeric field(s), click Select, choose MotherTongueSpeakers, and click Apply.
    • Under Data Labels, check Label bars.
    • For Sort, choose Y-axis Ascending.

    Chart properties

    The chart would be easier to read if the language names and data labels were horizontal.

  5. On the chart view toolbar, click Rotate Chart.

    Rotate Chart button

    Now the largest bar sits on the bottom and all of the labels are visible. You'll simplify the labels as well to make them easier to read.

  6. In the Chart Properties pane, click the Axes tab. Under Number format, click the edit button and change the following properties:
    • For Category, choose Rate.
    • For Factor, choose 1000000.
    • For Decimal places, type 1.

    Number format properties

  7. Click Apply.

    The data labels are now expressed in millions.

    Bar chart with data values expressed in millions

  8. On the Chart Properties tab, click the General tab. Uncheck all items.

    You'll add text later directly to the layout to explain the chart, which will allow you to position it more freely.

  9. Click the Format tab and click the Text elements tab.

    Format tab and Text elements tab

  10. Click All Text and change the following properties:
    • Change Font to Century Gothic.
    • Change Font Size to 8 pt.
    • Change Color to Gray 60%.

    All Text font properties

    You'll remove any extra markings from the chart, as well as its background so it does not hide other objects on the layout.

  11. Click the Symbol elements tab. For Background, Grid Lines, and X-Axis Line, change the Color to No color.

    Symbol elements set to No color.

  12. Close the chart view and the Chart Properties pane.
  13. On the ribbon, on the Insert tab, in the Map Surrounds group, click the bottom half of the Chart Frame button and choose the only available chart. Drag a rectangle anywhere on the layout to add the chart.

    The new chart frame appears empty. That is because the layer it is made from is not visible on the map.

  14. Right-click the chart frame and choose Properties. In the Format Chart Frame pane, click the Options tab.
  15. Under Content, uncheck Only show chart data visible in the map frame.

    Only show chart data visible in the map frame check box

    The chart appears on the layout.

    Chart on layout

    The data for the chart is stored in a feature layer that is invisible on the map. It could have been stored in a stand-alone table instead, but using a spatial layer provides an advantage: the chart's colors can match those of the map. Next, you'll change the symbology of the feature layer to control the symbology of the chart.

  16. In the Contents pane, under Map Frame, select LanguageTotals. On the ribbon, click the Appearance tab. In the Drawing group, click Import.

    Import button

  17. In the Import Symbology window, for Symbology Layer, click Browse. From the project folder, choose LanguageTotals.lyrx. Click OK.
  18. In the Import Symbology window, click OK.

    Each bar in the chart now has a different color, matching the colors of the map.

    Chart on layout with multiple colors

  19. Save the project.

You've now added two maps, two legends, a title, some text, and a bar chart to your layout. You learned how to format text and legends, create custom legends, set up guides, and build charts. Next, you'll position and size everything into a pleasing arrangement.


Balance a layout

When you create a layout, it's smart to wait until you have most of the items on the page before arranging them. Deciding on the size and placement of the title, for example, is hard to do when you don't yet know the size and placement of the map.

Next, you'll arrange the layout with consideration for the visual hierarchy of the page. Items that are larger, have bolder colors, greater contrast with the background, or greater detail, will be noticed first and given the most attention by map readers. You'll arrange the layout to promote more important elements to the foreground and push less important ones to the background.

Arrange layout items

The most important element of a map layout is usually a map. In this case, it is the primary map showing the geographic spread of each of the scheduled languages. You'll position it first and arrange the other elements around it.

  1. In the Contents pane, click Map Frame. Below the layout view, change the scale to 1:12,000,000.

    Map frame scale

  2. Right-click the map frame and choose Activate.

    Now you can navigate and interact with the map.

  3. Pan the map to position it slightly higher than the middle of the page. Make sure neither the map nor its labels are cut off.
    Tip:

    If you need to pan or zoom on the layout instead of the map, press and hold the 1 key.

    If you accidentally pan or zoom the map out of position, click the Map tab on the ribbon. In the Navigate group, click the Previous Extent button.

    Previous Extent button

  4. At the top of the layout view, click the Back to Layout button.

    Back to Layout button

  5. Position the Legend Group to the left of the Kashmiri, Dogri, and Punjabi labels.
  6. Select the smaller map and change the scale to 1:34,000,000. If necessary, resize the frame until you can see all of India.
  7. Position the smaller map near the bottom of the page, between southern India and the Nicobar Islands.
    Tip:

    If you find it difficult to position an element precisely, hold the spacebar key to temporarily turn off snapping.

  8. Position the legend and text for the smaller map next to its east coast. When you are happy with their arrangement, select all three items and group them together.

    Map, legend, and text selected on the layout.

  9. In the Contents pane, rename the new group element Language Density Map.
  10. Resize the chart frame so it fills the width of the layout. Snap it to the bottom and side guides.
  11. Resize the chart frame vertically so it ends just below the Malayalam label on the primary map.

    Chart at the bottom of the layout

    The chart should be big enough that the labels are not crowded, but small enough that it does not appear more important than the map.

  12. In the Contents pane, next to Chart Frame, click the lock button.

    Locking the chart frame will prevent you from selecting or moving the chart on the layout, making it easier to manipulate other, smaller elements on top.

  13. Lock and collapse Map Frame.

    Chart Frame and Map Frame locked in the Contents pane.

  14. On the layout, click the title text. Drag its edges to resize the title so it fills most of the width of the layout and snaps to the top guide.

    The title was made with straight text, so the font size changes when the box is resized.

  15. Make the text bold.
  16. Select the text block and position it under the right side of the title.

    Layout with title and text block positioned

Add text

There is still a lot of empty space on the layout. There is no need to fill all of the empty space on a page, rather it is important to balance the layout's visual elements with negative space. But in this case, you do have some more contextual information you'd like to share as part of this map. Now that you've included all of the essential elements, you can see what nonessential information can be included without overwhelming the design.

  1. On the ribbon, on the Insert tab, in the Graphics and Text group, click Circle text.

    Circle text button

  2. On the layout, on the white space under the title, click and drag to draw a circle.

    Empty circle text

  3. Copy and paste the following text:

    Shajapur is the only district in India with only one mother tongue language: Hindi.

    The census defines mother tongue as "the language spoken in childhood by the person's mother to the person." In the absence of a mother, the main language spoken in the childhood home is listed as the mother tongue.

    The text is confined to the shape of the circle.

  4. Select the text block. On the ribbon, on the Format tab, in the Text Symbol group, click the full-justify Font Alignment button.

    Full-justify text alignment

    The text now hugs the edges of the circle and emphasizes its shape.

  5. Drag the edges of the text to make the circle just large enough to contain all of the text.
  6. Copy and paste the text circle to make three copies. Move each one aside and replace the text inside each with the following:
    • Dimapur records 44 mother tongue languages, the most of any district. The language category with the largest share is Other, a category that includes any language with fewer than 10,000 speakers.

      Mountainous terrain and river density are high predictors of language diversity, much as they are for biodiversity. So it is unsurprising that the northeast, dominated by the Himalayas and the Brahmaputra, is India's most linguistically diverse region.

    • Urdu is spoken by more than 50 million people in India, but is difficult to see on this map, since no district has a dense concentration of this language. Hyderabad is the district reporting the highest rate of Urdu as a mother tongue, at 43.2 percent.

      Urdu and Hindi are both standard registers of the Hindustani language and are similar enough that speakers of the two languages can understand one another. Hindi is usually written in the Devanagari script, and Urdu in the Perso-Arabic script. Urdu is mostly spoken by Muslims and Hindi by Hindus.

    • 24,821 people returned Sanskrit as their mother tongue in the 2011 census. However, it is debated whether anyone truly speaks Sanskrit as a first language.

      Sanskrit is one of the earliest ancient documented languages in the world, and many of the languages spoken in India today are derived from it.

  7. Resize each of the text circles to fit their content.
  8. Place the text about Hyderabad above the smaller map. Place the text about Sanskrit below the larger map. Place the text about Dimapur above the Andaman Islands.

    Circle text placement

    Rectangular blocks of text look nice when they are neatly aligned with one another, but that is difficult to achieve with this layout. The circles float more freely on the page and don't seem inconsistent despite having different sizes. However, they also give the map a light tone, so they may not be appropriate for a more serious or somber map. You'll give the circles pale backgrounds to help ground them.

  9. Select all four circles and the rectangle text. Right-click any of them and choose Properties.
  10. In the Format Text pane, click the Display tab. Under Background, change the Symbol color to Gray 10%.

    Text background symbol set to gray.

    The color is pale, but it could be even paler. The text blocks should be very low on the visual hierarchy and not compete with the maps.

  11. Click the color again and click Color Properties.
  12. For Color Mode, choose Grayscale. Change Gray to 240.

    Grayscale color mode

    You'll also save this color so you can use it again later.

  13. Click Save color to style. For Name, type Gray 5%. Click OK.
  14. Click OK again.
  15. In the Format Text pane, under Background, change both the X gap and the Y gap to 2 mm.

    X gap and Y gap set to 2 mm.

    You'll add a similar gray background to the title.

  16. Draw a rectangle over the title text. Snap it to the top and side guides.
  17. In the Format Polygon pane, click the Symbol tab and change Color to Gray 5%.

    Gray color in Favorites style

  18. Change the Outline width to 0 pt and click Apply.

    You'll move the rectangle underneath the title so it doesn't hide it.

  19. On the layout, right-click the gray rectangle. Point to Order and choose Send To Back.

    Send rectangle to back.

    The rectangle now appears behind the title text. In the Contents pane, it has moved to the bottom of the layer list.

    Rectangle 1 at the bottom of the Drawing Order list

  20. Adjust all of the items on the layout until you are happy with their arrangement.

    Layout with all elements arranged

Connect the text to the map with lines

The paragraphs of text you added help to bring the data to life, but they will be more meaningful if they are tied to the geography. You'll draw lines from the text to the regions that they refer to.

  1. On the ribbon, on the Insert tab, in the Graphics and Text group, click Line.

    Line button

  2. Draw a line from the circle around Hyderabad to the circle text about Urdu. Double-click to finish the line.

    Line from Hyderabad to text circle

    The line has a dotted pattern because you changed the default line symbol earlier in the lesson.

  3. Draw a line from the circle in central India to the text about Shajapur.
  4. Select the newest line, and on the ribbon, click the Format tab. In the Edit group, click Edit Vertices.

    Edit Vertices on the Format tab of the ribbon

  5. Right-click the middle of the line and choose Add Vertex. Drag the new vertex to the southeast to form a right-angle corner in the line. Adjust the end vertices as well if needed.

    Adding a vertex to a line to make a right-angle corner

  6. Switch to the Line tool and draw a line from the circle in northeast India to the text about Dimapur. Adjust its vertices so it extends to the right and then downward, cutting through the Manipuri label.

    Line from Dimapur district to text circle

    The last circle text block has no geographic feature to point to. You'll connect it to the chart instead.

  7. Draw a line from the text about Sanskrit to the top bar in the bar chart.

    Next, you'll add a circle like the ones on the map.

  8. In the Graphics and Text group, click the Point button and add a point to the layout above the chart.
  9. In the Format Point pane, click the Symbol tab and change the following properties:
    • Change Color to No color.
    • Change Size to 17 pt.
    • Change Outline width to 2 pt.
  10. Click Apply.

    Now the point symbol looks the same as the others on the map.

  11. Position the new circle over the top bar and label of the chart. Edit the vertices of the line to form two right angles.

    Line from Sanskrit bar to text circle

    One of the lines passes through a map label (Manipuri). The label is still legible, but it can have a cleaner appearance. You'll place the line behind the label and create a mask to prevent any visual interference.

  12. Select the line and the circle text about Dimapur. Right-click, point to Order and choose Send To Back.

    Next, you'll add a white halo to the Manipuri label. You'll activate the map to make this change.

  13. In the Contents pane, right-click Map Frame and choose Activate.
  14. On the ribbon, on the Edit tab, in the Selection group, click the Select button.
  15. On the map, click the Manipuri label. On the ribbon, click the Attributes button to open the Attributes pane.

    Attributes button and the Manipuri label selected.

    The language labels are actually annotation features, which can be individually edited and positioned. The properties of annotation features are stored as attributes.

    Note:

    To learn more about annotation, including how to create and edit it, see Pro Map Text II: Annotation.

  16. In the Attributes pane, click Symbol to access more symbol properties.

    Symbol button

  17. Click the Properties tab and expand Halo. For Halo symbol, choose White fill.

    White halo symbol properties

  18. Change the Halo size to 3 pt and click Apply twice.
  19. On the ribbon, in the Selection group, click the Clear button to clear the selection.
  20. Click the Edit tab. In the Manage Edits group, click Save and click Yes.

    The dotted line now passes behind the label without interfering with it.

    Manipuri label with white halo

  21. Above the map, click the Back to Layout button to deactivate the map frame.

    Back to Layout button

Review the layout

Before you decide that a map layout is complete, it's important to pause and assess what you have made. You'll ask a series of questions to help you finish the layout.

  1. Zoom out until you can see the entire layout. Right-click the ruler and uncheck Guides.

    What is the visual hierarchy? Which part of the layout draws your eye first, second, and third?

    Nearly complete layout

    In this case, the map of scheduled languages draws the eye first. Next is the smaller map, title, and chart. Third are the text blocks, and fourth are the legends. This hierarchy is appropriate for your design and doesn't need to be adjusted.

    Should anything be removed? Sometimes, information that is interesting can distract from information that is important. In this case, you already removed all extra information from the legends and were careful not to crowd the design with too many text blocks. However, you were not able to remove the labels from the x-axis of the chart.

    X-axis of the chart

    These labels are redundant with the labels at the end of each bar. You'll hide them behind a white rectangle.

  2. Add a rectangle to the layout. Resize it so it covers all of the ticks and labels of the chart's x-axis.
  3. Change the Color of the rectangle to white and the Outline width to 0 pt.

    Symbol properties for the rectangle

    Are the maps adequately explained? Yes, the legends convey just enough information.

    Is the chart adequately explained? It is clear from the rest of the layout that the bars of the chart represent languages, but there is no explanation for their length. You'll add text to the x-axis of the chart.

  4. Add straight text below the chart, on top of the new white rectangle. Type Millions of speakers by mother tongue and change the font to bold.

    Bold text beneath the chart

    Do you need credit text to describe where the data came from? Yes. This information should always be included.

  5. Add rectangle text to the lower-right corner of the layout. Copy and paste the following text:

    Language data:

    2011 Census of India, via ArcGIS Living Atlas of the World

    Country border:

    National Geographic Society, via ArcGIS Living Atlas of the World

    This map was made by following the Learn ArcGIS lesson Design a layout for a thematic map in ArcGIS Pro by Your Name, 2021.

  6. Highlight the Language data: text and make it bold. Also bold the Country border: text.

    This small change acts like bookmarks in the text block, making it easier to read.

  7. Replace Your Name with your name and replace 2021 with the current year.
  8. Change the text size to 6 pt.

    You won't add a grey background to this text block. Credit text is typically assigned the lowest position in a layout's visual hierarchy. It should be the last thing that draws your eye.

    Credit text

    Do you need a north arrow? Only if north is not at the top of the map. Do you need a scale bar? Only if distance measurements are relevant to your map's theme. Do you need a locator map? Only if you think your audience may be unfamiliar with the mapped location. None of these elements are necessary for this map.

    Are there any inconsistencies in the design? The fonts and colors are consistent throughout. However, some of your text is left-justified and some is full-justified.

  9. Select the credit text at the bottom of the layout and the rectangle text at the top.
  10. On the ribbon, on the Format tab, in the Text Symbol group, click the full-justify Font Alignment button.

    Full-justify font alignment button

    One of the legends you made has square patches, and the other has rectangular ones. You'll adjust the legend for the larger map to match the smaller one.

  11. In the Contents pane, expand Legend Group and expand Legend. Right-click No data and choose Properties.

    Properties button in the context menu for No data

  12. In the Format Legend Item pane, under Sizing, change Patch width to 12 pt.

    Legend patch width setting

  13. Make any final adjustments that you want and save the project.

Export the layout

You'll export the layout to a .pdf file, which is a good way to share it with printers or online.

  1. On the ribbon, click the Share tab. In the Output group, click Export Layout.

    Export Layout button

  2. In the Export Layout pane, for File Type, choose PDF.
  3. For Name, click the Browse button. Choose a location that you can easily access and name the file IndiaLanguages.pdf. Click Save.
  4. Do not check Clip to graphics extent.

    This option will remove the white margins.

  5. Check Output as image.

    This option will convert all of your vector text and graphics to raster images. This will make your image less crisp, but it will also reduce the file size. Because this map has many layers that overlap with transparency, reducing the file size is important.

  6. Leave the other parameters at their default settings.

    The standard resolution for print graphics is 300 DPI (dots per inch).

    Export PDF settings

  7. Click Export.

    Final layout

    Finally, you'll undo the default graphic element symbols that you defined for this project.

  8. On the ribbon, click the Project tab. Click Options, and in the Options window, click Text and Graphics.
  9. Click Reset to Defaults and click OK. Close ArcGIS Pro.

In this lesson, you made a layout that combines two maps, a chart, legends, and text. You learned how to do the following:

  • Create a layout with guides and map frames.
  • Add and style legends, charts, and layout text.
  • Change the project's default text and graphics symbols.
  • Align, distribute, and group layout items.
  • Reorder and rename legend items.
  • Create and edit custom graphics.
  • Export a layout to a .pdf file.

You also learned how to design and assess a layout with consideration for visual hierarchy. You removed elements that were not necessary, replaced those that were not clear, and restyled those that were less important so they were also less visually dominant.

Good design requires iteration and experimentation. Several versions of this layout were designed before one was chosen for this lesson. You are encouraged to make a copy of this layout in the Catalog pane and create your own design. You may, for example, make a horizontal layout, or one with a dark gray background.

You can find more lessons in the Learn ArcGIS Lesson Gallery.