Work with multiple raster datasets

First, you'll focus on the management and storage of large volumes of imagery and remote sensing data in ArcGIS Pro. Big collections of raster data are being collected and assimilated at a rapid pace, and these datasets have significant value when the information inside them is shared and disseminated. ArcGIS Pro provides extensive enterprise image management capabilities and is used by organizations in a wide range of industries to manage imagery holdings, making them accessible and turning them into useful information products for both visualization and analysis.

Managing imagery and raster data efficiently and correctly is key to ensuring accessibility. For this, ArcGIS Pro uses mosaic datasets, a type of geodatabase structure, to manage imagery. In addition, ArcGIS Pro includes all the technology and associated tools needed to build and maintain mosaic datasets.

As a remote sensing and GIS analyst for the Upper Austria government, you will explore the challenges of working with multiple images individually and create a mosaic dataset that will allow you to work with the collection of seamless images, making them accessible and turning them into useful information products for both visualization and analysis.

Why use a mosaic dataset

This module covers some of the challenges of working with multiple images individually. Even though adjacent images may appear as a single image when displayed in a map, they are separate layers. Working with the individual layers is challenging when project requirements call for the application of any kind of enhancement or analysis because each layer must be handled separately.

  1. Go to the mosaic dataset lesson image collection on ArcGIS Online and click Download. If prompted, browse and choose a file location to save the downloaded image collection.

    Download button

    Note:

    The orthophoto image collection is large and consists of 73 individual images that may take some time to download. These images represent a collection of orthophotos that cover the region in and around the historic town of Hallstatt.

  2. Locate the Orthophotos.zip downloaded file on your computer. Right-click the file and extract it to a location you can easily find, such as your Documents folder.
  3. In your unzip location, verify the creation of a subfolder named OrthoPhotos containing the image collection.
    Note:

    The data used in this lesson comes from the State of Upper Austria (Land Oberoesterreich Open Data), which provides various regional vector and raster data layers under a Creative Commons Attribution 4.0 Austria license.

    If you have questions about this data, use the following contact information:

    Office of Upper Austria. State Government

    Directorate Presidium

    Department Presidium

    Landhausplatz 1

    4021 Linz

    Telephone (+43 732) 77 20-111 61

    Fax (+43 732) 77 20-21 16 21

    A list of available data is located at https://www.land-oberoesterreich.gv.at/119788.htm

  4. Start ArcGIS Pro. If prompted, sign in using your ArcGIS account.
    Note:

    If you don't have ArcGIS Pro or an ArcGIS account, you can sign up for an ArcGIS free trial.

    There are various templates for new projects. For this project, you'll use the Map template.

  5. Under Blank Templates, click Map.

    Map option

  6. In the Create a New Project window, for Name, delete the default project name and type CreateAndUseMD.

    By default, projects are saved in a new folder; however, you can save them to an existing folder by unchecking Create a new folder for this project and browsing to your target folder.

  7. For Location, browse to and choose your unzipped data folder (for example, C:\CreateUseMosaicDataset).
  8. Confirm that Create a new folder for this project is unchecked and click OK.

    Create a New Project window

    The project is created with a default map and associated basemap set to the world extent. The map consists of a map display and a contents pane displaying all map layers. In addition, the Catalog pane is located to the right of the map display and lists all files and folders associated with the project.

  9. In the Catalog pane, expand Folders. Verify that the OrthoPhotos folder is included in the project items.

    OrthoPhotos folder

    Note:

    If the OrthoPhotos folder is not present in your project folders, right-click Folders and add a new folder connection by browsing to and choosing the location containing of your unzipped orthophoto collection.

  10. In the Catalog pane, expand the OrthoPhotos folder.

    The folder contains a collection of 73 images in a .jp2 format.

    Orthophoto images

    Note:

    A .jp2 file is a compressed bitmap image created using JPEG 2000 (JP2) Core Coding. It supports color bit depth and image metadata and may be compressed with lossy or lossless compression and is typically used for storing digital photos and images.

  11. In the Orthophotos folder collection, expand 4727-08.jp2.

    Image bands

    The image consists of four bands. While they are not named as such, these represent red, green, blue, and infrared bands.

  12. In the Orthophotos folder, collapse 4727-08.jp2
  13. From the OrthoPhotos folder, press the Shift key and select 4727-08.jp2, 4727-16.jp2, and 4727-23.jp2. Right-click the selection and choose Add To Current Map.

    Add To Current Map option

    Note:

    The Calculate Statistics window may appear. If so, leave the box unchecked. Later in this lesson, you'll calculate the statistics for the entire collection of images.

    In the Contents pane, the selected images are added to the map as raster layers.

    Review image layers in contents pane.

    In the map display, adjacent images are rendered seamlessly so they appear as one image. However, as you pan and zoom, each individual image will be refreshed and displayed as a separate layer.

    Image layers on the map

  14. In the Contents pane, collapse the layers. Select 4727-08.jp2 and 4727-16.jp2.

    Selected layers

  15. On the ribbon, on the Appearance tab, in the Rendering group, click the Stretch Type drop-down menu and verify the current stretch type applied is Percent Clip.

    Percent Clip stretch type

  16. On the Map, zoom to the 4727-08.jp2 and 4727-16.jp2 layers.

    The layers overlap and vary in brightness and contrast.

    Images overlapping

  17. On the Appearance tab, in the Rendering group, click the Stretch Type drop-down menu and choose Minimum Maximum.

    Minimum Maximum stretch type

    On the map, the overlap between the layers is less pronounced and the stretch type has adjusted the brightness and contrast.

    Updated stretch effect

  18. In the Enhancement group, experiment using the Brightness, Contrast, and Gamma sliders to apply interactive adjustments to the imagery.

    Image enhancement sliders

    If you want to perform adjustments, you have to select layers individually. Furthermore, if you have overlaps between your images, you must adjust the order of the layers manually to control the overlap. The more images you have, the harder they are to manage as a collection.

  19. When you're finished, in the Contents pane, select 4727-08.jp2, 4727-16.jp2, and 4727-23.jp2. Right-click the selection and choose Remove.

In this module, you added separate images to a map and explored enhancing them individually and in small groups. While this is a good way to work with a few images, working with larger numbers such as your collection of 73 images can be challenging. In the next module, you'll explore creating a mosaic dataset and adding and working with your entire collection of orthophotos.


Create a mosaic dataset

A mosaic dataset is a well-defined geodatabase structure optimized for working with large collections of imagery and rasters. Mosaic datasets are stored in either a file geodatabase or an enterprise geodatabase. The imagery and raster data do not need to reside in the database. Most organizations store their imagery as files on disk, enterprise, or cloud storage. A single mosaic dataset can reference millions of images and make them appear as a single virtual dataset or enable quick access to any individual image or collection of images. With mosaic datasets, the large volume of pixel data (contained in the imagery and rasters) are not loaded into the database and are instead referenced. The metadata about the data sources, as well as information on how to process the imagery into different products, is stored in the mosaic dataset. When a request for imagery is made, the mosaic dataset is used to determine what images are required and what processing is to be applied. Only the required imagery is read, processed, and returned.

Manage the image collection

First, you'll create and populate a mosaic dataset to efficiently manage and display your orthophoto image collection.

  1. In the Catalog pane, expand Folders and expand the CreateAndUseMD folder.

    The CreateAndUseMD folder represents your project folder. Here you'll find the project geodatabase, which is named the same as your project. You can also access the project geodatabase in the Catalog pane by expanding Databases.

    Note:

    To create and work with a mosaic dataset, you must use geoprocessing tools. Access these on the Analysis tab on the ribbon using the Tools button. However, many geoprocessing tools are also provided as context menu items in the Catalog pane.

  2. In the Catalog pane, right-click CreateAndUseMD.gdb, point to New, and choose Mosaic Dataset.

    Mosaic Dataset option

    The Create Mosaic Dataset geoprocessing tool appears.

    Note:

    In the geodatabase the mosaic dataset name will appear as Hallstatt, while in the map contents pane the mosaic dataset layer is named HallStatt. A map layer may have a different more descriptive name than its data source.

  3. In the Create Mosaic Dataset window, for Output Location, verify CreateAndUseMD.gbd is chosen.
  4. In the Create Mosaic Dataset window, for Mosaic Dataset Name, type HallStatt.

    Leave all additional tool parameters at default.

  5. Click Run.

    Create Mosaic Dataset parameters

    The tool executes and creates a new mosaic dataset in the project geodatabase. In addition, it adds a mosaic dataset group layer to the contents pane of the map.

    Next, you'll associate your imagery to the mosaic dataset.

  6. In the Catalog pane, in the CreateAndUseMD.gbd item, right-click the HallStatt mosaic dataset and choose Add Rasters.

    Add Rasters option

    The Add Rasters To Mosaic Dataset tool opens. In the tool, mosaic dataset parameters are already filled in based on your context; however, you update the type of imagery you have. If, for example, you had satellite imagery with metadata, you can specify the type of data to add to the mosaic dataset (for example, Landsat 8).

  7. In the Add Rasters To Mosaic Dataset tool, verify the Raster Type is set to Raster Dataset.

    Since the imagery you are working with is simple imagery without any metadata, you can use the default Raster Dataset raster type.

    Next, you'll specify input data type and location.

  8. Click the Input Data drop-down menu and choose Folder.
    Note:

    The Add Rasters To Mosaic Dataset tool has several options to allow users to add imagery of different types to a mosaic dataset. A good example of this is located in the Raster Processing section of the tool, where the Minimum Rows or Columns parameter manages how many source image pyramids are used when an image is added to the mosaic dataset.

  9. Click the Browse button. Browse to and choose your OrthoPhotos folder.
    Note:

    Raster pyramids are down-sampled versions of an image that are used to improve display performance.

  10. Before proceeding, verify the following parameters:
    • Confirm that Raster Type is set to Raster Dataset.
    • Confirm that Input Data is set to Folder.
    • Confirm that Folder location is set to OrthoPhotos.
  11. Expand the Raster Processing options. For Minimum Rows or Columns, type 10.

    By specifying a value of 10, you are allowing the mosaic dataset access to all the pyramids from the source images that have 10 or more rows or columns. Now you are ready to run the tool and associate the images to the mosaic dataset.

    Add Rasters To Mosaic Dataset parameters

  12. Click Run.
    Note:

    Adding images to the mosaic dataset does several things, including adding references to the images on disk (not copies) to the attribute table of the mosaic dataset and setting the field values that control at which scale images are displayed based on the pyramids in the image and which images overlap them. Once the tool is finished, the mosaic layer in the Contents pane updates to reflect the number of bands in the first image added to the mosaic.

    Mosaic dataset in the map

    The HallStatt layer is a group layer containing three sublayers:

    • Boundary
    • Footprint
    • Image

    Review mosaic dataset components in the Contents pane.

  13. In the Contents pane, uncheck the Image and Footprint sublayers and verify the Boundary sublayer remains checked.

    Mosaic dataset boundary on map

    The boundary sublayer is a feature class that represents the combined footprints of images added to the mosaic dataset.

  14. In the Contents pane, uncheck the Boundary sublayer and check the Footprint sublayer.

    Mosaic dataset footprints on map

    The Footprint sublayer is a feature class that represents the footprint (minimum and maximum extent) of each image added to the mosaic dataset.

  15. In the Contents pane, right-click the Footprint sublayer and choose Attribute table.

    Attribute Table option

    The attribute table has fields that not only tell you the source name of the image or scene but also the pixel sizes of the images (MinPS and MaxPS) and the scales at which they will be displayed (LowPS and HighPS).

    Note:

    If your mosaic dataset consists of images with metadata and you specify the appropriate raster type, the attribute table will be populated with far more attribute fields with values derived from the metadata.

    Mosaic dataset attribute table fields

  16. Close the table. In the Contents pane, check the Image sublayer.

    Image sublayer

    This layer represents a seamless mosaic of all the images added to the mosaic dataset. Not all 73 images added to the mosaic dataset are displaying and that the band names in the contents pane for the mosaic dataset do not reflect the colors. Next, you'll correct this.

  17. In the Catalog pane, right-click the HallStatt mosaic dataset and click Properties.

    Properties option

    In the Mosaic Dataset Properties pane, there are two tabs: General and Defaults. In the General tab, you'll find information regarding the mosaic dataset such as source information, location, and whether it has statistics or not.

  18. Verify the General tab is selected and expand Raster Information.

    Raster Information heading

  19. In the expanded Raster Information properties, locate Product Definition.

    In Product Definition, you can specify the type of imagery the mosaic dataset represents, resulting in the setting of several preset default values for various display and other properties applicable to that raster type.

  20. In the Product Definition window, click the None drop-down menu to display a list of product definitions.

    Review product definition.

  21. In the Product Definition drop-down list, choose NATURAL_COLOR_RGBI.

    Product Definition option

    The product definition settings update to display band information that correctly identifies band names and the minimum and maximum wavelengths for each raster band.

    Updated product definition

  22. In the Product Definition window, click OK.
  23. In the Mosaic Dataset Properties pane, click Defaults. Expand Image Properties.

    Image Properties heading

    The Defaults tab allows you to control properties specific to the images comprising the mosaic dataset. Currently, your mosaic dataset is only displaying 10 images.

  24. In the Image Properties list, for Maximum Number of Rasters Per Mosaic, type 100 and press Enter.

    This property sets how many images are displayed by the mosaic dataset. Since your mosaic dataset consists of 73 images, setting the maximum value to 100 ensures all source images will be displayed.

    Maximum Number of Rasters Per Mosaic parameter

  25. In the Mosaic Dataset Properties pane, click OK.

    Updated mosaic dataset in map

  26. In the Contents pane, uncheck the Footprint sublayer.

    Unchecked Footprint sublayer

    The band names in the Contents pane under the Image sublayer have updated to display the correct band names.

    The mosaic layer in the contents pane updates and now displays all 73 images in the mosaic dataset.

    Explore updated mosaic dataset in map.

  27. On the ribbon, on the Appearance tab, in the Compare group, click and use the Swipe tool to investigate images located at the top of the lake.

In this module, you created a mosaic dataset and added the images from your orthophoto collection. Now you are ready to work with the images as a collection and enhance the mosaic dataset by applying and incorporating analysis functionality.


Use a mosaic dataset as a dynamic image

In this module, you will work with the mosaicked image collection and enhance the dataset by applying and incorporating analysis functionality.

Enhance the mosaic dataset

First, you'll enhance the dataset.

  1. In the Contents pane, click the HallStatt mosaic layer to select it.
  2. Ensure the Image sublayer is checked and the Footprint and Boundary sublayers are checked off.

    To perform visual enhancements on the mosaic dataset, you'll need to build statistics.

  3. In the Catalog pane, right-click the Hallstatt mosaic dataset and click Properties.
  4. In the Mosaic Dataset Properties pane, on the General tab, locate and expand Statistics. Verify the statistics have not been calculated.

    Uncalculated statistics

    When a mosaic dataset is created and images are loaded, statistics are not automatically generated, since calculating statistics for the mosaic dataset may be time consuming. Once the mosaic dataset is built, it is advisable to include a step in the workflow to calculate statistics to improve performance.

  5. Click OK to close the Properties pane.
  6. In the Catalog pane, right-click the Hallstatt mosaic dataset, point to Enhance, and choose Calculate Statistics.

    Calculate Statistics option

  7. In the Calculate Statistics geoprocessing tool, verify the following parameters:
    • Confirm that Input Raster Dataset is set to Hallstatt.
    • Confirm that X Skip Factor is set to 1.
    • Confirm that Y Skip Factor is set to 1.

    Calculate Statistics parameters

  8. Click Run.

    Calculating statistics for the mosaic dataset may take a few minutes to complete. When done, the mosaic layer in the Contents pane will update and you can then use the updated statistics to improve performance.

    Updated mosaic dataset on map

  9. In the Catalog pane, right-click the Hallstatt mosaic dataset and click Properties. In the General tab, locate Statistics.

    Updated statistics

    The mosaic dataset statistics have been updated and now include band specific values that are used to enhance display and processing performance.

    Next, you'll use a stretch type to apply additional enhancements to your mosaic dataset.

  10. On the Appearance tab, in the Rendering group, click the Stretch Type drop-down menu and verify the default stretch type is set to Percent Clip.

    Percent Clip stretch type

  11. On the Appearance tab, in the Rendering group. Click the Stretch Type drop-down menu and choose Minimum Maximum.

    Minimum Maximum stretch type

    This updates and changes the way your mosaic dataset displays.

  12. On your own, experiment with various stretch types and use the Swipe tool to explore. If you do not have a preference, you can choose Percent Clip.
  13. On the Appearance tab, in the Enhancement group, use the Brightness, Contrast, and Gamma sliders to interactively enhance the way the image looks.

    Enhancement sliders

    Because your mosaic dataset has multiple bands, you can also use the Band Combination drop-down menu and pick a preset to quickly change to a different band combination. For example, the Color Infrared band combination allows you to easily see vegetation.

  14. On the Appearance tab, click the Band Combination drop-down menu and choose Color Infrared.

    Color Infrared band combinations

    Since the mosaic dataset images have a near-infrared band, the color infrared band combination creates a false color composite, where the near-infrared band is displayed as red. The red band is displayed as green, and the green band is displayed as blue. The Color Infrared band combination is good to highlight vegetation (in red) and water (in black).

    Updated layer in map

    Note:

    Any change to the appearance of a layer, such as band combination, is only for visual display purposes and will not actually change the source data. Changes will not persist unless you save a layer file or save the project. Saving the project will save the state of the layer as you have modified it but only within this project. Saving a layer file will save the layer properties and allow for the layer to be reused in multiple projects.

  15. On the Appearance tab, in the Band Combination drop-down menu, choose Natural Color.

    Next, you'll build overviews or reduced resolution datasets for your dynamically mosaicked image to speed up display.

    The mosaic dataset name in the geodatabase has been modified to Hallstatt to conform to database naming conventions.

    Note:

    You can generate overviews, which are like raster pyramids, for a mosaic dataset. Overviews are reduced resolution datasets that are generated to improve the speed at which the mosaic is displayed. You can allow the default overviews to be generated across the entire mosaic dataset. Alternatively, you can control how they're created by defining specific a down sampling ratio, as well as a defined extent and a specific spatial resolution.

  16. In the Catalog pane, right-click the Hallstatt mosaic dataset, point to Optimize, and choose Build Overviews.

    Build Overviews option

  17. If necessary, in the Build Overviews geoprocessing tool, check the following parameters:
    • Define Missing Overview Tiles
    • Generate Overviews
    • Generate Missing Overview Images Only
    • Regenerate Stale Overview Images Only
  18. Click Run.

    Build Overviews parameters

    Building overviews may take a few minutes as the reduced resolution datasets are generated to improve the display speed of the mosaic dataset. Once it is done, the mosaic layer in the Contents pane will update, and you can observe the effect of updated overviews by changing extent in the map.

  19. Use the Explore tool to pan and zoom the map.

    The image display performance is faster as a result of the overviews. Before generating overviews, the entire image was rendered at full resolution each time you navigated the map. Now, based on the extent, only specific overviews at the relevant resolution are displayed and as you navigate the map, the display updates quickly as it no longer needs to render all data, but only that which falls within the new boundary.

Add analysis to a mosaic dataset

Next, you'll execute an analysis workflow using the mosaic dataset and associate the analysis workflow with the mosaic dataset so users can apply the same workflow on demand.

  1. In the Contents pane, select the HallStatt mosaic layer.
  2. Ensure that the Image sublayer is checked on and the Footprint and Boundary sublayers are checked off.
  3. On the ribbon, on the Imagery tab, in the Analysis group, click Raster Functions.

    Raster Functions button

    The Raster Functions pane displays and shows various functions that you can use to perform analysis on your imagery.

    Raster Functions pane

  4. In the Raster Functions pane, in the Analysis subcategory, click the NDVI Colorized function.

    NDVI Colorized creates a multiband dataset that represents vegetation health based on the difference between the red and near infrared bands.

    NDVI Colorized raster function

    The NDVI Colorized Properties pane appears.

  5. In the NDVI Colorized Properties pane, for Raster, click the drop-down menu and chooseHallStatt.
  6. Leave the other parameters unchanged and click Create new layer.

    NDVI Colorized raster function parameters

    The NDVI Colorized Properties raster function creates and adds a new layer to the map and uses the red and infrared bands from your imagery to highlight areas of healthy vegetation.

    NDVI Colorized raster layer on map

  7. In the Contents pane, select the NDVI Colorized_HallStatt layer.

    NDVI Colorized raster layer selected

  8. Use the Swipe tool to explore the NDVI Colorized_HallStatt layer on the map.

    If you compare the NDVI Colorized_HallStatt layer to the mosaic layer, you'll see that areas of healthy vegetation are colored green and areas with snow or shadows and areas where vegetation has been removed are colored lighter. Areas with water are colored orange to brown.

    Compare the NDVI Colorized and HallStatt layers.

    Using NDVI Colorized function is a relatively fast way to highlight healthy vegetation in your imagery. However, it is also temporary and only available in the new layer created in the Contents pane.

    Next, you'll take this analysis and attach it to the mosaic dataset so it can be applied by anyone using the mosaic dataset.

  9. In the Contents pane, right-click the NDVI Colorized_HallStatt layer and choose Save Function Chain.

    Save Function Chain option

    The Raster Function Editor window appears.

  10. In the Raster Function Editor window, click the Save button.

    Save button

  11. In the Save window, for Name, type NDVI Colorized.
  12. For Category, choose Project. Click OK.

    Set Raster Function parameters

    You've now saved the analysis as a raster function template that can be associated to the mosaic dataset.

  13. In the Contents pane, right-click the NDVI Colorized_HallStatt layer and choose Remove.

    Remove option

  14. In the Catalog pane, right-click the HallStatt mosaic dataset and choose Manage Processing Templates.

    Manage Processing Templates option

    The Manage Processing Templates pane appears.

    Manage Processing Templates pane

  15. In the Manage Processing Templates pane, click the Import button.

    Import button

  16. In the Select Processing Templates window, click Raster Functions and double-click Project and Project1. Pick the NDVI Colorized function.

    NDVI Colorized function

  17. Click OK.

    The Manage Processing Templates pane updates and displays the attached NDVI Colorized raster function.

    Template displayed

    Now that you have attached the processing chain to the mosaic dataset, you can reuse the same analysis any time it is required.

  18. In the Contents pane, ensure the HallStatt layer is selected. On the Data tab, in the Processing group, click the Processing Templates drop-down menu and choose NDVI Colorized.

    NDVI Colorized option

    The map display changes to show you the results raster function template applied to the layer.

  19. On the Data tab, in the Processing group, click Processing Templates and choose None from the drop-down menu.

    Your display changes back to the imagery.

    None option

You've explored how to enhance your mosaic dataset by applying and incorporating analysis functionality. Next, you'll explore a mosaic dataset hosted as a dynamic imagery layer in ArcGIS Living Atlas.


Use a mosaic dataset as a catalog of imagery

Next, you'll use a catalog of imagery from a ArcGIS Living Atlas mosaic dataset layer and explore how you can use the layer as a catalog of imagery.

Use dynamic imagery hosted online

Dynamic imagery is imagery hosted online that you can add to a project and use for exploration and analysis. For example, all the Landsat imagery used in this section is stored in the cloud through the Amazon Web Services (AWS) cloud. Therefore, you'll access the imagery dynamically through an internet connection without the need to download and store the imagery locally. In addition, visual rendering and image computations are executed on-demand in real time. As a result, everything displayed on your screen is dynamically generated from the source Landsat repository on AWS without the need to precompute and store separate imagery products.

  1. In the Catalog pane, click the Portal tab.
  2. In the Portal tab, click the Living Atlas button.
    Note:

    ArcGIS Living Atlas of the World is a large collection of geographic information from around the globe and includes many dynamic imagery layers. You'll use the ArcGIS Living Atlas website to browse, filter, and discover ready-to-use dynamic imagery.

  3. In the Living Atlas search, type Multispectral Landsat and press Enter.

    Multispectral Landsat search

    Multispectral Landsat is a dynamic image service provided by Esri that is driven by a mosaic dataset and is a service containing imagery of the world over multiple years collected by the Landsat satellites.

  4. In the search results, locate the Multispectral Landsat (Mature Support) imagery layer. Point to the name and review the layer metadata.

    Multispectral Landsat imagery metadata

    Note:

    Mature Support in the item name indicates this item will be updated and replaced soon. A new Landsat imagery service with improvements that incorporate advanced data processing, updated algorithms, improved data access, and distribution capabilities is in development and testing and will be available soon. Refer to this ArcGIS Landsat announcement for details. This lesson will be updated with the new service as soon as it becomes available. In the meantime, you can use the mature support version without any issues.

  5. Right-click the Multispectral Landsat (Mature Support) imagery layer and choose Add To Current Map.

    Add To Current Map option

  6. In the Contents pane, right-click the Hallstatt layer and choose Zoom To Layer.

    The map updates to display the extent of the Hallstatt area.

    Multispectral Landsat imagery on map

  7. In the Contents pane, right-click the Multispectral Landsat (Mature Support) layer and choose Attribute table.

    Multispectral Landsat imagery attribute table

    The Multispectral Landsat (Mature Support) layer attribute table (footprint table) contains several fields that are different from those added to the table for your local mosaic dataset. These fields contain metadata, such as Acquisition Date, CloudCover, SunElevation, Sensor Name, and so on. Additional attributes were added by a technician creating the service and these include a Best field. You can use these fields to review information about the data but also to query and filter images as needed.

  8. Close the table. In the Contents pane, right-click the Multispectral Landsat layer and click Properties.
  9. In the Layer Properties pane, click Definition Query.

    The layer has a current definition query set. This definition query filters the images displayed using the values from the Best field. For the Hallstatt area, the current query does not change the visible imagery.

    Definition Query tab

  10. In the Definition Queries tab, point to Query 1 and click the Remove definition query button. In the Remove Definition Query window, click Yes.

    Remove Definition Query window

  11. In the Layer Properties pane, click OK.

    The map refreshes, but removing the definition query has had no effect on the image display and did not change the layer.

  12. In the Contents pane, right-click the Multispectral Landsat (Mature Support) layer and choose Properties. In the Layer Properties pane, click Time.

    The Time tab uses a time field in your mosaic dataset to allow users to step through time and view the data that corresponds with different times. This is one of the major features of this mosaic dataset. For now, you will turn time off so you can explore other cataloging capabilities of the mosaic dataset.

    Time tab

  13. In the Time tab, click the Layer Time drop-down list. In the drop-down list, click No Time.

    No Time option

  14. In the Layer Properties pane, click OK.

    Once again, the map updates with no change to the layer.

  15. In the Contents pane, select the Multispectral Landsat (Mature Support) layer. On the ribbon, in the Data tab, in the Processing group, click the Processing Templates drop-down menu and choose Natural Color with DRA.

    Natural Color with DRA option

    The display updates and shows the layer in natural color.

    Note:

    Images in this mosaic dataset have a lot of overlap not only between images captured at the same time but also between images captured over multiple years. This makes it important to configure your mosaic dataset to display the most relevant imagery for your analysis.

    Next, you'll filter and pick items of interest in the Hallstatt area using the Raster Item Explorer.

  16. In the Contents pane, right-click the Hallstatt layer and choose Zoom to Layer.
  17. In the Contents pane, select the Multispectral Landsat layer. On the ribbon, in the Data tab, in the Selection group, click Explore Raster Items.

    Explore Raster Items button

    The Raster Item Explorer pane presents a way to review current images displayed in the mosaic dataset and apply a filter to them based on fields in the attribute table.

    Display Raster Item Explorer pane.

    The item explorer displays one item representing the image currently displayed in the map. If the map were displaying multiple images, the item explorer would show more than one item that representing the mosaic of the images in the display. For an example if you were to change the scale of the map to 1:250,000 and refresh the Explore Raster Items pane. You would see two or more items which means these multiple items are currently being mosaicked together to make up the layer displayed.

    Next, you'll explore all the items that make up the current display extent.

  18. In the Raster Item Explorer pane, click the By Area Of Interest drop-down menu and choose Display Extent. Check Exclude Overviews and click Apply.

    Select tab parameters

    The item list updates and identifies 359 items (items numbers may vary based on your extent) that do not represent overviews and that partially or completely overlap the current extent.

    Note:

    The Multispectral Landsat (Mature Support) layer is a dynamic image layer published on ArcGIS Living Atlas and as such is subject to frequent updates that may include additional or more current scenes added or removed. As a result, the number of images selected may differ from those in this lesson.

    Number of selected items

    The Multispectral Landsat layer has been configured to display imagery that is best on top. The best imagery is determined using the value in the best field. Next, you'll explore how this can affect how images in the mosaic are displayed.

  19. On the ribbon, click the Data tab. In the Image Display Order group, click the Sort drop-down and choose North-West..

    North-West option

    The layer updates but does not look as good. This is because the images that are most northwest in the mosaic dataset are being displayed regardless of whether they are covered by clouds or not.

    Northwest sorted images

  20. In the Sort drop-down menu, choose By Attribute.

    Sorting by attribute requires you to specify an attribute field to sort images in the mosaic dataset. As a result, the Layer Properties pane appears and you can select an order field.

  21. In the Layer Properties pane, verify the Order field value has been set to Best and click OK.

    Order field set to Best

  22. In the Raster Item Explorer pane, click the Configure Results button.

    Configure Results button

  23. In the Configure Results window, check Show Thumbnails and click Apply.

    Show Thumbnails option

    The item list updates and displays thumbnails for the items, which simplify identification and allow for a visual comparison.

    Image thumbnails

    The items list consists of 359 items. Next, you'll filter out the most current items for the year 2020.

  24. In the Raster Item Explorer pane, click the By Attribute drop-down menu and choose Field. For Field name, choose Acquisition Date.

    AcquisitionDate field

  25. Click the Start Date drop-down menu and choose More.

    More option

  26. Click the Start Date drop-down menu and choose the first 2020 date, 1/4/2020 9:52:00 AM. Click the End Date drop-down menu and choose 12/28/2020 9:58:16 AM.
  27. Click Apply.

    Apply button

    The item list updates and has been filtered to 43 items.

    Filtered images

    By default, these items are sorted by date, so the last item is the latest date. Ideally, you want to work with the latest imagery of the area; however, not all images may be of the same quality.

  28. In the Raster Item Explorer pane, in the Item list, scroll and identify the last item. Click Add to Current Map.

    Add to Current Map button

    A new layer named Multispectral Landsat:3522101 is added to the map. This layer represents the associated image collected on the last date in 2020.

    Multispectral Landsat:3522101 image in map

    The layer extent covers only a part of the current area of interest and it has a lot more snow in it than the source layer.

  29. In the Contents pane, right-click Multispectral Landsat:3522101 and choose Remove.

    Next, you'll sort items based on cloud cover.

  30. In the Raster Item Explorer pane, in the Item list, click the Sort By button, and choose CloudCover.

    CloudCover option

    The item list refreshes and is sorted based on cloud cover. The first item has a 98.44 percent cloud cover.

    Percentage of cloud cover

  31. In the Item list, click the Sort in Descending Order button.

    Sort in Descending Order button

    The item list is sorted and the first item in the list now has the lowest percentage of cloud cover.

    Image with least cloud cover

  32. In the Item list, select the item and click the Add to Current Map button.

    The image has little cloud cover and covers the full area of interest.

    Lowest cloud cover image on map

  33. In the Contents pane, right-click Multispectral Landsat (Mature Support):3421885 and choose Remove.

    In addition to adding items as new layers, you can lock one or more items so that the original layer only shows a specific area of interest you are investigating.

  34. Click the Sort By button on the toolbar and click Acquisition Date.

    The cloud cover is now filtered items based on acquisition date.

  35. In the Item list, select the item with the date 6/28/20 9:51:33 AM and verify the item is checked. In the Item list, select the item with the date 7/5/2020 9:57:47 AM.

    Specific dated images

  36. On the Item list, on the toolbar, click the Lock button.

    Lock button

    This will lock the Multispectral Landsat layer to only show the two items you selected as a single mosaicked image.

    Locked images on map

    The two items selected display as one. This is an important way to combine multiple items seamlessly for a specific area of interest.

    Note:

    The Multispectral Landsat (Mature Support) layer is a dynamic image layer and as such is subject to frequent updates that may include additional or more current scenes added or removed. As a result, your images may differ from those displayed in this lesson.

  37. On the Item list, on the toolbar, click the Unlock button to revert to the original display.
  38. In the Contents pane, drag the Hallstatt layer to the top of the layers list and ensure the Footprint layer is checked on.

    Hallstatt mosaic

    Now your map displays your area of interest with detailed high-resolution local imagery on top of less detailed dynamic imagery hosted online.

  39. Save the project.

In this lesson, in your role as a remote sensing and GIS analyst for the Upper Austria government, you received a collection of orthophotos that you needed to manage and share effectively with stakeholders. You explored the challenges of working with multiple images individually, and created a mosaic dataset to allow you to work with the collection of seamless images, making them accessible and turning them into useful information products for both visualization and analysis. Finally, you enhanced the mosaic dataset by applying and incorporating analysis functionality. Lastly, you added a dynamic image layer hosted online in ArcGIS Living Atlas to your map and explored how overlapping imagery is handled dynamically, how you can use the fields in the mosaic dataset to query items, and how the mosaic dataset is time aware.

You can find more lessons in the Learn ArcGIS Lesson Gallery.