Create an office building

To compare plans for an upcoming remodel, you'll create realistic models of two buildings on the Penn State campus. With multipatch editing, you can create and texture complex 3D building forms. You'll start with Oswald Tower, an office-type building. After converting the building footprint to a multipatch feature, you'll use lidar point cloud data to extrude it to the correct height. Then, you'll create and edit vertices to add more architectural features, and finally apply texture images to give the facade a realistic appearance. Using these basic components, you can quickly generate models of other commercial or office buildings common in the downtown area of any major city.

Create a local scene and download data

First, you'll open a project in ArcGIS Pro and add a local scene. Local scenes are useful for datasets with limited spatial extents that use a projected coordinate system, such as the data for the Penn State campus. Then, you'll download data and save it to your project folder.

  1. Start ArcGIS Pro. If prompted, sign in using your licensed ArcGIS account.
    Note:

    If you don't have ArcGIS Pro or an ArcGIS account, you can sign up for an ArcGIS free trial.

    When you open ArcGIS Pro, you're given the option to create a new project or open an existing one. If you've created a project before, you'll see a list of recent projects.

  2. Under New, Blank Templates, click Local Scene.

    Create a new local scene

  3. In the Create a New Project window, name the project Penn State Buildings.
  4. Save the project in the location of your choice, make sure the Create a new folder for this project box is checked, and click OK.

    Default local scene

    The Local_Scene template creates a 3D scene of your project that is used for smaller extent content in a projected coordinate system, where the curvature of the earth isn't needed. Note that the data for the Penn State campus is projected in a local projection and won't be compatible with a global scene.

    The project opens and displays a local scene.

  5. Download the PSU_data folder ZIP file.

    This compressed file contains a geodatabase with multipatch features for the two buildings you'll edit, as well as a folder of building textures that you'll use to make realistic-looking facades.

  6. Unzip the PSU_data file to the Penn State Buildings project folder that you just created.

Add the Penn State data

Now that you have the project set up, you can add the necessary data. To create a realistic building, you need reference data. For this project, you have high-resolution aerial imagery, a lidar dataset, and the building footprint for Oswald Tower to work with.

  1. On the ribbon, click the Map tab. In the Layer group, click the Add Data button.

    Add Data button

    The Add Data window appears. In the browser, you can search your project, your computer, or your portal for data to add. Your portal is the licensed account you used to sign in when you first started ArcGIS Pro. Because you signed in with an ArcGIS Online account, you have access to all the ArcGIS Online data your account can access.

  2. In the Add Data window, under Portal, click All Portal.

    All Portal

  3. In the search box, type 2017 PSU LiDAR. To narrow the results, add owner:Learn_ArcGIS if necessary.

    Depending on the data that is publicly available, many search results may be returned.

  4. In the list of results, choose the 2017 PSU LiDAR layer and click OK.

    Search portal

    The lidar point cloud data draws on the map, which zooms to the location of the data. These points will be used as a reference layer to determine how high to extrude your building footprint.

    Lidar overview

  5. Click the Add Data button again. In the Add Data window, under Project, click Folders, open the Penn State Buildings lesson folder, and open Multipatch Editing Lesson Data.gdb in the PSU_data folder.
  6. In the Multipatch Editing geodatabase, press Ctrl and choose the PSU_Oswald polygon layer and the PSU_Buildings multipatch layer. Click OK to add them to the scene.

    Add building footprints

  7. In the Contents pane, turn off the lidar layer and pan the map until you can see the polygon and building names.

    Building footprint polygons

    Notice that the building footprint seems to sink into the ground. Because you're looking at a 3D scene, some of the polygon is covered by small differences in elevation. The Oswald Tower footprint is a z-enabled polygon feature class. Before you can use the multipatch editing tools, the footprint must be copied to the Penn State 3D Buildings multipatch feature class.

  8. On the ribbon, on the Map tab, in the Selection group, click the Select tool, and click the PSU_Oswald polygon feature.

    The polygon is selected and highlighted.

  9. Right-click the selection and choose Copy.

    Copy selection

  10. On the ribbon, in the Clipboard group, click the Paste drop-down arrow and choose Paste Special.

    Paste Special button

  11. In the Paste Special pane, choose the Penn State 3D Buildings multipatch feature class, check the Keep source attribute values check box, and click OK.

    Choose multipatch feature class

    The Name attribute from the source polygon feature class is copied to the destination multipatch feature (for example, "Oswald Tower").

    Note:

    The target layer PSU_Buildings must be added to the Contents pane when using Paste Special.

  12. On the ribbon, in the Selection group, click Clear to remove any active selections.

    Clear selection

    To save the edits you made to the multipatch feature class, you'll use the Edit tab.

  13. On the ribbon, click the Edit tab. In the Manage Edits group, click Save. Click Yes to save all edits.

    Save edits

    With the building footprint polygon converted to a mulitpatch feature, you can now edit it as a 3D feature.

  14. In the Contents pane, turn off the PSU_Oswald layer.

Extrude the building footprint

The first step in creating any building form is to extrude the footprint into a 3D block model; this is called a Level of Detail 1 (LoD1) 3D building. Higher levels of detail include roof forms (LoD2), architectural details such as columns or doors (LoD3), and finally, interior features (LoD4). To accurately extrude Oswald Tower, you'll use the lidar data you added earlier.

  1. Use the Select tool to select the Penn State 3D Buildings multipatch footprint for Oswald Tower.
  2. In the Contents pane, turn on the 2017 PSU LiDAR layer.

    Lidar for Oswald Tower

    Note:

    To tilt and rotate the scene, press the V and B keys, respectively. To pan, press the C key. You may also activate and use the Navigator control located on the View Tab, Navigation group.

  3. On the ribbon, click the Edit tab. In the Tools group, click Vertices.

    Vertices tool

    The Modify Features pane appears for the Vertices tool. You can also access the Vertices tool using the Modify button in the Features group.

  4. Point to the multipatch building footprint until you see the green editing handle (sphere) in the middle of the footprint.

    Editing handle

  5. Click the editing handle and drag it up to the height of the lidar points around the outer rim of the rooftop.

    Extrude the building height

  6. On the editing ribbon, click Finish to commit your edit.
  7. On the ribbon, in the Selection group, click Clear to deselect the building. In the Manage Edits group, click Save and Yes to save all edits.

    You've created a LoD1 3D building. Next, you'll add real-world textures to the sides and roof of Oswald Tower to make it a LoD3 building.

Add facade textures

Oswald Tower is relatively short for an office-style building and is not blocked by other buildings or vegetation, so it was easy to obtain a clear photo of the building facade. In this section, you'll apply a single image texture to each face of the building that has already been cropped and rectified. A facade tile image covering two floors has also been provided so you can experiment with repeating textures on a single face.

  1. In the Contents pane, turn off the 2017 PSU LiDAR layer.
  2. On the Edit tab, in the Features group, click Modify.
  3. In the Modify Features pane, expand the Reshape group and click Multipatch Texture.

    Multipatch Texture tool

    The Modify Features pane appears for the Texture tool.

  4. If necessary, click the multipatch feature to select it and click Load Texture.

    Load Texture

    The load texture browser opens.

  5. Browse to the lesson data folder you downloaded and open the FacadeTextures folder. Select Oswald_Front.png from the OswaldTower folder and click Open.
  6. Once the texture loads in the Modify Features pane, click one of the four side facades to apply the texture.

    Apply facade texture

    The image has been cropped to the aspect ratio of the building using the georeferencing and image transformation tools in ArcGIS Pro so it will fit the extent of the facade face.

  7. Adjust the image size or alignment using the adjustment buttons in the image preview window if necessary. For fine zoom adjustments, click the Zoom button and move the pointer to zoom in or out.

    If you zoom far enough out, the facade texture repeats. This is useful for skyscrapers or other buildings with constraints that don't let you capture an image of the full building face.

  8. To center the side facade image, use the Pan button to move the image left or right.

    Once the side is complete, click each of the other three facades to apply the same texture. If you changed the zoom level or any other characteristic of the facades, make sure the windows of each side are aligned.

    Note:

    To tilt and rotate the scene, press theV and B keys, respectively. To pan, press the C key.

    Side textures for Oswald

  9. When you're happy with the sides, click Apply.

    Now that the sides have texture, you'll add the roof texture. Unlike the sides of the building, the roof isn't a flat surface—it has an air conditioning unit and several other features that you'll need to extrude.

  10. Click the Load Texture button and choose Oswald_Roof.jpg. Click the roof to add the texture.
  11. Use the Pan, Rotate, and Zoom controls to make the roof texture fit the rooftop area. (Facing north, the air conditioning unit with the fans should be at the lower -left.) You can turn on the lidar points for reference.

    Add roof texture

  12. On the ribbon, click Clear. In the Manage Edits group, click Save and Yes to save all edits.

Add rooftop details

The roofs of tall office buildings often have mechanical equipment, solar panels, or other structures that may rise a floor or more above the surface. Using the Vertices editing tool, you'll cut out and extrude the rooftop structures—a mechanical room and a HVAC unit— on Oswald Tower. You'll then apply generic textures to them that involve repeating tiles. This process can also be used if you're working with very tall office buildings or other structures that have repeating patterns of windows or other architectural features on each floor that can be captured and duplicated as many times as necessary.

  1. If it's visible, turn off the 2017 PSU LiDAR layer in the Contents pane and zoom to the rooftop area of Oswald Tower.

    The roof texture was captured via aerial imagery, which introduced some distortion and shadow, obscuring some of the structures you're modeling. In the following steps, you'll use the Measure tool as a guide to accurately cut and extrude the roof surface.

  2. Center the roof with the view exactly perpendicular to the ground.

    Center the roof

  3. On the ribbon, click the Map tab. In the Inquiry group, click Measure.

    Measure tool

    To account for any distortion and the relationship between the camera and the subject (Oswald), you'll first measure a couple dimensions of the Oswald rooftop structure. Then you'll use the measurements to accurately split the roof surface for the areas that are hidden by the camera perspective.

  4. Measure the distance across the base of the short side of the rooftop structure (1 in the following image). Then measure the long edge (2 in the following image).
    Measurements

    You should get values of approximately 11.75 feet for the short edge and 15.6 feet for the long edge.

  5. On the ribbon, click the Edit tab. In the Editor Tools group, click Vertices and select the Oswald rooftop.

    The entire rooftop is selected, and the green editing handle appears.

  6. At the bottom of the Map pane, click Constraints to turn on dynamic constraints.

    Constraints button

    Turning on dynamic constraints shows you the length of the features you're working with. Because you have exact measurements for the rooftop structure, you'll use constraints for more accuracy.

  7. Starting at the upper left of the structure, click the visible corner intersection of the rooftop structure and the roof surface to add a vertex. Draw a line across the top of the structure and add another vertex at the upper right corner.

    Vertices on top of the structure

  8. Moving clockwise around the structure, use the parallel/perpendicular editing constraints. When you get to the bottom right edge, press Tab. In the constraints measurement box, type 11.75 ft and press Enter.

    Vertex 2

    The Tab key allows you to provide precise measurements for the lengths of each side. You can change the direction of the line segment but not its distance.

  9. Add a vertex to form the bottom of the roof structure, make a right angle, and add another vertex 15.6 ft above the last. Use the constraints to add a final vertex on the corner where you started.

    Roof structure

  10. Turn on the 2017 PSU LiDAR layer, click the green editing handle, and raise the newly-cut surface to the lidar points.

    Extrude the roof structure

  11. On the editing ribbon, click Finish to commit your edit.
  12. Clear the selection and save the edits to the roof structure.
  13. Select the roof again and repeat the process with the air conditioning unit.

    Air conditioning unit

  14. Clear the selection and save the edits.

    When surfaces are pushed or pulled on a multipatch model, any newly-created faces will be textured by mirroring textures on adjacent surfaces. For the roof of Oswald, this creates some unusual surfaces, such as the air conditioning fan that is now mirrored on the side of a wall. In addition, the images on top of each rooftop structure need to be moved slightly so they match the edge.

  15. In the Modify Features pane, click the back button.
  16. In the Reshape group, click Multipatch Texture. Select Oswald Tower, click Load Texture, and choose the Oswald_Roof texture.
  17. Click the top of the rooftop structure and fit the roof to match the structure.
  18. Add the Oswald_Roof texture again and center it on the air conditioning unit.

    Roof with extrusions

  19. Click Load Texture and add Oswald_RoofWall.jpg.
  20. Save the edits, and select Oswald Tower. Load the Oswald_RoofSide texture and apply it to the vertical sides of the rooftop structures.

    Side textures

  21. Add vertices to the wall around the air conditioning unit.

    When you try to extrude the selection, because of its shape, the editing handle is impossible to click.

  22. Press Ctrl and click the air conditioning unit wall to change the location of the editing handle. Click the handle and use the lidar data to extrude the wall.

    Apply as many additional rooftop structures and details as you'd like, such as splitting vertices, pushing and pulling faces, and applying additional textures or colors. The minute details help add realism to this basic 3D building form. For example, you can add the small ledges around the rooftop structure, the entire roof, or both.

  23. Clear any active selections and save all edits. Click Save on the Quick Access toolbar at the top of the project.

    Oswald final building

In this lesson, you created a realistic 3D office building using multipatch editing tools, textures, and lidar point cloud data. Though it included some rooftop structures, Oswald Tower was a simpler building than many you encounter every day. Many residential and small commercial buildings have more complex building geometry and roof forms. In the next lesson, you'll learn how to use precise measurements to construct an accurate building shape, including more challenging rooftop shapes and details.


Create a residential building

In the previous lesson, you created a simple office building using multipatch editing and realistic textures. In this lesson, you'll create a slightly more complex residential-style building on the Penn State campus, the Old Botany building. This structure, built in the late 1800s, has a gable roof and distinctive eyelid dormers. These features are a little more challenging to create than the rooftop structures that you built on Oswald Tower but use the same Vertices tool and texturing process. You'll extrude the building based on measurements (in feet), apply textures, and build the architectural details.

Add the Penn State data

The Old Botany building is just south of Oswald Tower, so you'll use the same local scene in ArcGIS Pro, which already contains the imagery and lidar reference layers. You'll add the building footprint to the same multipatch feature class you used to build Oswald Tower.

  1. If necessary, open your Penn State Buildings project.
  2. Click Add Data and browse to the Multipatch Editing Lesson Data geodatabase.
  3. Click the PSU_OldBotany layer and click OK to add it to the scene.
  4. Zoom out until you see the building footprint.

    Location of the Old Botany building

    The Old Botany building is near Oswald Tower.

  5. In the Contents pane, if necessary turn off the 2017 PSU LiDAR layer.

    Rather than using the point cloud as a visual reference for extruding the building footprint, you'll use measurements instead.

  6. On the ribbon, click the Map tab. In the Selection group, click Select and click the PSU_OldBotany polygon layer.

    The polygon is highlighted.

  7. Right-click the polygon, choose Copy, expand Paste, and choose Paste Special.
  8. In the Paste Special pane, choose the multipatch Penn State 3D Buildings layer, check the Keep source attribute values check box, and click OK.
  9. In the Contents pane, turn off the PSU_OldBotany layer.

Extrude the building footprint and align the editing grid

Now you'll begin construction of the Old Botany building by extruding the building into a simple LoD1 model. Once the simple block model is created, you'll align the editing grid to the orientation of the roof, which will constrain the movement of the editing handles so that accurate measurements can be applied in the correct directions. The editing grid is a useful reference surface for controlling alignment and distance when splitting or moving the vertices of a mulitpatch feature, but it aligns north-south unless otherwise specified.

  1. On the ribbon, click the Edit tab. In the Tools group, click Vertices. Make sure the building footprint is still selected.

    As you did with the roof structures, you can use the Tab key to provide precise measurements.

  2. Click the green editing handle in the middle of the building footprint and press Tab. Type 27.25 ft and press Enter.

    Press Tab to enter a height value

    Note:

    If the editing handle is red or the entered value isn't honored, you may need to reset your display cache. On the Project tab, click Options, then click Display. Under Local Cache, check the Clear cache box and restart your instance of ArcGIS Pro.

    Old Botany is now extruded, but as you can see, it doesn't align perfectly north-south. Because Old Botany is rotated approximately 44 degrees from north, rotating the grid to this orientation will constrain the directions you can move the roof faces in the next section to those parallel or perpendicular/normal to the building orientation.

  3. At the bottom of the map pane, click the grid button.

    Editing grid

    This enables the editing grid, but it isn't visible until you set the origin.

  4. Hover over the grid button, set the grid spacing to 1 ft, and click the Set Origin and Rotation button in the grid options menu.

    Grid settings

    The mouse pointer changes to a red plus sign.

  5. Hover over the vertex end of one of the long edges of the roof until the pointer snaps to the vertex. Click to set the grid origin.

    Set grid origin

    When you move the pointer, the grid shifts. To set the rotation, you'll add another point at the other end of the roof.

  6. Click the vertex at the other side of the long edge of the roof.

    Set grid rotation

    The editing grid is a useful reference surface for controlling alignment and distance when splitting or moving the vertices of a mulitpatch feature, or for any common editing tasks in ArcGIS Pro. The X/Y/Z vertex editing handles also respect the rotation of the editing grid, when present; otherwise, they align with north/south. This can extrude facades and other details in the wrong direction.

  7. At the bottom of the map pane, click the grid button to turn off grid visibility.

    Even though you can't see the grid anymore, its settings remain valid for any future edits you make in the project.

  8. On the ribbon, click Clear and save your edits.

Create a hip roof form

Once you have a flat roof surface and modified editing constraints, you'll use the Vertices editing tool to split the face and create a hip shape roof form.

  1. In the Modify Features pane, click Change the Selection and choose the Old Botany building.
  2. Hover over the middle of the short edge of the roof until an orange X appears.

    Orange X

    The orange X indicates the center of that edge. To create the hip roof form, you'll split the top of the roof in half.

  3. Click the X to add a vertex, hover over the middle of the opposite edge, and click again on the orange X to complete the split line through the center of the flat roof.

    Split roof

  4. Click the green editing sphere on the newly-created roof split line and press Tab. Type 17 ft as the distance and press Enter.
  5. Create a horizontal split line on the shorter side facade by clicking each edge of the eave. Repeat this on the other side of the building.

    Add horizontal split lines

  6. Double-click one of the two top edges of the roof (an orange circle appears as you hover over the edge vertex) to show the X/Y/Z vertex editing handles.

    Add editing handles

  7. Click the blue handle and press Tab. Type 16.75 ft (positive or negative) in the distance text box and press Enter. (The values can be positive or negative, depending on the side you start from.)
  8. Repeat the process on the other roof edge vertex, again using a value of 16.75 ft.

    Hip roof form

    Now that the basic hip roof shape is in place, you'll extend each of the four roof planes away from the center of the building, creating overhangs, or eaves, on each side. You'll also leave a small flat surface on the top edge of the hip, where some terra cotta tiles are part of the design of Old Botany.

  9. Hover over one of the two smaller side roof surfaces and click the green editing handle. Press Tab, type a value of 1.5 ft, and press Enter.

    Overhang

    The roof is extended to create a 1.5 foot overhang. Be sure that the movement of the roof plane is along the horizontal editing constraint indicated by the green arrow.

  10. Repeat the process to pull each roof surface out, creating a 1.5 foot overhang all the way around.

    As a byproduct of creating the overhanging roof, a large flat area was created on its top edge. You'll now correct that, leaving a 1-foot wide strip where you'll later apply a terra cotta color.

  11. Using the Edit Vertices tool, double-click one of the four top corners of the flat surface on the top edge of the roof. Click the red editing handle and move it toward the center, or press Tab and type a value of 1 ft (one side will be positive, one will be negative), and press Enter.

    Move flat top of roof

  12. Repeat the process to move all four vertices of the flat portion of the roof.

    The final roof form will have a small flat surface on top, a 1.5-foot overhang, and perfect symmetry.

  13. Turn on the PSU LiDAR 2017 layer to see how the facade measurements match the building shape represented by the lidar point cloud.

    Check lidar

    Unlike Oswald Tower, Old Botany has lots of vegetation surrounding it. This won't affect the roof form.

  14. Clear any active selections. On the Edit tab, in the Manage Edits section, click Save.

You may not be fortunate enough to have lidar data readily available to determine your building's height. In this case, you can directly input measured distance and height values to create a 3D building. Even when you do have lidar data, entering values manually is the best way to ensure feature symmetry, for example, between the two sloping sides of the Old Botany building's hip roof.

Add facade textures

Now that the basic form for the Old Botany building is in place, you can start texturing it. As you did in the first lesson, you'll use a combination of single textures and repeating tiled textures to give the model a realistic appearance.

  1. On the ribbon, on the Edit tab, in the Features group, click Modify.
  2. In the Modify Features pane, expand the Reshape group and click Multipatch Texture.
  3. Click the Old Botany building to select it.
  4. Click Load Texture, browse to the Textures folder in the lesson data, select OldBotany_Front.jpg, and click Open.
  5. Click the front facade of Old Botany (the long side that has a pathway leading up to it).

    Front facade

  6. Use the Pan, Rotate, and Zoom controls to fit the front image as closely as possible to the front facade extent.
  7. Once the front facade image is placed accurately, click Load Texture and add OldBotany_Back.jpg.
  8. Rotate Old Botany around to the other side and click the rear facade surface.
  9. Use the Pan, Rotate, and Zoom controls to fit the rear facade image as closely as possible to the back of the building.

    Next, you'll add textures to the sides of the building. The left side (with the split pathway) has a door, while the other side doesn't.

  10. Add the OldBotany_RightSide texture to the right side of the building. Line up the brick/stone textures as closely as possible.

    Brick-stone line texture

  11. Add the OldBotany_LeftSide texture to the left side of the building.
  12. When you're satisfied with the look of the sides, click Apply and save your edits.

    With the facade sides complete, you'll repeat the texturing process on the sloped roof surfaces of Old Botany.

  13. Click Load Texture and open OldBotany_Roof.jpg.
  14. Click the front roof surface to select it, and use the Pan, Rotate, and Zoom buttons in the image preview window to fit the roof image as accurately as possible.

    Add front roof

  15. When the front roof surface is finished, click the rear roof surface to duplicate this texture, retaining the same scaling and placement.

    The front and back sides of the roof have distinctive dormer window features that need to be positioned in specific locations, making a single texture image preferable to a repeating texture. However, two sides of the roof have a uniform pattern of shingles that can be applied via a single repeating, tiled texture image. This tiled image was clipped out from a small section of front roof texture.

  16. Click Load Texture and open OldBotany_RoofShingles.jpg.
  17. Click one of the side roof surfaces, and use the Pan, Rotate, and Zoom buttons in the image preview window to fit the shingles as accurately as possible, matching the size and spacing of the shingles on the edge of the other textured roof surfaces.
  18. When one of the roof sides is textured accurately, click the opposing side to duplicate this texture, retaining the same scaling and rotation.

    Roof shingles

    The last uncovered piece of the roof is the long flat strip at the top of the roof. On the original building, this is a terra cotta tile feature. You'll make it a similar color.

  19. In the Modify Features pane, next to the Load Textures button, click the color selector. Choose Cocoa Brown or a similar red-brown color and click the top roof edge to apply it.

    Terra cotta roof feature

    Cocoa Brown is close to a terra cotta color, but you can also look online for textures and apply an actual terra cotta image.

  20. Use the color menu to apply a dark grey color to the areas under the eaves.

    Shadow under the eaves

  21. Clear any active selections. On the Edit tab in ArcGIS Pro, in the Manage Edits section, click Save.

Image textures add a specific look and feel to the generic residential-looking 3D form, transforming it into a recognizable replica of the Old Botany building. You'll now add the signature rooftop eyelid dormers using the same editing tools.

Add eyelid dormers

The eyelid dormers on Old Botany are a signature architecture feature that are important to recreate on a realistic model. They are a challenge to model accurately but use the same 3D multipatch editing tools you've been using.

  1. On the Edit tab, in the Tool group, click Vertices, and select Old Botany Building.
  2. Using the rooftop imagery and the editing constraints as a guide, create a triangle around one of the dormers, snapping back to the origin vertex using the orange circle as a guide.

    Triangle dormer window cutout

    As you create the feature, note the approximate length of each side, so that you can repeat the same approximate shape for each dormer.

  3. Click the green editing handle of the dormer triangle and pull the surface upward along the green (vertical) editing constraint arrow. Press Tab to set a value of 2 ft and press Enter.

    Extrude the dormer window

    You may need to rotate the building to a sidelong angle to see this editing handle.

  4. Using the center snapping guide (the orange X), split the dormer vertically in half. Use the center snapping guide to click the midpoint of the long side of the triangle and split each half vertically again to create four parts.

    Split the window into fourths

  5. Double-click the lower left vertex of the dormer window, use the green editing handle to move it down, and press Tab to set a value of -2 ft.
  6. Repeat this process on the lower right vertex so that both outside corners of the window touch the roof again with a bulge in the middle.

    Dormer window sides

  7. Double-click each of the two middle vertices of the dormer, press Tab, and set a value of -0.6 ft.

    Create eyelid shape

    The center vertex is still at a height of 2 feet, so the slight depression of the sides creates a more rounded, half-circle shape. The window now has its signature eye-shaped surface. Though the window texture is currently reflected on the top of the window, you'll change the textures when you're finished creating all four dormer windows.

  8. Double-click each of the three rear vertices of the eyelid, and use the red editing handle to drag them back to meet the surface of the roof (or press Tab and set a value of 2 ft).

    Fit the top of window to the roof

    On the back of the building, these values will be negative.

  9. Once you have the first eyelid dormer shape completed, repeat the process with the three remaining rooftop dormers.

    Eyelid shaped windows

  10. In the Modify Features pane, click the back button and click the Multipatch Texture tool.
  11. Click Load Texture and choose OldBotany_DormerWindows.jpg.
  12. Click the front face of one of the dormer eyes to apply the texture. Use the Pan, Rotate, and Zoom buttons to fit the texture as closely as possible.

    Window texture

    The windows are still visible as stretched textures on top of each dormer. You'll fix the top of the windows using the same repeating roof shingle texture that you used on the sides of the roof.

  13. Click the Load Texture button and choose OldBotany_RoofShingles.jpg.
  14. Click one of the top dormer surfaces to apply the shingle texture. Use the Pan, Rotate, and Zoom buttons to fit the texture as closely as possible, matching each surface texture to the one next to it. (It's helpful to start on one of the left or right edges of the dormer so you can better match the shingle size with the main roof surface using the Zoom button.)

    Finished dormer windows

  15. Repeat the process for the remaining dormers of Old Botany.
  16. In the Modify Features pane, click Apply. On the ribbon, in the Manage Edits group, click Save.

Add stair and front door details

For added realism, you'll recess the doors and 3D stairs. These fine details can be created using the same vertices editing tools you've been using.

  1. Zoom close to the front door and stairs of Old Botany.
  2. On the Edit tab, click Vertices and select the front facade.
  3. Using the perpendicular and parallel editing constraints, cut out a block that matches the extent of the stairs.
  4. Using the Vertices tool, use midpoint snapping to split this face into four stairs. Then pull each stair out so that each is 1 foot deep (press Tab to set the exact value for each stair).

    Front stairs

    The stair textures mirror the door. You'll correct that next by applying a solid grey color that mimics concrete.

  5. In the Modify Features pane, click the back button and choose the Multipatch Texture tool.
  6. Using the color menu, choose a dark grey color and apply it to each stair face.

    Concrete colored stairs

    You can use a lighter shade of grey for the top and a darker shade for the side of each stair for contrast. To finish Old Botany, you'll recess the front door slightly for a more realistic look.

  7. On the Edit tab, choose Vertices and select the front facade.
  8. Use the Vertices tool to cut out the door, using the facade texture as a guide, finishing on the same vertex where you began.

    Door cutout

    Note:

    To get around the arch of the door, you can add several vertices connected by short line segments that mimic a curve.

  9. Push the green editing handle approximately 1.5 feet toward the inside of the building.

    If you use Tab, note that the value is negative. Notice that the brick texture wraps around the corner of the doorway.

    Recessed doorway

  10. Clear any active selections and click Save to save the project.

    The windows of the building are similarly recessed. To make the building more detailed, you can use the same process to push each feature in 0.5 feet. After that, you can pull out the window ledges and window air conditioning units. Depending on how realistic you want your building to look, there are hundreds of additional edits you can make.

In this lesson, you learned how to create the more complicated roof forms and features that are common to many residential buildings: splitting a flat roof, pulling it into a gable, and moving individual vertices to achieve the final hip form. By adding the signature eyelid dormers, recessed doorway, and entry stairs to Old Botany, you now have features that separate a simple 3D building model from a detailed and realistic one.

This process can be used for many building types and shapes, with little more than a building footprint, height information, and images for texturing.

You can find more lessons in the Learn ArcGIS Lesson Gallery.