Create a geodatabase project

At its most basic level, the geodatabase is a container for storing spatial and attribute data and the relationships that exist among them. In a geodatabase, features and their associated attributes can be structured to work together as an integrated system using rules, relationships, and topological associations. In other words, the geodatabase allows you to model the real world in a simple or complex manner as needs dictate.

Create an ArcGIS Pro project for a geodatabase

The organization and structure of a geodatabase are generally referred to as its schema. Before developing a geodatabase schema for use by Salzburg tourism agencies, it would be useful to investigate a generic basemap schema that can be deployed by organizations and agencies when requirements call for them to manage a specific collection of base or source data.

While there are several methods for creating a geodatabase, for this lesson, you'll start by creating an ArcGIS Pro project from a template that includes a geodatabase. When you create a new project, a new file geodatabase is automatically created and set as the default geodatabase. This geodatabase will store the data used by the Salzburg tourism agencies to support their mapping efforts.

Note:

The current trend is for cities, organizations, and agencies to maintain their own unique or proprietary data and supplement it with published and publicly available basemaps, map services, and other authoritative data sources such as those available in ArcGIS Living Atlas of the World.

  1. Go to the Get Started with Geodatabases group.

    Get Started with Geodatabases group

  2. Scroll down until you see the Sample Basemap GDB Schema thumbnail. Click Download to download the zip file.

    Sample Basemap GDB Schema

  3. Click the SalzburgData thumbnail to download it.

    SalzburgData thumbnail

  4. Extract the contents of the files to a location of your choice (for example, C:\Salzburg).
  5. Open ArcGIS Pro.
    Note:

    If you don't have ArcGIS Pro or an ArcGIS account, you can sign up for an ArcGIS free trial.

    ArcGIS Pro opens to the start page.

  6. Click Settings and choose Options.

    The Options pane appears.

  7. In the Options pane, click Metadata.
  8. For Metadata style, choose FGDC CSDGM Metadata.

    Metadata style option

    The ArcGIS platform defaults to a basic metadata style known as Item Description, but you can update and modify the style to one of various additional styles. One such style is the FGDC CSDGM Metadata style, which allows you to view and edit full metadata and is a well-known metadata content standard that has been used in North America and around the world for many years.

  9. Click OK.
  10. Click the Back button to return to the start page.
  11. If necessary, sign in using your licensed ArcGIS account.
  12. Under New, click Catalog.

    Catalog template on start page

    ArcGIS Pro provides a few blank project templates to help you get started.

    • To build a 2D map, select the Map template.
    • To create a 3D global scene, select the Global Scene template.
    • To start with a 3D local scene, select the Local Scene template.
    • To start with the Catalog view, select the Catalog template.

    If data management is your primary focus, consider pinning this project to the start page or opening it automatically when you start ArcGIS Pro. Since your primary focus for this lesson is data management, the Catalog template is a good choice.

  13. For Name, type SalzburgGeodatabase.
  14. For Location, browse to and select the location of your downloaded project content (for example, C:\Salzburg).

    It is often helpful to create a dedicated folder for your project. Each new project includes a project file (.aprx), a default geodatabase, and a toolbox. Organizing these together in a single folder makes it easier to find, share, and store your project and data.

  15. Ensure that Create a new folder for this project is checked and click OK.

    Create a New Project window

    The project opens and displays the Catalog view.

  16. On the ribbon, click the View tab. In the Windows group, click Reset Panes and choose Reset Panes for Mapping (Default).

    Reset Panes for Mapping option

    This ensures that the Contents and Catalog panes are open and that other panes are closed.

    Contents pane, Catalog view, and Catalog pane

    The Catalog view allows you to access all items associated with a specific project in one place, whether they are available from a local or network computer, ArcGIS Online, or an ArcGIS Enterprise portal, as you build your project by adding maps, scenes, layouts, connections to folders, and geodatabases. From the ribbon, you can open several Catalog views and use them to compare the contents of databases or folders, compare metadata for two items, copy style items from one style to another, and so on.

    The Contents pane displays the contents of the active view. When a map view is active, the Contents pane displays the layers in the map. When the Catalog view is active, as it is now, the Contents pane displays the contents of the project, including collections of project items (toolboxes, databases, and so on), portal connections, and favorites.

    The Catalog pane is similar to the Catalog view but operates independently and is designed for different tasks. In both the pane and the view, you can manage and browse data. If the Catalog pane is good for quick access, the Catalog view is better for more in-depth data management tasks and has associated ribbon tabs with management functionality. In addition, the Catalog view displays item details in columns and gives access to metadata.

    In these lessons, you'll use the Catalog view and its associated Contents pane. You won't need the Catalog pane.

    Tip:

    Think of the Catalog pane as a light version of the Catalog view that offers access to project-related components through its Project, Portal, and Favorites tabs.

  17. Close the Catalog pane.
    Tip:

    You can reopen the Catalog pane at any time by clicking the Catalog Pane button on the View tab of the ribbon.

  18. In the Contents pane, click and expand Databases.

    SalzburgGeodatabase.gdb was created automatically when you created the project. Before you explore the Catalog view, you'll create a folder connection to easily access your lesson resources.

  19. In the Contents pane, click Folders.
  20. On the ribbon, click the Catalog tab. In the Create group, click Add and choose Add Folder Connection.

    Add button

  21. In the Add Folder Connection browser, browse to your extracted data folder (for example, C:\Salzburg) and click OK.

    A folder connection is a shortcut to locating important data and project-related materials.

  22. In the Contents pane, expand Folders.

    Contents pane with Folders collection expanded

    The project contains two folder connections. SalzburgGeodatabase is the folder that contains the project (also called the home folder). This folder connection was created automatically. The Salzburg folder connection is the one you just added.

  23. Save the project.

In this lesson, you generated a project to support populating a geodatabase and modified the project default metadata style from Item Description to FGDC CSDGM Metadata. Next, you'll evaluate various data sources to include in your geodatabase.


Evaluate data sources

Typical data quality criteria to note when evaluating a data source are relevance to your purpose; geographic extent; projection; currency; data and metadata standards; data lineage; spatial operations performed on data, including sampling, processing, modeling and analysis, accuracy, and completeness; and relevant attributes.

Evaluate data sources

Next, you'll evaluate potential data sources that will be migrated to the Salzburg geodatabase. These data sources include shapefiles and KMZ files.

  1. If necessary, open your project.
  2. In the Contents pane, expand the Salzburg folder connection and the Salzburg subfolder under it. Click the City_of_Salzburg subfolder.

    Item details

    Note:

    In the previous lesson, you made a folder connection to the Salzburg folder on your C:\ drive. This folder contains both the SalzburgGeodatabase project folder and a folder named Salzburg that was included in the data you downloaded. Your folder structure may look different if you extracted the data to a different location.

    The Catalog view updates to display the collection of shapefiles representing data for the city of Salzburg. Additional details about these shapefiles are listed in the Name, Type, and Date columns. To sort content by any of these columns, click the Sort button and choose an option. (Alternatively, click a column heading in the Catalog view.) In addition to item details, the Catalog view also provides access to information that describes an item, known as metadata.

    Note:
    In the Catalog view, metadata appears in a details panel, which you can show or hide. To show or hide the details panel, click the View tab on the ribbon. In the Options group, click Details Panel. (Alternatively, click the Show/Hide Details Panel button at the bottom of the Catalog view.)

    The City_of_Salzburg folder contains 30 shapefiles that tourism agencies can use to update maps and create new apps. Before deciding which data sources to keep or which to replace with data from other sources, you should access and review each potential data source.

  3. In the Catalog view, click BicyclePaths.shp.
  4. If necessary, click the Show/Hide Details Panel button at the bottom of the Catalog view to display the metadata.

    The Metadata tab displays detailed information about the shapefile.

    Shapefile metadata

    The metadata includes information about use limitations, credits, and the spatial reference.

    Review limitations and spatial referencing.

    The spatial reference is defined as follows:

    • Geographic coordinate reference—GCS_MGI
    • Projection—MGI_Austria_GK_M31

    Metadata is crucial in assessing the usefulness and relevance of a data source when developing a geodatabase.

    Learn more about viewing and editing metadata.

  5. Click the Geography tab to display the spatial data contained in the shapefile. If necessary, pan and zoom the map.

    Geography tab

  6. Click the Table tab to display the attribute fields and values for bicycle path features.

    Table tab

    Metadata plays an important part in documenting your content and the project items you create and use. These may include maps, projects, geoprocessing models, and geodatabase datasets.

    Note:

    Metadata is stored with the item it describes: in the geodatabase for geodatabase items such as feature classes, in the project for project items such as maps, and in the file system for file-based items such as CSV files or spreadsheets. Metadata managed by ArcGIS is copied, moved, and deleted with its associated item.

  7. Review the Metadata, Geography, and Table tabs for Museums.shp.

    These are locations that are often visited by tourists, and this layer is important to maintain and keep up to date. The spatial reference for this data source is defined as follows:

    • Geographic coordinate reference—GCS_MGI
    • Projection—MGI_Austria_GK_M31

    The table for this data source contains attribute fields that include the museum name and address, which will both be useful in tourism applications.

  8. Review the metadata for ReligiousMonuments.shp.

    This metadata appears to be fairly complete, but notice when you review the geography and the table that the shapefile contains no features. As a result, this data source may be rejected.

  9. In the Contents pane, under Folders, click the kmz-files subfolder.

    The folder contains three KMZ files that would be useful for tourism agencies. A KMZ file is a compressed Keyhole Markup Language (KML) file that can be displayed by any KML client, including ArcGIS Pro.

    Folder for KMZ files

    Note:

    KML is a common format for sharing geographic data with non-GIS users, as it can be easily delivered on the internet and viewed in a number of free applications. KML files have an XML-based format and can have either a .kml or .kmz (for compressed or zipped KML files) file extension. You can use either extension in ArcGIS Pro.

  10. In the Catalog view, click Kunstwerke_mit_Audiotext.kmz.

    The features in this KML file represent the location of several significant open-air and indoor art installations that may be searched and visited by tourists interested in the work of specific artists.

    Note:

    A single KML file can be composed of point, line, and polygon features and raster imagery, or a combination of these. KML can also contain related content such as graphics, pictures, attributes, and HTML. By contrast, datasets in ArcGIS are typically composed of homogeneous elements—for example, point feature classes contain only points.

  11. Review the metadata for Kunstwerke_mit_Audiotext.kmz.

    KMZ metadata

    In this case, the KMZ file has no useful metadata. However, because KMZ files are intended for use in web applications, they are typically referenced to the WGS84 coordinate system; therefore, some information is known about the data source.

  12. Review the geography for Kunstwerke_mit_Audiotext.kmz.

    KMZ file content

    The features displayed do not scale well and appear faded as you zoom in and out on the map. This is because the KMZ file includes its symbology and other layer properties (such as pop-up information) in the file.

  13. Review the table for Kunstwerke_mit_Audiotext.kmz.

    Because you are displaying the unconverted KMZ content as a layer, you are not able to access tabular information. KMZ uses a tag-based structure with nested elements and attributes and is based on the XML standard. To edit and modify the data, you would need to convert the KMZ file into a geodatabase feature class.

  14. In the Contents pane, under Folders, click the OpenStreetMap_Salzburg subfolder.

    This folder contains a collection of free OpenStreetMap data for Salzburg in shapefile format that would be useful for building tourism maps and apps. The data is collected and built by volunteers and released with an Open Content License. The OpenStreetMap License allows free access to map images and all underlying map data.

    Learn more about OpenStreetMap map features.

  15. In the Catalog view, click OSM_Salzburg_Amenities.shp. On the Metadata tab, review the spatial reference information.

    Amenities spatial reference information

    This data source has comprehensive metadata that makes it useful for your purposes. However, the spatial reference has its geographic coordinate reference set to GCS_WGS_1984 and its projection defined as WGS_1984_Web_Mercator_Auxiliary_Sphere. This is not a desirable projection if you want to accurately determine distances, measure areas, and compare shapes.

  16. On your own, review some additional OpenStreetMap data sources. Be sure to check if these sources have the same spatial reference.
  17. Save the project.

Next, you'll import the geodatabase schema for a generic basemap using an XML Interchange file. Using the basemap, you'll explore geodatabase objects before updating the metadata for your Salzburg geodatabase. Updating the metadata is a preparatory step to migrating data sources from their current format and spatial reference into a suitable spatial reference for use in tourism maps and apps.


Create a geodatabase schema

The geodatabase storage model is based on a series of relational database concepts and uses an underlying database management system (DBMS). The DBMS provides the storage structure, indexing, backup and rollback mechanisms, and security model. DBMS tables and well-defined attribute types are used to store the schema, rule base, and spatial attribute data for each geographic dataset. This approach provides a formal model for storing and working with your data.

Review geodatabase objects

In this lesson, you'll start by reviewing the schema for a generic basemap to gain insight into geodatabase components such as feature classes, feature datasets, and stand-alone tables that are used to organize and manage data. Then, you'll convert and import various datasets to create and update the schema of your Salzburg geodatabase. See What is a geodatabase? and Fundamentals of the geodatabase to learn more.

You'll start by importing the schema of a basemap geodatabase from an XML Interchange file.

  1. If necessary, open your project.
  2. In the Contents pane, click Databases.

    The default SalzburgGeodatabase.gdb was created automatically when you created the project. You'll populate this database with your Salzburg source data. In the next step, however, you'll create an additional geodatabase to explore geodatabase components.

  3. On the ribbon, under Manage, click the Databases tab. In the Project group, click New File Geodatabase.

    New File Geodatabase button

  4. In the New File Geodatabase browser, for Name, type SampleBaseMapGDB.gdb. Confirm that the geodatabase will be created in the SalzburgGeodatabase folder. Click Save.

    New File Geodatabase window

    Next, you'll import a basemap geodatabase schema from an XML document into SampleBaseMapGDB.gdb. This is not always necessary, but in this case you need to review a common geodatabase design and geodatabase objects and also explore how XML workspace documents can be used to share your own geodatabase schemas in the future.

  5. In the Contents pane, expand Databases, if necessary, and click SampleBaseMapGDB.gdb.
  6. On the ribbon, click the Catalog tab. In the Create group, click Import and choose XML Workspace Document.

    XML Workspace Document option

    The Geoprocessing pane appears and opens the Import XML Workspace Document geoprocessing tool.

    Note:

    This tool requires an ArcGIS Pro Standard license or an ArcGIS Pro Advanced license. (If you are using ArcGIS trial software, you have an ArcGIS Pro Advanced license.) If you have an ArcGIS Pro Basic license, you can continue with the section Document and prepare the Salzburg geodatabase. To check your license, click the Project tab on the ribbon. On the Settings page, click the Licensing tab.

  7. In the Import XML Workspace Document tool, for Import File, click the Browse button.
  8. In the Import File browser, browse to C:\Salzburg (or your data location) and select SampleBasemapGDB.xml. Click OK.

    Import File browser

  9. For Import Options, choose Import schema only. Click Run.

    Import XML Workspace Document tool parameters

    When the tool finishes, a completion message appears at the bottom of the Geoprocessing pane.

  10. In the Contents pane, right-click SampleBaseMapGDB.gdb and click Refresh.
  11. In the Catalog view, review the SampleBaseMapGDB.gdb contents.

    Geodatabases are composed of a collection of system tables plus user data. User data can be stored in the following types of datasets:

    • Feature class
    • Feature dataset
    • Mosaic dataset
    • Raster dataset
    • Table (nonspatial)

    In addition, feature classes and tables can include subtypes and have domains associated with them. You may also notice attachments and relationship classes in the geodatabase.

    Imported geodatabase objects

    In this geodatabase, feature classes are thematically organized into feature datasets named Administrative, Cultural, and so on. The geodatabase also includes a toolbox that can be used to store user-created geoprocessing tools, scripts, and models.

    Feature datasets can contain feature classes as well as the following types of datasets:

    • Trace networks
    • Network datasets (requires ArcGIS Network Analyst extension)
    • Terrains (requires ArcGIS 3D Analyst extension)
    • Topologies

  12. In the Catalog view, double-click the Administrative feature dataset to display its contents.

    Since this is a basemap geodatabase schema, the Administrative feature dataset contains several line and polygon feature classes designed to store and maintain boundary lines and polygons for administrative areas.

    Contents of the Administrative feature dataset

  13. In the Contents pane, click SampleBaseMapGDB.gdb. In the Catalog view, click the PointsOfInterest feature class.

    Feature class representing points of interest in the Catalog view

    The PointsOfInterest feature class is a stand-alone feature class that is not organized in a feature dataset. It has an associated attachment table, PointsOfInterest__ATTACH, capable of containing images and related documents and links for each point in the feature class. Attachment functionality provides a powerful way to associate nongeographic data with your geographic information. In this case, a relationship class named PointsOfInterest__ATTACHREL is used to maintain a link between the points and their related attachments.

    Learn more about attachments

  14. In the Catalog view, click the Slopemap raster dataset.

    Geodatabase rasters

    The Slopemap object represents a raster dataset that is a single raster or image data layer. It is also possible to create mosaic datasets in geodatabases. Mosaic datasets are used to manage, display, serve, and share collections of raster data.

  15. Click HistoricSitesDescriptions.

    This object represents a nonspatial geodatabase table that can contain descriptions, codes, and other data that can be associated with spatial features as needed.

    You imported the XML workspace document into SampleBaseMapGDB.gdb to explore and review a typical basemap design. You will not use this geodatabase again in the lesson.

  16. In the Contents pane, click SampleBaseMapGDB.gdb if necessary.
  17. On the ribbon, on the Catalog tab, in the Organize group, click Remove.
    Note:

    Removing the geodatabase only removes the selected item from the project. All project references to the item are removed, but the item remains on disk.

    Now that you have reviewed the sample basemap geodatabase schema, you are ready to proceed with populating your own tourism geodatabase.

Document and prepare the Salzburg geodatabase

In preparation for populating the Salzburg geodatabase, you'll edit and update your geodatabase metadata.

  1. In the Contents pane, under Databases, right-click SalzburgGeodatabase.gdb and choose Edit Metadata.

    Edit Metadata option

    A metadata view appears.

    Item description metadata element in Catalog view

    The Contents pane also updates to display metadata categories. For SalzburgGeodatabase.gdb, three metadata groups are defined: Overview, Metadata, and Resource. Each group contains a number of metadata elements. Elements required by the metadata style (in this case, FGDC CSDGM) are marked with a red x if they are incomplete.

    Learn more about editing metadata and creating FGDC CSDGM metadata.

    Metadata categories

    Next, you'll populate the item description element.

  2. In the Contents pane, under Overview, confirm that Item Description is selected.
  3. In the metadata view, update the following information:

    • For Title, type (or copy and paste) Salzburg Tourism Geodatabase.
    • For Tags, type Salzburg, Austria, Visitor map, Tourism, Tourist, Visitor guide, Food, Activities, Attendees, Places to visit, Places to eat, Bike Routes, Ski Resorts, Museums, Art, Castles, Cathedrals.
    • For Summary, type Collection of data for the city and surrounding areas of Salzburg Austria.
    • For Description (Abstract), type Geodatabase to store and manage a collection of spatial and attribute data that can be used by tourism agencies in the city of Salzburg, Austria to develop updated web maps and apps.

  4. For Credits, type the following information:

    • STADT: SALZBURG https://maps.stadt-salzburg.at/
    • National Mapping Agency - Federal Office for Metrology and Surveying (BEV) https://www.bev.gv.at
    • Austrian Map online
    • Land Salzburg - Open Government Data (OGD) - https://service.salzburg.gv.at/ogd/client/ and https://www.salzburg.gv.at/sagis/
    • Austrian OGD basemap https://www.basemap.at/index_en.html

  5. Set Appropriate Scale Range to 1:50,000 to 1:5,000.

    Scale range

  6. Click the add button to display and update the Bounding Box information. Add the following information:

    West

    12.058153

    East

    14.008495

    South

    46.938376

    North

    48.042424

    Bounding box values are useful for published layers and maps, as web applications display at the box extent and not the whole world.

    Tip:

    When you author or update metadata content for an ArcGIS item, record the information that is important for your organization to know about that item. This might include how accurate and recent the item is, restrictions on using and sharing the item, important processes in its life cycle such as generalizing features, and so on.

  7. On the ribbon, on the Metadata tab, in the Manage Metadata group, click Save.
  8. Close the metadata view.
  9. In the Contents pane, right-click SalzburgGeodatabase.gdb and choose View Metadata.

    The Catalog view details panel displays the updated metadata for your Salzburg Tourism geodatabase.

    Geodatabase metadata

    When care is taken to provide good descriptive information, you can find items with a search and evaluate which item in your search results is the correct one to use. You can improve communication and have confidence in making decisions based on an item's geospatial information. You can archive projects knowing they can be recovered, used, and evaluated in the future.

  10. Save the project.

Next, you'll start to migrate several data sources from the City_of_Salzburg, KMZ files, and OpenStreetMap_Salzburg folders into SalzburgGeodatabase.gdb.


Populate the geodatabase

Researching current tourism maps and online information for the city of Salzburg gives a good indication of which data themes various tourism agencies and private companies need to best serve visitors. These offer a good guideline for what data to add to your geodatabase. Keep in mind that most of the feature classes you build and later symbolize will most likely be displayed on current basemap layers published in ArcGIS Living Atlas of the World and other sources. Your feature classes will complement and supplement existing base data and serve to add value to the interactive web maps and apps that agencies may generate and publish.

The most popular maps and data used for Salzburg tourism include the following items:

  • Detailed city map showing streets, pedestrian areas, and buildings
  • Sightseeing map with tourist highlights
  • Map with locations for markets and exhibitions
  • Bus and rail stops and routes
  • Creative walks, including architecture, museums, art galleries, churches
  • Foot and cycling paths
  • Beer routes, including breweries and taverns
  • City and nature hiking trails
  • Hotel maps

Create feature datasets

While working with your geodatabase, you can create empty feature datasets directly from the geodatabase. You'll start by creating feature datasets for the following four data themes:

  • City_Attractions
  • Transportation
  • Scenic_Attractions
  • Trails

  1. If necessary, open your project.
  2. In the Contents pane, expand Databases if necessary. Right-click SalzburgGeodatabase.gdb, point to New, and click Feature Dataset.

    Feature Dataset option

    The Create Feature Dataset geoprocessing tool opens. By default, Output Geodatabase is set to SalzburgGeodatabase.gdb.

  3. In the Create Feature Dataset tool, for Feature Dataset Name, type City_Attractions.
  4. For Coordinate System, click the Select Coordinate System button.

    The simplest way to define the coordinate system for a geodatabase object is to import it from a current data source.

  5. On the Coordinate System dialog box, click the Add Coordinate System button and choose Import Coordinate System.

    Import Coordinate System option

  6. In the Import coordinate system browser, browse to the City_of_Salzburg folder (located, for example, at C:\Salzburg\Salzburg\City_of_Salzburg). Select BicyclePaths.shp and click OK.

    Import coordinate system browser

  7. In the XY Coordinate Systems Available list, confirm MGI Austria GK M31 is selected and click OK.

    Coordinate System window

  8. In the Create Feature Dataset tool, verify the parameters and click Run.

    Create Feature Dataset tool parameters

    When the tool finishes, the City_Attractions feature dataset is added to the SalzburgGeodatabase.gdb geodatabase.

    Note:

    In Austria, the official projected coordinate system used for cadastral data is MGI Austria GK Central, which is a Transverse Mercator projection. However, individual Austrian states, such as the one that includes the city of Salzburg, apply a shift (false easting) to avoid negative values and therefore use a custom coordinate system known as MGI Austria GK M31.

  9. In the Contents pane, click SalzburgGeodatabase.gdb.
  10. In the Catalog view, right-click the City_Attractions feature dataset and choose Edit Metadata.
  11. In the City_Attractions metadata view, make the following updates:

    • For Title, type (or copy and paste) Salzburg City Attractions.
    • For Tags, type Salzburg, Austria, City Attractions.
    • For Summary, type Collection of Salzburg visitor attractions.
    • For Description (Abstract), type Location of various city sites commonly visited by tourists in Salzburg Austria.
    • For Credits, type the following information:
      • STADT: SALZBURG https://maps.stadt-salzburg.at/
      • National Mapping Agency - Federal Office for Metrology and Surveying (BEV) https://www.bev.gv.at
      • Austrian Map online
      • Land Salzburg - Open Government Data (OGD) - https://service.salzburg.gv.at/ogd/client/ and https://www.salzburg.gv.at/sagis/
      • Austrian OGD basemap https://www.basemap.at/index_en.html
    • Set Appropriate Scale Range to City (1:50,000) to Buildings (1:5,000).
    • For Bounding Box, set the following values:

      West

      12.058153

      East

      14.008495

      South

      46.938376

      North

      48.042424

  12. On the ribbon, on the Metadata tab, in the Manage Metadata group, click Save.
  13. Close the City_Attractions metadata view.
  14. In the Catalog view, review the metadata.

    Feature dataset metadata

    Tip:

    If necessary, in the Contents pane, expand SalzburgGeodatabase.gdb. Right-click City_Attractions and choose View Metadata.

  15. In the Contents pane, click SalzburgGeodatabase.gdb.
  16. On the ribbon, on the Catalog tab, in the Create group, click New and choose Feature Dataset.

    New feature dataset

  17. In the Create Feature Dataset geoprocessing tool, set the following parameters:

    • For Output Geodatabase, confirm that the path is C:\Salzburg\SalzburgGeodatabase\SalzburgGeodatabase.gdb.
    • For Feature Dataset Name, type Scenic_Attractions.
    • For Coordinate System, import MGI Austria GK M31.

  18. Click Run.
  19. Create additional feature datasets for the following categories:

    • Transportation
    • Trails

    Since the geodatabase name and coordinate system are the same for all of these datasets, you can replace Scenic_Attractions with Transportation in the Feature Dataset Name box on the geoprocessing tool and run it again. Repeat the process for Trails.

  20. In the Contents pane, expand SalzburgGeodatabase.gdb if necessary, and verify the presence of the four feature datasets.
    Feature datasets
  21. Optionally, update the metadata for the additional feature datasets.

Import a single shapefile

You can add data to a geodatabase by importing and converting from source data formats into feature classes. First, you'll look at migrating shapefiles into the geodatabase. A shapefile is a legacy data format that is still popular but has limitations that hinder its use as an efficient data storage type. It is similar to a feature class and therefore directly maps to the geodatabase as a single feature class when you migrate it to the geodatabase.

  1. In the Contents pane, under SalzburgGeodatabase.gdb, right-click the City_Attractions feature dataset, point to Import, and choose Feature Class.

    Import feature class option

    Tip:

    An alternative is to click the Catalog tab on the ribbon. In the Create group, click Import and choose Feature Class.

    The Feature Class to Feature Class geoprocessing tool opens. This tool allows you to select a single data source to import into the geodatabase. In addition, you can rename the output feature class and choose which source attribute fields to retain or remove from the source data.

  2. In the Feature Class to Feature Class tool, for Input Features, browse to the OpenStreetMap_Salzburg folder and choose OSM_Salzburg_HistoricSites.shp.
  3. Confirm that Output Location is set to City_Attractions.
  4. For Output Name, type HistoricSites.
  5. At the bottom of the tool, expand Fields.

    In the Field Map section, the Output Fields list shows the attribute fields that will be copied to the output dataset. To exclude a field from the output dataset, select the field and click Remove. To remove multiple fields, press Shift+Ctrl to select the fields and click Remove on any field name.

  6. In the Output Fields list, keep the fields listed below and remove all the others:

    • HISTORIC
    • NAME
    • ADDR_HOUSE
    • ADDR_HOU00
    • ADDR_STREE
    • ADDR_CITY
    • ADDR_STATE
    • ADDR_POSTC
    • ADDR_PLACE

  7. Verify the parameters and click Run.

    Feature Class to Feature Class tool parameters

    Note:

    The coordinate system of the input shapefile is WGS_1984_Web_Mercator_Auxiliary_Sphere. When the shapefile is converted to a feature class in the City_Attractions feature dataset, its coordinate system is automatically reprojected to MGI Austria GK M31. As you'll see later, a feature dataset cannot contain a feature class that has a nonmatching coordinate system.

  8. In the Contents pane, right-click City_Attractions and choose Refresh.
  9. In the Catalog view, click HistoricSites.

    On the Metadata tab of the details panel, the original shapefile metadata has been copied to the new geodatabase feature class.

    Catalog view showing metadata for the HistoricSites feature class

    Tip:

    If the metadata isn't displayed, click the Show/Hide Details Panel button at the bottom of the Catalog view.

  10. In the Catalog view, right-click HistoricSites and choose Edit Metadata.

    Edit Metadata option

  11. In the metadata view, update the following information:

    • For Title, type Salzburg Historic Sites.
    • For Tags, type Salzburg, Austria, Historic sites.
    • For Summary, type Point features of historic sites in Salzburg Austria.
    • For Description (Abstract), type Location of historic sites in Salzburg Austria.
    • For Credits and Use Limitation, leave the default text, as these fields are populated from source metadata.
    • Set Appropriate Scale Range to City (1:50,000) to Buildings (1:5,000).

    Edited feature class metadata

  12. On the ribbon, on the Metadata tab, in the Manage Metadata group, click Save.
  13. Close the metadata view.

Export or import multiple feature classes to a geodatabase

Exporting or importing a single shapefile is useful if you need to convert only selected features and choose specific attribute fields to be copied to the output feature class. Sometimes it is necessary to batch convert multiple sources for quick conversion and spend time later removing unnecessary attribute fields.

  1. In the Contents pane, under Folders, browse to the City_of_Salzburg folder and select it.
  2. In the Catalog view, click Castles.shp, press the Ctrl key, and select Museums.shp and ReligiousMonuments.shp.
  3. Right-click Castles.shp, point to Export, and choose Feature Class(es) To Geodatabase.

    Feature Class(es) To Geodatabase option

    The Feature Class To Geodatabase geoprocessing tool opens. The input features are correctly set by default.

  4. In the Feature Class To Geodatabase tool, for Output Geodatabase, browse to and choose the City_Attractions feature dataset in SalzburgGeodatabase.gdb.

    Feature Class To Geodatabase tool parameters

  5. Click Run.
  6. When the tool completes, verify that the City_Attractions feature dataset in SalzburgGeodatabase.gdb contains four feature classes.

    Imported feature classes

  7. In the Contents pane, under SalzburgGeodatabase.gdb, right-click the Scenic_Attractions feature dataset, point to Import, and choose Feature_Class(es).

    Import Feature Classes tool

  8. In the Feature Class To Geodatabase geoprocessing tool, for Input Features, browse to and add the shapefiles in the following table.
    Note:

    You need to do this in two stages: first, browse to the City_of_Salzburg folder and add its shapefiles, and then browse to the OpenStreetMap_Salzburg folder and add its shapefiles.

    Source folder Source shapefile

    City_of_Salzburg

    NaturalParks.shp

    NatureReserves.shp

    Skilifts.shp

    SkiSlopes.shp

    SwimmingHoles.shp

    Waterbodies.shp

    Waterwheels.shp

    OpenStreetMap_Salzburg

    OSM_Salzburg_CableCar.shp

    OSM_Salzburg_CableCarStations.shp

    OSM_Salzburg_NaturalFeatureBoundaries.shp

    OSM_Salzburg_NaturalFeatures.shp

    OSM_Salzburg_ReceationSiteBoundaries.shp

    OSM_Salzburg_RecreationSites.shp

    OSM_Salzburg_Streams.shp

    Feature Class To Geodatabase tool parameters

    The Output Geodatabase parameter is correctly set by default to the Scenic_Attractions feature dataset.

  9. Click Run.
  10. When the tool finishes, in the Contents pane, click the Scenic_Attractions feature dataset.
  11. In the Catalog view, rename the feature classes as shown in the following table.
    Tip:

    To rename a feature class, right-click it and choose Rename. Alternatively, click the feature class to select it and click it again to make its name editable. Press Enter to commit your edit.

    Original nameNew name

    OSM_Salzburg_CableCar.shp

    CableCar

    OSM_Salzburg_CableCarStations.shp

    CableCarStations

    OSM_Salzburg_NaturalFeatureBoundaries.shp

    NaturalFeatureBoundaries

    OSM_Salzburg_NaturalFeatures.shp

    NaturalFeatures

    OSM_Salzburg_RecreationSiteBoundaries.shp

    RecreationSiteBoundaries

    OSM_Salzburg_RecreationSites.shp

    RecreationSites

    OSM_Salzburg_Streams.shp

    Streams

  12. Verify the Scenic_Attractions feature dataset contains 14 feature classes. (The number of items is shown at the bottom of the Catalog view.)

    Renamed imported feature classes

  13. Optionally, update metadata for Scenic_Attactions.
  14. Import the following shapefiles to the Transportation feature dataset.

    Source folder Source shapefile

    City_of_Salzburg

    BicyclePaths.shp

    BusLanes.shp

    OneWayStreets.shp

    Pavement.shp

    RoadNetwork.shp

    Sidewalks.shp

    Tunnels.shp

    OpenStreetMap_Salzburg

    OSM_Salzburg_Airports.shp

    OSM_Salzburg_PublicTransportStations.shp

    OSM_Salzburg_Railroads.shp

    OSM_Salzburg_RailroadStations.shp

    Feature Class To Geodatabase tool parameters

  15. When the tool finishes, in the Catalog view, rename the following feature classes:

    Original nameNew name

    OSM_Salzburg_Airports.shp

    Airports

    OSM_Salzburg_PublicTransportStations.shp

    PublicTransportStations

    OSM_Salzburg_Railroads.shp

    Railroads

    OSM_Salzburg_RailroadStations.shp

    RailroadStations

  16. Confirm that the Transportation feature dataset contains 11 feature classes.

    Transportation feature classes in the Catalog view

  17. Optionally, update metadata for the Transportation feature classes.

Import KML files

Several useful tourism-themed data sources are only available as KML files. You'll use the KML To Layer tool to convert a .kmz file to a file geodatabase.

  1. In the Contents pane, under Folders, browse to the kmz_files subfolder and click it.

    In the Catalog view, there are three .kmz files. These are compressed KML files.

    KMZ files in Catalog view

    Because you already have a museums layer in your geodatabase, you'll convert only the Burgen_und_Schloesser.kmz and Kunstwerke_mit_Audiotext.kmz files. These are features representing castles and palaces and the location of art installations by recognized artists.

  2. In the Geoprocessing pane, click the Back button.

    Back button in Geoprocessing pane

  3. In the Geoprocessing pane, search for kml.

    KML To Layer tool

    The KML To Layer tool should be the first result.

    The KML To Layer tool converts a KML file with its features, which are XML based, into a unique geodatabase specific to the KML file being converted. The features, such as points and polygons, are then added as separate feature classes to a Placemarks feature dataset within this geodatabase. After performing this conversion, you can use the geographic data in these feature classes from your KML file in the same ways you would use any other GIS data.

    Tip:

    The buttons at the bottom of the Geoprocessing pane allow you to display tools with descriptions (as shown above) or as a list.

  4. Click the KML To Layer tool.
  5. In the KML To Layer tool, set the following parameters:

    • For Input KML File, browse to the kmz-files folder and select Burgen_und_Schloesser.kmz.
    • For Output Location, specify your data folder, for example, C:\Salzburg.
    • For Output Data Name, type Castle_Palace.

    KML To Layer tool parameters

  6. Click Run.

    The tool creates an output file geodatabase named Castle_Palace.gdb and an output layer file named Castle_Palace.lyrx in your output folder location (for example, C:\Salzburg).

  7. Execute the KML To Layer tool a second time with the following parameters:

    • For Input KML File, browse to and select the Kunstwerke_mit_Audiotext.kmz file in the kmz-files folder.
    • For Output Location, specify your data folder, for example, C:\Salzburg.
    • For Output Data Name, type Art_Installations.

    KML To Layer tool parameters

  8. Click Run.

    The tool creates an output file geodatabase named Art_Installations.gdb and an output layer file named Art_Installations.lyrx in your output folder location.

  9. In the Contents pane, expand the Salzburg folder if necessary and confirm that Art_Installations.gdb and Castle_Palace.gdb have been created.
  10. Expand the geodatabases and confirm that each contains a feature dataset named Placemarks.

    Geodatabases expanded in Contents pane

  11. Under Art_Installations.gdb, click the Placemarks feature dataset.

    In the Catalog view, you can see that the feature dataset contains a feature class named Points. This feature class contains the converted KML point features.

  12. Rename the Points feature class to Art_Installations.
  13. In the Contents pane, under Castle_Palace.gdb, click the Placemarks feature dataset.
  14. In the Catalog view, rename the Points feature class to Castle_Palace.
  15. In the Catalog view, browse to the Art_Installations point feature class. Right-click the feature class and choose Copy.

    Copy option

    Copying feature classes between geodatabases is a simple and fast way to move or create copies of feature classes when you are not converting data formats.

  16. In the Contents pane, under SalzburgGeodatabase.gdb, right-click the City_Attractions feature dataset and choose Paste.

    Paste option

    The process fails. An error message reports that the spatial references of the source feature class and the target feature dataset do not match.

    Error message with information about the copy failure

    The original KML file—and thus the converted feature class containing points—uses the GCS_WGS_1984 coordinate system. The target City_Attractions feature dataset uses the MGI_Austria_GK_M31 coordinate system. The copy and paste operation failed because all feature classes in a feature dataset must have the same coordinate system as the feature dataset. However, it is possible to export the feature class into the feature dataset with the Feature Class To Geodatabase tool. The tool automatically projects the source data into the coordinate system of the feature dataset.

  17. Click OK on the error message.
  18. In the Catalog view, right-click the Art_Installations feature class, point to Export, and choose Feature Class(es) To Geodatabase.

    Context menu option to export a feature class to a geodatabase

    In the Feature Class to Geodatabase tool, Art_Installations is selected by default as an input feature class. You'll add the Castle_Palace feature class also.

  19. In the Feature Class To Geodatabase tool, set the following parameters:

    • For Input Features, browse to and add the Castle_Palace feature class. (You can also drag it from the Catalog view to the empty Input Features box.)
    • For Output Geodatabase, browse to and select the City_Attractions feature dataset. (You can also drag it from the Contents pane to the Output Geodatabase box.)

    Feature Class To Geodatabase tool parameters

  20. Click Run.

    The feature classes are successfully added to the City_Attractions feature dataset.

  21. In the Contents pane, click the City_Attractions feature dataset. In the Catalog view, confirm that the feature classes appear.

    New feature classes

  22. Save the project.
  23. Optionally, update the Art_Installations and Castle_Palace feature class metadata.

    Your SalzburgGeodatabase.gdb now has several feature classes organized into thematic feature datasets that will be useful for tourist agencies to maintain and update to generate new and improved maps and apps for tourists visiting the city of Salzburg.

    Before sharing the geodatabase with stakeholders for feedback, you'll do some geodatabase management.

Prepare the geodatabase for review and distribution

A file geodatabase is stored as a folder of binary files on disk. When you first add data to a file geodatabase, the records in each file are in order and are accessed efficiently by the file system. However, as you delete and add records over time, the records in each file become unordered, and unused space develops as records are removed and new ones are added elsewhere in the file. This causes the file system to perform more record-seeking operations in each file, slowing the rate at which records are accessed. Since you were adding feature datasets and feature classes by importing various source datasets into your geodatabase, you were in essence editing the geodatabase and thereby impacting geodatabase performance.

You'll reorder records and remove unused space by compacting your geodatabase. Compacting a frequently edited geodatabase cleans up storage and unused space while also reducing the size of each file. If you frequently add and delete data, you should compact your file geodatabase on a monthly basis. You should also compact a geodatabase after any large-scale change.

  1. In the Contents pane, right-click SalzburgGeodatabase.gdb, point to Manage, and choose Compact.

    Compact option for geodatabases

    The operation completes quickly.

    Tip:

    To see a history of your geoprocessing operations, including Compact, click the Analysis tab on the ribbon. In the Geoprocessing group, click History.

    In addition to compacting a geodatabase, you can apply compression. A compressed dataset, when distributed, is read-only and therefore cannot be edited or modified in any way except for changing its name and modifying attribute indexes and metadata. Compression is ideal for datasets that do not require further editing, and this may be a suitable way to deliver your initial geodatabase to stakeholders for review without giving them the ability to modify source data features.

    There are several alternatives to consider for sharing your geodatabase with stakeholders. These include creating an XML workspace document; using the Copy or Clip tool to extract subsets of the data; or using the Package toolset to consolidate, package, and share layers, map documents, and results.

    In the following optional steps, you will generate an XML workspace document to share both the data and the schema for your SalzburgGeodatabase.gdb.

  2. In the Contents pane, right-click SalzburgGeodatabase.gdb, point to Export, and choose Geodatabase To XML Workspace Document.

    Geodatabase To XML Workspace Document option

    The Export XML Workspace Document tool opens. The Input Data parameter is correctly set by default.

  3. Confirm that the following parameters are set as follows:
    • Output File is set to SalzburgGeodatabase_ExportXM.xml.
    • Export Options is set to Data.
    • Storage Type is set to Binary.
    • The Export Metadata check box is checked.

    Export XML Workspace Document tool parameters

  4. Click Run.

    The tool may take several minutes to run.

    Tip:
    If you specify an Output File name with a .zip or .z file extension, the resulting XML file is saved in a compressed ZIP file.

  5. When the tool finishes, in the Contents pane, under Folders, click the SalzburgGeodatabase home folder. In the Catalog view, confirm that the XML document appears.

    XML workspace document in project home folder

    You may now distribute and share your output XML workspace document with stakeholders for review and comments.

  6. Save the project.

In this lesson, you created an ArcGIS Pro project to support the creation of a geodatabase. You used the Catalog view to interact with project components and manage the geodatabase. You created several feature datasets and imported various feature classes. You also added metadata to geodatabase items and compressed the geodatabase to make it more efficient.

You can find more lessons in the Learn ArcGIS Lesson Gallery.