Configure summary data for a feature layer

You’ll create a hosted web feature layer in ArcGIS Online to display near real-time COVID-19 cases data for California counties from an ArcGIS Pro project package that contains the near real-time COVID-19 cases for the United States and a polygon layer of California county boundaries.

Download the project data

First, you will download the ArcGIS Pro project package.

  1. Download the Automate Feature Updates project package.
  2. After the download has completed, locate and double-click the AutomateFeatureUpdate.ppkx project package to open the project in ArcGIS Pro.
  3. Sign in to your ArcGIS organizational account.
    Note:

    If you don't have an organizational account, you can sign up for an ArcGIS free trial.

  4. Review the project.

    The ArcGIS Pro project AutomateFeatureUpdate consists of two layers in addition to the basemap layer.

    • COVID-19 Cases US is a feature layer from ArcGIS Living Atlas of the World that shows the near real-time situation for the COVID-19 virus in the United States. This layer is updated hourly.
    • California Counties is a feature class located in the project’s geodatabase. This feature class contains California county boundaries including an attribute with the 2020 total population for each county.

    Map of COVID-19 cases in California by county

Summarize COVID-19 cases by county

Next, you will overlay the California Counties polygon layer with the COVID-19 Cases US layer to summarize the number of confirmed COVID-19 cases and deaths in each county.

  1. On the ribbon, click the Analysis tab, and in the Tools group, click Summarize Within.

    Summarize Within tool.

    The Geoprocessing pane appears.

  2. In the Geoprocessing pane, set the following parameters:

    • For Input Polygons, choose California_Counties.
    • For Input Summary Features choose COVID-19 Cases US.
    • For Output Feature Class, type California_Counties_CovidCases.
    • Ensure that Keep all input polygons is checked.

    Summarize Within tool parameters

  3. In the Summary Fields section, enter the following:
    • For the first Field menu, choose Confirmed. For Statistic, choose Sum.
    • For the second Field menu, choose Deaths. For Statistic, choose Sum.
    • Uncheck Add shape summary attributes.

    Summary Fields

  4. Click Run.

    The California_Counties_CovidCases layer is added to the map. The layer references a polygon feature class that includes a per-county summary of confirmed COVID-19 cases and deaths.

  5. In the Contents pane, right-click the California_Counties_CovidCases layer and click Attribute Table.

    Attribute Table in layer context menu

  6. Review the California_Counties_CovidCases table and the Sum confirmed and Sum deaths fields.

    The Sum confirmed and Sum deaths fields in the attribute table contain the total number of confirmed cases and deaths for each California county.

    Sum confirmed and Sum deaths fields in the attribute table

Create normalized fields for confirmed cases and deaths

Although the absolute numbers of confirmed COVID-19 cases and deaths for each county are helpful information, revealing regional patterns associated with the pandemic requires normalized data (for example, cases per 10,000 people) rather than absolute data. In this step, you will create two fields to capture the confirmed numbers of COVID-19 cases and deaths, normalized by the county’s population.

  1. In the California_Counties_CovidCases table, click Calculate.

    Calculate button on the attribute table toolbar

    Next, you will use an Arcade expression to calculate a field value. The Arcade expression will calculate values for the CasesPer10000 field, representing the total number of COVID-19 cases per 10,000 people for each county.

    Note:

    Learn more about ArcGIS Arcade.

  2. In the Calculate Field window, set the following parameters:

    • For Input Table, confirm that California_Counties_CovidCases is selected.
    • For Field Name (Existing or New), type CasesPer10000.
    • For Field Type, choose Double (64-bit floating point).
    • For Expression Type, choose Arcade.
    • For CasesPer10000 =, build or copy and paste the following expression: ($feature.SUM_Confirmed / $feature.keyusfacts_totpop_cy) * 10000.

    Note:

    Using Arcade, field names are formatted as $feature["field name"] or $feature.fieldname.

    Calculate Field tool parameters for CasesPer10000 field

    Note:

    The CasesPer10000 field does not exist in the original input table; it is added by the Calculate Field tool.

  3. Click OK.
  4. In the attribute table, confirm that the CasesPer10000 field and calculated values have been added to the California_Counties_CovidCases attribute table.

    Next, you will add a second field named DeathsPer10000 and calculate the normalized COVID-19 deaths per 10,000 people for each county.

  5. In the California_Counties_CovidCases table, click Calculate.
  6. In the Calculate Field tool, set the following parameters:
    • For Input Table, choose California_Counties_CovidCases.
    • For Field Name (Existing or New), type DeathsPer10000 and press Tab.
    • For Field Type, choose Double (64-bit floating point)
    • For Expression Type, choose Arcade.
    • For DeathsPer10000 =, build or copy and paste the following expression: ($feature.SUM_Deaths / $feature.keyusfacts_totpop_cy) * 10000.
  7. Click OK. In the attribute table, verify the addition of the DeathsPer10000 field.

    DeathsPer10000 field in the attribute table

  8. Close the table.
  9. On the Quick Access Toolbar, click the Save button to save the project.

    Save button on the Quick Access Toolbar

Enable editor tracking

Next, you will enable editor tracking for the California_Counties_CovidCases feature class. Editor tracking allows you to automatically record information about updates that are made to the feature layer, including a time stamp of when updates occur.

  1. On the ribbon, click the View tab, and in the Windows group, click Catalog Pane.

    Catalog Pane button on the ribbon

  2. In the Catalog pane, expand Databases and expand Automatefeatureupdate.gdb.

    Databases and AutomateFeatureUpdate.gdb expanded in the Catalog pane

  3. Right-click California_Counties_CovidCases and click Properties.

    The Feature Class Properties window appears.

  4. In the Feature Class Properties window, click Manage and check Editor tracking.

    Editor tracking checked in the Feature Class Properties window

  5. Click OK.

Style the resulting layer

To better visualize the COVID-19 cases in California counties, you will use graduated symbols to show a quantitative difference between each county by varying the size of symbols.

  1. In the Contents pane, uncheck the COVID-19 Cases US and California_Counties layers.

    Unchecked layers in Contents pane

  2. In the Contents pane, ensure the California_Counties_CovidCases layer is checked and selected.
  3. On the ribbon, click the Feature Layer tab. In the Drawing group, click Symbology.

    Symbology button on the ribbon

  4. In the Symbology pane, for Primary symbology, choose Graduated Symbols.
  5. For Field, choose CasesPer10000.
  6. Set Minimum size to 2 pt and Maximum size to 20 pt.

    This will generate a good visual contrast, highlighting the difference between counties with low and high numbers of cases.

  7. In the Symbology pane, click More, and click Format all symbols.

    Format all symbols in the More menu

  8. Click the Properties tab. Under Appearance, click the Color menu and choose Poinsettia Red. (Point to colors to read their names.)

    Poinsettia Red

  9. Click Apply.

    The map updates with the California_Counties_CovidCases layer symbolized using graduated symbols based on the confirmed number of COVID-19 cases per 10,000 people in each California county.

    Map with updated symbology

  10. Close the Symbology pane and save the project.

Share the layer as a hosted web feature layer

In this step, you will share the California_Counties_CovidCases layer created previously as a hosted web feature layer in your ArcGIS Online organization.

  1. In the Contents pane, right-click California_Counties_CovidCases, point to Sharing, and choose Share As Web Layer.

    Share As Web Layer

    Note:

    If Share As Web Layer is not available, review your current Sign-in Status at the top of the ribbon. If the status is set to Not signed in, sign in to enable sharing.

  2. In the Share As Web Layer pane, for Name, type California_Counties_CovidCases, followed by your name or initials (for example, California_Counties_CovidCases Your Name).

    You cannot create two layers in an ArcGIS organization with the same name. Adding your initials to a layer name ensures that other people in your organization can also complete this lesson. Once a layer has been created, you can rename it in the map to remove your initials, which will not affect the name of the underlying data layer.

  3. In the Share As Web Layer pane, enter the following:

    • For Summary, type This is a web feature layer of COVID-19 information for California counties.
    • For Tags, type COVID-19, California.
    • For Layer Type, choose Feature.
    • For Share with, check Everyone.

    Share As Web Layer parameters

  4. In the Share As Web Layer pane, click the Configuration tab. Under Layer(s), for Feature, click the Edit button.

    Configuration tab

    The Feature Properties pane appears.

  5. If necessary, expand Operations. Check Approve for Public Data Collection and Enable editing and allow editors to.
  6. Ensure that Add, Delete, and Update are all checked.

    Operations options

  7. In the Share As Web Layer pane, click Analyze.

    A warning appears stating unique numeric IDs are not assigned.

  8. Double-click the error.

    The Map Properties window appears, open to the General tab.

  9. Check the Allow assignment of unique numeric IDs for sharing web layers check box.
  10. Click OK.
  11. In the Share As Web Layer pane, click Analyze again. When it is complete, click Publish.
  12. Close the Share As Web Layer pane.
  13. Save the project.

Next, you will build a web map in ArcGIS Online that includes the shared web feature layer, and you'll configure custom pop-ups and create an online dashboard with a map, charts, and an indicator to view COVID-19 information for California counties.


Configure a web map and dashboard

You will build a web map in ArcGIS Online, configure custom pop-ups and create an online dashboard with a map, charts, and an indicator to view COVID-19 information for California counties.

Create the web map

Next, you will create a web map in ArcGIS Online that includes the shared web feature layer from the previous steps.

  1. Sign in to your ArcGIS organizational account.
  2. On the ribbon, click Map.

    Map on the ArcGIS Online ribbon

    Note:

    Depending on your organizational and user settings, you may have opened Map Viewer Classic. ArcGIS Online offers two map viewers for viewing, using, and creating maps. For more information on the map viewers available and which to use, please see this FAQ.

  3. If necessary, in the pop-up window, click Open in new Map Viewer or on the ribbon, click Open in new Map Viewer.

    Map Viewer opens.

  4. On the Contents (dark) toolbar, click Basemap. In the Basemap pane, choose Light Gray Canvas.

    Light Gray Canvas basemap in the Basemap pane

  5. On the Contents toolbar, click Layers. In the Layers pane, click Add layer.

    Add layer button in the Layers pane

    The Add layer pane appears showing layers from My Content.

  6. In the Add layer pane, locate the California_Counties_CovidCases feature layer and click the Add button.
    Note:

    If there are many layers in your account, you may need to search for the layer based on a keyword or the title of the web layer shared from ArcGIS Pro.

    Add button for the California_Counties_CovidCases layer

    The California_Counties_CovidCases layer with graduated symbols is added to the map.

  7. At the top of the Add layer pane, click the back arrow to return to the Layers pane.

    Back arrow on the Add layer pane

    Next, you will save your web map.

  8. On the Contents toolbar, click Save and open and choose Save as.

    Save in the Save and open menu

  9. In the Save map window, update the following:
    • For Title, type California Counties COVID-19 Cases.
    • For Tags, type COVID-19, California, and counties.
    • For Summary, type Web map of COVID-19 information for California counties.

    Save map parameters

  10. Click Save map.

Configure custom pop-ups for the web map

Next, you will configure pop-ups in the web map to display key COVID-19 statistics for each California county. First, you'll look at the default pop-up and see how it can be improved.

  1. On the map, click any county in California.

    The feature's pop-up window appears.

    Pop-up window for a county

    The pop-up currently displays the attribute values for the selected county based on all the attributes in the original feature layer. You will configure the pop-up to display only the important attributes related to the COVID-19 statistics.

  2. Close the pop-up.
  3. On the Settings (light) toolbar, click Configure pop-ups.

    Configure pop-ups

    The Pop-ups pane appears. Next, you will configure the pop-ups to show custom text. You do not need to display the full field list, so you will remove it.

  4. In the Pop-ups pane, next to Field list, click the Options button and click Delete.

    Options button and Delete option

  5. Click the Add content button and click Text.

    A text editor window appears. You'll use the text editor window to create a sentence that will appear in the pop-up. Your pop-up can also include attribute information that changes depending on which California county is clicked.

  6. In the text editor window, type Confirmed cases: {.

    After typing the brace, a menu appears with the field names from the California_Counties_CovidCases layer.

    Brace with fields list

  7. In the list of fields, scroll down and choose sum_confirmed.
  8. Press Enter and type or copy and paste the following:

    Deaths: {sum_deaths}

    Cases per 10,000: {CasesPer10000}

    Deaths per 10,000: {DeathsPer10000}

    Text content for the pop-up

    Next, you will use text formatting to add more clarity to your pop-up by bolding the field name descriptions.

  9. Highlight the text Confirmed cases: and click the bold button.

    Confirmed cases highlighted and the bold button

    The text Confirmed cases: is now in bold.

  10. Add a bold text format to the remaining field descriptions and click OK.

    The pop-up is updated.

    Updated pop-up

    The pop-up now contains the most relevant and important information, but the number format could be made clearer.

  11. On the Settings toolbar, click Configure fields.
  12. In the Fields pane, click Sum confirmed.
  13. In the Formatting pane, for Significant digits, choose 0 Decimal places. Turn on Show 1000 separator, and click Done.

    Formatting options

    The pop-up preview shows the updated number formatting.

    Pop-up with updated formatting

  14. Use what you have learned to update the remaining three fields so Significant digits is set to 0 Decimal places and Show 1000 separator is turned on.
    Tip:

    You can configure multiple fields at the same time by pressing Ctrl and selecting multiple fields in the Fields pane. The changes made in the Formatting pane will update for all the selected fields.

    The pop-up is now configured.

  15. Close the Fields pane.

    Before you save the map, you'll adjust its extent. The extent of the map when you save will be the extent of the map that appears on the dashboard.

  16. Zoom and pan the map so the state of California is centered.
  17. Save the map.

Create and configure the dashboard

ArcGIS Dashboards is a configurable web app that provides location-aware data visualization and analytics for a real-time operational view of people, services, assets, and events.

Previously, you created a web map with a web feature layer showing the current COVID-19 information for California counties. In this step, you will create an ArcGIS Online dashboard with the following elements:

  • Maps
  • Charts
  • Indicators

  1. If necessary, open your California Counties COVID-19 Cases web map.
  2. On the Contents (dark) toolbar, click Create app and choose Dashboards.

    Dashboards option in the Create app menu

    The Create new dashboard window appears.

  3. For Summary, type Online dashboard with near real time COVID-19 information for California counties.

    Create new dashboard window

  4. Click Create dashboard.

    The dashboard displays the California Counties COVID-19 Cases web map.

    Next, you will configure the map settings.

  5. Point to the upper left corner of the map to reveal a toolbar. Click Configure.

    Configure button

  6. In the Map window, on the Settings tab, set the following:

    • Turn on Pop-ups.
    • Turn on Default extent and bookmarks.
    • Turn on Zoom in/out.

    Map settings

  7. Click Done.

Add serial charts to the dashboard

Next, you will add two serial charts to display the counties in California with the most COVID-19 cases.

  1. On the dashboard toolbar, click the Layout button.

    The Layout pane appears.

    Layout button on the dashboard toolbar

  2. In the Layout pane, click Add element and click Serial chart.

    Serial chart in the Add element menu

  3. In the Select a layer window, click California_Counties_CovidCases.

    The Serial chart element configuration window appears. You'll configure the chart to create categories from the layer's features: each bar in the chart will represent a county in California.

  4. In the Data options pane, for Categories from, choose Features. For Category field, choose NAME.

    Categories from and Category field settings

    The size of each bar in the chart will be determined by the Sum confirmed field, so the chart will show which counties have the most confirmed cases.

  5. In the Series section, click Add series and choose Sum confirmed.

    Sum confirmed in the Add series menu

    There isn't enough room on the dashboard to show all of the counties in California, so you'll configure the chart to show only the ten counties with the most confirmed cases.

  6. Continue configuring the Data options pane as follows:
    • For Sort by, click Add field and choose Sum confirmed.
    • For Sum confirmed, choose Sort descending.
    • For Maximum categories, type 10.

    Chart sorted by Sum confirmed, Sort descending, and Maximum categories set to 10

  7. Click the Chart tab. In the Chart options pane, for Orientation, choose Horizontal.

    Chart orientation set to Horizontal

    You'll change the color of the chart to match the map's symbology.

  8. Click the Series tab and open the Color menu. For Hex, type E60000 and press Enter.

    Chart color set to red

  9. Click the General tab. For Title, click Edit.
  10. In the text editor that appears, type Top 10 counties with confirmed COVID-19 cases.
  11. Highlight the text, click Normal, and choose Heading 3.

    Title text formatting set to Heading 3

  12. Click Done.

    The chart appears next to the map on the dashboard.

    Dashboard with map and chart

  13. Use what you have learned to add a second serial chart that shows the top 10 counties with the highest number of COVID-19 cases per 10,000 people. For Data Options, set the following parameters:
    • For Categories From, choose Features.
    • For Category Field, choose NAME.
    • For Series, choose CasesPer10000.
    • For Sort By, choose CasesPer10000 and Sort descending.
    • For Maximum Categories, type 10.
  14. Update the parameters as follows:
    • On the Chart tab, set Orientation to Horizontal.
    • On the Series tab, set Color to #E60000.
    • On the General tab, for Title, type Top 10 counties with cases per 10,000 people and format the text to Heading 3.
  15. Click Done.

    You now have two serial charts and a web map on your dashboard. Next, you will reposition the dashboard elements.

  16. Point to the upper left corner of one of the charts. In the toolbar, click the Drag item button.

    Drag item button

    By clicking and holding the Drag item button as you drag, you can reposition the chart frame on your dashboard as needed.

  17. Drag the chart and dock it as a row above the other chart.

    Docking location

  18. Drag the divider between the charts and the map so all three elements are clearly visible.

    Dashboard elements resized

  19. On the dashboard toolbar, click the Save button and click Save.

    Save button on the dashboard toolbar

You have added two bar chart elements. Next, you will add an indicator element to show when the dashboard was last updated.

Add an indicator to the dashboard

Next, you will add an indicator to show when the data was last updated.

  1. In the Layout pane, click Add element and click Indicator.
  2. In the Select a layer window, click California_Counties_CovidCases.
  3. In the Indicator window, in the Data options pane, update the following:

    • For Value type, choose Feature.
    • For Value field, choose any one of the fields that will receive updates: Sum confirmed, Sum deaths, CasesPer10000, DeathsPer10000, Shape__Area, or Shape__Length.
    • For Maximum features displayed, set the value to 1.

    Data options for the indicator element

  4. Click the Indicator tab and update the following:
    • For Top text, type Last updated on.
    • For Middle text, replace the existing text with {last_edited_date}.

    Top and middle text edited for indicator element

    The preview of the indicator element updates to show the last edited text for the map layer.

  5. Click Done.
  6. On the dashboard, drag and position the indicator above the map. Drag the divider between the map and indicator to make the indicator smaller.

    Indicator element on dashboard

    Finally, you will update the dashboard theme to match the tone of the COVID-19 pandemic.

  7. On the dashboard toolbar, click the Theme button.
  8. In the Theme pane, for Theme, click Dark.

    Theme set to Dark

    The dashboard theme updates to a dark theme.

    Dashboard with dark theme

  9. Close the Theme pane and save the dashboard.

Next, you will build a model with steps to update the California_Counties_CovidCases web feature layer used in the dashboard.


Create and schedule a model to automate updates

In this module, you will build and run a geoprocessing model using ArcGIS Pro ModelBuilder. In the model, you will automate the update process for the California_Counties_CovidCases web feature layer.

Create a model

First, you will create a new geoprocessing model and add tools to automate updates to the California_Counties_CovidCases web feature layer.

  1. If necessary, open the AutomateFeatureUpdate project in ArcGIS Pro.
  2. On the ribbon, click the Analysis tab. In the Geoprocessing group, click ModelBuilder.

    ModelBuilder button on the ribbon

    The model view tab appears. You can resize, dock, or tile the tab in any position, as you would a map view tab. When the model is saved, it is added to the default toolbox associated with the project.

  3. On the ribbon, on the ModelBuilder tab, in the Model group, click Properties.

    Properties button on the ribbon

    The Tool Properties window appears.

  4. In the Tool Properties window, on the General tab, for Name, type UpdateCACovidWebLayer. For Label, type Update CA Covid Web Layer.

    Model Name and Label

  5. Click OK.

    The model view tab updates with the name you specified.

Add geoprocessing tools to the model

You can add tools to your model in several ways. Next, you will drag the geoprocessing tools you used earlier in the lesson to the model from the geoprocessing history.

  1. On the ribbon, click the Analysis tab. In the Geoprocessing group, click History.

    History button on the ribbon

    The History pane appears. It maintains a list of all Geoprocessing tools run in the current project. From the list of geoprocessing steps, you can rerun a process or add one or more geoprocessing steps to a model.

  2. In the History window, press Ctrl and select both Calculate Field tools and the Summarize Within tool.

    Three tools selected in the History pane

  3. Drag the three selected tools onto the model view.
  4. In the model view, confirm that both Calculate Field tools and the Summarize Within tool were successfully added.

    Tools added to model

    Note:

    Alternatively, you can manually drag each tool from the History pane to the model and connect the tools to run in the correct sequence.

    Next, you will update the shared web feature layer with the new output from the model. To accomplish this, you can append new data into the existing table or feature class. However, in this workflow, the new analysis result replaces the contents of the web layer, so you will delete all existing rows to empty the web feature layer prior to appending new records.

  5. In the model view, click in any open space in the model and type Delete Rows.

    As you start typing, the Add Tools To Model window appears.

    Add Tools To Model window

    Note:

    You can also search and add the Delete Rows tool from the Geoprocessing pane.

  6. In the Add Tools To Model window, double-click Delete Rows to add the tool to the model.

    The Delete Rows tool is added to the model.

    Delete Rows tool added to model

  7. Close the Add Tools To Model window.

    Next, you will specify your published California_Counties_CovidCases web layer as the target for row deletion and updating.

    Note:

    Ensure that you are signed in to your ArcGIS organizational account.

  8. In the model view, double-click Delete Rows.
  9. In the Delete Rows window, for Input Rows, click the Browse button.

    Browse button

    The Input Rows window appears.

  10. In the Input Rows window, expand Portal and click My Content. Search for and open your California_Counties_CovidCases layer.

    California_Counties_CovidCases feature layer

  11. In the Delete Rows window, click OK.

    Next, you will rename the input and output variables for the Delete Rows tool in the model.

  12. In the model view, right-click the input parameter (blue oval to the left of the Delete Rows tool) and click Rename.

    Rename option in context menu

    The input parameter name becomes editable.

  13. Replace the existing text with Target Hosted Web Feature Layer and press Enter.

    The input parameter name updates.

  14. Rename the Delete Rows tool output (green oval to the right of the Delete Rows tool) CA Covid Cases After Delete Rows.

    Renamed tool output

    Next, you will add the Append tool to your model.

  15. In the model view, click any open space and type append.
  16. In the Add Tools To Model window, double-click Append to add the tool to the model.

    Append tool

  17. Close the Add Tools To Model window.
  18. In the Model window, drag and reposition the Append tool to the right of the Delete Rows output parameter.

    Append tool repositioned next to Delete Rows tool

    Next, you will connect the Delete Rows tool output parameter to the Append tool input.

  19. Click the CA Covid Cases After Delete Rows output parameter and drag an arrow to the Append tool.

    Arrow connecting CA Covid Cases After Delete Rows output parameter to the Append tool

  20. In the menu that appears, click Target Dataset.

    Target Dataset option in the context menu

  21. For the second Calculate Field tool, rename the output parameter Updated CA Covid Cases.

    Renamed output parameter for the second Calculate Field tool

    Next, you will connect the Updated CA Covid Cases output as an additional input to the Append tool.

  22. Drag an arrow from the Updated CA Covid Cases output parameter to the Append tool. In the menu that appears, click Input Datasets.

    Updated CA Covid Cases connected to the Append tool as an input dataset

  23. Double-click the Append tool. In the Append window, for Field Matching Type, choose Use the field map to reconcile field differences.

    Field Matching Type set to Use the field map to reconcile field differences

  24. Click OK.
  25. On the ribbon, click the ModelBuilder tab. In the View group, click Auto Layout.

    Auto Layout button on the ribbon

    The model parameters are automatically arranged in an organized layout.

    Automatically arranged model layout

Set model parameters

Next, you will specify the model parameters for the Update CA Covid Web Layer model. Variables that are set as model parameters show as tool parameters when the model is run as a geoprocessing tool, allowing you to specify different data or values for your model to process than what was specified when the model was created. You will also rename some model variables to make them easier to read.

  1. In the model view, right-click California_Counties, and click Parameter.

    Parameter option in context menu

    An indicator (P) displays above the variable to indicate it is now set as a model parameter, and a check mark appears next to Parameter on the variable context menu.

    Parameter indicators

  2. Use what you have learned and set COVID-19 Cases US and Target Hosted Web Feature Layer as model parameters.

    Two more input parameters set as model parameters

    Next, you will rename the California_Counties and COVID-19 Cases US model parameters to make them easier to read.

  3. Rename the California_Counties model parameter Input California Counties.
  4. Rename the Covid-19 Cases US model parameter Input US COVID-19 Cases.

    Model parameters renamed

    The model is complete. You'll validate and run the model to ensure that it has no errors.

  5. On the ribbon, on the ModelBuilder tab, in the Run group, click Validate.

    Validate button on the ribbon

  6. Click Run.

    As each step finishes running, a shadow appears behind its element in the model.

    Shadows in the model

  7. On the ribbon, on the ModelBuilder tab, in the Model group, click Save.
    Note:

    You can access a completed copy of the model in the Catalog pane. In the Catalog pane, expand Toolboxes and AutomateFeaturesUpdate.tbx to access the Update CA Covid Web Layer Original model.

    Next, you will schedule the model tool to run at a specific time every day. Scheduling a geoprocessing tool allows you to run and reuse a tool automatically to perform updates.

Schedule the model to automate updates to the feature layer

You will schedule the model tool that was created in the previous lesson to run at a specific time every day and update the California_Counties_CovidCases web feature layer. Scheduling a geoprocessing tool allows you to schedule and repeat a tool you need to run regularly. You will schedule the model tool directly in ArcGIS Pro from the Geoprocessing pane.

  1. Open the Catalog pane. On the Project tab, expand Toolboxes, and expand AutomateFeatureUpdate.tbx. Right-click Update CA Covid Web Layer and click Open.
    Note:

    Alternatively, you can double-click the Update CA Covid Web Layer tool to open it.

    Open option in the tool's context menu

    The Geoprocessing pane appears, showing the Update CA Covid Web Layer tool parameters.

  2. Confirm Input California Counties is set to California_Counties and Input COVID-19 Cases US is set to COVID-19 Cases US.

    The Target Hosted Web Feature Layer is already set to the California_Counties_CovidCases web feature layer.

    Update CA Covid Web Layer tool parameters

  3. Click the arrow on the Run button.

    A warning icon appears next to the Schedule option.

    Warning icon next to Schedule option

    The warning appears because the project needs to be saved before you can schedule the tool. When a geoprocessing tool references existing layers in the current project’s Contents pane as the input, the project must first be saved before scheduling the tool.

  4. On the Quick Access Toolbar, click the Save button.
  5. Click the arrow on the Run button again and click Scehdule.

    First, you'll schedule the model to run every minute, to test that it works.

  6. In the Schedule window, specify the following parameters:

    • For Task Name, delete the text following Layer.
    • For Recurrence, choose Minutes.
    • For Begins On, set the date to today and the time to one minute from now.
    • For Recur every, ensure it is set to 1 Minute(s).

    Schedule options

  7. Click OK.

    Once a geoprocessing tool is scheduled, it is listed in the History pane.

  8. On the ribbon, click the Analysis tab. In the Geoprocessing group, click History.
  9. In the History pane, click the Scheduled Tools tab.

    Scheduled Tools tab

    The Update CA Covid Web Layer task appears. A timestamp is listed under the tool's name for each time the scheduled tool ran. A green check mark indicates the tool ran successfully. A red warning icon indicates the tool failed to run successfully.

    Successfully run tool in the History pane

  10. Open the California Counties COIVD-19 Cases dashboard that you made earlier in the lesson.

    The indicator above the map should show a timestamp from the last minute.

  11. Close the dashboard.

    Geoprocessing tools are scheduled in your operating system. This means that the scheduled task will continue to run even when ArcGIS Pro is closed, provided the following conditions are met:

    • The computer is running.
    • All changes to the ArcGIS Pro project are saved.
    • The Sign me in automatically option is selected when using the Named User license.

    Note:

    The geoprocessing scheduling feature in ArcGIS Pro also works with Single Use and Concurrent Use licensing.

    The California_Counties_CovidCases layer does not need to be updated every minute. Now that you have tested that the scheduling works, you'll update the schedule to run once a day instead of once every minute.

  12. In ArcGIS Pro, on the History pane, right-click Update CA Covid Web Layer and click Edit Schedule.

    Edit Schedule

  13. In the Schedule window, update the following parameters:

    • For Recurrence, choose Daily.
    • For Begins On, set the date to the next day at 1:00 AM.
    • For Recur every, ensure it is set to 1 day(s).

    Schedule options

  14. Click OK.
  15. Save the model and save the project.

In this lesson, you created and scheduled a custom ArcGIS geoprocessing model to automatically update a web feature layer with the latest COVID-19 cases in all California counties. You also learned how to share a hosted web feature layer from ArcGIS Pro to ArcGIS Online and set up an ArcGIS Online dashboard. As a challenge, you can repeat the same process for a different state.

You can find more lessons in the Learn ArcGIS Lesson Gallery.