Modify a raster image service

The Community Rating System (CRS) only gives discounts for specific types of open space. These areas must meet the following criteria:

  • The parcel is located in the FEMA-designated 100-year floodplain.
  • The parcel is open space, meaning it has no buildings, significant areas of pavement or other impervious surfaces, or dumps.
  • The parcel is preserved as open space by a long term contract from the private owner or public agency.

Because of these constraints, it's easiest to consider public lands, such as parks, and non-profit lands, such as a church or Boy Scout camp. In many cases, it's difficult to obtain the detailed large-scale data needed for floodplain analysis. This data is more readily available at a national scale. You'll use a Living Atlas raster image of the United States and raster functions to prepare it for parcel-scale analysis. First, you'll filter out impervious surfaces. Then you'll clip the raster so you only have your county of interest. Finally, you'll save the Living Atlas raster locally and create an attribute table for it.

Download and open the project

First, you'll download and familiarize yourself with the data for your community, Georgetown County, South Carolina.

  1. Download the GeorgetownCo_CRS zipped folder.
  2. Locate the downloaded folder on your computer and unzip the file to a location you can easily find, such as the Documents folder. Don't unzip the file to your Downloads folder.

    The folder contains an ArcGIS Pro project file (.aprx) and a file geodatabase with the community data (.gdb).

  3. Double-click the CRS_Georgetown_Co.aprx file to open the project in ArcGIS Pro. If prompted, sign in using your licensed ArcGIS account.
    Note:

    If you don't have ArcGIS Pro or an ArcGIS account, you can sign up for an ArcGIS free trial.

    The map contains a basemap, feature classes for Georgetown County parcels, the county boundary, the 100-year regulatory floodplain, and a table. The 100-year Floodplain layer has three zone types: A, AE, and VE. These are FEMA codes for subtypes of floodplains.

  4. In the Contents pane, under Standalone Tables, right-click PADUS_CRS_attrib and choose Open.

    Open a stand-alone table

    Each unique OBJECTID contains all the attributes for the Protected Areas Database of the United States (PADUS) that you'll eventually join to your parcel data. Due to the amount of records, you'll filter the national scale dataset before you join this information back to the data. Lookup tables like this provide an efficient way to store a lot of information.

  5. Close the attribute table.

Modify a raster image service processing template

Now that you've seen the community data available, you'll add the OSP Activity 420 for FEMA's CRS raster image service to your map. Then, you'll use a raster processing template to filter out raster cells below a certain value. This process will remove impervious surfaces that are ineligible for the program. Then, you'll use on-the-fly processing to clip the data to your community boundary and regulatory floodplain. On the fly means that the clip is performed every time you need to access the data, rather than only once so that you must save the results. Because you're using portal data instead of locally saved data, you'll need to use raster functions instead of the similar geoprocessing tools. Once you finish clipping and modifying the raster, you'll save it to your project.

  1. On the ribbon, click the View tab. In the Windows group, click Catalog Pane.

    Catalog Pane button

    The Catalog pane opens.

  2. At the top of the Catalog pane, click Portal and click the Living Atlas button.

    Living Atlas portal

    The Living Atlas portal opens. From this portal, you can access the data in the Living Atlas repository, including basemaps, boundary layers, demographic maps, and so on.

  3. In the search box, type OSP Activity 420 for FEMA's CRS. Press Enter.
  4. Right-click the OSP Activity 420 for FEMA's CRS imagery service layer and choose Add To Current Map.

    Add Living Atlas layer

    The raster layer draws on your map. This layer represents areas that are likely eligible for open space preservation (OSP). The layer is derived from both the PADUS and the National Hydrology Dataset (NHD), and contains the attribute max_imperv with information about the impervious surfaces within each raster cell.

    There is a scale dependency set on the image service, so if you are at too small of a scale, it will not be visible.

  5. If necessary, in the Contents pane, right-click Community_Boundary and choose Zoom To Layer.

    Next, you'll use the raster processing template to filter this image service to show only cells that are within a chosen threshold of impervious surface percentage. Areas that impede natural water filtration and movement are not eligible for OSP credit. This includes parking lots, buildings, roads, driveways, and so on. You'll filter the national scale data based on the estimated percentage of impervious surface per grid cell. It has been shown that water quality and ecosystem health are often degraded when impervious surfaces exceed 10 percent of an area. Using this as the threshold, you'll filter the OSP Activity 420 for FEMA's CRS raster service to select only areas that likely have less than or equal to 10 percent impervious surface.

  6. In the Contents pane, right-click the OSP Activity 420 for FEMA's CRS raster service and choose Properties.
  7. In the Layer Properties window, click the Processing Templates tab.

    Processing Templates tab

  8. If necessary, for Processing Template, choose OpenSpacePotential.
  9. In the Inputs section, for Parameter, type max_imperv. For Value, type 10. Click the validate button to verify that your Inputs information is valid.

    Processing template

  10. Click OK.

    The resulting raster shows only those cells that are estimated to have no more than 10 percent impervious surface coverage. To qualify for OSP credit, the protected areas also need to be in the regulatory floodplain. You'll clip the national raster to Georgetown County's 100-year floodplain.

  11. On the ribbon, click the Imagery tab. In the Analysis group, click the Raster Functions button.

    Raster Functions

    The Raster Functions pane opens.

  12. If necessary, in the Raster Functions pane, click the System tab.
  13. Expand the Data Management section and click Clip.

    Clip raster

    The Clip Properties function opens.

  14. In the Clip Properties pane, click the General tab.
  15. For Name, type PADUS_CRS_clip (this will be the name of the output raster). For Output Pixel Type, choose 32 Bit Unsigned.

    Clip Properties General tab

  16. Click the Parameters tab. For Raster, choose OSP Activity 420 for FEMA's CRS.
  17. If necessary, for Clipping Type, choose Outside.

    Specifying Outside will remove the raster cells outside the clipping geometry. The other option is Inside, which removes the raster cells inside the clip features.

  18. For Clipping Geometry/Raster, choose 100-year Floodplain. Check the Use Input Features for Clipping Geometry box.

    Parameters tab

    Using input features for clipping geometry specifies that the raster will be clipped to the floodplain layer you chose. Alternatively, you can set an extent by drawing a rectangle around the area you want clipped.

  19. Click Create new layer.

    The function may take several minutes to run. When it finishes, a temporary layer called PADUS_CRS_clip_OSP Activity 420 for FEMA's CRS is added to the map. The default name is long, so you'll rename it.

  20. In the Contents pane, click PADUS_CRS_clip_OSP Activity 420 for FEMA's CRS to select it. Click it again to make the layer name editable and change the name to PADUS_CRS_clip.

Save the clipped raster

Now that you've filtered and clipped the national raster dataset down to a useful size, you'll save it locally for future use. Using the Export Raster tool, you'll save the raster for your area of interest as a TIFF, a compact format. Then, you'll create an attribute table for the .tif file that you'll use to join the raster with its attribute table for analysis in the next lesson.

  1. In the Contents pane, uncheck OSP Activity 420 for FEMA's CRS and 100-year Floodplain to turn the layers off.

    Now the new clipped layer is the only one visible on the map. Unlike geoprocessing tools, the raster functions tools apply an operation to a raster image on the fly, meaning that the original data is unchanged and no new dataset is created. If you remove the layer from the map, you'll erase the PADUS_CRS_clip layer you just created. This enables faster processing because it requires less storage and memory on your computer. Because you'll need the raster later, you'll save it.

  2. In the Contents pane, right-click the PADUS_CRS_clip raster, point to Data, and choose Export Raster.

    Export Raster

    The Export Raster pane opens.

  3. On the General tab, for Output Raster Dataset, name the output PADUS_CRS_final.tif.
  4. For Clipping Geometry, choose Community_Boundary.
  5. Check the Use Input Features for Clipping Geometry check box. If necessary, for Clipping Type, choose Outside.

    Export Raster General tab

  6. In the lower part of the pane, make sure that Cell Size is 30 for X and Y, andPixel Type is 32 Bit Unsigned
  7. For NoData value enter 2147483648, which is a value just beyond the range of actual useable values, and check that Output Format is TIFF.

    Lower section of the Export Raster General tab

  8. In the Settings tab, for Snap Raster choose PADUS_CRS_clip. Click Export.

    The new layer is added to the map.

  9. In the Contents pane, right-click the PADUS_CRS_clip layer and choose Remove.

    Final clipped raster

    The data is now clipped to the extent required by FEMA. Your output is in TIFF format, which is an efficient file type but doesn't have an attribute table. To use this layer later, you'll create one.

  10. On the ribbon, click the Analysis tab. In the Geoprocessing group, click Tools.

    Geoprocessing Tools

    The Geoprocessing pane opens.

  11. In the search box, type build raster. In the list of results, click Build Raster Attribute Table.

    Build Raster Attribute Table tool

  12. In the Build Raster Attribute Table pane, for Input Raster, choose PADUS_CRS_final and click Run.
  13. Right-click PADUS_CRS_final.tif and choose Attribute Table.
    Note:

    If you can't open the attribute table, try removing and re-adding the PADUS_CRS_final.tif layer. This helps refresh the data.

    Attribute table

    The Value field in this attribute table represents the most common value from each cell. Later, you'll use this field to join the PADUS attribution to your parcel dataset.

  14. Close the attribute table and save the project.

You've modified a Living Atlas raster layer to fit your community's needs. To start the CRS analysis, you filtered out impervious surfaces and clipped the national raster down to Georgetown County, South Carolina. Next, you'll perform a parcel-scale analysis on this data to determine the likely acreage of eligible open space per parcel in your community.


Calculate areas of eligible open space

Previously, you filtered the national raster based on your desired impervious surface threshold and clipped to your area of interest. Now, pursuant to the requirements of the CRS review process, you need to determine the acreage of eligible open space per parcel in your community. Since the acreage calculated also needs to be joined back to the raster data for final analysis, you'll run zonal statistics. Zonal statistics will calculate the majority statistic for a specified boundary layer, which is the same as the value attribute you gave your PADUS_CRS_final.tif layer in the previous lesson. Once you have this information, you'll join the tables to the parcel and raster datasets.

Calculate the majority statistic

The Zonal Statistics geoprocessing tool allows you to calculate a variety of statistics, including mean and median, within a defined area. The majority statistic summarizes the most common value found in all the PADUS_CRS_final raster cells within each parcel. This field will be used later to join the parcel tables together.

  1. If necessary, open your CRS_Georgetown_Co project.
  2. If necessary, open the Geoprocessing pane. In the search box, type Zonal Statistics as Table.
  3. Click Zonal Statistics as Table (Spatial Analyst Tools).

    Zonal Statistics as Table tool

  4. For Input raster or feature zone data, choose GeorgetownCo_Parcels. For Zone field, choose PARCEL_ID.
  5. For Input value raster, choose PADUS_CRS_final.tif. Name the output table Parcels_Zonal.
  6. For Statistics type, choose Majority.

    Zonal Statistics parameters

  7. Click Run.

    If the warning message "some zones may not have been rasterized" appears, just ignore it. The result table is added to the Contents pane under Standalone Tables.

  8. Right-click Parcels_Zonal and choose Open.

    The table includes columns for area (sq m) of open space per unique PARCEL_ID. The majority statistic summarizes the most common value found in all the PADUS_CRS_final raster cells within each parcel. Majority is the same attribute as the Value field in the attribute table you created for the PADUS_CRS_final.tif raster. Majority also is the same as the ObjectID field in the PADUS_CRS_attributes lookup table. You'll use this common field to join these data sources later.

    Majority column

Estimate open space acreage

FEMA encourages conservative estimations of OSP eligible area per parcel. When using coarse data, you can incorporate the accuracy of the underlying data to accomplish this. In this case, 0.85 represents the measured level of interpretation accuracy for the 2011 National Land Cover Database (NLCD) Impervious Surface Estimation layer. The NLCD is the source for the max_imperv variable that you filtered the image by in the previous lesson. Multiplying the cumulative OSP area in each parcel by this value states that you are 85 percent confident that a given parcel has at least "X" acres of eligible open space. Additionally, eligible OSP area per parcel is required to be reported in acres for the CRS program, so you'll convert square meters to acres.

  1. At the top of the Parcels_Zonal attribute table, click Add.

    Add field

    The Fields: Parcel_Zonal pane opens. In this editor, you can change the properties of the new field.

  2. In the last row (the new field), for Field Name, type ACRES. For Data Type, double-click the cell and choose Double.

    Edit new field

  3. On the ribbon, on the Fields tab, click Save.

    Save table edits

    The ACRES field is added to the table.

  4. Close the Fields: Parcels_Zonal table.

    The field is currently populated by the default null value. Next, you'll calculate the values for the field.

  5. In the Parcels_Zonal attribute table, right-click the ACRES field and choose Calculate Field.

    Calculate Field

    The Calculate Field tool opens in the Geoprocessing pane.

  6. On the Parameters tab, for ACRES =, type (or copy and paste) (!AREA! * 0.85) * 0.000247105. Click Run.

    ACRES expression

    The ACRES field is ultimately what the CRS reviewer will use to validate the eligible area of open space your community is claiming per parcel. If only a small portion of the parcel overlaps the floodplain area, only that overlapping area is eligible, not the entire parcel. To make your final analysis easier, you'll remove the smallest parcels.

  7. On the ribbon, on the Table View tab, in the Selection group, click Select By Attributes.

    Select By Attributes

  8. In the Geoprocessing pane, for Input Rows, confirm that Parcels_Zonal is selected. If necessary, for Selection type, choose New selection. Click New expression.

    New expression

  9. Use the drop-down menus to create the query ACRES Is Less Than 1.

    Select by query

  10. Click Run.

    The acreages that meet your query are now highlighted in the attribute table. These are the smallest pieces of land that are likely too small to provide many credits.

  11. On the ribbon, click the Table View tab. In the Selection group, click Delete.

    Delete small values

    Approximately 245 parcels remain.

  12. Close the attribute table.

Join the datasets

You now have all the information you need, but it is spread across three locations: your parcel dataset, the zonal table, and the PADUS_CRS_attrib table. The CRS review process requires that you report eligible OSP acreages per parcel. You ultimately need the OSP acreage values and the PADUS information included in the attribute table of your parcel dataset. To accomplish this, you will use multiple joins to integrate this data by a common attribute.

  1. In the Contents pane, right-click the Georgetown_Co_Parcels layer, point to Joins and Relates, and choose Add Join.

    Add Join

    The Add Join tool opens in the Geoprocessing pane.

  2. For Input Join Field, choose PARCEL_ID.
  3. For Join Table, choose Parcels_Zonal. For Output Join Field, choose PARCEL_ID.
    Note:

    You may receive a warning about the join field not being indexed. Indexes are useful if you need to query your data frequently, as they speed up searches in ArcGIS. For the purpose of this analysis, your data is more for presentation than continued use, so you won't index it.

    Add Join

  4. Click Run.
  5. Open the GeorgetownCo_Parcels attribute table and confirm that the Parcels_Zonal attributes have been added.

    There will be many null values because you created the Parcels_Zonal table by removing smaller parcels from the GeorgetownCo_Parcels layer. You want to keep all these records, because you have another dataset to join to the GeorgetownCo_Parcels layer.

  6. In the Geoprocessing pane, for Input Join Field, choose Parcels_Zonal.MAJORITY.
  7. For Join Table, choose PADUS_CRS_attrib. For Output Join Field, choose OBJECTID.

    Add Join

  8. Click Run.
  9. In the GeorgetownCo_Parcels attribute table, confirm that the PADUS_CRS_attrib fields were added.

    For the CRS review process, you only need to submit the parcels you claim are OSP eligible. Next, you'll filter these out.

  10. On the ribbon, on the Table View tab, click Select By Attributes.
  11. In the Geoprocessing pane, for Input Rows, confirm that GeorgetownCo_Parcels is chosen. Click New Expression.
  12. Create the expression MAJORITY is Not Null and press Enter.

    Select by Attribute query

  13. Click Run.

    The result is a comprehensive dataset of only parcels with at least 1 acre of likely eligible open space and all the attributes from the PADUS dataset.

  14. Below the attribute table, click the Show selected records button.

    Show selected records

    The data sorts so that the 245 records that fit your criteria are shown at the top of the table. Next, you'll export these results so you can symbolize them.

  15. In the Contents pane, right-click GeorgetownCo_Parcels, point to Data, and choose Export Features.
  16. Name the Output Feature Class GeorgetownCo_OSP and click Run.

    When the Copy Features tool finishes, the new GeorgetownCo_OSP layer is added to the Contents pane.

  17. Close the attribute table and save the map.

You've learned how to aggregate raster information into parcel zones and used a network of joins to create a comprehensive parcel data table that contains all the information required for the CRS review process. Next, you'll create a custom map to pair with the final parcel data table that your planner can submit to apply for CRS credits during the review process.


Create a print map

Previously, you used zonal statistics and joins to create a comprehensive parcel dataset. Next, you'll address the final requirement of the CRS review process by creating a custom print map that visualizes this information and a supporting parcel table.

Create a layout

To complete the review process, the Insurance Services Officer needs the spatial information you just found to verify OSP eligibility and determine the number of credits your community will receive. Until now, you've been working in map view. To create a custom exportable map, you'll add a layout view.

  1. If necessary, open your CRS_Georgetown_Co project.
  2. On the ribbon, click the Insert tab. In the Project section, click New Layout.

    New Layout

  3. In the ANSI - Portrait group, choose Letter.

    A new layout tab is added to the map project.

  4. On the Insert tab, in the Map Frames group, click the bottom of the Map Frame button and choose the second map. Click and drag on the layout to place the map.

    Add map

    The blank layout is populated with the data from your map view. The zoom extent and layers that are shown on your Map tab will be drawn on the layout.

  5. If necessary, in the Contents pane, expand the Map Frame and Map groups until you can see all the layers. Click the Georgetown_Co_OSP layer twice and change the name to OSP Eligible Parcels.
  6. Uncheck all the layers except OSP Eligible Parcels, 100-year Floodplain, Community_Boundary, and the basemap.

    These are the layers that you want to show on your final map. Next, you'll symbolize them.

  7. Right-click OSP Eligible Parcels and choose Symbology.

    Symbology

    The Symbology pane opens.

  8. In the upper right corner, click the options button and choose Import symbology.

    Import symbology

  9. For Symbology Layer, click the Browse button and choose OSP_Eligible_Parcels.lyr from the project folder.

    Symbology Layer

  10. Click Run.

    The saved symbology is applied to the OSP_Eligible_Parcels layer. The map still needs a few elements that will help viewers, such as a scale bar and legend.

  11. In the Insert tab, in the Map Surrounds group, click North Arrow. At the bottom right corner of the map, on the water, draw a rectangle to add the north arrow. Resize if necessary.

    North Arrow

    The default Esri north arrow is added to the map.

  12. In the Map Surrounds group, click Legend. At the top left corner of the map, draw a rectangle to add the legend.

    Layout with legend

Add and format text

The final element your map needs is a title. You'll add and format a title, and change the legend to match it. The legend has a few formatting issues remaining from the Map tab functionalities. You'll fix these spacing and naming issues.

  1. On the ribbon, in the Insert tab, in the Text group, click Rectangle. Draw a rectangle above the map to insert a text box.

    Once you create a text box, the Text Format tab is added to the ribbon.

  2. On the Text Format tab, in the Text Symbol group, change the formatting to Arial, 16 pt, Bold.
  3. Click the blank text box on the map and type Georgetown County, SC. Center the text in the white margin above the map.
  4. Insert a second text box below the first. Format it with Arial, 14 pt, Regular text, and type Impact Adjustment Map for Open Space Preservation Activity 420 — Element 422a. Center the text under the first box.

    Layout title

  5. In the Contents pane, double-click Legend. In the Format Legend pane, click the Text Symbol tab.

    Format Text Symbol

  6. If necessary, click Properties. On the General tab, expand the Appearance group. Change the formatting to Arial, Regular, 14 pt.

    The text is larger, but you want to make it stand out more against the background.

  7. Expand the Halo section. Change Halo symbol to White fill and click Apply.

    Add white halo

    The halo is a white border for the text that makes it more visible against the topographic basemap. There are still a few formatting changes to make for readability, which can all be done in the Contents pane. Files can't be saved if they have names with spaces, but you'll change them to add spaces for the final map.

  8. In the Contents pane, click Community_Boundary twice and delete the underscore.
  9. Expand the 100-year Floodplains layer. Under the layer name, click ZONE_COMBI twice and delete it.

    Legend

    As with the underscore, this attribute subheading was left from the Map tab. It is unnecessary on the final map layout. Now that you have the elements fixed, you'll export the map.

    Final map for export

  10. On the ribbon, click the Share tab. In the Export group, click Layout.

    Export layout

  11. In the Export Layout window, name the file Georgetown CRS. Save as type PNG and enter 300 (in DPI) for the resolution. Click Export.

    Your planner can use this map in the county's application for CRS credits along with the parcel table you'll create next.

    Note:

    Although the FEMA CRS application process requires planners to submit finished maps and tables that can be printed, you can also export your final product as a web map service to your organization's ArcGIS Online account or an enterprise server. Access these options on the Share tab on the ribbon: Share As, Web Map or Web Layer.

Export and edit the parcel table

The CRS application process requires both spatial and tabular information on OSP eligibility per parcel. You'll export your parcel dataset attribute table to a CSV file to prepare and format the information in a clear and concise way for the CRS reviewer.

  1. In the Contents pane, right-click OSP Eligible Parcels, point to Data, and choose Export Table.

    Export Table

    The Geoprocessing pane opens.

  2. In the Geoprocessing pane, confirm that Input Rows is set to OSP Eligible Parcels and name the output Georgetown_OSP_Table. Click Run.

    Export table parameters

    The table is added to the Contents pane under Standalone Tables.

  3. In the Geoprocessing pane, search for Table to Excel and choose Table To Excel.

    Table To Excel tool

  4. For Input Table, choose Georgetown_OSP_Table.
  5. Set Output Excel File to the project folder and change the output name to Georgetown_OSP_Table.xls. Check the Use field alias as column header check box and click Run.

    Table To Excel parameters

  6. Save the project.
  7. In your computer's file explorer, browse to where you saved the Excel table and open the Georgetown_OSP_table.xls file with Excel.
    Note:

    If you don't have Excel, open the file with Notepad or a similar text editor.

  8. Remove the shapefile fields OBJECTID, MAJORITY, STATE_CODE, CNTY_CODE, and shapearea. Delete the second PARCEL_ID field.
  9. Change the field names based on the following table:

    FromTo

    ACRES

    OSP Eligible Acres

    CATEGORY

    OSP Type

    GIS_Acres

    Total Parcel Acres

    Own_Type

    Owner Type

    Loc_Own

    Local Owner

    Mang_Type

    Local Manager Type

    Loc_Mang

    Local Manager

    Loc_Ds

    OSP Description

    Loc_Nm

    Local Name

  10. Save the spreadsheet as GeorgetownCo_OSP_Table.xls (or .csv).

In this lesson, you used a national-scale raster image service to perform a parcel-scale analysis that can help your community save money on flood insurance while reducing their flood risk. Your planner will use the map and parcel data table you created to submit for OSP points in the upcoming CRS review. Assuming all OSP areas you've identified are validated, Georgetown County will move from a CRS Class 8 to Class 7. This move equates to a 15 percent discount on flood insurance for policy holders in the 100yr floodplain, and 5 percent for those outside the floodplain. These savings would amount to over $1,000,000 total annual savings across the community or $128 per policy holder. Your planner can also use the data you generated to help influence land use management planning, prioritize future open space in the floodplain, make the case for policy or regulatory changes such as raising base flood elevations or rezoning, and to more effectively engage decision makers and land owners about flood risks and nature-based solutions such as preserving open space.

You can find more lessons in the Learn ArcGIS Lesson Gallery.