Skip To Content

Calculate the burn index

In the previous lesson, you looked at the imagery through different spectral band combinations to visually identify burn scars. In this lesson, you'll use an equation to quantitatively identify burned areas. This equation is the Normalized Burn Ratio (NBR). It mathematically compares the Near Infrared and Shortwave Infrared 2 bands (bands 5 and 7, respectively) to determine burn severity. Then, you'll compare the NBR of the 2014 and 2015 imagery to calculate NBR change, showing only areas that have been burned between the dates both images were taken. You'll then digitize the burned areas as feature classes and share those feature classes on ArcGIS Online.

Calculate the Normalized Burn Ratio

You'll calculate the NBR twice: once for the 2014 image and once for the 2015 image. To make the calculation, you'll use the Raster Calculator geoprocessing tool and use the following equation:

NBR = (Band 5 – Band 7)/(Band 5 + Band 7)

For the equation to work, you'll extract the bands used in the calculation (bands 5 and 7) from the original data.

  1. If necessary, open your Montana Fires project.
  2. On the ribbon, click the View tab and click Catalog Pane.

    Catalog Pane

    The Catalog pane opens (it may have been open already). Next, you'll navigate to the folder where the data is stored. Since you downloaded this project as part of a package, a folder connection has already been established.

  3. Click the drop-down arrow next to Folders. Open the Montana Fires folder, the commondata folder, and lastly the raster_data folder.

    Folders

    The raster_data folder contains two raster datasets: the imagery layers currently on the map.

  4. Click the arrow next to the G_2014.tif file.

    Bands

    The individual bands are listed. You need band 5 (Near Infrared) and band 7 (Shortwave Infrared 2).

  5. Right-click the NearInfrared band and choose Add To Current Map.

    The band is added to the map. It looks like a black-and-white image because it is not being shown as part of an RGB composite. Single-band image layers often look black and white.

  6. Right-click the ShortWaveInfrared_2 band and choose Add To Current Map.
  7. Click the arrow next to the G_2015.tif file. Add the NearInfrared band and the ShortWaveInfrared_2 band to the map.

    The Contents pane now has four band layers, two for each year. Next, you'll use these bands to calculate the NBR with a geoprocessing tool called Raster Calculator.

  8. On the ribbon, click the Analysis tab and click Tools.

    Tools

    The Geoprocessing pane opens.

  9. In the Geoprocessing pane, click the search box and type Raster Calculator. From the list of results, click Raster Calculator (Spatial Analyst Tools).

    Search for Raster Calculator

    The Raster Calculator tool opens. This tool allows you to create a new raster dataset based on an equation to determine its pixel values. You can create this equation with existing images in your project, including the individual bands from the fire imagery. You'll run this tool twice, once for the 2014 bands and once for the 2015 bands, using the following equation:

    (Band 5 – Band 7)/(Band 5 + Band 7)

  10. Under Rasters, double-click G_2014.tif_NearInfrared to add it to the expression box.

    Beginning of the expression

    The 2014 Near Infrared band will be the Band 5 in the equation.

  11. Under Operators, double-click the minus sign to add it to the expression. Then, double-click the G_2014.tif_ShortWaveInfrared_2 raster.

    Continued expression

    To create a ratio, you'll divide what you have so far by the same two bands added together instead of subtracted.

  12. Edit the expression box by adding parentheses around the existing expression. After the closed parenthesis, add a division operator.
  13. Double-click the G_2014.tif_NearInfrared raster to add it to the expression. Add an addition operator and then double-click the G_2014.tif_ShortWaveInfrared_2 raster.
  14. Put parentheses around the second part of the equation.

    Your expression should look like the following image:

    Final expression

    Tip:

    To increase the size of the expression box and see the entire expression at once, increase the size of the Geoprocessing pane by dragging its border.

    Before you run the tool, you'll set the output location and name.

  15. For Output raster, click the Browse button.

    Browse button

  16. In the Output raster window, under Project, click Folders. Double-click the Montana Fires folder.

    Because Montana Fires is a project package, its folder also includes the commondata and p20 folders. You can ignore these.

  17. Change the name to 2014_nbr and click Save.
  18. Click Run.

    The tool runs and adds a new image to the map. Like the bands, the new layer is black and white and gives little information about burn scars. Only when you determine how much the NBR changed between 2014 and 2015 will the burn scars become apparent. To make this comparison, you first need to use the Raster Calculator tool again for the 2015 bands.

  19. In the Geoprocessing pane, under Map Algebra expression, change all instances of 2014 to 2015.

    Altered expression

  20. For Output raster, change the output name to 2015_nbr (leave the output location unchanged) and click Run.

    2015 NBR

Determine change in NBR

Next, you'll use the Raster Calculator tool one more time to calculate the change in NBR between the two images. In doing so, you'll remove values for areas that were not burned between 2014 and 2015, showing only the burn areas and removing everything else from the image.

  1. In the Geoprocessing pane, delete the expression in the Map Algebra expression box.

    You want to find the change, or difference, between the two NBRs. To do so, you'll subtract the post-fire (2015) NBR from the pre-fire (2014) NBR.

  2. In the Map Algebra expression box, create the expression "2014_nbr" - "2015_nbr".

    Change expression

  3. Change the output raster to change_nbr (leave the output location unchanged) and click Run.

    Change NBR

    The fire locations now appear almost solid white, contrasting strongly against the gray and black areas around them. The only other white areas are the snowy mountainous areas, which are generally not conterminous with the fire areas. You can heighten the contrast by symbolizing the image.

  4. In the Contents pane, click the color ramp beneath the change_nbr layer.

    Color ramp

    The Symbology pane opens. The change_nbr layer symbology is determined by a color ramp instead of an RGB composite because, like the other NBR layers, it contains only one band.

  5. In the Symbology pane, next to Color scheme, choose the Condition Number (green to red) color scheme.

    Condition Number

    Tip:

    To see the name of a color scheme, either point to the scheme or check the Show names box at the bottom of the Color scheme menu.

    The symbology updates on the map.

    Change symbolized

    Both fires are now clearly demarcated on the map.

  6. Close the Symbology pane, and theGeoprocessing pane.

    You no longer need the original NBR layers or the individual band layers, so you'll remove them.

  7. In the Contents pane, right-click the 2015_nbr layer and choose Remove.

    Remove

  8. Remove the following layers:
    Tip:

    While pressing Shift, click the first and last layers listed to select all the layers. Right-click one of the selected layers and choose Remove.

    • 2014_nbr
    • G_2015.tif_ShortWaveInfrared_2
    • G_2015.tif_NearInfrared
    • G_2014.tif_ShortWaveInfrared_2
    • G_2014.tif_NearInfrared

    Only the NBR change layer, the two original imagery layers, the Glacier National Park boundary, and the Topographic basemap remain.

Digitize the fire area

You now have a clear enough image of the fire extents to digitize them as features to share with the Montana Department of Forestry and Resource Management. You'll first create a feature class and then use editing tools to approximate the boundaries of both fires.

  1. In the Catalog pane, open the Databases folder.

    The folder contains two geodatabases, Montana_Fires and Montana_Fires1. The home icon next to Montana_Fires signifies it's the default geodatabase created with the project. The other was included in the project package, and contains the Glacier National Park layer.

  2. Right-click montana_fires1, point to New, and choose Feature Class.

    New Feature Class

    The Geoprocessing pane opens to the Create Feature Class tool.

  3. In the Create Feature Class pane, for Name, type Fires. Leave the other parameters unchanged and click Finish.
    Create feature class
  4. In the Catalog pane, click the arrow next to montana_fires1.gdb to expand it, and right-click the new Fires feature class and click Add To Current Map.
  5. In the Contents pane, click the symbol for Fires.

    The Symbology pane appears. Because the new feature class's default symbology has a solid fill, it can be difficult to properly draw all around the map feature you're tracing.

  6. In the Symbology pane, click the Gallery tab if necessary. Choose the second option, Black Outline (2pts).

    Black Outline 2pts

  7. Zoom to the Reynolds Creek fire.

    Reynolds Creek fire

  8. On the ribbon, click the Edit tab. In the Features group, click Create.

    Create

    The Create Features pane appears. It contains the layers for which you can create new features.

  9. In the Create Features pane, click the Fires feature layer.

    Fires

    The pointer changes to a crosshair when you move it over the map.

  10. Click anywhere on the edge of the Reynolds Creek fire area to begin drawing a polygon feature.

    Draw feature

    If you click anywhere else, another vertex will be placed.

  11. Add vertices along the edge of the fire area.
    Note:

    The more vertices you add, the more accurate your feature will be. Since you're only doing an exercise, don't worry about creating a perfect feature, just one that's reasonably accurate.

  12. When you've finished placing vertices, double-click to finish creating the feature.

    Reynolds Creek feature

    Note:

    If you don't like how your feature turned out, click Vertices (on the Edit tab, in the Tools group) and modify the placement of vertices. Alternatively, on the Edit tab, in the Features group, click Delete to delete the entire feature and start over.

  13. When you're satisfied with the feature, on the Edit tab, in the Manage Edits group, click Save.

    Save edits

  14. In the Save Edits window, click Yes to save all edits.
  15. Press the Esc key to get back to the map navigation mode.
  16. Zoom out and zoom back in to the Thompson fire.

    Thompson fire

    The Thompson fire is larger than the Reynolds Creek fire, so it will take longer to digitize.

  17. In the Create Features pane, under Fires, click the Polygon button.

    Create Features

  18. Digitize the Thompson fire.

    Thompson feature

  19. When you're satisfied with your feature, save the edits.
  20. Close the Create Features and Symbology panes, and return to the full extent of the imagery.

Add attribute information

You've created features for both fires, but they currently have no attribute information. You'll edit the attribute table to identify each fire and calculate each fire's acreage.

  1. In the Contents pane, right-click the Fires layer and choose Attribute Table.

    Attribute Table

    The attribute table has two features, in the order they were digitized. The last feature you created, the Thompson fire, might still be selected.

  2. On the attribute table ribbon, click the Clear Selection button.

    Clear Selection

    The perimeter and area of the fires have already been calculated, but these calculations are in square meters. A more standard measurement for area would be acres.

  3. On the attribute table ribbon, click the Add Field button.

    Add Field

    The Fields view opens, with an empty field at the bottom. You'll add two fields: one for the fire name and one for the fire acreage.

  4. For the new field, change the Field Name to Name. Double-click the Data Type and choose Text.

    Field Name

  5. On the ribbon at the top of the screen, in the Changes group, click Save.

    Save
    Note:

    If you have unsaved edits from when you digitized the fire features, you won't be able to save changes to the attribute table. If you can't save, close the attribute table without saving, save your feature edits on the Edit tab, and add the new field again.

  6. Click the bottom of the list of fields to add a new field.
  7. Change the name of the new field to Acres and the Data Type to Float.

    Acres field

  8. On the ribbon, click Save.
  9. Close the Fields view to return to the attribute table.

    Null fields

    The fields are currently empty. You'll edit the Name fields directly, but to calculate acreage you'll run a geoprocessing tool.

  10. Double-click the Name field for the first feature to edit it. Type Reynolds Creek and press Enter.
  11. Change the name of the second feature to Thompson.
  12. Right-click the Acres field heading and choose Calculate Field.

    Calculate Field

    The Geoprocessing pane opens to the Calculate Field tool. The Calculate Field tool allows you to create an expression to determine field values. The Fires feature class already has an area field, but it's in square meters, not acres. One acre equals 4,046.86 square meters, so you'll use this conversion rate to calculate acreage.

  13. For Field Name, choose Acres.
  14. Under Expression, double-click Shape_Area to add it to the expression box. Add a division operator and type 4046.86 after it.

    Field expression

  15. Click Run.

    Final Attribute Table

    The Acres field is calculated. The Reynolds Creek fire is approximately 4,400 acres, and the Thompson fire is approximately 12,400. Your values will vary because you digitized your features differently.

  16. Close the attribute table and the Geoprocessing pane.
  17. On the ribbon, click the Edit tab. In the Manage Edits group, click Save and save the edits you made to the attribute table.
  18. Save the project.

Share your results

You now have polygon features for both fires with attribute information on their names and acreage. The last thing you'll do is publish the Fires feature class to ArcGIS Online to share it.

  1. In the Contents pane, right-click the Fires layer and click Sharing. Choose Share As Web Layer.

    The Share Web Layer pane appears. Before you can share a layer, you must input metadata so it can be searched for and catalogued.

  2. In the Share Web Layer pane, change the name from Fires to Glacier_National_Park_Fires. Add your name or initials to the end of the name to make it unique.

    Name

  3. For the summary, copy and paste the following text:

    Perimeter definition of the Reynolds Creek and Thompson fires in Glacier National Park during the summer of August 2015. Perimeters defined by difference in Normalized Burn Ratio.

  4. For the tags, type Fire, Reynolds Creek, Thompson, Glacier National Park, Montana and then press Enter.
  5. For Layer Type, leave Feature.
  6. For Sharing With, choose to share with either Everyone or your organization, depending on who you want to see your web layer.
  7. Click Analyze.

    Analyze

    The layer is analyzed for errors. If metadata is missing or there is something wrong with the data, the error will be catalogued and described so you can fix it.

  8. If no errors are found, click Publish.

    The layer is published to ArcGIS Online. You can access it in My Content. The layer can be added to any number of maps, symbolized, and shared.

In these lessons, you used Landsat imagery to determine the extent of two fires. You first looked at the imagery through various spectral band combinations to visually assess the fire location. Then, you calculated the Normalized Burn Ratio to specifically highlight burned areas. Lastly, you digitized both fires and shared them to ArcGIS Online. In a real-world scenario, the Montana Department of Forestry and Resource Management could then use your layer for vegetation succession studies or to plan for future fires in the area.