Social-Distancing-Daten von SafeGraph erkunden

Alles ändert sich im Laufe der Zeit. Städte wachsen, Steuerschätzungen nehmen zu, Verbrechenstrends nehmen zu und auch wieder ab. Die damit verbundene Unbeständigkeit lässt sich studieren und verstehen.

Dies gilt auch für unsere alltäglichen Entscheidungen und die Veränderung unserer Aktivitäten. Aber nichts hat unser kollektives räumliches Verhalten so sehr verändert wie die COVID-19-Pandemie. Das Verhalten der Menschen hat sich auf unterschiedlichste Art und Weise und in unterschiedlichen Geschwindigkeiten im ganzen Land verändert. ArcGIS Pro stellt Werkzeuge bereit, die dabei helfen, diese Veränderungen zu verstehen. In dieser Lektion werden Sie einige dieser Werkzeuge verwenden, um einige der Auswirkungen, die diese Pandemie auf die Fahrgewohnheiten in Kalifornien hatte, zu visualisieren und zu verstehen.

Das Social-Distancing-Dataset erkunden

Zuerst müssen Sie die Daten herunterladen und analysieren.

  1. Laden Sie über Visualize SafeGraph die Daten herunter.

    Da die Projektdatei 1,2 GB groß ist, kann dies einige Zeit in Anspruch nehmen.

  2. Doppelklicken Sie nach dem Herunterladen auf das Projektpaket VisualizeSafeGraphSocialDistancing.ppkx.

    Wegen der großen Menge an Daten (Blockgruppen-Polygone für Kalifornien für 45 Tage) kann das Laden des Projekts etwa eine Minute dauern. Wenn Sie dazu aufgefordert werden, melden Sie sich mit Ihrem ArcGIS-Konto an.

    Hinweis:

    Sollten Sie weder ArcGIS Pro noch ein ArcGIS-Konto besitzen, können Sie sich für eine kostenfreie Testversion von ArcGIS registrieren.

    Das Projekt enthält zwei Karten und eine lokale Szene. Die Karte von Kalifornien ist aktiv.

    Karte des Verhaltens von daheim bleibenden Personen für Kalifornien von SafeGraph

    Diese Karte zeigt die Social-Distancing-Daten von SafeGraph, wobei die Daten nach dem Feld % devices with stay at home behavior symbolisiert sind. Je heller die blauen Flächen sind, desto niedriger ist der Prozentsatz der abgefragten Geräte, die das als "Verhalten von daheim bleibenden Personen" beschriebene Muster zeigen, das heißt, die Geräte, die das Gebiet mit einem 200-Meter-Radius um das Heim nicht verlassen.

    Diese Daten enthalten Tagesintervalle vom 1. Mai 2020 bis zum 14. Juni 2020.

Als Nächstes erstellen Sie ein zeitliches Diagramm, um die Trends über diesen Zeitraum zu visualisieren.

Ein Datenuhr-Diagramm erstellen

Zeitliche Diagramme sind eine Möglichkeit zum Entdecken von Trends in Daten, die einen Zeitwert enthalten, wie zum Beispiel diese Daten von SafeGraph. Eine Datenuhr ist ein kreisförmiges Diagramm, das eine größere Zeiteinheit in Ringe unterteilt und diese wiederum durch eine kleinere Zeiteinheit in Keile unterteilt, wodurch eine Gruppe von Zeitabschnitten erstellt wird. Diese Datenuhr-Diagramme werden Sie verwenden, um Trends in mehreren Variablen basierend auf dem Wochentag zu verstehen.

  1. Klicken Sie im Bereich Inhalt mit der rechten Maustaste auf den Layer SG Social Distancing polygon, klicken Sie auf Diagramm erstellen, und klicken Sie auf Datenuhr.

    Ein Datenuhr-Diagramm erstellen.

  2. Definieren Sie auf der Registerkarte Daten im Bereich Diagrammeigenschaften die folgenden Variablen:

    • Wählen Sie für Datum die Option Datum aus.
    • Wählen Sie für Ringe die Option Wochen aus.
    • Wählen Sie für Keile die Option Wochentage aus.
    • Wählen Sie für Aggregation den Eintrag Mittelwert aus.
    • Wählen Sie für Zahl den Eintrag % devices with stay at home behavior aus.
    • Wählen Sie für Null den Eintrag Keine Farbe aus.

    Diagrammeigenschaften festlegen.

    In dieser Datenuhr steht jeder konzentrische Kreis (Ring) für eine Woche, während die Kreissegmente (Keile) für die Wochentage stehen. Der Datumsbereich (1. Mai 2020 bis 15. Juni 2020) beginnt in der Mitte und erstreckt sich nach außen. Die Farbe jedes Keils steht für den Variablenwert. Die von Ihnen erstellte Datenuhr zeigt den mittleren Prozentsatz der Geräte mit Verhalten von daheim bleibenden Personen in allen Blockgruppen.

    Veränderung im mittleren Prozentsatz der daheim bleibenden Personen nach Wochentagen

    Dieses Diagramm zeigt, dass für Geräte mit Verhalten von daheim bleibenden Personen der Sonntag tendenziell ein beliebter Tag zum Daheimbleiben zu sein scheint, obwohl dieser Trend allmählich sinkt.

    Die Daten von SafeGraph enthalten weitere Felder mit dem Prozentsatz der Geräte, die andere Verhaltensmuster zeigen. Das Projekt enthält drei weitere Datenuhren, die denselben Zeitrahmen für andere Verhaltensmuster zeigen.

  3. Doppelklicken Sie im Bereich Inhalt auf das Diagramm Change in mean % devices with a delivery driver behavior by Days over Weeks.

    Das Datenuhr-Diagramm für Auslieferungsfahrer öffnen.

    Datenuhr-Diagramm für Auslieferungsfahrer

    Dieses Diagramm zeigt, dass es für Geräte mit Verhalten von Auslieferungsfahrern eine Zunahme der Aktivität an Freitagen gibt. Möglicherweise war dies ein beliebter Tag zum Bestellen, Anliefern und Abholen von Lebensmitteln.

  4. Doppelklicken Sie im Bereich Inhalt auf das Diagramm Change in mean % devices with full-time worker behavior by Days over Weeks.

    Das Datenuhr-Diagramm für Vollzeit-Beschäftigte öffnen.

    Datenuhr-Diagramm für Vollzeit-Beschäftigte

    Dieses Diagramm zeigt, dass für Geräte mit Verhalten von Vollzeit-Beschäftigten die Tage von Montag bis Freitag die Tage mit Spitzenaktivität sind. Die Prozentsätze liegen zwischen 3 Prozent und 5,5 Prozent, was noch relativ niedrig ist. Einen signifikanten Abfall in den Fahrten zur Arbeit gibt es am US-Feiertag "Memorial Day" (Montag, 25. Mai 2020).

  5. Doppelklicken Sie im Bereich Inhalt auf das Diagramm Change in mean % devices with part-time worker behavior by Days over Weeks.

    Das Datenuhr-Diagramm für Teilzeit-Beschäftigte öffnen

    Datenuhr-Diagramm für Teilzeit-Beschäftigte

    Dieses Diagramm zeigt, dass es für Geräte mit Verhalten von Teilzeit-Beschäftigten an den Wochentagen höhere Werte gab. Es ist aber auch zu sehen, dass die Werte für den Samstag allmählich zunehmen. Die Prozentsätze liegen zwischen 5 Prozent und 7,7 Prozent, was relativ niedrig, aber höher als bei Vollzeit-Beschäftigten ist.

  6. Schließen Sie die vier Datenuhr-Diagramme.

Datenuhr-Diagramme sind eine gute Möglichkeit zum Visualisieren von zyklischen oder saisonalen Daten. Als Nächstes verwenden Sie ein Liniendiagramm, um die zeitlichen Trends auf eine andere Art zu visualisieren.

Ein Liniendiagramm erstellen

Liniendiagramme werden häufig zum Visualisieren von Daten verwendet. Jetzt erkunden Sie die Veränderung der Variable % devices with stay at home behavior über den Datumsbereich mit einem Liniendiagramm. Damit lässt sich der zeitliche Trend für den Mittelwert der Variable vom 1. Mai 2020 bis zum 14. Juni 2020 zeigen.

  1. Klicken Sie im Bereich Inhalt mit der rechten Maustaste auf den Layer SG Social Distancing polygon, klicken Sie auf Diagramm erstellen, und klicken Sie auf Liniendiagramm.

    Erstellen Sie ein Liniendiagramm.

  2. Definieren Sie auf der Registerkarte Daten im Bereich Diagrammeigenschaften die folgenden Variablen:

    • Wählen Sie für Datum oder Zahl den Eintrag Date aus.
    • Wählen Sie für Aggregation den Eintrag Mittelwert aus.
    • Wählen Sie für Numerische Felder die Option % devices with stay at home behavior aus, und klicken Sie auf Übernehmen.

    Mit dem Erstellen des Liniendiagramms beginnen

  3. Klicken Sie im Abschnitt Zeiteinteilungsoptionen auf die Schaltfläche Intervallgröße, und legen Sie die Intervallgröße auf 1 und die Einheit auf Tage fest.

    Mit dem Erstellen des Liniendiagramms fortfahren

    Das generierte Liniendiagramm zeigt einen bemerkenswerten Abwärtstrend in der Variable % devices with stay at home behavior über den Datumsbereich sowie ein zyklisches wöchentliches Muster.

    Liniendiagramm mit Rückgang im Verhalten von daheim bleibenden Personen

    Wie Sie bereits bei den Datenuhren gesehen haben, liegen diese zyklischen Spitzen im Verhalten von daheim bleibenden Personen in der Regel an den Sonntagen. Dies zeigt, dass die Menschen das Verhalten von daheim bleibenden Personen mit der Zeit allmählich reduzieren, obwohl die Muster nach Wochentag variieren.

  4. Schließen Sie das Liniendiagramm und den Bereich Diagrammeigenschaften.
  5. Als Nächstes untersuchen Sie die Veränderungen im Zeitverlauf mit dem Zeitschieberegler.

Veränderung mit dem Zeitschieberegler visualisieren

Nützlich ist der Zeitschieberegler vor allem für eine qualitative, visuelle Beurteilung eines symbolisierten Datasets mit einer Zeitkomponente. Der Zeitschieberegler filtert die Anzeige der Features gemäß dem auf dem Schieberegler eingestellten Datumsbereich. Auf diese Weise können Sie Trends im Zeitverlauf besser erkennen.

  1. Klicken Sie auf dem Menüband auf der Registerkarte Karte im Abschnitt Navigieren auf die Schaltfläche Lesezeichen. Klicken Sie im Abschnitt California Bookmarks auf San Francisco.

    Zum Lesezeichen "San Francisco" wechseln.

    Die Karte wird auf San Francisco gezoomt.

  2. Doppelklicken Sie im Bereich Inhalt auf den Layer SG Social Distancing polygon, um die Layer-Eigenschaften zu öffnen.
  3. Klicken Sie auf die Registerkarte Zeit, klicken Sie in der Dropdown-Liste Layer-Zeit auf Jedes Feature hat ein Zeitfeld, und klicken Sie auf OK.

    Auf die Registerkarte "Zeit" klicken und den Typ der Layer-Zeit festlegen

    Das Zeitfeld wird standardmäßig auf Datum festgelegt. Dies ist das korrekte Feld in diesem Layer.

    Auf der Karte wird die Schaltfläche Zeit angezeigt.

  4. Klicken Sie auf die Schaltfläche Zeit.

    Auf "Zeit" klicken, um den Zeitschieberegler anzuzeigen

  5. Klicken Sie im Zeitschieberegler auf die Schaltfläche Wiedergabe.

    Auf die Schaltfläche "Wiedergabe" klicken

    Die Karte gibt eine Animation der Daten für jeden Tag wieder. Sie können auf die Schaltfläche Pause klicken, um die Animation zu unterbrechen, oder daneben auf die Schaltflächen Schritt vorwärts und Schritt zurück klicken, um zum Intervall danach bzw. davor zu wechseln.

    Beim Betrachten der Zeitintervalle können Sie Änderungen auf dieser Karte im Zeitverlauf erkennen. Dies ist eine Methode zur qualitativen visuellen Beurteilung, mit deren Hilfe Sie Trends im Zeitverlauf besser erkennen können. Bei manchen Datasets ist dies nützlicher als bei anderen. Durch Symbolisieren des Layers nach anderen Variablen können Sie sie visuell erkunden.

    Wegen der geringen Anzahl der erfassten Geräte in der Blockgruppe fehlen einige Polygone in einigen Zeitintervallen.

    Bei diesem Dataset lassen sich die Muster im Zeitverlauf nur schwer visuell quantifizieren. Es gibt aber einen Impuls. Der Zeitbezug der Intervalle (wie zum Beispiel der Wochentag) ist notwendig, um dem, was wie ein zyklisches Muster aussieht, einen Sinn zu verleihen. Zudem helfen Ihnen das Datenuhr-Diagramm und das Liniendiagramm weiter oben in dieser Lektion bei der Interpretation dessen, was Sie in dieser Animation sehen.

  6. Klicken Sie auf der Symbolleiste für den Schnellzugriff auf die Schaltfläche Speichern, um das Projekt zu speichern.
    Hinweis:

    Möglicherweise werden Sie in einer Meldung gewarnt, dass Sie nach dem Speichern der Projektdatei in der aktuellen ArcGIS Pro-Version die Datei nicht mehr in einer früheren Version öffnen können. Wenn diese Meldung angezeigt wird, klicken Sie auf Ja, um fortzufahren.

Sie haben einige Methoden zum Beurteilen von zeitlichen Trends in den Social-Distancing-Daten von SafeGraph erlernt. Die Visualisierungen mit Datenuhren haben Ihnen beim Identifizieren von zyklischen Mustern geholfen. Sie haben gesehen, dass der Sonntag der Tag mit dem höchsten Prozentsatz der Personen, die daheim bleiben, ist und dass der höchste Prozentsatz an Personen, die auf dem Arbeitsweg zur Vollzeit-Beschäftigung sind, auf Montag bis Freitag fällt. Das Liniendiagramm hat gezeigt, dass es einen Abwärtstrend im Prozentsatz der Personen, die daheim bleiben, gibt. Und schließlich hat Ihnen der Zeitschieberegler beim Visualisieren des Prozentsatzes der Geräte mit Verhalten von daheim bleibenden Personen, der räumlich und zeitlich variiert, geholfen.

Eine Datenexploration wie diese ist ein erster Schritt dahin, ein umfassendes Verständnis Ihrer Daten zu erlangen. Die Datenexploration ist zwar wertvoll, aber auch subjektiv. Als Nächstes verwenden Sie die Geoverarbeitungswerkzeuge Raum-Zeit-Würfel und Trendanalyse von Hot-Spots, um statistisch signifikante Trends im zeitlichen Verlauf zu identifizieren.


Hot-Spot-Trends über Zeit und Raum identifizieren

Jetzt konvertieren Sie die Daten in ein Format, das die erweiterte statistische Analyse und Visualisierung unterstützt.

Einen Raum-Zeit-Würfel durch Aggregieren von Punkten erstellen

Um eine Trendanalyse von Hot-Spots durchzuführen und die Daten als Voxel zu visualisieren, müssen Sie aus den Social-Distancing-Daten von SafeGraph einen Raum-Zeit-Würfel erstellen.

  1. Öffnen Sie bei Bedarf das Projekt.
  2. Klicken Sie auf die Registerkarte Musteranalyse, um die Karte zu aktivieren.

    Aktivieren Sie die Karte "Musteranalyse".

    Der Punkt-Layer auf dieser Karte wurde von dem Blockgruppen-Layer, den Sie zuvor verwendet haben, mit an den Blockgruppen-Schwerpunkten gebundenen Attributen abgeleitet.

  3. Klicken Sie auf dem Menüband auf die Registerkarte Analyse und in der Gruppe Geoverarbeitung auf Werkzeuge.

    Klicken Sie auf Werkzeuge.

  4. Suchen Sie im Bereich Geoverarbeitung nach dem Werkzeug Raum-Zeit-Würfel durch Aggregieren von Punkten erstellen, und klicken Sie darauf, um es zu öffnen.

    Das Werkzeug Raum-Zeit-Würfel durch Aggregieren von Punkten erstellen befindet sich in der Toolbox Space Time Pattern Mining.

    Suche nach dem Werkzeug "Raum-Zeit-Würfel durch Aggregieren von Punkten erstellen".

  5. Legen Sie im Bereich des Werkzeugs Raum-Zeit-Würfel durch Aggregieren von Punkten erstellen die folgenden Parameter fest:

    • Wählen Sie für Eingabe-Features die Option SG Social Distancing point aus.
    • Navigieren Sie für Ausgabe-Raum-Zeit-Würfel zu dem Ordner, wie zum Beispiel C:\SocialDistancing, in dem die Ausgabe-NetCDF-Datei gespeichert werden soll, und geben Sie einen Namen ein, wie zum Beispiel SG_Social_Distancing.
    • Wählen Sie für Zeitfeld den Eintrag date_range_start_Converted aus.
    • Wählen Sie für Zeitschrittintervall das Intervall 1 Tage aus.
    • Wählen Sie für Entfernungsintervall das Intervall 5 Meilen aus.

    Erste Gruppe der Eingaben für das Werkzeug "Raum-Zeit-Würfel durch Aggregieren von Punkten erstellen"

  6. Klicken Sie im Abschnitt Zusammenfassungsfelder auf die Schaltfläche Viele hinzufügen, um Felder hinzuzufügen.

    Viele Felder hinzufügen.

  7. Aktivieren Sie die folgenden Felder, und klicken Sie auf Hinzufügen.

    • mean_distance_traveled_from_home
    • pctdelivery
    • pctfulltime
    • pctHome
    • pctpttime

    Mehrere Felder hinzufügen.

    Die Felder werden im Abschnitt Zusammenfassungsfelder hinzugefügt. Das Warnsymbol im Abschnitt weist darauf hin, dass Sie für jedes Feld weitere Informationen angeben müssen.

    Warnung, dass weitere Informationen erforderlich sind.

  8. Legen Sie für jedes Feld den Wert Statistik auf Mittelwert und den Wert Leere Abschnitte füllen mit auf Räumliche Nachbarn fest.

    "Mittelwert" und "Räumliche Nachbarn" für alle

  9. Klicken Sie auf Ausführen.

    Das Werkzeug erstellt einen Raum-Zeit-Würfel, der in einer NetCDF-Datei in dem von Ihnen angegebenen Ordner gespeichert wird. Die Ausgabe dieses Werkzeugs wird Ihrer Karte nicht hinzugefügt. Die NetCDF-Datei organisiert die Zusammenfassungsdaten in einem Format, das Sie verwenden können, um Trends anzuzeigen, Trendanalysen von Hot-Spots durchzuführen und Visualisierungen zu erstellen.

Als Nächstes verwenden Sie die Ausgabe des Werkzeugs, um eine Trendanalyse von Hot-Spots durchzuführen.

Eine Trendanalyse von Hot-Spots durchführen

Das Werkzeug Trendanalyse von Hot-Spots identifiziert Trends in den Werten des Raum-Zeit-Würfels, den Sie zuvor erstellt haben. Dieses Werkzeug kategorisiert die Daten in den räumlichen Abschnitten, damit Sie das, was im Laufe der Zeit geschehen ist, besser verstehen und charakterisieren können. Das Werkzeug müssen Sie zweimal ausführen, um das raumzeitliche Muster im Prozentsatz der Geräte von Personen, die daheim geblieben sind, und den Prozentsatz der Geräte, die das Verhalten von Vollzeit-Beschäftigten zeigen, zu vergleichen.

  1. Klicken Sie im Bereich Geoverarbeitung auf die Schaltfläche Zurück, und geben Sie Trendanalyse von Hot-Spots im Suchfeld ein.

    Suche nach "Trendanalyse"

  2. Klicken Sie auf Trendanalyse von Hot-Spots, um das Werkzeug zu öffnen.
  3. Legen Sie im Bereich des Werkzeugs Trendanalyse von Hot-Spots die folgenden Parameter fest:

    • Wählen Sie für Eingabe-Raum-Zeit-Würfel den Ausgabe-Würfel der vorherigen Schritte aus, zum Beispiel SG_Social_Distancing.nc.
    • Wählen Sie für Analysenvariable den Eintrag PCTHOME_MEAN_SPATIAL_NEIGHBORS aus.
    • Geben Sie für Ausgabe-Features den Text PctHome_EmergingHotSpotAnalysis ein.

    Werkzeug "Trendanalyse von Hot-Spots"

  4. Klicken Sie auf Ausführen.
  5. Deaktivieren Sie den Layer SG Social Distancing point, um die Ergebnisse der Trendanalyse von Hot-Spots anzuzeigen.
  6. Vergrößern Sie auf das Gebiet von Los Angeles in Südkalifornien.

    Los Angeles liegt in Südkalifornien

    Die Zellen mit den blauen Quadraten zeigen das Muster neuer Cold-Spots. Dies sind statistisch signifikante Cold-Spots im letzten Zeitintervall, die vorher nie statistisch signifikante Cold-Spots waren. Eine statistisch signifikante Anzahl der Geräte in Los Angeles haben zuletzt ihren Prozentsatz der daheim bleibenden Personen reduziert.

    Gebiet von Los Angeles.

  7. Schwenken Sie die Karte, um das Gebiet von San Francisco in Nordkalifornien zu sehen.

    San Francisco liegt in Nordkalifornien

    Im Gegensatz zu Los Angeles zeigt sich im Gebiet von San Francisco ein Übergewicht des Musters sich abschwächender Hot-Spots. Dies sind Zellen, die für 90 % der Zeitintervalle, einschließlich des letzten Zeitintervalls, statistisch signifikante Hot-Spots enthalten. Außerdem ist für jeden Zeitschritt eine allgemeine, statistisch signifikante Intensitätsabnahme hinsichtlich der Cluster-Bildung zu beobachten.

    Gebiet von San Francisco

    In der Dokumentation finden Sie weitere Informationen zur Funktionsweise der Trendanalyse von Hot-Spots.

    Dies zeigt, dass die Menschen in Los Angeles ihr Heim im Allgemeinen häufiger verlassen als die Menschen in San Francisco, und dieses Muster zeigt sich später im Datumsbereich der Daten. Die Menschen in San Francisco reduzieren in diesem Zeitraum allmählich ihr Verhalten von daheim bleibenden Personen.

    Jetzt führen Sie das Werkzeug noch einmal aus, um die Muster in der Variable "Vollzeit-Beschäftigung" zu analysieren.

  8. Deaktivieren Sie im Bereich Inhalt den Layer PctHome_EmergingHotSpotAnalysis.
  9. Klicken Sie auf dem Menüband auf der Registerkarte Analyse in der Gruppe Geoverarbeitung auf Verlauf.

    Den Geoverarbeitungsverlauf öffnen.

    Der Bereich Verlauf enthält eine Liste der Geoverarbeitungswerkzeuge, die Sie ausgeführt haben.

    Werkzeug "Trendanalyse von Hot-Spots" im Bereich "Verlauf".

  10. Doppelklicken Sie im Bereich Verlauf auf Trendanalyse von Hot-Spots.

    Das Werkzeug wird mit den von Ihnen zuvor verwendeten Einstellungen geöffnet. Dies ist hilfreich, wenn Sie ein Werkzeug mehrmals mit geringfügigen Änderungen ausführen müssen. In diesem Falle müssen Sie die Analysevariable und den Ausgabenamen ändern.

  11. Legen Sie im Bereich des Werkzeugs Trendanalyse von Hot-Spots die folgenden Parameter fest:

    • Wählen Sie für Analysenvariable den Eintrag PCTFULLTIME_MEAN_SPATIAL_NEIGHBORS aus.
    • Geben Sie für Ausgabe-Features den Text PctFulltime_EmergingHotSpotAnalysis ein.

    Ausführung des Werkzeugs "Trendanalyse von Hot-Spots" für Variable "Vollzeit"

  12. Führen Sie das Werkzeug aus.

    Die Ergebnisse zeigen einige interessante Muster.

    Ergebnisse der Trendanalyse von Hot-Spots für San Francisco für Variable "Vollzeit"

    Die Flächen in Rot sind dauerhafte Hot-Spots, was bedeutet, dass diese Gebiete im gesamten Zeitraum statistisch signifikante Hot-Spots für das Verhalten von Vollzeit-Beschäftigten waren.

    Die Ursache dafür ist nicht einfach zu finden. Aber in diesen Gebieten ist das Tapestry-Segment The Great Outdoors, basierend auf dem System der Tapestry Segmentation von Esri (siehe Feature-Layer "2020 USA Tapestry Segmentation"), stark vertreten. Die Merkmale dieses Tapestry-Segments weisen darauf hin, dass die Bevölkerung größtenteils aus Ruheständlern besteht und Freizeitaktivitäten in der Natur nachgeht (was auch als Verhalten von Personen auf dem Arbeitsweg registriert werden könnte).

    Die Gebiete nördlich von San Francisco und nordwestlich von Carson City zeigen, dass es im Gebiet einen vergleichsweise höheren Trend zu Fahrten zur Vollzeit-Beschäftigung gibt und dass dieser Trend im Analysezeitraum gleich geblieben ist.

    Im Gebiet von Los Angeles ist das Muster anders.

    Ergebnisse der Trendanalyse von Hot-Spots für Los Angeles für Variable "Vollzeit"

    Die Gebiete östlich von Los Angeles zeigen sowohl schwankende Cold-Spots als auch zeitweilige Cold-Spots. Der schwankende Cold-Spot östlich von Los Angeles enthält für das letzte Zeitintervall einen statistisch signifikanten Cold-Spot, war aber in vorherigen Intervallen ein Hot-Spot. Der zeitweilige Cold-Spot im Osten dieses Gebiets zeigt, dass es keine Zeiträume gab, die statistisch signifikante Hot-Spots waren, und weniger als 90 % der Zeitintervalle statistisch signifikante Cold-Spots waren.

    Gebiete im Osten von Los Angeles zeigen weniger beständige Trends im Prozentsatz der Personen, die auf dem Arbeitsweg zur Vollzeit-Beschäftigung sind. In den Gebieten, die als schwankende Cold-Spots klassifiziert wurden, gab es in jüngerer Zeit weniger Fahrten zur Vollzeit-Beschäftigung (aber es gab Zeitintervalle, in denen sie ein Hot-Spot waren). Die Gebiete weiter östlich von Los Angeles, die als zeitweilige Cold-Spots klassifiziert wurden, waren im Zeitraum der Analyse nie Hot-Spots für Aktivität wegen Fahrten zur Vollzeit-Beschäftigung.

Sie haben die Feature-Daten in einen Raum-Zeit-Würfel konvertiert, der im NetCDF-Datenformat gespeichert wurde, und das Werkzeug Trendanalyse von Hot-Spots verwendet, um statistisch signifikante Muster für zwei Verhaltensvariablen im Zeitverlauf zu extrahieren. Im nächsten Abschnitt erfahren Sie, wie die Daten des Raum-Zeit-Würfels als Voxel-Layer angezeigt werden.


Die Social-Distancing-Daten als Voxel-Layer visualisieren

Jetzt visualisieren Sie die Daten als Voxel in einer 3D-Szenenansicht.

Daten als multidimensionalen Voxel-Layer visualisieren

Wie Sie bereits erfahren haben, lassen sich mit dem Werkzeug Raum-Zeit-Würfel durch Aggregieren von Punkten erstellen die Feature-Daten in einen Raum-Zeit-Würfel strukturieren und aggregieren, der im NetCDF-Datenformat gespeichert wird. Diese regelmäßig gerasterten Daten können als multidimensionaler Voxel-Layer angezeigt werden. Der Voxel-Layer verwendet die Struktur des NetCDF-Dateiformats zum Anzeigen der 3D-Daten auf eine neue Art und Weise. In diesem Abschnitt werden Sie den Raum-Zeit-Würfel erkunden, der als Voxel-Layer visualisiert wird.

  1. Klicken Sie auf die Registerkarte SafeGraph Voxel Layer, um diese Szene zu aktivieren.

    Die Szene "SafeGraph Voxel Layer" aktivieren

  2. Klicken Sie im Menüband auf der Registerkarte Karte auf das Dropdown-Menü Daten hinzufügen, und klicken Sie auf Multidimensionaler Voxel-Layer.

    Fügen Sie einen Multidimensionalen Voxel-Layer hinzu.

  3. Navigieren Sie zum Ordner, in dem Sie Ihre NetCDF-Datei aus dem letzten Abschnitt gespeichert haben, klicken Sie auf die von Ihnen erstellte Datei SG_Social_Distancing.nc, und klicken Sie auf OK.
  4. Blättern Sie im Abschnitt Variablen auswählen zum Ende der Liste, klicken Sie auf die Schaltfläche Standardvariable für PCTHOME_MEAN_SPATIAL_NEIGHBORS, um sie als Standardvariable festzulegen, und klicken Sie auf OK.

    PCTHOME_MEAN_SPATIAL_NEIGHBORS als Standardvariable festlegen.

    In dieser Liste können Sie die Variablen auswählen, die im Layer enthalten sein sollen.

  5. Klicken Sie im Bereich Inhalt auf das Farbschemafeld für den Layer SG_Social_Distancing.

    Auf das Farbfeld für den Layer klicken

    Mit dem aktuellen Regenbogen-Farbschema ist es nicht einfach, Flächen mit hohen und niedrigen Werten zu unterscheiden.

  6. Klicken Sie im Bereich Symbolisierung auf die Dropdown-Liste Farbschema. Aktivieren Sie die Option Namen anzeigen. Führen Sie einen Bildlauf nach unten durch, und wählen Sie das Farbschema Rot-Blau (kontinuierlich).

    Das Farbschema "Rot-Blau (kontinuierlich)" auswählen

  7. Aktivieren Sie das Kontrollkästchen Transparenzfunktion.

    Das Kontrollkästchen "Transparenzfunktion" aktivieren

    Im Steuerbereich Transparenzfunktion ist keine Transparenz festgelegt. Sie können im Farbverlauf Kontrollpunkte hinzufügen, um anzugeben, wie transparent die Farben sein sollen.

  8. Doppelklicken Sie auf eine Stelle nahe der Mitte des roten Abschnitts im Verlauf, etwa auf halbem Wege zum unteren Rand.

    Ergebnis beim Hinzufügen des ersten Kontrollpunkts in Rot

    An der Stelle, an der Sie doppelt geklickt haben, wird ein Kontrollpunkt eingefügt.

    Der Hintergrund des Steuerelements Transparenzfunktion erhält ein grau und weiß kariertes Muster, und die schwarze Linie, die die drei Kontrollpunkte verbindet, zeigt an, wie transparent der Farbverlauf in jeder angegebenen Farbe ist. Je weiter oben sich die Linie befindet, desto undurchsichtiger sind die Farben. Je weiter unten sich die Linie befindet, desto transparenter sind die Farben.

  9. Doppelklicken Sie auf eine Stelle nahe der Mitte des blauen Abschnitts im Verlauf, etwa auf halbem Wege zum unteren Rand.

    Ergebnis beim Hinzufügen des ersten Kontrollpunkts in Blau

    Nach dem Hinzufügen dieser Kontrollpunkte sind die Schattierungen im mittleren Bereich von Rot und Blau halbtransparent, während die extremeren Werte an beiden Enden des Verlaufs undurchsichtiger bleiben. Dadurch heben sich die extremeren Werte in der Szenenansicht stärker ab.

  10. Klicken Sie auf dem Menüband auf der Registerkarte Karte im Abschnitt Navigieren auf die Schaltfläche Lesezeichen und im Abschnitt SafeGraph Voxel Layer Bookmarks auf NorCal.

    Zum Lesezeichen "NorCal" wechseln.

    Die Ansicht zoomt auf Nordkalifornien.

    NorCal in der Ansicht

    Einige Flächen scheinen eine weiße, "bewölkte" Füllung zu haben. Dies liegt daran, dass die Werte im mittleren Bereich des Farbschemas nur halbtransparent sind.

    In dieser volumetrischen Visualisierung befinden sich ältere zeitliche Abschnitte unten und jüngere zeitliche Abschnitte oben. Flächen mit einem höheren Prozentsatz der daheim bleibenden Personen werden in Blau dargestellt, und die höheren Werte sind undurchsichtiger und werden in dunklerem Blau dargestellt. Flächen mit dem niedrigsten Prozentsatz der daheim bleibenden Personen werden in Rot dargestellt, und die niedrigsten Werte sind undurchsichtiger und werden in dunklerem Rot dargestellt. Dies hilft beim Visualisieren der höheren und niedrigeren Werte für das Verhalten von daheim bleibenden Personen.

    Die Voxel in jeder Spalte entsprechen den Zeitintervallen für jede Position. Da niedrigere Voxel älter sind, können Sie an den Werten in einer Spalte erkennen, wie sich das Verhalten an einer bestimmten Position geändert hat. Wenn zum Beispiel eine Spalte dunkelblau beginnt und allmählich in helleres Blau, Rosa und Dunkelrot übergeht, dann können Sie davon ausgehen, dass es an dieser Position einen Trend gibt, dass weniger Personen daheim geblieben sind. Erinnern Sie sich, dass die Datenuhren und das Liniendiagramm in jeder Woche Zyklen aus zunehmendem oder abnehmendem Verhalten von daheim bleibenden Personen gezeigt haben und dass es generell Trends gibt, dass weniger Personen daheim bleiben gibt.

  11. Verwenden Sie die Maus, um die Anzeige zu schwenken, zu vergrößern/verkleinern und zu drehen.

    Weitere Informationen zur 3D-Navigation finden Sie im Hilfethema Navigation in 3D.

  12. Klicken Sie im Bereich Symbolisierung im Steuerelement Transparenzfunktion auf die beiden Kontrollpunkte, die Sie hinzugefügt haben, und ziehen Sie sie ganz nach unten.

    Volle Transparenz für Werte im mittleren Bereich

    Sie können den transparenten Abschnitt im Histogramm der Datenwerte über dem Steuerelement Transparenzfunktion sehen.

  13. Kehren Sie zum Lesezeichen NorCal zurück.

    Nordkalifornien mit vollständig transparenten Werten im mittleren Bereich

  14. Klicken Sie im Bereich Symbolisierung im Steuerelement Transparenzfunktion auf den Kontrollpunkt am roten Ende des Farbschemas, und ziehen Sie ihn ganz nach unten.

    Volle Transparenz für rote Werte

    Volle Transparenz für rote Werte in Szenenansicht

    Damit werden die Voxel hervorgehoben, bei denen das Verhalten von daheim bleibenden Personen am höchsten ist.

  15. Passen Sie die Kontrollpunkte so an, dass die Werte im mittleren Bereich halbtransparent sind.

    Halbtransparente Werte im mittleren Bereich

    Halbtransparente Werte im mittleren Bereich in Szenenansicht

    Wie Sie sehen, werden die höheren Werte für das Verhalten von daheim bleibenden Personen im Kontext mit den niedrigeren, rot symbolisierten Werten, die meistens transparent sind, hervorgehoben.

    Wechseln Sie jetzt die Hervorhebung, sodass die Flächen mit den niedrigsten Werten für das Verhalten von daheim bleibenden Personen angezeigt werden.

  16. Passen Sie die Kontrollpunkte so an, dass die blauen Werte vollständig transparent sind und die roten Werte undurchsichtig werden.

    Alle roten

    Alle roten in Szenenansicht

    Damit werden die Voxel hervorgehoben, bei denen das Verhalten von daheim bleibenden Personen am niedrigsten ist.

Sie haben die Daten als Voxel-Layer visualisiert und die Steuerelemente für Farbe und Transparenz verwendet, um unterschiedliche Werte in den Daten hervorzuheben. Jetzt werden Sie Ausschnitte durch den Voxel-Layer erstellen, um Querschnitte der Daten sehen zu können.

Ausschnitte des Voxel-Layers erstellen

Der Voxel-Layer zeigt eine volumetrische 3D-Ansicht der Daten. Bei Voxeln in der Umgebung der Kanten können Sie den gesamten Zeitraum der Daten sehen. Datenwerte nahe dem inneren des Volumens werden in der Regel durch die in ihrer Umgebung verborgen. Sie können Ausschnitte durch den Voxel-Layer erstellen, um einen Einblick in das Innere zu erhalten.

  1. Klicken Sie im Bereich Inhalt im Abschnitt mit dem Layer SG_Social_Distancing mit der rechten Maustaste auf Ausschnitte, und klicken Sie auf Ausschnitt erstellen.

    Ausschnitt erstellen

    Unten in der Szenenansicht wird die Werkzeugleiste Ausschnitt und Abschnitt für die Arbeit mit Ausschnitten hinzugefügt, und der Mauszeiger wird als Fadenkreuz angezeigt.

    Werkzeugleiste "Ausschnitt und Abschnitt"

  2. Klicken Sie auf eine rote Zelle an der westlichen Kante des Voxel-Layers, bewegen Sie den Mauszeiger nach Osten, und klicken Sie noch einmal.

    Klicken Sie auf eine Position, bewegen Sie den Mauszeiger, und klicken Sie noch einmal, um einen Ausschnitt zu erstellen.

    Der Ausschnitt wird zwischen den Positionen, die Sie angeklickt haben, angezeigt.

    Der Ausschnitt wird zwischen den Positionen, die Sie angeklickt haben, angezeigt.

    Wenn Sie einen Ausschnitt durch den Voxel-Layer erstellen, können Sie in ihn hineinschauen.

  3. Klicken Sie auf der Werkzeugleiste Ausschnitt und Abschnitt auf die Schaltfläche Schieben oder ziehen, klicken Sie auf den Ausschnitt, und ziehen Sie rechtwinklig zur Ebene des Ausschnitts.

    Klicken Sie auf die Schaltfläche "Schieben oder ziehen".

    Schieben oder ziehen Sie den Ausschnitt durch den Voxel-Layer.

    Wenn Sie den Ausschnitt durch den Voxel-Layer schieben oder ziehen, können Sie interaktiv Schnitte durch die Daten an unterschiedlichen Positionen sehen und die Position eines Ausschnitts ändern.

  4. Geben Sie im Bereich Voxel-Erkundung den Namen SF West-East für den Ausschnitt ein.

    Einen Namen für den Ausschnitt eingeben.

  5. Klicken Sie auf den Schieberegler Position im Bereich Voxel-Erkundung, und ziehen Sie ihn, um den Ausschnitt zu verschieben.

    Den Schieberegler ziehen, um den Ausschnitt zu verschieben.

  6. Erstellen Sie einen weiteren Ausschnitt, indem Sie dieses Mal auf eine Stelle nahe dem ersten Ausschnitt klicken, den Mauszeiger vom ersten Ausschnitt weg nach Norden bewegen und dann noch einmal klicken.

    Einen weiteren Ausschnitt mit Nord-Süd-Ausrichtung erstellen.

    Jetzt sind die Daten entlang der Nord-Süd-Achse ausgeschnitten.

  7. Klicken Sie auf der Werkzeugleiste Ausschnitt und Abschnitt auf die Schaltfläche Umdrehen, um die Daten an der anderen Seite des Ausschnitts anzuzeigen.

    Auf "Umdrehen" klicken.

    Sichtbarkeit eines umgedrehten Ausschnitts

  8. Geben Sie im Bereich Voxel-Erkundung den Namen SF North-South für den Ausschnitt ein.

    Der Bereich Voxel-Erkundung steuert den Ausschnitt, der im Bereich Inhalt ausgewählt ist.

  9. Deaktivieren Sie im Bereich Inhalt im Layer SG_Social_Distancing im Abschnitt Ausschnitte den Ausschnitt SF West-East.

    Jetzt ist nur der Nord-Süd-Ausschnitt durch die Daten sichtbar.

Sie haben gelernt, wie durch Erstellen und Verwalten von Ausschnitten die Werte im Inneren des Voxel-Layers erkundet werden können.

Eine andere Variable im Voxel-Layer anzeigen

Der Voxel-Layer ist eine Möglichkeit zum Visualisieren des multidimensionalen Raum-Zeit-Würfels. Sie haben zwar die Variable für das Verhalten von daheim bleibenden Personen erkundet, die Originaldaten enthielten jedoch Variablen für die weiteren Verhaltensmuster als Auslieferungsfahrer, als Vollzeit-Beschäftigter und als Teilzeit-Beschäftigter. Jetzt werden Sie zu einer anderen Variable wechseln.

  1. Klicken Sie auf dem Menüband auf der Registerkarte Voxel-Layer im Abschnitt Variable auf den Dropdown-Pfeil Variable und dann auf PCTDELIVERY_MEAN_SPATIAL_NEIGHBORS.

    Die Variable ändern

    Die neue Variable wird im Voxel-Layer mit einem neuen Farbschema angezeigt.

  2. Legen Sie die Symbolisierung des Layers auf das Farbschema Rot-Blau (Kontinuierlich) fest.
  3. Ändern Sie die Transparenz so, dass die extremeren Werte angezeigt und die mittleren Werte transparenter dargestellt werden.
  4. Analysieren Sie die Daten durch Schwenken und Vergrößern/Verkleinern.
  5. Verwenden Sie die Ausschnitte durch den Voxel-Layer, um die Werte im Inneren zu sehen.

Sie können auch weitere Variablen erkunden, Ausschnitte in unterschiedlichen Winkeln erstellen und horizontale Ausschnitte durch die Daten erstellen.

Sie haben mehrere Techniken zum Erkunden der Social-Distancing-Daten von SafeGraph erlernt. Diese Techniken können bei vielen anderen Datendomänen und -typen angewendet werden, zum Beispiel in der Kriminalitätsanalyse, in der Analyse demografischer Daten und bei jedem anderen Punkt-Dataset mit Datumswerten. Datenuhren visualisieren zyklische Muster, und Liniendiagramme machen Gesamttrends im Zeitverlauf sichtbar. Mit dem Zeitschieberegler können Sie Ihre Daten visuell interpretieren. Mit dem Werkzeug Trendanalyse von Hot-Spots können Sie statistisch signifikante räumlich-zeitliche Trends quantifizieren und basierend auf diesen Trends Flächen klassifizieren.

Das Visualisieren von Trends im Zeitverlauf in 3D ist eine hervorragende Möglichkeit, das ganze Bild räumlich zu sehen, von der viele Benutzer überzeugt sind, dass dies eine intuitive Methode zum Verstehen von räumlich-zeitlichen Trends ist. Sie haben den neuen Voxel-Layer zum Visualisieren von Variablen in Ihrem multidimensionalen Raum-Zeit-Würfel verwendet. Sie haben die Transparenz verwendet, um bestimmte Werte in den Daten hervorzuheben, und Ausschnitte durch den Voxel-Layer verwendet, um die Werte in der Mitte des Datenvolumes zu sehen.

Diese Techniken können Ihnen helfen, räumlich-zeitliche Trends in einem komplexen Dataset, wie zum Beispiel in den Social-Distancing-Kennwerten von SafeGraph, zu erkunden und zu verstehen. Wenn Sie diese Techniken auf Ihre eigenen räumlich-zeitlichen Daten anwenden, können Sie durch qualitative und quantitative Analysen ein tiefgreifendes Verständnis Ihrer Daten erlangen.