Ein Geodatabase-Projekt erstellen

Eine Geodatabase ist ein Container zum Speichern von räumlichen und Attributdaten und den zwischen ihnen bestehenden Beziehungen. In einer Geodatabase können mit Regeln, Beziehungen und topologischen Verbindungen bestimmte Features und deren Attribute so strukturiert werden, dass sie als integriertes System zusammenwirken. Mit anderen Worten: Mit der Geodatabase können Sie die Realität ganz nach Bedarf einfacher oder auch komplexer modellieren.

Ein ArcGIS Pro-Projekt für eine Geodatabase erstellen

Die Gesamtheit aus Organisation und Struktur einer Geodatabase wird im Allgemeinen als Schema bezeichnet. Vor dem Entwickeln eines Geodatabase-Schemas für die Verwendung durch die Salzburger Tourismusbehörden ist es hilfreich, ein generisches Grundkartenschema zu untersuchen, das durch Organisationen und Behörden eingesetzt werden könnte, wenn es notwendig wird, dass sie eine bestimmte Sammlung aus Basis- oder Quelldaten verwalten.

Es gibt mehrere Methoden zum Erstellen einer Geodatabase. Für diese Lektion erstellen Sie jedoch zuerst ein ArcGIS Pro-Projekt aus einer Vorlage, die eine Geodatabase enthält. Wenn Sie ein Projekt erstellen, wird automatisch eine neue File-Geodatabase erstellt und als Standard-Geodatabase festgelegt. In dieser Geodatabase werden die Daten gespeichert, die durch die Salzburger Tourismusbehörden beim Erstellen von Karten verwendet werden.

Hinweis:

Häufig verwalten Städte, Organisationen und Behörden ihre eigenen Daten und ergänzen sie anhand von veröffentlichten und öffentlich verfügbaren Grundkarten, Kartenservices und sonstigen verlässlichen Daten, wie zum Beispiel mit den Daten, die in ArcGIS Living Atlas of the World verfügbar sind.

  1. Rufen Sie die Elementdetailseite zu den Daten und dem Schema für Salzburg auf, und klicken Sie auf Herunterladen.
  2. Wechseln Sie zur heruntergeladenen Datei Salzburg.zip, und extrahieren Sie sie auf Laufwerk C:\.

    Das Verzeichnis "C:\Salzburg" enthält jetzt drei Ordner und eine XML-Dokumentdatei.

    Heruntergeladene Daten am neuen Speicherort

  3. Starten Sie ArcGIS Pro. Melden Sie sich mit Ihrem lizenzierten ArcGIS-Konto an, falls Sie dazu aufgefordert werden.
    Hinweis:

    Sollten Sie weder ArcGIS Pro noch ein ArcGIS-Konto besitzen, können Sie sich für eine kostenfreie Testversion von ArcGIS registrieren.

    Diese Lektion wurde kürzlich für ArcGIS Pro 2.7 getestet. Wenn Sie eine andere Version von ArcGIS Pro verwenden, sind die Funktionalität und Ergebnisse möglicherweise unterschiedlich.

    Wenn Sie ArcGIS Pro öffnen, haben Sie die Möglichkeit, ein neues Projekt zu erstellen oder ein vorhandenes Projekt zu öffnen. Wenn Sie bereits ein Projekt erstellt haben, wird eine Liste der zuletzt verwendeten Projekte angezeigt.

  4. Klicken Sie auf Einstellungen, und wählen Sie Optionen aus.

    Das Fenster Optionen wird angezeigt.

  5. Klicken Sie im Fenster Optionen auf Metadaten.

    Der Standard-Metadaten-Style ist Elementbeschreibung.

    Option für Metadaten-Style

    Dieser Metadaten-Style ermöglicht es, erstellte Metadaten an mehreren Speicherorten anzuzeigen und mit dem Projekt zu nehmen, wenn es in andere ArcGIS-Programme übertragen wird, z. B. ArcGIS Online.
  6. Klicken Sie auf Abbrechen.
  7. Klicken Sie auf die Schaltfläche Zurück, um zur Startseite zurückzukehren.

    Unter Neu werden mehrere Projektvorlagen aufgeführt. Die Vorlage Katalog ist eine gute Wahl, wenn Sie ArcGIS Pro hauptsächlich für das Datenmanagement verwenden und nicht unbedingt Karten erstellen müssen. Sie könne dem Projekt immer auch später noch Karten hinzufügen.

  8. Klicken Sie unter Neu auf Katalog.

    Katalogvorlage auf Startseite

  9. Geben Sie für Name den Namen SalzburgDataManagement ein.
  10. Übernehmen Sie den standardmäßigen Speicherort, oder wählen Sie einen neuen aus, z. B. Ihren Desktop oder Laufwerk C:\.

    Jedes neue Projekt enthält eine Projektdatei (.aprx), eine Standard-Geodatabase und eine Toolbox. Es ist oft hilfreich, einen dedizierten Ordner für diese Elemente und alle zukünftigen Dateien, die Sie für dieses Projekt erfassen, zu erstellen.

  11. Stellen Sie sicher, dass das Kontrollkästchen Einen neuen Ordner für dieses Projekt erstellen aktiviert ist, und klicken Sie auf OK.

    Das Fenster "Neues Projekt erstellen"

    Das Projekt wird mit der Katalogansicht geöffnet.

  12. Klicken Sie auf dem Menüband auf die Registerkarte Ansicht. Klicken Sie in der Gruppe Fenster auf Bereiche zurücksetzen, und wählen Sie Bereiche für Kartenerstellung zurücksetzen (Standardeinstellung) aus.

    Option "Bereiche für Kartenerstellung zurücksetzen"

    Damit wird sichergestellt, dass die Bereiche Inhalt und Katalog offen und alle anderen Bereiche geschlossen sind.

    Bereich "Inhalt", Ansicht "Katalog" und Bereich "Katalog"

    Über die Ansicht "Katalog" können Sie auf alle mit dem Projekt verknüpften Elemente zugreifen und diese verwalten, und zwar unabhängig davon, ob sie über einen lokalen oder Netzwerkcomputer, über ArcGIS Online oder über ein ArcGIS Enterprise-Portal verfügbar sind.

    Im Bereich Inhalt wird der Inhalt der aktiven Ansicht aufgelistet. Wenn eine Kartenansicht aktiv ist, werden im Bereich Inhalt die Layer der Karte angezeigt. Wenn die Ansicht Katalog wie jetzt aktiv ist, enthält der Bereich Inhalt den Inhalt des Projekts, einschließlich Sammlungen von Projektelementen (Toolboxes, Datenbanken usw.), Portalverbindungen und Favoriten.

    Der Bereich Katalog und die Ansicht "Katalog" ähneln einander, sie sind aber für unterschiedliche Aufgaben vorgesehen. Der Bereich Katalog eignet sich für einen schnellen Zugriff. Die Katalogansicht ist besser geeignet, wenn es um Aufgaben im Rahmen des detaillierten Datenmanagements geht. Sie bietet Zugriff auf die Metadaten, während über die Steuerelemente auf dem Menüband mehr Funktionen als im Bereich verfügbar sind. Der Bereich Katalog ist eine vereinfachte Version der Ansicht "Katalog".

    In dieser Lektion verwenden Sie die Ansicht "Katalog". Der Bereich Katalog wird nicht benötigt.

  13. Schließen Sie den Bereich Katalog.

    Schaltfläche "Schließen" im Bereich "Katalog"

  14. Blenden Sie im Bereich Inhalt die Datenbanken ein.

    SalzburgDataManagement.gdb wurde beim Erstellen des Projekts automatisch erstellt. Bevor Sie die Katalogansicht erkunden, sollten Sie eine Ordnerverbindung erstellen, um auf Ihre Lektionsressourcen zugreifen zu können.

  15. Klicken Sie hierzu im Bereich Inhalt mit der rechten Maustaste auf Ordner, und klicken Sie dann auf Ordnerverbindung hinzufügen.

    Ordnerverbindung hinzufügen

  16. Navigieren Sie im Fenster Ordnerverbindung hinzufügen zu C:\Salzburg, und klicken Sie auf OK.

    Eine Ordnerverbindung ist eine Verknüpfung zum Lokalisieren von wichtigen Daten und projektbezogenen Materialien. Es ermöglicht außerdem die Verwaltung dieser Daten in der Ansicht "Katalog".

  17. Blenden Sie im Bereich Inhalt das Element Ordner ein.

    Bereich "Inhalt" mit erweiterter Sammlung "Ordner"

    Das Projekt enthält zwei Ordnerverbindungen. SalzburgDataManagement ist der Ordner mit dem Projekt (auch als Home-Ordner bezeichnet). Diese Ordnerverbindung wurde automatisch erstellt. Die Salzburg-Ordnerverbindung ist diejenige, die Sie gerade hinzugefügt haben.

  18. Speichern Sie das Projekt.

In dieser Lektion haben Sie ein Projekt erstellt, um das Füllen einer Geodatabase zu unterstützen. Sie haben Daten heruntergeladen und dem Projekt eine Ordnerverbindung hinzugefügt. Als Nächstes bewerten Sie verschiedene Datenquellen hinsichtlich ihrer Einbeziehung in Ihrer Geodatabase.


Datenquellen bewerten

Typische Kriterien der Datenqualität, die beim Bewerten einer Datenquelle zu berücksichtigen sind, sind Relevanz für Ihren Zweck, geographische Ausdehnung, Projektion, Aktualität, Daten- und Metadatenstandards, Datenherkunft, mit Daten durchgeführte räumliche Operationen, einschließlich Stichproben, Verarbeitung, Modellierung und Analyse, Genauigkeit und Vollständigkeit, sowie relevante Attribute.

Datenquellen bewerten

Als Nächstes bewerten Sie potenzielle Datenquellen, die für Ihre Projekt-Geodatabase verwendet werden sollen. Diese Datenquellen enthalten Shapefiles und KMZ-Dateien.

  1. Öffnen Sie bei Bedarf Ihr Projekt.
  2. Blenden Sie im Bereich Inhalt den Ordner Salzburg ein. Klicken Sie auf den Unterordner City_of_Salzburg.

    Ordner "City_of_Salzburg" und ein Teil des Inhalts

    Die Katalogansicht wird aktualisiert und enthält dann eine Sammlung der Shapefile-Daten für die Stadt Salzburg. Für alle Dateien werden grundlegende Informationenwie Name und Typ angezeigt.

    Der Ordner "City_of_Salzburg" enthält 30 Shapefiles, die Tourismusbehörden zum Aktualisieren von Karten und Erstellen von Apps nutzen können. Bevor Sie entscheiden, welche Datenquellen unverändert verwendet oder mit Daten aus anderen Quellen ersetzt werden sollen, sollten Sie jede potenzielle Datenquelle aufrufen und überprüfen.

  3. Klicken Sie in der Katalogansicht auf BicyclePaths.shp.

    Metadaten für das Shapefile werden im Detailbereich neben der Dateiliste angezeigt.

  4. Klicken Sie bei Bedarf auf die Schaltfläche Detailbereich ein-/ausblenden unten in der Ansicht "Katalog", um die Metadaten anzuzeigen.

    Auf der Registerkarte Metadaten werden detaillierte Informationen über das Shapefile angezeigt.

    Metadaten für Shapefile

    Tipp:
    Klicken Sie hierzu auf die Registerkarte Ansicht auf dem Menüband. Klicken Sie in der Gruppe Optionen auf Bereich "Details". (Klicken Sie alternativ dazu auf die Schaltfläche Detailbereich ein-/ausblenden unten in der Ansicht "Katalog".)

    Zu den Metadaten gehören Informationen zu Quellennachweisen, Nutzungsbeschränkungen und Ausdehnung. Der Raumbezug (d. h. das Koordinatensystem) der Daten wird nicht angezeigt. Diese Informationen werden im Fenster Eigenschaften angezeigt.

  5. Klicken Sie mit der rechten Maustaste auf BicyclePaths.shp, und wählen Sie Eigenschaften aus.

    Eigenschaften im Kontextmenü von "Bicyclepaths.shp"

  6. Klicken Sie im Fenster Eigenschaften: Shapefile auf Quelle, und blenden Sie den Abschnitt Raumbezug ein.

    Überschrift "Raumbezug" im Fenster "Eigenschaften: Shapefile"

    Für das Shapefile "BicyclePaths" wird das Koordinatensystem "MGI Austria GK M31" verwendet. Diesem liegt das geographisches Koordinatensystem "Militar-Geographische Institut" zugrunde. Diese Koordinatensysteme sind zur Verwendung in Österreich vorgesehen und damit eine gute Option für Ihre Daten.

    Beim Entwickeln einer Geodatabase sind die Metadaten für die Beurteilung von Nützlichkeit und Relevanz einer Datenquelle von entscheidender Bedeutung. Metadaten werden zusammen mit dem Element gespeichert, das sie beschreiben – bei Geodatabase-Elementen wie Feature-Classes in der Geodatabase, bei Projektelementen wie Karten im Projekt, bei dateibasierten Elementen wie CSV-Dateien oder Tabellen im Dateisystem. Die von ArcGIS verwalteten Metadaten werden zusammen mit dem zugehörigen Element kopiert, verschoben und gelöscht.

    Weitere Informationen zum Anzeigen und Bearbeiten von Metadaten

  7. Klicken Sie auf Abbrechen, um das Fenster Shapefile-Eigenschaften zu schließen.
  8. Klicken Sie im Detailbereich auf die Registerkarte Geographie, um die Geodaten des Shapefiles anzuzeigen. Schwenken und zoomen Sie, um die Karte zu erkunden.

    Registerkarte "Geographie"

  9. Klicken Sie auf die Registerkarte Tabelle, um die Attributfelder und Attributwerte für Fahrradweg-Features anzuzeigen.

    Registerkarte "Tabelle"

  10. Überprüfen Sie die Registerkarten Metadaten, Geographie und Tabelle für Museums.shp.
  11. Überprüfen Sie die Registerkarten Metadaten, Geographie und Tabelle für ReligiousMonuments.shp.

    Obwohl die Metadaten scheinbar vollständig sind, werden Sie beim Überprüfen der Geographie und der Tabelle feststellen, dass keine Features angezeigt werden. Das Shapefile ist leer. Daher wird die Datenquelle möglicherweise abgelehnt.

  12. Klicken Sie im Bereich Inhalt unter Ordner auf den Unterordner kmz-files.

    Dieser Ordner enthält drei KMZ-Dateien, die für Tourismusbehörden nützlich sein könnten. Eine KMZ-Datei ist eine komprimierte KML-Datei (Keyhole Markup Language), die durch einen KML-Client, wie zum Beispiel ArcGIS Pro, angezeigt werden kann.

    Ordner für KMZ-Dateien

    Hinweis:

    KML ist ein häufig verwendetes Format zum Freigeben von geographischen Daten für Benutzer, die GIS nicht verwenden, da die Daten auf einfache Weise im Internet bereitgestellt und in zahlreichen kostenlosen Anwendungen angezeigt werden kann. KML-Dateien haben ein XML-Format und besitzen die Dateierweiterung .kml oder .kmz (für komprimierte oder gezippte KML-Dateien). In ArcGIS Pro können Sie beide Erweiterungen verwenden.

  13. Klicken Sie in der Katalogansicht auf Kunstwerke_mit_Audiotext.kmz und dann auf die Registerkarte Metadaten.

    Die Features in dieser KML-Datei stellen den Standort wichtiger Open-Air- und Indoor-Kunstinstallationen dar, die durch Touristen, die an der Arbeit bestimmter Künstler interessiert sind, gesucht und besucht werden können.

  14. Klicken Sie auf die Registerkarte Metadaten.

    In diesem Fall enthält die KML-Datei keine nützlichen Metadaten. Für KML-Dateien gibt es auch kein Eigenschaften-Fenster. Somit kann das Koordinatensystem nicht angezeigt werden. KML unterstützt jedoch nur WGS 1984 als Koordinatensystem. Daher sind einige Informationen über die Datenquelle bekannt. WGS 1984 ist ein allgemeines globales geographisches Koordinatensystem.

  15. Klicken Sie auf die Registerkarte Geographie.

    Inhalt der KML-Datei

    Die angezeigten Features sind nicht besonders gut skaliert und nur schwer zu erkennen. Der Grund dafür ist, dass die KML-Datei eine eigene Symbolisierung und sonstige Layer-Eigenschaften, wie zum Beispiel Pop-up-Informationen, enthält.

    Hinweis:

    Eine KML-Datei kann aus einer Kombination aus Punkt-, Linien- und Polygon-Features und Raster-Bilddaten bestehen. Eine KML-Datei kann außerdem zugehörige Inhalte wie Grafiken, Bilder, Attribute und HTML enthalten. Datasets bestehen in ArcGIS dagegen in der Regel aus homogenen Elementen: Zum Beispiel enthalten Point-Feature-Classes nur Punkte.

  16. Klicken Sie auf die Registerkarte Tabelle.

    Für KML-Dateien werden keine Tabellen verwendet. Stattdessen wird für KML-Dateien eine Tag-basierte Struktur mit geschachtelten Elementen und Attributen verwendet, die auf dem XML-Standard basieren. Zum Bearbeiten oder Ändern der Daten können Sie die KML-Datei in einem Text-Editor öffnen oder in eine Geodatabase-Feature-Class konvertieren.

  17. Klicken Sie im Bereich Inhalt unter Ordner auf den Unterordner OpenStreetMap_Salzburg.

    Dieser Ordner enthält eine Sammlung aus freien OpenStreetMap-Daten für Salzburg im Shapefile-Format, die beim Erstellen von Tourismuskarten und -Apps verwendet werden können. Die Daten werden durch Freiwillige gesammelt und erstellt und mit einer Open-Content-Lizenz freigegeben. Die OpenStreetMap-Lizenz ermöglicht den freien Zugriff auf Kartenbilder und alle zugrunde liegenden Kartendaten.

    Erfahren Sie mehr über die Map Features von OpenStreetMap.

  18. Klicken Sie in der Katalogansicht mit der rechten Maustaste auf OSM_Salzburg_Amenities.shp, und wählen Sie Eigenschaften aus. Blenden Sie die Informationen zum Raumbezug ein, und verschaffen Sie sich einen Überblick darüber.

    Diese Daten sind im projizierten Koordinatensystem WGS 1984 Web Mercator (Auxiliary Sphere) gespeichert, was bei Daten für Webkarten wie OpenStreetMap üblich ist. Diesem liegt das geographische Koordinatensystem WGS 1984 zugrunde, dasselbe wie Ihren KML-Daten, jedoch ein anderes wie Ihren anderen Shapefile-Daten, für die ein für Österreich spezifischer Raumbezug verwendet wird. Den Daten in einer Karte muss jedoch dasselbe geographische Koordinatensystem zugrunde liegen. Sie werden später eines auswählen und die anderen Daten entsprechend transformieren.

    Hinweis:

    Jedes projizierte Koordinatensystem enthält ein zugrunde liegendes geographisches Koordinatensystem. Weitere Informationen finden Sie unter Geographische und projizierte Koordinatensysteme im Vergleich.

  19. Schließen Sie das Fenster Eigenschaften: Shapefile.

    Für alle Shapefiles in diesem Ordner wird dasselbe Web Mercator-Koordinatensystem. verwendet.

  20. Speichern Sie das Projekt.

Als Nächstes importieren Sie mit einer XML-Datei das Geodatabase-Schema für eine generische Grundkarte. Anhand der Grundkarte erkunden Sie dann die Geodatabase-Objekte vor dem Aktualisieren der Metadaten für Ihre Geodatabase "Salzburg". Das Aktualisieren der Metadaten ist eine Vorbereitung auf das Migrieren der Datenquellen aus ihrem aktuellen Format und Raumbezug in einen geeigneten Raumbezug zur Verwendung in touristischen Karten und Apps.


Ein Geodatabase-Schema erstellen

Das Geodatabase-Speichermodell basiert auf einer Reihe von relationalen Datenbankkonzepten und nutzt ein zugrunde liegendes Datenbankmanagementsystem (DBMS). Das DBMS stellt die Speicherstruktur und die Mechanismen für Indizierung, Sicherung und Rollback mit dem entsprechenden Sicherheitsmodell bereit. DBMS-Tabellen und gut definierte Attributtypen werden zum Speichern des Schemas, der Regelgrundlage und der räumlichen Attributdaten für die einzelnen geographischen Datasets verwendet. Dieser Ansatz liefert ein formales Modell zum Speichern und Arbeiten mit Daten.

Geodatabase-Objekte überprüfen

In dieser Lektion beginnen Sie mit dem Überprüfen des Schemas für eine andere Geodatabase, um einen Einblick in Geodatabase-Komponenten, wie zum Beispiel Feature-Classes, Feature-Datasets und Standalone-Tabellen, die zum Organisieren und Verwalten von Daten verwendet werden, zu gewinnen. Danach konvertieren und importieren Sie verschiedene Datasets, um das Schema Ihrer Geodatabase "Salzburg" zu erstellen und zu aktualisieren. Weitere Informationen finden Sie unter Was ist eine Geodatabase? und Grundlagen zur Geodatabase.

Zuerst importieren Sie das Schema einer Grundkarten-Geodatabase aus einer XML-Datei.

  1. Öffnen Sie bei Bedarf Ihr Projekt.
  2. Klicken Sie im Bereich Inhalt auf Datenbanken.

    Die standardmäßige Datenbank SalzburgDataManagement.gdb wurde beim Erstellen des Projekts automatisch erstellt. Diese Datenbank werden Sie mit Ihren Salzburg-Quelldaten füllen. Zunächst erstellen Sie jedoch eine zusätzliche Geodatabase, um die Geodatabase-Komponenten zu erkunden.

  3. Klicken Sie im Bereich Inhalt mit der rechten Maustaste auf Datenbanken, und klicken Sie auf Neue File-Geodatabase.

    Option "Neue File-Geodatabase" im Kontextmenü

  4. Geben Sie im Fenster Neue File-Geodatabase als Name den Text SampleBaseMapGDB ein. Bestätigen Sie, dass die Geodatabase im Ordner SalzburgDataManagement erstellt wird. Klicken Sie auf Speichern.

    Fenster "Neue File-Geodatabase"

    Die neue Geodatabase wird in der Ansicht "Katalog" angezeigt.

    Als Nächstes importieren Sie ein Geodatabase-Schema aus einer XML-Datei in die Geodatabase SampleBaseMapGDB.gdb. Dies ist nicht immer notwendig, aber in diesem Fall müssen Sie ein allgemeines Geodatabase-Design und Geodatabase-Objekte überprüfen und außerdem erkunden, wie Sie XML-Dokumente für eine spätere Freigabe Ihrer eigenen Geodatabase-Schemas verwenden können.

  5. Blenden Sie im Bereich Inhalt die Option Datenbanken ein, und klicken Sie auf SampleBaseMapGDB.gdb.
  6. Klicken Sie im Menüband auf die Registerkarte Katalog. Klicken Sie in der Gruppe Erstellen auf Importieren, und wählen Sie XML-Workspace-Dokument aus.

    Option "XML-Workspace-Dokument"

    Der Bereich Geoverarbeitung wird mit dem Geoverarbeitungswerkzeug XML-Workspace-Dokument importieren geöffnet.

    Hinweis:

    Für dieses Werkzeug benötigen Sie eine ArcGIS Pro Standard- oder eine ArcGIS Pro Advanced-Lizenz. (Wenn Sie eine ArcGIS-Testversion nutzen, haben Sie eine ArcGIS Pro Advanced-Lizenz.) Wenn Sie eine ArcGIS Pro Basic-Lizenz haben, können Sie mit dem Abschnitt Die Geodatabase "Salzburg" dokumentieren und vorbereiten fortfahren. Klicken Sie auf die Registerkarte Projekt im Menüband und dann auf die Registerkarte Lizenzierung, um die Lizenz zu prüfen.

  7. Klicken Sie im Werkzeug XML-Workspace-Dokument importieren für Datei importieren auf die Schaltfläche Durchsuchen.
  8. Klicken Sie im Fenster Datei importieren auf Ordner, um die Ordnerverbindungen aufzurufen. Doppelklicken Sie auf Salzburg, um die zu Beginn der Lektion heruntergeladenen Daten zu finden. Wählen Sie SampleBasemapGDB.xml aus, und klicken Sie auf OK.

    Fenster "Datei importieren"

  9. Wählen Sie unter den Importoptionen die Option Nur Schema importieren aus.

    Parameter des Werkzeugs "XML-Workspace-Dokument importieren"

  10. Klicken Sie auf Ausführen.

    Wenn die Ausführung des Werkzeugs abgeschlossen ist, wird unten im Bereich Geoverarbeitung eine Meldung über den Abschluss angezeigt.

  11. Schließen Sie den Bereich Geoverarbeitung.
  12. Klicken Sie im Bereich Inhalt mit der rechten Maustaste auf SampleBaseMapGDB.gdb, und klicken Sie auf Aktualisieren.
  13. Überprüfen Sie in der Katalogansicht den Inhalt von SampleBaseMapGDB.gdb.

    Geodatabases bestehen aus einer Sammlung von Systemtabellen sowie Benutzerdaten. Benutzerdaten können in den folgenden Dataset-Typen gespeichert werden:

    • Feature-Class
    • Feature-Datasets
    • Mosaik-Dataset
    • Raster-Dataset
    • Tabelle (nicht räumlich)

    Zusätzlich können Feature-Classes und Tabellen Subtypes enthalten und mit Domänen verknüpft sein. Außerdem werden Sie feststellen, dass Anlagen und Beziehungsklassen in der Geodatabase vorhanden sind.

    Importierte Geodatabase-Objekte

    In dieser Geodatabase sind Feature-Classes thematisch in Feature-Datasets organisiert, zum Beispiel "Administrative", "Cultural" usw. Die Geodatabase enthält auch eine Toolbox, die Sie zum Speichern einer Reihe von Geoverarbeitungswerkzeugen, Skripten und Modellen, die von Benutzern erstellt wurden, verwenden können.

    Feature-Datasets können Feature-Classes sowie die folgenden Dataset-Typen enthalten:

    • Verfolgungsnetze
    • Netzwerk-Datasets (erfordert Erweiterung "ArcGIS Network Analyst")
    • Terrains (Erweiterung "ArcGIS 3D Analyst" erforderlich)
    • Topologien

  14. Doppelklicken Sie in der Ansicht "Katalog" auf das Feature-Dataset Administrative, um seinen Inhalt anzuzeigen.

    Da dies ein Grundkarten-Geodatabase-Schema ist, enthält das Feature-Dataset "Administrative" mehrere Line- und Polygon-Feature-Classes zum Speichern und Verwalten der Grenzlinien und -polygone für Verwaltungsbereiche.

    Inhalt des Feature-Datasets "Administrative"

  15. Klicken Sie im Bereich Inhalt auf SampleBaseMapGDB.gdb. Klicken Sie in der Katalogansicht auf die Feature-Class PointsOfInterest.

    Feature-Class mit Points of Interest in der Ansicht "Katalog"

    Die Feature-Class "PointsOfInterest" ist eine Standalone-Feature-Class, die nicht in einem Feature-Dataset organisiert ist. Sie enthält die Anlagentabelle "PointsOfInterest__ATTACH", in der Bilder und verbundene Dokumente und Links für jeden Punkt in der Feature-Class enthalten sein können. Die Anlagenfunktionalität bietet eine leistungsstarke Möglichkeit, nicht geographische Daten mit den geographischen Informationen zu verknüpfen. In diesem Fall wird die Beziehungsklasse "PointsOfInterest__ATTACHREL" verwendet, um eine Verknüpfung zwischen den Punkten und deren Anlagen zu erstellen und beizubehalten.

    Weitere Informationen zu Anlagen

  16. Klicken Sie in der Ansicht "Katalog" auf das Raster-Dataset Slopemap.

    Das Objekt Slopemap repräsentiert ein Raster-Dataset, das ein einzelner Raster- oder Bilddaten-Layer ist. Es ist auch möglich, Mosaik-Datasets in Geodatabases zu erstellen. Mosaik-Datasets werden verwendet, um Sammlungen von Raster-Daten zu verwalten, anzuzeigen, bereitzustellen und freizugeben.

  17. Klicken Sie auf HistoricSitesDescriptions.

    Dieses Objekt repräsentiert eine nicht räumliche Geodatabase-Tabelle, die Beschreibungen, Codes und sonstige Daten enthalten kann, die bei Bedarf mit räumlichen Features verknüpft werden können.

    Sie haben das XML-Workspace-Dokument in SampleBaseMapGDB.gdb importiert, um ein typisches Grundkartendesign zu erkunden und zu überprüfen. Diese Geodatabase werden sie in dieser Lektion nicht wieder benötigen.

  18. Klicken Sie im Bereich Inhalt mit der rechten Maustaste auf SampleBaseMapGDB.gdb, und klicken Sie auf Aktualisieren.
    Hinweis:

    Beim Entfernen der Geodatabase wird nur das ausgewählte Element im Projekt entfernt. Alle Projektverweise auf das Element werden entfernt. Das Element wurde jedoch nicht gelöscht und verbleibt auf der Festplatte.

    Nachdem Sie sich das Beispiel für ein Grundkarten-Geodatabase-Schema angesehen haben, können Sie nun mit dem Füllen Ihrer eigenen Tourismus-Geodatabase fortfahren.

Die Geodatabase "Salzburg" dokumentieren und vorbereiten

Im Rahmen der Vorbereitung auf das Füllen der Geodatabase "Salzburg" müssen Sie ihre Geodatabase-Metadaten bearbeiten und aktualisieren.

  1. Klicken Sie im Bereich Inhalt unter Datenbanken mit der rechten Maustaste auf SalzburgDataManagement.gdb, und wählen Sie Metadaten bearbeiten aus.

    Eine Metadatenansicht wird angezeigt.

    Metadatenelement "Elementbeschreibung" in der Ansicht "Katalog"

    Erforderliche Metadatenelemente werden rot hervorgehoben. Als Nächstes füllen Sie sie.

  2. Aktualisieren Sie in der Metadatenansicht die folgenden Informationen:

    • Geben Sie unter Titel den Titel Salzburg Tourism Geodatabase ein (oder kopieren und fügen Sie ihn ein).
    • Geben Sie als Tags die Begriffe Salzburg, Austria, Visitor map, Tourism, Tourist, Visitor guide, Food, Activities, Attendees, Places to visit, Places to eat, Bike Routes, Ski Resorts, Museums, Art, Castles, Cathedrals ein.
    • Geben Sie als Zusammenfassung (Zweck) den folgenden Text ein: Collection of data for the city and surrounding areas of Salzburg Austria.
    • Geben Sie als Beschreibung (Kurzfassung) den folgenden Text ein: Geodatabase to store and manage a collection of spatial and attribute data that can be used by tourism agencies in the city of Salzburg, Austria to develop updated web maps and apps.

  3. Geben Sie als Quellennachweis die folgenden Informationen ein:

    • STADT: SALZBURG https://maps.stadt-salzburg.at/
    • National Mapping Agency - Federal Office for Metrology and Surveying (BEV) https://www.bev.gv.at
    • Austrian Map online - http://www.austrianmap.at/amap/
    • Land Salzburg - Open Government Data (OGD) - https://service.salzburg.gv.at/ogd/client/ and https://www.salzburg.gv.at/sagis/
    • Austrian OGD basemap https://www.basemap.at/index_en.html

    Tipp:

    Wenn Sie Metadateninhalt für ein ArcGIS-Element erstellen oder aktualisieren, sollten Sie alle Informationen über das Element erfassen, die für Ihre Organisation im Zusammenhang mit dem Element von Bedeutung sind. Das können Informationen über die Genauigkeit und Aktualität des Elements sein, Einschränkungen bei der Verwendung und beim Austausch des Elements oder wichtige Prozesse in seinem Lebenszyklus, z. B. das Generalisieren von Features usw.

  4. Klicken Sie auf dem Menüband auf die Registerkarte Metadaten und in der Gruppe Metadaten verwalten auf Speichern.
  5. Schließen Sie die Metadatenansicht.
  6. Klicken Sie im Bereich Inhalt mit der rechten Maustaste auf SalzburgDataManagement.gdb, und wählen Sie Metadaten anzeigen aus.

    Im Detailfenster der Ansicht "Katalog" werden die aktualisierten Metadaten für die "Salzburg Tourism Geodatabase" angezeigt.

    Geodatabase-Metadaten

    Wenn gute beschreibende Informationen vorliegen, können Sie Elemente mit einer Suchfunktion finden und einschätzen, welches Element in den Suchergebnissen das gewünschte ist. Basierend auf den räumlichen Informationen eines Elements können Sie die Kommunikation verbessern und zuverlässigere Entscheidungen treffen. Sie können Projekte mit dem Wissen archivieren, dass sie zu einem späteren Zeitpunkt wiederhergestellt, verwendet und ausgewertet werden können.

  7. Speichern Sie das Projekt.

Als Nächstes beginnen Sie mit dem Migrieren von mehreren Datenquellen aus den Ordnern "City_of_Salzburg", "KMZ files" und "OpenStreetMap_Salzburg" in SalzburgDataManagement.gdb.


Die Geodatabase füllen

Recherchen an aktuellen Tourismuskarten und Online-Informationen für die Stadt Salzburg haben einen guten Hinweis darauf geliefert, welche Datenkategorien die Tourismusbehörden und Privatunternehmen benötigen, um den Besuchern bestmögliche Leistungen zu bieten. Dies können Sie als Richtlinie dafür verwenden, welche Daten Sie Ihrer Datenbank hinzufügen sollten. Dabei sollten Sie berücksichtigen, dass die meisten der Feature-Classes, die Sie erstellen und später symbolisieren, höchstwahrscheinlich in aktuellen Grundkarten-Layern, die in ArcGIS Living Atlas of the World und anderen Quellen veröffentlicht wurden, angezeigt werden. Ihre Feature-Classes ergänzen und erweitern vorhandene Basisdaten und haben die Aufgabe, den Nutzen der interaktiven Webkarten und Apps, die durch Behörden generiert und veröffentlicht werden, zu erhöhen.

In den beliebtesten Karten und Daten, die für den Salzburger Tourismus verwendet werden, sind die folgenden Elemente enthalten:

  • Detaillierter Stadtplan mit Straßen, Fußgängerbereichen und Gebäuden
  • Karte mit besonderen Sehenswürdigkeiten für Touristen
  • Karte mit Ortsangaben für Märkte und Ausstellungen
  • Haltestellen und Routen von Bus und Bahn
  • Rundgänge für Kreative: Architektur, Museen, Kunst, Galerien, Kirchen
  • Fuß- und Radwege
  • Bierstraßen mit Brauereien und Schenken
  • Wanderwege in Stadt und Natur
  • Hotelkarten

Feature-Datasets erstellen

Während Sie mit Ihrer Geodatabase arbeiten, können Sie leere Feature-Datasets direkt in der Geodatabase erstellen. Erstellen Sie zunächst Feature-Datasets für die folgenden vier Datenkategorien:

  • City Attractions
  • Transportation
  • Scenic Attractions
  • Trails

  1. Öffnen Sie bei Bedarf Ihr Projekt.
  2. Blenden Sie im Bereich Inhalt die Datenbanken ein. Klicken Sie mit der rechten Maustaste auf SalzburgDataManagement.gdb, zeigen Sie auf Neu, und klicken Sie auf Feature-Dataset.

    Option "Feature-Dataset"

    Das Geoverarbeitungswerkzeug Feature-Dataset erstellen wird geöffnet. Ausgabe-Geodatabase ist standardmäßig auf SalzburgDataManagement.gdb festgelegt.

  3. Geben Sie als Feature-Dataset-Name den Text City_Attractions ein.
  4. Klicken Sie für Koordinatensysteme auf die Schaltfläche Koordinatensystem auswählen.

    Das Koordinatensystem für ein Geodatabase-Objekt kann am einfachsten definiert werden, indem es aus einer aktuellen Datenquelle importiert wird.

  5. Klicken Sie im Fenster Koordinatensystem auf die Schaltfläche Koordinatensystem hinzufügen, und wählen Sie Koordinatensystem importieren aus.

    Option "Koordinatensystem importieren"

  6. Navigieren Sie im Fenster Koordinatensystem importieren zum Ordner City_of_Salzburg (im Verzeichnis C:\Salzburg\City_of_Salzburg). Wählen Sie BicyclePaths.shp aus, und klicken Sie auf OK.

    Browser "Koordinatensystem importieren"

  7. Vergewissern Sie sich, dass im Fenster Koordinatensystem im Feld Aktuelles XY-Koordinatensystem das Koordinatensystem MGI Austria GK M31 angezeigt wird, und klicken Sie auf OK.

    Fenster "Koordinatensystem"

    Für das Koordinatensystem "MGI Austria GK", bei dem es sich um ein offiziell projiziertes Koordinatensystem für die Katasterkartenerstellung in Österreich handelt, wird die Transversale Mercator-Projektion verwendet. M31 ist eine Version dieses Koordinatensystems, das für die Region um Salzburg optimiert wurde.

  8. Klicken Sie im Werkzeug Feature-Dataset erstellen auf Ausführen.

    Nach der Ausführung des Werkzeugs wird das Feature-Dataset City_Attractions zur Geodatabase "SalzburgDataManagement.gdb" hinzugefügt.

  9. Klicken Sie im Bereich Inhalt auf SalzburgDataManagement.gdb.
  10. Klicken Sie in der Katalogansicht mit der rechten Maustaste auf City_Attractions, und wählen Sie Metadaten bearbeiten aus.
  11. Nehmen Sie in der Metadatenansicht "City_Attractions" folgende Änderungen vor:

    • Geben Sie für Titel den Titel Salzburg City Attractions ein (oder kopieren Sie den Titel, und fügen Sie ihn ein).
    • Geben Sie als Tags die Begriffe Salzburg, Austria, City Attractions ein.
    • Geben Sie als Zusammenfassung den Text Collection of Salzburg visitor attractions ein.
    • Geben Sie als Beschreibung (Kurzfassung) den folgenden Text ein: Location of various city sites commonly visited by tourists in Salzburg Austria.
    • Geben Sie als Quellennachweis die folgenden Informationen ein:
      • STADT: SALZBURG https://maps.stadt-salzburg.at/
      • National Mapping Agency - Federal Office for Metrology and Surveying (BEV) https://www.bev.gv.at
      • Austrian Map online - http://www.austrianmap.at/amap/
      • Land Salzburg - Open Government Data (OGD) - https://service.salzburg.gv.at/ogd/client/ and https://www.salzburg.gv.at/sagis/
      • Austrian OGD basemap https://www.basemap.at/index_en.html

  12. Klicken Sie auf dem Menüband auf die Registerkarte Metadaten und in der Gruppe Metadaten verwalten auf Speichern.
  13. Schließen Sie die Metadatenansicht "City_Attractions".
  14. Überprüfen Sie die Metadaten in der Katalogansicht.

    Metadaten für Feature-Dataset

    Tipp:

    Blenden Sie ggf. im Bereich Inhalt das Objekt SalzburgDataManagement.gdb ein. Klicken Sie mit der rechten Maustaste auf City_Attractions, und wählen Sie Metadaten anzeigen aus.

  15. Klicken Sie im Bereich Inhalt auf SalzburgDataManagement.gdb.
  16. Klicken Sie auf dem Menüband auf der Registerkarte Katalog in der Gruppe Erstellen auf Neu, und wählen Sie Feature-Dataset aus.

    Neues Feature-Dataset

  17. Legen Sie im Geoverarbeitungswerkzeug Feature-Dataset erstellen die folgenden Parameter fest:

    • Vergewissern Sie sich, dass der Pfad für Ausgabe-Geodatabase C:\Salzburg\SalzburgDataManagement.gdb lautet.
    • Geben Sie als Feature-Dataset-Name den Text Scenic_Attractions ein.
    • Wählen Sie als Koordinatensystem die Option MGI Austria GK M31 aus.

  18. Klicken Sie auf Ausführen.
  19. Erstellen Sie zusätzliche Feature-Datasets für die folgenden Kategorien:

    • Transportation
    • Trails

    Da der Name der Geodatabase und das Koordinatensystem für alle diese Datasets identisch sind, können Sie im Feld Feature-Dataset-Name des Geoverarbeitungswerkzeugs den Namen Scenic_Attractions durch Transportation ersetzen und das Werkzeug erneut ausführen. Wiederholen Sie den Vorgang für Trails.

  20. Blenden Sie im Bereich Inhalt das Objekt SalzburgDataManagement.gdb ein, und überprüfen Sie das Vorhandensein der vier Feature-Datasets.
    Feature-Datasets
  21. Die Metadaten für die zusätzlichen Feature-Datasets können Sie ebenfalls ändern.

Ein einzelnes Shapefile importieren

Sie können einer Geodatabase Daten hinzufügen, indem Sie sie aus Quelldatenformaten importieren und in Feature-Classes konvertieren. Sehen Sie sich zunächst das Migrieren von Shapefiles in die Geodatabase an. Ein Shapefile ist ein älteres Datenformat, das noch recht beliebt ist aber einige Nachteile aufweist, die für seine Verwendung als Typ der effizienten Datenspeicherung hinderlich sind. Da es einer Feature-Class ähnelt, wird es in der Geodatabase direkt als einzelne Feature-Class abgebildet, wenn Sie es in die Geodatabase migrieren.

  1. Klicken Sie im Bereich Inhalt unter SalzburgDataManagement.gdb mit der rechten Maustaste auf das Feature-Dataset City_Attractions, zeigen Sie auf Importieren, und wählen Sie Feature-Class aus.

    Option zum Importieren einer Feature-Class

    Tipp:

    Alternativ können Sie auch im Menüband auf die Registerkarte Katalog klicken. Klicken Sie in der Gruppe Erstellen auf Importieren, und wählen Sie Feature-Class aus.

    Das Geoverarbeitungswerkzeug Feature-Class in Feature-Class wird geöffnet. Mit diesem Werkzeug können Sie eine einzelne Datenquelle für den Import in die Geodatabase auswählen. Zusätzlich können Sie die Ausgabe-Feature-Class umbenennen und wählen, welche Quellattributfelder in den Quelldaten übernommen oder entfernt werden sollen.

  2. Navigieren Sie im Werkzeug Feature-Class in Feature-Class für Eingabe-Features zum Ordner OpenStreetMap_Salzburg, und wählen Sie OSM_Salzburg_HistoricSites.shp aus.
  3. Überprüfen Sie, ob Ausgabeverzeichnis auf City_Attractions festgelegt ist.
  4. Geben Sie als Ausgabename den Dateinamen HistoricSites ein.
  5. Blenden Sie im unteren Bereich des Werkzeugs Felder ein.

    Im Abschnitt Feldzuordnung werden in der Liste Ausgabefelder die Attributfelder angezeigt, die in das Ausgabe-Dataset kopiert werden. Wenn Sie ein Feld aus dem Ausgabe-Dataset ausschließen möchten, wählen Sie das Feld aus und klicken auf Entfernen. Wenn Sie mehrere Felder entfernen möchten, drücken Sie Umschalt+Strg, um die Felder auszuwählen. Klicken Sie dann auf einem Feldnamen auf Entfernen.

  6. Lassen Sie in der Liste Ausgabefelder die folgenden Felder unverändert, und entfernen Sie alle anderen:

    • HISTORIC
    • NAME
    • ADDR_HOUSE
    • ADDR_HOU00
    • ADDR_STREE
    • ADDR_CITY
    • ADDR_STATE
    • ADDR_POSTC
    • ADDR_PLACE

  7. Überprüfen Sie die Parameter, und klicken Sie auf Ausführen.

    Parameter des Werkzeugs "Feature-Class in Feature-Class"

    Hinweis:

    Für das Eingabe-Shapefile wird das Koordinatensystem "WGS_1984_Web_Mercator_Auxiliary_Sphere" verwendet. Wenn das Shapefile in eine Feature-Class im Feature-Dataset "City_Attractions" konvertiert wird, wird das Koordinatensystem automatisch in "MGI Austria GK M31" neu projiziert. Wie Sie später noch sehen werden, kann ein Feature-Dataset keine Feature-Class enthalten, die ein nicht übereinstimmendes Koordinatensystem aufweist.

  8. Klicken Sie im Bereich Inhalt mit der rechten Maustaste auf City_Attractions, und wählen Sie Aktualisieren aus.
  9. Klicken Sie in der Katalogansicht auf HistoricSites.

    Auf der Registerkarte Metadaten im Detailfenster wurden die ursprünglichen Shapefile-Metadaten in die neue Geodatabase-Feature-Class kopiert.

  10. Klicken Sie in der AKatalogansicht mit der rechten Maustaste auf HistoricSites, und wählen Sie Metadaten bearbeiten aus.
  11. Aktualisieren Sie in der Metadatenansicht die folgenden Informationen:

    • Geben Sie als Titel den Text Salzburg Historic Sites ein.
    • Geben Sie als Tags die Begriffe Salzburg, Austria, Historic sites ein.
    • Geben Sie als Zusammenfassung (Zweck) den folgenden Text ein: Point features of historic sites in Salzburg Austria.
    • Geben Sie als Beschreibung (Kurzfassung) den folgenden Text ein: Location of historic sites in Salzburg Austria.
    • Lassen Sie für Quellennachweis und Nutzungsbeschränkungen den Standardtext unverändert. Diese Felder werden mit Daten aus der Metadatenquelle gefüllt.
    • Legen Sie als Geeigneter Maßstabsbereich den Bereich Stadt (1:50.000) bis Gebäude (1:5.000) fest.

    Geeigneter Maßstabsbereich

  12. Klicken Sie auf dem Menüband auf die Registerkarte Metadaten und in der Gruppe Metadaten verwalten auf Speichern.
  13. Schließen Sie die Metadatenansicht.

Mehrere Feature-Classes in eine Geodatabase exportieren oder importieren

Das Exportieren oder Importieren eines einzelnen Shapefile ist nützlich, wenn Sie nur ausgewählte Features konvertieren und bestimmte Attributfelder, die in die Ausgabe-Feature-Class kopiert werden sollen, auswählen müssen. Manchmal ist es notwendig, schnell mehrere Quellen gleichzeitig zu konvertieren und erst später die nicht benötigten Attributfelder zu entfernen.

  1. Klicken Sie im Bereich Inhalt unter Ordner auf den Ordner City_of_Salzburg.
  2. Klicken Sie in der Katalogansicht mit der rechten Maustaste auf Castles.shp, zeigen Sie auf Exportieren, und wählen Sie Feature Class(es) in Geodatabase aus.

    Option "Feature-Class(es) in Geodatabase"

    Das Geoverarbeitungswerkzeug Feature-Class in Geodatabase wird geöffnet. Der Parameter Eingabe-Features ist bereits angegeben. Sie können jedoch weitere Shapefiles als Eingaben hinzufügen, bevor Sie das Werkzeug ausführen.

  3. Klicken Sie neben dem zweiten Eingabe-Features-Feld auf die Schaltfläche Durchsuchen.
  4. Navigieren Sie zum Ordner "City_of_Salzburg", und wählen Sie Museums.shp aus. Klicken Sie auf OK.
  5. Navigieren Sie unter Ausgabe-Geodatabase zum Feature-Dataset City_Attractions in SalzburgDataManagement.gdb, und wählen Sie es aus.

    Parameter des Werkzeugs "Feature-Class in Geodatabase"

  6. Klicken Sie auf Ausführen.
  7. Überprüfen Sie nach der Ausführung des Werkzeugs, ob das Feature-Dataset City_Attractions in SalzburgDataManagement.gdb drei Feature-Classes enthält.

    Importierte Feature-Classes

  8. Klicken Sie im Bereich Inhalt unter SalzburgDataManagement.gdb mit der rechten Maustaste auf das Feature-Dataset Scenic_Attractions, zeigen Sie auf Importieren, und wählen Sie Feature_Class(es) aus.
  9. Navigieren Sie im Geoverarbeitungswerkzeug Feature-Class in Geodatabase für Eingabe-Features zu den Shapefiles in der folgenden Tabelle, und fügen Sie sie hinzu.
    Hinweis:

    Hierzu sind zwei Schritte erforderlich: Navigieren Sie zunächst zum Ordner City_of_Salzburg, und fügen Sie die entsprechenden Shapefiles hinzu. Navigieren Sie anschließend zum Ordner OpenStreetMap_Salzburg, und fügen Sie die entsprechenden Shapefiles hinzu.

    QuellordnerQuell-Shapefile

    City_of_Salzburg

    NaturalParks.shp

    NatureReserves.shp

    Skilifts.shp

    SkiSlopes.shp

    SwimmingHoles.shp

    Waterbodies.shp

    Waterwheels.shp

    OpenStreetMap_Salzburg

    OSM_Salzburg_CableCar.shp

    OSM_Salzburg_CableCarStations.shp

    OSM_Salzburg_NaturalFeatureBoundaries.shp

    OSM_Salzburg_NaturalFeatures.shp

    OSM_Salzburg_ReceationSiteBoundaries.shp

    OSM_Salzburg_RecreationSites.shp

    OSM_Salzburg_Streams.shp

    Parameter des Werkzeugs "Feature-Class in Geodatabase"

    Der Parameter Ausgabe-Geodatabase ist standardmäßig richtig auf das Feature-Dataset Scenic_Attractions festgelegt.

  10. Klicken Sie auf Ausführen.
  11. Klicken Sie nach der Ausführung des Werkzeugs im Bereich Inhalt auf das Feature-Dataset Scenic_Attractions.
  12. Benennen Sie die Feature-Classes in der Katalogansicht entsprechend der folgenden Tabelle um.
    Tipp:

    Zum Umbenennen einer Feature-Class gibt es drei Möglichkeiten:

    • Klicken Sie mit der rechten Maustaste auf die Feature-Class, und wählen Sie Umbenennen aus.
    • Klicken Sie auf die Feature-Class, um sie auszuwählen, und drücken Sie die Taste F2, damit der Name bearbeitet werden kann.
    • Klicken Sie auf die Feature-Class, um sie auszuwählen, und klicken Sie anschließend erneut darauf, damit der Name bearbeitet werden kann.

    Ursprünglicher NameNeuer Name

    OSM_Salzburg_CableCar.shp

    CableCar

    OSM_Salzburg_CableCarStations.shp

    CableCarStations

    OSM_Salzburg_NaturalFeatureBoundaries.shp

    NaturalFeatureBoundaries

    OSM_Salzburg_NaturalFeatures.shp

    NaturalFeatures

    OSM_Salzburg_RecreationSiteBoundaries.shp

    RecreationSiteBoundaries

    OSM_Salzburg_RecreationSites.shp

    RecreationSites

    OSM_Salzburg_Streams.shp

    Wasserläufe

  13. Überprüfen Sie, ob das Feature-Dataset "Scenic_Attractions" 14 Feature-Classes enthält.

    Die Anzahl der Elemente, die im unteren Bereich der Katalogansicht angezeigt werden.

  14. Die Metadaten für "Scenic_Attactions" können Sie ebenfalls ändern.
  15. Importieren Sie die folgenden Shapefiles in das Feature-Dataset "Transportation".

    QuellordnerQuell-Shapefile

    City_of_Salzburg

    BicyclePaths.shp

    BusLanes.shp

    OneWayStreets.shp

    Pavement.shp

    RoadNetwork.shp

    Sidewalks.shp

    Tunnels.shp

    OpenStreetMap_Salzburg

    OSM_Salzburg_Airports.shp

    OSM_Salzburg_PublicTransportStations.shp

    OSM_Salzburg_Railroads.shp

    OSM_Salzburg_RailroadStations.shp

  16. Benennen Sie die folgenden Feature-Classes nach der Ausführung des Werkzeugs in der Katalogansicht um:

    Ursprünglicher NameNeuer Name

    OSM_Salzburg_Airports.shp

    Airports

    OSM_Salzburg_PublicTransportStations.shp

    PublicTransportStations

    OSM_Salzburg_Railroads.shp

    Railroads

    OSM_Salzburg_RailroadStations.shp

    RailroadStations

  17. Vergewissern Sie sich, dass das Feature-Dataset "Transportation" 11 Feature-Classes enthält.

    Transportation-Feature-Classes in der Katalogansicht

  18. Die Metadaten für die Feature-Classes Transportation können Sie ebenfalls ändern.

KML-Dateien importieren

Einige Datenquellen zum Thema "Tourismus" sind nur als KML-Dateien verfügbar. Verwenden Sie das Werkzeug KML in Layer, um eine .kmz-Datei in eine File-Geodatabase zu konvertieren.

  1. Navigieren Sie im Bereich Inhalt unter Ordner zum Unterordner kmz_files, und klicken Sie darauf.

    In der Katalogansicht sind drei .kmz-Dateien vorhanden. Dies sind komprimierte KML-Dateien.

    KMZ-Dateien in der Katalogansicht

    Da in Ihrer Geodatabase bereits ein Layer für Museen vorhanden ist, müssen Sie nur die Dateien "Burgen_und_Schloesser.kmz" und "Kunstwerke_mit_Audiotext.kmz" konvertieren. Dies sind Features, die Burgen und Schlösser und den Standort von Kunstinstallationen bekannter Künstler darstellen.

  2. Klicken Sie im Bereich Geoverarbeitung auf die Schaltfläche Zurück.

    Die Schaltfläche "Zurück" im Bereich "Geoverarbeitung"

  3. Navigieren Sie im Bereich Geoverarbeitung zum Werkzeug KML in Layer, und öffnen Sie es.

    KML in Layer (Werkzeug)

    Das Werkzeug KML in Layer konvertiert eine KML-Datei mit ihren Features, die XML-basiert sind, in eine spezielle Geodatabase für die konvertierte KML-Datei. Diese Features, wie zum Beispiel Punkte und Polygone, werden dann als separate Feature-Classes zu einem Feature-Dataset mit dem Namen "Placemarks" in dieser Geodatabase hinzugefügt. Nachdem diese Konvertierung durchgeführt wurde, können Sie die geographischen Informationen aus Ihrer KML-Datei auf die gleiche Weise wie andere GIS-Daten verwenden.

  4. Legen Sie im Werkzeug KML in Layer die folgenden Parameter fest:

    • Navigieren Sie für Eingabe-KML-Datei zum Ordner kmz-files, und wählen Sie Burgen_und_Schloesser.kmz aus.
    • Wählen Sie unter Ausgabeverzeichnis das Verzeichnis C:\Salzburg aus.
    • Geben Sie als Ausgabe-Datenname den Text Castle_Palace ein.

    Parameter für das Werkzeug "KML in Layer"

  5. Klicken Sie auf Ausführen.

    Das Werkzeug erstellt im Ordner "Salzburg" die Ausgabe-File-Geodatabase Castle_Palace.gdb und die Ausgabe-Layer-Datei Castle_Palace.lyrx.

  6. Führen Sie das Werkzeug KML in Layer ein zweites Mal mit den folgenden Parametern aus:

    • Navigieren Sie für Eingabe-KML-Datei zur Datei Kunstwerke_mit_Audiotext.kmz im Ordner kmz-files, und wählen Sie sie aus.
    • Wählen Sie unter Ausgabeverzeichnis das Verzeichnis C:\Salzburg aus.
    • Geben Sie als Ausgabe-Datenname den Text Art_Installations ein.

    Parameter für das Werkzeug "KML in Layer"

  7. Klicken Sie auf Ausführen.

    Das Werkzeug erstellt die Ausgabe-File-Geodatabase Art_Installations.gdb und die Ausgabe-Layer-Datei Art_Installations.lyrx im Ausgabeverzeichnis.

  8. Blenden Sie im Bereich Inhalt den Ordner Salzburg ein, und überprüfen Sie, ob Art_Installations.gdb und Castle_Palace.gdb erstellt wurden.
  9. Blenden Sie die Geodatabases ein, und vergewissern Sie sich, dass jede Geodatabase ein Feature-Dataset mit dem Namen Placemarks enthält.

    Eingeblendete Geodatabases im Bereich "Inhalt"

  10. Klicken Sie unter Art_Installations.gdb auf das Feature-Dataset Placemarks.

    In der Katalogansicht können Sie sehen, dass das Feature-Dataset eine Feature-Class mit dem Namen "Points" enthält. Diese Feature-Class enthält die konvertierten KLM-Punkt-Features.

  11. Benennen Sie die Points-Feature-Class in Art_Installations um.
  12. Klicken Sie im Bereich Inhalt unter Castle_Palace.gdb auf das Feature-Dataset Placemarks.
  13. Benennen Sie die Points-Feature-Class in der Katalogansicht in Castle_Palace um.
  14. Navigieren Sie in der Katalogansicht zur Point-Feature-Class Art_Installations. Klicken Sie mit der rechten Maustaste auf die -Feature-Class, und wählen Sie Kopieren aus.

    Option "Kopieren"

  15. Klicken Sie im Bereich Inhalt unter SalzburgDataManagement.gdb mit der rechten Maustaste auf das Feature-Dataset City_Attractions, und wählen Sie Einfügen aus.

    Bei diesem Vorgang tritt ein Fehler auf. Dies ist zu erwarten, da die Raumbezüge der Quell-Feature-Class und das Ziel-Feature-Dataset nicht zusammenpassen.

    In der ursprünglichen KML-Datei – und damit auch in der konvertierten Feature-Class mit den Punkten – wird das Koordinatensystem "GCS_WGS_1984" verwendet. Im Ziel-Feature-Dataset "City_Attractions" wird das Koordinatensystem "MGI_Austria_GK_M31" verwendet. Beim Kopier- und Einfügevorgang tritt ein Fehler auf, da alle Feature-Classes in einem Feature-Dataset dasselbe Koordinatensystem aufweisen müssen. Es ist jedoch möglich, die Feature-Class mit dem Werkzeug Feature-Class in Geodatabase in das Feature-Dataset zu exportieren. Das Werkzeug projiziert die Quelldaten automatisch in das Koordinatensystem des Feature-Datasets.

  16. Klicken Sie in der Katalogansicht mit der rechten Maustaste auf die Feature-Class Art_Installations, zeigen Sie auf Exportieren, und wählen Sie Feature-Class(es) in Geodatabase aus.

    Im Werkzeug Feature-Class in Geodatabase ist Art_Installations standardmäßig als Eingabe-Feature-Class ausgewählt. Fügen Sie außerdem die Feature-Class Castle_Palace hinzu.

  17. Klicken Sie im Bereich Inhalt unter Castle_Palace.gdb auf Placemarks.
  18. Klicken Sie in der Katalogansicht auf Castle_Palace, und ziehen Sie die Feature-Class in den Bereich Geoverarbeitung. Legen Sie sie im leeren Eingabe-Features-Feld ab.

    Feature-Class "Castle_Palace" ziehen und ablegen

    Die Ausgabe-Geodatabase können Sie auf dieselbe Weise füllen.

  19. Blenden Sie im Bereich Inhalt den Eintrag SalzburgDataManagement.gdb ein. Klicken Sie auf das Feature-Dataset City_Attractions, und ziehen Sie es in den Bereich Geoverarbeitung im Parameter Ausgabe-Geodatabase.

    Feature-Database "City_Attractions" ziehen und ablegen

    Die Ausgabe-Geodatabase ist nun auf City_Attractions festgelegt.

  20. Klicken Sie auf Ausführen.

    Die Feature-Classes werden zum Feature-Dataset City_Attractions hinzugefügt.

  21. Klicken Sie im Bereich Inhalt auf das Feature-Dataset City_Attractions. Vergewissern Sie sich, dass die Feature-Classes in der Katalogansicht angezeigt werden.

    Neue Feature-Classes

  22. Die Metadaten für Ihre Art_Installations- und Castle_Palace-Feature-Classes können Sie ebenfalls ändern.

    Ihre Geodatabase SalzburgDataManagement.gdb enthält jetzt mehrere thematisch in Feature-Datasets organisierte Feature-Classes, die durch Tourismusbehörden genutzt werden können, um neue und verbesserte Karten und Apps für Touristen, die die Stadt Salzburg besuchen, zu erstellen.

    Bevor Sie die Geodatabase freigeben, um von Projektbeteiligten Feedback zu erhalten, führen Sie einige Geodatabase-Verwaltungsaufgaben durch.

  23. Speichern Sie das Projekt.

Die Geodatabase für Überprüfung und Verteilung vorbereiten

Eine File-Geodatabase wird als Ordner von binären Dateien auf Festplatte gespeichert. Beim ersten Hinzufügen von Daten zu einer File-Geodatabase sind die Datensätze in jeder Datei geordnet, und das Dateisystem kann effizient auf sie zugreifen. Wenn Sie jedoch im Laufe der Zeit Datensätze löschen und hinzufügen, beeinträchtigt dies die Anordnung der Datensätze in den Dateien, und Speicherplatz bleibt ungenutzt, da Datensätze entfernt und an anderer Stelle in der Datei wieder hinzugefügt werden. Dadurch muss das System nach bestimmten Datensätzen innerhalb jeder Datei suchen, was zu einem langsameren Zugriff auf die Datensätze führt. Da Sie Feature-Datasets und Feature-Classes hinzugefügt haben, indem Sie verschiedene Quellen-Datasets in Ihre Geodatabase importiert haben, haben Sie im Wesentlichen die Geodatabase bearbeitet, was sich auf die Performance der Geodatabase auswirkt.

Ordnen Sie die Datensätze neu und entfernen ungenutzten Speicherplatz, indem Sie Ihre Geodatabase reorganisieren. Durch das Reorganisieren einer häufig bearbeiteten Geodatabase wird Speicherplatz bereinigt, unbenutzter Speicherplatz freigegeben und die Größe jeder Datei verringert. Wenn Sie regelmäßig Daten hinzufügen und löschen, sollten Sie die File-Geodatabase monatlich reorganisieren. Sie sollten auch nach jeder großen Änderung eine Reorganisation durchführen.

  1. Klicken Sie im Bereich Inhalt mit der rechten Maustaste auf SalzburgDataManagement.gdb, zeigen Sie auf Verwalten, und wählen Sie Reorganisieren aus.

    Der Vorgang ist schnell abgeschlossen.

    Tipp:

    Wenn Sie den Verlauf Ihrer Geoverarbeitungsvorgänge einschließlich des Vorgangs Reorganisieren anzeigen möchten, klicken Sie im Menüband auf die Registerkarte Analyse. Klicken Sie in der Gruppe Geoverarbeitung auf Verlauf.

    Hinweis:

    Zusätzlich zum Reorganisieren einer Geodatabases können Sie auch eine Komprimierung anwenden. Ein komprimiertes Dataset ist nach der Verteilung schreibgeschützt und kann deshalb nicht bearbeitet oder geändert werden. Nur der Name, die Attributindizes und Metadaten können geändert werden. Die Komprimierung eignet sich am besten für Datasets, die nicht weiter bearbeitet werden müssen. Damit ist sie eine geeignete Methode, die erste Version Ihrer Geodatabase für Projektbeteiligte zur Überprüfung ohne die Möglichkeit zum Modifizieren der Quelldaten-Features bereitzustellen.

    Als Nächstes erstellen Sie ein XML-Workspace-Dokument zur Freigabe des Schemas für SalzburgDataManagement.gdb. Die Freigabe eines Geodatabase-Schemas kann für die Überprüfung und die Zusammenarbeit mit anderen nützlich sein. Es kann vorkommen, dass eine Organisation Kopien eines Geodatabase-Schemas zur Verwendung in den verschiedenen Abteilungen erstellt.

  2. Klicken Sie im Bereich Inhalt mit der rechten Maustaste auf SalzburgDataManagement.gdb, zeigen Sie auf Exportieren, und wählen Sie Geodatabase in XML-Workspace-Dokument aus.

    Option "Geodatabase in XML-Workspace-Dokument"

    Das Werkzeug XML-Workspace-Dokument exportieren wird angezeigt.

  3. Legen Sie den Parameter Eingabedaten auf SalzburgDataManagement.gdb und Ausgabedatei auf SalzburgDataManagement_Expor.xml fest.
  4. Wählen Sie unter Exportoptionen die Option Nur Schema aus.

    Der Export der Daten kann lange dauern. Daher gibt es verschiedene Alternativen bei der Freigabe der vollständigen Geodatabase mit Schema und Daten. Dazu gehören das Verwenden des Werkzeugs Kopieren oder Ausschneiden zum Extrahieren von Teilmengen der Daten oder das Verwenden des Toolsets "Paket" zum Konsolidieren, Packen und Freigeben von Layern, Kartendokumenten und Ergebnissen.

    Das XML-Workspace-Dokument im Home-Ordner des Projekts

  5. Klicken Sie auf Ausführen.

    Tipp:
    Wenn Sie den Namen einer Ausgabedatei mit der Dateierweiterung .zip angeben, wird die resultierende XML-Datei als komprimierte .zip-Datei gespeichert.

  6. Klicken Sie nach der Ausführung des Werkzeugs im Bereich Inhalt unter Ordner auf den Home-Ordner SalzburgDataManagement. Vergewissern Sie sich, dass das XML-Dokument angezeigt wird.

    Das XML-Workspace-Dokument im Home-Ordner des Projekts

    Jetzt können Sie Ihr Ausgabe-XML-Workspace-Dokument verteilen und für die Überprüfung und Kommentierung durch Projektbeteiligte freigeben.

  7. Speichern Sie das Projekt.

In dieser Lektion haben Sie ein ArcGIS Pro-Projekt erstellt, um die Erstellung einer Geodatabase zu unterstützen. Sie haben die Katalogansicht verwendet, um mit Projektkomponenten zu interagieren und die Geodatabase zu verwalten. Außerdem haben Sie mehrere Feature-Datasets erstellt und verschiedene Feature-Classes importiert. Und schließlich haben Sie Metadaten zu Geodatabase-Komponenten hinzugefügt und die Geodatabase komprimiert, um die Effizienz der Geodatabase zu erhöhen.

Weitere Lektionen finden Sie in der Learn ArcGIS-Lektionsgalerie.